#koha: Development IRC meeting 17 June 2020

Meeting started by Joubu at 13:00:27 UTC (full logs).

Meeting summary

  1. Introductions (Joubu, 13:00:33)
    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_17_June_2020 (Joubu, 13:00:47)
    2. Jonathan Druart (Joubu, 13:00:54)
    3. Tomas Cohen Arazi, Theke Solutions (tcohen, 13:00:55)
    4. Kyle M Hall, ByWater Solutions (khall_, 13:01:04)
    5. tuxayo/Victor Grousset, France (tuxayo, 13:01:06)
    6. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 13:01:17)
    7. Joy Nelson, ByWater Solutions (talljoy, 13:01:48)
    8. David Nind, Wellington, New Zealand (davidnind, 13:01:58)
    9. Marcel de Rooy, Rijksmuseum, Netherlands (marcelr, 13:02:06)
    10. Martin Renvoize, PTFS Europe. (ashimema, 13:02:13)
    11. Henry Bolshaw, House of Lords Library, UK (HenryB, 13:02:15)
    12. Katrin Fischer, BSZ, Germany (cait1, 13:02:23)

  2. Announcements (Joubu, 13:03:14)
    1. I am planning to upgrade and move our git server. The plan is to have a new server and suggest gitea as a replacement of the couple gitweb/gitolite (Joubu, 13:05:06)

  3. Update from the Release manager (20.11) (Joubu, 13:06:48)
    1. https://codeberg.org/Codeberg/gitea (davidnind, 13:09:08)
    2. Mason James, NZ (mtj, 13:10:11)

  4. Updates from the Release Maintainers (Joubu, 13:12:13)
  5. Updates from the QA team (Joubu, 13:16:08)
  6. Community testing events for 'big stuff' bugs (example: Bug 20271, Bug 20168) (Joubu, 13:21:09)
    1. ACTION: cait Organise a testing day for "big stuffs" (Joubu, 13:25:16)

  7. General development discussion (trends, ideas, ...) (Joubu, 13:26:34)
  8. Generic example template for new pages in the OPAC (Joubu, 13:27:49)
    1. ACTION: open a bug report to introduce the idea of having a "skeleton" template we could copy for new pages (Joubu, 13:34:58)

  9. Routes for authorised values (RFC) (Joubu, 13:38:13)
    1. https://wiki.koha-community.org/wiki/Authorised_values_endpoint_RFC (Joubu, 13:40:53)

  10. Review of coding guidelines (Joubu, 13:47:52)
  11. We should require all OPAC pages always contain a single 'maincontent' class to denote the main content of the page Bug 22807 (Joubu, 13:48:00)
    1. ACTION: ashimema to draft the first 'Accessibility' guideline; All OPAC pages require a single 'maincontent' classed block. (ashimema, 13:54:05)
    2. ACTION: ashimema write a guideline about mandatory 'maincontent' class (OPAC) (Joubu, 13:54:10)

  12. We should add a coding guideline for language involving allow/deny lists Bug 25708 and using inclusive language (Joubu, 13:54:51)
    1. ACTION: talljoy Propose a guideline for "inclusive langage" (whitelist/blacklist vs allowlist/denylist) (Joubu, 14:04:11)

  13. Set time of next meeting (Joubu, 14:07:31)
    1. ACTION: tuxayo write a proposal for handing over stable branches (Joubu, 14:16:29)
    2. Next meeting: 1 July 2020, 20 UTC? (Joubu, 14:18:20)


Meeting ended at 14:18:45 UTC (full logs).

Action items

  1. cait Organise a testing day for "big stuffs"
  2. open a bug report to introduce the idea of having a "skeleton" template we could copy for new pages
  3. ashimema to draft the first 'Accessibility' guideline; All OPAC pages require a single 'maincontent' classed block.
  4. ashimema write a guideline about mandatory 'maincontent' class (OPAC)
  5. talljoy Propose a guideline for "inclusive langage" (whitelist/blacklist vs allowlist/denylist)
  6. tuxayo write a proposal for handing over stable branches


Action items, by person

  1. ashimema
    1. ashimema to draft the first 'Accessibility' guideline; All OPAC pages require a single 'maincontent' classed block.
    2. ashimema write a guideline about mandatory 'maincontent' class (OPAC)
  2. talljoy
    1. talljoy Propose a guideline for "inclusive langage" (whitelist/blacklist vs allowlist/denylist)
  3. tuxayo
    1. tuxayo write a proposal for handing over stable branches
  4. UNASSIGNED
    1. cait Organise a testing day for "big stuffs"
    2. open a bug report to introduce the idea of having a "skeleton" template we could copy for new pages


People present (lines said)

  1. Joubu (104)
  2. ashimema (82)
  3. tuxayo (51)
  4. tcohen (32)
  5. cait1 (30)
  6. oleonard (24)
  7. talljoy (24)
  8. marcelr (17)
  9. huginn (11)
  10. wahanui (9)
  11. davidnind (2)
  12. khall_ (2)
  13. mtj (2)
  14. gmcharlt_ (1)
  15. HenryB (1)


Generated by MeetBot 0.1.4.