14:00:58 <ashimema> #startmeeting Development IRC meeting 18 March 2020
14:00:58 <huginn> Meeting started Wed Mar 18 14:00:58 2020 UTC.  The chair is ashimema. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:58 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:58 <huginn> The meeting name has been set to 'development_irc_meeting_18_march_2020'
14:01:28 <ashimema> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_18_March_2020#Agenda Agenda
14:01:40 <ashimema> #topic Introductions
14:01:44 <ashimema> Please uss #info to appear in the minutes
14:01:46 <cait2> #info Katrin Fischer, BSZ, Germany
14:01:46 <Joubu> gmcharlt: Hi Galen, could you add 2020 to https://meetings.koha-community.org/ ?
14:01:56 <ashimema> #info Martin Renvoize, PTFS Europe
14:02:06 <oleonard> #info Owen Leonard, Athens County Public Libraries in Exile, Ohio, USA
14:02:21 <cait2> Rmaints?
14:02:55 * cait2 pings people the old fashioned way by pm
14:02:56 <kidclamp> #info Nick Clemens, ByWater Solutions
14:03:20 <Joubu> #info Jonathan Druart
14:04:20 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
14:05:26 <gmcharlt> Joubu: done
14:05:35 <Joubu> thanks!
14:05:39 <cait2> :)
14:05:41 <cait2> gmcharlt++
14:05:51 <tcohen> gmcharlt++
14:05:59 <ashimema> wizzyrea
14:06:17 <cait2> tcohen:
14:06:19 <ashimema> Nice..
14:06:27 <tcohen> cait2
14:06:48 <ashimema> I've been meaning to catch you for that for ages
14:07:07 <ashimema> right..
14:07:17 <ashimema> #topic Announcements
14:07:22 <ashimema> #info Sadly the Hackfest has had to be cancelled next week due to COVID-19
14:07:31 <ashimema> #info We do however hope to run a virtual hackfest in it's place
14:08:18 <ashimema> #chair cait2
14:08:18 <huginn> Current chairs: ashimema cait2
14:08:37 <ashimema> happen to have the wiki page link cait2.. I can't seem to find it.
14:08:44 <ashimema> #link https://wiki.koha-community.org/wiki/Virtual_Hackfest_2020 Virtual Hackfest
14:09:00 <cait2> i linked it :)
14:09:02 <cait2> on the wiki
14:09:03 <ashimema> foud it.
14:09:14 <ashimema> #info As part of the virtual hackfest Bywater Solutions are hosting a couple of virtual meetings
14:09:20 <Joubu> I updated the event on the calendar
14:09:28 <koha-jenkins> Yippee, build fixed!
14:09:28 <koha-jenkins> Project Koha_Master_D8 build #760: FIXED in 34 min: https://jenkins.koha-community.org/job/Koha_Master_D8/760/
14:09:41 <greenjimll> #info Jon Knight
14:09:51 <oleonard> Thank you Joubu seeing it there was making me sad
14:10:07 <ashimema> #info I hope to do the same at PTFS-Europe but am a little behind on organising them.. mine will focus on using sandboxes for signoff and how to pick bugs to test for begginers
14:10:22 <cait2> bywater++ ashimema++
14:10:35 <cait2> I will try to be online an dhappy to help with evreything i can
14:10:42 <ashimema> Anyone else have any announcements?
14:10:54 <cait2> magnuse: around?
14:11:01 <cait2> we got a hackfest twitter accoutn actually
14:11:02 <Joubu> yes, related to the virual hackfest
14:11:08 <cait2> we probably should start feeding it
14:11:15 <greenjimll> What's the twitter handle?
14:11:16 <cait2> can also add it to the hackfest page
14:11:21 <cait2> hm
14:11:22 <Joubu> I worked on making koha-testing-docker supporting UNIMARC
14:11:32 <cait2> i think it's for GBSD actually
14:11:44 <Joubu> so French testers will be able to test with a known environment, using the new sandboxes
14:12:06 <ashimema> #info Joubu has been working on making koha-testing-docker and koha-sandboxes-docker work with UNIMARC
14:12:08 <cait2> greenjimll: i'll add it to hte wiki later
14:12:19 <oleonard> Joubu++
14:12:27 <Joubu> https://gitlab.com/koha-community/koha-misc4dev/-/merge_requests/39
14:12:29 <ashimema> Joubu++
14:12:40 <Joubu> That is the merge request that needs to be approved
14:13:05 <cait2> Joubu++
14:13:54 <ashimema> where are we at with that Joubu.. do we need khall to merge/test still.. and do we still need any more koha side bugs pushed for it?
14:14:28 <ashimema> ?
14:14:37 <Joubu> we need the PR on koha-misc4dev, then the PR koha koha-sandboxes-docker
14:14:48 <Joubu> and I think that's all
14:15:36 <ashimema[m]> OK.. I'll help chase those through
14:15:58 <Joubu> ho, and bug 24856, but that does not prevent the things to work. Only a cosmetic big
14:15:58 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24856 minor, P5 - low, ---, jonathan.druart, Signed Off , invalid itemtypes.imageurl in fr-FR sample data
14:16:00 <Joubu> bit
14:16:00 <ashimema[m]> #topic Update from the RM
14:16:22 <ashimema[m]> #info Things have progressed quickly the past few weeks, but we still need help reducing the queues.
14:16:36 <cait2> should we send another announcement of virtual hackfest?
14:16:38 <cait2> advertising?
14:17:01 <ashimema[m]> yeah.. that's a good idea cait2
14:17:02 * oleonard blankets YouTube with ads
14:17:20 <cait2> oleonard++ ;)
14:17:37 <ashimema[m]> are you volunteering to send something out cait2.. or should I?
14:17:40 <Joubu> yes, do we know if people who planned to participate physically still have that time to dedicate to the project?
14:17:42 <cait2> would you please?
14:18:05 <cait2> Joubu: not sure wae have talked enough about virtual yet, i know from some
14:18:11 <ashimema[m]> #action Ashimema to send out a reminder about virtual hackfest
14:18:23 <cait2> and i plan to be there too - most libraries closed now... not so many tickets atm
14:18:24 <Joubu> what about BibLibre, ByWater, PTFS-E?
14:18:36 <Joubu> paul_p: ? :)
14:19:17 <cait2> there are also some topics on the hackfest 2020 doc we could turn inot virtual meetings
14:19:20 <ashimema[m]> I think we intend to go ahead with participating in hackfest at ptfs-e
14:20:07 <tcohen> we'll be there
14:20:12 <ashimema[m]> still hackfest related
14:20:20 <kidclamp> bywater is organizing some events
14:20:24 <kidclamp> grabbing jzairo
14:20:42 <cait2> with time ticking we should definitely try to spread the word
14:20:49 <tcohen> I've just granted jz access to a team trello we had back when I was RM
14:20:51 <kidclamp> https://trello.com/b/8PHH9gJ2/virtual-hackfest2020bugzilla
14:21:00 <tcohen> https://trello.com/kohadevel/
14:21:04 <cait2> I was wondering on running a twitter thing : collecting quotes of the day for a new sample file with koha tipps and tricks
14:21:09 <cait2> we could ship that with the dev envs
14:21:14 <cait2> or even in general
14:21:15 <jzairo> hello
14:21:27 <ashimema[m]> #info I intend to start getting much more vigilent about what code I push once the hackfest is complete.. i.e. this is your last change this cycle to try and push bigger enhancements and new features over the line.. I will be getting the team to focus on bugfixes and polishing come April.
14:21:27 <tcohen> hola jzairo alex_a
14:21:56 <jzairo> hi tcohen
14:22:26 <tcohen> Theke will be there
14:22:34 <ashimema[m]> great idea's cait2
14:22:48 <tcohen> I will poke amoyano to present hist work on koha-docker
14:22:51 <cait2> sorry for the 2 btw... still only one
14:23:10 <jzairo> we have 2 scheduled for live youtube events https://wiki.koha-community.org/wiki/Virtual_Hackfest_2020
14:24:24 <ashimema[m]> So.. lots of things to send out about virtual hackfest.. I'll start drafting an email after this meeting and use the trello board and wiki as inspiration for what to write about our plans
14:24:52 <cait2> I'll try to update the wiki in a bit, but some work stuff popping up right now
14:25:11 <ashimema[m]> please add cards to the trello for 'all the things'.. lots of good suggestions getting thrown around here.
14:25:18 <magnuse> cait2: yes, the twitter account is for gbsd, but it can be used for other things, if we want
14:26:10 <cait2> ok
14:26:39 <Joubu> #action Joubu will send an email to the French ml
14:27:09 <ashimema[m]> ok.. moving on in the agenda
14:27:21 <ashimema[m]> #topic Update from the RMaints
14:27:45 <cait2> awesome
14:27:46 <ashimema[m]> We're due a release soon.. not sure if I've seen a string freeze announce or not yet?
14:28:26 <ashimema[m]> Yup.. I have seen it
14:28:39 <cait2> yep
14:28:46 <ashimema[m]> #info We are currently in string freeze for the next maintanence releases
14:28:48 <Joubu> what about bug 24846, do we try to make it into the next 19.11.x?
14:28:48 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24846 new feature, P5 - low, ---, jonathan.druart, Signed Off , Add a tool to bulk edit due dates
14:28:49 <cait2> only a few translations, but files were updated too
14:29:00 <Joubu> if so, we need more signoff on it
14:29:57 <ashimema[m]> #info We are still attempting to have bug 24846 ready and pushed for this maintanence release but we need a final QA on it.
14:30:09 <tcohen> Joubu I agree!
14:30:24 <tcohen> I am testing a secutiry  one, can do next
14:30:34 <cait2> :)
14:30:36 <ashimema[m]> ok.. moving on
14:31:06 <ashimema[m]> thanks tcohen
14:31:18 <ashimema[m]> #topic General development discussion
14:31:29 <ashimema[m]> seems I put one of these in the wrong section on the agenda
14:31:45 <ashimema[m]> #info Consider advocating the use of `<input type=”text” inputmode=”numeric” pattern="[0-9]*">` instead of `<input type="number">`
14:31:51 <lukeG> morning
14:31:56 <ashimema[m]> Did anyone have a chance to look at the reasoning article I linked and have an opinion on it?
14:32:04 <cait2> i'd suggest making it a coding guideline
14:32:21 <ashimema[m]> I'm certainly thinking along those lines cait..
14:32:22 <oleonard> I agree with it ashimema[m]
14:32:37 <ashimema[m]> just wanted to check if anyone had any contrasting opinion on it.
14:32:44 <cait2> could we also discuss a variation for decimal using number?
14:32:45 <Joubu> same, I read it when you posted it, and it made sense to me
14:33:24 <cait2> i can share the pattern we use for years now
14:33:29 <ashimema[m]> not sure I follow cait2
14:33:39 <cait2> number can also be used for something like 1.00
14:34:04 <cait2> I'd be happy if we generally went without using type=number in Koha
14:34:08 <cait2> as we had tons of trouble with it
14:34:56 <ashimema[m]> so you're basically suggesting an update to the 'pattern' part of the suggestion right?
14:35:08 <tcohen> the pattern can be any regex, right?
14:35:11 <cait2> yes
14:35:22 <ashimema[m]> yup
14:35:24 <tcohen> dot vs comma :-D
14:35:26 <ashimema[m]> `pattern="[0-9]*"` is the UK Gov's recommendation
14:35:26 <cait2> let me quickly find an example of the one i was thinking about
14:35:54 <ashimema[m]> do you have an alternative to put forward cait2?
14:36:04 <cait2> for whole numbers that looks great
14:36:08 <cait2> just looking for the other one, sec
14:36:32 <cait2> <input type="number" name="amount" id="amount" required="required" value="" step="any" min="0" />
14:36:41 <cait2> <input type="text" pattern="\d+(\.\d{2})?" name="amount" id="amount" required="required" value="" step="any" min="0" />
14:38:02 <kidclamp> this brings up, we have step=".10" on some payment fields, however, fines can be generated for partial cents - this makes soem fines unpayable
14:38:17 <kidclamp> I like "any"
14:38:27 <cait2> see another reason not do what we do now...
14:38:29 <koha-jenkins> Project Koha_Master_D9 build #1215: SUCCESS in 54 min: https://jenkins.koha-community.org/job/Koha_Master_D9/1215/
14:38:30 <ashimema[m]> so `pattern="\d+(\.\d{2})?"`
14:38:30 <cait2> just a pattern check
14:38:47 <cait2> i am not sure where i stole that from
14:38:50 <cait2> but has not giving us trouble so far
14:38:56 <ashimema[m]> `<input type="text" inputmode="numeric" pattern="\d+(\.\d{2})?">`
14:39:22 <oleonard> What does the "step" attribute do on a field like that?
14:39:26 <ashimema[m]> ok.. I'll draft up a new guideline and we can ratify it next meeting.. certainly sounds like we all think it's a step in the right direction
14:39:29 <cait2> there is little arrows
14:39:38 <cait2> when you move them it increases the step vlaue i think
14:39:41 <ashimema[m]> #action ashimema to write up a guideline to be ratified at the next meeting.
14:40:00 <ashimema[m]> it's if you want to display the little incrementing buttons
14:40:17 <kidclamp> it also limits you to amounts fitting the step
14:40:24 <ashimema[m]> step says how much those arrows will increment/decrement the value by
14:40:25 <kidclamp> step=".01" shoudl eb above
14:40:38 <kidclamp> trying to enter .005 not allowed
14:40:46 <ashimema[m]> correct kidclamp.. though a proper patturn will also do that
14:41:03 <kidclamp> yeah, that d{2} worries me
14:41:15 <kidclamp> because we don't enforce this everywhere
14:41:22 <kidclamp> our fields are 6 decimals
14:41:23 <cait2> we could change that
14:41:24 <ashimema[m]> mmm.. I was thinking that too
14:41:37 <cait2> the trouble we have is the decimal separator
14:41:58 <ashimema[m]> we perhaps need to fix that with a preference so we can optionally limit it to however many decimal places your currency supports (for example)
14:41:59 <cait2> with number... we have seen strange things in different browsers/language settings/plack locale settings...
14:42:26 <ashimema[m]> I think we should generally drop 'step' and improve the 'patturn' instead?
14:42:49 <ashimema[m]> next topic...
14:42:54 <ashimema[m]> #topic Review of coding guidelines
14:43:01 <cait2> sounds good
14:43:10 <ashimema[m]> #info Drop or Update `JS5: Enabling translation of language strings in linked JavaScript` now we have bug 21156 pushed
14:43:10 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21156 enhancement, P5 - low, ---, julian.maurice, Pushed to stable , Internationalization: plural forms, context, and more for JS files
14:43:33 <ashimema[m]> I have already updated the guideline so it's not mandatory with a note
14:43:48 <oleonard> \o/
14:43:53 <ashimema[m]> but we should clarify it now we have bug 21156 pushed in master and 19.11
14:44:13 <ashimema[m]> and friends
14:44:26 <cait2> not mandatory with a note?
14:44:39 <ashimema[m]> as in..
14:44:47 <ashimema[m]> I added `NOTE: Since Bug 21156 - Internationalization: plural forms, context, and more for JS files this rule is deprecated, one should now use the options available via that bug.`
14:45:27 <ashimema[m]> I think we should now update the guideline as a whole to reflect whats available to us with bug 21156
14:45:42 <cait2> i tihnk it would be nice to have an example of the new thing in the guildelines
14:45:55 <cait2> or link to some commits to see how it's done...
14:46:02 <ashimema[m]> exactly
14:46:19 <ashimema[m]> I'll try to add a few examples
14:46:31 <Joubu> caroline wrote some good examples
14:46:37 <ashimema[m]> #action ashimema to update the guidelines with examples of how we now expect this to be done.
14:46:40 <ashimema[m]> ok.. that was easy
14:46:55 <ashimema[m]> #topic Set time of next meeting
14:47:06 <Joubu> I have a last question
14:47:18 <Joubu> do we have a hashtag for the hackfest?
14:47:21 <ashimema[m]> fire away Joubu
14:47:48 <ashimema[m]> cait2 said we do.. but hasn't alluded to what it is yet
14:49:17 <cait2> i think i was thinking of GBSD
14:49:20 <cait2> we should have one
14:49:26 <cait2> hackfest2020?
14:49:29 <cait2> hm no koha
14:49:36 <cait2> kohackfest2020?
14:49:38 <oleonard> Do we have an established pattern for the hackfest hashtag? No reason not to continue with it
14:49:43 <cait2> i tihnk
14:49:48 <cait2> hfk...something
14:49:50 <Joubu> #hfk19
14:49:50 <caroline> re: internationalization, I wrote myself a cheatsheet. I can translate it and share it if needed
14:49:54 * oleonard doesn't have one saved in his Twitter client
14:49:55 <Joubu> seems that we used #hfk19
14:49:57 <cait2> checking the excel
14:50:12 <cait2> hfk20 was noted there
14:50:21 <ashimema[m]> hfk20 sounds good to me
14:50:32 <cait2> maybe stil combine with #kohails whentweeting
14:50:44 <ashimema[m]> yup
14:51:03 <oleonard> It will collide with all the tweets about this: https://trimantec.com/products/airtac-hfk-air-gripper-parallel-hfk20
14:51:07 <oleonard> ;)
14:51:27 <ashimema[m]> lol
14:51:54 <Joubu> @later tell davidnind Hi David, could you tweet something about the hackfest that will be virtual this year? with #hfk20 #kohails thanks!
14:51:54 <huginn> Joubu: The operation succeeded.
14:52:38 <cait2> :)
14:54:05 <oleonard> Okay now set time of next meeting?
14:54:18 <ashimema[m]> same time in two weeks seem reasonable for next meeting
14:54:25 <tcohen> +1
14:54:26 * oleonard is getting called to do yard work... perils of working from home
14:54:37 <greenjimll> Assuming there's anything of civilisation left by then?
14:55:11 <cait2> let's hope
14:55:15 <oleonard> If #koha is offline then meet by the big rock near the stream
14:55:15 <tcohen> greenjimll right
14:55:25 <tcohen> hehe
14:55:39 <ashimema[m]> #info Next meeting: 01 April 2020, 14 UTC
14:55:44 <cait2> hm next general we should probably also discuss roles etc
14:55:56 <ashimema[m]> #endmeeting
14:56:15 <cait2> time runs
14:56:39 <oleonard> ashimema[m]++
14:56:53 <ashimema[m]> thanks everyone..
14:57:48 * ashimema[m] is having IRC issues it seems.. messages coming out of order it seems
14:57:59 <cait2> might be me talking confused
14:58:09 <ashimema[m]> for next release you mean cait?
14:58:35 <cait2> [off] We will close offices until april 19
14:58:40 <cait2> ashimema[m]: yep
15:01:00 <ashimema[m]> wow.. this cycle has gone quick
15:02:08 <cait2> yep
15:02:29 <corilynn> I'm terribly confused by koha-testing-docker
15:03:15 <corilynn> "ERROR: for koha  Cannot create container for service koha: create .: volume name is too short, names should be at least two alphanumeric characters
15:03:15 <corilynn> "
15:05:53 <Joubu> #endmeeting
15:06:02 <Joubu> #endmeeting
15:06:06 <Joubu> huginn: ?
15:06:07 <huginn> Joubu: downloading the Perl source
15:06:50 <Joubu> gmcharlt: The minutes from the last meeting has not been generated
15:08:25 <Joubu> ashimema[m]: can you endmeeting without your [m] nick?
15:10:03 <ashimema[m]> #endmeeting
15:10:23 <cait2> #endmeeting