15:00:34 <Joubu> #startmeeting Development IRC meeting 18 November 2020
15:00:34 <huginn> Meeting started Wed Nov 18 15:00:34 2020 UTC.  The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:34 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:34 <huginn> The meeting name has been set to 'development_irc_meeting_18_november_2020'
15:00:42 <Joubu> #topic Introductions
15:00:51 <Joubu> #info Jonathan Druart
15:00:53 <Joubu> rmaints?
15:00:53 <wahanui> rmaints is lukeG, aleisha, and tuxayo, I SUMMON THEE!!⚡⚡
15:00:55 <Joubu> qa_team?
15:00:55 <wahanui> qa_team is probably cait Joubu marcelr kohaputti josef_moravec tcohen kidclamp khall ashimema alex_a jajm matts
15:01:08 <Joubu> Music suggestion for this meeting - https://www.youtube.com/watch?v=n9MaxD2IWbU
15:01:12 <ashimema> #info Martin Renvoize, PTFS-Europe
15:01:32 <kidclamp> #info Nick Clemens, ByWater Soluitions
15:01:45 <lukeG1> #info Lucas Gass, ByWater Solutions
15:02:33 <lukeG1> Hi All! The Rmaints are finishing up our final release of the cycle. Seems thing to be proceeding well!
15:02:50 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
15:03:16 <Joubu> #topic Announcements
15:03:17 <khall> #info Kyle M Hall, ByWater Solutions
15:03:21 <Joubu> Anyone have something?
15:03:40 <cait> #info Katrin Fischer, BSZ, Germany
15:03:58 <Joubu> I have things to say, so moving on :)
15:04:02 <Joubu> #topic Update from the Release manager (20.11)
15:04:09 <Joubu> Today is the "bugfixes freeze for 'normal'". Starting tomorrow, nothing not considered at least major will be pushed for inclusion to 20.11.
15:04:17 <Joubu> So, Here is your list for today (please):
15:04:21 <Joubu> Waiting for QA: bug 25514, bug 26984, bug 26363
15:04:23 <Joubu> Waiting for SO: bug 27026, bug 26940
15:04:23 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25514 normal, P5 - low, ---, jonathan.druart, Signed Off , REST/Plugin/Objects.t is failing randomly
15:04:24 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26984 normal, P5 - low, ---, jonathan.druart, Signed Off , Tests are failing if AnonymousPatron is configured
15:04:25 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26363 enhancement, P5 - low, ---, dcook, Signed Off , Provide a systemd unit file for background_jobs_worker
15:04:26 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27026 normal, P5 - low, ---, jonathan.druart, Needs Signoff , New circulation rule "Days mode" values are not explained anywhere
15:04:27 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26940 normal, P5 - low, ---, didier.gautheron, Needs Signoff , debarred comment in borrowers table is lost on patron modifications in memberentry.pl page
15:04:33 <Joubu> And others for 20.11:
15:04:34 <Joubu> bug 26363, bug 26992,.
15:04:34 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26992 critical, P3, ---, frederic, Signed Off , On serial collection page, impossible to delete issues and related items
15:05:25 <Joubu> Waiting for patches:
15:05:30 <Joubu> bug 26922, bug 17809, bug 26282, bug 26659
15:05:30 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26922 major, P5 - low, ---, tomascohen, ASSIGNED , SendAlerts does not correctly handle error on sending emails
15:05:31 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17809 normal, P5 - low, ---, fridolin.somers, Failed QA , Correct some authorised values in fr-FR
15:05:32 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26282 major, P5 - low, ---, kyle, Failed QA , Allow staff to decide if a hold cancellation notice will be sent when cancelling a hold
15:05:33 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26659 major, P5 - low, ---, koha-bugs, Failed QA , An item can be renewed even if there are holds waiting to be filled
15:05:36 * ashimema will jump on some QA of those
15:05:45 <Joubu> And there is one discussion on bug 26947, we will talk about it later.
15:05:45 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26947 normal, P5 - low, ---, nick, Needs Signoff , kohastructure.sql should be updated for each release
15:05:50 <Joubu> Otherwise, good news, D11 issues will (hopefully) be fixed for 20.11 (see bug 26893)
15:05:50 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26893 blocker, P5 - low, ---, mtj, ASSIGNED , New version of JSON::Validator (D11) break our REST API routes
15:05:56 <Joubu> If you have some time this week, have a look at the release notes and make sure they look nice :)
15:05:59 <Joubu> https://gitlab.com/koha-community/koha-release-notes/-/blob/master/release_notes_20_06_00.md
15:06:02 <Joubu> There are some entries missing a description in the "technical release notes": https://annuel.framapad.org/p/koha_20.11_tech_release_notes (ping kidclamp, oleonard, khall, tcohen, and... Joubu!)
15:06:21 <cait> Joubu++
15:06:22 <Joubu> Some news about the move of the git server, it is planned for next Monday (Nov 23th 20UTC)! I will email Rmaints and the devel list to announce it.
15:06:34 <ashimema> nice one
15:06:37 <Joubu> any questions?
15:07:06 <Joubu> #info Search for the rel_20_11_target to follow what's missing for 20.11
15:07:21 <Joubu> #info D11 issues will certainly be fixed for 20.11 (see 26893)
15:07:21 <cait> info the date for git move please too
15:07:31 <ashimema> :)
15:07:34 <cait> maybe email to the mailing list too?
15:07:35 <Joubu> #info Have a look at the technical release notes, and the usual ones
15:07:38 <cait> and thx for managing all that! impressive!
15:07:40 <Joubu> #link https://annuel.framapad.org/p/koha_20.11_tech_release_notes
15:07:43 <Joubu> #link https://gitlab.com/koha-community/koha-release-notes/-/blob/master/release_notes_20_06_00.md
15:08:08 <cait> sorry, was moving to fast, you already said that about the mailing lists
15:08:18 <Joubu> cait: I will email the general ML when it's done and everything went fine
15:08:41 <fridolin> #info Fridolin Somers, Biblibre, France
15:08:51 <Joubu> #info Git server move planned on Nov 23th 20UTC
15:09:06 <fridolin> (ouf i nearly missed the meating )
15:09:19 * ashimema is liking the fast and furious approach to todays meeting
15:09:48 <Joubu> better to collect the link and bug # before the meeting ;)
15:09:52 <Joubu> #topic Updates from the Maintainers
15:09:59 <cait> :)
15:10:13 <Joubu> #info The Rmaints are finishing up their final release of the cycle. Seems thing to be proceeding well!
15:10:45 <Joubu> something else?
15:10:57 <cait> not that I can think of
15:11:00 <Joubu> #topic Updates from the QA team
15:11:22 <ashimema> QA all the things!
15:11:48 <ashimema> I've been trying to keep on top of the Majors and Criticals
15:12:10 <Joubu> last day for the normal ones at least!
15:12:18 <ashimema> some are FQA and only need fairly minor followups.. would be good to have people doing those...
15:12:26 <ashimema> bug 26634 for example
15:12:26 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26634 critical, P5 - low, ---, andrew, Failed QA , Hold rules applied incorrectly when All Libraries rules are more specific than branch rules
15:12:36 <Joubu> 2 I missed from the NQA queue: bug 26518 and bug 25942
15:12:36 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26518 major, P5 - low, ---, jonathan.druart, Signed Off , Adding a record can succeed even if adding the biblioitem fails
15:12:37 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25942 major, P5 - low, ---, nick, Signed Off , Batch biblio and borrower operations on report results should not concatenate biblio/cardnumbers into a single string
15:12:42 <ashimema> I've just not had the time to personally add qa followups on others bugs
15:12:56 <Joubu> (26518 is using Koha::Biblio for Add/ModBiblio)
15:14:22 <ashimema> many of those bugs are one's I've already touched so am locked out.. i.e calling other QA eyes ;)
15:14:53 <Joubu> qa_team around?
15:15:07 <tcohen> yes
15:15:18 <cait> I am sorry, I didn't have any time on my hands for the last 2 weeks :(
15:15:28 <cait> it's probably not going to get better any time soon
15:15:38 <cait> we are also trying to finish the German translation on time
15:15:38 <wahanui> okay, cait.
15:15:50 <cait> forget we are
15:15:58 <cait> forget we
15:15:58 <wahanui> cait: I forgot we
15:16:30 <Joubu> ok, moving on...
15:16:37 <koha-jenkins> Yippee, build fixed!
15:16:37 <wahanui> Congratulations!
15:16:38 <koha-jenkins> Project Koha_Master_D9_My8 build #470: FIXED in 1 hr 4 min: https://jenkins.koha-community.org/job/Koha_Master_D9_My8/470/
15:16:41 <Joubu> #topic Actions from last meeting
15:16:55 <Joubu> #action amoyano advertise 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc.
15:17:00 <Joubu> postponed for later
15:17:06 <Joubu> #action davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (still working on this)
15:17:09 <Joubu> same
15:17:13 <Joubu> #topic ashimema Open an omnibus bug to fix the existing occurrences of input type "number"
15:17:18 <Joubu> ashimema, did you?
15:17:25 <ashimema> done and linked on the agenda
15:18:05 <ashimema> #info Bug 26926 - Update all occurrences of <input type="number"> to apply ACC2 coding guideline
15:18:05 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26926 enhancement, P5 - low, ---, koha-bugs, NEW , Update all occurrences of <input type="number"> to apply ACC2 coding guideline
15:18:21 <ashimema> #link http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26926 Bug 26926
15:18:21 <huginn> 04Bug 26926: enhancement, P5 - low, ---, koha-bugs, NEW , Update all occurrences of <input type="number"> to apply ACC2 coding guideline
15:18:28 <Joubu> #topic oleonard ask the list if someone use OpacGroupResults somewhere
15:18:43 <Joubu> #info email about deprecation of OpacGroupResults has been sent
15:18:47 <Joubu> #link  https://lists.katipo.co.nz/pipermail/koha/2020-November/055362.html
15:18:51 <cait> and no vetos so far :)
15:18:54 <Joubu> #link  https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20410
15:18:54 <huginn> 04Bug 20410: enhancement, P5 - low, ---, koha-bugs, NEW , Remove OpacGroupResults system preference and feature
15:18:58 <Joubu> so far we are good :)
15:19:02 <ashimema> Zero replies so far.. so I reckon go for it ;)
15:19:09 <Joubu> thanks oleonard!
15:19:19 <Joubu> #topic General development discussion (trends, ideas, ...)
15:19:20 * ashimema is looking forward to waving goodbye to that one
15:20:15 <ashimema> I like the idea of making kohastructure more consistent.. not sure whether to do it at release time or require that it's built as part of submissions in the way kidclamp suggests rather than devs doing it manually
15:20:30 <Joubu> #topic Bug 26947 - we should update the kohastructure file as part of the release process
15:20:30 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26947 normal, P5 - low, ---, nick, Needs Signoff , kohastructure.sql should be updated for each release
15:20:33 <ashimema> it would certainly be a good start to get it consistent at the next release however.
15:20:36 <Joubu> sorry, was updating the OpacGroupResults bug
15:20:44 <ashimema> hehe
15:20:57 <Joubu> yes, I commented for the kohastructure.sql
15:21:00 <Joubu> it didn't work for me
15:21:16 <ashimema> interesting
15:21:22 <Joubu> I am willing to push it later (even right before the release) if we reach something that is working
15:21:24 <kidclamp> I need ot test, just wanted to put something there to see what happened
15:21:34 <kidclamp> and get feedback
15:21:43 <kidclamp> feel free to tweak or propose something else
15:22:23 <Joubu> kidclamp, will you have time to get back to it this week?
15:22:34 <kidclamp> I cannot say at this point
15:22:45 <Joubu> ok, I will see with ashimema then
15:22:53 <cait> woudl we use it to compare only or as a replacementß
15:22:57 <cait> i mean to create the file?
15:22:58 <ashimema> okies
15:23:08 <cait> just worried about the comments, might have to convert them to COMMENT() first?
15:23:11 <Joubu> cait: the idea is to recreate the file
15:23:15 <Joubu> at least to reach a clean state
15:23:37 <cait> i think my argument ofr the comments stands then
15:23:37 <Joubu> then to maintain properly, it when a new table is added (or even FK constraint)
15:23:50 <Joubu> yes, good point
15:23:55 <ashimema> I agree cait..I already highlgihted that we have a few different way's we've done comments
15:24:04 <cait> i know, but we didn't clean it up yet
15:24:08 <ashimema> tuxayo did some investigation to see how different they were
15:24:11 <ashimema> we need to clean up
15:24:12 <cait> although we agreed using COMMENT in the futur was fine
15:24:19 <Joubu> we could move them all with a script
15:24:21 <ashimema> I think we did
15:24:29 <cait> i think we onl ytalked about it
15:24:32 <cait> but easy to verify :)
15:24:41 <ashimema> yeah.. I can help craft such a script before we use this bug to dump a fresh copy
15:25:17 <Joubu> some comments are nonsense however
15:25:27 <Joubu> borrower.surname -- surname of the borrower
15:25:28 <Joubu> that's useless
15:25:34 <Joubu> anyway, not the point here
15:25:40 <ashimema> agreed
15:25:43 <ashimema> also agreed ;)
15:26:01 <Joubu> something else you would like to talk before we end the meeting?
15:26:30 <ashimema> we need to start getting ourselves organised for focus area's next cycle
15:26:39 <ashimema> I've not had a moment to think about it yet though.
15:26:49 <Joubu> yes, I'd like to send such email
15:26:55 <ashimema> brill
15:26:58 <Joubu> certainly right after 20.11 is released
15:27:08 <ashimema> :)
15:27:22 <Joubu> I've a list of stuffs, and I'd like to form work groups
15:27:58 <Joubu> well, I won't form them. I'd like to see work groups to be formed
15:28:07 <Joubu> ok.. time to end :D
15:28:09 <Joubu> #topic Set time of next meeting
15:28:10 <ashimema> +1
15:28:29 <Joubu> #info Next meeting: 2 December 2020, 20 UTC
15:28:40 <Joubu> 20 UTC is 9am in NZ
15:29:02 <Joubu> #endmeeting