14:07:23 <ashimema> #startmeeting Development IRC meeting 1 April 2020
14:07:23 <huginn> Meeting started Wed Apr  1 14:07:23 2020 UTC.  The chair is ashimema. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:07:23 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:07:23 <huginn> The meeting name has been set to 'development_irc_meeting_1_april_2020'
14:08:02 <ashimema> #topic Introductions
14:08:10 <ashimema> please use #info to introduce yourselves
14:08:12 <Joubu> meetings are no longer displayed/created in the agenda?
14:08:21 <Joubu> #info Jonathan Druart
14:08:22 <ashimema> #info Martin Renvoize, PTFS Europe
14:08:24 <marcelr> #info Marcel de Rooy, Rijksmuseum, Netherlands
14:08:25 <ashimema> they should be
14:08:35 <Joubu> I don't see them
14:09:03 <Joubu> next ones are on 8th and 9th and not there either
14:09:31 <ashimema> #topic Announcements
14:09:33 <Joubu> qa_team?
14:09:33 <wahanui> well, qa_team is cait Joubu marcelr kohaputti josef_moravec tcohen kidclamp khall
14:09:37 <Joubu> welcome back wahanui
14:10:00 <ashimema> interesting.. I don't see them either
14:10:03 <ashimema> grr
14:10:23 <Joubu> I will check when running the script, maybe there is an error
14:10:31 <ashimema> thanks Joubu
14:10:40 <thd> #info Thomas Dukleth, Agogme, New York City [capital of bad viruses and hour long queues to see empty shelves]
14:11:00 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
14:11:30 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_1_April_2020
14:11:35 <Joubu> it's empty
14:11:39 <ashimema> #info The virtual hackfest was a reasonable success.. lots of bugs pushed and a huge amount of movement in bugzilla. Thankyou to everyone who contributed and got involved.
14:11:49 <marcelr> https://wiki.koha-community.org/wiki/Development_IRC_meeting_1_April_2020
14:11:50 <kidclamp> #info Nick Clemens, ByWaterSolutions
14:12:07 * ashimema is juggling meetings
14:12:13 <ashimema> #chair Joubu
14:12:13 <huginn> Current chairs: Joubu ashimema
14:12:26 <Joubu> #chair cait
14:12:26 <huginn> Current chairs: Joubu ashimema cait
14:12:28 <Joubu> :D
14:12:34 <ashimema> any other anouncements?
14:13:40 <ashimema> ok
14:13:47 <ashimema> #topic Update from the Release manager
14:15:39 <ashimema> #info We are moving into the bugfix and polishing stage of the cycle now.  I will be going through the rel_20_05_target and rm_priority lists and tidying it up... I will make some exceptions, but generally we should not be focusing on cleaning up for the release, finding and fixing bugs and polishing enhancements and new features.
14:16:06 <marcelr> not = now ?
14:16:08 <ashimema> #topic Update from the Release maintainers
14:16:12 <ashimema> rmants?
14:16:13 <Joubu> s/not// :)
14:16:20 <ashimema> ack.. correct
14:16:23 * ashimema can't type
14:16:30 <Joubu> rmaints?
14:16:30 <wahanui> i think rmaints is talljoy, lucas, hayley
14:16:47 <tallerjoy> hi!
14:16:52 <khall> #info Kyle M Hall, ByWater Solutions
14:17:01 <tallerjoy> #info Joy Nelson Bywater Solutions
14:17:12 <ashimema> [off] the fun of watching a folio demo whilst hosting a koha meeting
14:17:12 <lukeG1> #info Lucas Gass, ByWater Solutions
14:17:43 <tallerjoy> I am behind, but taking this week to catch up to all the things that Martin has been pushing to master
14:18:22 <lukeG1> 19.05.09 was released last week, everything going along smoothly
14:18:43 <ashimema> it's been fast and furious of late.. sorry you've got so much to catch up on rmaints ;)
14:19:15 <cait> #info Katrin Fischer, BSZ, Germany
14:19:17 <Joubu> lukeG1: not sure you saw my later
14:19:20 <ashimema> #info Joy is catching 19.11 up with master that the moment.. fast moving master.
14:19:22 <Joubu> in 19.05.09 there are 2 features
14:19:34 <Joubu> bug 24260 is part of the release notes
14:19:34 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24260 new feature, P5 - low, ---, lari.taskula, NEW , REST Self Registration
14:19:42 <Joubu> no idea how it goes there
14:19:48 <ashimema> #info releases went out last week and included 2 new features
14:20:00 <Joubu> no, one :)
14:20:05 <ashimema> hmm, me either
14:20:11 <Joubu> https://koha-community.org/koha-19-05-09-release/
14:20:34 <Joubu> I think we should edit the wiki and the release notes md file
14:21:19 <Joubu> s/wiki/website
14:21:44 <cait> because it's not actually in?
14:21:50 <cait> revert or bug number typo?
14:23:25 <Joubu> lukeG1: could you double check?
14:23:32 <Joubu> moving on then
14:23:33 <Joubu> #topic Updates from the QA team
14:23:51 <Joubu> cait maybe?
14:23:55 <lukeG1> yes, i will Joubu, thanks for pointing out
14:24:00 <oleonard> QA team update: QA team is great.
14:24:01 <ashimema> thanks Joubu
14:24:20 <cait> thinking
14:24:20 <wahanui> thinking is so much easier
14:24:25 <Joubu> I think we should highlight bug 22001 that has been pushed a couple of days ago
14:24:25 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22001 enhancement, P5 - low, ---, jonathan.druart, Pushed to master , RaiseError and PrintError flags must be set for tests
14:24:36 <cait> can you say smething about the consequences?
14:24:37 <oleonard> wahanui: Easier than what??
14:24:37 <wahanui> oleonard: no idea
14:24:47 <Joubu> some problems poped up, and I fixed them
14:24:54 <Joubu> but maybe there are some left
14:25:25 <Joubu> I think we need to write something to koha-devel about it, that's a bit technical and tricky
14:25:31 <Joubu> but basically, we did things wrong
14:25:38 <cait> not the first time :)
14:25:45 <cait> shoudl we action you for the email?
14:25:46 <Joubu> now it's correct for tests, but as things were wrong, we did other things to balance
14:26:09 <Joubu> #action Joubu add an email to koha-devel about 22001 (RaiseError)
14:26:12 <Joubu> will do
14:26:31 <Joubu> something else?
14:26:57 <cait> i think just the usual - queue is full, please QA :)
14:27:14 <cait> the hackfest was a success i think in that - the SO are really down, so QA is up
14:27:18 <Joubu> I made it down to 10 yesterday, this morning it was up again
14:27:29 <Joubu> not sure what to do...
14:27:31 <cait> yeah, it does that, good and bad
14:27:32 <cait> another thing
14:27:40 <cait> shoudl we start looking for next Release team?
14:27:54 <cait> we got about 2 months now, so maybe a little early, but not very early
14:27:59 <Joubu> we elected you as RM already cait
14:28:00 <cait> we need more hands on QA if possible
14:28:12 <cait> I know what date it is! .)
14:28:33 <ashimema> We should certainly start promoting for the next team
14:29:00 <ashimema> #topic General development discussion
14:29:07 * oleonard posts the job on LinkedIn
14:29:15 <ashimema> #info We should start thinking about the next cycle and the next team
14:29:19 <kidclamp> Please vote on my RFC?
14:29:30 <kidclamp> https://wiki.koha-community.org/wiki/Advanced_editor_macros_endpoint_RFC
14:29:31 <ashimema> #action Martin will send out an email
14:29:50 <cait> oh good one
14:30:00 <ashimema> #info Nick has an RFC we need to look at
14:30:08 <ashimema> #link https://wiki.koha-community.org/wiki/Advanced_editor_macros_endpoint_RFC
14:30:18 <cait> the api naming looks good to me
14:30:24 <cait> for the paths better to ask tcohen maybe
14:30:28 <cait> or someone else .)
14:30:38 <oleonard> I like tcohen's suggestion at the bottom of the page
14:30:49 <cait> agreed
14:30:52 <cait> just spotted it as well
14:30:55 <kidclamp> yes, I will adopt his path changes
14:31:01 <ashimema> I like tcohens path
14:31:14 <cait> maybe we could even vote then?
14:31:28 <kidclamp> please!
14:32:06 <ashimema> fancy phrasing a vote question someone?
14:32:16 <marcelr> incl path of tcohen
14:32:32 <ashimema> +!
14:32:37 <tcohen> hola
14:32:37 <wahanui> hello, tcohen
14:32:48 <tcohen> I didn't know it was wednesday already :-/
14:32:50 <cait> tcohen must haveh eard us
14:32:54 <oleonard> "Heretofore shall it henceforth and in perpetuity..."
14:33:11 <kidclamp> Should we accept the advanced editor macros endpoint as proposed by kidclamp on the wiki with the path changes proposed by tcohen?
14:33:14 * tcohen has just seen a green symbol on my IRC client
14:33:35 <cait> #startvote "Do you agree with the RFC for advanced editor macros as wirtten on the wiki including suggested path change by tcohen? (yes,no,abstain)
14:33:35 <huginn> Begin voting on: "Do you agree with the RFC for advanced editor macros as wirtten on the wiki including suggested path change by tcohen? Valid vote options are , yes, no, abstain, .
14:33:35 <huginn> Vote using '#vote OPTION'. Only your last vote counts.
14:33:47 <tcohen> #vote yes
14:33:50 <thd> #vote yes
14:33:52 <marcelr> #vote yes
14:33:54 <Joubu> #vote yes
14:33:55 <tallerjoy> #vote yes
14:33:55 <cait> kidclamp: was already typing sorry, saw your suggestion too late
14:33:57 <ashimema> should we have created and updated dates i there?
14:33:58 <khall> #vote yes
14:34:03 <ashimema> #vote yes
14:34:06 <ashimema> we can add those later
14:34:09 <cait> #vote yes
14:34:15 <cait> ashimema: like a tiemstamp?
14:34:21 <ashimema> indeed
14:34:42 <ashimema> I don't know.. how much auditing of macros may need to take place ;)
14:34:46 <ashimema> just a question..
14:34:48 <oleonard> #vote yes
14:35:11 <kidclamp> file a bug and I will add in timestamps after initial bug is in
14:35:13 <cait> but could be a separate bug maybe? if there isn't one currently
14:35:25 <cait> yes
14:35:31 <tcohen> auditing_columns++
14:35:34 <ashimema> agreed
14:35:40 <cait> ending vote!
14:35:42 <cait> 3
14:35:42 <cait> 2
14:35:45 <cait> 1
14:35:49 <cait> #endvote
14:35:49 <huginn> Voted on ""Do you agree with the RFC for advanced editor macros as wirtten on the wiki including suggested path change by tcohen?" Results are
14:35:49 <huginn> yes (9): Joubu, cait, tallerjoy, oleonard, ashimema, marcelr, khall, tcohen, thd
14:35:52 <cait> there you go
14:35:55 <cait> please update the wiki :)
14:36:05 <ashimema> thanks
14:36:08 <kidclamp> will do, thank you!
14:36:08 <cait> #action kidclamp to update wiki with changes, vote date etc.
14:36:38 <ashimema> any more general discussion points?
14:37:09 * oleonard would like to advertise Bug 25031
14:37:09 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25031 enhancement, P5 - low, ---, oleonard, Needs Signoff , Improve handling of multiple covers on the biblio detail page in the staff client
14:37:15 <oleonard> I think it's fun. Please test!
14:38:29 <Joubu> oleonard: Don't you think we should have a multiple sysprefs for cover images?
14:38:44 <oleonard> We do
14:38:59 <oleonard> the bug better accommodates covers when multiple preferences are enabled at once
14:38:59 <Joubu> really?
14:38:59 <wahanui> really is good to have josef_moravec back.. always get a boost from seeing a bunch of signoffs :)
14:39:02 <cait> some of them need extra parameters - probably not possible to wraup it all in one?
14:39:41 <tcohen> Why not add a new admin page "Cover images sources"
14:39:49 <Joubu> we should have one you mean?
14:40:04 <oleonard> My patch doesn't make any changes to the covers features, it merely changes the display if you have multiple cover sources enabled.
14:40:19 <Joubu> yes ok
14:40:37 <cait> tcohen: we have a pref tab - catalog enrichments or so
14:41:39 <cait> better display for mulitple is quite a long standing bug - thx for tackling it Owen :)
14:41:53 <cait> um oleonard
14:41:53 <wahanui> i guess oleonard is happy for ashimema to write the release script
14:42:35 <oleonard> If folks like it I will try to adapt some of those principles to search results & OPAC
14:42:49 <ashimema> :)
14:43:57 <tcohen> oleonard++
14:44:20 * oleonard will accept karma if the patch works ;)
14:45:11 <ashimema> moving on...
14:45:11 <Joubu> nothing else?
14:45:16 <ashimema> #topic Review of coding guidelines
14:45:34 <ashimema> I don't think we have anything to discus this time :)
14:45:42 <oleonard> I have a question that might be relevant
14:45:51 <ashimema> fire away
14:46:12 <oleonard> I was going to ask cait but I'll throw it out to you all: Do we have established rules for how to add the use of a cookie other than documenting it?
14:46:25 <oleonard> Rules about how the cookie can/should be removed, for instance?
14:47:07 <marcelr> Privacy stuff?
14:47:10 <cait> not that I know of - for the GDPR group my work was mostly documentation
14:47:24 <cait> i think if the feature is not used/active - set no cookie
14:47:34 <cait> keep cookie duration to a sensible length for the feature
14:47:54 <cait> be more careful in OPAC than in staff?
14:47:58 <Joubu> and use localStorage when possible
14:48:21 <oleonard> Was just about to say: guidelines for when to prefer cookies over localstorage and vice versa
14:48:30 <marcelr> right
14:48:45 <Joubu> when localStorage possible, use it
14:48:52 <oleonard> I'd like to hear more about folks' preference for localstorage
14:48:57 <Joubu> ie. no need to get the info on the server
14:49:46 <cait> i am not sure if we need to document those as well... but possibly?
14:49:56 <marcelr> kind of the same
14:50:02 <Joubu> nope
14:50:10 <Joubu> the usage is not the same
14:50:13 <marcelr> depends on what you store
14:50:40 <Joubu> if it's client only, you do not need to use a cookie
14:50:48 <oleonard> Joubu why wouldn't we document localstorage just as we do cookies?
14:51:03 <Joubu> we can, but there is no privacy concerns
14:51:13 <marcelr> not sure about that
14:51:18 <Joubu> localStorage is not shared with the server
14:51:27 <marcelr> thats not all
14:51:45 <marcelr> it is stored, maybe people dont want that
14:51:56 <Joubu> then use sessionStorage
14:51:57 <cait> i am really not sure about procedures there
14:52:18 <Joubu> it's stored as well but removed when the tab is closed
14:52:44 <oleonard> I think our answer should be: Document localstorage just as we do cookies because more information is better.
14:54:17 <Joubu> none is used at the OPAC it seems
14:54:41 <Joubu> from Koha code (but used by emoji-picker)
14:55:06 <tcohen> really?
14:55:06 <wahanui> really is probably good to have josef_moravec back.. always get a boost from seeing a bunch of signoffs :)
14:55:16 <Joubu> koha-tmpl/opac-tmpl/lib/emoji-picker/js/util.js:                        localStorage.setItem(key, value);
14:55:21 <tcohen> oh!
14:55:21 <oleonard> wahanui: forget really
14:55:21 <wahanui> oleonard: I forgot really
14:55:54 <marcelr> did we use sessionStorage for searches ?
14:56:25 <oleonard> marcelr yes
14:56:35 <oleonard> In the staff client
14:56:49 <tcohen> is there some docs to read so I undestand the concern about cookies¿
14:56:50 <cait> forget really
14:57:02 <cait> wahanui: forget really
14:57:02 <wahanui> cait, I didn't have anything matching really
14:57:08 <cait> oh :)
14:57:13 <Joubu> found that if you want, there is a table that explains clearly the differences https://wpreset.com/localstorage-sessionstorage-cookies-detailed-comparison/
14:57:23 <oleonard> tcohen: I think it all stems from GDPR
14:57:25 <Joubu> like "Accessible server-side – yes no no"
14:57:50 <cait> interesting
14:58:00 <tcohen> cookies and localStorage are the only way to have persistent state browser-side
14:58:41 <cait> https://softwareengineering.stackexchange.com/questions/290566/is-localstorage-under-the-cookie-law (probably not best source) claims local storage is also eccected by cookies
14:59:00 <marcelr> eccected ?
14:59:22 <cait> hm does't seem like the original soruce of tha tstatement still exists, so probably need to do more research
14:59:27 <cait> sorry
15:00:12 <marcelr> well localstorage is also in the GDPR domain
15:00:12 <wahanui> okay, marcelr.
15:01:28 <cait> not against use - but we might be better off documenting
15:01:44 <cait> and from the beginning, because finding them al was no fun and I still feel i might have missed some
15:01:47 <oleonard> Okay: 1. Prefer localstorage if possible. 2. Document both cookies and localstorage.
15:01:59 <oleonard> Sound correct?
15:02:07 <cait> coudl someone try and phrase out an update to the coding guideline including this?
15:02:07 <marcelr> And hold back from adding them too much ?
15:02:08 <Joubu> prefer sessionstorage first
15:02:16 <Joubu> then local, then cookie
15:02:16 <ashimema> +1
15:02:24 <Joubu> then send me cookies
15:02:49 <oleonard> I'd like to suggest that we document new cookies/localstorage on the wiki when we submit patches, not just after they're pushed to master
15:03:02 <oleonard> It'd be good to catch that stuff during QA
15:03:12 <marcelr> add when they are pushed
15:03:40 <cait> whoever catches it - there is a cookie keyword that can be set
15:04:07 <cait> we could note 'in dev' for version and the bug number
15:05:49 * oleonard likes that
15:05:59 <tcohen> sessionStorage would be the option for those concerned about privacy, but using that instead of localStorage would be a big behaviour change
15:06:15 <tcohen> am I getting it right?
15:06:41 <oleonard> tcohen: We could switch to sessionStorage for any cookie which we set only for the session
15:07:52 <cait> we can at least define a goal - and use it for new features, move ove the others
15:08:53 <Joubu> example, bug 25027 I wrote yesterday, move from sessionStorage to localStorage
15:08:53 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25027 enhancement, P5 - low, ---, jonathan.druart, Needs Signoff , Result browser should not overload onclick event
15:09:25 <Joubu> (to see the difference between both)
15:09:32 <oleonard> Joubu++
15:09:53 <Joubu> I think most of the time we need localStorage over sessionStorage
15:10:43 <marcelr> htg
15:11:24 <oleonard> The question came up for me in part because I was working on Bug 24625, which seems to be a great candidate for sessionStorage
15:11:24 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24625 enhancement, P5 - low, ---, oleonard, NEW , Phase out jquery.cookie.js:  showLastPatron
15:12:35 <Joubu> sounds like it is, yes
15:12:41 <oleonard> Anyway, I think we needn't continue this discussion now since the meeting is running long now
15:13:05 <cait> you are rright
15:13:07 <Joubu> moving on?
15:13:18 <Joubu> #topic Set time of next meeting
15:13:24 <cait> thx Joubu
15:13:32 <cait> 2 weeks?
15:13:48 <Joubu> 15 April 2020, ?
15:13:49 <Joubu> hour?
15:14:13 <Joubu> #info Next meeting: 15 April 2020, 20 UTC
15:14:13 <Joubu> that?
15:14:13 <wahanui> it has been said that that is what blou added in his patch
15:14:23 <cait> 20 UTC?
15:14:23 <wahanui> i heard 20 UTC was currently set for the general meeting but I think 19 UTC may be closer to what people favoured in the preferred times poll.
15:14:30 <cait> not sure how this works with recent daylight savings changes
15:14:39 <oleonard> wahanui you are full of comments today
15:14:39 <wahanui> ...but wahanui is back??!!!|a political leader|a conch...
15:14:46 <cait> i am wayyy too slow today :)
15:14:48 <cait> works for mw!
15:15:08 <cait> end?
15:15:09 <Joubu> #endmeeting