20:03:53 <davidnind> #startmeeting Development IRC meeting 1 July 2020
20:03:53 <huginn> Meeting started Wed Jul  1 20:03:53 2020 UTC.  The chair is davidnind. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:03:53 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:03:53 <huginn> The meeting name has been set to 'development_irc_meeting_1_july_2020'
20:04:15 <davidnind> #chair cait ashimema
20:04:15 <huginn> Current chairs: ashimema cait davidnind
20:04:33 <davidnind> #info Agenda: https://wiki.koha-community.org/wiki/Development_IRC_meeting_1_July_2020
20:04:39 <cait> #info Katrin Fischer, BSZ, Germany
20:04:49 <davidnind> #topic Introductions
20:04:55 <cait> oops, too early
20:04:58 <tallerjoy> #info Joy Nelson Bywater Solutions
20:05:11 <davidnind> #info David Nind, Wellington, New Zealand
20:05:19 <davidnind> :)
20:05:25 <lukeG1> #info Lucas Gass ByWater Solutions
20:05:39 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
20:06:31 <bag> #info Brendan Gallagher ByWater
20:06:58 <kidclamp> #info Nick Clemens ByWater
20:07:13 <tuxayo> #info tuxayo/Victor Grousset, France
20:08:02 <davidnind> #topic Announcements
20:08:24 <davidnind> Has anyone got any announcements to share?
20:09:11 <cait> oh
20:09:40 <cait> i got one
20:09:48 <davidnind> Nice update on kohacon20 is here https://www.catalyst.net.nz/blog/keeping-kohacon20-%E2%80%93-episode-1
20:10:04 <cait> #info Please help testing Bug 20271  - Merge deleted biblio, biblioitems, biblio_metadata, and items tables! (also see Call for Testing on koha-devel)
20:10:32 <davidnind> #info Update on Kohacon20 https://www.catalyst.net.nz/blog/keeping-kohacon20-%E2%80%93-episode-1
20:10:42 <davidnind> Thanks cait!
20:10:56 <davidnind> #topic Update from the Release manager (20.11)
20:11:34 <davidnind> Possible a bit late for Joubu... so moving on.
20:11:35 <tuxayo> For bug 20271, a summary is here:
20:11:36 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20271 enhancement, P1 - high, ---, jonathan.druart, Signed Off , Merge deleted biblio, biblioitems, biblio_metadata, and items tables
20:11:36 <tuxayo> https://lists.koha-community.org/pipermail/koha-devel/2020-June/045810.html
20:11:36 <tcohen> he's offline
20:11:50 <davidnind> #topic Updates from the Release Maintainers
20:12:02 <tcohen> I've successfully tested yesterday an
20:12:04 <tcohen> d a 0bit t0oday
20:12:11 <davidnind> thanks tcohen!
20:12:15 <tcohen> Javier says hi to the keyboard
20:12:32 <tcohen> there's an issue with teh atomicupdate
20:12:33 <ashimema> #info Martin Renvoize, PTFS-E
20:12:36 <tuxayo> rmaints?
20:12:36 <wahanui> lukeG, aleisha, and tuxayo, I SUMMON THEE!!
20:13:02 <davidnind> congratulations to the release maintainers aleisha and tuxayo for their first releases!
20:13:15 <cait> tcohen: could you add what you tested here maybe tcohen? https://lite.framacalc.org/9hdw-bug_20271
20:13:24 <tcohen> yes m'am
20:13:27 <cait> aleisha++ tuxayo++
20:13:33 <cait> thx :)
20:13:38 <davidnind> #info Congratulations to the release maintainers aleisha and tuxayo for their first releases
20:13:40 <lukeG1> First maintain release was last week for the new team. Things seem to be going well. Thanks to Joubu for rolling the 20.05.01 release for me while I was away!
20:13:43 <tuxayo> 19.05.x: first release was done. I'm looking forward to next ones to less struggle ^^
20:13:59 <tuxayo> Joubu++
20:14:27 <tuxayo> Thanks to various people here on the channel that helped me! :D <3
20:14:39 <davidnind> Excellent!
20:14:39 <wahanui> darn tootin' it is.
20:14:47 <ashimema> Well done guys and gals
20:15:35 <davidnind> #topic Updates from the QA team
20:16:14 <cait> #info QA team is bigger, list is too! :)
20:16:55 <cait> looking for something to add :9
20:17:06 <ashimema> Trying to keep up cait.  But also catching up on work
20:17:16 <cait> at the moment the queue has a lot of bigger patches, so getting the numbers down is not so easy
20:17:23 <cait> but we will keep at it
20:17:39 <ashimema> Nice to see more names regularly on the QA leaderboards
20:17:53 <tuxayo> No worries about numbers, it's the big stuff window now!
20:17:58 <davidnind> one bug at  a time :-D
20:18:23 <cait> yep, that's the thing, one bug at a time :)
20:18:32 <ashimema> +1
20:18:57 <davidnind> thanks cait and the QA team!
20:19:16 <davidnind> #topic Actions from last meeting
20:20:07 <davidnind> as there are a few items, maybe just a quick comment from whomever is responsible
20:20:27 <tuxayo> «tuxayo write a proposal for handing over stable branches»
20:20:28 <tuxayo> Late sorry, not drafted for now
20:21:05 <cait> #info testing day turned into a 2 week thing, maybe will try a different approach next time :)
20:21:15 <davidnind> thanks tuxayo!
20:21:45 <ashimema> Yikes.. I failed on both my actions
20:22:00 <cait> and you wrote the action reminder thing :)
20:22:06 <davidnind> with action points being picked up by the meeting script, I guess I just add as actions again..
20:22:23 <tuxayo> yep
20:22:40 <davidnind> #action tuxayo - write a proposal for handing over stable branches
20:23:00 <tuxayo> Thanks davidnind  I was searching the thing
20:23:18 <davidnind> #action ashimema - open a bug report to introduce the idea of having a "skeleton" template we could copy for new pages
20:23:33 <ashimema> I did start drafting, but got distracted..
20:23:48 <ashimema> Thanks davidnind
20:23:52 <davidnind> #action ashimema - to draft the first 'Accessibility' guideline; All OPAC pages require a single 'maincontent' classed block.
20:24:11 <davidnind> #action ashimema - write a guideline about mandatory 'maincontent' class (OPAC)
20:24:16 <cait> I think oleonard had suggested to wait with the template until we got the bootstrap update in? (iirc?)
20:24:20 <tuxayo> Lot of homework for ashimema
20:24:45 <tuxayo> cait: Indeed that was mentioned. Not sure about the outcome.
20:24:57 <ashimema> I think so too cait
20:25:01 <davidnind> okay, that sounds sensible
20:25:28 <davidnind> I'll manually update the agenda for next time to remove it
20:25:47 <ashimema> 😀
20:26:24 <cait> ;)
20:26:34 <davidnind> #info "skeleton" template we could copy for new pages - deferred until Boostrap update merged
20:26:48 <davidnind> talljoy?
20:26:48 <wahanui> well, talljoy is here :)
20:26:54 <tallerjoy> yes?
20:27:22 <davidnind> the action point for inclusive language
20:27:25 <ashimema> You were drafting a language guideline
20:27:43 <tallerjoy> Well, i was going to, but it appears that someone already updated the coding guidelines terminology page.
20:28:01 <tallerjoy> so, it didn't seem relevant to propose it?  But i can still write one if you'd like it.
20:28:32 <cait> do you have the link maybe?
20:28:54 <tallerjoy> https://wiki.koha-community.org/wiki/Terminology
20:29:06 <cait> ah ok, the terminology
20:29:08 <tallerjoy> that link?
20:29:11 <kidclamp> bye all. gotta run
20:29:11 <cait> was looking at coding guidelines
20:29:14 <davidnind> #info Terminology list updated for more inclusive language for https://wiki.koha-community.org/wiki/Terminology
20:29:17 <tuxayo> https://wiki.koha-community.org/wiki/Coding_Guidelines#TERM1:_The_agreed_set_of_library_terms_must_be_used
20:29:26 <cait> should we have a more general rule?
20:29:32 <cait> we only deal with deny list etc now
20:29:33 <tallerjoy> this is a terminology issue mainly, so putting it there seems most appropriate.
20:29:42 <cait> i think having a guideline as we find more would be helfpul
20:29:58 <cait> TERM3 maybe, after gender neutral pronouns
20:30:01 <cait> that would be a good spot
20:30:17 <tuxayo> Doesn't TERM1 work?
20:30:25 <tallerjoy> i had that though, but also tuxayo's thought
20:30:27 <cait> only if you have already listed it
20:30:57 <cait> so someone hands something in... we think it's bad... QA could refer to general rule about inclusive language
20:31:40 <cait> also a terminology list and stating that you want to use inclusive language are different things
20:31:50 <cait> explicit and implicit
20:31:56 <cait> if that makes sense?
20:32:00 <tallerjoy> It would be easy to draft something for a TERM3 section.  I can do that.  I think also folks wanted some context as well about why the change was proposed, and I can include that as well.
20:32:10 <cait> yep
20:32:14 <tallerjoy> thanks cait.
20:32:15 <cait> context
20:32:24 <davidnind> tallerjoy++
20:32:26 <ashimema> Perfect
20:32:29 <tuxayo> +1
20:32:33 <tcohen> talljoy++
20:33:11 <bag> tallerjoy++
20:33:23 <cait> tallestjoy++
20:33:25 <cait> :P
20:33:26 <tallerjoy> :D
20:33:36 <tcohen> tallerjoy++
20:33:43 <ashimema> Lol
20:33:43 <davidnind> #action tallerjoy - Draft TERM3 for for inclusive language
20:33:58 <ashimema> Toomanyjoys++
20:34:02 <tallerjoy> heh
20:34:36 <ashimema> Hehe
20:34:47 <davidnind> Once that is done I guess we will need some bugs for any changes required, but that will come later
20:35:18 <tuxayo> «why the change was proposed»
20:35:36 <tuxayo> Indeed it was at the proposal stage, so a draft submitted at a meeting would help more people more of us understand the reasons.
20:35:41 <tuxayo> That depend of the culture and background: the POV of what kind of language changes are desirable.
20:36:09 <tallerjoy> and also to see what other languages have different inclusive language concerns as well.
20:36:19 <tuxayo> yep
20:36:40 <cait> yeah i think translators coudl refer to the rule as well
20:36:58 <tallerjoy> good point!
20:37:14 <davidnind> agree, always important that the rationale for a guideline or rule is identified/documented
20:37:18 <davidnind> #topic General development discussion (trends, ideas, ...)
20:37:29 <davidnind> thanks tallerjoy!
20:38:16 <davidnind> there are no names beside the agenda items...
20:38:36 <koha-jenkins> Project Koha_19.11_D9 build #195: SUCCESS in 43 min: https://jenkins.koha-community.org/job/Koha_19.11_D9/195/
20:38:38 <davidnind> start removing 'indirect object notation' calls - bug 25898
20:38:39 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25898 enhancement, P5 - low, ---, julian.maurice, Needs Signoff , Prohibit indirect object notation
20:38:52 <davidnind> any takers for this one?
20:38:52 <tcohen> +1
20:38:58 <ashimema> The first one is about advocating more modern best practice.. we mostly do it already
20:39:38 <ashimema> It's 'new thing' Vs 'thing->new' syntactically in code
20:39:48 <davidnind> does this need to be a coding guideline?
20:39:57 <ashimema> The latter is more modern and is where perl appears to be headed in general
20:40:18 <davidnind> or is it just something that needs to be done?
20:40:24 <cait> it looks like it would be reaosnably safe to replace?
20:40:46 <tuxayo> The manual equivalent of git blame but for the wiki blames ashimema for this meeting item :P
20:40:48 <ashimema> Yup
20:41:15 <cait> always good to have a coding guideline and qa tools updated
20:41:20 <cait> for these kind of things if we are serious about it
20:41:20 <davidnind> (not sure whether developers need a guideline for everything, or they automagically pick these things up)
20:41:39 <cait> davidnind: i don't think so, because code base is big and undocumented expectations are hard
20:41:41 <ashimema> Yup.. we should guideline it and add it to QA tools
20:41:54 <cait> it always helps if you can point to something written to help people
20:41:55 <ashimema> Ack.. I sense more homework coming
20:42:23 <cait> especially the ones new to the project
20:42:30 <davidnind> #info  start removing 'indirect object notation' calls - bug 25898 and add as a coding guideline
20:42:36 <tuxayo> ++
20:42:41 <davidnind> so who gets this one? :)
20:44:06 <davidnind> #action ashimema - add a draft coding guideline for direct notation rather than indirect object notation calls
20:44:14 <ashimema> Joubu.. for his absence 😛
20:44:24 <ashimema> Lol
20:44:37 <davidnind> volunteered!
20:44:41 <thd> #info Thomas Dukleth, Agogme, New York City
20:45:08 <tuxayo> "Seeking cosponsors"
20:45:11 <ashimema> Hehe
20:45:32 <ashimema> This next one was me too
20:46:03 <ashimema> I was just surprised to see the two varieties in the dB structure and wondered if there was a reason to go for one or the other
20:46:07 <ashimema> Brb
20:46:43 <davidnind> we'll tackle the Perl version until ashimema is back
20:47:43 <davidnind> was any general consensus reached on this with developers on the minimum version (I sort of followed some of the discussion, but....)
20:48:18 <tuxayo> About item 2: «the former appears in schema classes at dump time.»
20:48:18 <tuxayo> Is this good?
20:48:20 <ashimema> Back.
20:48:29 * cait lost the wiki page again
20:48:36 <tuxayo> https://wiki.koha-community.org/wiki/Development_IRC_meeting_1_July_2020
20:49:19 <cait> I tihnk we picked what will show up on schema
20:49:21 <cait> schema?
20:49:58 <cait> Example: http://schema.koha-community.org/master/tables/items.html
20:49:58 <tuxayo> I suppose both show? Otherwise part of them is much less useful :o
20:50:10 <davidnind> I like consistency so ...
20:50:15 <cait> it's been a whie, do we have an example for comment?
20:50:23 <koha-jenkins> Yippee, build fixed!
20:50:23 <wahanui> Congratulations!
20:50:23 <koha-jenkins> Project Koha_19.11_D8 build #197: FIXED in 40 min: https://jenkins.koha-community.org/job/Koha_19.11_D8/197/
20:50:24 <tuxayo> I'm searching
20:51:17 <cait> https://wiki.koha-community.org/wiki/Coding_Guidelines#SQL11:_All_fields_added_to_the_database_must_be_documented_in_kohastructure.sql
20:51:42 <cait> We have updated Schema Spy a few times since - not sure if there was a change
20:52:07 <tuxayo> https://gitlab.com/koha-community/Koha/-/blob/master/installer/data/mysql/kohastructure.sql
20:52:08 <ashimema> I would hope schemaspy would grab both
20:52:18 <tuxayo> Two instance of "COMMENT="
20:52:22 <tuxayo> And it's on tables
20:52:46 <tuxayo> schemaspy uses it for the table description
20:52:55 <ashimema> The -- version only appears in the dumpfile so can't get picked up by dbic dump.. hense why only 'COMMENT' works in the dbic context..
20:53:26 <cait> I'd hate to lose the comments on schema
20:53:39 <cait> maybe we can find something that works for both
20:53:48 <ashimema> In the dbic context it's just the addition of information in the POD.. so describes the fields use in the code rather than having to refer to schemaspy or the kohastructure to find out.
20:53:55 <tuxayo> ashimema: this is an example of the alternative?
20:53:56 <tuxayo> https://gitlab.com/koha-community/Koha/-/blob/master/installer/data/mysql/kohastructure.sql
20:54:27 <tuxayo> whoops
20:54:38 <tuxayo> * https://gitlab.com/koha-community/Koha/-/blob/master/installer/data/mysql/kohastructure.sql#L132
20:54:52 <tuxayo> CREATE TABLE `biblio` ( -- table that stores bibliographic information
20:55:29 <koha-jenkins> Yippee, build fixed!
20:55:29 <wahanui> Congratulations!
20:55:29 <koha-jenkins> Project Koha_19.11_U18 build #192: FIXED in 44 min: https://jenkins.koha-community.org/job/Koha_19.11_U18/192/
20:55:30 <ashimema> collections_tracking has COMMENT at the field level
20:55:48 <ashimema> How does it appear in the schemaspy schema
20:56:24 <ashimema> I also don't know if you need different options when dumping schema via schemaspy to pick them up if we don't already..
20:56:26 <cait> http://schema.koha-community.org/master/tables/collections_tracking.html
20:56:30 <tuxayo> Ok, so it's like that in SQL
20:56:31 <tuxayo> `name` varchar(255) NOT NULL COMMENT 'the name of the field as it will be stored in the search engine',
20:56:37 <cait> not sure if it looks right (sparse comments?)
20:57:24 <tuxayo> For search field it's ok
20:57:25 <tuxayo> http://schema.koha-community.org/master/tables/search_field.html
20:57:46 <tuxayo> > not sure if it looks right (sparse comments?)
20:57:47 <tuxayo> Seems right
20:59:02 <ashimema> Struggling to follow in phone.. but it sounds like the COMMENT version works for both.. so I think I'd advocate moving to that consistently ?
20:59:10 <ashimema> As apposed to mixing and matching
21:00:05 <davidnind> sounds sensible to me, but I know nothing about this :)
21:00:21 <tuxayo> It that the same for the table comment?
21:00:33 <davidnind> so, looks like an updated guideline is required - who would like to do that?
21:01:26 <ashimema> Fancy investigating that side of it and drafting a guideline tuxayo?
21:01:39 <tuxayo> ok!
21:01:39 <ashimema> I can help tomorrow
21:02:27 <cait> cool
21:02:28 <tuxayo> I'm writing the action
21:02:32 <davidnind> #action tuxayo - prepare draft update to SQL11 to improve consistency for descriptions in kohastructure files
21:02:38 <tuxayo> thanks davidnind
21:02:48 <davidnind> hope I got that right!
21:02:57 <davidnind> we are coming up on the hour
21:03:08 <davidnind> defer the Perl version to the next meeting?
21:03:11 <ashimema> Perfec
21:04:05 <ashimema> Did the next one get anywhere on the lists?
21:04:19 <ashimema> I reckon defer it..
21:04:24 <cait> hm it looked like 3.14?
21:04:36 <ashimema> The conversation seemed to be ongoing on lists 😀
21:04:38 <tuxayo> The conclusion was to add it to the next dev meeting :P
21:04:39 <cait> the last argument seemed that we push for the version that has the features we want
21:04:52 <ashimema> Lol
21:04:57 <cait> and i haven't seen someon eargueing for anything beyond 3.14 yet :)
21:05:12 <cait> and stick with debian/ubuntu (not go higher than there?)
21:05:26 <ashimema> I have in the past.. but I'm not of the same opinion now 😉
21:05:39 <davidnind> we could create a loop, and refer it back to the mailing list for discussion :)
21:05:53 <tuxayo> Oh yes!
21:06:09 <ashimema> 3.14 seems reasonable to me until we find were wanting to use something from a more recent version
21:06:15 <tuxayo> +1
21:06:20 <cait> +1
21:06:46 <tuxayo> > stick with debian/ubuntu (not go higher than there?)
21:06:46 <tuxayo> Perl seems to be very backward compatible IIUC so no issues on that side.
21:06:48 <ashimema> No point in artificially inflating it
21:06:51 <davidnind> is this a voting thing, or just an info and then action to document?
21:07:01 <ashimema> Cool
21:07:02 <thd> without objection
21:07:22 <tuxayo> it' just to reflect the current state of the code. There is no actual change
21:07:34 <thd> tuxayo++
21:07:42 <ashimema> I reckon we've all just agreed, so let's just action it
21:07:43 <cait> yep i think 3.14 is safe and should be done
21:07:54 <cait> we should update website, manual and release notes scripts
21:07:57 <tuxayo> *5.14
21:08:09 <cait> https://koha-community.org/download-koha/
21:08:12 <cait> hm we don't list versions there
21:08:22 <davidnind> #info Minimum recommended Perl version is 5.14 (until need to use a more recent version is identified)
21:08:41 <ashimema> We should Cait..
21:08:46 <ashimema> I'm happy to add that
21:08:48 <cait> yeah we probably should
21:08:48 <tuxayo> > hm we don't list versions there
21:08:48 <tuxayo> Good otherwise that would another source of inconsistency ^^"
21:09:01 <tuxayo> Like to somewhere else maybe?
21:09:02 <cait> #action ashimema to update requirements on website
21:09:11 <tuxayo> Or make the other places link to this?
21:09:18 <cait> good question
21:09:27 <cait> we could also say: refer to release notes of the version you want to install
21:09:31 <cait> for exact version
21:09:31 <cait> s
21:09:32 <tuxayo> To have less sources of truth
21:09:45 <cait> that way if we change for an upcoming veresion... things would still work
21:09:52 <ashimema> I like that.. refer to release notes
21:09:58 <cait> i mean, the information would still be correct
21:10:00 <cait> sorry, late
21:10:00 <ashimema> Reference the definitive source
21:10:04 <ashimema> 😉
21:10:17 <tuxayo> > refer to release notes of the version you want to install
21:10:18 <tuxayo> This is very relevant for OS and DBMS, they can change in the middle of a cycle
21:10:20 <cait> checking manual
21:10:45 <ashimema> /me is getting tired
21:11:20 <cait> aren#t you an hour earlier even? ;)
21:11:40 <cait> https://koha-community.org/manual/20.05/en/html/intro.html#koha-recommendations
21:11:42 <cait> we shoudl update that too
21:11:47 <cait> it refers to wiki, which is not really true
21:11:57 <cait> Full system recommendations can be found on the official Koha wiki along with the developer documentation: http://wiki.koha-community.org
21:12:18 <cait> #action cait to propose discussion about supported browsers at next meeting (IE especially)
21:12:25 <davidnind> Just pick the right page, and your good!
21:12:28 <tuxayo> oleonard should be happy
21:12:41 <davidnind> #info davidnind Find and update relevant places to record Perl version required, including manual and wiki (one source of the truth)
21:12:42 <cait> yeah, that's very hard to follow as advice :)
21:12:55 <cait> davidnind: maybe refer to release notes too? people best check that
21:13:21 <tuxayo> davidnind: I can also help, these system requirements things have been a lot in my mind lately ^^
21:13:27 <davidnind> #action davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth)
21:13:37 <davidnind> tuxayo++
21:13:49 <davidnind> #topic Set time of next meeting
21:13:52 <cait> it's also something that's asked about reasonably often
21:14:39 <davidnind> 14:00 next time and two weeks time?
21:14:43 <ashimema> Worthwhile meeting everyone, thanks
21:14:54 <tallerjoy> thanks!
21:15:01 <ashimema> Works for me
21:15:03 <cait> sounds good
21:15:15 <tallerjoy> UTC time i assume.
21:15:20 * tallerjoy will have to do some maths
21:15:24 <davidnind> UTC
21:15:47 <ashimema> #info davidnind has been an excellent chairperson, thankyou
21:15:51 <tallerjoy> yes, that works for me
21:15:59 <cait> davidnind++ :)
21:16:05 <tallerjoy> davidnind++
21:16:06 <tuxayo> davidnind++
21:16:26 <davidnind> #info Next meeting: 15 July 2020, 14:00 UTC
21:16:31 <davidnind> #endmeeting