14:00:02 <Joubu> #startmeeting Development IRC meeting 20 May 2020
14:00:02 <huginn> Meeting started Wed May 20 14:00:02 2020 UTC.  The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:02 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:02 <huginn> The meeting name has been set to 'development_irc_meeting_20_may_2020'
14:00:12 <Joubu> #topic Introductions
14:00:21 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_20_May_2020
14:00:24 <Joubu> #chair cait
14:00:24 <huginn> Current chairs: Joubu cait
14:00:30 <Joubu> #chair ashimema
14:00:30 <huginn> Current chairs: Joubu ashimema cait
14:00:44 <Joubu> #info Jonathan Druart
14:00:48 <ashimema> #info Martin Renvoize, PTFS-Europe
14:00:52 <oleonard_> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
14:00:55 <ashimema> where does the time go!
14:00:57 <Joubu> qa_team.
14:00:57 <wahanui> qa_team is cait Joubu marcelr kohaputti josef_moravec tcohen kidclamp khall
14:01:01 <cait> #info Katrin Fischer, BSZ, Geramny
14:01:02 <Joubu> rmaint?
14:01:06 <Joubu> rmaints?
14:01:06 <wahanui> hmmm... rmaints is talljoy, lukeG, hayley
14:01:07 <wizzyrea> #info liz rea
14:01:31 <nsk> thanks a lot
14:02:06 <Joubu> waiting few more minutes
14:02:42 <kidclamp> #info Nick Clemens, ByWater Solutions
14:03:07 <thd> #info Thomas Dukleth, Agogme, New York City
14:03:17 <Joubu> #topic Announcements
14:03:22 <Joubu> Anyone?
14:03:22 <wahanui> i guess Anyone is free to give it a shot :-)
14:03:54 <Joubu> apart from bots I mean
14:04:03 * oleonard_ is working on a Bootstrap 4 update for the OPAC
14:04:10 <wizzyrea> ooh exciting
14:04:15 <cait> jajm: wrong path on pacakge based installations
14:04:22 <ashimema> Nearly release time
14:04:24 <Joubu> great, did you open a bug report already?
14:04:29 <cait> oh sorry meeting
14:04:48 <oleonard_> Bug 20168
14:04:49 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20168 enhancement, P5 - low, ---, oleonard, ASSIGNED , Update of the OPAC bootstrap template to bootstrap v4
14:05:03 <Joubu> #info Owen is working a Bootstrap 4 update for the OPAC, see bug 20168. It will be ready for 20.11
14:05:12 <Joubu> I took some liberty in the info
14:05:18 <ashimema> oleonard++
14:05:33 <oleonard_> I think I can work with that deadline
14:05:53 <cait> Joubu: i think you mentioned using taiga or another board again
14:06:13 <cait> i htink a place for bigger projects like this would be nice
14:06:15 <Joubu> Will talk about that with the team in a couple of weeks
14:06:21 <cait> ok
14:06:22 <ashimema> indeed.. do you have any plans you'd like to announce here as you're about to take over :)
14:06:40 <Joubu> no plan yet, push all the things
14:06:48 <ashimema> #info Joubu will announce plans for the next cycle at the next development meeting.. first of the next cycle :)
14:06:51 * oleonard_ hopes Joubu assigns us new uniforms
14:06:53 <ashimema> :)
14:07:14 <Joubu> #topic Update from the Release Manager (20.05)
14:07:16 * cait wants a pink superlibrarian cape.
14:07:25 <wizzyrea> ^ would be adorable
14:07:34 <wizzyrea> with sequins
14:07:39 <cait> oh yes :)
14:07:51 <Joubu> lol
14:08:09 <Joubu> ashimema: ?
14:08:16 <Joubu> something else to add?
14:08:30 <ashimema> #info 20.05 is nearly ready.. I'm still aiming for a release on the 22nd but withhold the right to postpone if Jenkins isn't looking happy or I don't get the OK from the packaging team.
14:09:01 <Joubu> I have added 2 bullet points for the "general discussion" topic
14:09:04 <cait> ashimema++
14:09:04 <Joubu> will talk about that
14:09:09 <cait> team++
14:09:19 <ashimema> #info Thanks must go out to all those devs who have been working day and night the last couple of weeks to polish and fix bugs.. they know who they are.. fantastic effort to get us over the line guys!
14:09:51 <Joubu> #info community++
14:09:56 <ashimema> thinks that's it from mee
14:09:58 <ashimema> well done everyone
14:10:06 <Joubu> #topic Updates from the Release Maintainers
14:10:34 <Joubu> I don't thing rmaints poped up for the meeting
14:10:56 <Joubu> I *think* 19.05.x is broken since March, because of a typo in updatedatabase.pl
14:11:09 <Joubu> so the upgrade process might be broken
14:11:09 <cait> is that lukeg?
14:11:14 <Joubu> but nobody complained
14:11:34 <Joubu> yes, it's fixed now, and will be in the next that is released in a few days
14:11:54 <Joubu> #topic Updates from the QA team
14:12:39 <Joubu> #info QA queue is still high, but mostly enh (110 reports, 17 bugs)
14:12:47 <cait> thx Joubu
14:12:48 <Joubu> something to add cait?
14:13:07 <cait> I am late this week with my QA email, it's been hard to keep on top of things
14:13:14 <cait> turns out you can have tons of meetings while working from home too :)
14:13:34 <cait> fantastic work everyone and looking forward to start the next cycle with old and new QA team members
14:13:50 <talljoy> #info Joy Nelson Bywater
14:13:51 <Joubu> biggest QA team ever I think :)
14:14:04 <cait> yeah :) if they all manage a bit of time we should get very far
14:14:14 <cait> but we will be missing Joubu, so there is a lot t balance out
14:14:39 <Joubu> talljoy: something to tell us for 19.11?
14:14:43 <Joubu> talljoy: and hi :)
14:14:48 <talljoy> good morning
14:15:01 <talljoy> i am waiting on feedback for bug 25510
14:15:02 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25510 critical, P5 - low, ---, jonathan.druart, Pushed to master , Typo in koha-common.postinst causing shell errors
14:15:14 <ashimema> agreed.. QA team is big next cycle.. but we need them all to contribute else we'll easily fall behind
14:15:14 <talljoy> i understand that is needed in 19.11.x branch, but won't apply currently
14:15:16 <Joubu> yes, there are rebased patch from dcook
14:15:25 <Joubu> I did not test them but they look correct to me
14:16:03 <talljoy> i will take a look today
14:16:18 <Joubu> ok, let me know if you need help
14:16:26 <Joubu> #topic General development discussion (trends, ideas, ...)
14:16:40 <Joubu> We have 3 subtopics
14:16:48 <Joubu> #topic Catching errors caused by missing itemtype, homebranch, holdingbranch (see discussion on Bug 24331)
14:16:49 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24331 normal, P5 - low, ---, nick, Failed QA , Internal server error when placing hold on item if itemtype undefined
14:17:06 <Joubu> cait added it I think
14:17:33 <Joubu> on bug 24331 marcel would like a coding guideline about something that we (more or less) agreed on it already
14:17:58 <cait> ah yes, i noticed it was kind of stuck so we shoudl make a general decision
14:18:11 <cait> and document it to be able to refer to it
14:18:14 <Joubu> The idea is to assume that there is no "data inconsistency" in the DB
14:18:18 <kidclamp> I think maybe the API work on catching general exceptions would help?
14:18:26 <kidclamp> we want to avoid ISE
14:18:38 <kidclamp> I would prioritize that over minimal code
14:18:48 <Joubu> yes, but catching them all is impossible
14:19:17 <Joubu> I provided a script people must run before anything else. Those kind of inconsistencies only appear if you mess with your data
14:19:26 <Joubu> either on import, on doing something wrong in the admin area
14:19:54 <kidclamp> then I suppose on that bug we must address the fact the you can create items with no itemtype during acq
14:20:22 <wizzyrea> i've always thought there should be a default item type that the user can set at install time, that Koha will use if there isn't one
14:20:46 <ashimema> agreed
14:21:22 <cait> the worry i had was about catching the ones you want to change
14:21:37 <wizzyrea> they could still be null, just that Koha won't care about it anymore
14:21:41 <cait> ah
14:21:48 <cait> sorry, i think we discussed this before
14:21:49 <wizzyrea> cos it'll have a fallback
14:22:20 <wizzyrea> i write a lot of email about this issue, can you tell?
14:22:35 <wizzyrea> :D
14:22:42 <ashimema> ah.. so you're saying 'if null or bad itemtype, default to something'
14:22:48 <wizzyrea> yes
14:23:03 <wizzyrea> user picks what it is, but there's a fallback
14:23:08 <ashimema> as aposed to 'default to setting X if passed null or bad data'
14:23:58 <Joubu> The itype should be retrieved from biblio's itemtype
14:24:00 <wizzyrea> I don't think I have an opinion on which of those two implementations would be better
14:24:15 <Joubu> the "default" I mean
14:24:38 <ashimema> depends mainly on if you want to be able to see the original bad data the user input anywhere
14:24:52 <ashimema> or whether you just nuke any bad data that's inbound and replace it with 'good defalt'
14:25:13 <ashimema> the issue with doing the former it you would have to catch bad data in all sorts of places like the bug above
14:26:03 <ashimema> but I can see cait points of wanting to be able to see the bad data so you can go fix it properly rather than it getting nuked and becoming a default
14:26:46 <Joubu> bug 25449
14:26:47 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25449 enhancement, P5 - low, ---, koha-bugs, NEW , Make itemtype mandatory by default
14:27:00 <wizzyrea> on further thought I think I'm in cait's camp
14:27:40 <cait> I'd be ok with a fallback 'in code' too, i just wonder if that would actually be less work than trying to catch them all
14:27:50 <cait> hm maybe could be in effective_itemtype - then maybe not
14:27:58 <wizzyrea> well that's what I was thinking?
14:28:11 <wizzyrea> if you give nothing to effective, then use the default
14:28:15 <cait> yep, i was just against "assigning" a default in the item
14:28:27 <cait> changing the actual item data
14:28:30 <cait> because ithink they shoudl fix these
14:28:35 <wizzyrea> same
14:29:27 <ashimema> are we confident we're calling effective_itemtype everywhere correctly..
14:29:38 <cait> probably not...b ut we probably shoudl?
14:29:38 <Joubu> I am searching for the "remove item-level_itypes pref" bug report, but cannot find it. I was sure we had one. Isn't this problem hidding something more general we should deal with?
14:29:39 <ashimema> if so.. then fixing it inside that routine sounds optimal
14:30:03 <cait> Joubu: you could also not have an itemtype on record level... os not sure it woule help to kill it
14:30:31 * ashimema is confused as to why the customised effective_itemtype routine is inside dbic schema as aposed to in koha::object level
14:30:59 <ashimema> I feel you there Joubu.. feels like there might be something more behind this
14:31:26 <ashimema> as kidclamp said.. we should probably be dealing with the case at import time to prevent bad data in the first place..
14:31:31 <ashimema> if that's how bad data is getting in.
14:31:35 <cait> no
14:31:37 <cait> acq items
14:31:43 <cait> and default framework
14:31:46 <ashimema> we already fall back to biblio itemtype btw
14:31:47 <cait> is not mandatory
14:31:50 <cait> there is multiple ways
14:32:16 <ashimema> hang on
14:32:25 <kidclamp> if we say the data shouldn't be bad, we should not allow it :-) but thta won't be easy either
14:32:31 <ashimema> no we dont
14:32:33 <ashimema> the error being warned is non-sense
14:32:54 <Joubu> why?
14:32:56 <cait> sorry, I thnk i am ont following now
14:32:57 <ashimema> oh.. I mis-read
14:33:01 <ashimema> yes we do fallback
14:33:05 <ashimema> my brain is bad today
14:33:19 <Joubu> we fallback and warn, then we have the script to catch them.
14:33:34 <Joubu> fixing it everywhere a call to ->effective_itemtype is done seems wrong to me.
14:33:50 <ashimema> the 'effective_itemtype' routine looks at the pref and if the item level itype exists.. if it doesn it falls back and only warns if the pref is set too
14:34:03 <Joubu> but I am willing to work on a global fix if we agree on how it should work
14:34:49 <ashimema> now I'm lost too
14:35:16 <kidclamp> and I conceded that a global fix is better than fixing in every script
14:35:24 <cait> i think that's agreeable :)
14:35:53 <cait> i woudl be ok with: item level itype > record level itype > global default set in onboarding ?
14:35:54 <Joubu> your suggestion on bug 25449 makes sense to me
14:35:55 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25449 enhancement, P5 - low, ---, koha-bugs, NEW , Make itemtype mandatory by default
14:36:11 <Joubu> make it mandatory if the pref is set to "item level"
14:36:12 <cait> and also take measures to make it more mandatory (avoid mistakes in the first place)
14:36:23 <ashimema> ++
14:36:30 <ashimema> make it mandatory
14:36:44 <Joubu> wizzyrea, kidclamp?
14:37:23 <kidclamp> +1
14:37:56 <Joubu> to add to the discussion: https://lists.koha-community.org/pipermail/koha-devel/2015-December/042114.html
14:37:58 <wizzyrea> yeah I'm ok with whatever you all decide there, I"ll be happy to not write emails about ISEs due to item types
14:38:00 <Joubu> [Koha-devel] Get rid of item-level_itype?
14:38:21 <Joubu> so we continue on bug 25449?
14:38:26 <cait> i think it won't help but is a separate issue
14:38:30 <cait> well help...but not for that problem
14:38:38 <cait> we need the itemtype on both levels
14:38:51 * kohaputti is afraid things are gonna break (although they probably were already)
14:39:06 <cait> we#d just remove the unlikely choice
14:39:06 <kidclamp> 25449 is good start, and come up with a global fix if the data sneaks by
14:39:26 <Joubu> ok, let's start with that. It's an easy fix.
14:39:39 <Joubu> #action Joubu add a fix for 25449
14:39:51 <Joubu> #action cait signoff on 25449
14:39:57 <Joubu> #action kidclamp QA 25449
14:40:00 <Joubu> and we are done
14:40:06 <kidclamp> :-D
14:40:11 <ashimema> ++
14:40:17 <talljoy> :)
14:40:20 <kidclamp> gotta run off
14:40:32 <Joubu> #info Package bugs for 20.05
14:40:38 <Joubu> tcohen: maybe?
14:40:52 <tcohen> hola
14:40:52 <wahanui> hey, tcohen
14:40:55 <Joubu> I added it to let people know that we fixed a bunch of criticals/blockers
14:41:05 <cait> we just found something new
14:41:05 <Joubu> it *should* work now
14:41:25 <Joubu> but it would be great to have a "alpha" version available somewhere, to test it
14:41:30 <cait> the Koha.mo (js translations etc.) don't work with packages, tested with 18.11 but i think files are the same. it loosk for it in the wrong path
14:41:55 <Joubu> should we ask mtj[m]?
14:42:04 <ashimema> good idea Joubu
14:42:10 <cait> yes and alpha would be good
14:42:26 <ashimema> I was indeed going to ask for a test run of the package build asap
14:42:27 <cait> and maybe someoen with a working pacakgein stallaton coudl help verify my new bug on a newer version
14:42:32 <Joubu> @later tel mtj could you provide us a "alpha" version of the Koha 20.05 package?
14:42:33 <huginn> Joubu: I'll give you the answer as soon as RDA is ready
14:42:33 <wahanui> i already had it that way, huginn.
14:42:39 <Joubu> @later tell mtj could you provide us a "alpha" version of the Koha 20.05 package?
14:42:39 <huginn> Joubu: The operation succeeded.
14:42:55 <Joubu> #action mtj provide a "alpha" version of the Koha 20.05 package
14:43:21 <Joubu> #topic Some tests are failing randomly (Bug 25551)
14:43:23 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25551 normal, P5 - low, ---, chris, NEW , [OMNIBUS] Some tests are failing randomly
14:43:43 <Joubu> We "always" had them, so I grouped them under an umbrella bug report
14:43:52 <Joubu> there are several that should be fixed for 20.05 imo
14:44:07 <Joubu> and I am stuck with them, cannot fix. It would be great to get help
14:44:48 <Joubu> bug 24229
14:44:49 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24229 normal, P5 - low, ---, tomascohen, NEW , /items API tests fail on Ubuntu 18.04
14:44:55 <Joubu> bug 25513
14:44:56 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25513 normal, P5 - low, ---, chris, NEW , acquisitions_orders.t is failing randomly
14:45:08 <Joubu> bug 25514
14:45:09 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25514 normal, P5 - low, ---, chris, NEW , REST/Plugin/Objects.t is failing randomly
14:45:17 <Joubu> bug 25538 (this is a new one)
14:45:19 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25538 normal, P5 - low, ---, chris, NEW , www/search_utf8.t is failing randomly
14:45:25 <Joubu> bug 25540
14:45:27 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25540 normal, P5 - low, ---, chris, NEW , Biblio.t is failing randomly
14:45:57 <Joubu> there are few others, but those 5 need to be fixed. Or at least know why they are failing
14:46:00 <ashimema> thanks for grouping those Joubu
14:46:41 <Joubu> anyone volunteering?
14:47:06 <ashimema> I have been trying to get to them this week but would also appreciate more hands on them
14:47:15 <kohaputti> I'm having my eyes on them right now but no guarantees I will find the cause either
14:47:26 <ashimema> the items api one for example has exhausted my brain already
14:47:41 <Joubu> I have let ideas/tracks on some them
14:47:56 <talljoy> kidclamp and i looked as well at that one and couldn't make any headway this morning
14:48:42 <Joubu> there is something weird about it, it fails with a "Inactivity timeout" error
14:48:52 <Joubu> that I can recreate locally
14:49:13 <Joubu> also, I noticed that the GET route for items retrieve *all* the item
14:49:14 <Joubu> s
14:49:22 <Joubu> without pagination, and I am wondering if this is expected
14:49:50 <Joubu> the tests say it is, but it means that if you GET 6 times the route, then the server.... explode?
14:50:33 <Joubu> the CPU of my laptop almost burns and never end, had to hard reboot
14:50:46 <kohaputti> Joubu, the failure for bug 25540 says "# Looks like you planned 29 tests but ran 31." so something going on with that
14:50:47 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25540 normal, P5 - low, ---, chris, NEW , Biblio.t is failing randomly
14:50:48 <ashimema> yeah.. I did feel it should be paged by default
14:51:27 <ashimema> shall we drawer the meeting to a close and then work through these bugs as a group
14:51:27 <Joubu> kohaputti: because it stopped before all tests run
14:52:16 <Joubu> I am avaible if any of you want to work on them
14:52:22 <Joubu> alone I am stuck
14:52:23 <kohaputti> huh, it says "planned 29". And then it runs more than that
14:53:00 <Joubu> kohaputti: ok, let's talk about it after the meeting.
14:53:03 <kohaputti> yes
14:53:21 <Joubu> #info  Review of coding guidelines
14:53:35 <Joubu> #topic  Review of coding guidelines
14:53:41 <Joubu> "FYI - Terminology addition (from 7 May 2020 documentation meeting): Spell & in full unless part of a proper noun or common abbreviation, for example: Notices and slips, not Notices & slips; Baker & Taylor. "
14:53:47 <Joubu> no idea what's that
14:54:39 <oleonard_> When we're adding a label to something we should spell out "and" and avoid the use of "&"
14:54:54 <ashimema> sounds sensible enough to me..
14:54:56 <cait> docs team working towards more consistency - I like it
14:55:04 <oleonard_> Unless it's the name of something like "Baker & Taylor"
14:55:09 <cait> also going to file a ton of bugs where I found inconsistencies when translating - beware!
14:55:18 <cait> but waiting for after release, can't fix them now anyway because of translations
14:55:21 <davidnind> thanks oleonard!
14:55:37 <ashimema> and 'Baker & Taylor.' is a noun as a whole so the & is OK there
14:55:59 <Joubu> #agreed Use "and" instead of "&" w
14:56:47 <Joubu> is the "agreed" enough?
14:57:14 <ashimema> should be :)
14:57:34 <cait> it's explained nicely on the wiki
14:58:08 <Joubu> #topic Set time of next meeting
14:58:30 <Joubu> #info Next meeting: 3 June 2020, 20 UTC
14:58:31 <Joubu> that?
14:58:31 <wahanui> it has been said that that is how it works now
14:58:43 <ashimema> works for me
14:58:50 <ashimema> oh fearless new RM
14:59:09 <Joubu> #endmeeting