#koha: Development IRC meeting 29 January 2020

Meeting started by ashimema at 14:00:50 UTC (full logs).

Meeting summary

    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_29_January_2020 Agenda (ashimema, 14:00:57)

  1. Introductions (ashimema, 14:01:03)
    1. please use "#info" in front of your introduction to have it show up in the automatic minutes (ashimema, 14:01:12)
    2. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 14:01:13)
    3. Marcel de Rooy Rijksmuseum (marcelr, 14:01:22)
    4. Martin Renvoize, PTFS Europe (ashimema, 14:01:26)
    5. Thomas Dukleth, Agogme, New York City (thd, 14:02:09)
    6. Jonathan Druart (Joubu, 14:02:26)
    7. Tomas Cohen Arazi, Theke Solutions (tcohen, 14:02:53)
    8. Nick Clemens, ByWater Solutions (kidclamp, 14:02:54)
    9. Joonas Kylmälä (kohaputti, 14:02:56)
    10. Katrin Fischer, BSZ, Germany (cait, 14:03:44)

  2. Announcements (ashimema, 14:04:59)
    1. GBSD rescheduled for the 14th February (ashimema, 14:10:56)
    2. Fridolin will be taking a break from Koha for a few months. He wishes us all the best and will be back :) (ashimema, 14:11:31)

  3. Update from the RM (ashimema, 14:11:52)
    1. The master branch is moving along nicely at the moment with lots having been pushed over the past couple of weeks. Thanks go out the QA team who are diligently working through bugs. (ashimema, 14:12:54)
    2. I am paying close attention to some of the refactoring bugs that are currently making their way through SO/QA and I look forward to pushing them soon. (ashimema, 14:13:37)

  4. Updates from the RMaints (ashimema, 14:13:43)
    1. 19.11.02, 19.05.07 and 18.11.13 were all released since the last meeting (ashimema, 14:16:43)

  5. Updates from the QA team (ashimema, 14:17:29)
    1. Queues are super full - please all balance your patch writing with sign-offs and QA a bit more! (cait, 14:18:16)
    2. Stilll over 100 major and critical - we need people working on those, retesting, confirming, fixing etc. (cait, 14:19:34)

  6. General development discussion (ashimema, 14:27:45)
  7. RFC /subscriptions endpoint (ashimema, 14:28:56)
    1. https://wiki.koha-community.org/wiki/Subscriptions_endpoint_RFC /subscriptions (ashimema, 14:29:11)
    2. There are stll allot of blanks in the mappings table, so rather than vote this week I suggest we all try to find time to take a look at it before the next meeting and help fill in those fields. (ashimema, 14:30:02)

  8. RFC /suggestions endpoint (ashimema, 14:31:11)
    1. votes are not holding up development and as such will be postponed untill we have written clear guidlines for the contentious field names (date vs date and timestamp vs date consistency) (ashimema, 15:03:21)

  9. Moving on with Bug 22407 (ashimema, 15:03:34)
    1. We will clarify the wording of PERL15 (perhaps even splitting it out into it's own guidline) for Koha::Object relationships (ashimema, 15:13:23)

  10. Review of coding guidelines (ashimema, 15:13:30)
  11. PERL27: Return values consistency. If a method returns a list, and there are no items, it should return [] (empty list). If it is a scalar, undef. (ashimema, 15:13:49)
  12. Reinforce good commit messages guideline (ashimema, 15:23:37)
    1. https://wiki.koha-community.org/wiki/Commit_messages#Examples Guidline (ashimema, 15:23:48)
    2. ACTION: Joubu will send an email to the list to remind devs about good/bad commit messages (Joubu, 15:28:56)

  13. Set time of next meeting (ashimema, 15:40:12)
    1. Next meeting: 5 February 2020, 20 UTC (ashimema, 15:48:21)


Meeting ended at 15:48:41 UTC (full logs).

Action items

  1. Joubu will send an email to the list to remind devs about good/bad commit messages


Action items, by person

  1. Joubu
    1. Joubu will send an email to the list to remind devs about good/bad commit messages


People present (lines said)

  1. ashimema (130)
  2. marcelr (84)
  3. cait (78)
  4. Joubu (70)
  5. tcohen (33)
  6. kohaputti (29)
  7. thd (17)
  8. fridolin (6)
  9. wahanui (4)
  10. oleonard (4)
  11. huginn (4)
  12. kidclamp (2)


Generated by MeetBot 0.1.4.