20:04:36 <ashimema> #startmeeting Development IRC meeting 3 June 2020
20:04:36 <huginn> Meeting started Wed Jun 3 20:04:36 2020 UTC. The chair is ashimema. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:04:36 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:04:36 <huginn> The meeting name has been set to 'development_irc_meeting_3_june_2020'
20:04:39 <cait> #info Katrin Fischer, BSZ, Germany
20:04:48 <ashimema> #chair cait
20:04:48 <huginn> Current chairs: ashimema cait
20:04:49 <ashimema> #chair tcohen
20:04:49 <huginn> Current chairs: ashimema cait tcohen
20:04:50 <ashimema> #chair tuxayo
20:04:50 <huginn> Current chairs: ashimema cait tcohen tuxayo
20:04:57 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
20:04:57 <magnuse> #info Magnus Enger, Libriotech, Norway
20:04:58 <enkidu> #info Mengü Yazıcıoğlu, Devinim, Turkey
20:05:07 <tuxayo> XD
20:05:09 <ashimema> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_3_June_2020 Agenda
20:05:14 <ashimema> #topic Introductions
20:05:19 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
20:05:24 <ashimema> Please use #info to introduce yourselves
20:05:25 <davidnind> #info David Nind, Wellington, New Zealand
20:05:27 <rangi> #info Chris Cormack, Catalyst iT
20:05:27 * magnuse relizes who enkidu is and waves in his direction
20:05:36 <ashimema> #info Martin Renvoize, PTFS-Europe, UK
20:05:40 <tuxayo> #info tuxayo/Victor Grousset, France
20:05:43 <wizzyrea> #info Liz Rea
20:05:58 <ashimema> ooh.. hi enkidu, nice to see you here :)
20:06:00 <enkidu> magnuse :)
20:06:06 <enkidu> Hi all
20:06:11 <tcohen> hi enkidu
20:06:25 * magnuse watches nz crimes on television - "brokenwood mysteries" or something like that
20:07:07 <ashimema> #topic Announcements
20:07:25 <tcohen> I have an announcement on behalf of Joubu
20:07:43 <ashimema> #info The 20.05 release happened, just in time to get into May.. delays were caused by some hurdles to get over with packaging.
20:08:10 <tuxayo> (announcement about the IPA stocks?)
20:08:20 <tcohen> [off] #info Joubu quit beer
20:08:25 <ashimema> #info Packages should be available very soon, transfering them from the staging repository to live is in progress.
20:08:47 <cait> mtj++ :)
20:08:49 <tcohen> mtj++
20:08:50 <enkidu> Oh no, Joubu without a beer ?
20:09:01 <tuxayo> mtj++
20:09:09 <magnuse> mtj++
20:09:13 <ashimema> anyone else got any announcements..
20:09:16 <tcohen> yes
20:09:16 <enkidu> mtj++
20:09:17 <cait> enkidu: just rumours
20:09:17 <ashimema> mtj++
20:09:38 <enkidu> cait: Oh nice ! I miss the Kohacon days.
20:09:40 <tcohen> We forked koha-gitify into the community Gitlan
20:09:47 <tcohen> Gitlab
20:10:15 <ashimema> :)
20:10:28 <tcohen> and KTD now points there
20:10:33 <ashimema> #info koha-gitify has been forked into the koha-community gitlab organisation
20:10:44 <tuxayo> tcohen: it was another in koha's git server before?
20:10:46 <tcohen> community++
20:10:58 <tcohen> it was in a personal github repo
20:11:02 <tuxayo> *was it in koha's git server
20:11:03 <tuxayo> ok
20:11:09 <ashimema> #info koha-testing-docker now utilises the community maintained version hosted on gitlab
20:11:16 <tcohen> it was the only stack piece we didn't, as community, control
20:11:26 <tuxayo> Nice!
20:11:28 <ashimema> it was on githbub if i recall correctly tuxayo
20:11:46 <tuxayo> anyone else got any announcements, or rumours?
20:11:51 <ashimema> not sure how well maintained if has been.. I vaguely recollect the original maintainers have moved on to other pastures?
20:12:23 <tcohen> ashimema that's correct, but have to say anytime we needed anything, our PR were always accepted promptly
20:12:42 <ashimema> good to know
20:13:05 <tcohen> chris hall?
20:13:24 <tcohen> https://github.com/chrisosaurus/koha-gitify
20:13:42 <ashimema> #info Many thanks should be passed to the original maintainers of koha-gitify and their diligent eforts keeping it up to date when pull requests were submitted :)
20:13:44 <rangi> yeah he works for google now
20:13:52 <ashimema> nice
20:14:05 <cait> chris_hall++ :)
20:14:15 <tcohen> chris_hall++
20:14:46 <enkidu> chris_hall++
20:14:59 <tuxayo> chris_hall++
20:14:59 <tuxayo> & ++ to other maints
20:15:38 <cait> as someoen who started out with a classic git installation... things are so much better these days i can tell you :)
20:15:56 <tcohen> community++
20:15:58 <oleonard> Definitely
20:16:04 <wizzyrea> gitify was a fantastic evolution
20:16:13 <tcohen> it was the trampolin
20:16:23 <cait> :)
20:16:37 <tcohen> filling the gap between deb installs and our dev environments
20:16:45 <tcohen> then kohadevbox, then KTD
20:16:52 <tcohen> all relying on koha-gitify
20:17:03 * ashimema actually still uses a classic git install allot for dev
20:17:08 <magnuse> chris_hall++
20:17:09 <ashimema> but also leans on k-t-d
20:17:28 <wizzyrea> (same person, not to get off track, also facilitated the change from the old templating system to template toolkit)
20:17:39 * magnuse needs to get into ktd
20:17:40 <cait> I'll wait with ktd until tomas can show me in person again ;)
20:18:01 <tcohen> I'll buy the tickets as soon as they allow me to, cait
20:18:02 <magnuse> ooh, good plan, cait
20:18:10 <cait> :)
20:18:14 <wizzyrea> ktd has really improved
20:18:21 <wizzyrea> docker itself, has really improved.
20:18:36 <ashimema> right.. shall we move on
20:18:40 <tcohen> speaking of which
20:18:42 <tcohen> exaclty
20:18:51 <ashimema> #topic Update from the Release manager
20:19:01 <ashimema> er.. RM is MIA ;)
20:19:17 <tcohen> #info Joubu brewed 20L of IPA, don't count on him for the rest of the week
20:19:20 <wizzyrea> he said he agreed with whatever you decided
20:19:58 <tuxayo> Yes, we can do whatever we want! :D
20:19:59 <ashimema> #info Jonthan is missing this evening, but expressed he has great trust in the team around him
20:20:01 <ashimema> lol
20:20:08 <tcohen> LOL
20:20:16 <tcohen> I like british formality
20:20:27 <ashimema> hehe
20:20:30 <cait> hm we could discuss the koha release naming again :P
20:20:30 <enkidu> :)
20:20:49 <ashimema> I like minutes to look half professional
20:20:53 <tcohen> montypython++
20:21:12 <ashimema> I as very dissapointed to see the first commit this cycle
20:21:26 <ashimema> sooo boring
20:21:48 <ashimema> #topic Updates from the Release Maintainers
20:21:52 <ashimema> rmaints?
20:21:52 <wahanui> rmaints is talljoy, lukeG, hayley
20:22:02 <tuxayo> Not anymore!
20:22:16 <ashimema> no, rmaints is lukeG, aleisha, tuxayo
20:22:30 <tuxayo> > the first commit this cycle
20:22:33 <tuxayo> The one who says «All our codebase are belong to everybody» ?
20:22:43 * oleonard liked that one
20:22:44 <ashimema> rmaints is lukeG, aleisha and tuxayo
20:22:56 * tuxayo too
20:23:13 <magnuse> rmaints?
20:23:13 <wahanui> rmaints is talljoy, lukeG, hayley
20:23:22 <wizzyrea> forget rmaints
20:23:23 <wahanui> wizzyrea: I forgot rmaints
20:23:37 <wizzyrea> rmaints is <reply> lukeG, aleisha, and tuxayo
20:23:43 <wizzyrea> rmaints?
20:23:43 <wahanui> lukeG, aleisha, and tuxayo
20:23:49 <magnuse> yay!
20:23:52 <enkidu> wizzyrea++
20:24:04 <ashimema> hmm.. maybe i missed a commit
20:24:07 <ashimema> I only see
20:24:23 <oleonard> No, make it say "lukeG, aleisha, and tuxayo, I SUMMON THEE!!"
20:24:30 <ashimema> `Koha 20.06 - start of a new dev cycle`
20:24:31 <wizzyrea> forget rmaints
20:24:31 <wahanui> wizzyrea: I forgot rmaints
20:24:38 <ashimema> lol
20:24:43 <tuxayo> #info tuxayo (for 19.05) is learning the RMaint workflow and how to interpret CI results
20:24:48 <magnuse> + NewVersion( $DBversion, undef, 'All our codebase are belong to everybody' );
20:24:53 <wizzyrea> rmaints is <reply> lukeG, aleisha, and tuxayo, I SUMMON THEE!!
20:25:02 <ashimema> haha
20:25:10 <tcohen> tuxayo we'll talk about it shortly
20:25:12 <ashimema> ah.. nice
20:25:13 <ashimema> :)
20:25:55 <ashimema> #info rmaints are all setup and ready to go.. handover complete :)
20:26:01 * magnuse needs to catch some sleep, even if the sun is high in the sky - have fun #koha!
20:26:07 <ashimema> doubt there's much more to say
20:26:14 <tcohen> enjoy magnuse
20:26:21 <enkidu> bye magnuse
20:26:24 <ashimema> #topic Updates from the QA team
20:26:26 <ashimema> cait
20:26:29 <tuxayo> found one test bug, also moved 1 step in the RMaint queue :D
20:26:55 <ashimema> :)
20:27:02 <ashimema> well done tuxayo
20:27:39 <cait> oops
20:27:46 <tcohen> I'm worried about 24986
20:27:57 <cait> Joubu said when asked: QA ALL THE THINGS!
20:28:01 * ashimema is getting temped by his bed..
20:28:02 <cait> I'd like to forward this message of our RM
20:28:10 <ashimema> :)
20:28:12 <cait> otherwise, we are stlil focusing on bugs right now
20:28:20 <ashimema> #info QA ALL THE THINGS :)
20:28:25 <cait> I was told tests had to be fixed... but I am not up to date if they have been already
20:28:39 <cait> it's been a little busy, will try to catch up soon
20:29:02 <cait> i still see a lot of yellow so i guess.. FIX ALL THE TESTS! is stlil on as well
20:29:04 <cait> thx
20:29:10 <tcohen> understood
20:29:14 <ashimema> #info bugs are priority for the first month, but there's also a few 20_11_target bugs in the queue I believe which didn't make it end of last cycle and would be nice to do early this cycle.
20:29:46 <ashimema> #info We need to get the test suits passing again...
20:29:49 <cait> we've also discussed makeing the items, biblio, biblioitems merge soon
20:30:03 <tuxayo> > We need to get the test suits passing again...
20:30:03 <tuxayo> At least they pass locally
20:30:11 <cait> as this blocks progress in functionality like showing info about deleted items and such in variou splaces
20:30:16 <ashimema> indeed.. I think that's badged up.. if it isn't already we should do so
20:30:17 <cait> cancelled records in acq
20:30:28 <tuxayo> It's not that centralized even if it's harder without CI
20:30:49 <tcohen> I'm working on jenkings
20:30:52 <tcohen> jenkins
20:30:58 <tcohen> wanted to talk about it next
20:31:05 <ashimema> #topic General development discussion (trends, ideas, ...)
20:31:09 <ashimema> all your tochen :)
20:31:28 <ashimema> #info Test suite, proper environment to test stable branches
20:31:43 <ashimema> lets do your first tcohen.. I think it's more important
20:31:46 <tcohen> The last couple weeks, we've been fighting packaging, and the OSs we support
20:32:12 <tcohen> some problematic libraries involve the API (i.e. Mojolicious, OpenAPI, YAML, etc)
20:32:32 <tcohen> making things work on all the supported Debian/Ubuntu versions
20:32:34 <tcohen> has been a pain
20:32:36 <tcohen> mtj++
20:32:49 <tuxayo> (CI for tests is like an addiction, we see the signs of lack of it quickly ^^)
20:32:54 <ashimema> mtj++
20:33:05 <tcohen> There are nasty problems with DBD::mysql (regressions)
20:33:21 <tuxayo> mtj++
20:33:21 <tuxayo> tcohen++
20:33:21 <tuxayo> The new matrix of test envs is great!
20:33:36 <ashimema> So.. is the jenkins change that we're now avoiding cpan for installing any deps
20:33:47 <tcohen> that cause some tests to fail. I consider those failures minor, as they are mostly problems with representation of floats
20:34:00 <ashimema> i.e. relying more strictly on the koha-common package pulling in all the right things?
20:34:00 <tcohen> BUT
20:34:06 <tcohen> rigt
20:34:22 <tcohen> this morning I branched KTD for 19.11
20:34:29 <tcohen> and cleaned all the things it installs
20:34:37 <tuxayo> > the jenkins change
20:34:37 <tuxayo> Only in Jenkins or in koha-testing-docker in general?
20:34:37 <ashimema> excellent
20:34:37 <wahanui> darn tootin' it is.
20:34:39 <tcohen> it will now *only* install koha-common and dependencies
20:34:48 <tcohen> and just a few cpan things required for tests
20:34:57 <tcohen> this way we can be sure about things
20:35:15 <tcohen> Joubu considered we should discuss this somehow as it is an overhead
20:35:24 <tcohen> I belive it is fairly 'light'
20:35:38 <tcohen> specially if we finish building the .deb building pipeline
20:35:41 <ashimema> i must admit I still find the control file syntax weird.. surely test-depends should be what it sounds like
20:35:44 <tcohen> and all gets automated
20:35:54 <ashimema> but that's a topic for another day..
20:36:42 <tcohen> right
20:36:47 <ashimema> I agree the .deb building pipeline is key to this.. and has been the missing element for the whole 12 months of my time as RM
20:36:51 <ashimema> well..
20:36:54 <tcohen> So, my plan is to make all the stable branches tests
20:37:00 <tcohen> run on version-spcific KTD
20:37:08 <tuxayo> great!
20:37:19 <enkidu> tcohen++
20:37:26 <tcohen> so 19.11 will be run against koha/koha-testing:19.11-stretch
20:37:28 <ashimema> the full pipeline has always been missing.. but during my tenure with the loss of mirko we lost an important part of it which was working
20:37:44 <tcohen> and I'd say rmaints should do their job probably on that images as well
20:37:45 <ashimema> tcohen++
20:38:13 <ashimema> what do you mean by rmaints do their job properly on those images?
20:38:21 <tcohen> once the packages for 20.05 arrive I'll branch KTD for that as well
20:38:28 <tuxayo> > and I'd say rmaints should do their job probably on that images as well
20:38:28 <tuxayo> Good, that's how I understood it.
20:38:30 <ashimema> watch the debian.control bugs and ensure they test and push patches that land there
20:38:40 <tcohen> rmaints: ask me whatever you need about jenkins or the pipelines we are setting
20:38:48 <tcohen> and ask me the changes you want
20:38:55 <tcohen> (for example, if you want to test on another OS)
20:39:42 <tuxayo> > (for example, if you want to test on another OS)
20:39:43 <tuxayo> are there missing OSes that we support?
20:39:50 <enkidu> another OS? Do we have so much people to work on?
20:40:17 <tuxayo> Or maybe you mean like OS+the DBMS
20:40:54 * ashimema thinks we're now well covered for combinations really
20:41:02 <tcohen> I'm talking about debianderivative like Ubuntu
20:41:06 <tcohen> or newer Debian
20:41:14 <tcohen> but if you want to set another OS
20:41:22 <tcohen> I could guide or help if needed
20:41:27 <ashimema> we could in theory test a few more combinations.. but I'm not entirely sure we need to
20:41:49 <ashimema> having said that.. we do know the DBD versions can make a difference.. so perhaps we should be.
20:42:00 <tcohen> we should
20:42:04 <tuxayo> I was thinking the stable branches might need MariaDB testing.
20:42:06 <tuxayo> But maybe the angle should be: should MySQL remain the default DBMS?
20:42:28 <tuxayo> > we do know the DBD versions can make a difference
20:42:28 <tuxayo> What do you mean?
20:42:46 <tcohen> https://github.com/perl5-dbi/DBD-mysql/issues/212
20:42:50 * ashimema opened a bug asking for DB versions in HEA to help asses this
20:42:59 <ashimema> it got mostly shot down
20:43:24 <rangi> i think if it was just major version number
20:43:27 <rangi> thats ok
20:43:39 <rangi> 5.5 not 5.5.10~dsfg etc
20:43:39 <tcohen> I found a bug on DBD::mysql, that got fixed in v4.042
20:43:45 <tuxayo> I wanted to try to move this bug forward. It didn't seemed blocked.
20:43:58 <tuxayo> (bug about HEA & DBMS)
20:44:16 <tcohen> and people find the fix got reverted in a few newer versions
20:44:21 <tcohen> (Buster's, for example)
20:44:31 <ashimema> lets ove it forward tuxayo.. I have more time for things like that now
20:44:38 <ashimema> only so many battles I could fight as RM
20:45:15 <ashimema> sounds sane to me rangi.. and all we really need I think
20:45:20 <rangi> yep
20:45:50 <ashimema> ooh.. rangi.. did you see I added a followup pull request on dashboard..
20:45:52 <tuxayo> > 5.5 not 5.5.10~dsfg etc
20:45:52 <tuxayo> That was the next step for me. Try to find a reliable way to parse at least MySQL and MariaDB version strings.
20:45:58 <rangi> ashimema: yep merged and deployed
20:46:08 <ashimema> awesome, thanks
20:46:15 <ashimema> apologies for messing up :(
20:47:10 <rangi> no worries
20:47:10 <tcohen> #info rmaints contact tcohen about jenkins and environments their branches should be tested against
20:48:42 * ashimema is really happy to see Jenkins growing so much... it really improved last couple of cycle and the trend is only getting better :)
20:49:19 <ashimema> shall we move on tcohen?
20:49:27 <tcohen> yes
20:49:42 <ashimema> #info Can we/Should we deprecate MySQL 5.5 support?
20:49:56 <tcohen> yes please
20:49:57 <tcohen> haha
20:50:07 <ashimema> we have a few challenges to overcome if we want to continue to support it
20:50:14 <tcohen> dcook could argue if he has some old RHEL
20:50:17 <ashimema> bug 10517 for instance
20:50:19 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10517 normal, P5 - low, ---, rudolfbyker, Needs Signoff , koha-restore fails to create mysqluser@mysql_hostname so zebra update fails
20:50:19 <tuxayo> Which OS has it by default?
20:50:22 <ashimema> but I'm sure there are some others
20:50:43 <ashimema> D8 did, D9 does if you upgraded from D8 I believe
20:51:23 <enkidu> do we have some statistics about OS and DB versions around the world?
20:51:27 <tuxayo> Is D8 deprecated? For 20.11
20:51:37 <ashimema> I found some case where you could certainly end up with it on D9 without really trying to.. when upset me.
20:51:40 <tcohen> it is EOL
20:51:49 <ashimema> D8 is deprecated already
20:52:11 <ashimema> crap.. I forgot to add specific mention of that in the release notes
20:52:22 <ashimema> 20.05 supports it, but not deliberately..
20:52:23 <tcohen> https://wiki.debian.org/DebianReleases
20:52:38 <tcohen> it seems stretch is EOL soon LOL
20:52:50 <tcohen> everybody should switch to Ubuntu 20.04 hahaha
20:53:04 <ashimema> the idea is to formally drop D8 support ith 20.05.00, 19.05.12, 18.11.06 (i.e. the set of releases that just happened)
20:53:34 <ashimema> but.. we could do it with the next set of point releases.. which will actually correspond to when D8 is officially dropped by Debian themselves
20:53:36 <tuxayo> > I found some case where you could certainly end up with it on D9 without really trying to
20:53:39 <tuxayo> Sound reasonable to ask for a migration to MariaDB or a latter MySQL version.
20:54:12 <tcohen> what is the mysql 5.5 correspondent mariadb version?
20:54:44 <ashimema> 5.5 I think
20:55:25 <enkidu> 5.5, Mysql5.6 is MariaDB 10.0 I remember
20:55:34 <wizzyrea> ^ that's right
20:55:41 <tcohen> stretch ships 10.1
20:55:42 <ashimema> personally.. I think we should bump to minimum of MariaDB 10.1
20:56:02 <ashimema> that's the default if you install from fresh in D9..
20:56:07 <wizzyrea> it is
20:56:32 <tcohen> and MySQL 5.7
20:56:40 <ashimema> pretty sure you only get mysql5.5 if you upgraded from D8 or explicitly ask for MySQL instead of MariaDB
20:56:54 <ashimema> indeed
20:57:21 <tcohen> lets vote for deprecation
20:57:30 <tuxayo> Is MariaDB 10.1 == MySQL 5.7 ?
20:57:30 <tuxayo> Are there know limitations that the MySQL side would cause?
20:57:34 <ashimema> ++
20:57:40 <enkidu> 5.7 -> 10.2
20:57:56 <tuxayo> great!
20:58:21 <tuxayo> Anyone has an info or argument before voting?
20:59:05 <ashimema> these days you have to jump through some hoops to install MySQL if you really want it.. all distros I've worked with of late use MariaDB even if you install the mysql-server package it's just a symlink
21:00:21 <tuxayo> Thanks, I had this impression also
21:00:45 <ashimema> #startvote Should we officially deprecate MySQL5.5 support (upping minimum SQL versions to MariaDB 10.1/MySQL 5.7? Yes, No, Abstain
21:00:45 <huginn> Begin voting on: Should we officially deprecate MySQL5.5 support (upping minimum SQL versions to MariaDB 10.1/MySQL 5.7? Valid vote options are Yes, No, Abstain.
21:00:45 <huginn> Vote using '#vote OPTION'. Only your last vote counts.
21:01:02 <tcohen> #vote Yes
21:01:13 <enkidu> #vote Yes
21:01:14 <ashimema> #vote Yes
21:01:16 <tuxayo> #vote yes
21:01:57 <tuxayo> For with Koha version BTW?
21:01:58 <tuxayo> *Which
21:02:10 <davidnind> #vote Yes
21:02:15 <wizzyrea> #vote Yes
21:02:16 <tcohen> onwards
21:02:21 <tcohen> 20.11
21:02:22 <tuxayo> Like for Debian ("retroactive drop") or less strict
21:02:30 <tuxayo> Thanks tcohen
21:03:07 <ashimema> I would say probably retroactive (to keep your tasks as rmaints simple)
21:03:42 <ashimema> people should really be upgrading debian at this point and as part of that expecting/requirement them to upgrade mysql doesn't seem terrible to me..
21:03:52 <tcohen> We are not taking advantage of Joubu's absense laissez-faire message
21:04:02 <ashimema> but.. Im happy to be overruled on that one.. i's not a process I've had to do much of..
21:04:19 <wizzyrea> jessie goes out of support Very Soon Now
21:04:19 <ashimema> we could do with a sysops view on that
21:04:23 <tuxayo> > as part of that expecting/requirement them to upgrade mysql doesn't seem terrible to me..
21:04:23 <tuxayo> ++
21:04:42 <ashimema> any more for any more..
21:04:45 <ashimema> 3
21:04:52 <ashimema> 2
21:04:53 <ashimema> 1
21:04:54 <tcohen> deprecating Debian 8
21:04:54 <ashimema> .
21:04:58 <tcohen> implies somehow
21:04:59 <ashimema> #endvote
21:04:59 <huginn> Voted on "Should we officially deprecate MySQL5.5 support (upping minimum SQL versions to MariaDB 10.1/MySQL 5.7?" Results are
21:04:59 <huginn> Yes (6): davidnind, wizzyrea, ashimema, tuxayo, tcohen, enkidu
21:05:08 <ashimema> excellent
21:05:08 <wahanui> darn tootin' it is.
21:05:32 <ashimema> any more general topics chaps?
21:05:35 <ashimema> or shall we move on
21:05:39 <tuxayo> Where should/are these things (Debian, DBMS support) documented?
21:06:29 <tuxayo> > any more general topics chaps?
21:06:29 <tuxayo> Can we have MariaDB by default in dev&test environment then?
21:06:36 <ashimema> wiki pages somewhere.. the website on the install details page and in every release note
21:06:40 <tcohen> #info Joubu volunteers to announce MySQL 5.5 deprecation
21:06:45 <ashimema> perhaps the coding guidelines too
21:06:54 <ashimema> nice touch tochen
21:06:57 <ashimema> tcohen.. even
21:07:01 <tuxayo> > Joubu volunteers
21:07:01 <tuxayo> he he
21:07:15 <davidnind> I will update the section in the manual
21:07:25 <ashimema> thanks davidnind
21:07:34 <tcohen> Joubu is quietly preparing to FQA my patches, for sure
21:07:45 <ashimema> #action davidnind will update the manual with new minimum requirements updates
21:07:56 <ashimema> #topic Review of coding guidelines
21:08:07 <ashimema> i don't believe there's anything to review
21:08:09 <ashimema> so...
21:08:15 <tcohen> right
21:08:25 <ashimema> #topic Set time of next meeting
21:08:32 <tcohen> should we file a bug for KTD to default to other DB version then?
21:08:36 <tuxayo> davidnind: great, there is a section in the manual :D
21:08:40 <tcohen> nevermind
21:08:55 <tuxayo> > should we file a bug for KTD to default to other DB version then?
21:08:55 <tuxayo> Ok, I can do that
21:09:08 <ashimema> deffo tcohen
21:09:23 <tcohen> I'd say each OS it's shipped version
21:09:29 <tcohen> and MySQL 8
21:09:33 * ashimema is bowing out.. brain is fading fast now
21:09:35 <tcohen> as we do already
21:09:40 <tcohen> go to bed!
21:09:46 <ashimema> agreed tcohen
21:09:53 <tuxayo> > I'd say each OS it's shipped version
21:09:53 <tuxayo> Yes, I was thinking about that.
21:11:25 <tuxayo> > and MySQL 8
21:11:25 <tuxayo> So every matching MariaDB by default + an optional way to have MySQL 8 to offer a cutting edge option.
21:11:36 <tcohen> right
21:11:38 <tcohen> ashimema
21:11:38 <wahanui> it has been said that ashimema is literally just writing up the release anouncement ;)
21:11:38 <tuxayo> Like with ES 7
21:11:41 <tuxayo> Good
21:11:44 <tcohen> yup
21:11:48 <tcohen> time for next meeting
21:12:09 <tuxayo> June 17th?
21:12:42 <ashimema> general meeting is on 17th too
21:13:10 <ashimema> how did we end up conflicting again
21:13:18 <ashimema> mwah
21:13:35 <ashimema> it's a 3pm.. we could do 2 and force ourselves to finish on time
21:13:47 <ashimema> or follow the general meeting
21:13:50 <ashimema> or change day
21:13:50 <wahanui> ashimema: that doesn't look right
21:14:02 <tuxayo> > how did we end up conflicting again
21:14:02 <tuxayo> Months are a bit more than 4.0 weeks
21:14:11 <ashimema> indeed
21:14:22 <tcohen> same day, another time?
21:15:39 <tuxayo> Do people usually manage to have 2 meeting in the same day?
21:15:57 <tuxayo> without having trouble fitting them with the rest.
21:16:00 <tcohen> 3 or 4
21:16:14 <tcohen> I'd say same day another time
21:16:17 <tcohen> and make them fit
21:17:40 <tuxayo> ok, so one hour before the general meeting?
21:19:23 <ashimema> 13 or 15 UTC.. which is 14 or 16 UK, 10 or 12 BA,
21:19:40 <ashimema> 13 works for me..
21:20:08 <ashimema> I think that fit more timezones (except Wellington.. sorry rangi, davidnind)
21:21:16 <ashimema> #info Next meeting: 17 June 2020, 13 UTC
21:21:18 <ashimema> #endmeeting