20:00:28 <ashimema> #startmeeting Development IRC meeting 5 February 2020
20:00:28 <huginn> Meeting started Wed Feb  5 20:00:28 2020 UTC.  The chair is ashimema. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:28 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:28 <huginn> The meeting name has been set to 'development_irc_meeting_5_february_2020'
20:00:38 <ashimema> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_5_February_2020#Agenda Agenda
20:00:59 <ashimema> #topic Introductions
20:01:06 <ashimema> please use "#info" in front of your introduction to have it show up in the automatic minutes
20:01:14 <ashimema> #info Martin Renvoize, PTFS Europe, UK
20:01:29 <JesseM> #info Jesse Maseto, BWS, USA
20:01:51 <davidnind> #info David Nind, New Zealand
20:01:55 <lisettelatah> #info Lisette Scheer, Latah County Library District, USA
20:02:06 <josef_moravec> #info Josef Moravec
20:02:19 <wizzyrea> #info Liz Rea
20:02:21 <khall> #info Kyle M Hall, ByWater Solutions
20:02:44 <ashimema> #topic Announcements
20:03:07 <ashimema> #info  GBSD 14th February, Valentine's Edition
20:03:45 <ashimema> #link https://wiki.koha-community.org/wiki/2020-02-14_Global_bug_squashing_day GBSD Details
20:04:07 <ashimema> Lets get that majors queue under 100! :)
20:04:20 <ashimema> anyone else want to announce anything?
20:04:51 <JesseM> ByWater Solutions will be hosting a YouTube Live Session on Friday, February 14th from 11:00 am EST to 1:00 pm EST where we will SQUASH SOME BUGS!!!! Join in, chat with us and ask questions!!
20:04:51 <JesseM> Join us at: https://www.youtube.com/user/bywatersolutions/live
20:05:15 <ashimema> awesome, bywater++
20:05:56 <ashimema> #info ByWater Solutions will be hosting a YouTube Live Session on Friday 14th from 11am EST to 1pm EST in support of GBSD
20:06:09 <JesseM> Going to be a good time squashing bugs
20:06:16 <ashimema> #link https://www.youtube.com/user/bywatersolutions/live Join in
20:06:22 <ashimema> hat's awesome guys, thanks :)
20:06:28 <bag> #info brendan bywater
20:06:39 <ashimema> bywater++
20:07:31 <ashimema> #topic Update from the Release Team
20:07:38 <ashimema> Squashing the updates into one short section to save on time ;)
20:08:05 <ashimema> #info Release is moving along nicely, lots of bugfixes and enhancements getting pushed.. Thanks everyone for the consistent level of SO and QA.
20:09:38 <ashimema> #info Bug 18936 - Circulation Rules Ratification has been pushed, thanks to all involved, and sorry for the rebases it may have created for people.. its a big step in the right direction for koha's codebase modernisation and maintainability wise.
20:09:38 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18936 enhancement, P5 - low, ---, jonathan.druart, Pushed to master , Convert issuingrules fields to circulation_rules
20:10:14 <ashimema> #topic General development discussion (trends, ideas, ...)
20:10:41 <ashimema> #info Deprecate/remove QueryParser (see Bug 12742)
20:10:41 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12742 enhancement, P5 - low, ---, gmcharlt, NEW , Omnibus: QueryParser
20:11:22 <ashimema> this one was from cait, but I think a few of us have been thinking about it for a while..
20:11:34 <ashimema> should we start the process of stripping out QueryParser code..
20:11:39 <ashimema> at this point I don't know anyone using it.. but that doesn't mean nobody is..
20:11:46 <ashimema> less code to maintain and all that...
20:12:53 <ashimema> bywater.. do you have any partners using queryparser?
20:13:35 <wizzyrea> i'm not sure we'd know - how would we tell? (sorry if that's a dumb question)
20:13:39 <josef_moravec> Hea says only 5 of roughly 2300 instances uses it
20:14:14 <wizzyrea> what problems would it have solved?
20:14:15 <ashimema> not sure how accurate hea is.. but it shows a trend at the very least
20:14:20 <ashimema> #link https://hea.koha-community.org/systempreferences HEA stats
20:14:39 <wizzyrea> it's off by default yeah?
20:15:00 <ashimema> I believe the idea was that it was a re-write/cleanup of the searching logic in generall.. but starting with the idea of sharing the search query parsing logic from evergreen..
20:15:27 <ashimema> but.. I don't think it ever fully worked and reached critical mass
20:15:51 <ashimema> if it was going to be re-invigorated I feel it was have been with the coming of ES code..
20:15:58 <ashimema> but that went a very different route
20:16:14 <ashimema> it if inded disabled by default
20:16:33 <josef_moravec> it is disabled by default
20:16:40 <ashimema> it is indeed disabled by default.. even
20:17:36 * ashimema would rather see the effort put into making ES great than try and maintain 3 sets of search code
20:17:50 <ashimema> we can save a vote for next meeting.. but worth raising to get people thinking about it..
20:18:19 <ashimema> #action Add vote for QueryParser removal to next meeting agenda
20:18:39 <ashimema> moving on
20:18:47 <ashimema> #topic Review of coding guidelines
20:19:09 <ashimema> #info Vote for SWAGGER1.3.4: mapping
20:19:47 <ashimema> #link https://wiki.koha-community.org/wiki/Coding_Guidelines_-_API#SWAGGER1.3.4:mapping-_DRAFT Guideline
20:20:46 <ashimema> So, as discussed at the last meeting we wanted to add some guidelines around api field mappings to help lower the debate around them during votes.
20:21:09 <ashimema> I've drafted the above and run them past tcohen and a few other interested parties..
20:21:52 <ashimema> I suggest taking a vote on the first two guidelines and leaving the third to another time as that's still in discussion whilst we work through the embed technicalities.
20:22:05 <ashimema> do we have enough people here to take a vote?
20:23:23 <josef_moravec> we are 7 or 8 according to info...
20:23:34 <ashimema> indeed
20:23:43 <JesseM> How many do we need?
20:23:52 * ashimema works on the vote question for a second..
20:24:15 <ashimema> I think we're corate enough.. i was testing that people are still out there as much as anything ;)
20:25:23 <ashimema> #startvote Do you agree with adding the proposed new coding guideline as phrased (First 2 points only)? Yes, No, Abstain
20:25:23 <huginn> Begin voting on: Do you agree with adding the proposed new coding guideline as phrased (First 2 points only)? Valid vote options are Yes, No, Abstain.
20:25:23 <huginn> Vote using '#vote OPTION'. Only your last vote counts.
20:25:38 <ashimema> #vote Yes
20:25:50 <josef_moravec> #vote Yes
20:25:52 <lisettelatah> #vote Yes
20:26:00 <davidnind> #vote Yes
20:26:00 <JesseM> #vote Yes
20:26:33 <khall> #vote Yes
20:27:35 <ashimema> last calls...
20:28:20 <ashimema> #endvote
20:28:20 <huginn> Voted on "Do you agree with adding the proposed new coding guideline as phrased (First 2 points only)?" Results are
20:28:20 <huginn> Yes (6): davidnind, josef_moravec, lisettelatah, ashimema, khall, JesseM
20:28:59 <ashimema> excellent.. hopefully that'll help lower the cahnces of getting stuck in planning blight :)
20:29:15 <josef_moravec> ashimema++
20:29:30 <ashimema> #topic Set date and time for next meeting
20:29:49 <ashimema> I'm suggesting 19 February 2020, 14 UTC
20:29:54 <ashimema> fits the patturn
20:30:10 <ashimema> back to the early slot
20:30:18 <ashimema> any objections?
20:31:23 <ashimema> #info Next meeting: 19 February 2020, 14 UTC
20:31:26 <ashimema> #endmeeting