19:10:58 <tcohen> #startmeeting Development IRC meeting 6 May 2020
19:10:58 <huginn> Meeting started Wed May  6 19:10:58 2020 UTC.  The chair is tcohen. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:10:58 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:10:58 <huginn> The meeting name has been set to 'development_irc_meeting_6_may_2020'
19:11:03 <cait> ah :)
19:11:12 <cait> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_6_May_2020 Agenda
19:11:12 <tcohen> #topc Introductions
19:11:31 <cait> #info Katrin Fischer, BSZ, Germany
19:11:33 <tcohen> #info Tomas Cohen Arazi, Javier and Manuel's father
19:11:33 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
19:11:44 <tuxayo> #topic Introductions
19:12:05 <davidnind> #info David Nind, Wlelington, New Zealand
19:12:13 <tuxayo> #info tuxayo/Victor Grousset, France
19:12:18 <tcohen> #chair tuxayo
19:12:18 <huginn> Current chairs: tcohen tuxayo
19:12:27 <tcohen> do not overlap
19:12:28 <tuxayo> whaaaat
19:12:30 <thd> #info Thomas Dukleth, Agogme, New York City [still world virus capital]
19:12:34 <tcohen> but if you want to do it, be my guest
19:12:40 <tuxayo> I just wanted to fix a typo >_<
19:12:51 <tcohen> ah
19:12:54 <tcohen> haha
19:13:23 <cait> oops
19:13:37 <tuxayo> topc→topic. Maybe it was not a big deal. Anyways ^^"
19:13:38 <tcohen> #topic Introductions
19:13:53 <tcohen> You don't need to introduce yourself again
19:14:11 <tcohen> #topic Announcements
19:14:16 <cait> tuxayo: only chairs can set topics
19:14:29 <tcohen> Anyone has any announcement to make?
19:14:48 <cait> #info We are in feature freeze, heading into String freeze end of week
19:15:13 <tuxayo> cait: And if some tries, they get a place in the chair instead, hue hue
19:15:18 <cait> can't think of something else :)
19:16:05 <cait> move on?
19:16:13 <tcohen> #topc Update from the Release manager (20.05)
19:16:28 <tcohen> just messing with you
19:16:30 <ashimema[m]> Just join by phone
19:16:31 <tuxayo> tcohen: topc→topic
19:16:35 <tuxayo> hooo >_<
19:16:36 <ashimema[m]> Sorry, computer issues
19:16:39 <tcohen> #topic Update from the Release manager (20.05)
19:16:47 <tcohen> just in time, ashimema[m]
19:16:53 <ashimema[m]> #info Martin Renvoize, PTFS-Europe
19:17:00 <tuxayo> o/ ashimema
19:17:10 <tcohen> o/
19:17:50 <ashimema[m]> #info We are loving at a pace readying ourselves for release.. QA team are great and bugs are getting squashed.  We're now in feature freeze and string freeze is this coming Friday.
19:18:15 <ashimema[m]> Please excuse a higher rate of typos.. no idea why I can't sign in on the laptop or pc
19:18:19 <AnnaBoten> \_o< quack!
19:18:19 <wahanui> *click*
19:18:24 <tcohen> !bang
19:18:24 <AnnaBoten> \_x< tcohen: 2 (5.15 seconds)
19:18:25 <AnnaBoten> [('tcohen', 2), ('tuxayo', 1)]
19:18:26 <AnnaBoten> Best time: tcohen with 5.15 seconds
19:18:27 <AnnaBoten> Longest time: tuxayo with 845444.47 seconds (this is your new longest time in this channel! Your previous longest time was 386334.35)
19:18:28 <AnnaBoten> tcohen took the lead for the week over kidclamp with 2 points.
19:18:33 <tcohen> !stop
19:18:34 <AnnaBoten> Not a single duck was shot during this hunt!
19:18:35 <AnnaBoten> Nothing to stop: there's no hunt right now.
19:18:54 <tcohen> ashimema[m]++
19:19:00 <tcohen> very excited about this release!
19:19:11 <cait> me too :)
19:19:21 <tcohen> moving on then
19:19:29 <cait> good pace overall - just no slacking off after release please heh
19:19:51 <tcohen> I'm sure we will all be busy next cycle
19:19:59 <tcohen> #topic Updates from the Release Maintainers
19:20:14 <tcohen> rmaints?
19:20:14 <wahanui> hmmm... rmaints is talljoy, lukeG, hayley
19:21:27 <ashimema[m]> yeay.. back in.. I can type again :)
19:21:37 <talljoy> #info Joy Nelson ByWater
19:21:45 <tuxayo> o/
19:21:49 <tcohen> o/
19:21:58 <tcohen> it is the rmaints report topic
19:22:22 <talljoy> Jenkins is failing on me and aborted on two runs.  Anyone able to help with that (19.11.x)
19:22:51 <talljoy> other than that, trying to catch up to ashimema with stuff being pushed to 20.05
19:22:52 <tcohen> \o
19:23:07 <tcohen> I will Joy, sorry I forgot this morning
19:23:24 <talljoy> thanks!
19:23:50 <tcohen> #info some tests are failing on 19.11, no news from other rmaints
19:24:00 * ashimema[m] isn't sure what he did to upset Jenkins.. noever seen him to red and mad looking
19:24:19 <tcohen> we need a bigger server
19:24:26 <ashimema[m]> well.. once maybe.. I got he devil response once
19:24:26 <tcohen> I will take care of that
19:24:36 <tcohen> and probably move into gitlab-ci
19:24:44 <tuxayo> tcohen: that's the cause of failures?
19:24:54 <tcohen> sometimes jenkins is causing OOM
19:25:04 <tcohen> I haven't found the plugin that is to blame
19:25:15 <tuxayo> Ho, that's bad.
19:25:17 <tcohen> if you wanna chat about that we can on pm
19:25:26 <tuxayo> ok!
19:25:26 <tcohen> ideas are welcome
19:25:40 <ashimema[m]> +1
19:25:57 <cait> :)
19:26:07 <tcohen> can we skip the next topic? cait will kick our butts I think
19:26:16 <cait> lol
19:26:24 <cait> why would i? qa team is great the rM said... ;)
19:26:24 <tcohen> #topic Updates from the QA team
19:26:42 <cait> .... well, QA team IS great, but we can always do better
19:26:54 <tcohen> Joubu++ # his numbers are impressive
19:27:19 <cait> #info QA Team please jump on any bugs popping up now - there is still some things we should include in release to make things go smoothly especially with the new feature sintroduced and highlighted
19:28:15 <tcohen> I wanted to mention some recent changes on the API front
19:28:19 <cait> so please, all hands on deck, don't fiddle with your shiny features for a bit, but hunt bugs :)
19:28:26 <cait> ok, go for it
19:28:28 <tcohen> have broken some behaviour on the plugins that implement routes
19:28:33 * oleonard pouts
19:29:13 <tcohen> it only highlighted that on the plugins front, the 'anonymous', 'public' and 'privileged' access paths hadn't been thought much
19:29:19 * ashimema[m] sends less than subliminal messge to devs to contribute to the technical release notes pad
19:29:35 <cait> oh, did i miss the link for that?
19:29:43 <tcohen> in a minute
19:30:18 <tuxayo> cait: email "[Koha-devel] New technical changes for 20.05?"
19:30:26 * cait doesn't get koha-devel recently, it looks like my web.de email is blocked soemwhere :(
19:30:26 <tcohen> that's it tuxayo
19:30:46 <cait> any help with that appreciated by the way...
19:31:26 <tuxayo> cait: that shouldn't block incoming mail though. Maybe it's web.de that blocks lists.koha-community.org
19:31:27 <tcohen> I will finish what I was writing
19:32:20 <ashimema[m]> #link https://hebdo.framapad.org/p/9ga9-koha-tech-release-notes tech notes
19:32:21 <tcohen> what I meant to say is that before the release, we need to replicate the behavioiur for the core API, on the plugins front, with a /public path, and honouring the 'RESTAnnonymous...' syspref as well
19:32:33 <tcohen> I will work as fast as possible on that
19:32:42 <ashimema[m]> thanks tcohen
19:32:52 <tcohen> and write on that technical notes so any dev knows about this change
19:33:18 * ashimema[m] has lost track of topics
19:33:24 <tcohen> anyway, we don't catch this things in QA
19:33:28 <cait> technical_notes++
19:33:30 <tcohen> and we need to work on that as well
19:33:40 <cait> there is info on the wiki about api - but a note on the outdated pages would be great too
19:33:47 <tcohen> #topic General development discussion (trends, ideas, ...)
19:34:08 <tcohen> #info 1) What's the state of ES 7 support
19:34:11 <tcohen> tuxayo?
19:34:11 <wahanui> tuxayo is probably on a role
19:34:23 <tuxayo> I'll detail
19:34:34 <tcohen> can I ask a question?
19:34:36 <tuxayo> There doesn't seem to be anything related to ES 7 other than Bug 22520
19:34:36 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22520 enhancement, P5 - low, ---, koha-bugs, NEW , Be Elastic compliant 7.x and 8.x (_doc)
19:34:44 <tuxayo> Should we have something like this? «Bug 20196 - [Omnibus] Prepare Koha to ElasticSearch6 - ES6»
19:34:44 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20196 enhancement, P5 - low, ---, alex.arnaud, RESOLVED FIXED, [Omnibus] Prepare Koha to ElasticSearch6 - ES6
19:34:56 <tuxayo> done. (for this question)
19:35:09 <tuxayo> oops, sorry tcohen , go on.
19:35:17 <tcohen> its ok
19:35:35 <tcohen> I wanted to ask if there's a concept of LTS for ES
19:35:47 <tuxayo> tcohen: nope
19:35:52 <tcohen> because we are always running way behind
19:35:52 <ashimema[m]> good question
19:36:01 <tcohen> lets move back to SolR then :-D
19:36:12 <kidclamp> No, too late
19:36:14 <tcohen> </rant>
19:36:21 <tuxayo> After looking a lot about to try to find the end of life of ES 6, there is definitely no LTS
19:36:23 <ashimema[m]> ?
19:36:43 <ashimema[m]> it's hard to keep up with a fast moving project like ES
19:36:55 <cait> good and bad...
19:37:19 <thd> It may be possible to artificially create a long term stable version at least somewhat.
19:37:25 <tuxayo> From what I get, ES has a new major release every 12 or 18 months (variable)
19:37:52 <tuxayo> And a version is supported during until the next next release
19:38:00 <ashimema[m]> what does 'Major' constitute?
19:38:10 <tuxayo> 6.X 5.X
19:38:18 <ashimema[m]> compared to our own cycle for example
19:38:30 <thd> One could standardise on some Elastic Search release in some Long Term Stable GNU/Linux distribution for example.
19:38:32 <tuxayo> So between 2 to 3 year of support for each major version.
19:38:36 <ashimema[m]> number of breaking changes I supose it my question
19:39:08 <tcohen> that's LTS-ish
19:39:51 <thd> LTS-ish++
19:40:11 <kidclamp> It should be easier to keep up when we have broader use, the slow point right now is not a lot of devs or users
19:40:19 <tuxayo> > number of breaking changes
19:40:19 <tuxayo> Breaking changes are only in major release. And with deprecation notices on the previous version. That helps.
19:40:37 <ashimema[m]> mmm
19:40:57 <cait> is it hard to install an 'older' version?
19:41:21 <tcohen> two years is ok
19:41:25 <ashimema[m]> we don't as a community have any form of centrally lead roadmaps so it's hard to build in regular updates for dependancies like this
19:41:28 <tcohen> the issue here is lack of devs
19:41:48 <ashimema[m]> that's something i would have loved to try and change during my time as RM but alas it was a mountain too far..
19:42:03 <tuxayo> > is it hard to install an 'older' version?
19:42:03 <tuxayo> I guess not because we are still installing 5.X which is EOL.
19:42:10 <cait> ok
19:42:16 <ashimema[m]> I am however, happy to work on such a scheme next cycle or too if the next RM is keen for me to do so
19:42:22 <cait> so at least if we miss one, it will not break stuff for people immediately
19:42:37 <cait> i think if we had a group of three that helped each other out, that oculd go far
19:42:58 <ashimema[m]> indeed
19:43:20 <ashimema[m]> once we got a core group testing the last ES upgrade.. it went pretty quick
19:43:37 <ashimema[m]> just needs focus
19:44:01 <tuxayo> So, that might be useful to have something like «Bug20196 - [Omnibus] Prepare Koha to ElasticSearch6 - ES6» but for ES 7.
19:44:24 <tuxayo> I'll create it to link new bugs if they pop.
19:44:35 <ashimema[m]> yup
19:44:37 <ashimema[m]> tuxayo++
19:44:52 <cait> tuxayo :)
19:44:53 <tuxayo> The next questions might help also. Moving on to them?
19:45:12 <tcohen> #info 2) Default ES versions of koha-testing-docker and KohaDevBox
19:45:23 <ashimema[m]> what shape are we in for ES unit tests and running them on Jenkins?
19:45:53 <tuxayo> Are there much unit/UI tests using ES for now?
19:46:18 <ashimema[m]> I'm seeing another whole raft of CI work in need :(.. we hugely improved our coverage the last couple of cycle by introducing a bigger mix of OS + DB combinations
19:46:30 <ashimema[m]> so we also need to start testing ES combinations too
19:46:50 <tcohen> koha-testing-docker currently can be started with es6
19:47:00 <tuxayo> nice to learn about these CI improvement! :D
19:47:05 <tcohen> with just a param change
19:47:18 <tuxayo> Oh, yes so the question was.
19:47:21 <tcohen> in the case of KohaDevBox
19:47:23 <tuxayo> 2) Default ES versions of koha-testing-docker and KohaDevBox [tuxayo]
19:47:26 <tuxayo> Should they move to ES 6 by default? ES 5 is end of life since 2019-03 (ES 7 release)
19:47:32 <tcohen> that's alreay configurable in the user.yml file
19:47:39 <tuxayo> And should they move to ES 7 by default after a few months ?
19:48:22 <cait> tcohen: if ES6 is officially supported having it as default for a new one would make sense to me
19:48:25 <tuxayo> tcohen: the default is how devs/SO/QA can discover new bugs right?
19:49:25 <tcohen> totally
19:49:32 <cait> kidclamp: maybe?
19:49:33 <tuxayo> Otherwise it's only on user reports and the devs/SO/QA tjat choose to use ES 6.
19:49:49 <tcohen> changing the default is ok
19:50:04 <tcohen> but we need to make sure CI is testing against 5.x
19:50:11 <ashimema[m]> I will admit.. I only really pay attention to ES when I'm looking specifically at and ES bug
19:50:15 <tuxayo> Good :D
19:50:20 <ashimema[m]> agreed
19:50:26 <cait> info?
19:50:26 <wahanui> somebody said info was largely out there.. just not especially well summarised
19:50:33 <cait> or agreed, but log :)
19:50:46 <tcohen> I don't know how to start a vote
19:51:06 <ashimema[m]> do we even need to vote on that?
19:51:12 <ashimema[m]> feels like a no brainer to be honest
19:51:12 <tcohen> #agreed We will make ES 6.x the default in our dev tools (koha-testing-docker and KohaDevBox)
19:51:22 <tuxayo> hooray!
19:51:22 <ashimema[m]> :)
19:51:24 <ashimema[m]> +1
19:51:26 <cait> not vote, but log it :)
19:51:33 <cait> for the minutes
19:51:34 <tuxayo> Next question (related)
19:51:36 <tcohen> #info tcohen will make sure our CI is still running tests against ES 5.x
19:51:47 <tuxayo> tcohen++
19:51:52 <tcohen> #info We will make ES 6.x the default in our dev tools (koha-testing-docker and KohaDevBox)
19:51:53 <cait> tcohen++
19:52:05 <ashimema[m]> should we be running against both ES5 and ES6 tcohen?
19:52:18 <tcohen> yes, and why not 7?
19:52:26 <ashimema[m]> then have a deprecation point for dropping ES5
19:52:30 <ashimema[m]> sounds good to me..
19:52:32 <tuxayo-read-only> Yes, +1 to 5, 6 and 7
19:52:34 <ashimema[m]> poor Jenkins..
19:52:37 <tcohen> haha
19:52:39 <ashimema[m]> it's probably my fault he hurts
19:52:51 <ashimema[m]> and drop 5 probably with 20.11
19:53:01 <tcohen> I will ask mtj[m]  to talk about his setup for running more tasks simultaneously on his node
19:53:19 <ashimema[m]> :)
19:53:21 <tcohen> he's node is big and has resources
19:53:55 <tcohen> #info 3) Should koha-testing-docker and KohaDevBox have ES enabled by default instead of Zebra?
19:54:03 <ashimema[m]> awsome
19:54:15 <tuxayo> Again, to find more bugs.
19:54:24 <tuxayo> And it would make sense if we want to move toward making ES
19:54:25 <tuxayo> the recommended search engine in Koha.
19:54:33 <tuxayo> done.
19:54:52 <tcohen> koha-testing-docker has ES set by default
19:54:53 <ashimema[m]> tuxayo++ # raising great talking points
19:55:13 <tcohen> it is only a matter of enabling it in misc4dev, probably
19:55:21 <tuxayo> tcohen: But one must set the SearchEngine syspref and index ES right?
19:55:22 <tcohen> in the case of KohaDevBox
19:55:29 <tcohen> tuxayo yes
19:55:53 <tcohen> in the case of KohaDevBox the thing is it would require VirtualBox to assign more resources (RAM)
19:55:57 <kidclamp> Sorry, with kid so not here, we need to build actual search tests, but we need support for testing in a dev env that won't leave records in our indeed
19:56:00 <tcohen> 4GB
19:56:01 <kidclamp> Index
19:56:18 <tuxayo> > in the case of KohaDevBox the thing is it would require VirtualBox to assign more resources
19:56:18 <tuxayo> Indeed
19:56:46 <tcohen> kidclamp didn't we solve taht already by having a separate index?
19:56:47 <tuxayo> > we need support for testing in a dev env that won't leave records in our
19:56:47 <tuxayo> what do you mean kidclamp ?
19:57:00 <tcohen> or we didn't finish that...
19:58:17 <tuxayo> > one must set the SearchEngine syspref and index ES
19:58:19 <tuxayo> This means that many of our dev, SO, QA work in still done on Zebra so discovery on new bugs will be low.
19:58:25 <kidclamp> our general tests that create bibs end up in the index
19:58:38 <cait> i thnk we can't break Zebra either
19:58:40 <kidclamp> because we don't have a queue, we just index upon creation/change
19:58:40 <cait> i regularly switch
19:58:49 <cait> when your devbox is set up, you can just throw the pref
19:59:07 <cait> it's not an either/or choice
19:59:43 <tuxayo> hmmm, so how could we have a mixed usage of ES or Zebra?
19:59:46 <davidnind> I find it easy enough to switch when testing elastic search bugs (koha-testing-docker)
20:00:17 <cait> tuxayo: i think we already have
20:00:32 <kidclamp> bug 24119
20:00:32 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24119 major, P5 - low, ---, chris, NEW , Records indexed into ES during tests are not removed by rollback
20:01:23 <tuxayo> cait, davidnind . Good, I was worried that the usage was low and that many ES
20:01:26 <tuxayo> bugs could sneak to end user.
20:01:51 <cait> i think the ones we find now are too specific often, ES works 'well enough' i don#t notice when i forget to turn it off
20:01:59 <cait> but i don't do the real hard stuff in testing
20:02:00 <tuxayo> nice!
20:02:16 <cait> like importing, merging etc. - unless i test a bug in that area
20:02:20 <kidclamp> tuxayo: yes, we are trying to get a broad base of our users testing right now  - once we upgrade to 19.11 we will work on switching to ES6 and finding those bugs, then can focus on support ofr 7/8
20:02:37 <tuxayo> Though if we want to catch up with ES versions. That means bugs than the current pace.
20:03:00 <tuxayo> kidclamp: very good :D
20:03:28 <tuxayo> Would it be worth it to make docker-testing-docker and the DevBox to automatically index ES on startup?
20:03:29 <tuxayo> Then it's only a matter of syspref.
20:03:42 <ashimema[m]> ptfs-e are starting to migrte customers to es with 19.11 too
20:04:03 <kidclamp> es indexing should be added to 'do all you can do'
20:04:08 <kidclamp> and need support in sandbox
20:04:13 <kidclamp> for indexing es
20:04:23 <cait> do we have bugs for thoseß
20:04:24 <cait> ?
20:04:25 <ashimema[m]> yes.. sandbox support would be good..
20:04:30 <cait> we could tag them priority at least
20:04:35 <cait> well or gitlab issues
20:04:37 <ashimema[m]> but I imagine that could increase system requirements for sandbxoes significantly?
20:04:56 <tcohen> ashimema[m] sandboxes should share an ES instance
20:05:14 <kidclamp> good idea, less resources
20:05:19 <ashimema[m]> I think they might already.. I can't remember what state it's currently in
20:05:37 <ashimema[m]> khall is king there.. I just dable with patches now and then
20:05:57 <kidclamp> afaik they support es, but users cannot index it
20:06:00 <tuxayo> So the proposals would be.
20:06:00 <tuxayo> - es indexing should be added to 'do all you can do'
20:06:05 <tuxayo> - add support in sandboxes for ES
20:06:05 <tuxayo> - ES support in KohaDevBox
20:06:06 <tuxayo> Any thing more?
20:06:36 <tcohen> I don't get the KohaDevBox item
20:07:00 <tuxayo> tcohen: I though KohaDevBox didn't use ES.
20:07:18 <tcohen> it does, if you launch vagrant with KOHA_ELASTICSEARCH=1
20:07:37 <tcohen> and vars/user.yml lets you change the ES version
20:07:59 <tcohen> but someone needs to try setting 6,x and see if the repo works, or needs to be changed in the config
20:08:15 <cait> i know the default works
20:08:17 <cait> i use it all the time
20:08:31 <tcohen> yes, I'm talking about making 6.x the default
20:08:37 <tcohen> and what changes are needed
20:08:50 <tcohen> re: install repositories, for example
20:09:05 <cait> tcohen: that was to tuxayo's question :)
20:09:30 <tuxayo> tcohen: Good. So nothing to do about DevBox except the default ES version (when choosing ES, Zebra stays by default)
20:09:45 <tcohen> I'm just suggesting someone should volunteer to try and file an issue in Gitlab if we need to change something
20:09:52 <kidclamp> I have been using ES6, works in testing docker well
20:10:21 <tcohen> kidclamp would you suggest we make it the default?
20:10:24 <kidclamp> yes
20:10:26 <kidclamp> 100%
20:10:29 <kidclamp> definitely
20:10:31 <kidclamp> absolutely
20:10:35 <kidclamp> :-)
20:10:40 <tuxayo> tcohen: okay, I'm noting that. So:
20:10:40 <tuxayo> - es indexing should be added to 'do all you can do'
20:10:41 <tcohen> #info tcohen will make ES6 the default in koha-testing-docker
20:10:42 <tuxayo> - add support in sandboxes for ES
20:10:42 <tuxayo> And that's all?
20:11:23 <tcohen> maybe
20:11:38 <ashimema[m]> :)
20:11:43 <tuxayo> Great :D
20:11:50 <kidclamp> gotta run
20:11:55 <tcohen> thanks kidclamp
20:11:58 <ashimema[m]> next topic?
20:12:00 <tcohen> kidclamp++
20:12:05 <tuxayo> yup
20:12:19 <tcohen> #topic Review of coding guidelines
20:12:47 <tcohen> #info There's a proposal to add aria-hidden="true" in the guidelines
20:13:04 <tcohen> #link https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25166
20:13:04 <huginn> 04Bug 25166: enhancement, P5 - low, ---, oleonard, Pushed to master , Add aria-hidden = "true" to Font Awesome icons in the OPAC
20:13:53 * tuxayo tries to understand
20:13:54 <oleonard> #info https://fontawesome.com/v4.7.0/accessibility/
20:13:57 <tuxayo> https://developer.mozilla.org/en-US/docs/Web/Accessibility/ARIA/ARIA_Techniques/Using_the_aria-hidden_attribute
20:14:07 <oleonard> "If you're using an icon to add some extra decoration or branding, it does not need to be announced to users as they are navigating your site or app aurally"
20:14:33 <tuxayo> Adding aria-hidden="true" to an element removes that element and all of its children from the accessibility tree.
20:14:35 <tuxayo> This can improve the experience for assistive technology users by hiding:
20:14:38 <tuxayo> - purely decorative content, such as icons or images
20:14:39 <thd> Having worked with people using screen readers, anything to reduce the auditory noise in screen reading should be done.
20:14:41 <tuxayo> - duplicated content, such as repeated text
20:14:41 <tuxayo> - offscreen or collapsed content, such as menus
20:14:45 <cait> so if we have an edit button that is labelled added with a pencil icon,.. we don't need the icon
20:15:17 <tcohen> and what about role="button" and aria-label?
20:15:48 <oleonard> ....and if we have an icon which is the entire control (no label) we can add aria-label to the <button> or <a> to convey more meaning
20:16:17 <oleonard> tcohen: Are you asking about adding guidelines for those attributes?
20:16:22 <tcohen> yes
20:16:36 <tcohen> I had to read the whole docs to understand cait's QA concern
20:16:45 <tcohen> and my conclusion was we should also add those
20:16:53 <tcohen> but I ain't no expert in the area
20:17:05 <oleonard> tcohen: Nor I, but let's do one thing at a time.
20:17:12 <tcohen> agreex
20:17:12 <tuxayo> How would the guideline looklike?
20:17:40 <tuxayo> «Decorative HTML element should have aria-hidden="true"»
20:18:15 <thd> A user interface which works well with screen readers is difficult to find.  1990s style user interfaces work best with screen readers in my experience.
20:18:43 <oleonard> thd please file bugs if you know of areas where we can improve
20:20:07 <cait> thd: we had a blind staff person for a while, koha is not super bad from what i was told
20:20:10 <cait> can still improve tho :)
20:20:30 <cait> screen readers can do a lot nowadays, i was worried when we started to do more ajax in circ, but it worked
20:20:38 <tuxayo> «aria-label should be used on elements that have a function but no text. Like icons»
20:20:43 <oleonard> tuxayo: I think the guideline should talk specifically of font-awesome icons since that's the most commonly-encountered case in our templates
20:20:52 <tuxayo> okay
20:20:52 <thd> oleonard: I am not visiting these people currently because of COVID but part of the problem is how the screen reading software is set to work.  I was not working with people experienced at setting screen reading software.
20:21:07 <ashimema[m]> it's imminently UK legislation that we abide by aaa accessability guidelines.. reaching that is less than trivial though.. and need regular testing to ensure we hit it..
20:21:31 <tcohen> Owen
20:21:45 <tcohen> oleonard do you volunteer to put the words for this on the coding guidelines?
20:22:06 <tcohen> (sorry)
20:22:14 <oleonard> Sure
20:22:25 <thd> Koha is definitely not bad for screen readers.  Popular webmail is bad and constantly becoming worse.
20:22:56 <oleonard> thd: GMail at least is constantly becoming worse for all of us!
20:22:59 <davidnind> as an aside, the WAVE extension for browsers is reasonably good for testing accessibility issues https://wave.webaim.org/extension/
20:23:03 * ashimema[m] is about to embark on working through all header tags in the opac to mke sure they are in ascending order...
20:23:27 * tuxayo wonder how feasible doing some signoffs using a screenreader would be.
20:23:39 <cait> if you are  not trained probabl yhard
20:23:45 <cait> i listened in on some of it when we did testing
20:24:00 <tuxayo> Do we have a place to note resources about testing and devolving accessibility?
20:24:08 <cait> quite interesting tho - she has a sign-off in codebase too :)
20:24:11 <tuxayo> Like for the tool davidnind mentioned.
20:24:28 <tuxayo> > if you are  not trained probabl yhard
20:24:28 <tuxayo> Indeed.
20:24:30 <cait> not yet i think
20:24:46 <tuxayo> documentation team?
20:24:48 <tuxayo> ^^
20:25:04 <tuxayo> Anything known?
20:25:27 <ashimema[m]> sounds like something to add to the dev handbook
20:25:46 <tuxayo> There is a dev handbook? :o
20:25:51 <ashimema[m]> I'd love to see more guidelines generally for accessability.
20:26:00 <tcohen> There's one on the wiki
20:26:03 <ashimema[m]> and more automated testing wherever we can
20:26:06 <tuxayo> I know my next bed-reading.
20:26:12 <tcohen> and khall started one on github we could resurrect
20:26:16 <ashimema[m]> it needs lot of updating
20:26:35 <tcohen> I would prefer markdown on gitlab for this honestly
20:26:36 <davidnind> Interesting, 9 errors on the staff interface home page, and 1 contrast error
20:26:50 <tuxayo> > and khall started one on github
20:26:50 <tuxayo> A dev handbook?
20:27:19 <oleonard> Lots of contrast errors with the OPAC unfortunately. Makes me consider adding some kind of "high contrast" option
20:27:32 <tcohen> he wanted to start onw
20:27:33 <tcohen> one
20:27:36 <tcohen> https://github.com/kylemhall/koha-developers-handbook
20:27:39 <tcohen> it is empty hehe
20:27:47 <tuxayo> ^^
20:28:25 <oleonard> The real developers handbook can only be found within yourself after a spiritual journey
20:28:39 <tuxayo> Quote!
20:29:23 <tcohen> #actions aria-hidden="true" for FontAwesome icons is approved without objections and oleonard volunteered to write the coding guidelines entry. We will review the wording on the next dev meeting
20:29:26 <ashimema[m]> shall we start wrapping this up
20:29:28 <davidnind> err, don't look at the catalog folks (16  errors with two search results, and lots of low contrast errors)
20:29:30 * ashimema[m] is geting tired
20:29:32 <cait> i think we need dev docs.. but not sure we need another way of doing things
20:29:39 <cait> could be using the manual software be an option?
20:30:05 <cait> we could add dev docs on next meeting sagenda
20:30:05 <davidnind> I have a plan, I just need a plan to finish the plan!
20:30:07 <ashimema[m]> I was just suggesting cleaning up whats in the wiki
20:30:09 <tuxayo> Is there something wrong with the wiki version of the book?
20:30:14 <davidnind> cait++
20:30:18 <cait> yes, hat woudl be a good start too
20:30:27 <cait> but i tihk scattering more and more syntaxed is not going to help :)
20:30:32 <cait> move on?
20:30:38 <tcohen> yes
20:30:45 <tcohen> I already wrote the action on this item
20:30:59 <tcohen> #topic Set time of next meeting
20:31:22 <tcohen> need help with this
20:31:25 <tuxayo> > yes, hat woudl be a good start too
20:31:25 <tuxayo> I though a dev handbook existed in the wiki.
20:31:31 * tuxayo is getting tired also.
20:32:00 * tuxayo is getting tired also.
20:32:00 <tcohen> #link https://wiki.koha-community.org/wiki/Developers_Handbook
20:32:07 <tuxayo> oops
20:32:13 <ashimema[m]> release is aimed at 22nd
20:32:21 <tuxayo> tcohen++
20:32:36 <tcohen> #info the 20.05 release is aimed at 22nd
20:33:13 <ashimema[m]> if we stuck to the 2 week cycle, dev meeting would be 20th
20:33:37 <tcohen> is there a special syntax for this?
20:33:42 <tcohen> so the script catches it?
20:34:49 <ashimema[m]> Next meeting: 20 May 2020, 14 UTC
20:34:56 <ashimema[m]> how does that sound?
20:35:18 <ashimema[m]> tcohen.. the last #info wit the above syntax wins
20:35:29 <tcohen> #info Next meeting: 20 May 2020, 14 UTC
20:35:31 <tcohen> thanks
20:35:33 <tcohen> :-D
20:35:36 <tcohen> thank you all
20:35:42 <tcohen> #endmeeting