#koha: Development IRC meeting 9 September 2020

Meeting started by davidnind at 20:09:40 UTC (full logs).

Meeting summary

    1. Agenda https://wiki.koha-community.org/wiki/Development_IRC_meeting_9_September_2020 (davidnind, 20:10:01)

  1. Introductions (davidnind, 20:10:15)
    1. Aleisha Amohia, Catalyst IT, Wellington NZ (aleisha_, 20:10:31)
    2. David Nind, Wellington, New Zealand (davidnind, 20:10:32)
    3. Henry Bolshaw, House of Lords Library, UK (henryb, 20:10:59)
    4. tuxayo/Victor Grousset, France (tuxayo, 20:11:05)

  2. Review of action points (davidnind, 20:13:20)
    1. ACTION: ashimema is collecting notes about bug 15522 and is going to review and dig a bit more into the code (postponed) (davidnind, 20:14:35)
    2. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 20:16:20)
    3. tuxayo has added the RMaint-handover-draft into the "release maintenance" wiki page https://wiki.koha-community.org/wiki/Release_maintenance#Handover_between_two_cycles (davidnind, 20:17:50)
    4. ACTION: davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (postponed) (davidnind, 20:20:49)
    5. Joubu has opened a bug report for the QA script to catch input type number - see https://gitlab.com/koha-community/qa-test-tools/-/issues/38 (there is a merge request attached) (davidnind, 20:21:49)
    6. ACTION: ashimema to write a guideline to forbidding the use of type "number" (davidnind, 20:22:54)

  3. Announcements (davidnind, 20:23:50)
    1. Update of the OPAC bootstrap template to bootstrap v4 now pushed, see bug 20168 (davidnind, 20:26:33)
    2. let oleonard know if you have issues rebasing patches, is happy to help (davidnind, 20:27:20)
    3. koha-US's annual conference is on this month, and is online beginning on 22 September - see http://koha-us.org/learn/conferences/onlinetogether2020/ (davidnind, 20:29:44)
    4. kohacon20's working together will still be going ahead in some shape or form, so keep tagging bugs as #academy for us to work on :) (aleisha_, 20:31:04)

  4. Updates from the Release Maintainers (davidnind, 20:33:06)
    1. 19.11.x is going well. if anyone wants things backported, please don't direct message me - just add me to the CC list of the bug and leave a note on the bug report for me so i can look into it (aleisha_, 20:34:10)
    2. 19.05.x nothing unusual to report, will try to focus on more severe bugs. Too much backporting on oldoldstable isn't much worth it and is bad for translations when it's string changes. (tuxayo, 20:36:27)
    3. https://wiki.koha-community.org/wiki/User:Victor_Grousset_-_tuxayo/Release_maintenance_tips (tuxayo, 20:38:02)
    4. ACTION: davidnind to add information about what to backport to the release maintainers role page (as a starting point for further notes and guidance) (davidnind, 20:41:54)

  5. Updates from the QA team (davidnind, 20:43:31)
    1. ACTION: tuxayo to collect notes (if any) from past&present RMaints about their backport policies. (tuxayo, 20:45:57)
    2. Send the QA Team cookies and chocolate for the great job they do (and oleonard for all the UI things)! (davidnind, 20:47:09)
    3. Nick Clemens (kidclamp, 20:47:26)
    4. Nick Clemens is working on testing the circulations rules rewrite (wahanui, 20:47:26)
    5. Please help with sign offs (now around 260), so the QA Team can have some things to do :-D (davidnind, 20:51:16)
    6. Thomas Dukleth, Agogme, New York City (thd, 20:51:45)
    7. Help with sign-off for Recalls in Koha would be appreciated (bug# 19532) (davidnind, 20:54:22)

  6. General development discussion (trends, ideas, ...) (davidnind, 20:54:56)
  7. Set time of next meeting (davidnind, 20:59:01)
    1. Next meeting: 23 September 2020, 14:00 UTC (davidnind, 21:03:22)


Meeting ended at 21:03:29 UTC (full logs).

Action items

  1. ashimema is collecting notes about bug 15522 and is going to review and dig a bit more into the code (postponed)
  2. davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (postponed)
  3. ashimema to write a guideline to forbidding the use of type "number"
  4. davidnind to add information about what to backport to the release maintainers role page (as a starting point for further notes and guidance)
  5. tuxayo to collect notes (if any) from past&present RMaints about their backport policies.


Action items, by person

  1. davidnind
    1. davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (postponed)
    2. davidnind to add information about what to backport to the release maintainers role page (as a starting point for further notes and guidance)
  2. tuxayo
    1. tuxayo to collect notes (if any) from past&present RMaints about their backport policies.
  3. UNASSIGNED
    1. ashimema is collecting notes about bug 15522 and is going to review and dig a bit more into the code (postponed)
    2. ashimema to write a guideline to forbidding the use of type "number"


People present (lines said)

  1. davidnind (65)
  2. tuxayo (30)
  3. aleisha_ (12)
  4. oleonard (6)
  5. huginn (6)
  6. wahanui (5)
  7. kidclamp (5)
  8. henryb (4)
  9. ashimema[m] (4)
  10. thd (1)


Generated by MeetBot 0.1.4.