18:13:14 <caroline> #startmeeting Documentation IRC meeting 15 October 2020
18:13:14 <huginn> Meeting started Thu Oct 15 18:13:14 2020 UTC.  The chair is caroline. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:13:14 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:13:14 <huginn> The meeting name has been set to 'documentation_irc_meeting_15_october_2020'
18:13:31 <caroline> #link https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_15_October_2020
18:13:48 <caroline> #chair davidnind
18:13:48 <huginn> Current chairs: caroline davidnind
18:13:52 <caroline> #topic Introductions
18:13:59 <caroline> please use "#info" in front of your introduction to have it show up in the automatic minutes
18:14:10 <caroline> #info Caroline Cyr La Rose, inLibro
18:14:18 <davidnind> #info David Nind, Wellington, New Zealand
18:15:06 <henryb> #info Henry Bolshaw, House of Lords Library, UK
18:15:44 <caroline> cait around?
18:16:18 <caroline> #topic Updates
18:16:36 <caroline> There were no action points from last meeting so I'll just skip that
18:16:45 <caroline> #topic  Project updates
18:17:19 <caroline> Unfortunately, I'm not giving the best example, I haven't workd on anything manual-wise in the past month
18:17:32 <caroline> anyone has updates they'd like to share?
18:17:39 <marie-luce> sorry to be late
18:17:45 <davidnind> No updates from me either on my projects :-(
18:17:50 <caroline> no worries we just started
18:17:57 <marie-luce> #info Marie-Luce Laflamme, inLibro
18:18:05 <davidnind> hi marie-luce
18:18:10 <henryb> Me neither. To be honest I'm still trying to work out the documentation workflow
18:18:21 <marie-luce> hi David
18:18:52 <marie-luce> Henri, you are not alone. There are so many places to look at
18:19:41 <caroline> I started a section in the wiki https://wiki.koha-community.org/wiki/Editing_the_Koha_Manual#.3D.3E_New_writers.2C_start_here.21_.3C.3D
18:19:44 <caroline> #link https://wiki.koha-community.org/wiki/Editing_the_Koha_Manual#.3D.3E_New_writers.2C_start_here.21_.3C.3D
18:20:24 <marie-luce> great! Thanks Caroline
18:20:42 <caroline> Where are you stuck henryb? Maybe we can discuss it and it'll clear it up for more people too
18:21:27 <henryb> I'm not stuck exactly just not entirely sure how bugzilla, taigo and gitlab all fit together
18:21:44 <caroline> that's a good question
18:21:47 <henryb> But the link you've sent is really helpful!
18:22:03 <marie-luce> ++caroline
18:22:10 <caroline> This is how I see it : bugzilla is the source of everything
18:22:25 <caroline> That's where the developers work and create new features
18:22:57 <ashimema[m]> #info Martin Renvoize - PTFS-EUROPE
18:23:02 <caroline> it is very useful to get an idea of what a feature is, what it does, the steps of how to use it etc
18:23:21 <caroline> There are also Documentation "bugs" on bugzilla
18:23:46 <ashimema[m]> I used to just use a search in bugzilla to find the manual keyword.. work on it and then remove the keyword when done..
18:23:52 <caroline> That's where we point poeple to when they see a typo or notice that something is missing or not explained well
18:24:04 <ashimema[m]> But you guys do much more and have a bigger workflow to manage.. I've not kept up
18:24:48 <caroline> We ask anybody who sees somthing like that (typo, missing, etc.) to file a bug in bugzilla in the Documentation component
18:25:22 <caroline> that way, we can at least keep a record of things that need to be corrected and since a lot of people already know bugzilla, it's easy for them to file a new bug
18:25:42 <caroline> #link https://bugs.koha-community.org/bugzilla3/buglist.cgi?cmdtype=dorem&list_id=347662&namedcmd=Documentation%20To-do&remaction=run&sharer_id=13
18:25:51 <caroline> ^ this is the list of such bugs
18:26:13 <caroline> From the main bugzilla page, you can click on Documentation To-Do to see this
18:26:23 <ashimema[m]> Dare I ask.. do you actually need tiaga?
18:26:37 <ashimema[m]> I always wonder why you didn't just do it all through BZ?
18:26:42 <caroline> I'm coming to that, but it could be a great discussion
18:27:07 <caroline> Taiga is where we write all the "new" things we need to add to the manual
18:27:16 <caroline> Not corrections, but new stuff
18:27:35 <caroline> Taiga is based on the release notes for each version
18:28:09 <ashimema[m]> Indeed... But those could be just bugs in BZ again.. for away with the keyword and instead add a linked bug in bz
18:28:39 <caroline> The reason I've been keeping it separate, and davidnind can interrupt me if im saying nonsense, is that devs have a workflow already established in bugzilla and we are nowhere in that workflow
18:29:00 <caroline> It's sign off, QA, push to master, push to stable, push to old stable, etc and then close
18:29:17 <ashimema[m]> Indeed..
18:29:20 <caroline> there is no step where we have a list of bugs that need to be added to the manual
18:29:36 <davidnind> have never heard caroline talking nonsense :)
18:29:37 <caroline> That's why I think it's a great discussion to have
18:29:52 <ashimema[m]> I'd be happy to help bridge the developer/docs divide
18:30:19 <caroline> Sure, we'd just need to squeeze in an extra step for us
18:30:26 <marie-luce> good points
18:30:55 <davidnind> we could do in the issues list in GitLab - easy to import from bugzilla
18:30:56 <caroline> It would certainly save me then step of copying everything in taiga
18:31:13 <ashimema[m]> I have the keys to the bugzilla configs.. happy to discus and impliment
18:31:22 <caroline> anyway, I just want to finish answering henryb before we diverge
18:31:25 <davidnind> I don't mind taiga, but it is one more thing...
18:32:21 <ashimema[m]> I don't want to push changes onto anyone.. but do feel free to reach out if there things that bug you and you think there could be a better way
18:32:42 <caroline> So that's taiga... when the bugs are done with their life with the devs in bugzilla, I copy everything in taiga so the docs team can look through
18:32:44 * ashimema[m] goes quite to let Caroline finish
18:33:08 <caroline> Then the final leg of the tripod, Gitlab is where the manual lives
18:33:19 <caroline> that's where you need to do the changes to the manual per se
18:34:00 <caroline> So look in bugzilla (Documentation To-Do) or taiga to find something to write about and write it in gitlab
18:34:04 <caroline> does that make sene?
18:34:17 <caroline> sense
18:34:23 <henryb> Yes it does! Thanks for the very patient explanation
18:34:30 <henryb> caroline++
18:34:38 <caroline> There is also the wiki... which is a whole nother thing...
18:34:57 <caroline> but it's not part of the docs workflow
18:34:59 <davidnind> caroline++
18:35:06 <henryb> No! just when I thought I understood
18:35:12 <caroline> lol!
18:35:18 <marie-luce> caroline++
18:36:07 <caroline> So do we want to simplify it and stay in bugzilla and ditch taiga?
18:36:32 <caroline> I agree that copying everything in taiga is an extra step that could be avoided
18:37:31 <henryb> Does taiga have any advantages over bugzilla - additional features etc?
18:37:31 <davidnind> thinking...
18:37:31 <wahanui> thinking is probably so much easier
18:37:45 <ashimema[m]> We could even broaden it and make it a requirement for enhancements and new features to have a corresponding manual merge request linked in the bug before QA
18:37:46 <caroline> it's prettier?
18:38:17 <caroline> ashimema[m]: oof... nothing will get past QA lol! Do you know how far behind we are?
18:38:32 <davidnind> LOL
18:38:36 <ashimema[m]> Tiaga is more modern and can handle lots of workflows.. I just wonder how much of it we actually make use of and need... I've tried to get into it on a few occasions and never fully got to grips
18:39:04 <caroline> maybe it's the way it's organized too...
18:39:14 <ashimema[m]> Well.. it would only require one is open.. not necessarily that it's fully finished..
18:39:31 <ashimema[m]> That would mean you have a record in girls of what to be done..
18:39:52 <ashimema[m]> s/girls/gitlab
18:40:06 <caroline> personally, when I write I like to pick a section and add all the new things in that section, rather than work bug by bug
18:40:53 <ashimema[m]> I also would love to see docs done by more people.. us Devs are terrible.. we should really give at least a skeleton of documentation for anything we add really.. if we can't then we should get someone in company to help us to
18:41:17 <ashimema[m]> Fair point
18:41:18 <caroline> at least a good test plan
18:41:33 <caroline> helps a lot when we try to figure out what something does
18:41:48 <ashimema[m]> Indeed
18:42:21 <davidnind> Options: use bugzilla, use GitLab, continue as currently
18:42:26 <caroline> ok so we need to actionize this
18:43:26 <caroline> I will write out neatly what I described here so that we have a trace of the current workflow
18:43:39 <caroline> #action caroline will write out the current worflow (from minutes)
18:43:47 <ashimema[m]> :)
18:43:55 <davidnind> bugzilla: no new tool to learn, either tag tasks or make a bugzilla doc tasks for topics for a release, link to bugs, non bug-related tasks have own bugzilla task
18:44:35 <caroline> davidnind: can you look into how it would work if we were to use gitlab issues?
18:44:59 <caroline> how to link with bugzilla etc
18:45:00 <davidnind> GitLab: use issues , import any bugzilla bugs (easier process than adding to taiga),  use boards
18:45:08 <davidnind> caroline: sure can!
18:45:14 <caroline> cool!
18:45:42 <davidnind> there is some intergration available with bugzilla, I looked at it a while ago and "seemed" relatively easy
18:45:51 <caroline> #action davidnind will check how we can use gitlab to simplify the workflow
18:46:27 <caroline> and when this is done, I'll check in with ashimema[m] on how to insert ourselves into the dev workflow
18:46:29 <davidnind> will write something up on the wiki, or in bugzilla and will send around the documentation and dev mailing lists
18:47:07 <caroline> #action caroline will check with ashimema on how to best insert the docs writing into the dev workflow
18:47:45 <caroline> woo, we'll be busy bees
18:47:56 <davidnind> #action davdnind to document options for docs tasks management including: using bugzilla, using GitLab issues, using Taiga, various other ideas discussed <- aim is to make as easy and as manageable as possible
18:48:10 <caroline> anything else to add to this?
18:48:19 <davidnind> (and less confusing for everyone...)
18:48:42 <marie-luce> great discussion, I can see the picture now!
18:49:15 <caroline> ok let's move on
18:49:20 <caroline> #topic  What's been done so far
18:49:27 <caroline> davidnind had a point here
18:50:00 <caroline> davidnind: tidied up the YouTube channel: added some sections and play lists, tracking down Kohacon videos, feedback welcome
18:50:20 <caroline> #link https://www.youtube.com/channel/UCqOmLE1-kt84liiG5233BRQ
18:50:56 <caroline> very cool!
18:51:03 <marie-luce> davidnind++
18:51:10 <caroline> davidnind++
18:51:28 <henryb> davidnind++
18:52:13 <caroline> So please if you have any feedback, let davidnind know with an @later or other means of communcation
18:52:27 <davidnind> finally working on getting last year's Kohacon videos added - is easy to split, but have an audio issue I'm trying to fix (not a docs related task though...)
18:52:34 <caroline> I'm sure we'll have new content from kohacon next week
18:53:20 <davidnind> our channel is being used as part of the live streaming, so that will be good
18:53:30 <caroline> cool!
18:53:58 <caroline> #topic  Content development guidelines
18:54:07 <caroline> I don't think there's anything new for this...
18:54:20 <caroline> We'll surely be adding to it with the workflow thing
18:55:00 <caroline> Feel free to interrupt me if you have something to add...
18:55:11 <davidnind> nothing to add
18:55:19 <caroline> #topic  Next steps
18:55:44 <caroline> #info the page for roles for 21.05 is up
18:55:46 <caroline> #link https://wiki.koha-community.org/wiki/Roles_for_21.05
18:55:55 <caroline> please add your name to the docs team!
18:56:33 <caroline> Also if anyone wants to have a go at docs manager, I'm happy to let someone else have a go!
18:57:13 <marie-luce> I would like to add my name in Doc team, but I don't have the rights to modify the page
18:57:28 <caroline> oh, you can request a login
18:57:38 <caroline> Click log in and click on "request"
18:57:57 <marie-luce> great, I will place my request
18:58:01 <caroline> +1
18:58:09 <caroline> same goes for anyone else
18:58:11 <davidnind> I can approve, so will keep an eye out
18:58:25 <davidnind> (approval is required to stop spam registrations)
18:59:04 <caroline> otherwise, priorities are on documenting new features for 20.11 as usual
18:59:22 <caroline> Check Taiga for new feature to document
19:00:02 <caroline> davidnind: I think the docs workshops at kohacon are in-person only, is that right? do you know?
19:00:59 <davidnind> it is, but I'm maybe going look at recording at least, and an online bit if there is any interest (either live streaming or using jitsi)
19:01:00 <davidnind> #info Kohacon20 documentation workshop - feel free to add your ideas to https://wiki.koha-community.org/wiki/Documentation_Workshop_KohaCon20
19:01:22 <marie-luce> it would be nice if someone could record it, I would be happy to watch later
19:02:03 <caroline> there will also be two days of "DIY" where we can work together on docs
19:02:05 <ashimema[m]> +1
19:02:19 <caroline> #link https://2020.kohacon.org/posts/programme/
19:02:26 <marie-luce> +1
19:02:41 <caroline> From what I understood it will be here on IRC for remote ppl
19:03:01 <davidnind> I'll try my best to at least record, I will add a jitsi meeting but quality will depend a bit on the wifi...
19:03:03 <davidnind> cool
19:03:37 <marie-luce> cool
19:04:19 <caroline> anything else to add?
19:04:42 <davidnind> nothing from me
19:04:48 <henryb> nothing from me
19:04:56 <caroline> #topic Set time of next meeting
19:05:07 <caroline> is november 12 good?
19:05:17 <caroline> it's 4 weeks from now
19:05:30 <davidnind> +1
19:05:33 <marie-luce> +1
19:05:34 <henryb> +1
19:05:49 <caroline> same time good for everyone?
19:06:03 <marie-luce> +1
19:06:26 <henryb> +1
19:06:34 <davidnind> +1
19:06:38 <caroline> we might be in regular time here so it will be earlier or later... never sure how it goes
19:06:57 <caroline> I'm bad with numbers...
19:07:39 <caroline> #info Next meeting: 12 November 2020, 18 UTC
19:07:44 <caroline> #endmeeting