19:05:35 <davidnind> #startmeeting Documentation IRC meeting 4 June 2020
19:05:35 <huginn> Meeting started Thu Jun  4 19:05:35 2020 UTC.  The chair is davidnind. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:05:35 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:05:35 <huginn> The meeting name has been set to 'documentation_irc_meeting_4_june_2020'
19:05:47 <davidnind> #chair caroline
19:05:47 <huginn> Current chairs: caroline davidnind
19:06:07 <davidnind> #info Agenda https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_4_June_2020
19:06:15 <davidnind> #topic Introductions
19:06:28 <davidnind> #info David Nind, Wellington, New Zealand
19:06:33 <caroline> #info Caroline Cyr La Rose, inLibro
19:06:37 <jzairo> #info Jessica Zairo, ByWater Solutions
19:06:39 <Marie-Luce> #info Marie-Luce Laflamme, inLibro Montreal
19:06:53 <DonnaB> #info Donna Bachowski, ByWater Solutions
19:06:55 <kellym> #info Kelly McElligott ByWaters Solutions
19:07:03 <tuxayo> #info tuxayo/Victor Grousset, France
19:07:30 <davidnind> It's nice to have so many attendees!
19:08:01 <davidnind> I think that is everyone...
19:08:27 <davidnind> #topic Review of action points
19:09:00 <davidnind> From what I can see (only looked briefly)...
19:09:30 <davidnind> caroline has been busy adding tasks to Taiga.io
19:09:38 <davidnind> caroline++
19:09:59 <caroline> yes I went through the last version of the release notes and added enhancements and new features to taiga
19:10:06 <caroline> it's a bit overwhelming tbh
19:10:44 <caroline> the devs are doing so much! (which is good!)
19:10:47 <davidnind> yeah, it's always where do we start!
19:11:27 <caroline> Anyway, now that we're a whole bunch, feel free to go and pick something to do in https://tree.taiga.io/project/ldjamison-kohadocs-1805/epics
19:11:33 <caroline> #link https://tree.taiga.io/project/ldjamison-kohadocs-1805/epics
19:11:41 <davidnind> the manual has been updated for 20.11 (thanks Chris!) - so master is now 20.11
19:11:44 <caroline> #info check taiga for things to add to the manual
19:12:14 <davidnind> Does everyone have an account on Taiga.io? If not we should add you.
19:12:43 <kellym> I was unable to assign myself something in taiga
19:13:01 <kellym> I have a login and can see tasks, but can’t assign myself.
19:13:34 <caroline> I don't see you in the "Team" section, maybe that's why
19:14:07 <kellym> My assumption is that either I don’t have the correct permissions?  or I am doing it wrong, but if I choose a module and click on a subtask where it says unassigned, it does nothing.
19:14:21 <DonnaB> I don't think I have an account
19:15:02 <davidnind> #action add kellym and DonnaB to Taiga.io
19:15:37 <caroline> I can't remember how to add someone to the team -_-;;
19:15:41 <kellym> Also, is there someway that I can find out what I did wrong in my last submission? Who do I go to for this?  I was adding something, got a denied alert and then I am not sure my next steps
19:16:32 <caroline> Can you send me or davidnind a screenshot?
19:16:52 <davidnind> was that for a merge request?
19:17:22 <kellym> I emailed you caroline a few weeks ago, but hadn’t heard back. But I can definitely do that again!
19:18:04 <caroline> I'm so sorry! Sometimes I read emails and then forget about responding... Definitely email back if I don't respond
19:18:05 <davidnind> I can have a look after the meeting and try and sort things out, if that would suit?
19:18:48 <kellym> Cool - and no worries, I know things are busy!
19:19:12 <davidnind> I think I jumped ahead in the agenda to what's been done so far...
19:19:43 <davidnind> so we may as well do that now and then go back..
19:19:59 <koha-jenkins> Project Koha_Master_D9_MDB_Latest build #318: NOW UNSTABLE in 5 hr 19 min: https://jenkins.koha-community.org/job/Koha_Master_D9_MDB_Latest/318/
19:20:52 <davidnind> actually (sorry my chairing isn't that great today!), will stay with action points
19:21:33 <caroline> davidnind want to talk about themes?
19:21:41 <caroline> #link https://gitlab.com/koha-community/koha-manual/-/issues/14#note_355587232
19:21:58 <caroline> #link https://davidnind.gitlab.io/test-themes/
19:22:02 <davidnind> under project updates
19:22:26 <caroline> right sorry, I thought we were in projects...
19:22:36 <davidnind> #topic Project updates
19:22:54 <davidnind> I have been experimenting with themes - see issue and link above
19:23:08 <davidnind> If anyone has nay comments, that would be great
19:23:21 <jzairo> I like this theme https://davidnind.gitlab.io/test-themes/p-green/
19:23:34 <jzairo> I like how the headings stand out
19:23:50 <jzairo> screenshots look clear
19:23:55 <davidnind> I was trying to aim for keeping it simple and clean, with a bit of enhancement
19:24:09 <jzairo> I really like it, simple and clean
19:24:09 <davidnind> thanks jzairo!
19:24:19 <jzairo> davidnind++
19:24:35 <ashimema> davidnind++
19:24:45 <ashimema> Looks nice.
19:24:56 <Marie-Luce> davidnind++
19:24:58 <kellym> I like that the page of contents  stays!
19:25:07 <kellym> davidnind++
19:25:11 <davidnind> I would like to change the landing page so that is something like https://docs.python.org/3/ - provides for links to tutorials and specific guides
19:25:16 <caroline> davidnind++
19:25:21 <DonnaB> I like that one too, my only concern is the color -
19:26:16 <caroline> DonnaB how do you mean?
19:26:24 <DonnaB> https://davidnind.gitlab.io/test-themes/p-green/ can the color be something other than green? for accessbility purposes
19:26:47 <DonnaB> I've been told that green is bad for folks with color blindness
19:27:06 <davidnind> the colours can be changed
19:27:08 <caroline> I liked the green b/c Koha is green, but if it's not accessible, then it's not great
19:27:52 <DonnaB> we just need to have brendan take a look and let us know if it works for him :-)
19:28:00 <davidnind> originally I think the idea was to match the Koha theme as much as possible
19:29:02 <davidnind> how do we decide on what theme to use? I quite like the RTD theme as well...
19:29:04 <caroline> bag around?
19:29:10 <kellym> maybe the green could be more of an accent color than a main color, so if someone can’t see it well, they are not missing the content of what the green is on.
19:29:30 <caroline> I would veto this one https://davidnind.gitlab.io/test-themes/sphinxbootstrap4theme/
19:29:45 <caroline> just because the sidebar is behaving weird
19:30:16 <davidnind> me too - I was quite keen initially to have a bootstrap theme, but I think the one there would need a bot of work
19:30:17 <kellym> I like the side bar of that one!
19:30:25 <caroline> My faverite is this onw https://davidnind.gitlab.io/test-themes/sphinx-rtd-theme/
19:30:34 <davidnind> then there were three!
19:31:09 <Marie-Luce> me too, I like the highlight in the content sidebar of the sphinx-rtd-theme
19:32:16 <caroline> are we enough to vote, do you think?
19:32:32 <davidnind> So down to the RTD and PShinxTheme (with colour changes and customisations) (I didn't do any tweaking of the theme settings)
19:32:37 <DonnaB> I say yes!
19:32:48 <kellym> I like that one too, we had something like that before I believe
19:33:17 <caroline> the translated manuals have this theme https://translate.koha-community.org/manual/20.05/fr_CA/html/index.html
19:33:25 <davidnind> The RTD theme is used on th etranslation site
19:33:26 <DonnaB> just noticed the green one doesn't have the side bar, so I would switch my vote to RTD
19:34:20 <davidnind> trying to find how to vote commands.. I don't think we've ever voted on anything before!
19:34:28 <kellym> yes I like the translation one best
19:34:45 <davidnind> all the themes can be customised to some extent..
19:35:34 <tuxayo> davidnind: example: http://irc.koha-community.org/koha/2020-06-03#i_2254844
19:36:16 <davidnind> #startvote Which theme should be change to? rtd,phtyon,pshinx
19:36:16 <huginn> Begin voting on: Which theme should be change to? Valid vote options are rtd, phtyon, pshinx.
19:36:16 <huginn> Vote using '#vote OPTION'. Only your last vote counts.
19:36:43 <DonnaB> #vote rtd
19:37:29 <caroline> #vote rtd
19:37:32 <davidnind> #vote rtd
19:37:34 <jzairo> #vote rtd
19:37:34 <Marie-Luce> #vote rtd
19:37:49 <davidnind> (although I like the phython one as well)
19:38:28 <jzairo> rtd has the best features
19:38:29 <davidnind> #endvote
19:38:29 <huginn> Voted on "Which theme should be change to?" Results are
19:38:29 <huginn> rtd (5): jzairo, davidnind, caroline, DonnaB, Marie-Luce
19:39:09 <davidnind> I'll work on this further and make the change for master (which is now 20.11)
19:39:29 <tuxayo> davidnind++
19:39:33 <DonnaB> excellent! thanks david!
19:39:40 <kellym> #vote rtd
19:39:42 <caroline> davidnind++
19:39:50 <Marie-Luce> nice work!
19:39:51 <kellym> sorry got distracted!
19:39:55 <kellym> davidnind++
19:40:08 <kellym> will this change how documentation is done/process?
19:40:09 <Marie-Luce> davidind++
19:40:11 <davidnind> # davidnind to update the theme for master to sphinx-rtd-theme
19:40:31 <caroline> you forgot action
19:40:39 <davidnind> no change to how the documentation is done at this stage
19:40:49 <davidnind> #action davidnind to update the theme for master to sphinx-rtd-theme
19:41:06 <davidnind> it wasn't deliberate...:)
19:41:07 <ashimema> Awesome
19:41:12 * ashimema is lurking
19:41:15 <caroline> haha I know!
19:41:48 <davidnind> I have no updates for my other projects... https://wiki.koha-community.org/wiki/Koha_Documentation_Team#To_do_lists_and_projects
19:42:19 <caroline> Me either... actually I will remove my name from reviewing acquisitions
19:42:19 <davidnind> I know work is being done on the wiki updgrade, so I think that is getting closer
19:42:39 <caroline> I've been working on the index
19:42:50 <caroline> I have like less than 10 terms, but still...
19:43:12 <Marie-Luce> sorry...I was not able to check the documentation bugs
19:43:20 <davidnind> got to start somewhere...
19:44:04 <caroline> you'd think with libraries closed we'd have less work, but it doesn't work like that haha!
19:45:01 <davidnind> Should we add projects as GitLab issues (where they are not content related) -  I find it relatively easier to keep track of things on GitLab
19:45:25 <caroline> sure I donm't mind either way
19:45:45 <caroline> with gitlab at least we get notifications :)
19:47:42 <davidnind> #info Add projects (non-content related) as issues in GitLab (preference up to person project assigned to)
19:48:03 <davidnind> #topic What's been done so far
19:48:27 <davidnind> I think we have done some of this agenda item already
19:48:50 <davidnind> Anything else to add?
19:49:04 <caroline> I don't know about you, but I feel like action points, projects and what's been done is kind of the same thing?
19:49:41 <davidnind> Should we merge for future agendas?
19:50:15 <caroline> I feel like yeah, what about you?
19:50:40 <Marie-Luce> I will start checking those documentation bugs
19:51:03 <davidnind> That would be fine with me
19:51:13 <davidnind> Marie-Luce++
19:51:36 <davidnind> Apart from the latest merge request, everything that has come through has been merged
19:52:01 <davidnind> #topic Content development guidelines
19:52:03 <caroline> thanks davidnind++ for merging
19:52:47 <davidnind> no problem!
19:53:38 <davidnind> shall we defer my point about using contractions, as I'm conscious we've nearly been going for an hour!
19:54:42 <caroline> also maybe wait for when cait is there, more translation opinions
19:55:10 <davidnind> okay, we'll defer
19:55:22 <davidnind> For priorities, have you got anything to add caroline?
19:55:37 <davidnind> Pick something and work on it - ideally new system preferences and features
19:55:48 <caroline> yup that's pretty much it!
19:56:11 <davidnind> :)
19:56:14 <caroline> I don't think there's much that has been pushed for 20.11, so work on 20.05
19:56:22 <caroline> there's a lot to do
19:56:37 <davidnind> yes, very overwhelming!
19:57:07 <davidnind> I'm conscious that we have several new people on the team
19:58:20 <davidnind> There was a great session with jzairo via koha-US in May
19:58:43 <Marie-Luce> I'm may need some coaching
19:58:48 <davidnind> is there any interest in having hands on sessions, via Zoom or Jitsi?
19:59:01 <caroline> good idea!
19:59:22 <davidnind> I'm happy to do something, even if it is a Q&A sessions - like, how do I do XYZ, basic git workflow commands, etc.
19:59:23 <Marie-Luce> that would be awesome
19:59:47 <caroline> davidnind++
19:59:57 <davidnind> It can be a bit daunting figuring things out until you have a bit of a workflow going
20:00:16 <davidnind> would be pretty informal, and I can't promise I have all the answers
20:00:40 <Marie-Luce> any tips would be greatly appreciated
20:00:50 <DonnaB> I'd be happy to set up a Zoom if that would work
20:01:11 <davidnind> #action davidnind to organise a 'drop in session(s)' on how to contribute to the documentation
20:01:27 <davidnind> thanks DonnaB
20:02:42 <davidnind> does around this time suit, maybe on the equivalent of everyone's Friday's for maybe 1/2 an hour over the next 2-3 weeks?
20:03:17 <caroline> isn't our friday afternoon your saturday morning?
20:03:21 <caroline> Are you ok with that?
20:03:32 <davidnind> I'm okay with that
20:04:57 <DonnaB> so the first one would be what date/time in UTC?
20:06:46 <davidnind> How about next Friday 12 June 2020, 19:00 UTC? Will try Jitsi for the first one, can move to Zoom if we have problems.
20:07:01 <DonnaB> sounds good to me!
20:07:07 <davidnind> will send something to the mailing list, and happy to do any one-on-one sessions
20:07:38 <davidnind> I can always talk to myself!:-D
20:07:57 <davidnind> #topic Next meeting
20:07:58 <Marie-Luce> sounds good
20:08:15 <davidnind> Does this time suit everyone?
20:08:41 <caroline> ok for me
20:08:51 <DonnaB> ok for me!
20:09:36 <davidnind> #info Next meeting: 2 July 2020, 19:00 UTC
20:09:53 <davidnind> #endmeeting