15:01:04 <Joubu> #startmeeting Development IRC meeting 10 February 2021
15:01:04 <huginn> Meeting started Wed Feb 10 15:01:04 2021 UTC.  The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:04 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:04 <huginn> The meeting name has been set to 'development_irc_meeting_10_february_2021'
15:01:09 <Joubu> #topic Introductions
15:01:17 <Joubu> #info Jonathan Druart
15:01:20 <ashimema> #info Martin Renvoize, PTFS Europe, UK
15:01:20 <Joubu> qa_team?
15:01:20 <wahanui> rumour has it qa_team is cait, dcook, amoyano, ashimema, marcelr, kohaputti, jajm, tcohen, josef_moravec, kidclamp, khall and tuxayo
15:01:22 <Joubu> rmaints?
15:01:22 <wahanui> rmaints is fridolin, AndrewFH and tuxayo
15:01:43 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
15:01:54 <kidclamp> info Nick Clemens, ByWaterSolutions
15:02:06 <thd> #info Thomas Dukleth, Agogme, New York City
15:02:47 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_10_February_2021
15:02:54 <tuxayo> #info tuxayo/Victor Grousset, France
15:03:12 <Joubu> I have ton of things to tell you
15:03:17 <Joubu> #topic Announcements
15:03:24 <Joubu> Anyone have something?
15:03:29 <khall_> #info Kyle Hall, ByWater Solutions
15:04:07 <tcohen> nope
15:04:11 <Joubu> #topic Update from the Release Manager (21.05)
15:04:21 <Joubu> we push some interesting things lately
15:04:33 <Joubu> 1. Bug 20212 is adding all the DataTables features (we implement so far) on the parcel page
15:04:33 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20212 enhancement, P5 - low, ---, tomascohen, Pushed to master , Slowness in receiving in acquisitions
15:04:47 <Joubu> 2. Bug 25026 is turning on RaiseError on the DB handler
15:04:47 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25026 enhancement, P5 - low, ---, jonathan.druart, Pushed to master , RaiseError must be set for the UI
15:04:56 <Joubu> This is a quite big change, the SQL requests that are exploding will not longer explode silently. With bug 26048, a nice 500 will be displayed to the end user (only if not running a dev install).
15:04:57 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26048 normal, P5 - low, ---, dcook, Pushed to master , PSGI Koha does not use custom ErrorDocument pages
15:05:27 <Joubu> and I forgot the 3rd one
15:05:44 <Joubu> Then I'd like to highlight some patches I wrote in the last couple of weeks that need to be discussion/feedback/testing:
15:05:57 <Joubu> Bug 25078 - Rebuild the way our upgrade process is done. See comment 17 for screenshots.
15:05:57 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25078 enhancement, P5 - low, ---, jonathan.druart, In Discussion , Gracefully stop updatedatabase/installer when a database change cannot be applied
15:06:13 <Joubu> There is still a lot of work to do but we need first to agree on *how* that must be implemented.
15:06:23 <Joubu> Bug 27526 - Start removing MARC from our items form.
15:06:23 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27526 enhancement, P5 - low, ---, jonathan.druart, In Discussion , Remove Mod/AddItemFromMarc from additem.pl
15:06:32 <Joubu> It's only a first step, it needs to be tested carefully to let us apply it to other places where items are created/modified. Please test!
15:06:47 <Joubu> Bug 27467 - To add the ability to share a "datatable view" with an URL.
15:06:47 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27467 enhancement, P5 - low, ---, jonathan.druart, In Discussion , Provide a static URL for tables
15:07:22 <Joubu> Bug 27344 - Rely on RabbitMQ to schedule the record indexation (ES). That will speed up several workflows (see 27341). If we don't go with RabbitMQ we have to write an async solution anyway.
15:07:22 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27344 enhancement, P5 - low, ---, jonathan.druart, In Discussion , Implement Elastic's update_index_background using Koha::BackgroundJob
15:07:41 <Joubu> #info be involved on 25078, 27526, 27467 and 27344 (please)
15:07:43 <cait2> #info Katrin Fischer, BSZ, Germany
15:07:48 <ashimema> all interesting work.. all things I have on my list to work through :)
15:07:52 <Joubu> that's all for me, any questions?
15:08:00 <tcohen> reading
15:08:00 <ashimema> I've commented on many, but it would be great to get more eyes on them.
15:08:24 <Joubu> There are also things from the roadmap btw
15:08:47 <tuxayo> https://annuel.framapad.org/p/koha_21.05_roadmap
15:08:54 <Joubu> that's moving behind the scene, check the pad regularly to know what's happening
15:09:17 <ashimema> I'd like to see some improvements to the task queue system prior to bug 27344..
15:09:27 <Joubu> ha, and I am contacting "people" to get their go on removing the installer files for translated languages
15:09:42 <Joubu> it-IT answered yes, so far
15:09:46 <ashimema> I'm sold on 27344, but I feel strongly that we need to ensure that indexing doesn't get stuck behind long running batch jobs
15:10:00 <cait2> some kind of prioritizing maybe?
15:10:06 <ashimema> indexing jobs need their own worker in my opinion
15:10:07 <Joubu> ashimema: then you need several workers
15:10:12 <Joubu> that's a sysop job
15:10:35 <ashimema> except.. currently there's no way to specify what jobs a worker can take on
15:10:36 <ashimema> ;)
15:10:52 <Joubu> ashimema: but you can have several workers
15:10:59 * ashimema also wants 'delays' in the job queue system.. but that's another track entirely.
15:11:04 <Joubu> if you have 3 workers and 3 big things are running, yes, it will be delayed
15:11:12 <ashimema> indeed
15:11:14 <Joubu> And I understand your point ;)
15:11:54 <Joubu> I had a hard time getting it pushed, it's always hard for me to get back to things I need to pull strongly
15:12:03 <ashimema> also.. can our ES implementation cope with running multiple indexing simultaneously ;)
15:12:09 <Joubu> ashimema: you volunteered and I will be happy to test :)
15:12:11 <ashimema> we pass a 'bulk' call to the indexer
15:12:26 <ashimema> if we pass two with overlapping record ids what happens?
15:12:44 <Joubu> it's processed twice
15:13:02 <ashimema> I feel like we need one worker dedicated to the task.. then it can get through the queue without interuption from other jobs.. and also make sure they index runs are done in order
15:13:05 <tcohen> we need some sort of precedence, right?
15:13:12 <ashimema> it's processed twice.. that's fine
15:13:13 <ashimema> but..
15:13:41 <Joubu> I am not saying that's the perfect way of doing it, but it's the easiest for now
15:13:43 <ashimema> do we send the record data changes with our call to ES.. or do we lookup the latest version from the DB with each run?
15:13:53 <Joubu> and we absolutely need to async this task
15:13:54 <ashimema> if we send it along in the job.. then you could have them run out of order
15:14:06 <ashimema> and thus have the second run replace the first with older data
15:14:13 <ashimema> exactly..
15:14:24 <ashimema> so those are the questions I'm asking and reasons I'm asking them ;)
15:14:35 <ashimema> anywho.. it's a great way to go.. just needs a little more ;)
15:15:04 <Joubu> I am joining you if you want to improve it :)
15:15:20 * ashimema has soooooo many projects on the go right now..
15:15:30 <cait2> that's a general problem :)
15:15:33 <ashimema> but will certainly try to make some time for this one too
15:15:51 <ashimema> I did add a bug to clarify the warning on the about page for the message broker
15:16:05 <ashimema> that's my very first step at looking at the background jobs code more clearly
15:16:21 <thd> Is there a means to sequence separate worker index processes?
15:16:22 <ashimema> I don't like right now that we have to change lots of files to list the jobs
15:16:41 <ashimema> adding a job type should be as simple as adding a class file to me..
15:16:55 <ashimema> you shouldn't then have to list it in various places for it to actually ever get called
15:17:03 <ashimema> anywho.. I digress ;)
15:17:06 <ashimema> lets move on
15:17:06 <Joubu> ashimema: let's discuss this after the meeting
15:17:13 <ashimema> +1
15:17:29 <Joubu> yes, 1 file should ineherit, and overwrite things. But then it get more complex :)
15:17:36 <Joubu> other questions?
15:17:38 <ashimema> thd.. not yet ;)
15:18:01 <Joubu> #topic Updates from the Release Maintainers
15:18:51 <Joubu> rmaints?
15:18:51 <wahanui> it has been said that rmaints is fridolin, AndrewFH and tuxayo
15:18:56 <Joubu> nothing special?
15:19:12 <Joubu> #topic Updates from the QA team
15:19:16 <tuxayo> 19.11: Not much, catching up with the flow of patches resulting from the Catalyst academy :D
15:19:58 <cait2> Not much special for QA I think
15:20:03 <cait2> Please do QA! :)
15:20:12 <Joubu> #info Please do QA!
15:20:24 <cait2> Numbers are a little too high for my liking in the queue right now and we have some things from last year still waiting
15:20:32 <ashimema> as ever, cait2 has set us a challenging target to try and knock her off the top spot
15:20:40 <ashimema> someone help me kick her off ;)
15:20:49 <cait2> you can band up on me, I really don't mind :)
15:20:58 <Joubu> cait2 added a new entry on the agenda, "Status of roadmap projects"
15:21:03 <ashimema> kohaputti++ # not shying away from the bigger scary QA's
15:21:12 <cait2> yes, kohaputti++ definitely worth a shoutout
15:21:12 <Joubu> I will try to prepare it for the next dev meeting, asking the different groups where they are
15:21:22 <fridolin> #info Fridolin Somers, Biblibre, France
15:21:28 <ashimema> he should get extra points..
15:21:28 <cait2> i think maybe we could do some quick ones for the ones that have people present?
15:21:34 * fridolin nothing special
15:21:39 <cait2> not going through all of them
15:22:18 <Joubu> can try
15:22:26 <Joubu> #topic Status of roadmap projects
15:22:34 <Joubu> #link https://annuel.framapad.org/p/koha_21.05_roadmap
15:22:46 <Joubu> #topic Improve the reliability of transfers
15:22:51 <Joubu> ashimema: ?
15:23:16 <ashimema> #info Joonas has QA'd the Phase One tree :)
15:23:19 <Joubu> There is a huge pile of things that is hitting my QA
15:23:21 <Joubu> queue*
15:23:52 <ashimema> #info Looking for someone to QA the final bug on that tree which adds a nice 'Transfers to send' report.
15:24:14 <ashimema> #info Phase one adds all the methods we need for transfers to the Koha:: namespace, with clear uses and workflows for each
15:24:20 <Joubu> I can try and review it next week
15:24:30 <cait2> #info cait to check the old transfer bugs to give the new work some serious testing once pushed
15:24:34 <Joubu> will be mostly off the week after, so... you know what to do
15:24:38 <ashimema> #info Phase two will remove the last remaining cases where the C4 methods are used and drop those methods.
15:24:49 <ashimema> thanks Joubu :)
15:24:59 <Joubu> #toic
15:25:03 <Joubu> #topic Performance investigation
15:25:09 <ashimema> ?
15:25:23 <Joubu> It's related to using the task queue for ES reindex
15:25:29 <ashimema> :)
15:25:49 <Joubu> I need to redo some benchmarks and see if it lower the difference in exec time
15:25:50 <ashimema> #info First major identification lead to the backgrounding of the ES indexer bug.. work ongoing :)
15:26:11 <cait2> thx for doing the stats, it's really interesting
15:26:21 <ashimema> Joubu++
15:26:27 <Joubu> it almost burn my laptop everytime I run the benchmark
15:26:42 <Joubu> I bought a new CPU fan, so can continue the benchmark, but I am a bit hesitant :D
15:26:47 <ashimema> stick it in a fridge
15:26:51 <Joubu> #topic Git repository shrinking
15:26:52 <cait2> don't kill the laptop
15:27:08 <tuxayo> lol
15:27:17 <Joubu> I need to start this one! I am really excited about it
15:27:30 <Joubu> certainly in March
15:27:46 <ashimema> :)
15:27:48 <Joubu> #topic Release tools improvements
15:28:03 <Joubu> ashimema and me, we need to focus on that one, maybe closer from the release, like April
15:28:11 <Joubu> #topic Backup splitter on a separate server
15:28:13 <Joubu> we have it!
15:28:15 <ashimema> brill
15:28:18 <ashimema> :)
15:28:21 <cait2> awesome :)
15:28:25 <Joubu> https://splitter2.koha-community.org
15:28:36 <Joubu> still need to sync the DB from the original server however
15:28:42 <ashimema> #info Splitter backup is now available at https://splitter2.koha-community.org
15:28:50 <ashimema> ah yes
15:28:56 <cait2> #link https://splitter2.koha-community.org
15:28:57 <tuxayo> confetti!
15:28:57 <wahanui> o/`'`'`'`'`'`'`'`'`'`'`'`
15:29:00 <Joubu> I've added few commits, like the "Latest patch from" date on https://splitter2.koha-community.org/files
15:29:06 <Joubu> to tell us if it's up-to-date or not
15:29:18 <ashimema> nice
15:29:21 <cait2> shoudl we add it to the wiki page yet?
15:29:29 <Joubu> I will and it will be done
15:29:41 <cait2> ok
15:29:47 <Joubu> I haven't communicated on it yet as the DB is still not updated
15:30:03 <Joubu> (must be updated every night, I am in touch with rangi)
15:30:10 <Joubu> #topic Improve our "news" module
15:30:27 <cait2> sec
15:30:37 <Joubu> There are some (private) discussions, we are in a FQA state for now
15:30:55 <Joubu> the idea is to start with what is submitted yet, then improve a bit more the UI
15:30:59 <cait2> #info we discussed the different uses cases and probably a new naming scheme for the future, but moving forward with the move to the Koha namespace first
15:31:09 <Joubu> like we should rename this, from "news" to.. "additional contents"?
15:31:19 <ashimema> I'll try to get to look at the current submission again soon
15:31:23 <Joubu> more info coming in the next weeks certainly
15:31:32 <ashimema> +1
15:31:34 <Joubu> ashimema: I FQAed it last week
15:31:49 <Joubu> but you can fix if you don't want to wait for Josef :)
15:31:58 <ashimema> I Josef aware and looking at fixes..?
15:32:07 <ashimema> that's kinda what I meant.. take a look, see if he needs a hand
15:32:13 <Joubu> I sent him a ping
15:32:19 <ashimema> :)
15:32:22 <cait2> i guess it would be appreciated
15:32:44 <ashimema> soooo many projects on the go
15:32:51 <Joubu> (I did CC you ashimema! :D)
15:32:54 <cait2> but some are moving, that's nice :)
15:33:01 <ashimema> ah yes.. so you did
15:33:03 <Joubu> #topic Fix OPACHiddenItems [Bug 24403]
15:33:03 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24403 normal, P5 - low, ---, koha-bugs, NEW , [OMNIBUS] OpacHiddenItems should hide items everywhere in the OPAC
15:33:06 <Joubu> tcohen: around?
15:33:40 <cait2> there are curently no patches to test for this one I am aware of
15:33:41 <Joubu> it's ongoing, a bit slow right now but the first step has been pushed already
15:33:54 <Joubu> waiting for tcohen to write more things to test!
15:34:02 <cait2> i think that sums it up
15:34:03 <Joubu> #topic Handling of errors 500
15:34:06 <Joubu> that's done
15:34:11 <Joubu> (and that's awesome)
15:34:15 <cait2> should we mark it in the reaodmap?
15:34:23 <Joubu> see bug 26048
15:34:23 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26048 normal, P5 - low, ---, dcook, Pushed to master , PSGI Koha does not use custom ErrorDocument pages
15:34:31 <Joubu> it's almost done :)
15:34:39 <Joubu> we need to make it pretty now
15:34:57 <Joubu> see bug 27555, bug 27556 and bug 27557
15:34:57 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27555 enhancement, P5 - low, ---, koha-bugs, NEW , Use psgi_env from errors/* controller scripts
15:34:58 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27556 enhancement, P5 - low, ---, koha-bugs, NEW , Improve error pages
15:34:59 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27557 enhancement, P5 - low, ---, koha-bugs, NEW , Add the ability to display the error that caused a 500
15:35:12 <Joubu> waiting for dcook
15:35:24 <Joubu> (At least I am waiting for him)
15:35:27 <ashimema> :)
15:35:32 <Joubu> #topic Developer handbook and documentation
15:35:36 <Joubu> this is.. stuck
15:35:43 <Joubu> devs don't want to write documentation
15:35:53 <Joubu> I think that's the conclusion
15:35:57 <Joubu> (we knew that already)
15:36:10 * ashimema just has too many projects on..
15:36:21 <cait2> I think there was some discussion about how to use a different tool than the wiki maybe
15:36:25 <Joubu> yes, that's a big one, and we don't really know where to start
15:36:36 <Joubu> rm wiki; mkdir wiki
15:36:47 <cait2> i proposed a fresh start a whlie ago
15:36:49 <ashimema> I liked the advent calendar.. but I feel we took on too much too late with that
15:37:01 <cait2> once i get a bit more free time i could try to do some wiki weeding at least
15:37:15 <cait2> it was still very worthwhile
15:37:16 <ashimema> perhaps we could do a series similar to it.. but with a clearer timetable that commits us to writing stuff.. but not all at once
15:37:40 <cait2> it would be nice to see these kinds of things also linked to the website somehow
15:37:44 <Joubu> maybe we should ask the dev list?
15:37:45 <cait2> it was on social media, but harder to find there
15:38:00 <Joubu> on which topics you need more tech info/examples?
15:38:04 <cait2> need to get at least some links on the official pages
15:38:12 <cait2> i tihnk Rest API
15:38:13 <ashimema> it was very much a first go.. I'd love to see us do it again next year.. but with more planning and more officially
15:38:17 <Joubu> if we get no answer, we can forget about it :D
15:38:23 <cait2> but ithink the calendar covered that?
15:38:25 <cait2> maybe
15:38:33 <cait2> the information in the wiki is very scattered there
15:38:37 <ashimema> that was the focus area of the calendar..
15:38:39 <cait2> lots of discussion things where the status is not clear
15:38:40 <ashimema> but I've learnt allot since
15:38:43 <Joubu> ashimema: it's in my calendar already :D
15:38:53 <ashimema> I could happily add a few more articles now I've learnt some more :)
15:38:57 <ashimema> awesome Joubu :)
15:39:13 <cait2> it might also be time to review installation guides and such?
15:39:22 <cait2> the more boring things
15:39:37 <Joubu> I think that's the only ones that are up-to-date
15:39:52 <cait2> maybe :)
15:40:07 <cait2> what about a series explaining more about the Koha objects?
15:40:10 <ashimema> I feel the wiki upgrade has got us stuck for a very long time.. as that's still a work in progress... and may continue to be for some time to come.. I agree.. lets move the dev book to another platform
15:40:15 <cait2> i'd read it... if you start really low barrier
15:40:46 <Joubu> ashimema: it's yet another places
15:40:49 <ashimema> I sort of feel the guidelines could live in such a place too.. made clearer as an apendix to such a 'book'
15:40:54 <ashimema> mmm
15:41:06 <Joubu> I am not totally against the idea
15:41:07 <cait2> i think the wik woruld work, but some features currently don't work quite right
15:41:13 <cait2> and i believe we shoudl tidy up some stuff
15:41:21 <ashimema> indeed
15:41:26 <Joubu> but we will copy some info from the wiki, that might add confusion
15:41:34 <ashimema> anyways.. happy to help when we know a direction
15:41:37 <cait2> there is tons of old rfcs that never got implemented as described or at all
15:41:39 <cait2> for example
15:41:39 <wahanui> for example is not fixed
15:41:42 <cait2> it can get really ocnfusing
15:41:57 <ashimema> the wiki is a mess..
15:41:58 <Joubu> we need to obsolete those pages
15:42:07 <cait2> yes
15:42:11 <Joubu> ok
15:42:14 <thd> Yes, I am stuck with a death of a former employer leaving a mountain of books and other things to address for the past few months,
15:42:17 <caroline> I'm happy to help if I can
15:42:45 <Joubu> we will take over thd, we need it to be done. I will try to find some time during the next cycle
15:42:54 <cait2> we could still start with a new installation and move stuff that is good maybe? I am not sure it's worth a big amount of effort really
15:43:08 <ashimema> +1
15:43:14 * ashimema like fresh
15:43:19 <Joubu> yes
15:43:26 <Joubu> that's for later :)
15:43:33 <Joubu> good to know we are 4 already
15:43:39 <ashimema> Slips: I've not had allot of time to focus on this one yet.. it's likely to get bits of movement soon, but will also carry on into the next cycle.  Migrating the accounts slips to GetPrepparedLetter marks the start of me looking at this again.
15:43:42 <Joubu> moving on
15:43:45 <cait2> more than 4 even i think :)
15:43:48 <ashimema> ;)
15:44:09 <Joubu> #topic Automated updates for translated manuals
15:44:27 <Joubu> ashimema, cait2 , caroline: did something happen?
15:44:47 <caroline> no, I'm not sure we decided anything
15:45:04 <cait2> i think we still lack the technical "plan" for it
15:45:07 <cait2> for the automation
15:45:15 <ashimema> I worked to get the pull request process working more cleanly
15:45:44 <ashimema> that now works.. i.e if caroline goes to the secret tools page, she can request a merge-request to get the latest translations and can merge them into the manual
15:46:04 <cait2> and we might want to branch out 20.11 soon? currently no translations are built at all for 20.11
15:46:08 <caroline> I have to remember to do it, which I don't :(
15:46:22 <ashimema> as for automating.. I need to talk to rangi or wizzyrea.. so we can do regular rsyncs
15:46:27 <ashimema> or use bernardo's server
15:46:27 <caroline> I was trying to find how to branch earlier today
15:46:37 <ashimema> if the translate server has the space.. perhaps we just use that..
15:46:38 <caroline> but that's another matter
15:46:40 <caroline> there was the duplication between translate.k-c and manual.k-c that we needed to address
15:46:47 <ashimema> the community website server is struggling for space
15:47:04 <caroline> )I've had several failed pipes again today)
15:47:19 <cait2> there is some visual ifference in styling, but otherweise i'd be happy if we pointed to the tanslation server for the translated ones
15:47:45 <cait2> maybe need to ask bernardo, as the translation server is struggling a bit too currently
15:48:11 <ashimema> I'm happy to get it working.. just need to know what people want..
15:48:44 <cait2> we shoudl still regularly push the po files to another repo... having copies is good
15:48:49 <caroline> I'll email bernardo and ask if we can point to his translated manuals or if he has an idea
15:49:15 <ashimema> okies
15:49:22 <ashimema> next?
15:49:22 <wahanui> next is Koha bibliography in Zotero
15:49:30 * ashimema wants to get out for his walk
15:49:46 <Joubu> moving out
15:49:58 <Joubu> you will discuss detail off meeting :)
15:50:04 <Joubu> #topic Koha Cookbook Project
15:50:22 <Joubu> We had a meeting, setup a git project
15:50:30 <Joubu> next date is March, for another meeting
15:50:36 <cait2> :)
15:50:58 <Joubu> #topic Replace CGI scripts with Mojolicious controllers
15:51:15 <Joubu> I haven't heard anything about that
15:51:20 <Joubu> #topic Write Protecting fields in Koha from being overwritten through import
15:51:40 <Joubu> there are movements there
15:51:43 <cait2> it just got a rebase
15:51:45 <cait2> yes
15:51:45 <Joubu> but I haven't followed closely
15:51:58 <Joubu> bug 14957
15:51:58 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14957 enhancement, P5 - low, ---, glasklas, Failed QA , Write protecting MARC fields based on source of import
15:51:58 <wahanui> i guess bug 14957 is rebased against master I see
15:52:03 <ashimema> happy to help with QA there cait.. if you wanted to double team it.
15:52:04 <cait2> i'll try to get in touchwith AndrewFH
15:52:14 <cait2> that soudns good
15:52:26 <Joubu> ashimema: stop adding stuffs to you list!
15:52:32 <ashimema> hehe
15:52:39 <cait2> yeah he is terrible at that
15:52:40 * ashimema helps with all the things
15:52:41 <Joubu> your*
15:52:45 <ashimema> "helps"
15:52:47 <cait2> and i am enabling him...
15:53:02 <cait2> lol
15:53:03 <Joubu> we will have to limit to 4 topics next cycle
15:53:06 <Joubu> or 5
15:53:08 <Joubu> or 6
15:53:08 <cait2> and once done
15:53:10 <Joubu> ..
15:53:11 <cait2> we can add more
15:53:15 <cait2> no 4 is good
15:53:23 <ashimema> well.. I'm not the RM anymore.. so can throw myself into code a bit more again :)
15:53:24 <cait2> and oly can add one from backlog, when one is done
15:53:36 <cait2> finishing?
15:53:39 <Joubu> yes
15:53:40 <ashimema> 4 is good
15:53:43 <Joubu> #topic Actions from last meeting
15:54:00 <Joubu> #action amoyano advertise 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc.
15:54:06 <Joubu> will stop to postpone this one I think
15:54:06 <ashimema> We need a clear roadmap/backlog to pick of more strictly in general
15:54:12 <ashimema> good plan
15:54:15 <Joubu> haven't got reply
15:54:45 <Joubu> #topic  Review of coding guidelines
15:54:50 <Joubu> "     Terminology list - proposed addition for OPAC: use OPAC instead of opac or OPAC for online public access catalog, including in system preference names. (davidnind) "
15:54:58 <Joubu> I don't get it
15:55:14 <cait2> maybe ... or catalog?
15:55:24 <ashimema> pass
15:55:26 <cait2> or Opac
15:55:32 <cait2> i had a discussion with him on a bug about this
15:55:34 * ashimema switches to mobile
15:55:41 <cait2> the rename pref AllowOPACLists one
15:55:49 <cait2> maybe we can ask to clarify
15:55:57 <cait2> but i think it#s about the different spellings
15:55:59 <cait2> int he prefs
15:56:17 <Joubu> ok, will ask him and postpone
15:56:20 <cait2> use OPAC instead of Opac or opac
15:56:22 <Joubu> #topic Set time of next meeting
15:56:40 <Joubu> #info Next meeting: 24 February 2021, 20 UTC
15:56:42 <Joubu> is that correct?
15:57:11 <Joubu> #endmeeting