#koha: Development IRC meeting 10 March 2021

Meeting started by Joubu at 14:59:49 UTC (full logs).

Meeting summary

  1. Introductions (Joubu, 15:00:00)
    1. Jonathan Druart (Joubu, 15:00:07)
    2. Nick Clemens, ByWater Solutions (kidclamp, 15:00:12)
    3. tuxayo/Victor Grousset, France (tuxayo, 15:00:24)
    4. https://wiki.koha-community.org/wiki/Development_IRC_meeting_10_March_2021 (Joubu, 15:00:27)
    5. Andrew Fuerste-Henry, ByWater Solutions (AndrewFH, 15:00:30)
    6. Thomas Dukleth, Agogme, New York City (thd, 15:01:26)
    7. Fridolin, Biblibre, France (fridolin, 15:02:34)

  2. Announcements (Joubu, 15:02:35)
    1. Martin Renvoize, PTFS Europe (ashimema, 15:02:41)
    2. PTFS Europe sandboxes now support installation of German, French, Spanish, Greek and Dutch translations. (ashimema, 15:03:36)

  3. Update from the Release Manager (21.05) (Joubu, 15:04:14)
    1. There is now a --run-tests option to the QA script to run the tests modified by the patchset (Joubu, 15:04:54)
    2. we now have a new docker_7 node (Joubu, 15:05:16)
    3. Katrin Fischer, BSZ, Germany (cait1, 15:05:39)
    4. There is a "light test suite" that is run by Jenkins for most of the job (apart from D10) - checkout https://tree.taiga.io/project/koha-ils/task/102 for more info (Joubu, 15:05:53)

  4. Updates from the Release Maintainers (Joubu, 15:12:33)
  5. Updates from the QA team (Joubu, 15:15:13)
    1. More QA needed... always more QA needed :P (ashimema, 15:15:43)
    2. Status of roadmap projects (Joubu, 15:17:34)
    3. https://annuel.framapad.org/p/koha_21.05_roadmap (Joubu, 15:17:44)
    4. Tomas Cohen Arazi, Theke Solutions (tcohen, 15:25:27)

  6. Automated updates for translated manuals (Joubu, 15:40:46)
  7. Actions from last meeting (Joubu, 15:44:50)
    1. amoyano advertise Bug 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc. (Joubu, 15:44:58)
    2. General development discussion (trends, ideas, ...) (Joubu, 15:45:31)

  8. General development discussion (trends, ideas, ...) (Joubu, 15:45:40)
  9. Systemd, Containerisation, Packaging, Other... we need a long term goal and roadmap for these things. - Bug 25674 (Joubu, 15:45:48)
    1. we need a long term goal and roadmap (Joubu, 15:46:35)
    2. https://wiki.koha-community.org/wiki/Building_Debian_Packages (cait1, 15:54:24)
    3. https://wiki.koha-community.org/wiki/Building_Debian_Packages_-_The_Easy_Way (cait1, 15:54:40)
    4. https://wiki.koha-community.org/wiki/How_was_my_Koha_installed (how to figure out which package?) (cait1, 15:55:18)
    5. https://wiki.koha-community.org/wiki/Building_Debian_Dependencies (cait1, 15:55:53)
    6. ACTION: mtj write something about the new packages for the 21.05 release notes (Joubu, 15:58:07)

  10. Should we add a coding guideline to clarify our message types: 'alert' vs 'error' - Bug 27695 (Joubu, 15:58:27)
    1. ACTION: ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695) (Joubu, 15:59:09)

  11. We should reverse our 'title' elements - Bug 26703 (Joubu, 15:59:18)
    1. ACTION: Joubu we need to push 26703 asap (Joubu, 16:01:44)
    2. ACTION: ashimema Write a guideline for 26703 (Joubu, 16:02:12)

  12. Review of coding guidelines (Joubu, 16:02:25)
  13. On last meeting (24 feb) it was voted "using OPAC instead of Opac or opac", but it was forgotten to find someone to phrase it and add it to the guidelines. (Joubu, 16:02:33)
    1. ACTION: ashimema write a guideline about using "OPAC instead of Opac or opac" (Joubu, 16:03:06)
    2. "OPAC instead of Opac or opac" is on the Terminology wiki page (Joubu, 16:03:53)

  14. Set time of next meeting (Joubu, 16:04:10)
    1. Next meeting: 24 March 2021 20 UTC (Joubu, 16:04:18)
    2. Next meeting: 24 March 2021, 20 UTC (Joubu, 16:04:25)


Meeting ended at 16:05:08 UTC (full logs).

Action items

  1. mtj write something about the new packages for the 21.05 release notes
  2. ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695)
  3. Joubu we need to push 26703 asap
  4. ashimema Write a guideline for 26703
  5. ashimema write a guideline about using "OPAC instead of Opac or opac"


Action items, by person

  1. ashimema
    1. ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695)
    2. ashimema Write a guideline for 26703
    3. ashimema write a guideline about using "OPAC instead of Opac or opac"
  2. Joubu
    1. Joubu we need to push 26703 asap


People present (lines said)

  1. Joubu (145)
  2. ashimema (90)
  3. cait1 (72)
  4. huginn (24)
  5. tuxayo (18)
  6. fridolin (8)
  7. wahanui (4)
  8. thd (4)
  9. AndrewFH (2)
  10. kidclamp (1)
  11. tcohen (1)


Generated by MeetBot 0.1.4.