#koha: Development IRC meeting 21 April 2021

Meeting started by Joubu at 14:00:20 UTC (full logs).

Meeting summary

  1. Introductions (Joubu, 14:00:31)
    1. Jonathan Druart (Joubu, 14:00:40)
    2. Tomas Cohen Arazi, Theke Solutions (tcohen, 14:00:54)
    3. Nick Clemens, ByWater Solutions (kidclamp, 14:00:56)
    4. Thomas Dukleth, Agogme, New York City (thd, 14:01:05)
    5. Henry Bolshaw, House of Lords Library, UK (henryb, 14:01:19)
    6. Joy Nelson, ByWater Solutions (talljoy, 14:01:24)
    7. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 14:01:31)
    8. https://wiki.koha-community.org/wiki/Development_IRC_meeting_21_April_2021 (Joubu, 14:01:43)

  2. Announcements (Joubu, 14:02:06)
    1. Martin Renvoize, PTFS-Europe (ashimema, 14:02:35)

  3. Update from the Release Manager (21.05) (Joubu, 14:03:00)
    1. Katrin Fischer, BSZ, Germany (cait, 14:04:33)
    2. https://bugs.koha-community.org/bugzilla3/buglist.cgi?cmdtype=dorem&list_id=369387&namedcmd=Needs%20release%20notes&remaction=run&sharer_id=378 (Joubu, 14:05:35)
    3. Kyle M Hall, ByWater Solutions (khall, 14:05:44)
    4. keep an eye on the 21.05 candidate list https://frama.link/koha_bz_rel_21_05_candidate (Joubu, 14:05:57)
    5. Watchout the missing release notes! https://bugs.koha-community.org/bugzilla3/buglist.cgi?cmdtype=dorem&list_id=369387&namedcmd=Needs%20release%20notes&remaction=run&sharer_id=378 (Joubu, 14:06:16)

  4. Updates from the QA team (Joubu, 14:09:50)
  5. Updates from the Release Maintainers (Joubu, 14:14:33)
    1. April releases are expected for Monday 26th (Joubu, 14:15:38)

  6. Status of roadmap projects (Joubu, 14:20:40)
    1. Mason James, NZ (mtj, 14:22:44)

  7. Actions from last meeting (Joubu, 14:22:57)
  8. Joubu create the "roles for 21.11" wiki page and send an email to the list (Joubu, 14:23:04)
    1. https://wiki.koha-community.org/wiki/General_IRC_meeting_12_May_2021 (Joubu, 14:24:20)

  9. mtj write something about the new packages for the 21.05 release notes (Joubu, 14:25:00)
    1. New wiki page to explain the different debian packages has been written - https://wiki.koha-community.org/wiki/Package_types (Joubu, 14:25:41)

  10. ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695) (Joubu, 14:25:56)
    1. ACTION: ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695) (Joubu, 14:26:35)

  11. General development discussion (trends, ideas, ...) (Joubu, 14:26:46)
  12. Email unsubscribe - CAN-SPAM / GDPR - how to implement opt-out for Koha (Joubu, 14:26:54)
    1. tuxayo/Victor Grousset, France (tuxayo, 14:35:57)
    2. ACTION: kidclamp Ask the ML for additional info about how to implement opt-out for notices. One idea would be to have "My message" at the OPAC (Joubu, 14:40:04)

  13. Set time of next meeting (Joubu, 14:40:23)
    1. Next meeting: 5 May 2021 14 UTC (Joubu, 14:41:06)


Meeting ended at 14:41:31 UTC (full logs).

Action items

  1. ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695)
  2. kidclamp Ask the ML for additional info about how to implement opt-out for notices. One idea would be to have "My message" at the OPAC


Action items, by person

  1. ashimema
    1. ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695)
  2. kidclamp
    1. kidclamp Ask the ML for additional info about how to implement opt-out for notices. One idea would be to have "My message" at the OPAC


People present (lines said)

  1. Joubu (81)
  2. cait (52)
  3. ashimema (29)
  4. kidclamp (16)
  5. huginn (9)
  6. oleonard (5)
  7. tcohen (4)
  8. talljoy (4)
  9. henryb (3)
  10. koha-jenkins (3)
  11. thd (3)
  12. tuxayo (2)
  13. mtj (2)
  14. maya-das (2)
  15. wahanui (1)
  16. khall (1)


Generated by MeetBot 0.1.4.