20:05:48 <tuxayo> #startmeeting Development IRC meeting 24 February 2021
20:05:48 <huginn> Meeting started Wed Feb 24 20:05:48 2021 UTC.  The chair is tuxayo. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:05:48 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:05:48 <huginn> The meeting name has been set to 'development_irc_meeting_24_february_2021'
20:05:59 <tuxayo> #topic Introductions
20:06:10 <tuxayo> Let's restart ^^"
20:06:12 <tuxayo> #info tuxayo/Victor Grousset, France
20:06:15 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
20:06:33 <ashimema> #info Martin Renvoize, PTFS Europe
20:06:45 <ashimema> from mobile
20:07:11 <ashimema> Rmaints
20:07:16 <caroline> its been pretty quiet today on irc
20:07:22 <ashimema> Rmaints?
20:07:22 <wahanui> Rmaints is fridolin, AndrewFH and tuxayo
20:07:29 <tuxayo> qa_team?
20:07:29 <wahanui> qa_team is cait, dcook, amoyano, ashimema, marcelr, kohaputti, jajm, tcohen, josef_moravec, kidclamp, khall and tuxayo
20:07:34 <ashimema> QA?
20:07:34 <wahanui> somebody said QA was unhappy about that, please fix
20:07:43 <oleonard> Good one wahanui
20:07:45 <cait> #info Katrin Fischer, Germany
20:07:49 <cait> ooops
20:07:49 <ashimema> Hehe
20:08:16 <ashimema> Good to have you
20:08:51 <tuxayo> #topic Announcements
20:09:26 <tuxayo> Nothing in the meeting wiki page
20:09:27 <tuxayo> anything from anyone?
20:09:46 <ashimema> Nada
20:09:55 <cait> i don't have anything either
20:10:26 <tuxayo> #topic Update from the Release manager (21.05)
20:10:52 <tuxayo> #info apologies from Joubu: (mostly afk this week)
20:10:59 <cait> thx tuxayo
20:11:05 <cait> tuxayo++
20:11:23 <tuxayo> #topic  Updates from the Release Maintainers
20:12:16 <tuxayo> #info 2 security fixes and one bad bug that managed to get into this release (all 3 branche). team++
20:12:52 <ashimema> Well done Rmaints
20:12:54 <tuxayo> #topic Updates from the QA team
20:13:10 <tuxayo> well done quick QA also ^^
20:13:20 <thd> #info Thomas Dukleth, Agogme, New York City
20:14:20 <ashimema> As ever, QA load needs spreading more...
20:14:34 <ashimema> But the queues are slowly getting worked through by the usual suspects
20:14:46 <ashimema> A few bigger things recently hitting PQA
20:14:51 <ashimema> Which is great
20:15:00 <ashimema> But still plenty to do
20:15:18 <tuxayo> I'm trying at the oldest ones in queue, found 1 out of 8 that I could review :)
20:15:39 <tuxayo> (failed QA :P (minor QA script issue))
20:15:55 <ashimema> I intend to dig into the task queue bugs this coming month.. I feel like we really need to move a few things forward there for 20.11 to be really usable.
20:15:59 <ashimema> Personally..
20:16:44 <tuxayo> #topic Status of roadmap projects
20:16:57 <tuxayo> #link https://annuel.framapad.org/p/koha_21.05_roadmap
20:17:28 <tuxayo> News from projects?
20:18:08 <ashimema> #info Notices and Slips improvements slowly starting to move forward.. some foundational bugs need testing/QA . Listed on the pad
20:19:03 <ashimema> #info Translations.. not moved since last meeting.. needs a retest and getting moving again.  Fresh eyes welcome
20:20:10 <ashimema> #info Transfers - Phase one is PQA, awaiting Joubu's review and push
20:20:14 <ashimema> #info Money - Likely delayed to next cycle
20:20:59 <ashimema> #info Performance - Moving ES indexing to background jobs.. background job infrastructure work underway to support this move better
20:21:35 <ashimema> #info Git shrinking - Joubu and I will look into this again soon
20:22:05 <ashimema> #info News - On my list to revisit.. not sure of current state.
20:22:22 <ashimema> The rest I'm not up to speed on.. please chip in of you know anything
20:22:51 <ashimema> Ooh . Manual translations
20:23:50 <ashimema> #info Manual translations - The hosting is currently being upgraded for disk space which should get us back to building.  The. We need to get back to next steps again.
20:23:58 <ashimema> All your tuxayo :)
20:24:14 <tuxayo> Thanks for all the news :)
20:24:26 <tuxayo> #topic Actions from last meeting
20:24:50 <tuxayo> #action amoyano advertise 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc.
20:25:25 <tuxayo> #topic General development discussion (trends, ideas, ...)
20:25:47 <tuxayo> «When do we upgrade our yarn.lock? Right before the release seems a bit hazardous! After seems a bit too late...
20:25:49 <tuxayo> Part of the RM process and anytime there is a change we push it? »
20:26:03 <tuxayo> Does anyone know about this topic?
20:26:31 <oleonard> yarn.lock contains information about node modules and what versions should be installed
20:26:45 <oleonard> The upgrade process raises the version numbers
20:26:51 <tuxayo> a manual wikiblame has shown that it's a topic from Joubu ^^
20:26:51 <ashimema> I've asked myself that question a few times.. but never come up with a suitable answer
20:27:09 <oleonard> There is some potential for breakage when modules are upgraded, but I don't have specific experience to guide me.
20:28:06 <ashimema> We're still only using node for dev tasks though right...?
20:28:22 <ashimema> So not too horrific consequences
20:28:41 <tuxayo> I think so, only dev
20:29:17 <ashimema> If/when we move to front end framework if we use yarn/npm there weay need to be more careful
20:30:04 <ashimema> [off] I regularly get warned about old node dependencies we use
20:30:22 <tuxayo> Because yarn/npm will then be used for installation and update of Koha right?
20:30:39 <ashimema> Mmm
20:30:42 <ashimema> Indeed
20:31:25 <ashimema> I'm not the best to advise.. it's been on my list for years to get myself up to date in that scene
20:31:38 <thd> Common frameworks should make things more robust, not more brittle :)
20:32:39 <ashimema> Mmm
20:33:07 <oleonard> I think ashimema's point about node only being for dev tasks is a good one
20:33:23 <oleonard> I think it means the RM should have lots of leeway for doing the upgrade.
20:35:01 <tuxayo> #topic Review of coding guidelines
20:35:17 <tuxayo> «Terminology list - proposed addition for OPAC: use OPAC instead of opac or OPAC for online public access catalog,
20:35:18 <tuxayo> including in system preference names. (davidnind) »
20:35:58 <tuxayo> Are we enough people to review coding guidelines?
20:36:50 <tuxayo> Confused about: «or OPAC for online public access catalog»
20:38:10 <oleonard> I think this is specifically about using capitalized "OPAC" in system preferences
20:38:58 <tuxayo> That makes sense with «use OPAC instead of opac» but I don't get the rest
20:39:17 <oleonard> Nor do I.
20:39:22 <oleonard> There he is
20:39:55 <tuxayo> hi davidnind  :)
20:40:34 <davidnind> I'm not sure what I meant either? Just meant  to use OPAC instead of Opac or opac in things like system preferences.
20:40:41 <davidnind> hi tuxayo!
20:40:57 <tuxayo> ok, it clear now :)
20:41:00 <tuxayo> *it's
20:42:09 <oleonard> Agreed. It's official. Motion passes. Unanimous.
20:42:27 <tuxayo> Shall we call a vote? We are around 7 people I think
20:42:32 <tuxayo> lol oleonard
20:42:56 <thd> +1
20:43:18 <davidnind> +1
20:43:42 <oleonard> +1
20:44:49 <tuxayo> #startvote Ok for using OPAC instead of Opac or opac? (no, yes, abstain)
20:44:49 <huginn> Begin voting on: Ok for using OPAC instead of Opac or opac? Valid vote options are , no, yes, abstain, .
20:44:49 <huginn> Vote using '#vote OPTION'. Only your last vote counts.
20:44:57 <tuxayo> finally found the syntax!
20:45:10 <tuxayo> #vote yes
20:45:12 <oleonard> #vote yes
20:45:21 <tuxayo> sorry for the delay
20:45:34 <davidnind> #vote yes
20:45:34 <thd> #vote yes
20:46:14 <tuxayo> Closing in 1min. cc cait ashimema caroline
20:47:40 <tuxayo> #endvote
20:47:40 <huginn> Voted on "Ok for using OPAC instead of Opac or opac?" Results are
20:47:40 <huginn> yes (4): oleonard, tuxayo, thd, davidnind
20:48:07 <tuxayo> #topic Set time of next meeting
20:49:17 <tuxayo> This was the late one so next one will should be 15:00 UTC
20:49:30 <davidnind> +1
20:50:15 <oleonard> 10 March?
20:50:38 <davidnind> +1
20:51:07 <tuxayo> Yes, no collision
20:51:14 <tuxayo> #info Next meeting: 10 March 2021, 15:00 UTC
20:51:18 <tuxayo> #endmeeting