14:02:59 <Joubu> #startmeeting Development IRC meeting 27 October 2021
14:02:59 <huginn`> Meeting started Wed Oct 27 14:02:59 2021 UTC.  The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:59 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:59 <huginn`> The meeting name has been set to 'development_irc_meeting_27_october_2021'
14:03:03 <Joubu> #chair jzairo
14:03:03 <huginn`> Current chairs: Joubu jzairo
14:03:06 <Joubu> #chair cait
14:03:06 <huginn`> Warning: Nick not in channel: cait
14:03:06 <huginn`> Current chairs: Joubu cait jzairo
14:03:07 <Joubu> #chair cait1
14:03:07 <huginn`> Current chairs: Joubu cait cait1 jzairo
14:03:20 <Joubu> #topic Introductions
14:03:29 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
14:03:34 <marcelr> #info Marcel de Rooy, Rijksmuseum, The Netherlands
14:03:35 <ashimema> #info Martin Renvoize, PTFS Europe, UK
14:03:39 <cait1> #info Katrin Fischer, BSZ, Germany
14:03:42 <thd> #info Thomas Dukleth, Agogme, New York City
14:03:43 <Joubu> qa_team?
14:03:43 <wahanui> i guess qa_team is cait, dcook, amoyano, ashimema, marcelr, kohaputti, jajm, tcohen, kidclamp, khall, tuxayo, petrova, nugged
14:03:49 <Joubu> #info Jonathan Druart
14:03:56 <nugged> #info Andrew Nugged, National Library of Finland, HELSINKI
14:04:02 <Joubu> The agenda is full!
14:04:05 <petrova> #info Peter (Petro) Vashchuk, National Library of Finland, HELSINKI
14:04:05 <tuxayo> #info Victor Grousset, Tuxayo International Unlimited, France
14:04:07 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_27_October_2021
14:04:34 <davidnind> #info David Nind, New Zealand
14:04:47 <cait1> davidnind++
14:04:56 <jzairo> #info Jessica Zairo, ByWater Solutions
14:05:01 <cait1> 3am!
14:05:29 <davidnind> I happened to be awake!
14:05:41 <nugged> 🤗
14:06:02 <oleonard> davidnind++
14:06:13 <marcelr> keep awake david
14:06:44 <Joubu> jzairo: do want to chair?
14:07:01 <Joubu> #topic Announcements
14:07:03 * cait1 sends davidnind some hot coffee and dark chocolate
14:07:06 <Joubu> Anyone have something?
14:07:16 <cait1> deadlines maybe?
14:07:21 <davidnind> thanks cait1!
14:07:22 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
14:07:38 <tuxayo> KohaCon: I got the confirmation that it will be in-person only :(
14:07:39 <Joubu> cait1: yes, after
14:07:40 <jzairo> sure, I will give it a shot
14:07:55 <Joubu> tuxayo: from who?
14:08:11 <tuxayo> kohapakistan [AT] gmail.com
14:08:36 <tuxayo> I think it's Sher
14:08:49 <oleonard> Duplicate announcements to the Koha list and neither mentions in-person only :(
14:09:10 <Joubu> please fwd the email to "some of us"
14:09:34 <tuxayo> ok!
14:09:48 <ashimema> indeed
14:09:55 <fridolin> hi
14:09:56 <Joubu> continuing with my section then letting the meeting in other hands
14:10:04 <Joubu> #topic Update from the Release Manager (21.11)
14:10:09 <Joubu> I don't have much to say. Nothing different from the usual.
14:10:09 <thd> Perhaps someone could reach them with an offer to support a remote conference effort.
14:10:11 <tuxayo> fridolin: hi :D
14:10:16 <Joubu> * Feature freeze is end of the week!
14:10:27 <Joubu> Release dates sent to the list:
14:10:28 <Joubu> Oct 29th - "Soft" feature freeze, nothing big or with high risk of side-effects will be included into the final release if not marked as Passed QA
14:10:31 <Joubu> Nov 3-5 - "Hard" feature freeze, nothing considered as an improvement will be pushed if not marked as Passed QA
14:10:34 <Joubu> Nov 10th - String freeze, draft of release notes published
14:10:37 <Joubu> Nov 17th - Only bug fixes considered major, critical or blocker will be pushed
14:10:39 <Joubu> Nov 26th - Final release
14:10:41 <Joubu> * Please focus on this list - https://link.infini.fr/koha_bz_rel_21_11_candidate
14:10:50 <Joubu> I am keeping it up-to-date, so everything there is high priority (especially the bugfixes!)
14:11:00 <Joubu> * Missing release notes for new enh - Check that list, if you see your name please fill them in: https://link.infini.fr/koha_bz_release-notes-needed
14:11:07 <cait1> tuxayo: was any reason given?
14:11:31 <Joubu> * 3 big things pushed in the last week, that were part of the roadmap: bug 11175, bug 14957 and bug 19185. Thanks to everybody involved!
14:11:31 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11175 enhancement, P5 - low, ---, martin.renvoize, Pushed to master , Show the parent record's component parts in the detailed views
14:11:32 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14957 new feature, P5 - low, ---, glasklas, Pushed to master , Write protecting MARC fields based on source of import
14:11:33 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19185 enhancement, P5 - low, ---, jonathan.druart+koha, Pushed to master , Web installer and onboarding tool selenium test
14:11:49 <Joubu> 14957 is missing some stuffs to be fully ready, have a look at the last comments and follow-up bug reports.
14:11:55 <kidclamp> #info nick Clemens, ByWater solutions
14:11:56 <tuxayo> cait1: not really, I will see if I can get more info and forward it to you
14:12:05 <Joubu> 19185 is driving me crazy, I am having a hard time to make the tests pass (failing tests from Koha_Master, the full run). It seems that the "zebra srv mock" trick we have been doing for years in www/search_utf8.t isn't actually working as expected.
14:12:13 <Joubu> I based my last work on it assuming that... help welcome!
14:12:26 <Joubu> Ho, and we have a new blocker: bug 29330
14:12:26 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29330 blocker, P5 - low, ---, koha-bugs, NEW , Koha cannot send emails with attachments
14:12:26 <ashimema> nice work
14:12:31 <Joubu> and a critical one: bug 28236
14:12:31 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28236 critical, P5 - low, ---, johanna.raisa, Signed Off , Selecting database columns for system preferences in standard and dev installs is broken
14:12:32 <fridolin> #info Fridolin Somers, Biblibre
14:12:35 <Joubu> that's all for me
14:13:00 <ashimema> has anyone actually tested the new blocker?
14:13:22 <ashimema> I saw it float by.. but my understanding was that Email::Stuffer handles it transparently now
14:13:44 <Joubu> I haven't yet
14:13:49 <oleonard> The bug doesn't say how to reproduce the problem
14:13:50 <nugged> Joubu: I rebased and checked 20447 (right now installing on production) but seems because just 2 days to FF... that won't pass? (ashimema?) (yeah that's big feature)
14:14:14 <marcelr> bug 20447
14:14:14 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20447 new feature, P5 - low, ---, ere.maijala, Needs Signoff , Add support for MARC holdings records
14:14:17 <ashimema> I'd say lets push it over the edge first thing next cycle
14:14:26 <ashimema> it's very close.. but it's also very big 😉
14:14:31 <cait1> there is still also the bug for return-path, i m sorry we didn't get to test it yet
14:14:46 <marcelr> if it is a bug there is more time
14:15:07 <Joubu> nugged: my last comment is "Provide a full test plan and release notes please." and has been ignored, so... well..
14:15:12 <Joubu> I think it's too big and too late for that one
14:15:46 <nugged> ok
14:15:49 <cait1> maybe for fridolin - early next release
14:15:56 <cait1> to catch things
14:16:11 <ashimema> if anyone has time to test bug 28729 that would be awesome.. that's the return-path one cait1 was talking about.
14:16:11 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28729 critical, P5 - low, ---, martin.renvoize, Needs Signoff , Return-path header not set in emails
14:16:14 <marcelr> nice 500K patch
14:16:29 <marcelr> cait?
14:16:30 <wahanui> i heard cait was going to add one for a follow-up on the receive/currnecy/preselect we talked about
14:16:31 * ashimema is trying hard to focus on Joubu's list and anything else that feels blocker like
14:16:35 <cait1> yes?
14:16:58 <ashimema> I'm testing lots at the moment... hence spotted a few oddities this morning.. like the content blocks issue I promoited this morning
14:17:03 <marcelr> i am in for qa on that one ashimema
14:17:22 <marcelr> i just came across some authorised value problems
14:17:22 <Joubu> #action marcelr QA 28729
14:17:23 <cait1> marcelr++
14:17:36 <tcohen> marcel++
14:17:38 <cait1> marcelr "the brave"
14:17:45 <cait1> not shying away from big patches ever
14:17:59 <cait1> :)
14:18:04 <marcelr> hmm
14:18:17 <ashimema> beware.. the unit test is clear.. the code is clear.. but actually testing it is challenging to say the least..
14:18:22 <Joubu> were you talking about another one? I can add another action :D
14:18:39 <marcelr> actions can be reverted too Joubu
14:18:39 <cait1> moving on?
14:19:02 <ashimema> it relies on having a working email server and checking the results of sending an email... it's the MTA that actually sets the return path
14:19:03 <ashimema> fun aye.
14:19:15 <marcelr> sure
14:19:18 <Joubu> using gmail?
14:19:20 <cait1> yah, really thankful you dug into the documeantions
14:19:20 <ashimema> av problems marcelr?
14:19:27 <marcelr> yes
14:19:35 <marcelr> we have matching problems on the fields
14:19:40 <marcelr> field length
14:19:53 <marcelr> av is 80 but authority just is on 10 still
14:20:02 <marcelr> maybe a few more
14:20:08 <ashimema> ah,. yes.. think I've spotted that a few times.. feel free to punt it my way if you come up with a decent idea on how to resolve
14:20:23 <marcelr> trivial dbrev
14:20:31 <ashimema> 🙂
14:20:47 <Joubu> #topic Updates from the Release Maintainers
14:21:04 <Joubu> sorry, we need to move on, trying to make the meeting fit in 1h
14:21:11 <marcelr> good plan
14:21:21 <Joubu> nothing from rmaint I think
14:21:22 <fridolin> yey nothing about 20.11.x
14:21:32 <tuxayo> Will release the minor in the next hours
14:22:11 <davidnind> I successfully worked out how to setup koha-testing-docker so you can send email using gmail: https://gitlab.com/-/snippets/1893788#enabling-email-for-testing
14:22:19 <Joubu> #info expect the next minor releases in the next hours
14:22:37 <cait1> we had some issues with translations - something to check on next time maybe
14:22:38 <tuxayo> (20.05.x at least ^^")
14:22:42 <cait1> to see if things go smoothly again
14:23:09 <cait1> I suggested adjusting the mail text slightly - somtimes the strings are not updated yet when string freeze is called
14:23:12 <tuxayo> cait1: yes, I'll propose that we check that before announcing the string freeze
14:23:23 <cait1> so maybe good to word it like "check on new strings in the coming days" or so
14:23:40 <cait1> that would also be great :)
14:24:04 <tuxayo> That could be another way, I'll see if we can announce when it's ready but otherwise, yes changing the email text
14:24:13 <Joubu> Or ask Bernardo when he is usually doing it?
14:24:58 <Joubu> #topic Updates from the QA team
14:25:10 <tuxayo> I asked a long time ago, it's the 15th and the 17th but didn't ask if it's automated.
14:25:17 <Joubu> it's not
14:25:22 <fridolin> Bernardo is usually doing it around 15th yep
14:25:39 <tuxayo> ok
14:25:53 <Joubu> (well, I don't think it is, I saw run in the history every month around ~15-17th)
14:26:18 <Joubu> cait1, QA?
14:27:21 <marcelr> thats an answer too
14:27:30 <cait1> sorry
14:27:36 <cait1> I've been pushing for the bad and old bugs
14:27:52 <cait1> i'd really like to see a little mor QA action so close to freeze
14:28:21 <cait1> but overall... I was really happy to see some of the old and big go in this week
14:28:25 * ashimema is trying.. and marcelr has been magnificent
14:28:27 <cait1> a big thank you to those involved with that
14:28:42 <cait1> yes, as usual the wrong ones listen up :)
14:28:49 <marcelr> 58 is not that bad currently
14:28:56 <cait1> i know it was a big piece of work, so thanks a lot
14:29:01 <cait1> ashimema++ marcelr++
14:29:24 <cait1> i'll keep on pushing for some more old to new action next release cycle
14:29:49 <nugged> (from our side can say that we not directly placing QAs but we have current master on one pilot production and (I hope) that bunch of feedbacks we did directly to Joubu helped to move as well)
14:30:13 <cait1> every bit of feedback helps of course
14:30:16 <Joubu> yes, nugged, very useful!
14:30:23 <cait1> i can only talk about QA
14:30:35 <cait1> and we could use more hands/heads/exes there regularly to make things move better
14:30:40 <nugged> (and that production is alive with current master (1 week old though, just installing latest today - so will be more feedback these days)
14:31:34 <cait1> i didn't want that to sound too negative, but spreading the work more would really help I think
14:31:53 <ashimema> 🙂
14:32:19 <Joubu> # Status of roadmap projects
14:32:20 <cait1> I only see encoding error, but I hope it's a good one?
14:32:39 <tcohen> there are some roadmap projects PQA
14:33:39 <Joubu> ?
14:33:45 <marcelr> should you use # and topic
14:33:46 <Joubu> good news or complaining because it's not pushed?
14:33:57 <Joubu> there is something on the agenda
14:33:59 <tcohen> the latter
14:34:00 <wahanui> it has been said that the latter is the last of the list, no?
14:34:00 <tcohen> :-D
14:34:07 <marcelr> topic change?
14:34:11 <Joubu> so I was going to pick the stuff from there first
14:34:22 <Joubu> #topic Bug 19532 (Recalls)
14:34:22 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19532 new feature, P1 - high, ---, aleisha, Needs Signoff , Recalls for Koha
14:34:31 <Joubu> marcelr wanted to chat a bit about 19532
14:34:41 <marcelr> wont repeat my email here but wanted more feedback on it
14:34:42 <Joubu> everybody has the page opened?
14:34:46 <Joubu> "(Recalls) was on the roadmap; it is a feature that many libraries probably want; Aleisha rebased it around thousand times. It is too large to push it to 21.11 short before release. Some questioned the fundamentals too. It would only be fair if QA formulates an opinion on it as a team, and when agreed upon, new RM and QA coordinate pushing it early. As a side note, I really dislike patch sets of this size; we
14:34:52 <Joubu> should avoid them wherever possible"
14:35:25 <marcelr> think personally that we should try to adjust its current form; an other way will be harder in several aspects
14:35:28 <fridolin> i discover this bug
14:35:47 <marcelr> its 4 years ago so we cant say now rewrite it
14:35:48 <Joubu> If some of us are interested in it, we should help Aleisha
14:35:55 <Joubu> not letting her rebasing endlessly
14:35:59 <marcelr> right
14:36:00 <Joubu> I think that's marcelr's point
14:36:19 <marcelr> and since it is so large, asking for more opionions
14:36:23 <marcelr> hm
14:36:27 <fridolin> good thinks these feature can be turned off/on
14:36:46 <Joubu> once it's pushed, it's code to maintain
14:36:55 <fridolin> sure
14:36:56 <Joubu> so no, it's not because you can turn it off that you must push it, fridolin :D
14:37:06 <fridolin> ^^
14:37:19 <cait1> I have had a galcne at the spec
14:37:26 <cait1> it doesn't quite work as academics expect it
14:37:31 <cait1> but i see potential to extend
14:37:32 <Joubu> I think it's something for next month anyway
14:37:39 <cait1> i'd like to have a closer look and can offer GUI testing
14:37:42 <Joubu> it's too late for 21.11 and we have plenty of things to focus on
14:37:45 <cait1> but i'll need help with the code side
14:38:00 <cait1> yes, this is for after release
14:38:10 <marcelr> we need the new RM not to push other large stuff before it ?
14:38:19 <fridolin> i'll look at code
14:38:30 <Joubu> we need the team to focus on it and know if it's how we want this feature
14:38:39 <Joubu> if it's not, it's our job to rework it
14:38:55 <kidclamp> I worry that it is independent of holds as the workflows are similar, but if it is made clear how they interact it can be its own feature
14:39:07 <cait1> i believe maybe it can be separate
14:39:12 <cait1> if we can add an automatism too
14:39:16 <cait1> like... unmoderated recalls
14:39:29 <marcelr> kidclamp: building on holds is a tricky thing too
14:39:36 <ashimema> indeed
14:39:41 <ashimema> holds is a scary place
14:39:43 <marcelr> but it is a clear point
14:39:47 <kidclamp> thta would be nice - I feel it is a different workflow than others expect for recalls
14:39:48 <cait1> somaybe it is good to have it separate
14:39:52 <kidclamp> unmoderated is a nice compromise
14:40:11 <cait1> i think it might not be int here yet, but that's a direction we could look for
14:40:18 <oleonard> The workflow being different than some expect isn't a reason to reject it
14:40:20 <cait1> i have to study specs and docs more
14:40:32 <ashimema> It would be nice if it was written in a modern style.. that's my main issue.. yes it was written many moons ago.. but unless it's changed allot since.. it was a massive copy paste of holds at the time as far as I could tell
14:40:38 <koha-jenkins> Project Koha_Master build #1797: STILL UNSTABLE in 1 hr 5 min: https://jenkins.koha-community.org/job/Koha_Master/1797/
14:41:01 <cait1> so maybe we could agree on making this a priority after release?
14:41:09 <oleonard> I think that would be great
14:41:13 <cait1> fridolin volunteered for code - a second one maybe?
14:41:16 <marcelr> we should, or we should have disapproved much earlier
14:41:26 <marcelr> i am looking too
14:41:31 <cait1> ok
14:41:36 <cait1> so let's make that an agreed
14:41:41 <ashimema> I asked for a rename at some point.. I spoke to a number of interested parties and none of them recognised it as 'recalls' once I explained how it worked/what it did
14:41:44 <ashimema> which is a shame
14:42:00 <cait1> #agreed marcelr, fridolin and cait to look at recalls for QA after 21.11 release
14:42:05 <ashimema> not a blocker.. but I feel naming it recalls misleads over half the stakeholders interested in it.
14:42:11 <marcelr> did you put a better name on the report ?
14:42:11 <ashimema> 🙂
14:42:34 <ashimema> seems I didn't.. I am dredging the brain from reviewing it years ago 😉
14:42:44 <cait1> let's look at this with fresh eyes
14:42:47 <marcelr> what is the better name actually ?
14:43:00 <kidclamp> bug 17015 - if we want to save old much worked on code
14:43:00 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17015 enhancement, P5 - low, ---, maryse.simard, Failed QA , New Koha Calendar
14:43:02 <cait1> i think it#s somethig like... a patrn iitiated request to get something earlier?
14:43:05 <cait1> at th emoment
14:43:18 <tuxayo> patron driven recalls?
14:43:32 <cait1> i am nto done yet with docs, ran out of time an donly had a quick look
14:43:34 <oleonard> "stakeholders" aren't stakeholders if they're not chipping in
14:43:52 <ashimema> look at the bug 😉
14:43:53 <cait1> oleonard: hm?
14:43:54 <kidclamp> patron driven or unmoderated
14:44:01 <cait1> i think they are moderated
14:44:08 <ashimema> indeed
14:44:15 <Joubu> https://www.library.cornell.edu/services/request/recall # searched for "library recall"
14:44:18 <cait1> what we are looking for later might be unmoderated
14:44:51 <cait1> or more "uatomated" from staff side
14:45:11 <cait1> shall we leave it with the action/agreed and move on for now?
14:45:17 <kidclamp> this lets the patron place the recall on their own and automatically (cronjob) shortens the due date - no staff action (moderation)
14:45:23 <ashimema> either way.. lets attack it as a group at the beginning of the next cycle.
14:45:32 <marcelr> thats the plan
14:45:37 <cait1> kidclamp: ah ok - need to read up
14:45:44 <cait1> yep
14:45:49 <cait1> Joubu: moving on?
14:45:49 <kidclamp> I wondered if we were using different meanings :-)
14:46:02 <Joubu> #topic Actions from last meeting
14:46:08 <Joubu> #topic ashimema initiate the advent calendar - create a pad to collect ideas + send email to the list
14:46:11 <cait1> kidclamp: i missed out on my homework - that's the problem, I will catch up
14:46:28 <ashimema> ooh.. I forgot about the pad.. but did send an email
14:46:34 <ashimema> cait1 is the only one to have replied so far
14:46:38 <cait1> oops
14:47:13 <Joubu> Shouldn't we have a place to put ideas?
14:47:22 <cait1> i was not sure how technical so suggested something like "bugzilla search tips and tricks"
14:47:23 <Joubu> at least to know what others have in mind?
14:47:52 <cait1> so pad?
14:48:06 <Joubu> No action, in 2 weeks it will be too late
14:48:31 <cait1> we have about a month now... not a lot of time
14:48:43 <cait1> but if multiple authors know what to write and how it's doable still
14:49:00 <ashimema> yup
14:49:03 <ashimema> I have a list
14:49:10 <ashimema> and a small group of people
14:49:25 <cait1> will you get in touch?
14:49:27 <ashimema> but so far it's been a bit 'slack centric'
14:49:31 <cait1> maybe email?
14:49:32 <ashimema> yup
14:49:35 <cait1> slack?
14:49:35 <wahanui> i guess slack is expensive, but it falls under the 'just works' camp
14:49:56 <tcohen> let's do it!
14:50:08 <cait1> I don't have access to slack, so just let me know what's up please
14:50:10 <cait1> moving on?
14:50:10 <thd> slack is non-free
14:50:42 <cait1> thd: yes, it's not a community resource
14:51:39 <ashimema> lets move on
14:51:49 <Joubu> I haven't been approached to I guess you don't need help
14:51:51 <Joubu> good :)
14:52:02 <Joubu> #topic  LTS version
14:52:08 <Joubu> a fun one
14:52:14 <Joubu> won't fit in 1h..
14:52:15 <tuxayo> yes :D
14:52:27 <tcohen> lets make 20.05 the LTS
14:52:32 <Joubu> Should we skip it or discuss?
14:52:41 <Joubu> 20.05 is gonna be dropped in 1 month
14:52:56 <cait1> i think we can skip - but we shoudl agree on a next sstep
14:53:01 <cait1> are we postponing by 2 weeks
14:53:08 <cait1> or ... move back to mailing list?
14:53:21 <tuxayo> ok
14:53:21 <tcohen> what is to be discussed?
14:53:23 <cait1> i just put the questions there since I felt that the ml list thread got too quiet
14:53:26 <Joubu> it was stuck on the ML so decided here
14:53:29 <cait1> maybe too lost in the security discussion
14:53:30 <tcohen> 19.11 has volunteers to make it LTS
14:53:41 <cait1> shoudl we start a new thread just LTS?
14:54:06 <Joubu> ok, quick
14:54:10 <Joubu> * Will a 2 year cycle work for Koha?
14:54:11 <Joubu> yes/no?
14:54:25 <Joubu> is that too short or 2 years is fine?
14:54:26 <cait1> is that a lot of different to maintaining up to 3 now?
14:54:31 <cait1> i mean does it win us much time
14:54:32 <tuxayo> yes
14:54:55 <Joubu> as cait1 said, 2 is not much longer than what we do now
14:54:56 <cait1> half a year longer guaranteed then, right
14:54:57 <ashimema> if we're doing an LTS I would like to see us drop oldoldstable
14:55:11 <cait1> ashimema: that's question 2 or 3
14:55:19 <cait1> had you in mind :)
14:55:35 <cait1> ohw long is debian/ubuntu lts? 2 years?
14:55:46 <tuxayo> 6 at least
14:55:54 <ashimema> yup
14:56:02 <cait1> oh wow
14:56:05 <Joubu> 3y sounds better to me, but we need something to maintain it, and keep on doing it
14:56:11 <Joubu> someone* oops
14:56:20 <fridolin> indeed
14:56:20 <marcelr> does 3y make sense?
14:56:24 <cait1> 3 feels better, agree
14:56:27 <ashimema> 3y seems reasonable
14:56:36 <Joubu> * How will updates work? Can you jump from LTS to a version in between?
14:56:37 <tuxayo> 20.04 LTS released 2020-04-23, maintenance until 2030-04-23
14:56:37 <tuxayo> 10y!
14:56:49 <Joubu> I dont' think this question make sense, we have a strong upgrade progress
14:56:53 <cait1> i think that's too hard for us
14:56:54 <tuxayo> yes
14:56:54 <Joubu> what would be the problem?
14:56:56 <ashimema> indeed
14:56:56 <tuxayo> no issues
14:57:05 <cait1> it was raised last meetiing
14:57:15 <cait1> i try to remember what the point made was
14:57:29 <Joubu> * How many versions should be maintained apart from LTS?
14:57:30 <ashimema> LTS -> LTS would be a massive jump..
14:57:37 <ashimema> 3 years worth of DB upgrade
14:57:39 <cait1> yes, i think we need to give people an out
14:57:47 <ashimema> that's gonna be fun for anyone doing it.
14:58:02 <cait1> it does work (i just did one from 16.11) :) but people might follow LTS and want to switch
14:58:05 <Joubu> like those doing 3.22 to 20.11? :)
14:58:10 <fridolin> we have some jumps actually from 16.11 to 20.11
14:58:10 <cait1> if idempotent db updates is enough, we are good
14:58:26 <tuxayo> > LTS -> LTS would be a massive jump..
14:58:26 <tuxayo> A certain number of instances are upgraded like that right?
14:58:29 <Joubu> ok, so shouldn't be a problem
14:58:43 <Joubu> * How many versions should be maintained apart from LTS?
14:58:46 <cait1> just something to keep in mind and maybe soemthing to test
14:58:47 <Joubu> (bis)
14:58:58 <ashimema> I used to think following the ubuntu cycle made some sense.. but now I can't for the life of me see any patturn to it.
14:59:08 <cait1> heh
14:59:14 <Joubu> the number of versions we can maintain, depending on the rmaints available
14:59:18 <ashimema> personally.. I feel like the numerious stables pull resource away from QA and SO
14:59:19 <Joubu> at least 2, maybe 3
14:59:38 <marcelr> or say 4 and LTS==2 y
14:59:49 <marcelr> 'L'
14:59:52 <ashimema> I've felt for a while that it would be good to have 1 or 2 longer supported versions with more of a rolling option too
14:59:57 <fridolin> same feeling, we should focus on stable+oldstable in my opinion
15:00:01 <tuxayo> Ideally managing to keep only 3 RMaints in total since between half or a third of them could be doing QA instead of RMaint. To account for the QA workforce shortage.
15:00:29 <tuxayo> fridolin: how does that work for people doing yearly upgrades? Like BibLibre
15:00:38 <ashimema> LTS is basically security only isn't it.?
15:00:51 <Joubu> yes
15:00:59 <Joubu> shouldn't be too problematic for the maintainer
15:01:00 <tcohen> what about supported platforms?
15:01:01 <Joubu> more for the devs
15:01:07 <marcelr> even that may be hard to rrebase on older versions ?
15:01:26 <Joubu> but it will prevent us from delivering .patch files to apply, like we did last sec release
15:01:31 * ashimema would love to see 'LTS or Rolling'
15:01:59 <ashimema> monthly release for selected LTS versions for whatever period we decide.. monthly rolling release between times
15:01:59 <cait1> i don't know what Rolling means
15:02:31 <ashimema> rolling releases are the modern not quit continuous integration approach
15:02:36 <marcelr> heading for the canyon haha
15:02:54 <cait1> what about a compromise for next ccycle?
15:02:57 <ashimema> i.e. we just keep releasing as soon as feature are ready.. rather than have a dev branch that can be anything up to 6 months ahead
15:02:58 <cait1> we already have some gap
15:03:25 <Joubu> we have time to think it anyway, will postpone for next meeting
15:03:28 <Joubu> or even the one after
15:03:32 <Joubu> moving on
15:03:45 <cait1> ok
15:03:45 <Joubu> #topic KohaCon22
15:03:50 <tuxayo> > i.e. we just keep releasing as soon as feature are ready.. rather than have a dev branch that can be anything up to 6 months ahead
15:03:50 <tuxayo> Can it work for software that need training for users?
15:03:51 <Joubu> * Bidding deadline?
15:04:00 <cait1> sorry, as we decided no more general so often, I didn't know where to put that one
15:04:03 <ashimema> should 'LTS' actually be called 'ESM'
15:04:13 <ashimema> 'Extended Security Maintanence'
15:04:17 <ashimema> anywho.. we move on
15:04:33 <cait1> #link https://wiki.koha-community.org/wiki/KohaCon22_Proposals
15:04:45 <marcelr> Later To See
15:04:47 <tuxayo> ashimema: good point, don't forget it for for next meeting ^^
15:04:50 <cait1> caroline_catlady++ set it up
15:05:03 <cait1> i'd like to add a lmore prominent link to processes
15:05:10 <cait1> ah ok, it's there already
15:05:14 <cait1> but deadline is missing
15:05:17 <cait1> how long for biddings?
15:05:20 <cait1> next year is appraoching soon
15:05:28 <cait1> end of january too late?
15:06:33 <cait1> *coughs*
15:06:36 <ashimema> partly depends on when the organisors want to host it.
15:06:44 <Joubu> when do we open them?
15:06:48 <ashimema> if they're thinking end of year Jan isn't too late
15:06:50 <cait1> i thinkw e should open them now
15:06:50 <Joubu> has the email sent to the ML?
15:06:59 <ashimema> if they're thinking early summer.. Jan is pretty late
15:07:02 <cait1> we are already running late
15:07:09 <ashimema> yeah.. we should open asap
15:07:18 * ashimema has no idea if there are any interested parties out there already.
15:07:19 <Joubu> yes, open and close bid end JAN
15:07:20 <Joubu> Jan
15:07:27 <ashimema> decided 🙂
15:07:31 <cait1> so i am puttin gen dof january
15:07:36 <cait1> woudl someone be so kind and send email to list?
15:07:50 <cait1> ooh
15:07:51 <tuxayo> I have a draft for a section about avoiding holiday clash. Shall I sent it to cait1 and caroline in the next days when I finish it?
15:07:58 <cait1> let's make it end before next general
15:08:03 <cait1> we might need to organize voting...
15:08:24 <ashimema> perfec tuxayo
15:08:24 <cait1> january 8th?
15:08:46 <ashimema> go for it cait1
15:09:06 <cait1> we also need to adjust teh rporting section
15:09:11 <cait1> it says to send soemone to IRC meetings
15:09:19 <cait1> maybe we could ask for a monthly update to koha list?
15:09:36 <cait1> https://wiki.koha-community.org/wiki/Processes_for_KohaCons#Communication
15:09:45 <davidnind> +1
15:09:59 <tuxayo> +1
15:10:17 <tuxayo> more feasible than attending meeting and would solve most problems
15:10:20 <cait1> sorry, the richt section is "Expectations
15:10:29 <Joubu> cait1 is waiting for a volunteer to send the email I think
15:10:33 <cait1> https://wiki.koha-community.org/wiki/Processes_for_KohaCons#Expectations_for_successful_bidder
15:10:39 <cait1> we can updat ethe process page first
15:10:51 <cait1> i think the holiday clash one and themailing list one
15:11:00 <cait1> will check back with people on IRC
15:11:03 <cait1> maybe outside a meeting
15:12:36 <Joubu> can we move on then?
15:12:43 <cait1> yes
15:12:53 <Joubu> #topic Set time of next meeting
15:13:06 <Joubu> Nov 10
15:13:07 <cait1> #action tuxayo to send draft for holiday clash
15:13:12 <tuxayo> yes
15:13:25 <Joubu> #info Next meeting: 10 November 2021, 14 UTC
15:13:26 <cait1> #action cait to update expectations to monthly report to mailing list
15:13:35 <Joubu> #endmeeting