#koha: Development IRC meeting 7 April 2021

Meeting started by Joubu at 15:00:22 UTC (full logs).

Meeting summary

  1. Introductions (Joubu, 15:00:29)
    1. Martin Renvoize (ashimema, 15:00:41)
    2. Jonathan Druart (Joubu, 15:00:47)
    3. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard-away, 15:01:05)
    4. tuxayo/Victor Grousset, France (tuxayo, 15:01:15)
    5. Thomas Dukleth, Agogme, New York City (thd, 15:01:21)

  2. Announcements (Joubu, 15:02:27)
    1. https://koha-mw-pg-test01.agogme.com/wiki/Main_Page (thd, 15:03:05)
    2. https://koha-mw-my-test01.agogme.com/wiki/Main_Page (thd, 15:03:25)
    3. Tomas Cohen Arazi, Theke Solutions (tcohen, 15:04:59)
    4. Nick Clemens, ByWaterSolutions (kidclamp, 15:05:13)

  3. Update from the Release Manager (21.05) (Joubu, 15:11:24)
    1. ACTION: Joubu create the "roles for 21.11" wiki page and send an email to the list (Joubu, 15:14:22)

  4. Updates from the Release Maintainers (Joubu, 15:15:11)
    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_7_April_2021 (Joubu, 15:15:24)
    2. Fridolin is candidate for RMaint 20.11 during the next release cycle (Joubu, 15:16:11)

  5. Updates from the QA team (Joubu, 15:16:39)
    1. QA members should help a bit more on the final push during the next month (Joubu, 15:18:15)
    2. https://frama.link/koha_bz_nso-so-pqa_maj-blo-cri (Joubu, 15:20:51)

  6. Status of roadmap projects (Joubu, 15:26:55)
    1. https://annuel.framapad.org/p/koha_21.05_roadmap (Joubu, 15:28:15)
    2. https://annuel.framapad.org/p/koha_21.05_roadmap (tuxayo, 15:28:21)

  7. Actions from last meeting (Joubu, 15:29:06)
    1. ACTION: mtj write something about the new packages for the 21.05 release notes (Joubu, 15:29:14)

  8. ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695) (Joubu, 15:29:33)
    1. ACTION: ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695) (Joubu, 15:30:29)

  9. Joubu we need to push 26703 asap (Joubu, 15:30:36)
  10. ashimema Write a guideline for 26703 (Joubu, 15:31:00)
    1. Guideline about 26703 is at https://wiki.koha-community.org/wiki/Coding_Guidelines#ACC3:_Title_elements_should_contain_unique_information_information_first (Joubu, 15:32:47)

  11. General development discussion (trends, ideas, ...) (Joubu, 15:37:59)
    1. Next meeting: 21 April 2021, 14 UTC (Joubu, 15:39:21)


Meeting ended at 15:39:57 UTC (full logs).

Action items

  1. Joubu create the "roles for 21.11" wiki page and send an email to the list
  2. mtj write something about the new packages for the 21.05 release notes
  3. ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695)


Action items, by person

  1. ashimema
    1. ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695)
  2. Joubu
    1. Joubu create the "roles for 21.11" wiki page and send an email to the list


People present (lines said)

  1. Joubu (72)
  2. ashimema (31)
  3. thd (17)
  4. tcohen (14)
  5. huginn (11)
  6. tuxayo (8)
  7. wahanui (4)
  8. koha-jenkins (3)
  9. oleonard (2)
  10. kidclamp (1)
  11. oleonard-away (1)
  12. severine_q (1)


Generated by MeetBot 0.1.4.