15:01:10 <caroline> #startmeeting Documentation IRC meeting 7 January 2021
15:01:10 <huginn> Meeting started Thu Jan  7 15:01:10 2021 UTC.  The chair is caroline. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:10 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:10 <huginn> The meeting name has been set to 'documentation_irc_meeting_7_january_2021'
15:01:22 <caroline> #link https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_7_January_2021#Agenda
15:01:27 <caroline> #topic Introductions
15:01:33 <caroline> please use "#info" in front of your introduction to have it show up in the automatic minutes
15:01:48 <caroline> #info Caroline Cyr La Rose, inLibro, Canada
15:02:42 <ashimema> #info Martin Renvoize, PTFS Europe, UK
15:02:54 <thd> #info Thomas Dukleth, Agogme, New York City
15:05:10 <caroline> #topic  Review of action points
15:05:36 <caroline> change the Documentation to-do search on bz main page to include Documentation component OR manual keyword
15:05:37 <wahanui> caroline: that doesn't look right
15:06:06 <caroline> I checked and right now, the search is documentation component AND manual keyword, which is not what we need
15:06:19 <caroline> cait can you add an OR to this saved search?
15:06:31 <caroline> cait1 ^
15:07:03 <caroline> #link https://bugs.koha-community.org/bugzilla3/buglist.cgi?cmdtype=dorem&list_id=357040&namedcmd=Documentation%20To-do&remaction=run&sharer_id=13
15:07:46 <koha-jenkins> Yippee, build fixed!
15:07:46 <wahanui> Congratulations!
15:07:46 <koha-jenkins> Project Koha_20.11_U2010 build #19: FIXED in 34 min: https://jenkins.koha-community.org/job/Koha_20.11_U2010/19/
15:08:13 <caroline> #action  change the Documentation to-do search on bz main page to include Documentation component OR manual keyword
15:08:29 <Joubu> #info Jonathan Druart
15:08:34 * Joubu lurking mode
15:08:57 <caroline> I was supposed to document workflow for 21.05, but haven't done it yet, so I'll re-action it
15:09:07 <caroline> #action  caroline will document workflow for 21.05
15:09:21 <caroline> divide the syspref file as it is getting too big for updates through gitlab GUI
15:09:32 <ashimema> humm
15:09:36 <caroline> this was sone today by ashimema++
15:09:37 <ashimema> the search looks right to me..
15:09:53 <ashimema> 'Match ANY of the following separately'
15:09:58 <caroline> https://bugs.koha-community.org/bugzilla3/buglist.cgi?cmdtype=runnamed&list_id=357042&namedcmd=Manual
15:10:05 <lucyvh> ashimema++
15:10:15 <caroline> these two are not in the documentation to-do search
15:10:29 <ashimema> humm
15:10:34 <caroline> maybe because of the status?
15:10:43 <ashimema> ok.. I defer to cait then.. she's better at bugzilla searches than i
15:10:50 <ashimema> could be
15:11:07 <caroline> add to the Rst tips and tricks page how to wirte notes
15:11:11 <caroline> this is done
15:11:46 <ashimema> :)
15:11:53 <caroline> From now on, please use the .. Note:: syntax instead of **Note**
15:12:22 <caroline> #link https://wiki.koha-community.org/wiki/ReStructuredText_-_Tips_and_Tricks#Notes
15:12:30 <caroline> #info From now on, please use the .. Note:: syntax instead of **Note**
15:13:06 <caroline> I also started experimenting with other ones, such as .. Warning:: that could replace **Important**
15:13:36 <caroline> It makes it red-orange-ish instead of blue like a note
15:14:22 <caroline> I don't have a ready example though
15:14:55 <ashimema> nice
15:14:58 <caroline> I'll try to have one by next meeting and we can discuss if we want to adopt the .. Warning:: syntax
15:15:37 <caroline> #action caroline to prepare examples of .. Warning:: syntax for dicussion
15:15:37 <lucyvh> Sounds good
15:16:06 <caroline> #topic  Project updates
15:16:13 <caroline> anyone has project updates?
15:17:27 <koha-jenkins> Project Koha_20.11_D10 build #35: SUCCESS in 44 min: https://jenkins.koha-community.org/job/Koha_20.11_D10/35/
15:17:30 <caroline> There is a space issue on the server right now
15:17:52 <caroline> the manuals aren't being built with the new contributions, if I understand icorrectly
15:18:12 <caroline> ashimema: what are the options?
15:19:36 <ashimema> * remove the 21.05 in-development manual
15:19:47 <ashimema> * remove an older manual ?
15:20:06 <ashimema> * request some more disk space and do a little drive to help fund Liz's server again...
15:20:34 <ashimema> eventually we'll need more space regardless unless we start dropping older manuals
15:20:49 <lucyvh> There are lots of old branches in the respository - would removing them make a difference?
15:20:50 <caroline> do you know what is the oldest manual right now?
15:21:08 <ashimema> https://koha-community.org/documentation/documentation-unsupported-versions/
15:21:26 <ashimema> well.. we host copies all the way back to 3.0
15:21:32 <ashimema> which is an old PDF
15:22:12 <ashimema> the challenge is.. recent versions are much more extensive with the inclusion of translations..
15:22:19 <caroline> It's interesting for archival purposes
15:22:22 <ashimema> I don't think we share images between translations either..
15:22:28 <caroline> but I don't think we should keep this many
15:22:33 <ashimema> so it's literally a full on copy of the entire manual for each translation we have
15:23:03 <ashimema> but... weren't we contemplating having translated images too at some point..
15:23:18 <caroline> yes, eventually
15:24:07 <caroline> what would be possible consequences of dropping older versions?
15:24:38 <thd> Translated images are certainly better than untranslatable images :)
15:24:38 <ashimema> each manual is currently 119MB
15:24:41 <ashimema> which isn't huge
15:25:18 <ashimema> but when you consider we currently replicate it 12 times for each supported version
15:25:54 <ashimema> 119 * 12 = 1428
15:26:38 <ashimema> * 3 (recently translated versions) = 4284
15:26:46 <ashimema> yeah.. they're growing pretty quick now
15:27:02 <ashimema> so it's not all that surprising we're running out of space more quickly these days
15:27:16 <ashimema> I imagine we're on a tiny low space server
15:27:41 <caroline> I think dorpping older versions could have the good consequence of haveing only recent information in Google searches
15:28:09 <caroline> When I search for Koha something somethinmg, the first results are often manuals from Koha 3.X
15:28:13 <lucyvh> We have to prioritise the recent ones
15:28:32 <caroline> it would break links in blog posts
15:28:49 <ashimema> ok.. Liz is in another meeting
15:28:53 <thd> Better to add a label to the older directing people to the current version.
15:29:04 <ashimema> but she tells me it's a linode server and is relatively easy to add disk space to..
15:29:16 <ashimema> but obviously any increment in disk space is also a price increase for her.
15:29:21 <caroline> but the problem will be back in a couple of months
15:29:55 <caroline> I think we should move toward a more sustainable solution
15:30:02 <thd> Linode has two different means of adding disk space.
15:30:28 <ashimema> we could zip up older manuals so they're still available as a download from an archive.. but not as a public site?
15:30:53 <caroline> if that saves space I'm ok with that
15:31:09 <caroline> along with redirecting like thd said?
15:31:11 <ashimema> either way.. to get us out of trouble quick Liz has agreed to take a look after her meeting
15:31:15 * ashimema poked her on Slack
15:31:33 <ashimema> I recons so..
15:32:24 <caroline> ok so what are the actions? It's only liz that can do all of it right?
15:32:44 <koha-jenkins> Project Koha_20.11_U20 build #19: SUCCESS in 59 min: https://jenkins.koha-community.org/job/Koha_20.11_U20/19/
15:32:48 <caroline> or she just controls the the hardware
15:33:08 <koha-jenkins> Project Koha_20.11_U18 build #16: UNSTABLE in 59 min: https://jenkins.koha-community.org/job/Koha_20.11_U18/16/
15:33:34 <ashimema> and possible rangi.. but I think he said last night he's not really able to either
15:33:37 <thd> A disk volume which is not included in automatic backup can be attached on Lindode or the VPS host can be moved to a system with more disk space for a higher price.
15:33:42 <ashimema> she controls the hardware
15:33:51 <caroline> everyone OK with archiving older manuals as zip files (hosted where?), and redirecting links to newer versions of the manual
15:34:46 <lucyvh> +1
15:34:56 <caroline> I would archive all manuals for unsupported versions
15:34:57 <thd> Would redirection use a rewrite script?
15:35:45 <caroline> I don't know how it could work... I was imagining like the thing we have for "latest"
15:36:12 <ashimema> 'latest' is a sylink
15:36:18 <lucyvh> I'm not sure about all unsupported but certainly the very early manuals
15:36:28 <koha-jenkins> Project Koha_20.11_U16 build #21: SUCCESS in 1 hr 5 min: https://jenkins.koha-community.org/job/Koha_20.11_U16/21/
15:36:59 <caroline> So do we keep two unsupported versions + sall supported versions?
15:37:11 <ashimema> git space on gitlab and the likes is free I believe.. we could stick the archived one's in there and link to them that way
15:37:15 <caroline> do you have clients who still used Koha 18.05 or 18.11?
15:37:24 <ashimema> haha
15:37:31 <ashimema> I bet lots of people are still on 18.05 ;)
15:37:45 <ashimema> wouldn't be surprised to find 17.x's out there
15:37:48 <caroline> we still have one client on 3.14... so I'm not throwing rocks or anything
15:38:34 <lucyvh> We have one or two still on later 3.x I think?
15:38:56 <liliputech_asu> i
15:39:17 <lucyvh> How would this affect the contextual links from the staff interface?
15:39:18 <liliputech_asu> i think one of our customer even is 16.11
15:39:27 <lucyvh> For those still on really old versions?
15:39:50 <caroline> I mean... if they've been using Koha this long, they know how to use it right?
15:40:04 <caroline> lol
15:40:14 <ashimema> we do?
15:40:16 <ashimema> scary
15:40:31 <ashimema> lol
15:40:45 <lucyvh> haha, they should
15:40:51 <liliputech_asu> caroline: lol, within an organisation, people move (and the sigb may not)
15:40:59 <liliputech_asu> (sigb => ils)
15:41:05 <thd> There may always be new staff members and new use of some features.
15:41:09 <caroline> you're right liliputech_asu
15:41:57 <caroline> do we know what it does to the links in the staff interface like lucyvh said?
15:42:05 <liliputech_asu> if old link are redirecting to new pages, isn'it like some kind of advertisement? o:)
15:42:13 <ashimema> dang.. my math was wrong.. it's not 120mb per translation.. it's bigger than that becuase we also build PDF's, and ebooks and stuff
15:42:48 <ashimema> sounds like we're going back to needing to keep the older ones to me..
15:43:06 <ashimema> and think about somehow slimming them down or increasing disks semi-regularly
15:43:08 <caroline> Because for those who use really old versions, they could download the zip archive and link to them locally
15:43:57 <caroline> it's just the links in the staff interface that bug me
15:44:01 <koha-jenkins> Project Koha_20.11_D9 build #28: SUCCESS in 36 min: https://jenkins.koha-community.org/job/Koha_20.11_D9/28/
15:44:02 <cait1> Sorry for almost totally missing the meeting :(
15:44:23 <lucyvh> I don't think we need to keep them all - just longer than only the supported ones - 5 years back perhaps?
15:44:32 <caroline> but I think help was in Koha until more recent versions right?
15:44:54 <cait1> but the help pages link to the manual
15:44:56 <caroline> there were no links to the manual until... 17? 18?
15:44:57 <cait1> so we'd break these
15:45:04 <caroline> ah ok
15:45:05 <cait1> but yes, 16.11 would definitely have the help pages still
15:45:13 <thd> We need a better system for staff interface links so that they can direct to a local version with a system preference change.
15:45:21 <caroline> so would redirectins work in that case?
15:45:22 <reiveune> bye
15:45:24 <cait1> thd that is already possible
15:45:39 <cait1> you configure the link to the manual in a pref
15:45:42 * ashimema builds the manuals locally so check the sizes again
15:46:11 <caroline> I put another point in the agenda that is maybe linked to this
15:46:21 <caroline> manual.koha-community.org vs translate.koha-community.org/manual
15:46:36 <cait1> thd: for example we point ours to the nightly translation preview manuals... as the other s don't get updated
15:46:43 <cait1> exactly the point caroline is making there :)
15:46:45 <ashimema> haha.. that bug bear
15:46:49 <ashimema> that one's bugged me for ages
15:47:00 <caroline> I've had complaints that translations are not being built, but they are on translate...
15:47:04 <cait1> can't we just... do a domain redirect and use Bernardo's? ;)
15:47:12 <kidclamp> What is the point of the 'DEFAULT' authority type?
15:47:18 <kidclamp> oops, in meeting, sorry
15:47:27 <caroline> so coud we keep only the english manual on manual.koha... and the translated ones on translate?
15:47:34 <cait1> kidclamp: let me know when you figure it out :)
15:47:48 <cait1> kidclamp: i believe there is a bug somewhere in bugzilla about when it was added
15:48:06 <ashimema> the whole translate thing keeps really confusing me
15:48:11 <cait1> I believe the templates are a bit different between those 2 - do we want to make sure they actually look the same?
15:48:15 <ashimema> people going off in their own directions
15:48:26 <cait1> ashimema: i don't think they do
15:48:33 <thd> People merely need to be reminded to configure the system preference with a download to the manual for their version.
15:48:44 <cait1> Bernardo's was intended to help translating as it constantly updates so you can check what you did
15:48:58 <ashimema> right
15:49:22 <ashimema> I had a way to automatically submit merge requests for the translated manuals for you caroline
15:49:38 <caroline> oh right I forgot!
15:49:39 <ashimema> I was waiting on bernardo to let me update the version of git on he translations server..
15:49:41 <caroline> lol
15:49:43 <ashimema> I need to go ahead and do that
15:49:44 <ashimema> but...
15:49:52 <ashimema> I'm not sure that's what we actually want to do anymore?
15:49:59 <cait1> i think we do
15:50:15 <cait1> what we want is update the main repository with the po files generated on the translation server
15:50:21 <cait1> i think we just got stuck on the how often
15:50:23 <caroline> I don't know, I think it could solve our space problem to have them divided, but I don't want to impose on bernardo
15:50:30 <ashimema> do we.. or do we want to skip the merge step and push the translated builds straight to the koha-community.org/manual site instead
15:50:44 <ashimema> save caroline merging translations into our git every time?
15:50:44 <cait1> hm we could also do that
15:50:53 <cait1> and not keep the po in the main repo at all?
15:50:55 <caroline> Yes I would prefer that
15:51:03 <ashimema> I think I could work that out.. I'm sure if I asked liz would give me an rsync key for it.
15:51:08 <ashimema> indeed
15:51:13 <cait1> but it might be nice to have another copy outside of translate
15:51:24 <cait1> a mirror of the repo at least
15:51:33 <ashimema> yeah.. perhaps we update the po's in git once a month along with release?
15:51:40 <ashimema> koha release that is..
15:51:51 <ashimema> I'm getting pulled away.. the kids, and dog, want a walk
15:51:54 <cait1> on first glance that sounds good to me
15:52:05 <cait1> caroline: quick,@action ashimema ;)
15:52:25 <caroline> I think we need to discuss this in detail, maybe outside of a meeting?
15:52:31 <ashimema> can you action me for it.. but also add it to our roadmap doc cait1?
15:52:41 <ashimema> I'm using that roadmap as a bit of a to do list this cycle
15:52:41 <cait1> now I got actioned...
15:52:46 <ashimema> indeed
15:52:48 <caroline> action to action
15:53:11 <ashimema> right.. sorry chaps and chapesses.. and they/them/others
15:53:14 <ashimema> I need to scoot
15:53:14 <ashimema> see ya later
15:53:14 <cait1> @ashimema to move forward on updating the translated manuals on the website (details to be discussed)
15:53:15 <huginn> cait1: I'll give you the answer just as soon as RDA is ready
15:53:15 <wahanui> i already had it that way, huginn.
15:53:24 <cait1> @action ashimema to move forward on updating the translated manuals on the website (details to be discussed)
15:53:31 <caroline> its #action
15:53:35 <cait1> i probbably can't even do that... without chair?
15:53:41 <caroline> #chair cait1
15:53:42 <huginn> Current chairs: cait1 caroline
15:53:52 <cait1> #action ashimema to move forward on updating the translated manuals on the website (details to be discussed)
15:53:56 <cait1> i can do the roadmap later
15:54:11 <cait1> #action cait to add the translated manuals to the roadmap for 21.05
15:54:22 <caroline> ok I'll the other things since we're short on time
15:54:38 <caroline> if you wanted to discuss something, add it to the wiki page
15:54:52 <caroline> and we'll ppiroritize that next meeting
15:55:06 <caroline> #topic Set time of next meeting
15:55:26 <caroline> 4 weeks from now would be Feb 18
15:56:01 <caroline> I would make the meeting a bit later so david can attend, is that ok with you? I know you're all in europe
15:56:08 <caroline> (except thd)
15:56:10 <marie-luce> if there small things that a newbie could help you out?
15:57:17 <caroline> 19 UTC good?
15:58:00 <cait1> probably :)
15:58:02 <caroline> #info Next meeting: 18 February, 2021, 19 UTC
15:58:04 <lucyvh> That suits me
15:58:09 <caroline> #endmeeting