14:11:54 <cait> #startmeeting Development IRC meeting 14 September 2022
14:11:54 <huginn`> Meeting started Wed Sep 14 14:11:54 2022 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:11:54 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:11:54 <huginn`> The meeting name has been set to 'development_irc_meeting_14_september_2022'
14:11:59 <tuxayo> Sorry, a bit late to open everyhting.
14:11:59 <tuxayo> cait: yes
14:12:04 <cait> #topic Introductions
14:12:06 <cait> #chair tuxayo
14:12:06 <huginn`> Current chairs: cait tuxayo
14:12:13 <cait> Please introduce yourself using #info
14:12:22 <cait> #info Katrin Fischer, BSZ, Germany
14:12:29 <cait> want to take over tuxayo?
14:12:39 <paulderscheid[m]> #info Paul Derscheid, LMSCloud GmbH, Munich, Germany
14:12:53 <thd> #info Thomas Dukleth, Agogme, New York City
14:12:56 <tuxayo> If you want to have a chillier meeting, I can :
14:12:58 <tuxayo> * :)
14:13:10 <tuxayo> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_14_September_2022 Today's agenda
14:13:18 <ashimema> #info Martin Renvoize, PTFS Europe, UK
14:13:24 <cait> we can work together :)
14:13:29 <tuxayo> ↑↑ agenda just updated so reload if you had it
14:13:34 * ashimema is on the school run so excuse the mobile typos
14:13:35 <tuxayo> ok cait :)
14:13:55 <cait> qa_team
14:14:00 <tuxayo> #info Victor Grousset, Tuxayo Limited, France
14:14:04 <cait> hm wahanui?
14:14:04 <wahanui> i am a conch
14:14:05 <tuxayo> rmaints?
14:14:05 <wahanui> rmaints are lukeg, liliputech and tuxayo
14:14:12 <cait> qa_team?
14:14:12 <wahanui> i heard qa_team was cait, marcelr, khall, kidclamp, kohaputti, lukeg, aleisha, fridolin, ashimema, tuxayo, nugged, petrova, Joubu and dcook
14:14:13 <tuxayo> qa_team?
14:14:13 <wahanui> i guess qa_team is cait, marcelr, khall, kidclamp, kohaputti, lukeg, aleisha, fridolin, ashimema, tuxayo, nugged, petrova, Joubu and dcook
14:14:42 <cait> maybe anoter minute
14:14:59 <mtj> hi folks, im about-ish
14:15:01 <kidclamp> #info Nick Clemens, ByWater Solutions
14:15:21 <cait> moving on.... :)
14:15:26 <mtj> hi thd, perhaps we can chat about wiki stuff after meeting?
14:15:27 <cait> #topic Announcements
14:15:52 <thd> yes mtj
14:15:53 <liliputech> #info Arthur Suzuki, BibLibre, France
14:15:54 <tuxayo> Anything to announce that doesn't fit more the other topics?
14:15:58 <cait> #info KohaCon next week! If you are attending, feel free to add yourself to arrivals and departures on the wiki: https://wiki.koha-community.org/wiki/KohaCon22_Social
14:16:31 <cait> #link https://koha-community.org/kohacon/kohacon22/ KohaCon22 website - presentations will also be streamed to YouTube
14:16:50 <cait> #info National Library of Finland to host KohaCon23 in Helsinki, Finland!
14:16:58 <cait> anyone else? :)
14:16:58 <tuxayo> :D
14:17:45 <cait> tuxayo: shall we move on?
14:17:52 <tuxayo> k
14:18:00 <tuxayo> #topic  Update from the Release manager (22.11)
14:18:07 <cait> tcohen: around?
14:18:42 <tuxayo> Let's bring back of the topic later if they show up
14:18:45 <tuxayo> #topic Updates from the Release Maintainers
14:18:47 <cait> yep
14:18:50 <tuxayo> rmaints?
14:18:50 <wahanui> rmaints are lukeg, liliputech and tuxayo
14:18:59 <cait> i think I have seen tuxayo ...
14:19:50 <tuxayo> ^^
14:19:50 <tuxayo> Need some catch up for oldoldstable/21.05.x.
14:19:50 <tuxayo> Otherwise, nothing much to say.
14:20:01 <cait> liliputech?
14:20:01 <wahanui> somebody said liliputech was not around - so I think we'll postpone that one again
14:20:06 <cait> forget liliputech
14:20:06 <wahanui> cait: I forgot liliputech
14:20:31 <cait> move on?
14:20:36 <tuxayo> #topic Updates from the QA team
14:20:41 <tuxayo> qa_team?
14:20:41 <wahanui> qa_team is probably cait, marcelr, khall, kidclamp, kohaputti, lukeg, aleisha, fridolin, ashimema, tuxayo, nugged, petrova, Joubu and dcook
14:20:44 <cait> Riiiiight, that's me :)
14:20:47 <cait> (and more)
14:21:13 <cait> #info QAM is looking for some topic expert for LDAP - we got about 4 bugs waiting both queues since forever and I am calling for help!
14:22:13 <tuxayo> Patch testing session with french speakers last week had okay results compared to the time spend. Let's see how it goes with english speakers.
14:22:14 <ashimema> Are those ones I've already touched?
14:22:19 <ashimema> Have a feeling they are
14:22:37 <cait> #info QA Team is down another person with kohaputti leaving - thanks a lot for everything! You'll be missed!
14:22:51 <ashimema> Glad your patch testing sessions are going well tuyaxo
14:23:09 <tuxayo> #info monday 26th, patch testing session: https://lists.katipo.co.nz/pipermail/koha/2022-September/058422.html
14:23:32 <cait> LDAP patches are specifically bug 30646, bug 17215, bug 29930 and bug 11808
14:23:32 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30646 enhancement, P5 - low, ---, martin.renvoize, Signed Off , Add option to send WELCOME notice for new patrons added at first login via LDAP/SAML
14:23:33 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17215 enhancement, P5 - low, ---, janik.hilser, BLOCKED , Cardnumbers of patrons created using LDAP Replication not using autoMemberNum if configured
14:23:34 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29930 normal, P5 - low, ---, janik.hilser, Needs Signoff , Auth with LDAP: Update tag leads to unwanted updates
14:23:35 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11808 enhancement, P5 - low, ---, maryse.simard, Needs Signoff , When searching for a cardnumber in the intranet, also try to search for it on the LDAP server if one is configured and add/update user
14:24:05 <cait> tuxayo: do you want to info something about your patch testing session?
14:24:24 <tuxayo> I infoed the next one
14:24:27 <tuxayo> So it's okay
14:24:35 <cait> ah missed that in the bug noise
14:24:45 <cait> in other news... QA team please QA and testers please test :)
14:24:56 <cait> move on?
14:25:13 <tuxayo> #topic Status of roadmap projects
14:25:23 <cait> do you have the link by chance?
14:25:24 <tuxayo> #info https://annuel.framapad.org/p/koha_22.11_roadmap
14:25:30 <cait> perfect
14:25:48 <tcohen> hi all
14:25:55 <cait> you are jsut on time
14:25:55 <tuxayo> thd, tcohen , mtj, anothing about the wiki migration
14:25:57 <cait> roadmap update? :)
14:26:09 <cait> yes, maybe start with wiki migration
14:26:29 <thd> I fixed a bug for generating the postmigration database.
14:26:59 <thd> I fixed a bug for generating the postupdate database.
14:27:22 <mtj> i have been AWOL for a bit re: wiki stuff, will have a catchup with thd
14:27:26 <tcohen> I'm catching up with things after being absent-ish last week
14:27:29 <cait> is it a matter of finding another date now?
14:28:02 <cait> I am keen to start properly categorizing wiki pages once we got the new editor for it :)
14:28:07 <tcohen> thd provided an export of the migrated data, which he also fixed yesterday
14:28:09 * ashimema had totally failed at working on roadmap as a priority this cycle
14:28:21 <mtj> thd++
14:28:24 <tcohen> the plan is to load it in https://wiki.test.koha-community.org
14:28:29 <tcohen> ASAP
14:28:51 <ashimema> Excellent
14:28:51 <wahanui> darn tootin' it is.
14:29:04 * tcohen is opening the roadmap, sorry
14:29:20 <tcohen> OK, yeah
14:29:31 <cait> we have a bunch on the actions from last meeting today - maybe only touch those that have news
14:29:56 <thd> I have also been testing MediaWiki Canasta Docker container but do not have sufficient experience working with Docker containers.
14:30:00 <ashimema> +1
14:30:05 <tcohen> * Task queue
14:30:14 <cait> #info Wiki update is to continue ASAP - thd fixed another error and we hope for news very soon
14:31:00 <tcohen> We've made good progress here. The important stuff has moved, adding an API for displaying jobs info is NQA
14:31:35 <tcohen> moving stage MARC import into the task queue is PQA, we are doing great
14:31:49 <thd> The bug fix was a newly introduced bug and trivial for moving some code a few lines.
14:32:02 <cait> #info Staff interface redesign (bug 30952) is being worked on intensely. You can use patches on bug to set up a sandbox, issues for the branch are tracked on github: https://github.com/jajm/koha-staff-interface-redesign/issues (lots of screenshots to see)
14:32:02 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30952 enhancement, P5 - low, ---, julian.maurice, Needs Signoff , New design for staff interface
14:32:14 <tcohen> About the ERM and Vue, I've asked Agustin to look at the Vue integration done on that development. Any other Vue expert please take a look
14:32:40 <cait> #info Task queue: is moving along: API for jobs info is NQA, moving MARC import is PQA
14:32:53 <tcohen> C4::Biblio and C4::Items refactoring has moved steadily
14:33:06 <tcohen> lots of things already in master and old code removed
14:33:07 <cait> #info ERM Any Vue experts: Please have a look at the ERM development
14:33:58 <tcohen> CSRF prevention: we should do a 'CSRF day' in which we all chat about it, test it to make sure all is covered, and push it
14:34:01 <cait> #info Rewrite of C4::Biblio and C4::Items is progressing with some bigger patches pushed lately
14:34:19 <cait> do you want me to action you for calling that day?
14:34:21 <cait> :)
14:34:29 <tcohen> ok
14:34:46 <ashimema> ++
14:34:49 <tcohen> ashimema: anything to say about availability/policy in the Koha::* namespace
14:34:53 <cait> #action tcohen to schedule/call a "CSRF day" to work on related patches together
14:35:35 <ashimema> I need to get back on to it.. made lots of progress then went on vacation ;)
14:36:01 <tcohen> Not on the roadmap, but OAuth2/OIDC can already be tested, though it has on UI and the oauth providers need to be configured using the API <.<
14:36:04 <tcohen> https://gitlab.com/thekesolutions/Koha/-/commits/oauth_client
14:36:23 <tcohen> working on the login form right now
14:36:26 <cait> maybe also note ont he bug?
14:36:30 <cait> I had been asked about that one :)
14:36:41 <tcohen> That branch is not expected to be polished :-D
14:36:44 <tcohen> ok, I will
14:36:57 <cait> thx
14:36:59 <cait> tcohen++
14:37:09 <tcohen> wow, time flies!
14:37:09 <ashimema> I've reviewed that one and it's all pretty solid looking to me
14:37:15 <cait> #info OAuth2/OIDC work is progressing, see https://gitlab.com/thekesolutions/Koha/-/commits/oauth_client
14:37:22 <ashimema> Will be much easier to fully reviews once we have a simple configuration ui
14:37:41 <tcohen> absolutely, it should be submitted by the end of the week
14:37:49 <cait> great news overall!
14:37:51 <cait> team++
14:37:55 <ashimema> Awesome
14:38:23 <cait> ready to move on?
14:38:30 <tcohen> that's all, thanks everyone for the great submissions
14:38:42 <cait> #topic Actions from last meeting
14:38:42 <tcohen> also
14:38:45 <cait> ups
14:38:46 <tcohen> joonas++
14:39:11 <ashimema> joonas++
14:39:15 <tuxayo> joonas++
14:39:16 <cait> joonas++
14:39:32 <tuxayo> «ashimema needs to remove an introduced warning on bug 28854 tests (or test for its existence) »
14:39:32 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28854 new feature, P5 - low, ---, martin.renvoize, RESOLVED FIXED, Add ability to create bundles of items for circulation
14:40:01 <cait> RESOLVED fixed... done?
14:40:14 <ashimema> I think I did that one
14:40:16 <tuxayo> "introduced warning"
14:40:22 <ashimema> Yup
14:40:23 <tuxayo> So it need a followup?
14:40:25 <ashimema> Done
14:40:28 <cait> follow-up pushed to master
14:40:28 <tuxayo> ok
14:40:32 <cait> next: liliputech (deferred from previous meetingx2) discuss koha CI (docker  image built + manual build) hosting on gitlab instance provided by  BibLibre's partner AFI.
14:41:25 <tuxayo> #action liliputech (deferred from previous meetingx3) discuss koha CI (docker  image built + manual build) hosting on gitlab instance provided by  BibLibre's partner AFI.
14:41:33 <tuxayo> @later tell liliputech any news about that? http://irc.koha-community.org/koha/2022-09-14#i_2450094
14:41:33 <huginn`> tuxayo: The operation succeeded.
14:41:57 <tuxayo> next: «Katrin to update LTS wiki page with current information from last dev meeting»
14:42:43 <cait> I am sorry, I missed doing that
14:43:03 <cait> @action cait to update LTS wiki page
14:43:04 <huginn`> cait: I'll give you the answer as soon as RDA is ready
14:43:04 <wahanui> i already had it that way, huginn`.
14:43:12 <tuxayo> #action Katrin to update LTS wiki page with current information from last dev meeting
14:43:21 <cait> ah right
14:43:21 <tuxayo> next: «tcohen will make a counter proposal about public_read_list() »
14:43:39 <cait> do we have a bug number for that one?
14:44:17 <tcohen> I will go with Martin's idea of making it raise an exception
14:44:29 <tcohen> consider the action ended
14:44:42 <ashimema> I can't remember what we discussed around it.. oops
14:44:56 <cait> ashimema will file a bug making Koha::Object::public_read_list throw an exception
14:44:56 <tuxayo> ok
14:44:57 <ashimema> But happy to submit making it their an exception
14:45:12 <ashimema> Will do once gone from school run
14:45:27 <cait> rename the master branch to 'main'
14:45:34 <cait> I think this could have been a topic actually
14:45:40 <tuxayo> yes it is
14:45:43 <cait> hm we do have it int he next section too
14:45:47 <cait> ok, so maybe we move?
14:45:48 <tuxayo> I forgot to move it
14:46:02 <tuxayo> I moved it 5 min ago so juste refresh
14:46:03 <cait> #topic General development discussion (trends, ideas, ...)
14:46:10 <tuxayo> #action ashimema will file a bug making Koha::Object::public_read_list throw an exception
14:46:22 <tuxayo> «Renaming "master" branch. To "main" for example»
14:46:31 <cait> Rename "master" branch - suggestion: main
14:46:34 <cait> heh
14:46:41 * tcohen likes
14:46:50 <cait> I thnk if we do it, maybe at the beginning of the cycle
14:47:10 <mtj> i bumped into a security bug recently, will log a bug
14:47:14 <cait> it might need quite a lot of changes in scripts etc so better to do that early cycle
14:47:17 <tuxayo> main gets the most support. Catalyst uses that since a 1year+ and no confusion issue in day to day usage.
14:47:50 <cait> I also liked dev or development as a suggestion
14:48:03 <cait> because it eplains a bit better - but was told main was some kind of new standard?
14:48:05 <ashimema> main is good..
14:48:13 <ashimema> Mmm
14:48:18 <mtj> #info im working on a wiki doc to fix API proiblems, will upload today
14:48:31 <cait> mtj++
14:48:39 <cait> will be so happy to have something to point people to :)
14:48:41 <tuxayo> «main was some kind of new standard?»
14:48:41 <tuxayo> Indeed
14:48:56 <ashimema> Dev is also fine with me
14:49:13 <ashimema> I find both main and trunk a little ambiguous
14:49:28 <ashimema> But most Devs will understand without any explanting
14:49:35 <tcohen> it's Gitlab's default
14:49:37 <ashimema> Expplanation
14:50:22 <mtj> 'main' does seem to be a newish popular choice, so... im happy with that :)
14:51:00 <cait> I am ok with it too
14:51:11 <cait> what i'd like is make sure we have all things working still...
14:51:23 <cait> like have some easy to go instructions for people like me what to change on local repos etc. :)
14:52:31 <tuxayo> Is main okay enough to go with it or does someone feel like doing a poll between that and the other choices?
14:52:50 <ashimema> Worth a global search on master in the wiki
14:52:57 <mtj> #info i'll aim to chat to arthur about the koha CI stuff on AFI
14:53:00 <ashimema> I'd just go for it
14:53:59 <cait> I am not sure what all is involved and how much this woudl disrupt workflows - so happy to just follow someone taking the lead really
14:54:27 <tcohen> what would be the benefits compared to using Gitlab.com
14:54:31 <cait> happy to help with wiki changes when triggered to do so
14:54:33 <tcohen> is a good question
14:54:33 <tuxayo> So #agree about renaming "master" to "main"?
14:54:53 <cait> tcohen: isn't that a different topic?
14:55:14 <tcohen> about mtj's comment, sorry
14:55:31 <cait> oh right
14:55:32 <tcohen> let's make a vote please
14:55:40 <cait> tuxayo: yo or me?
14:55:40 <tuxayo> ok
14:55:45 <cait> you :)
14:57:34 <tuxayo> #startvote Renaming master branch to main? Yes, No, Another name would be way better, Asbtain
14:57:34 <huginn`> Begin voting on: Renaming master branch to main? Valid vote options are Yes, No, Another, name, would, be, way, better, Asbtain.
14:57:34 <huginn`> Vote using '#vote OPTION'. Only your last vote counts.
14:57:43 <tuxayo> oh no
14:57:47 <tuxayo> #endvote
14:57:47 <huginn`> Voted on "Renaming master branch to main?" Results are
14:57:57 <cait> the typo in abstain?
14:58:13 <tuxayo> #startvote Renaming master branch to main? Yes, No, Another_name_would_be_way_better, Abstain
14:58:13 <huginn`> Begin voting on: Renaming master branch to main? Valid vote options are Yes, No, Another_name_would_be_way_better, Abstain.
14:58:13 <huginn`> Vote using '#vote OPTION'. Only your last vote counts.
14:58:20 <tuxayo> Thanks cait
14:58:24 <tuxayo> #vote yes
14:58:25 <cait> #vote Yes
14:58:30 <tcohen> #vote Yes
14:58:34 <thd> #vote Yes
14:59:24 <ashimema> #vote Yes
15:00:32 <cait> tuxayo: got to step out for a moment
15:00:37 <tuxayo> k
15:00:53 <tuxayo> last seconds to vote
15:01:32 <tcohen> bag, kidclamp, khall, lukeg
15:02:01 <oleonard> #vote Yes
15:03:33 <cait> end vote?
15:03:41 <tuxayo> #endvote
15:03:41 <huginn`> Voted on "Renaming master branch to main?" Results are
15:03:41 <huginn`> Yes (6): cait, oleonard, ashimema, tuxayo, tcohen, thd
15:04:00 <cait> we do have quite a bit more topics but are over time already
15:04:08 <tuxayo> Last minute call to some people made me wait a bit :)
15:04:12 <cait> coudl those be postponed or is there something that needs resolving urgently?
15:04:15 <tuxayo> «how much this woudl disrupt workflows»
15:04:17 <tuxayo> My guess is likely not much after fixing all CI jobs. Locally it's about reminding to checkout main instead of master and deleting the local master. Which might cause some submission of patches that don't apply due to people not knowing/forgetting the change. The RMaint scripts should be ok.
15:04:45 <mtj> tcohen: re gitlab versus self-hosted - im not too sure of differences
15:04:49 <cait> my muscle memory will make this terrible for a whiel :)
15:05:04 <cait> (remembering to checkout main)
15:05:09 <tuxayo> #agreed Renaming master branch to main
15:05:48 <cait> so about the next topics?
15:05:51 <tuxayo> Who to volunteer to coordinate the change?
15:05:59 <cait> aah right!
15:06:04 <cait> who is taking the hat?
15:06:11 <mtj> tcohen: gitlab may allow us to use more 'runners', but we might hit limitations with gitlab too
15:06:15 <tcohen> I'm doing it
15:06:35 <mtj> tcohen++
15:06:44 <tuxayo> tcohen++
15:07:46 <tuxayo> tcohen: action for next meeting to have a date for the switch and list of stuff to change on that moment?
15:07:53 <tcohen> yes
15:08:38 <tuxayo> #action tcohen Date proposal for master→main change and draft of action list
15:09:07 <tuxayo> last topic about the CI stuff and we postpone reste?
15:09:21 <cait> sounds good to me
15:09:33 <cait> unless ES7 is a simple yes or no :)
15:09:47 <mtj> no :)
15:10:00 <tuxayo> It's about calling for volunteer to use it in production
15:10:44 <tuxayo> «what would be the benefits compared to using Gitlab.com»
15:10:44 <tuxayo> This dates from the time it was uncertain for Gitlab.com
15:11:20 <tuxayo> If people are motivated switch to community hosted, why not.
15:11:56 <mtj> #info i think we should aim to have koha 22.11 with ES7, running on deb11 and higher
15:12:07 <tcohen> +1
15:12:15 <cait> mtj: can you outline what is missing to achieve that?
15:13:15 <mtj> cait: all tests are passing now, so just updating doco and announcements
15:14:10 <tuxayo> I recall it was mentioned for ES 7 (and OpenSearch also I guess): A few instances using it in production to confirm nothing major is wrong.
15:14:42 <tcohen> I've gotta leave to take kids to school. Just a last comment: I'm favor of completely deprecating a distro support for new releases if not doing so would drain our energies
15:15:00 <tcohen> *an old distro version support*
15:15:47 <mtj> perhaps we suggest ES6 on koha-22.05 with deb10
15:15:54 <cait> we found bug 31471 testing package installation and kohadevbox - not sure if it relates to version, but seemed a good time to get some attention :)
15:15:54 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31471 normal, P5 - low, ---, koha-bugs, NEW , Duplicate check in cataloguing doesn't work with Elasticsearch
15:16:13 <mtj> ...and we suggest ES7 on koha-22.11 with deb11
15:16:30 <cait> is there something we should #info?
15:16:35 <cait> bit lost on this topic
15:17:11 <tuxayo> mtj: I'm not sure there is that much choice for a lot of implementer that it's useful to suggest a precise conbination.
15:17:37 <tuxayo> «is there something we should #info»
15:17:37 <tuxayo> Not yet, it's still unclear
15:18:31 <mtj> #info perhaps we suggest ES6 on koha-22.05 with deb10,  and ES7 on koha-22.11 with deb11
15:18:42 <tuxayo> «we suggest ES6 on koha-22.05 with deb10»
15:18:42 <tuxayo> ES 6 should be discouraged for all supported branches as soon as we announce ES 7 I think. Because ES 6 is not maintained since more than a year I think?
15:20:03 <tuxayo> 2022-02-10 actually
15:20:55 <mtj> #info good news is we do have ES7 tests passing on 22.05 and 21.11
15:21:04 <ashimema> dare I raise it.. but would switching from master to main also serve as a good juncture to finally carry out the repository split we've been considering for years
15:21:12 <tuxayo> And down to 21.05
15:21:52 <tuxayo> ashimema: It doesn't look like it would help. Not much has to be done locally by people having repos.
15:23:42 <tcohen> ashimema: just got back upstairs with that thought LOL
15:23:52 <tuxayo> mtj: Is that ok we aim to advertise ES7 for 22.11 release (and one all branches) and do it sooner if we get real world feedback.
15:23:54 <ashimema> great minds
15:24:01 * tcohen goes back downstairs
15:24:36 <tuxayo> So that people that will stay stuck on 21.05 know that ES7 is supported in case of new ES security release.
15:25:06 <mtj> tuxayo: sounds like a good plan to me
15:26:10 <tuxayo> #info Advertise support for ES7 for all branches on 22.11 release. Or sooner if ES7 real world feedback is enough in the meantime.
15:26:28 <tuxayo> ES7 topic closed
15:26:33 <cait> ok
15:26:35 <tuxayo> CI seems also
15:26:39 <cait> postpone mysql?
15:26:52 <tuxayo> Yes, postpone all the rest
15:27:08 <cait> ok :)
15:27:10 <tuxayo> I'll do it
15:27:28 <tuxayo> #action tuxayo postpone « Are we supporting MySQL? (either 5.7 or 8.0) - CI only tests MySQL 8 on main/master. »
15:27:30 <cait> we shold also check if the calendar has updated after the meeting script has been run
15:27:46 <cait> tuxayo++
15:27:53 <tuxayo> #action tuxayo postpone « SQL8 of our coding guidelines state that SQL should not be in .pl, but should be in the module in C4 or Koha. This would mean that SQL in the Koha namespace is allowed and there is no mention of DBIC in the coding guidelines right now. »
15:28:27 <mtj> tuxayo: i think tcohen said mysql 5.x has some nasty autoincrement problems
15:28:33 <tuxayo> #action tuxayo postpone «Update guidelines with the replacement of jQueryUI Datepicker with flatpickr - introduced in bug 29239. And document the usage in the wiki»
15:28:33 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29239 enhancement, P5 - low, ---, koha-bugs, NEW , [OMNIBUS] Replace jQueryUI's timepicker with flatpickr
15:28:42 <tuxayo> mtj: too late :P
15:28:57 <cait> #topic Set time of next meeting
15:29:04 <cait> 2 weeks wednesday?
15:29:22 <tuxayo> «we shold also check if the calendar has updated after the meeting script has been run»
15:29:22 <tuxayo> I think David N had to update the calendar manually
15:29:23 <cait> 28 September 2022
15:29:41 <cait> yeah, different people running the script had issues with it lately
15:29:49 <tuxayo> When is KohaCon again?
15:29:54 <cait> next week
15:29:54 <wahanui> next week is unknown for me.
15:30:04 <cait> so that woudl be after
15:30:20 <tuxayo> Ok 28 September then
15:30:32 <tuxayo> Let me check the last meeting
15:30:37 <cait> wahanui: feeling the same way
15:30:37 <wahanui> cait: i'm not following you...
15:30:55 <cait> the problem is, if the meeting script doesn't finish, the wiki is not updated witht he meeting minutes either
15:31:05 <tuxayo> #info Next meeting: 28 September 2022, 21 UTC
15:31:15 <tuxayo> Wait before ending
15:31:52 <tuxayo> Next meeting at this timeframe 12 october 14 UTC? (same hour)
15:33:10 <tuxayo> Let's go with it for now
15:33:12 <tuxayo> #info Next Americas-Europe slot meeting: 12 October 2022, 14 UTC
15:33:25 <tuxayo> #endmeeting