#koha: Development IRC meeting 23 March 2022

Meeting started by tuxayo at 15:02:11 UTC (full logs).

Meeting summary

  1. Introductions (tuxayo, 15:02:21)
    1. Victor Grousset, Tuxayo S.L., France (tuxayo, 15:02:28)
    2. Katrin Fischer, BSZ, Germany (cait1, 15:02:31)
    3. Martin Renvoize, PTFS Europe, UK (ashimema, 15:02:32)
    4. Andrew Fuerste-Henry, ByWater Solutions, USA (AndrewFH, 15:02:49)
    5. Andrew Nugged, National Library of Finland, HELSINKI (nugged, 15:03:12)
    6. Thomas Dukleth, Agogme, New York City (thd, 15:04:48)
    7. marcelr (marcelr, 15:05:48)
    8. https://wiki.koha-community.org/wiki/Development_IRC_meeting_23_March_2022 Today's agenda (tuxayo, 15:07:24)

  2. Announcements (tuxayo, 15:07:38)
    1. Jonathan Druart (Joubu, 15:08:57)
    2. https://www.arrosoir-marseille.com/ (Joubu, 15:13:06)

  3. Update from the Release manager (22.05) (tuxayo, 15:13:34)
  4. Updates from the Release Maintainers (tuxayo, 15:16:34)
  5. Updates from the QA team (tuxayo, 15:17:50)
    1. Tomas Cohen Arazi, Cordoba (tcohen, 15:21:20)
    2. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 15:31:22)

  6. Actions from last meeting (tuxayo, 15:31:48)
    1. ACTION: fridolin checking the GUI tool for alter on AnonymousPatron (tuxayo, 15:32:07)
    2. ACTION: fridolin create bug report for skipping AnonymousPatron from delete_patrons.pl (tuxayo, 15:32:12)

  7. General development discussion (trends, ideas, ...) (tuxayo, 15:37:18)
  8. Review of coding guidelines (tuxayo, 15:54:35)
    1. ACTION: tuxayo add "New notices should always be using TT syntax" in coding guidelines. (tuxayo, 16:02:03)
    2. https://wiki.koha-community.org/wiki/Coding_Guidelines#NOTICE1:_Default_Notices_should_now_be_writing_using_template_toolkit (ashimema, 16:02:23)
    3. https://annuel.framapad.org/p/koha_21.05_roadmap (Joubu, 16:04:43)
    4. https://wiki.koha-community.org/wiki/Coding_Guidelines#PERL30:_Pass_references_when_adding_a_new_plugin_hook (tuxayo, 16:10:15)
    5. VOTE: Voted on "Validate PERL30 draft?" Results are, Yes: 5 (tuxayo, 16:14:03)
    6. Next meeting: 6 April 2022, 22 UTC (tuxayo, 16:20:18)


Meeting ended at 16:20:55 UTC (full logs).

Action items

  1. fridolin checking the GUI tool for alter on AnonymousPatron
  2. fridolin create bug report for skipping AnonymousPatron from delete_patrons.pl
  3. tuxayo add "New notices should always be using TT syntax" in coding guidelines.


Action items, by person

  1. tuxayo
    1. tuxayo add "New notices should always be using TT syntax" in coding guidelines.
  2. UNASSIGNED
    1. fridolin checking the GUI tool for alter on AnonymousPatron
    2. fridolin create bug report for skipping AnonymousPatron from delete_patrons.pl


People present (lines said)

  1. ashimema (110)
  2. tuxayo (91)
  3. Joubu (49)
  4. cait1 (28)
  5. marcelr (20)
  6. huginn (13)
  7. nugged (13)
  8. tcohen (13)
  9. wahanui (7)
  10. udkoha (4)
  11. kidclamp (4)
  12. oleonard (3)
  13. thd (3)
  14. AndrewFH (2)
  15. reiveune (1)


Generated by MeetBot 0.1.4.