#koha: Development IRC meeting 9 March 2022

Meeting started by tuxayo at 10:01:15 UTC (full logs).

Meeting summary

  1. Introductions (tuxayo, 10:01:33)
    1. Victor Grousset, Tuxayo Company Limited, France (tuxayo, 10:02:36)
    2. Jonathan Druart (Joubu, 10:03:51)
    3. Fridolin Somers, Biblibre, France (fridolin, 10:03:54)
    4. Martin Renvoize, PTFS Europe, UK (ashimema, 10:03:58)
    5. https://wiki.koha-community.org/wiki/Development_IRC_meeting_9_March_2022 Today's agenda (tuxayo, 10:05:07)

  2. Announcements (tuxayo, 10:06:37)
    1. Katrin Fischer, BSZ, Germany (cait1, 10:09:48)
    2. Hackfest registration: email paul.poulain AT biblibre DOT com (tuxayo, 10:10:26)
    3. KohaCon 2022: In Lawrence, Kansas by koha-US. Please fill survey for attendance to help pick venue size (tuxayo, 10:11:15)
    4. it should be (or should come) in the general mailing list (tuxayo, 10:12:10)
    5. KohaCon: the selected dates are September 20-23, 2022 (tuxayo, 10:13:04)
    6. Koha Community Challenge https://runsignup.com/Race/CA/anywhere/KohaCommunityChallengeSpringintoFitness (tuxayo, 10:14:39)
    7. Bug Squashing Event in May: https://bywatersolutions.com/education/celebrate-open-source-with-this-bug-squashing-event (tuxayo, 10:14:59)
    8. In France there will be the a meeting event in May in Orléans https://koha-fr.org/symposium-2022 (tuxayo, 10:15:18)

  3. Update from the Release manager (22.05) (tuxayo, 10:15:55)
    1. Beware behavior around AnonymousPatron with Bug 30007 pushed (fridolin, 10:18:20)
    2. ACTION: fridolin checking the GUI tool for alter on AnonymousPatron (fridolin, 10:22:54)
    3. ACTION: fridolin create bug report for skipping AnonymousPatron from delete_patrons.pl (fridolin, 10:29:01)
    4. https://git.koha-community.org/Koha-community/Koha/src/branch/master/Koha/Patron.pm#L375 (ashimema, 10:29:51)
    5. ACTION: tuxayo update wiki to remove ub16.04 support for Koha 21.11 (and check if MariaDB versions should change also) (tuxayo, 10:34:31)

  4. Updates from the Release Maintainers (tuxayo, 10:37:11)
  5. Updates from the QA team (tuxayo, 10:41:56)
  6. Actions from last meeting (tuxayo, 10:45:55)
    1. https://lists.katipo.co.nz/pipermail/koha/2022-February/057429.html (Joubu, 10:48:16)

  7. General development discussion (trends, ideas, ...) (tuxayo, 10:49:55)
    1. https://lists.katipo.co.nz/pipermail/koha/2022-February/057447.html (Joubu, 11:10:53)
    2. plan for and ERM in Koha https://wiki.koha-community.org/wiki/ERM https://lists.katipo.co.nz/pipermail/koha/2022-February/057447.html (tuxayo, 11:16:05)

  8. Review of coding guidelines (tuxayo, 11:17:42)
    1. https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30072#c16 (tuxayo, 11:17:47)
    2. https://git.koha-community.org/Koha-community/Koha/src/branch/master/Koha/Plugins.pm#L69 (ashimema, 11:23:02)
    3. ACTION: ashimema draft coding guideline about reference passing for plugins (tuxayo, 11:26:08)

  9. Set time of next meeting (tuxayo, 11:27:02)
    1. Next meeting: 23 March 2022, 15 UTC (tuxayo, 11:31:49)


Meeting ended at 11:32:38 UTC (full logs).

Action items

  1. fridolin checking the GUI tool for alter on AnonymousPatron
  2. fridolin create bug report for skipping AnonymousPatron from delete_patrons.pl
  3. tuxayo update wiki to remove ub16.04 support for Koha 21.11 (and check if MariaDB versions should change also)
  4. ashimema draft coding guideline about reference passing for plugins


Action items, by person

  1. ashimema
    1. ashimema draft coding guideline about reference passing for plugins
  2. fridolin
    1. fridolin checking the GUI tool for alter on AnonymousPatron
    2. fridolin create bug report for skipping AnonymousPatron from delete_patrons.pl
  3. tuxayo
    1. tuxayo update wiki to remove ub16.04 support for Koha 21.11 (and check if MariaDB versions should change also)


People present (lines said)

  1. tuxayo (111)
  2. ashimema (84)
  3. Joubu (83)
  4. fridolin (74)
  5. cait1 (36)
  6. huginn (15)
  7. koha-jenkins (9)
  8. alohabot (1)


Generated by MeetBot 0.1.4.