17:56:09 <Brooke_> #startmeeting
17:56:09 <huginn> Meeting started Wed Mar  2 17:56:09 2011 UTC.  The chair is Brooke_. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:56:09 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:56:20 <Brooke_> #topic Introductions
17:56:41 <paul_p> paul_p, BibLibre, France
17:56:45 <Brooke_> Haere Mai, Egondea, Welcome to #koha, please introduce yourselves as we wait for others to arrive :)
17:56:52 * gmcharlt = Galen Charlton, Equinox
17:56:54 * cait = Katrin Fischer, BSZ, Germany
17:57:00 <thd> Thomas Dukleth, Agogme, New York City
17:57:07 * jcamins = Jared Camins-Esakov, ByWater Solutions
17:57:10 <kmkale> chatzilla tells me we are 4 mins early ;)
17:57:11 <jwagner> Jane Wagner, PTFS
17:57:16 * wizzyrea liz rea, NEKLS
17:57:17 * slef = MJ Ray, CEO software.coop
17:57:19 * davi davi = worker for software.coop
17:57:19 <JesseM> Jesse Maseto, ByWater Solutions
17:57:21 * magnuse Magnus Enger. Libriotech, Norway
17:57:30 <slef> kmkale: I think we are early too
17:57:44 <kmkale> Koustubha Kale Anant Corporation, VPM, Thane, granthalaya.org
17:57:46 <bg> Brendan Gallagher ByWater Solutions
17:57:47 * sekjal is Ian Walls, ByWater Solutions
17:58:26 <SandeepBhavsar> Sandeep Bhavsar Librarian Vidya Prasarak mandal, Thane's  Dr. V N Bedekar Institute of Management Studies
17:59:15 <NateC> Nate Curulla: ByWater Solutions
17:59:33 <space_librarian_home> Shelley Gurney, Catalyst IT
17:59:58 * hdl Henri-Damien LAURENT, biblibre
18:00:36 <Brooke_> welcome everyone again and now it is properly time ;)
18:00:49 <Brooke_> #topic Roadmap to 3.2
18:01:08 <Brooke_> so, do we have an update on the 3.2 Roadmap?
18:01:21 <slef> Do we have a chris_n?
18:01:47 <gmcharlt> chris_n++ # 3.2.4 and 3.2.5
18:02:00 <wizzyrea> chris_n++
18:02:05 <hdl> chris_n++
18:02:08 <wizzyrea> maybe enough beeps will raise him
18:02:16 <Brooke_> chris_n++ for timely delivery :D
18:02:28 <cait> chris_n++
18:02:52 <paul_p> can we speak of a security list as 3.2.5 has been released because of a security (hacker) issue ?
18:03:00 <slef> chris_n++ for timely releases, chris_n-- for not being here or putting his report on the wiki page?
18:03:04 <Brooke_> paul go for it
18:03:05 <gmcharlt> paul_p: I've added an item to the agenda
18:03:13 <gmcharlt> after the KohaCon 11 discussion
18:03:15 <paul_p> gmcharlt, sorry, missed it
18:03:23 <Brooke_> it's not on mine either
18:03:30 <gmcharlt> paul_p:  no problem, I *just* added it now
18:03:36 <paul_p> ah, ok ;-)
18:03:39 <gmcharlt> http://wiki.koha-community.org/wiki/General_IRC_Meeting,_2_March_2011#Agenda
18:03:47 <Brooke_> makes more sense here, methinks.
18:03:57 <slef> #link http://wiki.koha-community.org/wiki/General_IRC_Meeting,_2_March_2011
18:03:58 <gmcharlt> Brooke_: it's not specific to 3.2
18:04:05 <Brooke_> okily dokily.
18:04:33 <gmcharlt> shall we move on to 3.0?
18:04:36 <Brooke_> yep
18:04:43 <Brooke_> #topic 3.0 Roadmap
18:05:04 <mtj_> morning
18:05:05 <gmcharlt> I actually have an update for 3.0 - with hdl's consent, I intend to cut a security release of 3.0
18:05:14 <gmcharlt> which, IIRC, would make it 3.0.7
18:05:21 <hdl> yes.
18:06:24 <Brooke_> anything else?
18:06:24 <wahanui1> rumour has it anything else is reinventing the wheel
18:06:31 <gmcharlt> and ... I think that's about it for an update on 3.0
18:06:42 <Brooke_> brevity is a virtue sir
18:06:51 <Brooke_> #topic Roadmap to 3.4
18:06:58 <hdl> yes. it should be noted in the relase notes that it should be the last.
18:07:09 <Brooke_> Chris is skived off to a cool conference
18:07:16 <Brooke_> anyone want to sub?
18:07:20 <paul_p> I have something to say about 3.4 & bugzilla.
18:07:32 <Brooke_> shoot
18:07:58 <Brooke_> allez :D
18:08:05 <slef> #info the apologies section of the wiki page says "chris cormack will try to be there but is at a conference"
18:08:20 <paul_p> I did a lot of wrangling recently, and have some important numbers :85 bugs are "patch pushed" waiting for "bug closed" and 152 bugs "needs signoff"
18:08:48 <paul_p> What can we do to lower those numbers ?
18:09:04 <hdl> hehe: test and sign off ;)
18:09:10 <paul_p> the more there are, the hard it is to deal with them (specially the "need sign-off")
18:09:28 <paul_p> hdl, yes, so I change my question = how can we motivate ppl to sign-off & close ?
18:09:46 <paul_p> should we organise a "wrangling day" ? should we publish a weekly summary ?
18:09:51 <cait> I think hdl is right, we need more people testing and signing-off
18:09:53 <paul_p> a news in the newsletter ?
18:09:55 <magnuse> it's probably a question of time for most of us...
18:09:55 <sekjal> scoreboard
18:10:04 <wizzyrea> scoreboard++
18:10:04 <Brooke_> #idea Wrangling Day
18:10:23 <Brooke_> a newsletter item would make nengard happy
18:10:23 <hdl> what could help would be to have some dedicated server with as many vhosts as branches
18:10:26 <Brooke_> so I'm all for it
18:10:34 <gmcharlt> hdl: is BibLibre offering to set one up?
18:10:47 <hdl> we could do that.... on the new jenkins server.
18:10:56 <hdl> Problem would be the databases...
18:11:10 <paul_p> magnuse, yes, but once we've said it's a question of time, we have 2 options: or we *decide* to do something, each of us taking, for example 20 bugs. or we do nothing, and those numbers will continue to grow and our workflow is just a theory,...
18:11:26 <slef> magnuse++
18:11:31 <hdl> any help would be appreciated in setting that up and automating that..
18:11:32 <Brooke_> #help bug wranglers to address backlog
18:11:35 <paul_p> I don't have time, but I take time !
18:11:45 <magnuse> paul_p++
18:11:58 <paul_p> last night I worked up to 1AM, and signed/closed something like 20
18:12:17 <paul_p> (i'm not asking everybody to work up to 1AM ;-) )
18:12:27 <paul_p> s/asking/suggesting/
18:12:37 <magnuse> (it might help, though ;-) )
18:12:40 <Brooke_> I appreciate your dedication, as always Paul
18:12:57 <paul_p> thx Brooke_, but me alone won't be enough.
18:13:01 <thd> hdl: Do you not have appropriate test databases?
18:13:15 <hdl> thd: we have for unimarc
18:13:24 <Brooke_> I realise that, and I like the 20 per person. Do we have enough volunteers that could spare the time and technical expertise to make this happen?
18:13:26 <hdl> and databases are not automated.
18:13:41 <slef> Each time I put aside time, by the point I've got myself to the point of having a current master, reminded myself how to do the signing-off and found something I could test (right MARC format, reproducible problem, and so on), I'm out of time. Why does it take so long?
18:13:42 <paul_p> a good, but not enough news: Julian Maurice started yesterday a 6month time with us. He's a student, and will be dedicated to signin/closing/submitting BibLibre patches.
18:13:42 <gmcharlt> with respect, it is not just a numbers game
18:13:44 <hdl> And some bugs are really tightened to some systempreferences
18:13:55 <gmcharlt> the quality of the signoffs and testing also matters
18:14:13 <slef> gmcharlt++ security_bugs--
18:14:27 <cait> gmcharlt++
18:14:41 <magnuse> gmcharlt++
18:14:41 <Brooke_> I'd imagine that they won't necessarily break down cleanly as some would work packaged together, too
18:14:55 <Brooke_> but someplace there needs be a line drawn if we can manage
18:14:56 <sekjal> would be really helpful if bug reports came with testing plans.  "Here is how to confirm a fix works"
18:14:59 <gmcharlt> in terms of prioritizing, I suggest that the patches awaiting signoff should come first
18:14:59 <Brooke_> many hands make light work.
18:15:05 <davi> I could contribute 1 hour of my time to sign some bugs more
18:15:09 <thd> I think that we need to develop some automated systems for testing so that testing becomes easier.
18:15:09 <paul_p> gmcharlt, double right = it also means that it takes time to signoff/close (see some bugs that i've commented "can't sign-off")
18:15:12 <Brooke_> sekjal good idea
18:15:20 <Brooke_> thank you davi
18:15:20 <gmcharlt> once a patch has been pushed, it has presumably been tested at least once (by the person who signed off)
18:15:29 <slef> hdl++ do we need syspref summarising in "About Koha"?
18:15:33 <Brooke_> #idea automated testing
18:15:44 <gmcharlt> so additional testing to close the bug, while still important, is hopefully less of an issue
18:15:47 <Brooke_> #idea testing plans in conjunction with patches
18:15:52 <davi> no Brooke_
18:15:54 <davi> np
18:16:15 <hdl> slef: i think we could adding some test plans to reproduce the bug would be helpfull...
18:16:20 <paul_p> another idea = having more than one setup, with various configs (like marc21/unimarc , IndependantBranches ON/OFF,...)
18:16:27 <hdl> But it would add some more overhead to declare bugs.
18:16:38 <thd> I did not mean that all tests should be automated but we need to have good automation for setting up tests run by humans checking behaviour.
18:17:06 <slef> hdl: I think reporting already asks for steps to reproduce the bug
18:17:20 <wizzyrea> it does
18:17:26 <thd> paul_p++ Yes, that is what I meant.
18:17:27 <cait> I am not sure we have a technical problem
18:17:38 <cait> the easy bugs are done quickly - like interface changes
18:17:40 <hdl> slef: sometimes the bug comes because of one system preference.
18:17:48 <wizzyrea> cait: agreed
18:17:49 <hdl> And user are not aware of that.
18:18:07 <cait> but there are some things I have no idea about - we need people with enough knowledge looking at them
18:18:13 <mtj_> some bugs really need attached bib and syspref .sql files
18:18:14 <paul_p> can we consider that someone who declares a bug should be the one who closes it when "patch pushed" ? I could send some reminders to ppl in this situation ?
18:18:20 <slef> hdl: that's what I mean. If user could get a syspref summary code from "About Koha" to paste in the report which was useful to us that may help.
18:18:24 <hdl> mtj++
18:18:32 <mtj_> complex circ bugs, etc
18:18:43 <wizzyrea> slef++ a report about the reporter's config
18:18:47 <wizzyrea> would help immensely
18:18:51 * Brooke_ nods.
18:18:58 * paul_p agrees too
18:19:01 <gmcharlt> paul_p: yes, general the person who first reported a bug ought to test and close it, so reminders would be appropriate
18:19:12 <slef> I think mtj_ might be right - it would be a settings file to attach to the bug.
18:19:13 <hdl> #idea add a syspref summary code from About Koha" to paste in the report which was useful to us that may help.
18:19:14 <Brooke_> #idea enhancing About Koha to report more configuration details
18:19:18 <gmcharlt> (at least for project regulars, no need to bug somebody who just dropped by to report a bug)
18:19:21 <mtj_> hdl++, yes, a very nice idea to work towards
18:19:23 <paul_p> ok, will send reminder soon unless someone objects.
18:19:42 <Brooke_> I am hearing no objections
18:19:44 <Brooke_> am I right?
18:20:07 <paul_p> #idea paul_p will send mail reminders to ppl that have a bug where they are "reporter" that is "patch pushed, pls close"
18:20:08 <Brooke_> #action Paul to send a reminder about bug workflow details
18:20:10 <mtj_> an 'about this koha' page, to attach to bug reports
18:20:27 <thd> mtj_: Some bugs definitely require much more testing work but anything we can do to make any testing easier on people with limited time should help.
18:21:20 <slef> mtj_: we already have that, don't we?
18:21:37 * paul_p will deal with biblibre ppl that are no more working at BibLibre :\
18:21:44 <paul_p> (nahuel mostly)
18:22:06 <davi> Sometimes the one who report a bug do not have the expertise to test-close it
18:22:21 <gmcharlt> paul_p: is he still around (in the sense of having any interest or time to work on Koha)?
18:22:25 <magnuse> davi: true
18:22:49 <hdl> gmcharlt: he is around on koha-fr but no longer any time to work on koha
18:22:50 <paul_p> gmcharlt, nope. working for a university using Koha (AixMarseille), but not on Koha at all
18:23:01 <gmcharlt> davi: perhaps, but hopefully they should at least recognize when the initial problem they reported now appears to be working
18:23:14 <hdl> gmcharlt++
18:23:15 <gmcharlt> paul_p: thanks
18:23:30 <davi> gmcharlt, working in the new release, that is to say, check close after release
18:23:43 <davi> note they can not even install a dev version maybe
18:23:56 <davi> ?
18:24:23 <gmcharlt> davi: well, then they'd have to wait until the new release to test, then
18:24:40 <gmcharlt> though that leads to a variant of one of the ideas discussed
18:24:43 <davi> It is OK to ask the reported to test, but IMHO do not set as a "have to" because some ones will not be able to
18:24:48 <gmcharlt> #idea public database that always tracks master
18:25:01 * paul_p is wondering if we should not remind ppl that there are bug to test/close in a weekly/bi-monthly email on koha-devel.
18:25:25 <paul_p> I feel, but i may be wrong, that many ppl could find a few minuts if they knew exactly what to do.
18:25:27 <gmcharlt> davi: hence the distinction I made between project regulars and people who submit the occassional bug report
18:25:32 <slef> paul_p: I think we are always aware of it :-/
18:25:37 <davi> ack gmcharlt
18:26:07 <paul_p> slef, everybody is aware ? i'm not sure. I had Frydolin boss on phone this morning, not sure he was aware.
18:26:12 <Brooke_> it feels like this is exhausted
18:26:30 <gmcharlt> no! we must keep our energy up to close bugs!
18:26:40 <Brooke_> heh
18:26:41 <gmcharlt> Brooke_: oh, you meant the agenda item ;)
18:26:47 <paul_p> and i'm sure he could tell fridolyn to take a few hours!
18:26:58 <paul_p> gmcharlt, no! to what ?
18:27:11 <thd> paul_p: I think that many people would indeed take the issue seriously if all that people had to do was test and not set up and configure the system to run the test.
18:27:11 <gmcharlt> paul_p: as in "no, we must not be exhausted" ;)
18:27:36 <Brooke_> anything else relevant to 3.4?
18:28:07 <Brooke_> movin' on
18:28:09 <schuster> Schuster - Plano ISD
18:28:11 <thd> mtj_: What did you mean by "about this Koha?"
18:28:42 <Brooke_> #topic roles for 3.6
18:28:53 <Brooke_> soooo
18:28:58 <Brooke_> we've a slight problem here
18:29:02 <paul_p> gmcharlt, lol
18:29:06 <Brooke_> but it's not to big to surmount.
18:29:06 <slef> I don't remember who Frydolin is.
18:29:30 <Brooke_> Most of our slate is unopposed
18:29:38 <paul_p> slef, Progilone, french company that won at least 2 contracts in France
18:29:50 <paul_p> (Lyon2 university, Bulac university)
18:29:57 <Brooke_> so I think that we can probably manage a blanket affirmation on those.
18:30:00 * gmcharlt proposes that we proceed with votes on RM, TM, and DM for 3.6; with +1/0/-1 for the current (sole) candiates
18:30:10 <Brooke_> also, a bunch of the usual suspects are missing
18:30:38 <Brooke_> so the proposed Release Manager is Chris Cormack
18:30:39 <slef> gmcharlt: and RMaint?
18:30:42 <Brooke_> all in favour
18:30:44 <magnuse> #link http://wiki.koha-community.org/wiki/Roles_for_3.6
18:30:44 <space_librarian_home> i think Rangi was resigned to his fate before he left
18:30:48 <slef> +1
18:30:51 <gmcharlt> slef: yes, and RMaint
18:30:53 <paul_p> slef, http://www.progilone.com/Templates/Koha.htm
18:31:03 <thd> +1
18:31:05 <magnuse> +1
18:31:07 <paul_p> +1
18:31:07 <gmcharlt> +1
18:31:08 <sekjal> +1
18:31:10 <jcamins> +1
18:31:14 <cait> +1
18:31:15 <space_librarian_home> +1
18:31:18 <wizzyrea> +1
18:31:40 <brendan_> +1
18:31:51 <davi> 0
18:31:57 <JesseM> +1
18:32:12 <schuster> +1
18:32:22 <kmkale> +1
18:32:45 * gmcharlt further moves that we vote on sekjal's bid to be QAM
18:32:47 <Brooke_> #agreed Chris successfully suckered into another 6 months.
18:33:01 <Brooke_> I'm gettin' there gmcharlt.
18:33:04 <Brooke_> that's down the line.
18:33:19 <Brooke_> I go by the list or I git too squirrelly ;P
18:33:41 <Brooke_> Translation Manager is proposed to be Frédéric Demians
18:33:42 <gmcharlt> Brooke_: there is a motion on the table for voting on the slate of RM, TM, DM, and RMaint
18:34:16 <gmcharlt> it might save time to vote on all of the unopposed positions
18:34:23 * slef thought "tabled" meant something different to USians
18:34:34 <Brooke_> which is what I initially said, but I thought there was disagreement on that...
18:34:57 * paul_p was not sure to have understand, but anyway will say +1 once or 4 times.
18:34:58 <gmcharlt> slef: tabled != on the table, in US parliamentary speak
18:35:18 <Brooke_> so how about this
18:35:23 <Brooke_> we know chris is in
18:35:28 <Brooke_> let's bundle the other posts
18:35:33 <Brooke_> is everyone fine with that?
18:35:45 <space_librarian_home> yep
18:35:47 <paul_p> gmcharlt, in france, things that are on the table is usually food :D (kidding, we also use "tabled" in the "to be discussed" too)
18:35:49 <gmcharlt> yes
18:35:54 <Brooke_> so
18:35:59 <thd> Brooke_: I see no opposition to a blanket vote in the log
18:36:20 <slef> paul_p: ("tabled" is "postponed" to US I think)
18:36:34 <mtj__> i would like to propose a *new* position, some person/people to be elected as admins for the Koha lists on nabble.com
18:36:42 <Brooke_> Frédéric Demians for Translation Manager, Nicole Engard for Documentation Manager, Ian Walls for QA, Chris Nighswonger for Release Maintainer
18:36:44 <davi> paul_p, in Spain the discussion of a subject can be on the table too
18:36:54 <Brooke_> hang on to that idea mtj
18:37:02 <Brooke_> I'll come back to it and if I don't yell at meh
18:37:05 <mtj__> *nod*
18:37:18 <Brooke_> so all in favour of the afforementioned blanket slate
18:37:24 <gmcharlt> +1
18:37:27 <magnuse> +1
18:37:29 <space_librarian_home> +1
18:37:35 <thd> slef: 'tabled' meaning postponed is different from 'on the table' meaning the item for current discussion.
18:37:36 <davi> 0
18:37:37 <slef> 0
18:37:39 <thd> +1
18:37:41 <brendan_> +1
18:37:43 <cait> +1
18:37:43 <JesseM> +1
18:37:44 <paul_p> +1
18:37:46 <wizzyrea> +1
18:37:50 <cait> and we have things on the table in Germany too ;)
18:37:54 <sekjal> +1
18:37:56 <slef> thd: not in English English
18:38:13 <jcamins> +1
18:38:18 <schuster> +1
18:38:28 <hdl> +1
18:38:31 <slef> thd: we use "shelved" for postponed instead.
18:38:50 <paul_p> should we vote to decide if we can use the "tabled" word ? :D :D
18:39:08 <thd> slef: Do you use 'tabled' at all?
18:39:09 <slef> paul_p: yeah and we'll lose and still get confused!
18:39:16 * gmcharlt proposes that we use whatever the French term is ;)
18:39:28 <slef> thd: yes, to describe the state of the motion on the table.
18:40:03 <Brooke_> there's a current motion, and there are actions on the table, but not usually both at once
18:40:07 <Brooke_> anyhoo
18:40:11 <Brooke_> think it's safe to say
18:40:17 <Brooke_> #agreed the motion carries
18:40:37 <Brooke_> that leaves us with Bug Wrangler
18:40:42 <Brooke_> and a proposal for a new slot
18:40:47 <thd> slef: What is the standard manual for parliamentary procedure in the UK?
18:40:58 <paul_p> looking at bugwrangler position on the wiki page, I see "to do some PR about the work done", that's what I suggested a few mn ago with my weekly mail ;-) I candidate to write this PR. You'll enjoy my english ;-)
18:40:59 <gmcharlt> I propose that both applications for Bug Wrangler be accepted
18:41:05 <slef> thd: I think the Speaker makes it up as he goes along.
18:41:14 <thd> :)
18:41:17 <paul_p> the more bugwrangler we have the better it is.
18:41:28 <thd> pau_p++++
18:41:29 <cait> gmcharlt++
18:41:31 <Brooke_> I <3 that proposal gmcharlt
18:41:50 <paul_p> and I feel i've been a BW recently, event without the official position...
18:42:12 * Brooke_ notes that paul is getting dangerously close to a nomination with those words...
18:42:28 <slef> just to check, everyone has noticed my drastic WONTFIX plan?
18:42:31 <mtj__> im keen to be a bug-wrangler
18:42:32 * paul_p knew that and accept the position if ppl want ;-)
18:42:57 <Brooke_> so then, I'll entertain a motion to have Marcel de Rooy, MJ Ray, and Paul Poulain as Bug Wranglers.
18:43:07 <cait> I think the more bug wranglers the better
18:43:10 <thd> slef: Would explain you won't fix plan?
18:43:11 <gmcharlt> slef: noticed, though I'd prefer that those bugs be at least glanced at individually before being marked WONTFIX
18:43:14 * gmcharlt is willing to help with that
18:43:25 <cait> I will try to spend more time on it too - after march is over
18:43:32 <slef> gmcharlt: yes, I plan to check each one.
18:43:35 <paul_p> slef, or there is something i'm misunderstanding, or I agree with your proposition
18:43:38 <cait> too many projects at the moment :(
18:43:44 <slef> thd: so that we can concentrate on 3.6, I'd systematically check and RESOLVE WONTFIX the ~140 bugs reported not against maintained versions and I'd suggest reclassifying the 771 bugs reported against master as reported against the version which immediately follows the date they were reported
18:43:55 <mtj__> Brooke_: can i be a bug-wrangler too?
18:44:03 <Brooke_> hmmm
18:44:07 <Brooke_> this is pretty fluid
18:44:16 <Brooke_> what do we do with this as a group?
18:44:22 <sekjal> is there a formal relationship between the Bug Wranglers and the QAM?
18:44:25 <Brooke_> should we have a wrangler of the month?
18:44:29 <davi> sometimes WONTFIX can be as a wish for future version
18:44:34 <Brooke_> or a team with an appointed chair?
18:44:44 <gmcharlt> sekjal: I thnk that would be up to the QAM and the bug wranglers to work out
18:44:57 <cait> some bugs might be reported against older versions but still be existing on master
18:44:58 <thd> slef: I had read that but do you mean not maintained is that bugs reported against 3.0 would not be fixed if no longer maintained?
18:45:04 <sekjal> gmcharlt:  sounds good
18:45:11 <Brooke_> should we then allow Ian to appoint as many bug wranglers as he deems fit?
18:45:12 <paul_p> Brooke_, team-member of the month is only used in Mc Donalds here, so it's really not something ppl are proud to be ;-)
18:45:25 * gmcharlt is in favor of having anybody who wants to wrangle bugs to get the title of Bug Wrangler, as long as they publicly commit to put in a reasonable amount of effort to it
18:45:37 <slef> thd: yes, and all the 2.x and 1.x ones.
18:46:03 <paul_p> slef, i fear it will be a mountain to move !
18:46:08 <mtj__> gmcharlt++ , i agree
18:46:09 <paul_p> that's so many !!!
18:46:14 <paul_p> gmcharlt++
18:46:21 <Brooke_> so then
18:46:24 <Brooke_> open position
18:46:25 <magnuse> gmcharlt++
18:46:32 <Brooke_> that reports to the QA manager
18:46:41 <slef> paul_p: 140ish, plus some fraction of the 700+ bugs labelled master.
18:46:47 <Brooke_> and receives recognition at some point that they're an official bug wrangler
18:47:05 <Brooke_> the top wrangler can get a can of raid in the post ;)
18:47:08 <thd> slef: I assume that reporters would be notified with the suggestion that they login and reopen any bug which they believe still exists.
18:47:22 <slef> thd: reopen and update the labels, yes.
18:47:35 <schuster> part of the problem with the old ones it is hard to locate the originator...
18:47:35 <Brooke_> resolved: as many wranglers as will step forward
18:47:39 <paul_p> slef, /me think it would be more interesting to test/close pushed patches don't you agree ?
18:47:51 <gmcharlt> thd: slef: and if a bug is marked WONTFIX, a comment could be added that the WONTFIX was done semi-automatically, and is not meant as a moral pronouncement on the validity of the bug
18:47:52 <paul_p> s/interesting/useful/
18:48:13 <thd> gmcharlt++
18:48:31 <slef> paul_p: making it easier to find relevant things in bugzilla will free everyone's time for working on current development.
18:48:42 <paul_p> agreed
18:48:49 <schuster> slef++
18:48:57 <slef> this is unfun grunt work, but it's been left too long
18:49:14 <Brooke_> moving on to admins for the Koha lists on Nabble
18:49:33 <paul_p> OK, rereading your proposal, I misunderstood something slef !
18:49:35 <paul_p> slef++
18:49:36 <thd> Can we have a label for closed by rule but without investigation?
18:49:40 <paul_p> very good idea !
18:49:44 <gmcharlt> mtj: could you clarify what you mean by Nabble admin?
18:50:08 <gmcharlt> I thought Nabble itself was just one (of several) archives of the mailng list
18:50:12 <paul_p> why does not everybody in the world speak french? that would make my life so easier :D
18:50:12 <gmcharlt> *list
18:50:22 <mtj__> yeah, i would like to ask the admins at nabble, to grant access to the Koha lists at nabble.com
18:50:39 <mtj__> these lists... -> http://koha.1045719.n5.nabble.com/
18:51:00 <slef> It is, but the admin can update headers and so on. I think kados is the admin.
18:51:14 <mtj__> for 1 or 2 elected kc.org people
18:51:20 <gmcharlt> whoever it is did change the project link to koha-community.org
18:51:21 <slef> I got the koha nabble moved to the new site, but I find nabble very hard to use.
18:51:36 <slef> Ah, that was probably me whinging at them repeatedly :)
18:51:53 <gmcharlt> coo
18:51:57 <gmcharlt> cool, even
18:51:59 <slef> oh yeah, it says Hugo <Nabble> is the admin now.
18:52:04 <mtj__> gmcharlt: hugo, a nabble admin did that, as i asked him to , last week-ish
18:52:22 <slef> mtj__: ah, well done! I didn't think I got anywhere!
18:52:31 <mtj__> so currently, only hugo@nabble is an admin...
18:52:51 <paul_p> slef, previously, joshua upgraded all bug from N to N+1 when N was released. I think it means many bugs are now irrelevant, so setting WONTFIX is really a good idea !
18:53:03 <slef> mtj__: are you willing to admin?
18:53:08 <slef> anyone else willing to admin?
18:53:16 <mtj__> i propose we elect 1/2 people here, and ask hugo et al nicely f they will grant them admin access
18:53:25 <cait> paul_p/slef: can we reopen bugs if we find they still apply to master/3.2?
18:53:26 * gmcharlt tosses name in the hat for redundancy's sake
18:53:32 <mtj__> i am willing to admin the nabble lists
18:53:36 <gmcharlt> cait: sure
18:53:43 <thd> slef: Can we have a label in bugzilla for closed by rule but without investigation?
18:53:49 <Brooke_> so I'm hearing gmcharlt and mtj
18:53:51 <paul_p> cait, of course !
18:53:52 <Brooke_> anyone else?
18:53:57 <irma> Hi all - Irma from CALYX - sorry I am so late ...
18:54:27 <Brooke_> all in favour of gmcharlt and mtj as nabble admins
18:54:31 <mtj__> http://nabble-support.1.n2.nabble.com/Request-to-update-Koha-ILS-mailing-lists-topic-page-with-new-website-address-td6029182.html#a6030223
18:54:54 <slef> thd: I think a message is better, but maybe a bugzilla admin can tell us if that's possible.
18:54:58 <Brooke_> oi
18:55:00 <Brooke_> vote.
18:55:04 <space_librarian_home> +1
18:55:05 <slef> +1
18:55:11 <kmkale> +1
18:55:17 <jcamins> +1
18:55:19 <gmcharlt> thd: slef: yes, a new status could be added, but I prefer simply using a message
18:55:20 <slef> (anything so I don't have to use that site again!)
18:55:29 <hdl> +1
18:55:37 <paul_p> +1
18:55:38 <sekjal> +1
18:55:42 <mtj__> +1
18:55:50 <thd> gmcharlt: How can the message be found systematically?
18:56:06 <thd> +1
18:56:07 <gmcharlt> thd: why would it need to?
18:56:16 <hdl> thd: it will be sent to the reporter.
18:56:27 <gmcharlt> somebody who cares about a particular issue would either reopen it or file a new bug
18:56:39 <JesseM> +1
18:56:52 <magnuse> +1
18:57:15 <thd> gmcharlt: If you are looking for bugs which might be present but had been closed without investigation there should be a way to find them.
18:57:29 <Brooke_> #action motion carries
18:57:56 <slef> thd: search bug content for a phrase or tag we put in the message.
18:58:31 <Brooke_> moving on
18:58:39 <Brooke_> #topic KohaCon 11
18:58:50 <Brooke_> kmkale it's all yours :D
18:58:55 <kmkale> hi all
18:59:01 <slef> hi kmkale!
18:59:03 <thd> slef: The message would be fine if there is a consistent word or tag used.
18:59:08 <kmkale> Thanks to the commmunity form choosing India for Kohacon 11
18:59:24 <kmkale> I have prepared a Koha wiki page at http://wiki.koha-community.org/wiki/KohaCon2011
18:59:41 <kmkale> and a website at http://kohacon11.vpmthane.org/ocs ( this is running on Open Conference System from http://pkp.sfu.ca/ocs/)
18:59:45 <cait> paul_p: I suggest adding the bugs list as qa contact before closing those bugs - it's missing on a lot of them
19:00:04 <magnuse> kmkale++
19:00:20 <kmkale> At our end we are setting up sub-committees to handle conference arrangements, accomodation assistance, travelling guide, food guide, a day trip to Mumbai, getting sponsors, cultural program / conference dinner etc..
19:00:28 <Brooke_> #link http://kohacon11.vpmthane.org/ocs/index.php/k/k11
19:01:03 <paul_p> kmkale, the kohacon11.vpmthane.org is very slow from here at this time. Is there a known reason for this slowness ?
19:01:21 * chris_n = Chris Nighswonger, 3.2.x Release Maintainer... and very late :P
19:01:41 <gmcharlt> chris_n: and now 3.4.x Release Maintainer ;)
19:01:47 <paul_p> chris_n, too late, you've been elected 3.4 Rmaint :D
19:01:50 <kmkale> paul_p: its hosted inside campus. which has nill traffic atm. so i see no reason
19:02:10 <kmkale> may be a dns or routes issue between the two end points?
19:02:14 <gmcharlt> kmkale: would you be willing to extend the deadline call for papers a bit, say, to the end of July?
19:02:15 <chris_n> :-)
19:02:23 <paul_p> so it can be my connexion. Or india <=> france that is slow somewhere
19:02:40 <kmkale> gmcharlt: sure. I want us to discuss and decide these sorta points
19:02:57 <kmkale> may be form a comitee here to discuss and decidce
19:03:10 <gmcharlt> kmkale: cool.  another question - are you considering papers to be distinct from presentation proposals?
19:03:16 <Brooke_> worse ideas have been proposed ;)
19:03:17 <gmcharlt> or the same thing
19:03:27 <kmkale> same thing basically
19:03:31 <gmcharlt> ok
19:03:45 <kmkale> what you see at the above site is what comes with the ocs basically
19:03:50 <gmcharlt> gotcha
19:03:51 <kmkale> needs work
19:04:06 <kmkale> I would like us to form a committee of volunteers here to work on call for papers, paper selection, presentation scheduling, keynote address etc.
19:04:22 <paul_p> it's a cool framework to help organizing a conf if it's what is provided by default !
19:04:48 <kmkale> thanks to SandeepBhavsar for finding and suggesting it
19:04:53 <gmcharlt> I would like to volunteer to be a (remote) member of that committee
19:05:01 <paul_p> SandeepBhavsar++
19:05:03 <space_librarian_home> I volunteer too
19:05:05 <kmkale> great
19:05:07 <paul_p> (wow long name to type ;-) )
19:05:25 <kmkale> Also let us discuss and decide conference volunteers meeting times, the general timeline for events leading up to the conference like call for papers duration, last date of papers, programme finalization etc
19:05:43 <paul_p> kmkale, I candidate to help on the hackfest organization
19:06:02 <kmkale> super
19:06:14 <kmkale> paul_p had mentioned that he would like a longer hackfest following the kohacon. We can discuss that and decide on the number of days. I am pretty sure we can manage to provide a venue like a conference room or lab or a classroom for the hackfest duration.
19:06:34 <kmkale> with wi-fi
19:06:55 <Brooke_> wi-fi and beer? Catalyst gave you a high bar, ye know...
19:07:10 <paul_p> I'm probably with chris the only one who participated to the 3 previous hackfest, so have a little experience now ;-)
19:07:11 <kmkale> aye venue is a college
19:07:19 <kmkale> so no beer and no smoking
19:07:44 <kmkale> but we can all go out after hours ;)
19:07:55 <thd> kmkale: Is there a room big enough for all the people who voted for Thane?
19:07:59 <paul_p> (thinking of it, yes, chris & me are the only ones who made the 3 conferences in France/USA/NZ ;-) )
19:07:59 <gmcharlt> kmkale: that might make for better code, though, so it's all good ;)
19:08:01 <slef> please remember that each extra day increases the costs for attendees which increases the cost of Koha for libraries if it is priced fairly
19:08:44 <kmkale> thd: we have 4 seminar halls of 200 capacities each all interconnected with polycokm video conferencing hardware
19:09:03 <kmkale> so we can have parallel sessions if we get that much participation
19:09:13 <paul_p> kmkale, how many ppl from india to you think we may get ? (for the user conf I mean) ?
19:09:34 <paul_p> (really up to 800 ?)
19:09:36 <mtj__> slef: the hackfest days are optional tho, so people dont need to attend those
19:09:38 <kmkale> paul_p: I have done 4 or 5 koha trainings at various colleges so far
19:09:55 <magnuse> slef: everyone doesn't have to stay for the whole hackfest...
19:09:56 <kmkale> at each one ( paid trainings at that ) we had to send back librarians
19:10:26 <hdl> or you can choose between hackfest and user conference
19:10:29 <slef> mtj__: optional, but seems to be expected.
19:10:38 <kmkale> so we will get excellent indian participation. people are eager to learn Koha
19:10:48 <paul_p> wow... well : NZ 4million ppl, 60ppl at the conference, India 1.2billion, so 300x, the goal is 18 000 attendees then :D
19:10:49 <kmkale> we need good speakers and topics.
19:11:01 <thd> kmkale: You would need a large theatre or sports arena to hold everyone who voted for Thane :)
19:11:02 <magnuse> paul_p++ ;-)
19:11:09 <kmkale> which will help librarians get started in Koha and help developers get into koha
19:11:43 <hdl> not only into koha as it stands... but maybe also as it could grow.
19:12:02 <slef> paul_p: more realistically, it should be 660 people (= first choice votes for Thane, less some who can't go for various reasons, plus some who put it as a lower choice)
19:12:18 <space_librarian_home> kmkale: so, do you have any themes for the kohacon you wish to highlight?
19:12:33 <paul_p> what about some workshops about koha + other OSS tools for libraries (greenstone, Drupal/Joomla,...)
19:12:44 <slef> Brooke_: kmkale: sorry, what do we need to do here?
19:12:47 <hdl> kete
19:12:56 <hdl> Dspace
19:13:02 <paul_p> oops... sorry to have forgottent kete ...
19:13:40 <Brooke_> I think
19:13:43 <kmkale> What i have in mind is help librarians and developers get started and hooked on Koha
19:14:03 <Brooke_> we empower kmkale redundantly to go form a committee and report back with their progress next month
19:14:14 <paul_p> Brooke_++
19:14:22 <gmcharlt> Brooke_: sounds good
19:14:24 <space_librarian_home> Brooke_++
19:14:30 <chris_n> +1
19:14:35 <gmcharlt> kmkale: I also suggest that you call monthly KohaCon meetings in #koha
19:14:36 <slef> kmkale: can you remove the eye test from http://kohacon11.vpmthane.org/ocs/index.php/k/k11/user/account please, or at least provide another way to register?
19:14:54 <thd> Brooke++
19:14:54 <slef> (OpenID would be good)
19:14:55 <kmkale> slef: will do
19:15:00 <thd> gmcharlt++
19:15:11 <kmkale> gmcharlt: will do
19:15:21 <kmkale> need more volunteers
19:15:23 <slef> Brooke_++
19:15:28 <Brooke_> anything else, other than excitement about KohaCon 11?
19:15:37 <gmcharlt> KohaCon11++
19:15:43 <slef> KohaCon11++
19:15:44 <Brooke_> #help KohaCon 11 committee members and volunteers: see Kmkale
19:15:45 <kmkale> are we all good with tyhe proposed dates?
19:15:47 <slef> kmkale: thanks
19:15:51 <kmkale> what about hackfest duration
19:15:52 <Brooke_> one further note
19:16:10 <Brooke_> I'm very happy that no one went for each other's jugular upon hearing the results.
19:16:16 <paul_p> kmkale, let's speak of it on a commetee : depend on what we want to do during this fest.
19:16:25 <kmkale> paul_p: ok
19:16:28 <Brooke_> I hope in future as the conference rotates that everyone gets a crack at having it in their respective backyards. :)
19:16:43 <thd> kmkale: Does the date include both the conference and the developers' sessions?
19:16:48 <mtj__> kmkale: i'm volunteering to help
19:16:48 <paul_p> As i've already said, I think it could be worthwhile to have 2 parts : "learning to hack" then "real/deep hacking"
19:16:56 <kmkale> are we all good with the proposed dates? we can throw open registrations and start working on accomodation and travel then
19:17:08 <slef> kmkale: I'm OK with those dates as far as I know just now.
19:17:33 <paul_p> kmkale, I think that unless there is a worldwide event at those dates, it's OK
19:17:38 <schuster> paul_p ++ learning to hack...  I'm still trying to figure that out!
19:17:52 <space_librarian_home> dates look good.
19:17:53 <paul_p> mmm... thinking of it : when is the rugby world cup exactly ?
19:17:59 <Brooke_> it's diwali then, yes?
19:18:00 <thd> kmkale: How do the dates relate to paul_p's proposal for two part hacking period?
19:18:00 <space_librarian_home> september
19:18:04 <Brooke_> september Paul
19:18:14 <kmkale> Brooke_: Diwali ends 27th October
19:18:18 <Brooke_> perfect
19:18:19 <kmkale> just past Diwali
19:18:35 <kmkale> but you could come a bit early to enjoy the festival of lights :)
19:18:46 <slef> 9 Sep - 23 Oct http://www.rugbyworldcup.com/home/pools/index.html
19:18:48 <paul_p> Brooke_, start on sept, ends on oct, 23
19:19:12 <Brooke_> so rugger buggers have no excuse :P
19:19:21 <paul_p> so no overlap (that would be a real problem for chris & all kiwis ;-) )
19:19:28 <space_librarian_home> yes!
19:19:29 <space_librarian_home> :p
19:19:52 <mtj__> i think i'm cuming early, for Diwali
19:20:05 <Brooke_> okay moving on
19:20:13 <thd> paul_p: How do the closing date relate to your proposal for two part hacking period?
19:20:14 <Brooke_> #topic Security Issues
19:20:18 <pastebot0> "gmcharlt" at 68.101.78.67 pasted "security list proposal" (24 lines) at http://paste.koha-community.org/163
19:20:25 <kmkale> thd: conference 3 days 1 day Mumbai trip 3 day hackfest = 31st Oct to 6th Nov
19:20:28 <gmcharlt> #link http://wiki.koha-community.org/wiki/Security_Mailing_List_Proposal
19:20:36 <paul_p> thd, I think the closing date could/should be later than 6th
19:20:40 <schuster> FYI international library conference tracker - http://www.conferencealerts.com/library.htm
19:20:41 <kmkale> but we can extend the hackfest if community decides to do so
19:21:14 <paul_p> what i've experienced : after 3days of conf everybody is tired & happy to have a restful week-end. Then hackfest
19:21:14 <gmcharlt> details are in the link I just posted, but to boil down the proposal, I propose creating a new limited purpose mailing list for the confidential reporting and discussion of security bugs that aren't reported to Bugzilla
19:21:20 <kmkale> mtj__: good for you. Its the biggest festival here
19:21:22 <gmcharlt> with goal of quick resolution to security issues
19:21:31 <gmcharlt> and transparency via a time-delayed public archive
19:21:38 <thd> paul_p++
19:21:39 <slef> I suggest we should recycle koha-manage to be that list.
19:21:47 <slef> We don't need two private lists.
19:21:57 <gmcharlt> slef: I disagree; I'd rather that we simply close koha-manage
19:22:08 <paul_p> slef, koha-manage is not used. Whe have some archives that should not be set public
19:22:09 <thd> A restful weekend is much better than tired people at a hackfest.
19:22:10 <gmcharlt> "koha-manage" as a name does not apply to the purpose I'm proposing koha-security for
19:22:14 <paul_p> I prefer to close it definetly
19:22:22 <gmcharlt> and it's not like it's expensive to create mailing lists
19:22:27 <paul_p> I agree with galen
19:22:47 <mtj__> me too
19:22:49 <slef> I think labelling it koha-security will attract misdirected posts about more general security topics.
19:22:57 <paul_p> about delayed archives = is there a way to do that wit mailman ?
19:23:15 <gmcharlt> paul_p: I'm sure something can be hacked together; I'm willing to work out the details
19:23:36 <slef> it's not expensive to create mailing lists, but it is expensive to admin them well and to have the right people subscribed and participating well.
19:23:42 <gmcharlt> slef: we can simply redirect people to koha-devel in such instances
19:24:22 <paul_p> yes, and on mailman list header & koha-community.org, we can be very clear !
19:24:23 <thd> gmcharlt: are the bugs so dangerous that they need to have the security of not being published until they are patched?
19:24:29 <paul_p> thd, right
19:24:34 <gmcharlt> paul_p: to confirm, BibLibre would be willing to provide hosting for such a list, (along with the other lists you already host?)
19:24:36 <slef> Amend this proposal to close koha-manage too?
19:24:50 <gmcharlt> slef: +1 to closing koha-manage
19:25:08 <paul_p> thd, the 3.2.5 contains a fix that let anyone without any permission delete all authorities in your catalogue :\
19:25:22 <paul_p> (well the fix prevent this, not enable it ;-) )
19:25:30 <paul_p> +1 to closing koha-manage
19:25:41 <mtj__> +1 to closing koha-manage
19:25:44 <gmcharlt> thd: there are some where as a matter of practice, having a *bit* of time to work out a fix would help
19:25:51 <slef> paul_p: the current mailman listinfo pages are mostly unhelpful, containing only the default bugzilla text.
19:26:09 <gmcharlt> thd: plus, as was the case with the specific incident, the person who found the security issue was not willing to simply post it to bugzilla
19:26:24 <gmcharlt> and I'd rather that we get security bug reports rather than not get them
19:26:32 <paul_p> slef, what could/should we add ? (correct english welcomed !)
19:26:40 <schuster> +1 close koha-manage - that list gave me fits way back to KohaCon09...  forgiveness requested if you were on it.  Chances are you were not the one causing the consternation!
19:27:10 <mtj__> yeah, koha-manage does have some bad karma
19:27:20 <cait> +1 for gmcharlt's proposal
19:27:37 <cait> and +1 for closing koha-manage
19:27:37 <schuster> How often do we have "security" concerns of this magnitude?
19:27:43 <paul_p> about the security ML, if it's a invitation-only mailing list, then ppl can't write to it. So how will ppl be able to report a security issue ?
19:27:44 <thd> How do you decide who is safe enough to subscribe?
19:27:51 <gmcharlt> schuster: thus far, once or twice a year
19:28:03 <gmcharlt> I don't expect that koha-security will be high-volume
19:28:04 <slef> paul_p: permitted senders != subscribers
19:28:07 <paul_p> schuster, the more eyes seing the code, the more ppl finding such problems ;-)
19:28:39 <paul_p> slef, yep, but if anyone can send, we may get zillions of spams. But nevermind, we will deal with it.
19:28:56 <schuster> Obviously the person who reported this figured out who to talk with...  I suspect then the RM and others were contacted to "find help" to resolve the problem?
19:28:58 <paul_p> schuster, just FYI, the guy who reported this one is ... a french catholic monk !
19:29:02 <slef> paul_p: so you'll need a moderator
19:29:17 <gmcharlt> slef: I am willing to moderate and despam
19:29:23 <paul_p> schuster, exactly
19:29:27 <slef> and one who is a bit faster than the current list moderators IIRC
19:29:43 <Brooke_> okie dokie
19:29:56 <Brooke_> so is it safe to presume we've resolved to shut manage and open security?
19:29:57 <gmcharlt> schuster: yes, basically because I told the reporter what to do
19:30:05 <slef> paul_p: http://wiki.koha-community.org/wiki/Koha_List_Welcome is the suggestion for the koha list, but it doesn't seem to be on http://lists.katipo.co.nz/mailman/listinfo/koha yet.
19:30:09 <gmcharlt> schuster: I'd just like to have it a little more formalized
19:30:37 <paul_p> slef, for this one (katipo.co.nz), I can't do anything ;-)
19:30:43 <slef> I think the name should be something like koha-devel-private
19:30:59 <schuster> Dislikes closed lists - and it has been beat into him with FOSS to stay as transparent as possible...
19:31:13 <slef> but then I believe security should be full disclosure
19:31:22 <slef> which I think puts me in a minority here.
19:31:25 <gmcharlt> slef: "koha-devel-private" is broader scope than I intend
19:31:44 <gmcharlt> slef: this is not inconsistent with full disclosure
19:31:54 <slef> gmcharlt: how is it not?
19:31:58 <cait> I think private is not a good name
19:32:06 <cait> koha-securitiy-issues or something like that
19:32:11 <slef> cait: call a cat a cat.
19:32:12 <thd> cait++
19:32:27 <paul_p> slef, once we will be on debian with apt-get update koha, I think Full disc will be fair. But as ofnow, many libraries can't afford checking everyday & installing immediatly a security release i think
19:32:48 <gmcharlt> slef: anybody who cares to make a fully public report of a security issue and is irresponsible enough to also publicize an exploit is not prevented from doing so
19:33:02 * Brooke_ has always wondered what data Librarians stick in their systems to make security an issue in the first place...
19:33:10 <thd> slef: The list contents should be disclosed after the bug is fixed or found to be mistakenly reported..
19:33:23 <slef> paul_p: most libraries don't apt-get update AFAICT.
19:33:30 <cait> Brooke: data about persons
19:33:43 <davi> security coordinated disclosure++
19:33:44 <gmcharlt> Brooke_: long history on that one; there were various incidents back in the day when the FBI did go after library patron records
19:34:21 <davi> just koha-security would be OK IMHO
19:34:29 <paul_p> librarians, no. but libraries sysop I think yes. And if we are on Debian, we will be on security updates as well, no ? So anyone just checking this list will be aware.
19:34:31 <thd> gmcharlt: They still do.
19:34:31 * Brooke_ spots a dead horse
19:34:41 <paul_p> koha-security sounds OK to me as well
19:34:44 <gmcharlt> and as with the bug fixed in 3.2.5, security issues also mean things like holes that allow an external attacker to cause arbitrary damage to a database
19:34:52 <slef> paul_p: have you met any who do?
19:35:10 <paul_p> yes, some, at cnrs labs
19:35:26 <slef> thd: ok, but that should be less than a year, right?
19:35:28 <Brooke_> so, let's set this up
19:35:32 <Brooke_> and just do it
19:35:35 <paul_p> (but I agree, none in small public libraries. That's why we strongly suggest hosted Koha as the best solution ;-) )
19:35:36 <slef> sorry, six months
19:35:43 <Brooke_> cause the meeting is v long by now
19:35:57 <gmcharlt> ok
19:36:04 <mtj__> lets vote on the security list name, shall we?
19:36:04 <Brooke_> #topic time and date of next meeitng
19:36:04 <gmcharlt> I will work with BibLibre to start the list
19:36:06 <thd> slef: Disclosure should be as soon as people have had a reasonable time to update their installations.
19:36:15 <paul_p> Brooke_++, /me hungry ;-)
19:36:16 <gmcharlt> we can evaulate it after a few months
19:36:31 <jwagner> Question -- who is allowed to be a member of that list?
19:36:31 <slef> I'm really unhappy about encouraging security bugs into the dark, but I seem to be in a minority of one.
19:36:42 <slef> jwagner: read the links gmcharlt posted, please.
19:36:53 <jwagner> I did, what did I miss?
19:37:03 <slef> "membership to be RMs, RMaints, QAMs, past, present, and future"
19:37:04 <gmcharlt> slef: I guess I must have imagined writing things like "preference to simply use Bugzilla
19:37:04 <gmcharlt> "
19:37:04 <Brooke_> 6 April acceptable?
19:37:21 <paul_p> apr, 4-8th there will be the sprint in Marseille
19:37:25 <slef> gmcharlt: the list name sends mixed messages.
19:37:26 <gmcharlt> jwagner: and "other interested devs can join on request
19:37:26 <gmcharlt> "
19:37:27 <davi> slef, They will be on the dark, all koha dev will know, just that we will not publicity them
19:37:37 <paul_p> many ppl expected to work on 3.4 this week
19:37:41 <Brooke_> 13 April
19:37:42 <Brooke_> ?
19:37:45 <davi> s/They will/They will not/
19:37:49 <paul_p> (not meaning it's not a good week for this meeting)
19:37:50 <jwagner> OK, thanks -- missed that line.
19:37:59 <gmcharlt> paul_p: actually, I think that 4/6 would be good even with the sprint
19:38:08 <gmcharlt> you can add a report on the sprint to the agenda
19:38:09 <thd> slef: I think that we should encourage people to describe the type of problem publicly without enough public detail to reproduce the issue where it is too scary.
19:38:15 <paul_p> gmcharlt, yes, I think so, just reminding that ;-)
19:38:27 <Brooke_> so back to 6 April?
19:38:44 <gmcharlt> 6 April
19:38:53 <paul_p> Brooke_, OK to me. And if daylight time for europe it will even be better ;-)
19:40:00 <slef> I've no preference between 6 and 13.
19:40:56 <magnuse> i'd say 6th - might be good to have a few days before the scheduled relaese on 22nd, perhaps?
19:41:02 <space_librarian_home> 6 April is good.
19:41:04 * kmkale yawns its past 1 am
19:41:13 <slef> kmkale puts us all to shame
19:41:14 <thd> slef: I presume that Debian has no secret security related lists but I assume that there are secret security lists for upstream projects while patches are being developed.
19:41:52 <paul_p> kmkale, sweet dreams !
19:41:56 <kmkale> so 6th is it? what time?
19:42:03 <Brooke_> that's the question
19:42:14 <Brooke_> who takes the bullet this go
19:42:25 <paul_p> 8 hours sooner than today ?
19:42:31 <space_librarian_home> ack!
19:42:37 <space_librarian_home> not for the kiwis!
19:42:46 <mtj__> 12+ hours the start of this meeting
19:42:47 <gmcharlt> thd: an example http://httpd.apache.org/security_report.html
19:42:47 <paul_p> should we do8 hours sooner than the previous meeting each time ?
19:42:50 <slef> kmkale is in the worst time now IIRC
19:43:01 <kmkale> slef: not so bad
19:43:07 <space_librarian_home> It's going 8:45am here
19:43:08 <paul_p> I think no time is easy for everybody
19:43:22 <davi> thd, there can be at least some private emails exchange upstream
19:43:25 <schuster> paul_p ++
19:43:28 <paul_p> that's why I suggest to have a lasttime -8H everytime
19:43:50 <schuster> If it is important people will be there...
19:43:51 <thd> space_librarian_home: Your time will be very reasonable compared to the US.
19:43:52 <kmkale> 8hrs sooner i.e. 10.00 utc works for me
19:44:01 <mtj__> paul_p++ yeah, i agree
19:44:08 <Brooke_> I'd propse 8
19:44:09 <sekjal> rotating by 8 is good.... but i think we've been going + 8H... last one was 10:00 UTC
19:44:13 <paul_p> and next time that will be 2utc, and next time ...
19:44:15 <space_librarian_home> thd: point taken.
19:44:22 <Brooke_> that way kiwis aren't also taking a hit
19:44:27 <thd> 10.00 UTC ++
19:44:41 <magnuse> 10.00 UTC ++
19:44:41 <Brooke_> it's horribly early for yanks, but at least it's good for others
19:44:59 <davi> 10.00 UTC ++
19:44:59 <gmcharlt> Brooke_: we're used to it
19:45:06 <gmcharlt> +1 10:00 UTC+0
19:45:16 <slef> +1 10:00 UTC+0
19:45:26 <slef> (is 2 UTC good for anyone? We keep avoiding it)
19:45:29 <paul_p> Brooke_, , and next time, 2utc will be awful for us in europe
19:45:44 <Brooke_> that is good for kiwis slef
19:46:01 <Brooke_> so set
19:46:10 <Brooke_> 10AM UTC 6 April
19:46:10 <space_librarian_home> and for west coast US
19:46:22 <thd> Brooke_: Are you proposing 2:00 UTC?
19:46:24 <mtj__> so +8 hours is the new rule for meeting starts...
19:46:24 <Brooke_> #action 10 AM UTC 6 April
19:46:30 <paul_p> suggestion for next agenda : everybody speak french and come to france timezone :D
19:46:33 <Brooke_> #endmeeting