02:00:14 <Brooke> #startmeeting
02:00:14 <huginn`> Meeting started Wed Feb  8 02:00:14 2012 UTC.  The chair is Brooke. Information about MeetBot at http://wiki.debian.org/MeetBot.
02:00:14 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic.
02:00:23 <Brooke> #topic Welcome
02:00:40 <Brooke> please introduce yourselves using #info
02:00:54 <thd> #info Thomas Dukleth, Agogme, New York City
02:01:11 <jwagner> #info Jane Wagner LibLime/PTFS
02:01:13 <Space_Librarian> #info Shelley Gurney, NZICA, Wellington
02:01:22 <eythian> #info Robin Sheat, Catalyst IT, Wellington
02:02:00 <RA> #info rafael antonio, Portugal
02:02:49 <paul_p> hello #koha
02:03:22 <Brooke> Anything to announce?
02:04:03 <paul_p> #info paul P, current Release Manager, BibLibre, France
02:04:23 <Brooke> 3.4 news anyone?
02:05:16 <paul_p> chris_n not here, I fear there won't be any
02:05:42 <Brooke> prolly the same thing but who knows
02:06:24 <Brooke> #info if you have stuff that you missed mentioning for 3.4 or 3.6 send it to the list or stick it in the newsletter or on the wiki
02:06:46 <paul_p> this one is for me probably...
02:06:58 <Brooke> yep
02:07:03 <paul_p> still trying to finish opening my eyes...
02:07:35 <paul_p> well, as usual, I made a gave all infos on my RM newsletter.
02:08:20 <paul_p> I sent a request for testing sandboxes on koha-devel a few days ago, and got no feedback
02:08:37 <Brooke> perhaps try duplicating that to the main list
02:08:48 <Brooke> I was going to suggest that for your Patch Discussion as well
02:09:09 <paul_p> I'd really liked to have feedback before deploying the sandboxes on the 10 servers.
02:09:30 <Brooke> #help test out the sandboxes
02:09:59 <paul_p> oleonard tested once, I know wizzyrea gave a try as well (but she didn't send me any feedback)
02:10:41 <paul_p> I'm really hoping it will help having more tester. I'm even thinking about organizing some training session for french libraries about that.
02:10:58 <paul_p> (ie : what's the workflow, how it works, how to use sandboxes)
02:10:59 <thd> If I would have time in a fully awake state, I would be happy to test and give some feedback.
02:11:04 <paul_p> to attract more ppl
02:11:17 <paul_p> thd don't hesitate ;-)
02:11:40 <thd> paul_p: If you can buy me some sleep I will have more.
02:12:11 * oleonard apologizes for his lateness
02:12:14 <paul_p> hi oleonard
02:12:23 <thd> I like Brooke's idea of asking on the main list where more people are giving attention.
02:12:29 <RA> I will be interested to participate on testing
02:12:36 <Brooke> RA++
02:13:11 <Brooke> anything else for 3.8?
02:13:43 <paul_p> Brooke RA ???
02:13:54 <paul_p> ah, OK sorry
02:13:56 <Brooke> he said he'd test. This is good :)
02:14:17 <paul_p> hi RA, I don't remember speaking with you here before
02:14:38 <RA> Paul can i send you my email? We live in europe so we are very near...
02:14:39 <paul_p> well about 3.8 nothing more I think
02:14:50 <paul_p> RA of course you can
02:15:16 <RA> Rafael.antonio at sapo.pt
02:15:20 <Brooke> K
02:15:21 <paul_p> RA = Rafael, PT, (seenn in the minutes)
02:15:23 <Brooke> Slef is asleep
02:15:26 <Brooke> but
02:15:35 <Brooke> #info Conference Tue 5 June 2012 to Thu 7th, Hackfest Sat 9th June-Mon 11th June
02:15:42 <Brooke> Deposit has been placed for the venue.
02:15:44 <Brooke> hooray :D
02:16:14 <Brooke> uhh looks like he wants us to spread the word
02:16:17 <Brooke> so I'd say
02:16:19 <Brooke> http://wiki.koha-community.org/wiki/KohaCon12_Announcements
02:16:26 <Brooke> look there and either edit or just plain gossip :)
02:16:28 <paul_p> (what does it mean -the frenchy don't understand- ?)
02:16:46 <Brooke> preferably if you send it out mark it with (I already bugged these people ; date )
02:16:47 <paul_p> (Deposit has been placed for the venue)
02:16:56 <Brooke> it means we have a place to go :)
02:17:10 <Brooke> d'argent has been le paid :)
02:17:13 <Brooke> or at least some
02:17:26 <Space_Librarian> :)
02:17:31 <paul_p> OK, got it
02:17:36 * oleonard groans
02:17:44 <Brooke> msg slef your email address to join the volunteers mailing list and he'll get back to you before the end of the week.
02:17:46 <paul_p> (and in fact I understood, but thought I hadn't)
02:17:47 <thd> paul_p: non-refundable payment as security against changing one's mind.
02:18:15 <Brooke> so I'ma say questions to slef.
02:18:53 <paul_p> this one is for me too ;-)
02:19:12 <paul_p> We've recently added a "in discussion" bug status
02:19:38 <paul_p> so me must organize how to deal with "in discussion" to avoid having bugs staying in discussion but no discussion...
02:19:47 <paul_p> I made a proposal on the wiki agenda
02:20:10 <paul_p> have a wiki page "in discussion" pointing to all pending discussion. announce all discussion to koha-devel
02:20:10 <paul_p> each discussion will have a timeline for everyone to argue (2 weeks ? maybe depending on the complexity of the discussion, but should never be more than 1 month)
02:20:10 <paul_p> at the end of the timeline, if no clear agreement reached on the wiki discussion, open a vote, that would be made on the wiki page, announced on koha-devel mailing list, open for one week
02:20:10 <paul_p> depending on the result of the vote, change the status of the bug to "exit" in discussion
02:20:36 <paul_p> there are something like 10 discussions to start already
02:20:52 <Brooke> okay
02:20:53 <Brooke> so
02:20:54 <Brooke> first thing
02:20:56 <paul_p> I'm OK to write the wiki page explaining the problems
02:20:59 <RA> Sorry but i am quiting. Bye
02:21:08 <paul_p> bye RA. sweet dreams
02:21:13 <Brooke> I'd like a wiki page to be called summat better than "In discussion" cause that's not terribly descriptive
02:21:52 * oleonard thinks the term "summat" is confusing to English and non-English speakers alike
02:22:02 <Brooke> this is true
02:22:34 <Brooke> I'm thinking "Bug and Enhancement Discussion" Is that amenable?
02:22:52 <paul_p> Brooke of course. Your english is rumored to be better than mine
02:22:57 <Brooke> then we can have subcategories for bugs and enhancements
02:23:04 <Brooke> perhaps further subdivided by severity
02:23:15 <Brooke> so that folks get to talking about stuff that's more important first
02:23:25 <Brooke> it's just a rumour, paul
02:23:35 <Brooke> I think you're prolly easier to understand than me at most times
02:23:54 <paul_p> I was thinking that this page would be an entry, listing all discussions. This listing would, you're right have a column "severity"
02:23:59 <paul_p> Brooke not false ;-)
02:24:10 <Brooke> k
02:24:18 <thd> paul_p: Is discussion not useful for all bugs?  What is the special distinction which you are proposing?
02:24:50 <oleonard> Not all bugs raise issues which don't have a clear consensus
02:25:06 <Brooke> I agree owen
02:25:15 <paul_p> thd : look at 7387, 7248 and 6193
02:25:28 <jransom> Apologies for lateness (Jo Ransom - HLT)
02:25:30 <Brooke> you wouldn't want to go discussing history.txt changes, yes?
02:25:43 <paul_p> they try to add caching, with different methods, and introduce some change over existing caching
02:26:04 <paul_p> what do we want to do ? we need to be consistent, so this must be discussed
02:26:16 <paul_p> then a decision, then we all know where we're going
02:27:02 <Brooke> I don't think we've fleshed this out quite enough for a vote just yet
02:27:11 <Brooke> I think the wiki component is done, but I could be wrong
02:27:25 <oleonard> I worry that a wiki page will not get noticed. Is a thread on the devel list not more amenable to discussions?
02:27:29 <paul_p> bug 7075 is a little bit different = seems it can't be reproduced anymore. Maybe it's not worth discussing a lot for this one. but it will at least highlight the problem
02:27:29 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7075 trivial, PATCH-Sent (DO NOT USE), ---, chris, In Discussion , Fine in days values are returned for patrons with past overdues when fine in days is set to 0
02:27:38 <paul_p> oleonard in y proposition, there will be both
02:27:43 <Brooke> there's going to be a thread on devel according to the proposal
02:27:48 <paul_p> do a page / send a mail to koha-devel
02:27:49 <Brooke> but I'd add the main list
02:27:57 <Brooke> I want to avoid programming in a vacuum at all costs.
02:28:14 <paul_p> Brooke agreed for some discussions, but I feel that sometimes it would just confuse
02:28:29 <paul_p> for example, the "how to manage caching" discussion is a technical one
02:28:39 <Brooke> I think the folks that are confused would either not take part or perhaps might learn summat
02:29:20 <oleonard> I think already folks on the Koha list thing it's too technically-oriented
02:29:33 <oleonard> ...hence calls for a separate user list
02:30:20 <paul_p> I won't argue a lot against the idea to send mail to koha main list if you think it's a good idea.
02:30:37 <Brooke> I think it's worth it for a lot of the things that would change functionality
02:31:00 <paul_p> maybe there should be a specific title header, like [DISCUSSION TECH] or [DISCUSSION FEATURE]
02:31:10 <paul_p> Brooke definetly !
02:31:25 <Brooke> that would probably help folks sort their mail and hit their delete keys sooner :)
02:31:38 <Brooke> okay so timelines
02:31:45 <Brooke> we have meetings monthly
02:31:55 <Brooke> but you want this to be a 2 week span
02:32:10 <Brooke> also, GBSD is theoretically monthly too, yes?
02:32:12 <thd> paul_p: Librarians should probably be alerted where library science issues are at stake but those questions are generally different from what I think you are intending.
02:32:26 <SpaceLibrarian> agree with thd
02:32:43 <paul_p> thd probably
02:33:38 <paul_p> Brooke would you suggest something like : "open the discussion until next IRC -but no less than 1 week- and validate the decision here" ?
02:33:52 <thd> paul_p: Nothing should ever preclude subsequent discussion after some time period if there is a serious issue to be discussed.
02:34:05 <paul_p> (validate or vote)
02:34:19 <Brooke> #idea discussion mails will be flagged [Discussion Tech] [Discussion Feature] so folks that don't wish to follow a thread can easily delete
02:34:46 <Brooke> I think we need to separate that a bit
02:34:47 <paul_p> #idea discussion mails will be sent to both koha-devel and koha main mailing list
02:35:04 <Brooke> is there anyone here that thinks discussion should last LESS than a week?
02:35:13 <thd> Brooke: Your flagging idea is even better for alerting people to pay attention as opposed to ignoring.
02:35:24 <Brooke> not my idea, pauls :D
02:35:31 <thd> :0
02:35:43 <Brooke> going once
02:35:46 <paul_p> my main concern is to have everybody able to say what they think, not everybody is at the IRC meeting
02:35:49 <Brooke> going twice
02:35:54 <Brooke> I agree paul
02:35:57 <Brooke> going gone
02:36:07 <paul_p> Brooke sometimes the discussion will quickly reach an agreement
02:36:14 <Brooke> one hopes
02:36:19 <SpaceLibrarian> indeed
02:36:22 <paul_p> but less than a week seems really short
02:36:27 <Brooke> right
02:36:32 <Brooke> which everyone agreed with
02:36:51 <thd> the 2 UTC hour seems about the worst for IRC participation.
02:37:21 <paul_p> seems...
02:37:28 <SpaceLibrarian> possibly because a good chunk from our side are actually in the middle of a library conference this time.
02:37:31 <Brooke> seems that Kiwis make their plum time
02:37:46 <eythian> Yeah, everyone's at Vala
02:37:47 <Brooke> anyhow
02:37:58 <paul_p> Brooke also seems that rangi & bob/irma are at a conf
02:37:59 <oleonard> No excuses for the Americans :P
02:38:06 <Brooke> moving to vote
02:38:11 <Brooke> question will be
02:38:50 <Brooke> Discussion will be opened over the listserv and closed at the IRC meeting but never less than a week's time for input
02:38:56 <Brooke> all in favour +1
02:39:05 <Brooke> if that doesn't make sense, say so and I'll try a rephrase
02:39:13 <oleonard> +1
02:39:15 <paul_p> +1
02:39:16 <SpaceLibrarian> +1
02:39:49 <thd> Brooke: Discussion of what?
02:40:18 <thd> Brooke: I am confused about the question being put to a vote.
02:40:26 <Brooke> Bugs and Patchs as per paul's prior discussion
02:40:45 <Brooke> patches even
02:40:57 <thd> +1
02:41:16 <Brooke> okay
02:41:21 <Brooke> hopefully this will work
02:41:24 <Brooke> it carries
02:41:47 <Brooke> hey, guess what
02:41:52 <Brooke> it's global bug squashing day
02:41:53 <Brooke> :)
02:42:33 <paul_p> the pile of bugs pending QA has grown to 14 today. It was something like 8 yesterday.
02:42:34 <Brooke> I think we've got a lot done thanks to that
02:42:49 <paul_p> the pile of "need signoff" has moved from 94 to 66
02:42:57 <Brooke> hooray
02:43:03 <oleonard> http://wiki.koha-community.org/wiki/2012-02-08_Global_bug_squashing_day
02:43:20 <Brooke> #info thanks bug squashers :D
02:43:53 <paul_p> #info more bug testers needed
02:43:56 <paul_p> really.
02:44:19 <paul_p> cait noticed a few days ago that some bugs stay "need signoff" probably because they are hard to test.
02:44:38 <Brooke> Did we need to review anything from last meeting?
02:45:03 <paul_p> she said something like "easy or small bugs are usually fast to be signed off, but hardest ones are not"
02:45:13 <paul_p> (still on previous topic)
02:45:28 <Brooke> it's a sticky problem
02:45:39 <paul_p> agreed
02:45:52 <Brooke> just like attracting people that are not professional developers associated with the project is
02:45:58 <Brooke> if we could work on either
02:46:01 <Brooke> it'd be a damn fine day
02:46:38 <Brooke> any other stuff?
02:46:50 <thd> paul_p: What we do not want and apparently do not have for these is people signing off without really taking the time to test properly.
02:47:24 <paul_p> thd ???
02:47:25 <wahanui> thd is concerned that CCL, Pazpar2, and Zebra support should not be an either that or Solr/Lucene option.  We need CCL and Pazpar2 for metasearch and we currently need Zebra for a Z39.50/SRU server. or concerned that indentation styles which do not collapse in vim lead to overly long lines which cannot always be broken across multiple lines.
02:47:46 <thd> old news wahanui
02:47:48 <paul_p> (well, I think I understand and agree)
02:48:45 <thd> paul_p: Send reminders about testing patches to the mailing list with catchy subject lines.
02:49:01 <Brooke> which was settled earlier under the discussion tag thing :)
02:49:12 <thd> :)
02:49:31 <paul_p> that could be a good plan with sandboxes = it will be easier to do. will do that frequently, thx thd
02:49:48 <Brooke> I'm suggesting 14 March 18.00 UTC
02:50:19 <Brooke> good? +1
02:50:22 <paul_p> -1
02:50:28 <thd> [Test this bug for the great warm bug tester glow]
02:50:40 <Brooke> problem with the day paul?
02:50:41 <paul_p> could it be the next week ? because it's the hackfest in europe
02:50:46 <Brooke> ah crap
02:50:47 <Brooke> of course
02:51:04 <paul_p> 21th could be fun = we could stay and have dinner while IRCing
02:51:05 <Brooke> 21 March 18.00 UTC
02:51:12 <paul_p> (will be 7PM for us)
02:51:15 <thd> +1
02:51:19 <paul_p> +1
02:51:40 <jwagner> Why the move away from the first week in March?
02:51:49 <Brooke> cause I'm going to the opera
02:52:02 <paul_p> lol (be it true or not ;-) )
02:52:07 <Brooke> if someone else wants to chair, fine by me
02:52:08 <jwagner> For the entire week?
02:52:13 <thd> jwagner: A fine reason.
02:52:34 <thd> jwagner: I think that the issue is also that Wednesday is favoured.
02:52:42 <Brooke> do you have an issue with 21 March jane?
02:53:03 <paul_p> wed++ for me
02:53:22 <jwagner> Just wondering -- the meeting is normally first week, and this will be a six-week gap
02:53:37 <thd> s/Wednesday/Wednesday UTC/  # actual day varies with time zone
02:53:40 <Brooke> might be a good thing
02:54:02 <Brooke> any other feedback?
02:54:21 <oleonard> 21st is fine with me
02:54:36 <thd> jwagner: People might have to actually use the mailing list and non-meeting IRC a bit more to communicate during the interval :)
02:54:39 <Brooke> #agreed Next meeting 21 March 18.00 UTC
02:54:44 <Brooke> #endmeeting