02:00:25 <rangi> #startmeeting
02:00:25 <wahanui> if there is a meeting then Brooke must want me
02:00:25 <huginn> Meeting started Wed Nov  7 02:00:25 2012 UTC.  The chair is rangi. Information about MeetBot at http://wiki.debian.org/MeetBot.
02:00:25 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic.
02:00:34 <rangi> #topic Introductions
02:00:35 <wahanui> #info wahanui, a bot that has become sentient
02:00:44 <oleonard> #info Owen Leonard, Athens County Public Libraries
02:00:48 <libsysguy> #info Elliott Davis, ByWater Solutions
02:00:55 <rangi> #info Chris Cormack, Catalyst IT, Rmaint 3.8.x and 3.10.x
02:01:10 <BobB> #info Bob Birchall, Calyx information essentials
02:01:11 <cjh> #info Chris Hall, Catalyst IT
02:01:11 <nancyk> #info NancyK Reno
02:01:12 <rhcl> #info rhcl = Greg - Rolling Hills Consolidated Library
02:01:14 <jwagner> #info Jane Wagner, LibLime/PTFS
02:01:19 <jcamins> #info Jared Camins-Esakov, C & P Bibliography Services, Release Manager for 3.12 and RMaint emeritus for 3.6.x
02:01:24 <eythian> #info Robin Sheat, Catalyst IT
02:01:27 <libsysguy> aww I forgot to add that I am QAA 3.12
02:01:28 <libsysguy> shoot
02:01:30 <clintD> #info Clint Deckard, Anact
02:01:45 <JDatTeTakere> 2#info Joanne Dillon (JD), Te Takere
02:01:56 <rangi> in blue even
02:02:13 <rangi> anyone else?
02:02:13 <JDatTeTakere> 2Felt like being colourful :-)
02:02:17 <mtj> #info Mason James, NZ
02:03:04 <rangi> #topic Announcements
02:03:07 <kathryn> #info Kathryn Tyree, Catalyst IT NZ
02:03:08 <davidnind> #infor David Nind, NZ
02:03:25 <wizzyrea> #info Liz Rea
02:03:31 <rangi> anyone have any announcements ?
02:04:02 <rangi> wizzyrea starts work at catalyst on monday
02:04:07 <rangi> thats the only one i have
02:04:08 <wizzyrea> \o/
02:04:13 <libsysguy> I've starting working on automated testing
02:04:22 <libsysguy> with WWW::Mech
02:04:29 <wizzyrea> libsysguy++
02:04:30 <rangi> cool
02:04:32 <libsysguy> ill publish the repo soon
02:04:48 <rangi> #action libsysguy to publish repo of his mechanized testing suite
02:05:07 <rangi> anything else before we move on?
02:05:11 <jcamins> #info We now have a repository for a version of git-bz customized for Koha at http://git.koha-community.org/gitweb/?p=git-bz.git;a=summary
02:05:16 <mtj> #info i've just eaten waaay too many samosas :/
02:05:16 <jcamins> That's it from me.
02:05:21 <wizzyrea> oooo
02:05:27 <wizzyrea> to both
02:05:30 <rangi> git-bz++
02:05:40 <libsysguy> git-bz++
02:05:43 <wizzyrea> ^^ what he said
02:05:46 <rangi> #topic update on 3.8
02:06:05 <rangi> 3.8 is coming along nicely, on schedule for 3.8.7 release on time
02:06:18 <cjh> awesome
02:06:23 <libsysguy> is it going to include the hourly fixes?
02:06:30 <libsysguy> for use with the calendar
02:06:34 <rangi> if they are pushed to master then yes
02:06:39 <libsysguy> hehe
02:06:42 <libsysguy> fair enough
02:06:53 <rangi> ie signed off, passed qa, and pushed, then ill cherry pick them to 3.8.x
02:07:19 <rangi> #topic update on 3.10
02:07:38 <rangi> we have no paul, but i think reading the newsletter is a good idea
02:07:45 <jcamins> paul_p isn't here, so I'll give what information I have.
02:08:12 <rangi> #link http://koha-community.org/koha-release-manager-newsletter-11-12-2012-10/
02:08:27 <jcamins> Now that 3.10.x has been branched and I am pushing to master we have an additional set of eyes looking over code before it gets into 3.10.x.
02:08:37 <rangi> excellent
02:08:46 <jcamins> Paul is cherry-picking bugfixes that do not include string changes.
02:09:09 <tweetbot`> [off] twitter: @nzkoha: "@ranginui is chairing the #kohails IRC meeting like a boss"
02:09:13 <jcamins> Any code that either of us is uncomfortable with will probably not go into master until after 3.10.x is released.
02:09:30 <jcamins> *3.10.0
02:09:59 <jcamins> ("probably" because there is always the possibility -- however slight -- of an error)
02:10:10 <kathryn> oops I forgot about tweetbot sorry for the interruption, my jokes always backfire...
02:10:11 <rangi> sounds good to me
02:10:13 <jcamins> As far as I know, 3.10.0 is on-schedule
02:10:19 <jcamins> I will address 3.12 when we get there.
02:10:31 <rangi> anyone have anything else for 3.10?
02:10:40 <jcamins> Oh, one more thing.
02:10:49 <jcamins> TEST BUGFIXES!!!!
02:10:59 <rangi> oh yes
02:11:23 <rangi> #action everyone test bug fixes
02:11:29 <rangi> #topic 3.12
02:11:31 <jcamins> #action Test and sign off on the bugfixes that are already in Bugzilla, and test 3.10.x/master and fix any bugs you find.
02:11:38 <jcamins> Oh, rangi beat me.
02:11:40 <rangi> heh
02:11:47 <rangi> you again jcamins
02:11:52 <Irma> sorry I am late # Irma CALYX information essentials - Sydney
02:12:04 <Irma> hi all
02:12:18 <jcamins> The master branch will be 3.11 once 3.10.0 is released.
02:12:35 <jcamins> Right now I am only pushing 3.10-safe fixes to that branch.
02:12:43 <rangi> cool
02:13:00 <jcamins> However, as non-3.10 patches pass QA I am applying them to an integration branch on my local machine.
02:13:18 <jcamins> This brings up an important point.
02:13:53 <jcamins> One of the bugs that was marked "Passed QA" was marked that BY ITS AUTHOR, without ANY member of the QA team approving it.
02:14:06 <jcamins> Attached to that bug were no fewer than *three* patches that had not been tested by anyone.
02:14:09 <rangi> down with that kind of thing
02:14:20 <wizzyrea> ew yea not acceptable.
02:14:22 <jcamins> That is not, and never has been acceptable.
02:14:45 <jcamins> The change in release manager does not mean a relaxation of QA standards.
02:15:08 <jcamins> I will, in fact, be requesting additional signoffs from members of the QA team whenever they QA patches.
02:15:17 <rangi> shall i do an info point only qa team can mark things passed-qa ?
02:15:23 <jcamins> Yes, good idea.
02:15:36 <wizzyrea> I think bugzilla can manage that sort of thing or no?
02:15:40 <wizzyrea> with permissions
02:15:51 <wizzyrea> bugzilla can do some crazy awesome things.
02:15:52 <jcamins> wizzyrea: I'm not sure. But if it can, that might be good.
02:15:52 <libsysguy> yeah can we fix that kind of thing with perms
02:16:05 <rangi> #info only qa team should mark patches passed qa, unless there are some crazy circumstances like security and everyone is on holiday in tahiti or something
02:16:06 <wizzyrea> wewt
02:16:17 <jcamins> #action Find out if we can set Bugzilla permissions so that only the QA team can mark things "Passed QA"
02:16:18 <wizzyrea> tahiti_holiday++
02:16:29 <jcamins> Let's see, what else?
02:16:35 <cjh> although if a patch is 'passed qa' and then goes 'in discussion' it would require a qa team member to put it back to 'passed qa', is this desired?
02:16:43 <jcamins> cjh: I'm leaning towards "yes."
02:16:56 <wizzyrea> yea, I tend to agree with hat
02:16:58 <wizzyrea> that*
02:16:59 <libsysguy> same
02:17:03 <rangi> i think we have a big team now
02:17:06 <rangi> that should be ok
02:17:07 <jcamins> The bug report that I'm referring to was set to "Passed QA" by the author several times.
02:17:14 <cjh> eek
02:17:15 <wizzyrea> !!
02:17:18 <wizzyrea> oy
02:17:31 <cjh> jcamins++ # for bringing it up
02:17:57 <jcamins> Other than that, I expect a nice tight six-month release cycle, and I'll be preparing monthly "previews."
02:18:02 <eythian> a general reinforcement of the rules would be good
02:18:19 <wizzyrea> I like your style.
02:18:24 <eythian> I've seen a patch by company X that was signed off by someone associated with X, and then the QA signoff was also from X.
02:18:34 <eythian> And it broke things for other people.
02:18:40 <rangi> yeah, now the team is big too, its easy to stop that
02:18:41 <jcamins> Yes. That's a good point.
02:19:06 <rangi> i think cait will be great at managing those things
02:19:23 <jcamins> During the 3.12 cycle I'll be leaning on cait a lot to deal with delegation.
02:19:49 <libsysguy> cait will rule with an iron fist
02:20:46 <BobB> :)
02:20:47 <jcamins> #info During the 3.12 release cycle, the RM will assign the QAM as QA contact to bugs where he is concerned about a conflict of interest, and the QAM can delegate as appropriate.
02:21:01 <jcamins> I think that's pretty much it from me.
02:21:08 <rangi> thanks jcamins
02:21:11 <jcamins> Oh, one more thing.
02:21:24 * rangi pauses
02:21:55 <jcamins> #info The RM will prepare a "roadmap" for 3.12 after 3.10.0 is released, but since the focus is on "stability," don't expect a detailed plan for exactly what we're going to be working on at any given point.
02:22:00 <jcamins> That's it.
02:22:07 <rangi> jcamins++
02:22:11 <Irma> Is there a date for the next Global Bug Squashing Day?
02:22:18 <oleonard> jcamins++
02:22:23 <rangi> #topic kohacon13
02:22:30 <wizzyrea> jcamins++ i like roadmaps
02:22:38 <cjh> heh
02:22:40 <rangi> Irma: can you ask that again when we get to miscallaneous please
02:22:49 <Irma> ok
02:22:51 <rangi> but spelt right ;)
02:23:12 <rangi> nancyk: did you have any information about kohacon13 ?
02:23:15 <nancyk> almost finished touring hotels, have it narrowed down to 3
02:23:20 <rangi> oh cool
02:23:29 <nancyk> looks like mid odtober
02:23:40 <nancyk> rats bad spelling
02:23:59 <rangi> cool
02:24:12 <rangi> #info kohacon13 dates are looking like mid october
02:24:20 <Irma> nancyk ++
02:24:28 <nancyk> We will get info on the web site and wiki as soon as we know which hotel
02:24:42 <nancyk> Excited!!!!
02:24:49 <libsysguy> nancyk I require a beautyrest in my hotel :p
02:24:51 <jcamins> Could you put a link to the KohaCon13 website and wiki pages in the minutes?
02:24:55 <rangi> nancyk++
02:24:58 <wizzyrea> lol.
02:25:11 <oleonard> What's the weather like in October?
02:25:11 <wizzyrea> well you are our "hottest developer" so there's that.
02:25:14 <libsysguy> nancyk++
02:25:17 <rangi> #link http://wiki.koha-community.org/wiki/KohaCon13_Summary
02:25:23 <libsysguy> I do have to keep up my beauty :p
02:25:26 <rangi> and
02:25:29 <nancyk> 70s and sometimes 80s sunny
02:25:30 * wizzyrea giggles
02:25:37 <rangi> #link http://koha-community.org/kohacon/kohacon13-2/
02:25:37 <wizzyrea> sounds pretty perfect ;)
02:25:38 <oleonard> Swank.
02:25:41 <thd> #info Thomas Dukleth, Agogme , New York City, survived the blackout and heatout
02:25:52 <rangi> good to see you safe and sound thd
02:25:54 <wizzyrea> yes! thd made it through sandy!
02:26:06 <rhcl> thd: nor'easter coming, right
02:26:10 <rhcl> ?
02:26:13 <rangi> does anyone else have anything else about kohacon13 ?
02:26:22 <nancyk> no
02:26:36 <davidnind> 70 F = 21 degrees C
02:27:10 <rangi> #topic actions from the last meeting
02:27:32 <rangi> i don tthink we had any actions?
02:27:41 <jcamins> I don't see any.
02:27:48 <rangi> moving on
02:27:55 <rangi> #topic Miscellaneous
02:28:09 <BobB> spelt right, too
02:28:11 <rangi> Irma: you had a question? :)
02:28:52 <BobB> it was about Global Bug Squashing Day, is there a date?
02:29:07 <Irma> http://wiki.koha-community.org/wiki/2012-09-14_Global_bug_squashing_day Next date?
02:29:18 <Irma> snap
02:29:19 <rangi> ah, magnus usually organises that
02:29:30 <rangi> id suggest an email to the koha-devel list
02:29:35 <wizzyrea> he's sleeping :)
02:29:40 <rangi> of course, we could just pick a date ;)
02:29:55 <rangi> itd be good to do one before 3.10.0
02:29:59 <jcamins> It's usually the second Friday.
02:30:05 <rangi> *nod*
02:30:12 <rangi> which is tomorrow
02:30:13 <Irma> Stefan is in Sydney until 3/12 so before then would be good
02:30:20 <rangi> in nz
02:30:38 <jcamins> Which would be... 9 November
02:30:49 <oleonard> I'd love to see people try to lead testing on patches they have written which have languished in the needs-signoff queue for a long time.
02:30:58 <mtj> or 16th nov, the friday after that?
02:31:06 <rangi> i think the 9th is good
02:31:23 <rangi> 15th is string freeze for 3.8.x
02:31:46 <rangi> adn we dont want a pile of patches the week before 3.10.0
02:31:52 <mtj> yeah, so 16th not so good
02:31:53 <jcamins> I'm fine with the 16th, but keep in mind that I _am_ a stickler, and we have two people pushing code to get it into 3.10.x, so some patches would probably get deferred for 3.10.1
02:31:59 <rangi> yeah
02:32:15 <jcamins> And by "probably" I mean "I am absolutely certain."
02:32:22 <rangi> #idea bug squashing day on the 9th of november
02:32:36 <rangi> if people want it to happen then, they just need to make a wiki page
02:32:39 <rangi> and send out emails
02:32:54 <rangi> any one want to volunteer to do that ?
02:33:45 <wizzyrea> hrm think it'll actually get any traction? does it have to be a friday?
02:33:55 <rangi> nope
02:34:14 <rangi> make it monday and ill make it your job to test patches *grin*
02:34:26 <wizzyrea> ^.^
02:34:58 <Irma> Friday 9th Nov or Mon 12th Nov ok for CALYX
02:35:05 <rangi> well i think the secret with it, like pretty much everything in koha, is someone needs to organise/do it
02:35:18 <rangi> and magnuse is conferencing
02:35:24 <rangi> and so is cait
02:35:27 <rangi> and they usually do it
02:35:32 <rangi> so someone else will need to step up
02:35:46 <oleonard> I can to the wiki and the emails if we can settle on a date
02:35:57 <mtj> im trying to work out how to use a 'Template:Globsquad' template to make a new GSBD page
02:36:06 <mtj> +1 9th nov
02:36:47 <Irma> + 9th nov
02:37:09 <Irma> +1 9th nov
02:37:16 <oleonard> Will magnus and cait still be conferencing Friday? Monday?
02:37:28 <rangi> cait will be make on friday
02:37:35 <thd> +1 12 Nov.
02:37:50 <stefan-l> +1 9th nov
02:38:03 <jcamins> What about GBSW? - Global Bug Squashing Weekend
02:38:20 <jcamins> We're approaching 3.10.
02:38:24 <rangi> true
02:38:30 <jcamins> Now is a good time to really focus on testing.
02:38:32 <rangi> yup
02:38:35 * oleonard can bug-squash at work but too many obligations at home
02:38:50 <jcamins> oleonard: right, that's why it's Friday-Monday.
02:39:01 <jcamins> *College* weekend.
02:39:02 <oleonard> I see
02:39:05 <jcamins> Not real person weekend. :P
02:39:15 <cjh> I feel 2 days is a bit short notice, hopefully we can get enough people
02:39:30 <jcamins> Right, so we also have 5 days notice for Monday.
02:39:41 <jcamins> We'll call it a sprint, or a storm, or whatever's cool in project management.
02:39:47 <cjh> heh
02:39:52 <thd> storm :)
02:40:26 <jcamins> #action jcamins will mark candidates for 3.10 that are in "Needs signoff" assuming he has power this week.
02:40:28 <mtj> i love the  bugs squash weekend idea
02:40:34 <rangi> scrum storm sprint
02:40:40 <cjh> a bug squash weekend sounds cool.
02:40:41 <rangi> dont kick the ball
02:40:42 <rangi> pass it
02:40:46 <oleonard> Anyone object to GBSW?
02:40:50 <rangi> not me
02:40:51 <BobB> What about starting on Friday and letting it run until Monday?  Is that the suggestion?
02:40:56 <jcamins> This will make it easier for people to prioritize for the bug squashers.
02:40:57 <rangi> thats the one BobB
02:41:00 <jcamins> BobB: exactly. :)
02:41:06 <BobB> cool
02:41:09 <mtj> koha bitzkrieg
02:41:38 <wizzyrea> O.o
02:42:15 <jcamins> So, let's vote?
02:42:16 <mtj> 'Shock and Awe!'
02:42:17 <jcamins> +1
02:42:20 <rangi> +1
02:42:21 <oleonard> +1
02:42:33 <Irma> +1
02:42:41 <davidnind> +1
02:42:56 <mtj> +1
02:43:05 <cjh> +1
02:43:14 <thd> +1 all weekend although I am otherwise committed
02:43:24 <libsysguy> +1
02:43:41 <stefan-l> +1 on friday
02:43:46 <BobB> +1
02:44:09 <rangi> #agreed Global bug squashing weekend starting november 9th
02:44:56 <rangi> ok, anything else before we move on to the date for the next meeting?
02:45:29 <jcamins> Not from me.
02:45:42 <rangi> ok
02:45:48 <Irma> RDA and getting Koha ready for it ...
02:45:59 <rangi> heh, thats more of a wiki page i think
02:46:02 <BobB> ..that's a big one!
02:46:25 <rangi> first they need to decide which rda :)
02:46:37 <rangi> but yeah, can we move that one to the list?
02:46:42 <rangi> and/or wiki?
02:46:49 <rangi> http://wiki.koha-community.org/wiki/RDA
02:46:52 <thd> The MARC framewarks are years out of date.  Funding disappeared for that work.
02:47:13 <jcamins> Yeah, I'd say the wiki is the place for that discussion.
02:47:54 <Irma> Should we enter it as an agenda item for the next meetings though?
02:48:25 <oleonard> I'm not sure that would be productive before a list/wiki discussion has started
02:48:26 <BobB> Prolly need to get more momentum first, via the wiki.
02:48:35 <rangi> yeah
02:48:38 <wizzyrea> ^^
02:48:41 <Irma> So that we can briefly discuss progress and necessary actions?
02:48:44 <rangi> then organise a meeting of ppl interested in it
02:48:49 <oleonard> speaking of which, we need to get the license upgrade conversation started again too
02:48:51 <rangi> not really a general topic i dont think
02:48:52 <jcamins> Yeah, wiki and/or list, then when there's an action, discuss it in a general meeting.
02:49:17 <thd> We should be trying to push it so that people can at least have full RDA records from copy cataloguing when those start becoming widely available.
02:49:19 <wizzyrea> I feel like I need to know what exactly needs to be done? "RDA support" is pretty nebulous for me
02:49:34 <eythian> the wiki page makes a few starting points
02:49:37 <rangi> yep, those are all opinions
02:49:44 <rangi> and ripe for putting on a wiki page :)
02:49:52 * rangi moves on
02:49:57 <thd> I am well informed about RDA and paid for some expensive classes.
02:49:59 <rangi> #topic date for next meeting
02:50:14 <rangi> (i warned you about letting me chair, i have an awards thingy to go to later)
02:50:43 <rangi> the next time is 18:00 UTC
02:50:48 <wizzyrea> +1
02:50:49 <thd> I like the pace :)
02:51:05 <rangi> so who has a date in mind?
02:51:25 <thd> early in the month please
02:51:34 <BobB> 5 Dec?
02:51:39 <Irma> 5/12?
02:51:39 <wahanui> 0.416666666666667
02:51:40 <mtj> 5 dec
02:51:45 <davidnind> 5 December - first Wednesday of the MOnth?
02:51:48 <BobB> that's the first Wednesday in Dec
02:51:49 <rangi> sounds good
02:51:50 <cjh> sounds good.
02:51:53 <rangi> lets vote
02:51:56 <jcamins> +1
02:51:57 <mtj> +1
02:51:58 <cjh> +1
02:51:58 <oleonard> +1
02:52:00 <JDatTeTakere> +1
02:52:01 <thd> +1
02:52:02 <rangi> +1
02:52:05 <Irma> +1
02:52:06 <davidnind> +1
02:52:14 <nancyk> +1
02:52:17 <jwagner> +1
02:52:21 <kathryn> +1
02:52:28 <mtj> obama wins!
02:52:40 <wizzyrea> we can hope ;)
02:52:46 <rangi> heh
02:52:47 <Irma> Great voting! If only US elections were this simple ;-)
02:53:08 <rangi> #agreed Next meeting is Decmber 5 18:00 UTC
02:53:28 <mtj> ok, see y'all next 5 dec
02:53:29 <rangi> December too
02:53:34 <rangi> decememememeber
02:53:43 <rangi> #endmeeting