18:04:41 <cait> #startmeeting General IRC Meeting
18:04:41 <huginn`> Meeting started Wed Sep 11 18:04:41 2013 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:04:41 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:04:41 <huginn`> The meeting name has been set to 'general_irc_meeting'
18:04:48 <cait> #topic Introductions
18:04:49 <wahanui> #info wahanui, a bot that has become sentient
18:04:52 <rhcl> #info rhcl = Greg Lawson, Rolling Hills Consolidated Library
18:05:04 <gmcharlt> #info Galen Charlton, Equinox Software, 3.14 RM
18:05:05 <cait> please introduce yourself using #info
18:05:10 <nengard> #info Nicole Engard, ByWater Solutions
18:05:13 <cait> #info Katrin Fischer, BSZ Germany
18:05:14 <mduncan> #info Margo Duncan, University of Texas at Tyler
18:05:15 <NateC> #info
18:05:16 * thd is typing in lower case and yet the caps lock key is down.  What causes that?
18:05:19 <davidnind> #info David Nind, Wellington, New Zealand
18:05:20 <khall> #info Kyle M Hall, ByWater Solutions
18:05:21 <druthb> #info D Ruth Bavousett
18:05:23 <meliss> #info Melissa Lefebvre, ByWater Solutions
18:05:25 <tcohen> #info Tomas Cohen Arazi, Universidad Nacional de Cordoba
18:05:27 <bgkriegel> #info Bernardo Gonzalez Kriegel, Cordoba, Argentina
18:05:28 <mtompset> #info Mark Tompsett
18:05:29 <jwagner> #info Jane Wagner, LibLime/PTFS
18:05:38 <phred_> #info Fred King, Washington Hospital Center
18:05:41 <tajoli> Zeno Tajoli, CINECA, Italy
18:05:48 <drojf> #info Mirko Tietgen, Berlin, Germany
18:05:51 <thd> Thomas Dukleth, Agogme, New York City
18:05:52 <cait> #info Agenda for today's meeting: http://wiki.koha-community.org/wiki/General_IRC_meeting,_11th_September_2013
18:05:58 <mtompset> tajoli: You forgot the #info.
18:06:01 <tajoli> #info Zeno Tajoli, CINECA, Italy
18:06:03 <thd> #info Thomas Dukleth, Agogme, New York City
18:06:10 <NateC> Nate Curulla: Bywater Solutions
18:06:11 <cait> maybe that should have been #link :)
18:06:16 <bag> #info Brendan Gallagher ByWater
18:06:56 <cait> all done?
18:07:07 <tcohen> yeap
18:07:09 <cait> #topic Announcements
18:07:23 <cait> *waits*
18:07:53 <cait> no announcements? :)
18:08:27 <drnoe> #info David Noe, ByWater Solutions
18:08:28 <NateC> I like space
18:08:29 <gmcharlt> "... in other news, the sky is blue today"
18:08:30 <cait> ok, is chrish around?
18:08:54 <cait> bgkriegel?
18:08:54 <wahanui> bgkriegel is on a signoff spree
18:08:57 <cait> :)
18:09:00 <clint_> #info clintD, Anact, NZ
18:09:02 <bgkriegel> yes :)
18:09:11 <cait> #topic Update on 3.10
18:09:22 <bgkriegel> all is well, a little behind
18:09:28 <bgkriegel> but i will catch up
18:09:50 <cait> bgkriegel++
18:10:21 <cait> thx for your work :)
18:10:26 <cait> iwill move to 3.12 then?
18:10:33 <cait> #topic Update on 3.12
18:10:41 <cait> tcohen: the stage is yours :)
18:10:57 <tcohen> 3.12 is getting mature, no big bugs arise
18:11:09 <talljoy> #info Joy Nelson ByWater Solutions
18:11:14 <tcohen> i plan to cherry-pick dom indexing support for packages
18:11:23 <tcohen> but leaving grs1 as default
18:11:33 <tcohen> (dom-as-default would be a 3.14 feature)
18:11:43 <cait> sounds good to me
18:11:56 <tcohen> trying to catch up with master
18:12:01 <tcohen> and that's it :-D
18:12:20 <cait> thx tcohen - tcohen++ :)
18:12:36 <cait> #topic Update on 3.14
18:12:52 <gmcharlt> OK
18:12:59 <gmcharlt> #info Feature slush remains at 2012-09-25
18:13:09 <gmcharlt> #info Feature freeze remains at 2013-10-03
18:13:18 <gmcharlt> #info Architectural changes that are still on the table for inclusion in 3.14 are DBIx::Class and some sort of logging module
18:13:51 <gmcharlt> #info planning a big push, well, push next week after the QA sprint tomorroow
18:14:15 <cait> gmcharlt: can you define feature slush a little? want to prevent any misunderstandings if possible :)
18:14:56 <gmcharlt> #info RM emphasis for this release is reinforcing the QA process -- patches must have sufficient review to be accepted, and I'm heavily pushing for unit tests
18:15:27 <cait> gmcharlt++
18:15:34 <tcohen> gmcharlt++
18:15:49 <gmcharlt> cait: feature slush -- any new features that have hit passed QA by that date will be included in 3.14, assuming they don't raise signfiicant QA concerns on my part
18:16:29 <cait> thx :)
18:16:33 <gmcharlt> new features that have /not/ hit passed QA by feature slush are more liable to be left for the next release; if you want something that misses slush to make it in, you'll need to advocate for it
18:16:42 <thd> Why does slush have the name slush?
18:16:56 <gmcharlt> a partial freeze, of course
18:17:05 <thd> OK
18:17:37 <gmcharlt> also, another announcement -- I did not, of course, actually do a tarball of a pre-pre-alpha
18:17:48 <gmcharlt> instaed, I'll do so shortly after feature freeze
18:17:58 * thd was thinking of other domains in which slush is used.
18:17:59 <gmcharlt> any questions for me?
18:18:31 <thd> What is intended to be logged for a logging feature?
18:18:36 <cait> just a thank you for your work gmcharlt++
18:18:55 <tajoli> The differce beetwenn slush and freeze ?
18:19:02 <gmcharlt> thd: system events, debug info
18:19:33 <gmcharlt> essentially, the idea in the patch series for bug 8190, but a version that supports syslog
18:19:34 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=8190 enhancement, P5 - low, ---, jonathan.druart, Passed QA , Add a logging module to Koha
18:19:39 <gmcharlt> which is a sine qua non from my POV
18:19:43 <bag> gmcharlt: what's the road block for DBIx::Class currently?
18:20:04 <bag> is it just getting the DB foriegn keys worked out...
18:20:11 <gmcharlt> the current patch series needs some cleanup, and there are some FK to be added
18:20:12 <cait> just... :)
18:20:23 <oleonard> #info Owen Leonard, Athens County Public Libraries
18:20:26 <gmcharlt> also, the current patch series uses an otion that the DBIC maintainer specifically recommends against
18:20:35 <bag> ok subtract just from my statement cait :)
18:20:41 <gmcharlt> but be assured, it /will/ be in 3.14
18:20:44 <cait> i think it's doable
18:20:51 <bag> ok cool thanks galen
18:21:39 <cait> gmcharlt: have you seen tajoli's question?
18:21:48 <gmcharlt> ah, no, missed it
18:22:04 <tcohen> tajoli: any feature that is passed-qa by feature slush is elegible for 3.14, otherwise it isnt.
18:22:16 <gmcharlt> I did answer the question about the distinction between slush and freeze, if that's what you're referring to
18:22:23 <cait> then I missed it :)
18:22:39 <mtompset> frozen out, verses slushing in. :)
18:22:49 <gmcharlt> no, looks like tajoli had asked the same question you had asked, cait :)
18:22:50 <mtompset> ^verses^versus^
18:23:00 <cait> if there are no more questions we can move on?
18:23:09 <tajoli> In fact yes, is the same question
18:23:29 <cait> #topic QA sprint day
18:23:51 <cait> we had a qa team meeting and discussed some ideas on how to get things moving and flowing a bit better
18:23:59 <cait> and one of the ideas that came up was a QA sprint day
18:24:04 <cait> #link http://wiki.koha-community.org/wiki/2013-09-12_QA_Sprint_day
18:24:19 <cait> mtj++ has added a wiki page for it and i hope that lots of QA will be done
18:24:30 <cait> but right now I think the needs sign off queue needs some work too...
18:24:32 <tcohen> sounds great, can we non-QA people help?
18:24:49 <cait> and for the big features you want to see moved through qa a second sign off would make help
18:24:52 <cait> or third.. fourth...
18:25:02 <cait> best with some notes what you looked at
18:25:19 <cait> there are some pretty big patches in the qa queue right now that take a lot of time testing
18:26:19 <cait> so it's not a GBSD - but with 169 bugs in needs signoff... and 51 of that bugs...
18:26:37 <cait> please feel free to test test test everything you can get your hands on :)
18:26:55 <mtompset> But will it be coordinated after GBSD's in the future?
18:27:15 <cait> it's something new we try out, we will have to see how it goes I think
18:27:18 <tajoli> I have an annucement about sign off
18:27:39 <cait> I think it actually might have started already in kiribati or so?
18:28:14 <tajoli> As CINECA we try to sponsor an our internal IT as 'sign offer'
18:28:17 <cait> #info if you care about a feature, don't hesitate to give it another good testing and sign off
18:28:40 <drojf> tajoli++
18:28:48 * oleonard dispatches the QA team to Kiribati in a black helicopter
18:28:55 <tcohen> heh
18:29:16 <tajoli> this person is working only on bugs in 'Need Sign Off' to test them
18:29:40 <cait> tajoli: sounds good
18:29:45 <drojf> tajoli: you should probably send the person here
18:29:56 <cait> i was going to suggest that too :)
18:30:00 <drojf> if there is no language barrier
18:30:20 <tajoli> Her name is 'Paola Rossi' <paola.rossi@cineca.it>
18:30:24 <mtompset> oleonard has the helicopter to transport the person. ;)
18:30:35 <tajoli> She speak Italian and English
18:30:59 <cait> tajoli: I think I have seen her name on some patches already?
18:31:01 <tajoli> But she doesn't have a big knowldge of Koha
18:31:06 <cait> or maybe i confuse her
18:31:42 <tajoli> She stritly follow the plan inside
18:32:09 <cait> maybe she can note that - or she can drop on irc and ask if there is something she is not sure about
18:32:16 <cait> or just note on the bug :)
18:32:16 <tajoli> she worked heavly on waterfall metodology
18:33:17 <tajoli> so, if you receive an email from her, answer as longer as you can
18:34:02 <tajoli> I think that in some month she could stard to write unit test also
18:34:09 <tajoli> but not now
18:35:14 <tajoli> So if tomorrow you have a simple 'sign off', write me and I send it to her
18:35:17 <cait> cineca++
18:35:24 <tcohen> cineca++
18:35:25 <tajoli> That all folk
18:35:26 <cait> any more questions and notes about this topic?
18:35:47 <cait> is there something people would like to see given top priority in QA?
18:35:51 <cait> your chance ;)
18:36:05 <drojf> good qa
18:36:06 <drojf> :P
18:36:23 <cait> drojf: excellent priority :)
18:36:35 <gmcharlt> cait++
18:36:36 <cait> ok, i see that nancy has left a note on the wiki
18:36:37 <gmcharlt> drojf++
18:36:40 <tcohen> packages patches
18:36:40 <gmcharlt> tajoli++
18:36:51 <cait> tcohen: have been trying, but my vm ... was annoying
18:37:02 <tcohen> i'll be around to help on them if needed
18:37:03 <oleonard> cait, we contributed money towards Bug 2720, so we're anxious to see that pass
18:37:04 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=2720 enhancement, P3, ---, kyle, Signed Off , Overdues which debar automatically should undebar automatically when returned
18:37:05 <cait> will try again soon, but would be nice if someone beat me to it
18:37:36 <cait> oleonard: ok
18:38:11 <cait> #topic KohaCon2013
18:39:10 <cait> #info news from nancy were sent to the mailinglist and are also noted on the agenda
18:39:19 <cait> it looks like we need more people reserving rooms at the hotel
18:39:34 <drojf> hm
18:39:38 <drojf> question
18:39:39 <wahanui> question is "What is the meaning of life, the universe and everything?"
18:39:40 <cait> so if you are guilty of going to KohaCon but not having done your bookings yet...
18:39:51 <cait> yes drojf?
18:39:51 <wahanui> drojf is from Germany and developing Koha on a raspberry pi!
18:40:02 <thd> The note does not give a reminder of the required number for meeting the hotel conditions.
18:40:14 <cait> i think the email had it
18:40:17 <drojf> i don't think it is mandatory to sleep in that hotel, is it? so in theory, is it possible that there won't be a conference location if not enough people get rooms?
18:40:35 <thd> How many more reservations are needed?
18:40:44 <cait> I think they have to pay for the meeting rooms then
18:40:49 <cait> that's what i understood
18:41:20 <phred_> ISTR it was 125, with about 100 registered.
18:41:21 <drojf> and by they you mean you?
18:41:35 <cait> #link http://koha-community.org/koha-community-newsletter-august-2013/#kohacon13
18:41:48 <oleonard> As the hosts I think they would have to pay drojf
18:41:57 <oleonard> We don't have a mechanism set up to charge attendees
18:42:03 <drojf> ok
18:42:04 <cait> or look for more sponsors
18:42:46 <drojf> iw as a little confused by the calculation of every registration equals a room booked
18:42:52 <thd> drogf: The host goal is to break even on expenses.  If anything goes wrong, then they loose.
18:43:32 <cait> i thnk we can move on?
18:43:35 <drojf> yup
18:43:43 <cait> #topic KohaCon14
18:44:05 <drojf> as you have probably seen, i have sent out another mail. proposals close 15 september
18:44:16 <drojf> i set 18 UTC as the time, so there is one
18:44:24 <drojf> we have two proposals
18:44:28 <drojf> argentina and nigeria
18:44:58 <drojf> and i do not expect another one coming up in the next three days, but who knows
18:45:19 <drojf> i think that's about it
18:45:22 <cait> drojf: 2 will be easy for voting i think?
18:45:31 <drojf> one would have been easy :)
18:45:35 <cait> true :)
18:45:38 <cait> ok, next topic
18:45:49 <tcohen> voting?
18:45:50 <wahanui> voting is http://ci.openstack.org/meetbot.html
18:45:53 <cait> #topic Actions from previous meeting
18:46:02 <tcohen> when will it happen?
18:46:08 <cait> tcohen: sorry, was too fast
18:46:13 <tcohen> np
18:46:48 <cait> drojf: have we talked about that yet?
18:46:57 <drojf> we said beginning of october. sow e should probably fix that now
18:47:07 <drojf> because next meeting will be after that
18:47:22 <drojf> how long did we do the last times? open polls for a week or something?
18:48:00 <cait> maybe 2
18:48:07 <phred_> Sorry for delay--just found e-mail from Nancy--need 125 rooms booked, didn't say how many had been (as of 28 August)
18:48:49 <drojf> what about voting from 23september to 6 october?
18:48:55 <cait> sounds ok to me
18:48:59 <tcohen> +1
18:49:07 <mtompset> +1
18:49:12 <bgkriegel> +1
18:49:13 <cait> +1
18:49:14 <drojf> that would be two weeks and cover the beginning of october part, but would not delay things unnecessarily
18:49:21 <davidnind> +1
18:49:25 <cait> have we figured out who will set up the vote?
18:49:31 <tajoli> +1
18:49:40 <bag> nengard can you?
18:49:41 <drojf> i can do a limesurvey i guess
18:49:46 <cait> cool
18:49:47 <cait> drojf++
18:49:54 <bag> oh darn she's out
18:50:45 <cait> #agreed the vote for kohacon14 will be open from 23september to 6 october?
18:51:03 <cait> hm missed to delete the questionmark
18:51:26 <cait> #action drojf will set up a limesurvey
18:51:29 <cait> ;)
18:51:43 <cait> ok, as there are actually no actions left from last meeting it seems
18:51:46 <Brooke> 0/
18:51:51 <mtompset> Also back under KohaCon related issues, my Filipino colleague is dreaming of how to make a 2015 proposal work. But no promises. :)
18:51:56 <cait> i think we can move on and decide a time and date for the next :)
18:52:29 <Brooke> isn't next meeting essentially KohaCon?
18:52:30 <cait> roughly in a month... before kohacon?
18:52:39 <cait> #topic Set time for next meeting
18:52:53 <thd``> Do we want to set a time after the votes on KohaCon14 have been tallied?
18:52:54 <cait> Brooke: not everyone is going there - so i think having one before wouldn't hurt
18:52:59 <cait> and we are getting closer and closer to release
18:53:03 <cait> and deadlines
18:53:23 <cait> what about... october 12th?
18:53:29 <cait> drojf: which time is next?
18:53:46 <tcohen> why not just after kohacon14 voting end?
18:53:54 <oleonard> October 12 is a Saturday
18:54:06 <cait> oh sory, was looking at the wrong month
18:54:11 <oleonard> Wed. 9 October?
18:54:23 <thd``> +1
18:54:26 <tcohen> +1 # 9 Oct
18:54:30 <cait> +1
18:54:39 <thd``> What hour is next?
18:54:41 <oleonard> Where are we in the time rotation? What's next?
18:54:46 <davidnind> +1 9 October
18:54:47 <mtompset> That works without interfering with the travelling of those going to KohaCon.
18:54:50 <talljoy> +1
18:54:50 <gmcharlt> +1 10/9
18:54:53 <cait> i asked drojf - didn't work :)
18:55:07 <davidnind> 10:00 UTC
18:55:25 <cait> sounds about right
18:55:26 <cait> ok
18:55:40 <mtompset> +1 October 9.
18:55:47 <cait> #info next meeting will be on 9th October, 10 UTC
18:56:02 <cait> thank you all for attending :)
18:56:10 <bgkriegel> cait++
18:56:11 <cait> go testing patches!
18:56:13 <Brooke> thanks for chairing. *sucker* ;)
18:56:16 <mtompset> cait++ # thanks for chairing the meeting.
18:56:16 <drojf> sorry, was in the kitchen :)
18:56:17 <davidnind> cait++
18:56:18 <talljoy> cait++
18:56:19 <gmcharlt> cait++
18:56:19 <cait> #endmeeting