02:05:11 <gmcharlt> #startmeeting General Meeting, 2012-02-06
02:05:11 <huginn> Meeting started Thu Feb  7 02:05:11 2013 UTC.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
02:05:11 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
02:05:11 <huginn> The meeting name has been set to 'general_meeting__2012_02_06'
02:05:19 <wizzyrea> #info Liz Rea, CatalystIT
02:05:24 <wizzyrea> present yourselves.
02:05:27 <gmcharlt> #info Galen Charlton, Equinox
02:05:33 <JDatTeTakere> #info Joanne Dillon (JD), Te Takere
02:05:34 <druthb> #info D Ruth Bavousett, ByWater, Translation Manager 3.12
02:05:37 <davidnind> #info David Nind, Wellington, New Zealand (currently at DrupalCon Sydney)
02:05:42 <wizzyrea> (please :)
02:05:43 <jwagner> #info Jane Wagner, LibLime/PTFS
02:05:46 <libsysguy> #info Elliott Davis, Bywater, QAA
02:05:48 <kathryn> #info Kathryn Tyree, Catalyst IT
02:05:53 <mtompset> #info Mark Tompsett, Canada
02:05:55 <cjh> #info Chris Hall, Catalyst IT
02:05:58 <eythian> #info Robin Sheat, Catalyst IT
02:06:02 <bag> #info Brendan Gallagher, ByWater
02:06:07 <jcamins> #info Jared Camins-Esakov, C & P Bibliography Services, RM 3.12
02:06:12 <wizzyrea> agenda?
02:06:12 <wahanui> i guess agenda is a wiki
02:06:25 <mtompset> http://wiki.koha-community.org/wiki/General_IRC_meeting,_9_January_2013
02:06:25 <wizzyrea> http://wiki.koha-community.org/wiki/General_IRC_meeting,_7_February_2013
02:06:34 <mtompset> Oops... wrong one. :)
02:06:47 <nancyk> #info nancyk Reno, Nevada
02:06:50 <mtompset> (I was reading the back actions)
02:06:54 <khall> #info Kyle M Hall, Bywater
02:07:07 <trea> #info Thatcher Rea, ByWater Solutions
02:07:18 <wizzyrea> Right, so hello everybody, welcome to the Koha community meeting, I'll be your taskmaster today
02:07:29 <wizzyrea> to start with, we have Announcements
02:07:38 <jcamins> I think gmcharlt has to chair the meeting.
02:07:46 <wizzyrea> does anyone have any announcements that aren't already on the agenda?
02:08:06 <mtompset> (because he started the meeting?)
02:08:12 <jcamins> mtompset: right.
02:08:25 <wizzyrea> right well.
02:08:40 <gmcharlt> #chair wizzyrea
02:08:40 <huginn> Current chairs: gmcharlt wizzyrea
02:08:49 <mtompset> Solved. :)
02:09:00 <wizzyrea> right, so, see above :P
02:09:03 <wizzyrea> announcements?
02:09:21 <wizzyrea> births, deaths, new migrations you want to brag about
02:09:29 <wizzyrea> going once
02:09:34 <mtompset> I could be back on Koha development...
02:09:39 <mtompset> shortly. :)
02:09:59 <wizzyrea> cool :)
02:10:11 <wizzyrea> features you're developing that you want to suggest a sign off for
02:10:15 <wizzyrea> nothing?
02:10:16 <wahanui> nothing is a requirement, we have guidelines though
02:10:25 <libsysguy> possibly the nginx installer?
02:10:26 <wizzyrea> ok then on to the 3.8 update - rangi you about?
02:10:36 * libsysguy pipes down
02:11:09 <wizzyrea> nah, if you want to talk about that you go ahead
02:11:22 <wajasu> if i migrate to koha-packages and i want ICU(or ICR whatever for the character choice), is that a manual adjustment?
02:11:25 <libsysguy> nah, its out there, if anybody cares to look at it, go for it
02:11:34 <jcamins> wajasu: yes, but right now we're in the middle of a meeting.
02:11:41 <wajasu> my bad
02:11:43 <mtompset> Nothing big... just if I get SAML 2.0 to work, we could get wider acceptance of Koha in the organization. :)
02:11:44 <wizzyrea> I think 3.8 and 3.10 are going along ok - I don't know if there's all that much to say about it
02:11:59 <wizzyrea> so on to Update about 3.12
02:12:12 <jcamins> Yes.
02:12:20 <jcamins> I sent out a timeline a few days ago.
02:12:23 <wizzyrea> I saw that the schedule was posted - jcamins do you have a link for the irc log?
02:12:37 <jcamins> I do not.
02:12:46 <thd> #info Thomas Dukleth, Agogme, New York City
02:12:47 <wizzyrea> ok, so how are you feeling about 3.12
02:12:50 <jcamins> (looking now)
02:12:57 <wizzyrea> you talk, I'll look ;)
02:12:59 <bag> and thank you jcamins - nice to have it some what more clear :)
02:13:02 <jcamins> Thanks.
02:13:22 <jcamins> Well, on the one hand, lots of great things are going into 3.12.
02:13:35 <bag> also give the french hackfest an idea of things to tackle
02:13:42 <jcamins> And it's pretty stable for a release at this point in the cycle.
02:13:49 <jcamins> However, we have a *massive* backlog of patches.
02:14:08 <wizzyrea> #link http://lists.koha-community.org/pipermail/koha-devel/2013-February/038846.html
02:14:09 <jcamins> As of right now, I would say that at least 50% of the outstanding enhancements have no chance of getting into 3.12.
02:14:23 <jcamins> We have...
02:14:32 <jcamins> 138 bugs awaiting sign off.
02:14:39 <mtompset> 50%?! :(
02:14:45 <jcamins> 129 bugs awaiting QA.
02:14:48 <jcamins> mtompset: at least.
02:14:57 <jcamins> Of those, the majority are enhancements.
02:15:16 <jcamins> Bug fixes naturally need to receive priority, but I would _really_ like to see more of the good code we have go into 3.12.
02:15:35 <thd> Could you not delegate some of the task to allow the backlog to be managed?
02:15:36 <dcook> Random question for rangi or anyone else who might know...
02:15:37 <wizzyrea> sounds like it's time for a pep talk :)
02:15:43 <wizzyrea> dcook - meeting
02:15:44 <jcamins> thd: no, because it's not my backlog.
02:15:51 <jcamins> We need people to test.
02:15:58 <wizzyrea> and very good test plans
02:16:01 <jcamins> If people don't test, the code doesn't go in.
02:16:23 <jcamins> For 3.14 it might be a good idea to have a larger QA team.
02:16:26 <jcamins> But for 3.12 we don't have that.
02:16:32 <thd> That bottleneck should be in principle easier to solve than a RM backlog.
02:16:45 <jcamins> thd: yes, and I look forward to seeing the situation improve.
02:17:07 <jcamins> However, as the feature freeze approaches, it will be too late.
02:17:22 <wizzyrea> so the moral is, if you submit a patch, test one too, sign off if you can, mark it if you can't
02:17:34 <jcamins> There are only 168 hours a week, and I can't spend more than half of them on RM work.
02:17:49 <jcamins> As a reminder, new developments written during the hackfest will be held for 3.14.
02:18:01 <jcamins> And that's the status.
02:18:09 <jcamins> Any questions?
02:18:30 <jcamins> #info Everyone needs to test.
02:18:34 <mtompset> How could we solve the 50% problem now?
02:18:35 <jcamins> #info Test plans are NOT OPTIONAL.
02:18:40 <wizzyrea> test patches
02:18:44 <thd> What is the status of work on a boot system from which a new patch could be tested?
02:18:57 <jcamins> thd: it exists, the problem is *not* technical.
02:19:05 <jcamins> mtompset: every developer should test at least one patch.
02:19:05 <cjh> jcamins: is the bottleneck more of a qa or sign-off thing?
02:19:12 <dcook> #info David Cook, Sydney, Australia
02:19:15 <wizzyrea> both, at the moment
02:19:17 <libsysguy> based on the numbers I'd say half and half
02:19:18 <gmcharlt> #info write your patches to be easy to test -- e.g., separate whitespace changes into their own patches, include POD, and repeat, include test cases
02:19:33 <jcamins> cjh: the bottleneck is worse at QA, thanks to the reduced number of QAers, but only barely.
02:19:35 <thd> Actually, bootable is too high a barrier of entry.
02:19:58 <jcamins> thd: I look forward to seeing a an improved sandbox implementation.
02:20:00 <wizzyrea> if you have a good test plans (possibly even instructions on how to get your data into a testable state) it really, really helps
02:20:57 <jcamins> Anything else?
02:20:58 <wahanui> Anything else is a guess
02:21:13 <bag> HA
02:21:44 <wizzyrea> Righto then, I realize I haven't been marking the agenda items - gmcharlt how does one do that (an example would be fine)
02:22:01 <gmcharlt> wizzyrea: do #topic FOO
02:22:11 <wizzyrea> #topic Kohacon2013
02:22:15 <wizzyrea> whee!
02:22:28 <nancyk> #info Contract with the hotel signing this week.
02:22:34 <jcamins> Hooray!
02:22:37 <wizzyrea> right, so nancyk,
02:22:46 <wizzyrea> excellent
02:22:54 <nancyk> will be settting up registration and other info
02:23:12 <wizzyrea> is there anything you need help on from the global community?
02:23:25 <nancyk> #info a generous vendor has promised to sponsor
02:23:56 <nancyk> #info suggestions are always welcome
02:24:13 <nancyk> that's it for now
02:24:19 <wizzyrea> very cool - sounds like you've got it in hand. Any questions for nancyk?
02:24:34 <JDatTeTakere> I have a general question about Koha cons
02:24:39 <wizzyrea> go for it
02:24:48 <JDatTeTakere> What level of Koha user is the hackfest for?
02:24:53 <bag> any upcoming timeline?  like proposals due for talks?  or anything like that
02:25:14 <nancyk> not yet, but soon
02:25:19 * dcook has the same question as JDatTeTakere
02:25:28 <bag> JDatTeTakere: any level is more than welcome
02:25:29 <wizzyrea> my experience says "every level"
02:25:41 <dcook> To go off that, what's the purpose of the con?
02:25:42 <nancyk> #info we have an iRC meeting on the 19th
02:25:49 <JDatTeTakere> Awesome - thank you. Looking forward to my first KohaCon
02:25:50 <wizzyrea> it's really helpful to have users around when designing things
02:26:00 <dcook> While I already have some support for sending me over, I'd like to know what to expect to gain/contribute to it
02:26:14 <libsysguy> indeed, not everyone needs to know how to modify the marc editor :)
02:26:29 * libsysguy shudders
02:26:30 <thd> JDatTeTakere: With free software every user at any level should be a developer.
02:27:00 <wizzyrea> @quote add thd: With free software every user at any level should be a developer
02:27:00 <huginn> wizzyrea: Error: You must be registered to use this command. If you are already registered, you must either identify (using the identify command) or add a hostmask matching your current hostmask (using the "hostmask add" command).
02:27:01 <JDatTeTakere> Thanks everyone...looking forward to meeting some of you in real life
02:27:11 <nancyk> Iwant to know how to become a tester
02:27:23 <wizzyrea> yep, bring it up at the hackfest :)
02:27:27 <jcamins> nancyk: excellent!
02:27:28 <bag> nancyk++
02:27:31 <wizzyrea> right so -
02:27:36 <JDatTeTakere> Me too...re: tester
02:27:39 <jcamins> nancyk: after the meeting I'll walk you through it.
02:27:43 <jcamins> JDatTeTakere: you too.
02:27:43 <wizzyrea> #topic Roles for 3.14 (code name PI)
02:27:44 <jcamins> :)
02:28:05 <libsysguy> we're calling it PI !!
02:28:06 <libsysguy> excellent
02:28:17 <wizzyrea> no, that's just me. You can feel free to adopt that.
02:28:20 <mtompset> Does that mean 15 minor releases? ;)
02:28:30 <gmcharlt> or a big tiger release
02:28:37 <wizzyrea> ha
02:28:44 <bag> Well I've got a thought here and an idea - I'd like to bounce off all of you
02:28:46 <wizzyrea> right, so roles
02:28:51 <wizzyrea> bag, please go ahead
02:29:02 <bag> libsysguy, khall and I - as a three headed monster for RM
02:29:16 <jcamins> A three-person RM team?
02:29:29 <bag> between the three of us we can split up time and duties - with RM and some QA etc...
02:29:50 <wizzyrea> well I think you are perfectly within your rights to put out a proposal for that setup
02:29:56 <bag> yes we work closely everyday as a group - so it wouldn't be anything new to us
02:30:08 <bag> so I'm asking crazy or not?
02:30:17 <jcamins> bag: crazy.
02:30:24 <wizzyrea> I think I'd need to see a formalised proposal.
02:30:26 <jcamins> The coordination will drive you to an early grave.
02:30:33 <cjh> ^^ my concerns.
02:30:40 <mtompset> Dito.
02:30:44 <libsysguy> I don't think diving up the time would be a bad idea
02:30:45 <libsysguy> but
02:30:54 <libsysguy> I have never been in the position before
02:31:02 <libsysguy> so I don't want to go grey at 24 :p
02:31:30 * gmcharlt would suggest increasing the numbers of the QA team first
02:31:35 <wizzyrea> *nod*
02:31:38 <khall> Could you explain the coordination issues
02:31:52 <dcook> What does it take to be on the QA team?
02:32:02 <cjh> the idea of an 'RM mentoring program' does sound interesting though
02:32:03 <dcook> Not that I'm nominating myself at the moment, but I'm curious.
02:32:04 <bag> dcook: volunteering
02:32:10 <jcamins> dcook: a willingness to test thoroughly and offer useful feedback.
02:32:19 <dcook> Willingness and ability are one thing
02:32:25 <dcook> Are tests all automated or is a certain level of knowledge required?
02:32:28 <wizzyrea> perhaps a good understanding of the style rules that govern us
02:32:33 <dcook> Or is this still where testing plans come in ?
02:32:36 <jcamins> A certain level of knowledge, but you'll learn. :)
02:32:39 * libsysguy would like to automate test
02:32:51 <bag> libsysguy++
02:33:06 <khall> Testing plans are more for sign offs
02:33:18 <libsysguy> jcamins has a step in the right direction with the requisite of unit tests for all backend code
02:33:23 <thd> dcook: If the code could be self validating there would be no need for QA people.
02:33:31 <cjh> as qa you will have to read some code, mostly checking for style conformance. The tests are automated, but if they fail it can help to know if it is you or the patch that is causing this.
02:33:38 <JDatTeTakere> I'm happy to put my hand up for something...not sure whether it's testing or QA or something else.
02:33:56 <jcamins> khall: as an example, look at bug 9239.
02:33:57 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9239 enhancement, P5 - low, ---, jcamins, Passed QA , Koha should share Evergreen's QueryParser module for parsing queries
02:34:17 <khall> A sign off says the feature works, a qa says the feature doesn't break anything
02:34:18 <libsysguy> ah carp
02:34:23 <jcamins> It actually failed QA and then was marked "passed" by someone else.
02:34:26 <jcamins> libsysguy: sorry to pick on you.
02:34:29 <khall> In general
02:34:29 <libsysguy> its cool
02:34:32 <libsysguy> I owned that one
02:34:43 * druthb picks on libsysguy all the time; he's used to it.
02:34:44 * libsysguy knew that would come back to bite me
02:34:58 <cjh> khall: qa also means that the feature is conforming to the project guidelines (style, testing, etc.)
02:35:00 <mtompset> mistakes always do, libsysguy. Don't feel bad. :)
02:35:28 <khall> Cjh, absolutely!
02:36:26 <dcook> I'm encouraged by jcamins's faith ;)
02:36:30 <wizzyrea> I feel the need to note that if the 3 person Rteam were installed, ByWater would have docmanager, translation manager, and RM all at the same time
02:36:39 <jcamins> wizzyrea: that's a good point.
02:37:07 <dcook> I'm still trying to get back into a stable work routine at the moment, but I would be willing to learn more about being on the QA team. If nothing else, I could take on a lot of the little signed off patches that would free up the bigger QA guns
02:37:08 <bag> no worries I just didn't see anyone else offering up - and I know jcamins doesn't want to do another round
02:37:20 <jcamins> bag: if necessary, I'll do it again.
02:37:33 <dcook> Hmm, what's involved with docmanager?
02:37:41 <libsysguy> nengard
02:37:42 <wizzyrea> keeping the manual up to date
02:37:45 * dcook has been thinking about doing some work on the documentation
02:37:46 <libsysguy> oh waht not who
02:37:51 <wizzyrea> keeping the online help up to date
02:38:06 <bag> we also need RMaint's etc
02:38:16 <dcook> I was thinking of actually shooting Nicole an email about collaborating on the manual if nothing else
02:38:27 <jcamins> dcook++
02:38:34 <kathryn> http://wiki.koha-community.org/wiki/I_want_to_help <-- of interest?
02:38:35 <druthb> dcook++
02:38:37 <cjh> dcook++ awesome
02:38:38 <wizzyrea> yes I am sure nicole would be happy to share
02:38:45 <wizzyrea> repsonsibility on that
02:38:46 <jcamins> Speaking as the current RM, I'd encourage everyone who wants to RM try RMainting first.
02:38:49 <bag> I think rangi would perfer more time signing off on things than Rmaint-ing (but he speaks for himself better than I do )
02:38:49 <jcamins> It's good practice.
02:38:50 <wizzyrea> ^^
02:39:04 * gmcharlt is considering a prposal for RM or an RMaint ... and I also have some ideas on potential ways to spread the load
02:39:20 <wizzyrea> right so - What I think we are wanting
02:39:43 <jcamins> Concrete proposals?
02:40:08 <gmcharlt> jcamins: yes, but I'll need to cogitate a bit
02:40:15 <wizzyrea> is if you are interested - do up a proposal for what you want to accomplish as RM - simply as an example http://wiki.koha-community.org/wiki/Katrin%27s_Proposal_for_QAM_3.12 and http://wiki.koha-community.org/wiki/Jcamins_Proposal_for_RM-3.12
02:41:06 <druthb> On the less-contentious side of things, I've been learning the TM role, and have had some lovely help from cait and tcohen in particular.  If no one else wants it, I'll continue.
02:41:09 <wizzyrea> #action interested parties should submit their proposals for release team duties to the wiki, and mail the link to the devel list
02:41:32 <wizzyrea> those who want to stay on I think simply need to state that
02:41:51 <wizzyrea> and if you concretely want out of a role, please say and we will actively try to find someone to relieve you
02:41:51 <bag> probably vote next meeting?
02:41:56 <jcamins> bag: two meetings, I think.
02:41:59 <wizzyrea> that was the plan I believe
02:42:05 <wizzyrea> oh, what he said
02:42:38 <wizzyrea> #info vote for release team is in two meetings time
02:43:07 <dcook> I thought that said two minutes...
02:43:09 * dcook facepalm
02:43:24 <wizzyrea> Right, any more discussion needed on Roles for Pi?
02:43:45 <wizzyrea> All righty then
02:43:55 <wizzyrea> #topic actions from 9 Jan meeting
02:43:58 <dcook> Quick question on roles
02:44:07 <wizzyrea> shoot
02:44:40 <dcook> Do they just go under the Participation category on the wiki? Seems like a Proposal category/sub-category might be an idea, so it's not filing by the page title
02:45:07 <wizzyrea> sure, it's a wiki you can categorise however you want to :)
02:45:17 <dcook> Hehe. Noted.
02:45:50 <wizzyrea> so right, Actions from last meeting - looks like we have made some progress with bugzilla cleaning
02:46:54 <wizzyrea> Does anyone have any idea what magnus has been up to with the dev handbook?
02:47:05 <wizzyrea> any progress to report?
02:47:19 <jcamins> I do not know.
02:47:28 <wizzyrea> righty o then
02:47:32 <wizzyrea> that brings us to
02:47:41 <wizzyrea> #topic set time and date for next meeting
02:47:48 <wizzyrea> this is the part I am very bad at.
02:47:59 <thd> Wiki categories are extensible and you can extend them as needed.
02:48:10 <jcamins> 18:00UTC.
02:48:16 <wizzyrea> dcook - thd is quite adept with the wiki
02:48:16 <jcamins> Second Wednesday.
02:48:42 <wizzyrea> that's gonna be 13 Mar. 18:00 UTC
02:48:47 <dcook> Hmm
02:48:58 <jcamins> Sure.
02:49:07 <wizzyrea> 2013, future dwellers.
02:49:30 <jcamins> +1
02:49:37 <gmcharlt> +1
02:49:38 <jwagner> +1
02:49:46 <druthb> +1
02:49:47 <thd> +1
02:49:48 <dcook> I won't disagree but I'm not going to be up at 5am
02:49:59 <JDatTeTakere> +1
02:50:00 <cjh> +1
02:50:00 <wizzyrea> #info Next meeting time 13 March 2013, 18:00 UTC
02:50:11 <davidnind> +1
02:50:20 <khall> +1
02:50:23 <wizzyrea> Thank you friends for a most excellent meeting - anything else before we wrap this up?
02:50:40 <thd> That is actually Wednesday UTC next time.
02:50:42 <dcook> I did have a question before about Kohacon
02:50:55 <bag> +1
02:51:04 <nancyk> I'm still here
02:51:17 <dcook> Well, it's a generic question. What is the purpose of Koha con?
02:51:36 <dcook> Discussing the future? Success stories of the present? All the above? None of the above?
02:51:44 <wizzyrea> it's a global gathering of koha users and developers for the enrichment of all of them
02:51:45 <druthb> All the above, and more.
02:51:56 <nancyk> Training, sharing, mentoring, planning , working
02:52:03 <dcook> Mmmm
02:52:08 <dcook> Excellent. Thank you for all your answers :)
02:52:09 <druthb> Socializin', sticking faces with names, at last...
02:52:09 * thd races to the market before closing
02:52:17 <wizzyrea> later thd
02:52:20 <wizzyrea> #endmeeting