18:05:20 <gmcharlt> #startmeeting Koha General Meeting, 5 June 2013
18:05:20 <huginn`> Meeting started Wed Jun  5 18:05:20 2013 UTC.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:05:20 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:05:20 <huginn`> The meeting name has been set to 'koha_general_meeting__5_june_2013'
18:05:28 <gmcharlt> #info agenda is http://wiki.koha-community.org/wiki/General_IRC_meeting,_5_June_2013
18:05:39 <gmcharlt> #topic Introductions
18:05:39 <wahanui> #info wahanui, a bot that has become sentient
18:06:02 <gmcharlt> #info Galen Charlton, Equinox Software, 3.14 RM
18:06:10 <thd> #info Thomas Dukleth, Agogme, New York City
18:06:13 <nancyk> #info nancyk  Washoe County Library System KohaCon13 Chair
18:06:28 <tcohen> #info Tomás Cohen Arazi, Universidad Nacional de Córdoba, Argentina
18:06:33 <jwagner> #info Jane Wagner, LibLime/PTFS
18:06:40 <oleonard> #info Owen Leonard, Athens County Public Libraries
18:06:44 <JDatTeTakere> info#Joanne Dillon (JD) at TeTakere, Levin, NZ
18:06:49 <jcamins> #info Jared Camins-Esakov, C & P Bibliography Services, and (past) RM for 3.12
18:06:50 <mduncan> #info Margo Duncan, University of Texas at Tyler, Muntz Library
18:06:58 <pianohacker> #info Jesse Weaver, ByWater Solutions
18:07:07 <drojf> #info Mirko Tietgen, Berlin
18:07:12 <davidnind> #info David Nind, Wellington, New Zealand
18:08:18 <gmcharlt> ko
18:08:20 <gmcharlt> ok
18:08:30 <gmcharlt> #topic Announcements
18:08:52 <cait> #info Katrin Fischer, BSZ
18:08:53 <gmcharlt> two minutes for folks to chime in with Koha-related annoucnements
18:09:05 <jcamins> #info 3.12.0 was released on May 19
18:09:06 <edveal> #info Ed Veal, ByWater
18:09:51 <cait> jcamins++ :)
18:10:19 <gmcharlt> jcamins++
18:10:52 <gmcharlt> #topic Update on Koha 3.8
18:11:19 <mtompset> #info Mark Tompsett, Canada
18:11:19 <gmcharlt> #info Koha 3.8.13 was released on 2013-05-23
18:11:46 <Brooke> thanks folks that contributed we <3 you
18:11:57 <rhcl> #info rhcl = Greg Lawson, Rolling Hills Consolidated Library (I'm just here to watch the big dogs)
18:12:20 <gmcharlt> 3.8.13 was rangi's last release as 3.8 RMaint
18:12:22 <gmcharlt> rangi++
18:12:34 <tcohen> UNC <3 3.8.x and rangis' work
18:12:36 <tcohen> rangi++
18:12:45 <cait> rangi++ :)
18:12:54 <gmcharlt> cjh is now the current 3.8 RMaint
18:13:20 <gmcharlt> looks like his nick is idling, so I'll move on
18:13:31 <gmcharlt> #topic Update on Koha 3.10
18:13:53 <gmcharlt> #info Koha 3.10.6 was released on 2013-05-23
18:14:12 <gmcharlt> 3.10.6 was rangi's last release as 3.10 RMaint
18:14:19 <gmcharlt> rangi++ # I'm sensing a pattern here
18:14:30 <cait> rangi++ :) no surprise
18:14:56 <gmcharlt> and bgkriegel is the current RMaint for 3.10
18:15:02 <gmcharlt> and is not here, so...
18:15:07 <mtompset> rangi++
18:15:08 <gmcharlt> #topic Update on Koha 3.12
18:15:09 <tcohen> wait
18:15:23 <gmcharlt> hmm?
18:15:56 <tcohen> bug 10367 was pushed by eythian during packages build
18:15:57 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10367 enhancement, P5 - low, ---, robin, Pushed to Stable , Allow packages to work on debian wheezy
18:15:58 <tcohen> post-release
18:16:07 <tcohen> for both 3.10 and 3.12
18:16:24 <tcohen> to support debian wheezy
18:16:35 <tcohen> just wanted to note that
18:17:16 <gmcharlt> #info 3.12.0 was released on 2013-05-19
18:17:21 <gmcharlt> jcamins: any parting comments?
18:17:33 <jcamins> I don't think so.
18:17:42 <jcamins> I think we came together to produce a nice, stable release.
18:17:45 <jcamins> And, well done all.
18:17:47 <tcohen> jcamins++
18:17:54 <gmcharlt> jcamins++
18:17:56 <oleonard> all++
18:18:15 <cait> jcamins++ :)
18:18:24 <gmcharlt> tcohen: any comments regarding the upcoming 3.12.1?
18:18:49 <mtompset> nice PDF release notes. :)
18:18:53 <mtompset> jcamins++
18:19:08 <bag> #info Brendan Gallagher, ByWater
18:19:09 <tcohen> 3.no comments now
18:19:36 <tcohen> sorry
18:19:42 <gmcharlt> no problem
18:19:43 <tcohen> I want to say I'll do my best
18:19:45 <gmcharlt> moving on
18:19:54 <gmcharlt> #topic Update on Koha 3.14
18:20:04 <gmcharlt> #info gmcharlt has started pushing patches
18:20:08 <cait> yay!
18:20:09 <drojf> are we there yet?
18:20:25 <gmcharlt> #info biggest one so far is one implementing a course reserves feature
18:21:09 <gmcharlt> #info We need more folks testing and signing off on patches
18:21:49 * cait agrees with gmcharlt
18:22:07 <cait> and please if you can run the test suite
18:22:20 <cait> and take a look at the coding guidelines :)
18:22:39 <gmcharlt> #info gmcharlt will be starting conversations with the folks who thus far have expressed interest in being module maintainers
18:23:08 <gmcharlt> any questions?
18:23:40 <tcohen> how many module mantainers have postulated?
18:23:59 <gmcharlt> I think two, maybe three people have expressed interest
18:24:03 <cait> could you summarize quickly what the task of the module maintainers will be?
18:24:22 <gmcharlt> yes
18:24:44 <gmcharlt> a module maintainer would be somebody who is expert in a module and who takes responsibility for maintaining a tree of vetted patches related to that module
18:25:08 <gmcharlt> and (ideally) who also takes some responsibility for wrangling bugs related to that module
18:25:17 <gmcharlt> as well as doing QA for that module
18:25:43 <oleonard> "maintaining a tree of vetted patches?"
18:25:49 <gmcharlt> my idea is ultimately that the RM would be able to start pulling branches from the module maintainer's trees
18:25:52 <cait> same question here
18:26:24 <gmcharlt> rather than focusing on each and every bug that passes QA
18:26:39 <tcohen> a benevolent dictator
18:26:54 <gmcharlt> and even longer-term goal, depending on how things work out, is that module maintainers would get the ability to push directly to master for patches related to their modules
18:27:08 <pianohacker> gmcharlt: linux-ish setup?
18:27:37 <gmcharlt> pianohacker: yes
18:27:54 <Brooke> gmcharlt++
18:27:55 <pianohacker> sounds like a good plan
18:28:06 <gmcharlt> a good experiment, I hope, at least
18:28:52 <tcohen> gmcharlt++
18:29:18 <pianohacker> gmcharlt: is there any listing/volunteer page for module maintainers?
18:29:38 <gmcharlt> pianohacker: not yet; I'll need to trawl through the list archives
18:29:44 <gmcharlt> to set one up
18:29:55 <gmcharlt> folks who are intersted can also contact me directly, of course
18:29:56 <pianohacker> okay, just curious
18:30:26 <gmcharlt> any other questions regarding 3.14?
18:31:25 <tweetbot> [off] twitter: @kohails: "#KohaILS  Refonte complète du site de Pikoloco http://t.co/sG2tKik0du"
18:31:40 <tcohen> no quesitons here
18:31:46 <gmcharlt> ok, moving on
18:31:49 <gmcharlt> #topic KohaCon 2013
18:31:57 <nancyk> Koha reservation page has been fixed, thanks to Liz
18:32:14 <nancyk> Call for sponsors is going out later today, as are presentation confirmations
18:32:21 <cait> nancyk++
18:32:31 <nancyk> Digital flier inviting people to the conference will be out next week
18:33:00 <nancyk> Anyone have any questions or suggestions?
18:33:06 <gmcharlt> #info Koha reservation page has been fixed, thanks to Liz;  Call for sponsors is going out later today, as are presentation confirmations; Digital flier inviting people to the conference will be out next week;
18:33:25 <thd> To whom is the digital flier being sent?
18:33:36 <cait> nancyk: thx for all your work, really looking forward to kohacon :)
18:34:01 <nancyk> thanks
18:34:18 <nancyk> Fliers will go to library groups, and anywhere I can get them
18:34:31 <tcohen> nancyk: how is the room reservation count going? did we reach the goal?
18:34:44 <nancyk> Things are moving along very well
18:35:12 <nancyk> We have 64 registered, but not at the hotel yet
18:35:36 <nancyk> Some are waiting for their fiscal year to turn over
18:35:53 <nancyk> that's all for now
18:36:04 <gmcharlt> nancyk++
18:36:15 <cait> nancyk++
18:36:29 <tcohen> nancyk++
18:36:30 <thd> nancyk: What address can be used to confirm registrations?
18:37:13 <nancyk> I am sending them out personally, so everyone should have one as of today.  Use my email for probs
18:37:27 <nancyk> nkeener@washoecounty.us
18:37:56 <gmcharlt> #topic KohaCon 2014
18:38:20 <gmcharlt> on the agenda there's a question about whether we've sent out a call for potential host sites
18:38:42 <gmcharlt> I don't think it has, so who wants to volunteer to put out a call for proposals to host KohaCon in 2014?
18:40:00 <drojf> i can do that. probably not today but in the next days#
18:40:21 <gmcharlt> #action drojf will put out a call for proposals to host KohaCon in 2014
18:40:43 <cait> drojf++
18:40:47 <gmcharlt> moving on
18:40:56 <gmcharlt> #topic Version numbering
18:41:04 <gmcharlt> does anybody wish to adopt this agenda item?
18:42:00 <pianohacker> everyone has an opinion, nobody wants to take responsibility for starting the discussion
18:42:08 <thd> I just want the question to be clear.
18:42:21 <oleonard> http://wiki.koha-community.org/wiki/General_IRC_meeting,_5_June_2013
18:43:06 <oleonard> If no one wants to raise the issue and advocate the position I suggest we move on.
18:43:15 <thd> pianohacker: The discussion has been had at more length than many thought worthwhile.
18:43:42 <pianohacker> thd: Yeah, that was my understanding. Bikeshedded
18:43:51 <cait> so can we move on? :)
18:43:56 <pianohacker> yup, vote to move on
18:44:08 <gmcharlt> admittedly, this only delays the question -- but I suggest that version number questions be restricted to the period when roles for the next release are being considered
18:44:15 <thd> oleonard: If we move on then how has the issue been settled or has the issue been dropped?
18:44:43 <oleonard> thd: With no one here to advocate for a change there is no reason to discuss it
18:45:02 <drojf> thd: put it on the agenda for another meeting and it is back. i guess
18:45:08 <pianohacker> so dropped, with the release after pi continuing the trend and being 3.16
18:45:38 <cait> we are going to have 3.14 (codename pi)
18:45:42 <jcamins> pianohacker: or, more precisely, dropped and no decision made. There has been no solid proposal, just a lot of paint.
18:45:45 <gmcharlt> pianohacker: I'd say the question is dropped for now, with the question of how to number the next release after 3.14 to be decided during the election period
18:46:06 <pianohacker> gmcharlt: Sounds good, let's throw that on the minutes
18:46:11 <tcohen> +1 # gmcharlt's proposal
18:46:30 <cait> +1
18:46:35 <thd> oleonard: As posted on the wiki agenda the issue was only to vote on a question which had already been discussed at length already on the mailing list.
18:47:00 <oleonard> +1 # gmcharlt's proposal
18:47:40 <thd> +1 # gmcharlt postponing the dullest question ever
18:47:59 <gmcharlt> #agreed Any decision on the question of how to number the version of Koha following 3.14 is deferred to the project role election period
18:49:02 <gmcharlt> #topic Action items from the 7 May 2013 meeting
18:49:16 <gmcharlt> #info ifrst action item is Test all the things!
18:49:22 <gmcharlt> so, have all the things been tested?
18:49:37 <gmcharlt> no?
18:49:38 <wahanui> http://i.imgur.com/hVVuP.jpg
18:49:41 * cait reports that more testing is needed
18:49:47 <gmcharlt> cait++
18:50:26 <cait> Test all the things!
18:50:53 <tcohen> test coverage should be improved
18:51:03 <gmcharlt> there was also an action item for BobB to test reserves
18:51:07 <gmcharlt> BobB: anything to report?
18:52:09 <cait> hm wrong time I think
18:52:17 <gmcharlt> yep
18:52:20 <gmcharlt> so moving on
18:52:29 <gmcharlt> #topic Decide time of next meeting
18:53:20 <gmcharlt> going by our normal cycle, I think that would be Wednesday, 3 July 2013
18:53:21 <davidnind> Time for next meeting would be 10:00 UTC
18:53:30 <tcohen> is there a kohacon13 planning meeting soon?
18:53:47 <thd> Wed 3 is too soon after ALA
18:54:14 <nancyk> 26th of june 18UTC for KohaCon 13 planning
18:54:49 <thd> I suggest Wed. 10 July.
18:55:08 <gmcharlt> #info Next KohaCon 13 planning meeting is on 26 June 2013 at 18UTC
18:55:13 <oleonard> Either is fine with me, I don't object to the 10th.
18:55:24 <gmcharlt> ditto
18:56:04 <gmcharlt> OK, so +1/-1 for Wednesday, 10 July 2013 at 10:00 UTC+0 ?
18:56:28 <tcohen> +1
18:56:35 <oleonard> +1
18:56:40 <cait> +1
18:56:41 <thd> +1
18:56:42 <davidnind> +1
18:56:46 <drojf> +1
18:56:52 <mtompset> +1
18:57:01 <JDatTeTakere> +1
18:57:13 <gmcharlt> #agreed Next general meeting wlll be held on Wednesday, 10 July 2013 at 10:00 UTC+0
18:57:33 <gmcharlt> and ... we've run out of agenda items!
18:57:38 <tcohen> do we have a calendar@google for koha stufF?
18:58:11 <mtompset> I'm assuming to help co-ordinate various meetings, right, tcohen?
18:58:20 <thd> tcohen: If we did that would not be a free software calendar.
18:58:53 * tcohen hides
18:59:08 <tcohen> I belive we could have such a tool, maybe a hosted one
18:59:12 <mtompset> If the purpose it to co-ordinate meetings, it wouldn't have to be google. The point is a generally shared calendar.
18:59:22 <tcohen> nevermind,if I come up with a proposal, I'll make it
18:59:25 <drojf> do whatever you like on google, don't make it in any way obligatory for me to use it
18:59:26 <gmcharlt> I agree that some sort of calendar would be nice
18:59:34 <thd> tcohen: I would suggest creating a comprehensive calendar page at wiki.koha-community.org instead.
18:59:39 <oleonard> MediaWiki plugin?
18:59:50 <gmcharlt> tcohen: perhaps talk with wizzyrea?
18:59:55 <tcohen> i'll do it
19:00:01 <tcohen> touche drojf
19:00:03 <cait> i think we have a calendar on the kc-website
19:00:10 <cait> we just don't use it very often
19:00:19 <drojf> heh
19:00:22 <gmcharlt> cait: yeah, I vaguely remember that
19:00:24 <gmcharlt> :/
19:00:43 <gmcharlt> OK, thanks folks!
19:00:46 <gmcharlt> #endmeeting