10:06:34 <wizzyrea> #startmeeting Koha IRC meeting 10-7-13
10:06:34 <huginn`> Meeting started Wed Jul 10 10:06:34 2013 UTC.  The chair is wizzyrea. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:06:34 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:06:34 <huginn`> The meeting name has been set to 'koha_irc_meeting_10_7_13'
10:06:46 <kf> wizzyrea: thx :)
10:06:47 <wizzyrea> #topic introductions
10:06:47 <wahanui> #info wahanui, a bot that has become sentient
10:06:55 <wizzyrea> gogo
10:06:58 <kf> #info Katrin Fischer, BSZ Germany
10:07:10 <wizzyrea> #info Liz Rea, Catalyst IT
10:07:15 <jwagner> #info Jane Wagner, LibLime/PTFS
10:07:19 <oleonard> #info Owen Leonard, Athens County Public Libraries
10:07:20 <drojf> #info Mirko Tietgen, Berlin
10:07:25 <rangi> #info Chris Cormack, Catalyst IT
10:07:29 <BobB> #info Bob Birchall, Calyx, Australia
10:07:30 <eythian> #info Robin Sheat, Catalyst IT
10:07:34 <cjh> #info Chris Hall, Catalyst IT
10:07:49 <thd> #info Thomas Dukleth, Agogme, New York City (asleep)
10:08:04 <kf> lots of catalyst tonight :)
10:08:09 <wizzyrea> Alright, welcome everybody to the July edition of the Koha IRC community meeting
10:08:12 <wizzyrea> we'll start with
10:08:19 <wizzyrea> #topic Announcements
10:08:23 <wizzyrea> anybody got any?
10:09:07 <oleonard> If anyone hasn't heard, I'm working on a new theme for the OPAC
10:09:18 <wizzyrea> we are running a copy of oleonard's responsive bootstrap opac at responsive.mykoha.co.nz
10:09:23 <cjh> awesome
10:09:39 <kf> wizzyrea: can we send that to the maling list maybe?
10:09:55 <kf> wizzyrea: culd get more libraries involved in testing
10:09:56 <wizzyrea> not really sure about that kf
10:09:57 <oleonard> It's still a work-in-progress, but I'm interested in getting feedback
10:10:04 <thd> oleonard: Is that also fully resizeable with no commitment to particular screen size?
10:10:18 <wizzyrea> thd: you should check it
10:10:19 <oleonard> thd: Responsive, yes
10:10:20 <wizzyrea> ;)
10:10:25 <mtj> hi all
10:10:26 <mtj> #info Mason James, NZ
10:10:55 <wizzyrea> #action Liz will check about sending the responsive demo to the mailing list
10:11:04 <wizzyrea> other announcements?
10:11:19 <wizzyrea> Alrighty then, on to
10:11:24 <wizzyrea> #topic 3.8 update
10:11:29 <wizzyrea> cjh, over to you
10:11:35 <thd> oleonard: just making certain people who believe the world is exactly 960 pixels wide have not been creeping in the back door.
10:11:50 <mtj> #info http://wiki.koha-community.org/wiki/General_IRC_meeting,_10_July_2013
10:11:51 <cjh> Things have been very quiet since 3.8.14
10:12:29 <cjh> the problem we had with 3.8.14 regarding translations may have a fix, email from bgkriegel that I have to look into, so hopefully 3.8.15 will have some new translations :)
10:12:30 <wizzyrea> you planning a 15?
10:12:47 <kf> thd: I think oleonard has proven he is not one of those people
10:12:48 <wizzyrea> cool, so yes
10:13:07 <cjh> 3.10.x hasnt had any more patches since it's last release, so I will have to check bugzilla for that, the translations themselves might justify a 3.8.15.
10:13:53 <wizzyrea> #info 3.8.15, assuming that the translations are fixed, will be on schedule
10:14:22 <cjh> I think that is everything I have worth saying.
10:14:31 <kf> cjh++ :)
10:14:32 <wizzyrea> how are you feeling about retiring the 3.8 line?
10:15:13 <wizzyrea> or, how is *anyone* feeling about retiring the 3.8 line
10:15:31 <kf> hm i think we always said that we will maintain it as long as someone wants to maintain
10:15:32 <cjh> my thinking was that at the 3.14 release I wouldn't continue, so it depends if someone else wanted to carry it on.
10:15:57 <rangi> releases are always maintained as long as someone wants to maintain them
10:16:31 <drojf> will we have packages of older releases at some point?
10:16:40 <slef> #info MJ Ray, software.coop member, England
10:16:53 <wizzyrea> #info cjh thinks he will stop as maintainer for 3.8 after the Pi release
10:16:55 <rangi> drojf: hasnt happened yet
10:16:58 <kf> so i think if cjh is willing to continue until 3.14 that would be nice?
10:17:05 <eythian> drojf: if you want to build and maintain them :)
10:17:13 <drojf> eythian: i don't :)
10:17:31 <eythian> (or, there's sufficient call for them, which hasn't really happened)
10:17:41 <wizzyrea> cjh++, thanks for the update
10:17:44 <cjh> kf: that is the plan :)
10:17:52 <wizzyrea> #topic 3.10 update
10:18:40 <kf> :)
10:18:53 <cjh> I don't think Bernardo is here
10:19:04 <wizzyrea> I think the maintainer is not around - my knowledge of it is that releases are continuing on schedule
10:19:18 <wizzyrea> soo
10:19:26 <wizzyrea> #topic 3.12 update
10:19:35 <wizzyrea> is tcohen about?
10:19:59 <kf> hm might be a little early for him not sure
10:20:13 <wizzyrea> also not, so the same update there as well - releases are continuing on schedule.
10:20:30 <wizzyrea> does anyone have anything they would like to bring up for posterity regarding 3.10 or 3.12 at this time?
10:20:49 <eythian> oh one thing
10:20:50 <wahanui> i think one thing is sure there is no  AllowIssuingForPatronsWithOverdues in C4/Members.pm in the untarred source tree of koha-3.02.01.tar.gz
10:20:50 <kf> tcohen++ bgkriegel++? :)
10:21:15 <oleonard> Hush wahanui
10:21:20 <wizzyrea> continue, eythian :)
10:21:30 <eythian> a minor thing is that 3.12 has a new dependency, so the next release will require a dist-upgrade rather than a normal one.
10:21:43 <eythian> Just making sure it's documented somewhere.
10:21:58 <eythian> (this catches people out whenever it happens)
10:22:17 <wizzyrea> #info 3.12 has a new dependency, it will require a dist-upgrade instead of a normal upgrade for package users
10:22:30 <wizzyrea> cool, thanks eythian
10:22:38 <wizzyrea> speaking of, it's not in the agenda - but
10:22:51 <wizzyrea> #topic packaging update
10:22:53 <wizzyrea> anything to note really?
10:22:58 <cjh> heh
10:23:07 <wizzyrea> besides what is already noted? :P
10:23:12 <eythian> not really.
10:23:20 <wizzyrea> excellent. no news is good news.
10:23:20 <eythian> it's all fine.
10:23:39 <wizzyrea> right - so
10:23:48 <wizzyrea> #topic 3.14 update
10:23:50 <wizzyrea> gmcharlt?
10:23:50 <wahanui> rumour has it gmcharlt is an expert in all things library technology
10:23:58 <wizzyrea> well yes, but is he around?
10:24:03 <wizzyrea> I highly doubt it.
10:24:13 <kf> you know the ninja he is...
10:24:16 <wizzyrea> QA, would you like to say anything?
10:24:19 <kf> might just show up any second out of nowhere
10:24:36 <BobB> :)
10:24:42 <kf> hm i guess the usual: please people, keep testing and test well, sign off and write test plans
10:24:53 <kf> oh and also, try to go beyond the test plan of the developer
10:25:02 <kf> ask yourself what else might break and if the change makes sense
10:25:06 <drojf> i'm german, we follow orders
10:25:11 <kf> shush
10:25:13 <kf> :)
10:25:25 <wizzyrea> #info QA requests "please people, keep testing and test well, sign off and write test plans"
10:25:25 <cjh> kf++
10:25:36 <kf> so nothing new really ;)
10:25:41 <wizzyrea> #info and please try to go beyond the test plan of the developer
10:25:50 <kf> thx wizzyrea :)
10:26:03 <wizzyrea> #info ask yourself what else might break and if the change makes sense
10:26:19 <wizzyrea> How are the queues looking?
10:26:30 <kf> dashboard?
10:26:30 <wahanui> i heard dashboard was at http://dashboard.koha-community.org/
10:26:37 <kf> not too bad
10:26:43 <kf> i think we need someone lookig at unimarc patches
10:27:00 <wizzyrea> #action someone please look at unimarc patches. It's getting a little silly.
10:27:01 <kf> and we have some bigger patches going back and forth
10:27:10 <kf> hey, i didn't say that! :)
10:27:15 <wizzyrea> I did!
10:27:17 <wizzyrea> ;)
10:27:49 <wizzyrea> #info let the record show that it was wizzyrea who proclaimed the level of unimarc patches "silly," not kf
10:28:05 <kf> heh
10:28:31 <mtj> 'needs signoff' is quite high, atm
10:28:56 <rangi> nothing in there is very old to
10:28:58 <rangi> tho
10:29:17 <drojf> i think a lot goes in, a lot goes out
10:29:25 <wizzyrea> #info get busy signoffers! only about 3 months left! (ish)
10:29:34 <kf> oh wow true!
10:29:39 <mtj> thats a nice point chris :)
10:29:40 <wizzyrea> yea the turnover seems quite good lately
10:30:05 <wizzyrea> #info nothing in the signoff queue is all too old, so good work on that. Keep it up!
10:30:08 <drojf> we are a productive bunch of people ;)
10:30:26 <rangi> http://bugs.koha-community.org/BAM/index.php?s=Koha&p=Koha&c=
10:31:03 <wizzyrea> ok, if there's nothing else about 3.14 (code name Pi)
10:31:05 <wizzyrea> on to
10:31:10 <wizzyrea> #topic Kohacon13
10:31:11 <mtj> fwiw, 'needs signoff' was very low 3 months ago… such is progress :)
10:31:25 <wizzyrea> 3 months ago we released ^.^
10:31:43 <wizzyrea> updates on kohacon? how is the planning going?
10:32:24 <wizzyrea> hm seems no one is around who wants to talk about that eh
10:32:49 <wizzyrea> fair enough -
10:32:54 <BobB> I'll be coming.  We think (at the mo') that Irma may not this time.
10:33:19 <wizzyrea> yes, quick poll, how many in attendance are planning to go to Kohacon?
10:33:32 <BobB> +1
10:33:39 <thd> +1
10:33:44 <rangi> +1
10:33:46 <slef> 0
10:33:55 <drojf> 0
10:34:02 <kf> what are we voting?
10:34:05 <wizzyrea> 0 (lianza instead)
10:34:08 <kf> sorry, got distracted for a sec :)
10:34:10 <rangi> if we are going to kohacon
10:34:12 <wizzyrea> attendance to kohacon
10:34:13 <kf> +1!
10:34:34 * kf wants to mention the volunteers page
10:34:34 <kf> http://wiki.koha-community.org/wiki/KohaCon13_Volunteers
10:34:35 <eythian> 0
10:34:39 <cjh> 0
10:35:28 <oleonard> +1
10:35:32 <mtj> 0
10:35:44 <wizzyrea> cool, so a few in attendance are going, and it should be a good time :D
10:35:57 <wizzyrea> #topic Kohacon14
10:35:57 <kf> :)
10:36:01 <drojf> i said i'd send a mail to the list asking for proposals, which i did http://lists.katipo.co.nz/pipermail/koha/2013-June/036518.html
10:36:08 <drojf> i set up a wiki page for the proposals and we already got a first entry by tcohen and bgkriegel for kohacon in argentina http://wiki.koha-community.org/wiki/KohaCon2014_Proposals
10:36:12 <kf> I think we got one proposal from argentina
10:36:21 <wizzyrea> ah good someone who has something to talk about!
10:36:39 <kf> I think next step would be setting a date for the vote?
10:36:44 <kf> that might also trigger more proposals
10:36:55 <wizzyrea> when do you want to cut off the proposals?
10:37:03 <wizzyrea> no later than kohacon?
10:37:13 <wizzyrea> or a month in advance?
10:37:21 <drojf> i'd say around kohacon13
10:37:50 <wizzyrea> let's say have the vote a few weeks before Kohacon, so that the organisers can meet and hobnob
10:38:04 <drojf> a few weeks before kohacon is now :P
10:38:44 <wizzyrea> errr
10:38:47 <wizzyrea> it's in october :P
10:38:48 <drojf> so voting beginning of october?
10:39:00 <drojf> that is only a few weeks away ;)
10:39:01 <wizzyrea> yep, and submissions by mid september
10:39:02 <thd> wizzyrea. I think that drojf is correct meaning that you would be setting an impossible case.
10:39:43 <rangi> what?
10:40:00 <BobB> No, Sept is two months away.
10:40:00 <wizzyrea> kohacon14
10:40:07 <rangi> you cant really have the vote after october
10:40:25 <kf> i think another reminder to the list and begining of october/end of september
10:40:34 <rangi> that would make it impossible to actually organise a functional conference (or at least very very hard)
10:40:41 <kf> and make sure we get the voting mechanism and tool sorted way in advance
10:40:58 <wizzyrea> #info submissions due by 15 September, voting to commence first week of October
10:41:02 <drojf> i'd send another mail asking for proposals a little before next meeting so we can have a look at the outcome at the meeting
10:41:18 <wizzyrea> will you do that drojf?
10:41:22 <drojf> yes
10:41:25 <kf> drojf++ :)
10:41:37 <wizzyrea> #action drojf will send a reminder for people to get in their proposals by September 15
10:41:43 <BobB> Cook is out.  England 1-27 (for those who know what that means)
10:41:59 <wizzyrea> drojf++
10:42:12 <thd> If we have people giving attention to proposed venues at this time the case may not be impossible, otherwise Argentina would be chosen by default.
10:42:44 <rangi> im fine with taht
10:42:56 <wizzyrea> #topic Action items from last meeting
10:43:02 <rangi> its not like this is some new conference
10:43:13 <wizzyrea> we are still working diligently to "test all the things" so can put a tick next to that one
10:43:29 <wizzyrea> (but keep it up please and thank you)
10:43:53 <kf> :)
10:43:58 <wizzyrea> and drojf is again on the hook for kohacon emails :) but other than that, I think we are done here
10:44:03 <wizzyrea> #topic Anything else?
10:44:07 <kf> nope
10:44:18 <drojf> more cookies
10:44:37 <wizzyrea> Thank you all very much for your attention and commitment to the community, we will see you back here next month (if not before!)
10:44:51 <drojf> we should set a date ;)
10:44:58 <thd> :)
10:44:58 <kf> and a time
10:45:02 <wizzyrea> oh yes
10:45:11 <wizzyrea> #topic time and date of next meeting
10:45:35 <wizzyrea> someone who is good at calendars please help
10:45:41 <drojf> i think it's the uneuropean timeslot. 2UTC?
10:45:46 <kf> 7th?
10:45:46 <wahanui> i guess 7th is worth a try
10:45:59 <wizzyrea> 7 Aug, 2UTC?
10:46:15 * kf will be sleeping
10:46:20 * drojf too
10:46:51 <wizzyrea> #agreed Next meeting is 7 Aug, 2013, 0200 UTC
10:47:02 <wizzyrea> because no one stopped me to tell me otherwise
10:47:05 <thd> Would anyone objecgt to 14 Aug.?
10:47:16 <wizzyrea> mmm we usually do it first week
10:47:29 <drojf> unless brooke visits the opera
10:47:41 <wizzyrea> errr
10:47:44 <thd> Oh actually 2 UTC is not an obstacle for the first week.
10:47:48 <kf> i think shorter is better than longer
10:47:59 <kf> ok, have to go - bbl
10:48:07 <wizzyrea> ok, 7th is alright - all ok :)
10:48:08 <thd> +1 14 Aug. 2 UTC
10:48:16 <thd> +1 7 Aug. 2 UTC
10:48:25 <thd> s/14/7/
10:48:28 <wizzyrea> :)
10:48:29 <wizzyrea> gotya
10:48:42 <wizzyrea> Thank you all again, have a good $timeofday
10:48:49 <wizzyrea> #endmeeting