15:03:12 <cait> #startmeeting Dev IRC Meeting, part 1
15:03:12 <huginn> Meeting started Wed Apr 23 15:03:12 2014 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:12 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:12 <huginn> The meeting name has been set to 'dev_irc_meeting__part_1'
15:03:13 <tajoli> #info Zeno Tajoli, CINECA
15:03:25 <cait> #topic Introductions
15:03:26 <wahanui> #info wahanui, a bot that has become sentient
15:03:26 <marcelr> #info Marcel
15:03:31 <cait> please introduce yourself with #info
15:03:36 <JesseM> #info Jesse Maseto - ByWater
15:03:39 <tcohen> #info Tomas Cohen Arazi, Universidad Nacional de Cordoba
15:03:47 <talljoy> #info Joy Nelson - ByWater Solutions
15:03:50 <cait> #info Katrin Fischer, BSZ Germany
15:03:55 <ashimema> #info Martin Renvoize, PTFS Europe
15:04:03 <thd> #info Thomas Dukleth, Agogme, New York City
15:04:08 <tajoli> #info Zeno Tajoli, CINECA (Italy)
15:04:15 <bgkriegel> #info Bernardo Gonzalez Kriegel, UNCordoba
15:04:40 <cait> i wonder if the meeting bot allows a second chair?
15:04:48 <cait> if someone knows, please pm me
15:04:59 <cait> i'd like to start with the elections as a first item for today
15:05:12 <oleonard> #info Owen Leonard, Athens County Public Libraries
15:05:25 <ashimema> go for it cait..
15:05:36 <cait> #topic Elections - Release Team 3.18
15:05:50 <cait> #link http://wiki.koha-community.org/wiki/Roles_for_3.18
15:06:32 <cait> #chair ashimema
15:06:32 <huginn> Current chairs: ashimema cait
15:06:35 <cait> ah :)
15:06:39 <cait> just in case this takes longer ;)
15:06:45 <cait> or i fall off the free wifi
15:06:49 <cait> ok
15:07:08 <cait> we have different options here
15:07:33 <nengard> #info Nicole Engard, ByWater Solutions
15:07:36 <cait> vote on persons (p), roles (r) and the total release team (t)
15:07:41 <cait> can i get a qiuck preference?
15:07:42 <barton> #info Barton Chittenden, Bywater Solutions, Louisville KY, USA
15:07:58 <ashimema> I better find the agenda then, jsut in case ;)
15:08:02 <talljoy> roles
15:08:08 <cait> i linked the roles above, the agenda is here
15:08:09 <tajoli> roles
15:08:14 <ashimema> roles..
15:08:15 <jwagner> #info Jane Wagner, LibLime/PTFS
15:08:24 <Joubu> #info Jonathan Druart, BibLibre, France
15:08:27 <cait> #link http://wiki.koha-community.org/wiki/Development_IRC_meeting,_23_April_2014
15:09:03 <cait> ok :)
15:09:04 <cait> roles it is
15:09:12 <cait> so let's start with a vote on the most important role :)
15:09:19 <talljoy> QA
15:09:22 <talljoy> :-D
15:09:22 <cait> heh
15:09:24 <marcelr> :)
15:09:25 <cait> i was thinking RM :)
15:09:26 <tcohen> heh
15:09:36 <cait> #topic Vote on RM
15:09:38 <marcelr> +1 for tcohen
15:09:47 <ashimema> +1 for tcohen
15:09:48 <talljoy> +1
15:09:51 <oleonard> +1 for tcohen
15:09:54 <Joubu> +1
15:09:55 <cait> #info Candidate: Tomas Cohen Arazi
15:09:56 <cait> +1
15:09:58 <bgkriegel> +1
15:09:59 <rocio> #info Rocio Jordan ByWater Solutions
15:10:02 <cait> I am also going to add: gmcharlt: +1
15:10:02 <wahanui> okay, cait.
15:10:03 <nengard> +1 for tcohen
15:10:05 <JesseM> +1 for tcohen
15:10:12 <cait> the +1 for gmcharlts applies to all votes today :)
15:10:25 <thd> +1
15:10:30 <tajoli> +1 for tcohen
15:10:47 <bag_confcall> #info Brendan Gallagher ByWater
15:10:51 <bag_confcall> +1
15:10:52 <cait> #agreed Release manager for 3.18 is: Tomas Cohen Arazi (tcohen)
15:10:53 <mario> #info Mario Guilin ByWater Solutions
15:10:58 <thd> +1 tcohen
15:11:01 <cait> congratulations! :)
15:11:04 <nengard> congrats
15:11:11 <cait> tcohen++
15:11:14 <JesseM> congrats tcohen
15:11:26 <ashimema> you poor bugger tcohen..
15:11:31 <cait> #topic Vote on Release Maintainers
15:11:32 <nengard> heh
15:11:35 <chris_n> +1
15:11:37 <ashimema> sorry.. menna say congrats ;)
15:11:38 <tcohen> thanks for your support #koha
15:11:54 <cait> #info Candidates are: 3.16: Galen Charlton, 3.14 Fridolin Somers, 3.12 Kyle Hall
15:11:55 <tcohen> i know i'll do my best
15:11:56 <chris_n> #info Chris Nighswonger FBC
15:12:07 <marcelr> +1 for all three of them
15:12:10 <cait> please vote :)
15:12:12 <talljoy> +1
15:12:16 <chris_n> +1
15:12:17 <Joubu> +1
15:12:18 <nengard> +1 to all three
15:12:23 <JesseM> +1
15:12:24 <ashimema> +1 to all three
15:12:24 <cait> cait: +1, gmcharlt: +1
15:12:25 <oleonard> +1
15:12:25 <tcohen> +1
15:12:26 <bag> +1
15:12:27 <tajoli> +1 for all three
15:12:30 <thd> +1 all
15:12:42 <bgkriegel> +1 all
15:12:49 <tcohen> +1 all
15:13:14 <cait> #agreed Release maintainers are Galen Charlton (gmcharlt, 3.14), Fridolin Somers (3.14) and Kyle Hall (khall, 3.12)
15:13:30 <cait> #topic Vote on Module maintainers
15:13:32 <Joubu> s/3.14/3.16
15:13:35 <tcohen> gmcharlt  3.16
15:13:38 <cait> #info Candidates are...on the wiki
15:13:45 <cait> oh typoed
15:13:46 <cait> thx
15:13:56 <oleonard> So no more official support for 3.10 or 3.8?
15:14:01 <cait> #agreed .. and that would be Galen Charlton for 3.16!
15:14:18 <cait> oleonard: so far noone stepped up, i think we could still have somoene elected later
15:14:35 <cait> i am quite glad khall stepped up for 3.12 actually
15:14:42 <oleonard> khall++
15:14:48 <ashimema> khall++ indeed
15:15:05 <bag> khall++
15:15:05 <talljoy> khall++
15:15:16 <nengard> khall++
15:15:34 <tcohen> khall++ # lots of stuff
15:15:35 <cait> because it looked like that would go eol for a bit too
15:15:48 <khall> 3.8 has not needed an update in many months, I would be willing to work on 3.12, 3.10 and 3.8 if needed
15:16:04 <JesseM> khall++
15:16:07 <khall> I expect updates to 3.10 will be rare, and 3.8 even more so
15:16:09 <tajoli> very good khall
15:16:16 <ashimema> the whole LTS and support length is another conversation really..
15:16:20 <marcelr> i would focus on 3.12, khall
15:16:27 <cait> probably only security updates now
15:16:32 <khall> agreed
15:16:38 <ashimema> sounds fair to me..
15:16:39 <ashimema> +1
15:16:58 <tcohen> +1
15:17:10 <cait> thx to all who volunteered for being module maintainers
15:17:13 <cait> +1, gmcharlt +1
15:17:27 <cait> I am going to not list all in the agreed - please forgive me for that :)
15:17:28 <nengard> +1
15:17:39 <JesseM> +1
15:17:40 <bag> no vote for myself -->  but +1 for the rest
15:17:49 <oleonard> +1 for module maintainers
15:17:54 <talljoy> +1
15:17:57 * chris_n volunteers to keep riding herd on label, et. al.
15:18:21 <cait> +1 for chris_n :)
15:18:22 <marcelr> +1 for all MM
15:18:25 <ashimema> I was tihnking of volunteering for a module next time around.. but sticking to QA this time
15:18:36 <ashimema> +1 for all those who stepped up, good show
15:18:44 <marcelr> do not leave QA, ashimena
15:18:45 <Joubu> +1 for others, -1 for me (Acq will be a pain...)
15:18:59 <bag> heh Joubu++
15:19:02 <ashimema> was thinking I might persuade the boss to let me do both ;)
15:19:09 <thd> +1 sll
15:19:10 <cait> yeah, extra cookies for Joubu :)
15:19:11 <ashimema> Joubu++
15:19:17 <tcohen> Joubu++
15:19:22 <cait> ok, ready for an agreed? :)
15:19:23 <bag> ashimema: aren't you the boss of yourself
15:19:26 <marcelr> ashimena: you can always enter QA but never leave :)
15:19:43 <cait> #agreed All module maintainers elected (see wiki)
15:19:46 <ashimema> nah, the other half's gotta have some say bag ;)
15:19:55 <cait> #topic Vote on Translation manager
15:20:11 <cait> #info candidate is Bernardo Gonzalez Kriegel
15:20:12 <bag> +1
15:20:18 <oleonard> +1
15:20:19 <marcelr> +1
15:20:19 <tajoli> +1
15:20:19 <JesseM> +1
15:20:20 <ashimema> +1 Bernardo
15:20:22 <Joubu> +1
15:20:23 <tcohen> +1
15:20:30 <cait> bgkriegel++ # great work!
15:20:36 <talljoy> +1
15:20:37 <cait> and +1, gmcharlt +1
15:20:38 <chris_n> +1
15:20:40 <bgkriegel> thx :)
15:20:47 <nengard> +1
15:21:19 <khall> +1
15:21:24 <thd> +1
15:21:53 <cait> #agreed New old translation manager is Bernardo Gonzalez Kriegel (bgkriegel)
15:21:59 <cait> #topic Documentation manager
15:22:15 <cait> #info candidate is Nicole Engard (nengard)
15:22:18 <cait> please vote :)
15:22:19 <oleonard> I thought nengard had been elected for a lifetime term :P
15:22:20 <chris_n> +1
15:22:23 <cait> +1, gmcharlt +1
15:22:24 <talljoy> +1
15:22:24 <oleonard> +1
15:22:24 * nengard too
15:22:30 <barton> +1
15:22:31 <JesseM> +1
15:22:32 <chris_n> nengard++
15:22:33 <bag> +1
15:22:38 <ashimema> nengard++
15:22:40 <Joubu> +1
15:22:42 <ashimema> life term ;)
15:22:43 <thd> +1
15:22:45 <ashimema> +1
15:22:46 <bgkriegel> +1
15:22:51 <tajoli> +1
15:23:06 <marcelr> +1
15:23:19 <khall> +1
15:23:22 <tcohen> +1
15:23:32 <cait> #agreed New Documentation manager - Nicole Engard (nengard)
15:23:38 <nengard> :)
15:23:41 <cait> #topic Quality Assurance Manager
15:23:43 <edveal> #info edveal ByWater
15:24:00 <cait> #info candidate: Katrin Fischer (cait)
15:24:09 <nengard> +1
15:24:10 <chris_n> +1
15:24:11 <oleonard> +1 for cait!
15:24:16 <edveal> +1
15:24:17 <bag> +1
15:24:17 <ashimema> cait++
15:24:17 <barton> +1
15:24:18 <Joubu> cait++
15:24:20 <Joubu> +1
15:24:21 <ashimema> +1 for cait
15:24:24 <bag> cait++
15:24:25 <talljoy> +1
15:24:29 <chris_n> cait++
15:24:30 <thd> ashemima: Yes, it  could become a penal sentence
15:24:33 <khall> +1
15:24:34 <tcohen> +1
15:24:35 <JesseM> +1
15:24:38 <thd> +1
15:24:39 <bgkriegel> +1
15:24:48 <JesseM> cait++
15:24:53 <rocio> +1
15:25:03 <mario> +1
15:25:14 <nengard> cait we skipped the DB doc manager  (just a reminder to go back)
15:25:28 <cait> yep, will fix after qa assistants
15:25:31 <cait> sorry,  had scrolled too far
15:25:37 <nengard> no problem!
15:25:57 <cait> #agreed Katrin Fischer will be Quality Assurance Manager
15:26:03 <tcohen> :-D
15:26:07 <marcelr> +1 for cait
15:26:08 <thd> nengard++
15:26:10 <cait> thx all :)
15:26:21 <cait> #topic Quality Asssurance Team
15:26:49 <cait> long list of candidates - let's keep the queue small :)
15:27:02 <thd> +1 all we can have
15:27:03 <JesseM> +1 to all
15:27:04 <oleonard> +1 to all
15:27:09 <marcelr> +1
15:27:11 <chris_n> +1 to all
15:27:12 <tcohen> +1 all
15:27:13 <tajoli> +1 to all
15:27:22 <talljoy> +1
15:27:25 <edveal> +1 to all
15:27:27 <Joubu> +1
15:27:30 <nengard> +1
15:27:31 <cait> #info Candidates are: Martin Renvoize, Marcel de Rooy, Brendan Gallagher, Paul Poulain, Julian Maurice, Jonathan Druart, Galen Charlton, Kyle M Hall
15:27:36 <cait> +1 to all of them!
15:27:45 <cait> +1 from gmcharlt as well
15:27:50 <barton> +1 to all.
15:27:55 <ashimema> +1 to all
15:27:58 <barton> (and all for 1)
15:28:09 <rocio> +1 to all
15:28:13 <rocio> lol barton
15:28:46 <cait> #agreed QA team: Martin Renvoize, Marcel de Rooy, Brendan Gallagher, Paul Poulain, Julian Maurice, Jonathan Druart, Galen Charlton, Kyle M Hall
15:28:55 <cait> hmwondering if the election is official before the second meeting?
15:29:12 <cait> but I don't expect too many changes :)
15:29:25 <cait> #topic Database documentation manager
15:29:32 <cait> #info candidate is Zeno Tajoli
15:29:35 <nengard> +1
15:29:38 <cait> #1, gmcharlt +1
15:29:42 <thd> +1
15:29:43 <cait> hm +1
15:29:48 <oleonard> +1
15:29:51 <JesseM> +1
15:29:52 <tcohen> +1
15:29:56 <barton> +1
15:30:00 <Joubu> +1
15:30:01 <edveal> +1
15:30:04 <ashimema> +1
15:30:08 <bgkriegel> +1
15:30:11 <bag> +1
15:30:16 <talljoy> +1
15:30:22 <khall> +1
15:30:37 <cait> #agreed Database documentation manager is Zeno Tajoli
15:30:43 <cait> #topic  Packaging manager
15:30:44 <tajoli> :)
15:30:51 <cait> #info candidate is Robin Sheat (eythian)
15:30:58 <marcelr> +1
15:31:01 <thd> +1
15:31:03 <bag> +1
15:31:03 <JesseM> +1
15:31:03 <cait> almost done, hang on everyone :)
15:31:03 <ashimema> +1 for Robin..
15:31:06 <cait> +1, gmcharlt +1
15:31:09 <Joubu> +1
15:31:09 <tajoli> +1
15:31:12 <talljoy> +1
15:31:13 <cait> also eythian++ packages++
15:31:15 <bgkriegel> +1
15:31:17 <rocio> +1
15:31:22 <oleonard> +1
15:31:24 <barton> +1
15:31:42 <cait> #agreed Packaging manager is Robin Sheat
15:31:47 <cait> #topic Bug Wranglers
15:31:54 <cait> our list of bug wranglers is quite short this time
15:31:57 <thd> +1
15:32:02 <cait> any last minute wranglers? :)
15:32:10 <khall> +1
15:32:11 <talljoy> +1
15:32:14 <oleonard> +1
15:32:16 <cait> #candidate: Zeno Tajoli
15:32:17 <wahanui> well, Zeno Tajoli is the person who has introduced UNIMARC italian support into Koha
15:32:17 <nengard> +1
15:32:20 <thd> +1 all volunteers
15:32:25 <edveal> +1
15:32:26 <cait> ok, isee you people are on auto pilot by now :)
15:32:29 <oleonard> :)
15:32:38 * cait thinks oleonard is also a bug wrangler
15:32:39 <wahanui> okay, cait.
15:32:47 <tcohen> +1
15:32:50 <cait> ah wahanui...
15:32:54 <cait> +1, gmcharlt +1
15:33:25 <Joubu> +1
15:33:32 <tcohen> +1 # eythian, missed that 7
15:33:41 <cait> #agreed Bug wranglers... Zeno Tajoli
15:33:44 <cait> done!
15:33:52 <tajoli> :)
15:33:53 <cait> We got a release team 3.18 :)
15:33:54 <ashimema> I'll get athaei to volunteer before the seocnd meeting ;)
15:33:55 <thd> I still control my autopilot even in my sleep. :)
15:33:58 <cait> community++
15:34:10 <tcohen> koha+
15:34:21 <cait> :)
15:34:42 <cait> i am not sure we wll make the whole agenda in the time remaining
15:35:14 <cait> hm let's see:)
15:35:17 <ashimema> maybe not.. but worth starting ;)
15:35:20 * barton is stayin' the distance.
15:35:35 <cait> #topic Discussion: Role of Module Maintainrs
15:35:39 <cait> another typo, gr.
15:35:56 <cait> on the agenda is a link to the discussion page in the wiki, with some opinions about this
15:36:06 <ashimema> I'll take over if you have to go cait ;) (assuming I can remember any irc commands)
15:36:11 <cait> #link http://wiki.koha-community.org/wiki/Talk:What_does_a_module_maintainer_do
15:36:32 <cait> ashimema: thx:) if you could take over at around :50 that would be awesome
15:36:46 <ashimema> :)
15:37:09 <cait> I made the topic, i can't force you all to discuss :)
15:37:16 <ashimema> I think tcohens 'Communication would be key' sums up my thoughts on Module maintainers.
15:37:59 * cait agrees
15:38:24 <tcohen> my thought is that MM are people that have a deep insight on the problems related to a specific module
15:38:47 <tajoli> I'm agree with tcohen
15:38:52 <ashimema> yup..
15:38:55 <tcohen> as I expressed before, the main help will be integrating patch series into topic branches
15:39:28 * chris_n would suggest that MMs be able to QA within their module as well
15:39:29 <tcohen> which as RM i'd pull. I really hope i can do it well regarding to communication
15:40:26 <ashimema> agree with chris_n, it's often hard to find the expertise for certain area's in koha.. diluting the pool by removing the MM from QA for their module would just make that harder..
15:40:43 <bag> yes - MM has a good idea of what's important to get push to "help" his module.  I view my role would be to help encourage others to test and QA patches in "my" module... so things don't get lost.  Encouragement - then once it's all good - communicate with the RM to say it's important and has passed all steps :)
15:41:03 <ashimema> bag++
15:41:04 <cait> ashimema: i agree about that for some areas, other areas like holds and circs often can't have enough eyes on them
15:41:21 <cait> bag++
15:41:26 <tcohen> bag++
15:41:39 <cait> i think i like that idea - havign someone being responsible for an area, taking care no kittens get lost, prioritize etc
15:41:43 <cait> communicate :)
15:41:57 <thd> tcohen: Do you have any comment about the thought from paul_p that a module maintainer is automatically part of the  QA team for that  module?
15:42:22 <paul_p> hey, I missed the start of the meeting !
15:42:25 <ashimema> agreed cait, where there's not a lack of expertise, then get as many eys on the ball as possible... and as bag says, that's part of the MM's job.. to promote poeple looking at bugs in their area.
15:42:27 <paul_p> thx to call me thd !
15:42:30 <cait> thd: hm i think that goes into a very similar direction as the question before
15:42:33 <paul_p> (time passes so quickly...)
15:42:34 <bag> also for something with LDAP/SIP which I volunteered for - it's hard for people to test - so ideally I will help provide a testing suite to help, move things along
15:43:17 <cait> :)
15:43:20 <thd> paul_p: Would there be a danger of reduced review in your thought?
15:43:24 <cait> everything server side is a bit hard to get people on
15:43:25 <ashimema> perfect bag..
15:43:34 <cait> ldap, sip, packages, etc.
15:43:41 <tcohen> thd: i've just read the ongoing discussion (i've just arrived Cordoba from a month abroad)
15:43:56 <ashimema> I hadn't thought about that side.. good idea.. give people the tools to fish and they'll feed themsevles froever ;)
15:44:04 <cait> heh
15:44:11 <bag> welcome back tcohen :)
15:44:12 <paul_p> well, it was just a question/suggestion. and my main feeling is that it's the RM that should decide !
15:44:20 <cait> +1
15:44:21 <paul_p> tcohen welcome back 3.18 RM !!!
15:45:06 <tcohen> as i see it, MM should be part of the QA team, and the ones responsible of integrating the patches fr their modules for pulling
15:45:25 <tcohen> and i don't think this should prevent scrutiny from other QA members
15:45:25 <paul_p> maybe we should let tcohen some time to be back, and talk about that in the next days
15:45:42 <cait> I'd like MM not to replace QA
15:45:49 <tcohen> thanks paul_p
15:46:08 <cait> we will have overlap, but let's give it a try to get otherson board for testing
15:46:21 * paul_p remember his honeymoon, 20 years ago...
15:46:24 <ashimema> communication is key.. :)
15:46:27 <ashimema> +1 to communication
15:46:29 <thd> paul_p: I think that your sus excellent and of course the RM should decide.  I merely see the possibility of risk for not enough independent examination in merging MM with QA.
15:46:36 <tcohen> nothing ever gets pushed without a lot of eyes on it
15:46:59 <cait> :)
15:47:08 <cait> i will move the topic if that's ok?
15:47:09 <tcohen> this is a matter of trust and communication
15:47:11 <chris_n> I think if MMs are ever to direct push, they will need to QA also to some extent
15:47:12 <paul_p> thd = OTOH, if adding MM is only adding one step, I think/fear it won't improve our workflow.
15:47:18 <thd> paul_p: I think that it is a necessary risk to cope with the volume well.
15:47:59 <thd> s/volume/volume of patches/
15:48:06 <paul_p> thd (not sure I understand what you mean)
15:50:02 <cait> hm maybe we should move on and leave at that for now?
15:50:09 <paul_p> +1
15:50:12 <cait> #topic Discussion: Role of Release maintainers
15:50:12 <ashimema> +1
15:50:24 <thd> paul_p:The task of RM is very large and motivates using MM, similarly the task of QA, consequently I think that your thought about MM merging somewhat with QA is a good one despite risks of insufficient independence.
15:50:44 <cait> #link http://lists.koha-community.org/pipermail/koha-devel/2014-April/040420.html
15:51:03 <paul_p> thd= ok, so you mostly agree with me, right ? ;-)
15:51:04 <cait> linking to an email from gmcharlt on the mailing list
15:51:42 <chris_n> paul_p: probably the MM is a mini-RM for a given module with similar RM prerogatives limited to a given module
15:51:44 <cait> I think his definition covers the current role well
15:51:59 <thd> paul_p: I completely agree  I merely nopte the risk so that we can be aware of it.
15:52:22 <paul_p> chris_n that's my feeling & what I'd like to see on Koha !
15:52:27 <thd> paul_p++
15:52:30 <ashimema> ++
15:52:55 <ashimema> right.. so release maintainers..
15:53:22 <cait> i have to run :) - be good for ashimema #koha
15:53:44 <ashimema> I think the bigger question here is 'Should we adopt a more rigid release/support pattern'
15:54:04 <ashimema> in terms of.. how long we should support our cycle..
15:54:11 <ashimema> to me there's also two levels of support..
15:54:20 <ashimema> security only fixes, and bug fixes..
15:54:23 <ashimema> anyone?
15:54:24 <wahanui> Anyone? Anyone? Bueller? Bueller?
15:54:31 <paul_p> ashimema = I fear it's all related to having a volunteer to maintain !
15:54:56 <thd> paul_p++
15:55:02 <ashimema> having volunteers, or encouraging people to step up?
15:55:05 <paul_p> ashimema = for 3.14, I alsmot can guarantee you'll get a RMaint for the next 12 months, because we're deploying it a lot ;-)
15:55:20 <ashimema> ;)
15:55:29 <ashimema> likewise
15:55:58 <oleonard> I think the point is that if we *want* to adopt a more rigid release/support pattern then we can do more to convince folks to take on the role. Still no guarantee though.
15:56:20 <ashimema> oleonard++ exactly my thoughts
15:56:33 <thd> Despite the truth of needing a maintainer to volunteer, we might have an official community position that the community strives to maintain the previous X release for period Y.
15:57:10 <ashimema> I think the stats stuff will be usefull to tell us our demographic better too..
15:57:39 <ashimema> I actualyl have very little idea of what versions are in the wild outside of our own comapny ;)
15:57:40 <tajoli> For me as comunity i think we need encouraging people to step up around 18-24 months. LTS si for paid costumers
15:58:12 <ashimema> 18-24 months is 3-4 releases..
15:58:30 <ashimema> which is about what we've got ;)
15:58:35 <tajoli> In fact is the today situation
15:58:38 <paul_p> ashimema = 18 months sounds a good duration.
15:58:42 <paul_p> (to me)
15:58:43 <tcohen> we could add to the mix the fac tthat the current channel/pocket schema in the Debian repo makes people inadvertedly shift version too soon
15:59:13 <paul_p> channel/pocket schema ???
15:59:17 <ashimema> good point tcohen.. there was a mail thread aobut that too i think
15:59:34 <tcohen> ashimema: i missed it as well
15:59:46 <tcohen> paul_p: we call 'squeeze' the stable version
16:00:14 <tcohen> we where in 3.12.5 when 3.14.0 overwrote 'squeeze'
16:00:28 <ashimema> just trying to dig it out..
16:00:53 <ashimema> there was a conversation about switching the repository to testing, stable and oldstable..
16:01:00 <thd> squeeze forever :)
16:01:17 <ashimema> then trying to keep those inline with our verisoning instead of confusing people with squeeze, wheezy stuff.
16:02:03 <tcohen> i'm in favour of using "3.12" "3.14" and so on instead
16:02:24 * liw pipes in and says he'd be happy to discuss the apt repository setup if that'd be helpful, but not right now since he's at work and busy with things
16:02:25 <ashimema> how would you 'deprecate' a version tcohen?
16:02:50 <ashimema> liw, whose liw.. forgive my ignorance
16:02:59 <tcohen> lars
16:03:24 <ashimema> ooh.. lars. didn't know he still lurked..
16:03:26 <liw> (I made the .deb packages originally, though I haven't been involved in years)
16:03:33 <tcohen> liw: i'd be great to discuss it whenever you have time to do it
16:03:55 <ashimema> lets have a chat at a more appropriate moment maybe.. get the key players in packages together.
16:03:58 <liw> if someone can give me a URL to the email thread, I'll respond to that when I can
16:04:07 <ashimema> adn.. we're no in overtime for the meeting chaps.
16:04:18 <ashimema> I'll dig it out liw
16:04:48 <ashimema> http://lists.koha-community.org/pipermail/koha-devel/2014-April/040430.html
16:05:03 <ashimema> that's one thread.. but it morphed into another which i'm trying to find.
16:05:32 <pastebot> "tcohen" at 172.16.248.198 pasted "thread" (1 line) at http://paste.koha-community.org/11
16:05:36 <ashimema> actually.. i think it's all there.
16:05:45 <liw> ashimema, thanks; do continue the meeting
16:06:01 <ashimema> so.. shall we move on..
16:06:17 <ashimema> #Topic Additions to Coding guidelines
16:06:37 <ashimema> Does everyone agree on deprecating C4::Dates?
16:06:47 <ashimema> (first I've spotted this :S)
16:07:17 <Joubu> +1 for deprecating C4/*
16:07:26 <ashimema> +1
16:07:34 <ashimema> anyone else?
16:07:40 <tcohen> +1
16:08:23 <ashimema> and moving on again
16:08:26 <ashimema> #Topic Big stuff we are working on
16:08:30 <thd> Has it not already been deprecated and is the issue not more about updating the coding guidelines to reflect that?
16:08:51 <ashimema> good spot thd..
16:08:57 <thd> +1
16:08:59 <oleonard> ashimema: Did we arrive at an #agreed on that one?
16:09:00 <ashimema> yeah, we should reflect the change
16:09:07 <ashimema> +1
16:09:20 <gmcharlt> a commit adding a big "DO NOT USE" to C4/Dates.lpm would also be good
16:09:22 <ashimema> funny how peopel pipe up when you decide to move on ;).. works a charm
16:09:24 * gmcharlt is not really hear
16:09:29 <gmcharlt> *here
16:09:44 <ashimema> +1 to gmcharlt's suggestion
16:09:59 <ashimema> I'm happy to add it to the Coding guidlines if we agree..
16:10:04 <thd> +1
16:10:16 <ashimema> hell, lets go for it.
16:10:45 <ashimema> #agreed Add 'Deprecate C4/Dates.pm to coding guidlines'
16:11:17 <thd> +1 Changing the guidelines and adding an unmissable comment to the code..
16:11:35 <ashimema> can we now move on.. pretty please.. :)
16:11:38 <barton> How 'bout a 'depricated()' method in C4/Dates.pm.
16:11:56 <barton> sorry. will shutup now.
16:12:05 <ashimema> hehe..
16:12:14 <ashimema> did anyone have any anouncments then?
16:12:27 <ashimema> i facny that'll be more for the part 2 of this meeting.. if there are any?
16:13:07 <ashimema> ok, moving on again then..
16:13:16 <ashimema> #Topic Date of next meeting.
16:13:32 <ashimema> gmcharlt suggest same times on the 30th
16:14:02 <ashimema> +1 from me, though I personally can't make it
16:14:36 <thd> +1 Same times 30 April
16:14:48 <barton> umholdon...
16:15:08 <tajoli> not 30 May ?
16:15:15 <oleonard> Another meeting in 1 week?
16:15:21 <barton> bywater staff retreat is going on then...
16:15:26 <ashimema> 30 May, me thinks..
16:15:27 <barton> I don't know if that matters...
16:15:33 <ashimema> I only got 30th in the chat ;)..
16:15:38 <ashimema> 1 week is a bit short ;)
16:15:51 <gmcharlt> oleonard: next week is too soon, but mid-May or late May
16:15:58 <oleonard> 30 May is a Friday
16:15:59 <gaetan_B> bye
16:16:47 <oleonard> Wednesday 21 May?
16:16:50 * thd assumed some agenda forthcoming for 30 April -- oops.
16:17:00 <gmcharlt> +1 21 May
16:17:05 <barton> ok nevermind. may.
16:17:17 <ashimema> 21st is also good by me.. (and I can make that at the moment ;) )
16:17:18 <wahanui> okay, ashimema.
16:17:21 <ashimema> +1
16:17:36 <thd> +1 21 May same times.
16:17:51 <tajoli> +1 21 May same times.
16:18:44 <ashimema> ok, wanting to bring this to a close now.. only 1/3 time over ;)
16:18:59 <ashimema> #agreed 21st May for next meeting(s)
16:19:39 <thd> ashimema++
16:19:45 <ashimema> #endmeeting