22:01:03 <gmcharlt> #startmeeting Development IRC meeting, 11 June 2014, part 2
22:01:03 <huginn> Meeting started Wed Jun 11 22:01:03 2014 UTC.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:01:03 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:01:03 <huginn> The meeting name has been set to 'development_irc_meeting__11_june_2014__part_2'
22:01:17 <gmcharlt> #info Agenda is http://wiki.koha-community.org/wiki/Development_IRC_meeting,_11_June_2014
22:01:23 <gmcharlt> #topic Introductions
22:01:24 <wahanui> #info wahanui, a bot that has become sentient
22:01:30 <gmcharlt> #info Galen Charlton, ESI
22:01:51 <eythian_> #info Robin Sheat, Catalyst IT, NZ
22:01:52 <cait> #info Katrin Fischer, BSZ
22:02:21 <thd> #info Thomas Dukleth, Agogme, New York City
22:03:37 <rangi> #info Chris Cormack, Catalyst NZ
22:03:58 * thd is merely semi-present
22:04:09 <gmcharlt> ok
22:04:19 <gmcharlt> in tcohen's absence, we'll skip the RM 3.18 update
22:04:30 <gmcharlt> #topic Deprecate the OPAC prog theme officially
22:04:52 <wizzyrea> #info Liz Rea, Catalyst NZ
22:04:53 <gmcharlt> #info Current proposal for wording in the coding guidelines: (http://paste.lisp.org/display/142855
22:05:38 <gmcharlt> this was voted on in the first meet
22:05:41 <gmcharlt> ing
22:05:51 <gmcharlt> any questions, comments, or other feedback before we vote on it here?
22:06:16 <wizzyrea> besides, "good riddance?"
22:06:44 <gmcharlt> (no! we must keep at the historical dead things!)
22:06:45 <gmcharlt> ;)
22:07:06 <gmcharlt> #startvote Shall the change to the coding guidelines to deprecate OPAC and CCSR be approved (http://paste.lisp.org/display/142855)? Yes, No, Abstain
22:07:06 <huginn> Begin voting on: Shall the change to the coding guidelines to deprecate OPAC and CCSR be approved (http://paste.lisp.org/display/142855)? Valid vote options are Yes, No, Abstain.
22:07:06 <huginn> Vote using '#vote OPTION'. Only your last vote counts.
22:07:23 <eythian_> #vote yes
22:07:23 <cait> i was at the first meeting, so I won't vote again
22:07:25 <wizzyrea> #vote yes
22:07:29 <rangi> #vote yes
22:07:46 <thd> wizzyrea: The grass is always greener elsewhere until you have discovered all the difficulties of digesting especially green grass :)
22:08:09 <mtompset> #vote yes.
22:08:09 <huginn> mtompset: yes. is not a valid option. Valid options are Yes, No, Abstain.
22:08:14 <mtompset> #vote yes
22:08:19 <wizzyrea> that grass is pretty much dead.
22:08:25 <mtompset> (since I didn't get inthe first meeting. ;) )
22:08:43 <mtompset> #info Mark Tompsett
22:08:56 <gmcharlt> one minute too vote closing
22:08:57 * thd already voted yes with concerns about even free software projects originating at Twitter.
22:10:33 <gmcharlt> #endvote
22:10:33 <huginn> Voted on "Shall the change to the coding guidelines to deprecate OPAC and CCSR be approved (http://paste.lisp.org/display/142855)?" Results are
22:10:33 <huginn> Yes (4): eythian_, wizzyrea, rangi, mtompset
22:10:58 <gmcharlt> #agreed the coding guidelines will be updated per http://paste.lisp.org/display/142855 to discourage future patches from updating the prog and CCSR OPAC themes
22:11:15 <gmcharlt> #topic UTF-8 Clean-up - Bug 11944
22:11:16 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11944 major, P5 - low, ---, jonathan.druart, Needs Signoff , Cleanup Koha UTF-8
22:11:43 <gmcharlt> #info (from part 1) gmcharlt has action items to review patches and redy them for signoff by end of June
22:12:04 <gmcharlt> #info also action item to schedule a GBSD dedicated to it in early July
22:12:34 <gmcharlt> #info Joubu has action item to look at bug 11811 and look at adjusting on or more sandboxes to use the utf8_unicode_ci collation in their mysql databases
22:12:35 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11811 major, P1 - high, ---, dpavlin, In Discussion , tools/import_borrowers.pl doesn't support utf-8 encoded CSV
22:12:58 <gmcharlt> needless to say, anybody else who wants to join in patch review is very much welcome to
22:14:27 <gmcharlt> any comments before we move on?
22:14:53 <cait> apart from patch review i think there are some remaining problems
22:15:44 <rangi> ?
22:15:44 <cait> hm, trying to phrase that better
22:15:51 <thd> cait: Do you mean problems within the scope of the bug but out of scope for the existing patches?
22:15:59 <cait> there are some known issues still that need to be solved in the patch series
22:16:02 <gmcharlt> right, Joubu had identified a couple issues in the bug that he wants some help writing patches for
22:16:20 <gmcharlt> I'll undertake them as part of my review, but again, more eyes welecome
22:16:23 <cait> yes, thx gmcharlt
22:16:24 <gmcharlt> welcome, even
22:16:41 <cait> and thx again for working on those :)
22:16:51 <thd> *++
22:17:14 <gmcharlt> ok, moving on
22:17:20 <gmcharlt> #topic Big stuff we are working on
22:17:38 <gmcharlt> #info BibLibre is working on an RFC for revamping how taxes are handled in acquisitions
22:17:51 <wizzyrea> biblibre++
22:18:02 <rangi> im working on the mulitple bookcovers dev, that you would have seen kathryns email about, its not that big, should have something to submit in a couple of weeks
22:18:04 <gmcharlt> since the IRS's grand scheme to TAX THE WHOLE WORLD is not quite complete... feedback from everybody is essential
22:18:22 <gmcharlt> to ensure that the outcome works well enough for everybody
22:18:59 <thd> Did I understand that the BibLibre acquisitions RFC is awaiting more work before publishing it in English?
22:19:16 * eythian is no longer busmeeting.
22:19:16 <gmcharlt> that's my understanding
22:19:30 <gmcharlt> or at the very least, they're working on translating it
22:20:13 <gmcharlt> #info rangi is working on support for multiple sources of book covers
22:20:20 <gmcharlt> eythian: how is ES coming along?
22:21:00 <eythian> gmcharlt: quite well. Implementing all that's on the advanced search page is almost done (availability is slightly tricky for unexciting reasons.)
22:21:18 <eythian> Still figuring out how to do the browse interface stuff, but have some leads on that.
22:21:29 <gmcharlt> cool
22:21:32 <gmcharlt> any other projecst?
22:21:39 <eythian> I'm hoping to put patches up for testing reasonably soon
22:21:46 <thd> rangi: Do you mean multiple live sources?
22:21:47 <pianohacker> Oh right dev meeting
22:21:50 <eythian> very alpha testing.
22:22:42 <wizzyrea> defining availability has always been a question.
22:22:43 <thd> rangi: Or is there a bug blocking the use of stored images for book covers?
22:23:00 <pianohacker> Have rancor updates
22:23:19 <gmcharlt> pianohacker: go for it
22:23:28 <rangi> thd: multiple sources including local covers, but with fallback
22:23:50 <rangi> so you define the order, and it tries them until it gets one that has an image (or fails on all)
22:23:51 <pianohacker> Rancor has several bugfixes and a new metasearch backend that does not depend on pazpar2
22:24:00 <wizzyrea> oooo
22:24:25 <cait> pianohacker: what are you using instead?
22:24:46 <pianohacker> Needs to be refactored a bit, and the results have to be refetched for each page load, but it supports sorting and pagination
22:24:56 <pianohacker> Also needs relevance ranking at some point
22:25:17 <pianohacker> cait: Just ZOOM, all of the record fetching and sorting is done in Koha now
22:25:44 <pianohacker> seems to be about the same speed as pazpar2, and works more consistently
22:25:55 <cait> is that an option for opac too?
22:26:06 <pianohacker> cait: Possibly :)
22:26:15 <pianohacker> guessing you're thinking for bug 10486?
22:26:16 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10486 new feature, P5 - low, ---, jweaver, Failed QA , Allow external Z39.50 targets to be searched from the OPAC
22:26:58 <cait> of course :)
22:27:03 <gmcharlt> #info prog/CCSR deprecation now the HTML5 guideline: http://wiki.koha-community.org/wiki/Coding_Guidelines#HTML5:_Deprecation_of_the_.27prog.27_and_.27CCSR.27_OPAC_themes
22:27:20 <pianohacker> I'd definitely want some kind of results caching before I put it on an OPAC, and I'm not sure of the best way to do that
22:27:52 <gmcharlt> pianohacker: time for you to investigate Koha::Cache
22:28:11 <eythian> especially my new+improved version (I can't remember if it's in master yet or not)
22:28:24 <pianohacker> gmcharlt: That was my thought, my major question was value size limits, though
22:28:51 <eythian> oh, it's not it needs someone to poke bug 12041
22:28:52 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12041 enhancement, P5 - low, ---, robin, Passed QA , Improve Koha::Cache
22:30:27 <pianohacker> If I do the straightforward thing and shove the entire result set in as a MARC blob, it comes out to roughly 250 KB for the 100-record fetch I'm currently doing. This only really works for Memcached, though, and if servers send back a ton of huge records my impression is that the key storage silently fails
22:30:40 <pianohacker> Not a terrible thing but I was curious if there's a better way
22:31:42 <eythian> probablyu worth describing it in detail on a koha-devel post
22:31:45 <eythian> get more eyes that way
22:31:46 <gmcharlt> yeah
22:31:48 <pianohacker> Seems like a good idea
22:31:54 <gmcharlt> any other topics?
22:32:02 <eythian> yeah
22:32:20 <rangi> i have a couple that id like to run past people, not strictly dev, but related
22:32:28 <rangi> first there is
22:32:31 <rangi> http://osswatch.jiscinvolve.org/wp/2014/05/23/vals-semester-of-code-foss-projects-wanted/
22:32:33 <eythian> just a note that there's a series of plack patches around that people could look at if they want something to do.
22:32:41 <eythian> For staff client plack support.
22:33:09 <thd> Can the result set records be quickly stored in some temporary database storage if the result set is unexpectedly large but not egregiously large.
22:33:10 <cait> i think we have some areas were testing/qa gets into a bottleneck
22:33:11 <eythian> Some are in master now, but there are some that aren't.
22:33:13 <cait> sip, caching, ldap
22:33:14 <thd> ?
22:33:44 <cait> so if someone feels able to test in that areas, please go for it
22:33:59 <pianohacker> thd: that's a possibility
22:34:28 <eythian> cait: perhaps someone who knows them should write up testing guides on the wiki?
22:34:48 <cait> well not me then... i have done a bit of sip, but no ldap and caching so far :(
22:34:55 <cait> i'd like to use one of those tesitng guides
22:35:03 <eythian> caching is actually pretty easy, ldap is less so.
22:35:14 <cait> rangi: reading
22:35:20 <gmcharlt> rangi: the VALS SoC looks interesting; my main comment is that if we want to do it, we should line up several commitments for mentors first
22:35:27 <rangi> yep
22:35:31 <cait> it sounds interesting
22:37:03 <gmcharlt> rangi: and the other thing you wanted to bring up?
22:37:44 <rangi> ah yep
22:37:49 <rangi> http://paste.koha-community.org/40
22:37:56 <rangi> really really rough draft
22:37:57 <rangi> for
22:38:05 <rangi> https://linux.conf.au/miniconf-cfp
22:38:16 <gmcharlt> #info rangi mentioned the VALS summer of code (http://osswatch.jiscinvolve.org/wp/2014/05/23/vals-semester-of-code-foss-projects-wanted/) as a possible project for Koha to cnosider
22:38:27 <rangi> but if it does get accepted i will be trying to get some people from koha to be speakers
22:38:36 <rangi> as well as evergreen, islandora, et al
22:39:30 <cait> cool
22:39:50 <eythian> so if anyone feels like a trip to wherever the next LCA is... :)
22:39:57 <rangi> auckland nz
22:39:59 <gmcharlt> #info rangi is proposing a cultural hertiage and FLOSS miniconference for the lca2015 in Auckland (https://linux.conf.au/)
22:40:05 <cait> oooh...
22:40:06 <eythian> oh, that's boring
22:40:21 <wizzyrea> way not as cool as wellington.
22:40:24 <gmcharlt> heh
22:40:25 <wizzyrea> HAR
22:40:29 <wizzyrea> :)
22:40:36 <cait> true
22:40:41 <pianohacker> eythian: couple small questions about the new Koha::Cache module after da meeting
22:40:45 <eythian> sure
22:41:55 <gmcharlt> thanks, rangi
22:42:10 <rangi> thats all i have
22:42:21 <gmcharlt> regarding setting a date for the next meeting, I suggest we wait for when tcohen is back home
22:42:54 <rangi> sounds good
22:43:39 <gmcharlt> ok
22:43:42 <gmcharlt> thanks everybody
22:43:45 <gmcharlt> #endmeeting