#koha: Development IRC meeting, 5 August 2014 (part 1)

Meeting started by tcohen at 15:04:25 UTC (full logs).

Meeting summary

  1. Introductions (please use "#info" in front of your introduction to have it show up in the automatic minutes) (tcohen, 15:04:56)
    1. Tomas Cohen Arazi, Universidad Nacional de Cordoba (tcohen, 15:05:20)
    2. Katrin Fischer, BSZ - not quite here (cait, 15:05:36)
    3. Thomas Dukleth, Agogme, New York City - [dead drive today] (thd, 15:05:47)
    4. Jane Wagner, LibLime/PTFS (Guest4884, 15:06:24)
    5. Owen Leonard, Athens County Public Libraries (oleonard, 15:06:55)

  2. RM 3.18 comments (tcohen, 15:07:31)
    1. tcohen asked Chris Cormack to take care of integrating PROG/CCSR deprecation patches (tcohen, 15:08:20)
    2. tcohen provided a first approach to unit tests for LDAP-related code on bug 8148 (tcohen, 15:09:14)
    3. feedback on that is needed, urgently (tcohen, 15:09:32)
    4. RM is concerned about the lack of unit tests in some important bugs, he will continue to help write those tests for people not used to it (tcohen, 15:10:41)
    5. Jesse Maseto, ByWater Solutions (JesseM, 15:10:50)

  3. KohaCon14 update (tcohen, 15:13:25)
    1. the kohacon page will be updated tomorrow with more information (tcohen, 15:13:47)
    2. Nate Curulla ByWater (NateC, 15:13:56)
    3. tcohen makes a call for atendees and people making presentqations on kohacon (tcohen, 15:14:25)
    4. tcohen makes a call for people to register (tcohen, 15:15:12)

  4. Additions to Coding Guidelines (tcohen, 15:15:38)
    1. Bernardo Gonzalez Kriegel, late (bgkriegel, 15:15:41)
    2. Ed Veal ByWater (edveal, 15:18:34)
    3. ACTION: Katrin volunteers to fill a bug on missing lines in about.pl for external libs (tcohen, 15:20:05)

  5. DBIC (tcohen, 15:20:58)
    1. Example usage of DBIC http://wiki.koha-community.org/wiki/Examples_of_DBIC_in_Koha (tcohen, 15:22:44)
    2. ACTION: tcohen will promote this discussion on the development list (tcohen, 15:30:23)

  6. Bugs (tcohen, 15:32:06)
    1. Nicole C. Engard, ByWater Solutions (nengard, 15:41:37)
    2. Kyle Hall, ByWater Solutions (khall, 15:41:52)
    3. Brendan Gallagher ByWater (bag, 15:41:53)

  7. Big stuff we are working on (tcohen, 15:49:45)
  8. Set time of next meeting (tcohen, 15:51:50)
    1. AGREED: if part 2 agrees, next dev meeting is August 19th (part 1 15:00 UTC, part 2 22:00 UTC) (tcohen, 15:55:51)


Meeting ended at 15:56:13 UTC (full logs).

Action items

  1. Katrin volunteers to fill a bug on missing lines in about.pl for external libs
  2. tcohen will promote this discussion on the development list


Action items, by person

  1. tcohen
    1. tcohen will promote this discussion on the development list


People present (lines said)

  1. tcohen (93)
  2. cait (24)
  3. bag (8)
  4. thd (6)
  5. huginn (5)
  6. nengard (5)
  7. oleonard (4)
  8. wahanui (3)
  9. bgkriegel (3)
  10. jwagner (2)
  11. Guest4884 (1)
  12. JesseM (1)
  13. edveal (1)
  14. khall (1)
  15. NateC (1)


Generated by MeetBot 0.1.4.