#koha: Development IRC meeting, 9 September 2014 (part 2)

Meeting started by tcohen at 22:03:04 UTC (full logs).

Meeting summary

  1. Introductions (tcohen, 22:03:26)
    1. wahanui, a bot that has become sentient (wahanui, 22:03:26)
    2. Katrin Fischer (cait, 22:03:38)
    3. Tomas Cohen Arazi, Universidad Nacional de Cordoba (tcohen, 22:03:38)
    4. Liz Rea, Catalyst IT (wizzyrea, 22:03:47)
    5. Brendan Gallagher ByWater (bag, 22:03:50)
    6. Jason Burds I.T. Supervisor Carnegie-Stout Public Library (JasonBurds, 22:04:09)

  2. RM 3.18 comments (tcohen, 22:05:09)
    1. facets from zebra is needs sign off, bug 11232 (tcohen, 22:06:13)
    2. https://github.com/tomascohen/koha/commit/281808cce6cc94e26beb6281ec44daada0a85595 (tcohen, 22:08:29)

  3. General technical discussion (tcohen, 22:09:47)
    1. https://trello.com/c/vsrkdpvv/27-tests-mocking-when-to-and-when-not-to-that-is-the-question (tcohen, 22:10:24)

  4. Additions to Coding Guidelines (tcohen, 22:32:32)
    1. coding guidelines foe using Koha.Preference https://trello.com/c/8d7pELLj/28-coding-guidelines-koha-preference (tcohen, 22:33:45)
    2. AGREED: adding Koha.Preference use to coding guidelines (tcohen, 22:37:32)

  5. should we use DBIC on .pl scripts? (tcohen, 22:38:11)
  6. Naming of database columns (tcohen, 22:44:46)
    1. there is a partial agreement on having coding guidelines that match DBIc ones, concerns raise about how to migrate existing tables/column names and research is needed (tcohen, 23:08:59)

  7. Requirements for CLI scripts (tcohen, 23:09:13)
    1. VOTE: Voted on "Shall we adopt the pod* & Getopt::Long sections of the propose CLI script guidelines?" Results are, Yes: 5 (gmcharlt, 23:21:56)
    2. ACTION: eythian will start a discussion on koha-devel about --dryrun behavior for CLI scripts (gmcharlt, 23:22:48)

  8. Call for feedback (gmcharlt, 23:23:26)
    1. Joubu is requesting feedback on bug 10860, which adds a "reading room"/"in house use" feature (gmcharlt, 23:24:38)

  9. Big stuff we are working on (gmcharlt, 23:30:18)
    1. Feedback still being sought on the VAT/GST rewrite (gmcharlt, 23:33:33)

  10. Action items from previous meeting (gmcharlt, 23:37:55)
    1. ashimema added a note to the wiki to encourage use of columns stuff for datatables (gmcharlt, 23:38:03)
    2. ashimema has started qa for UTF8 bug.. minimal comments left already (gmcharlt, 23:38:11)
    3. gmcharlt and tcohen set deadline of 9/19 forwriting some unit tests for the utf8 bug (gmcharlt, 23:38:38)

  11. Next meeting (gmcharlt, 23:39:34)
    1. AGREED: We'll meet same time next week (gmcharlt, 23:41:10)


Meeting ended at 23:41:20 UTC (full logs).

Action items

  1. eythian will start a discussion on koha-devel about --dryrun behavior for CLI scripts


Action items, by person

  1. eythian
    1. eythian will start a discussion on koha-devel about --dryrun behavior for CLI scripts


People present (lines said)

  1. tcohen (113)
  2. gmcharlt (41)
  3. cait (31)
  4. rangi (25)
  5. eythian (25)
  6. pianohacker (13)
  7. bag (11)
  8. huginn (10)
  9. wahanui (6)
  10. dcook (4)
  11. wizzyrea (2)
  12. gmcharlt_ (1)
  13. JasonBurds (1)


Generated by MeetBot 0.1.4.