22:00:43 <gmcharlt> #startmeeting Deveopment meeting, 23 July 2014, part 2
22:00:43 <huginn> Meeting started Wed Jul 23 22:00:43 2014 UTC.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:43 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:43 <huginn> The meeting name has been set to 'deveopment_meeting__23_july_2014__part_2'
22:00:52 <gmcharlt> #info Agenda http://wiki.koha-community.org/wiki/Development_IRC_meeting,_23_July_2014
22:01:15 <gmcharlt> #info Part 1 minutes: http://meetings.koha-community.org/2014/koha_irc_developer_meeting__july_23rd__part_1.2014-07-23-15.00.html
22:01:26 <gmcharlt> #info Part 1 logs: http://meetings.koha-community.org/2014/koha_irc_developer_meeting__july_23rd__part_1.2014-07-23-15.00.html
22:01:36 <gmcharlt> #topic Introductions
22:01:36 <wahanui> #info wahanui, a bot that has become sentient
22:01:42 <gmcharlt> #info Galen Charlton, Equinox
22:01:52 <bgkriegel> #info Bernardo Gonzalez Kriegel
22:02:04 <bag> #info Brendan Gallagher, ByWater
22:02:48 <bag> welcome back to work gmcharlt
22:03:05 <gmcharlt> thanks
22:03:12 <tcohen> #info Tomas Cohen Arazi, Universidad Nacional de Cordoba
22:03:19 <tcohen> wb gmcharlt
22:04:52 <bgkriegel> so few... :)
22:05:17 <gmcharlt> indeed
22:05:24 <gmcharlt> but we WILL CHARGE ON REGARDLESS!!!
22:05:41 <gmcharlt> #topic RM 3.18 comments
22:05:48 <gmcharlt> tcohen: you have the floor
22:06:04 <tcohen> As mentioned earlier, some work is on its way in the Search front
22:06:24 <tcohen> and I've been concerned that the test suite doesn't cover UNIMARC
22:06:46 <tcohen> i want to run the same tests we run for MARC21, but on UNIMARC and
22:06:59 <tcohen> need UNIMARC people's help in crafting the sample data
22:07:23 <tcohen> Jonathan offered to help earlier, so, that's it
22:07:32 <bgkriegel> what kind of data?
22:07:53 <tcohen> marc data, and having a good default koha<->marc mapping
22:07:55 <bgkriegel> Joubu will be away for 3 weeks
22:08:04 <bgkriegel> vacation
22:08:09 * tcohen knows he needs to hurry
22:08:38 <tcohen> the only difficulty is having too little UNIMARC knowledge
22:08:57 <tcohen> but it seems there's a bug for fixing the default mappings
22:09:05 <tcohen> and it should be covered there
22:09:28 <tcohen> moving on
22:09:29 <bgkriegel> you know bug number?
22:09:58 <tcohen> #info bug 11586 might serve as input for having better UNIMARC search tests
22:09:59 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11586 enhancement, P5 - low, ---, jonathan.druart, ASSIGNED , Better default framework for UNIMARC
22:10:14 <bgkriegel> ok
22:11:07 <tcohen> gmcharlt, moving on?
22:11:12 <gmcharlt> ok
22:11:26 <gmcharlt> #topic Coding guidelines: Move towards deprecating GRS-1 in favor of DOM indexing
22:11:53 <gmcharlt> the first part of the meeting approved deprecated GRS-1 in favor of DOM
22:12:08 <gmcharlt> per the following wording - coding guideline about deprecating GRS-1 in favor of DOM
22:12:19 <gmcharlt> er, make that http://paste.lisp.org/display/143215
22:13:00 <gmcharlt> questions or comments about the proposal?
22:13:20 <tcohen> has anyone volunteered for filling a bug on this?
22:13:38 <gmcharlt> not specifically, yet
22:13:45 <tcohen> a lot has been said about current DOM configuration not being complete (lists, IRC)
22:14:00 <tcohen> i'd like to have specific bugs filled from those parties
22:14:12 <tcohen> all linked to the deprecation one
22:14:27 <gmcharlt> one moment
22:15:07 <tcohen> "removing GRS-1 indexing in favor of DOM, first steps: coding guideline, omnibus bug for tracking what needs to be done (remaining issues, needed changes, etc.)"
22:17:11 <gmcharlt> bug 12641
22:17:12 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12641 enhancement, P5 - low, ---, gmcharlt, NEW , Formally deprecate the GRS-1 indexing mode
22:17:21 <gmcharlt> tcohen: and we already have proposed wording for hte coding guideline
22:17:37 <tcohen> excellent!
22:18:12 <gmcharlt> the immediate step, as I see it, is that at this point, no further patches should be accepted into master that touch the GRS-1 config, with the exception of anything that is meant to be backported to fix an indexing bug
22:18:33 <tcohen> +1
22:19:24 <gmcharlt> #info The omnibus bug for deprecation of the GRS-1 indexing mode is 12641
22:20:21 <gmcharlt> any other comments
22:20:36 <gmcharlt> or any objections to adopting the new coding guideline?
22:20:37 <tcohen> we should provide a tools (for packages at least) to move
22:20:54 <tcohen> either migrating the current (if anyone volunteers)
22:20:59 <tcohen> or just a default config
22:21:10 <tcohen> but we will discuss that on the bugs I guess
22:21:13 <gmcharlt> yeah
22:21:36 <gmcharlt> (and we actually already have most of what we need to manage the index migration)
22:22:11 <tcohen> make_zebra_dom_cfg_from_record_abs
22:22:12 <wahanui> make_zebra_dom_cfg_from_record_abs is a script to migrate from grs-1 to dom, so it ie same of the last thing to do
22:22:24 <gmcharlt> exactly
22:23:27 <gmcharlt> ok
22:23:31 <gmcharlt> since I've heard no objections...
22:23:53 <gmcharlt> #agreed Koha adopts a new coding guideline per http://paste.lisp.org/display/14321 to deprecate the GRS-1 indexing mode
22:24:27 <gmcharlt> and rather than have an action item... one moment please
22:24:40 <pianohacker> tcohen: as a clarification, would this migrate custom indexes
22:24:42 <pianohacker> ?
22:24:58 <tcohen> we could provide a tool for that
22:25:11 <tcohen> it is almost there, just need to write the glue
22:25:22 <tcohen> i.e. make_zebra_dom_cfg_from_record_abs
22:25:38 <pianohacker> kk
22:25:39 <pianohacker> thanks
22:26:35 <gmcharlt> #info The new DEPR2 coding guideilne can be found at The DOM Zebra indexing mode is now the standard supported method for Koha.  The GRS-1 indexing mode is deprecated for all record types and MARC flavours.
22:26:35 <gmcharlt> New Koha patches that update index definitions must change the DOM indexing definitions.  If a patch is intended to be backported to a maintenance release, changes to GRS-1 index definitions should be kept in a separate patch.
22:26:44 <gmcharlt> gah
22:26:55 <gmcharlt> #info The new DEPR2 coding guideline can be found at http://wiki.koha-community.org/wiki/Coding_Guidelines#DEPR2:_The_GRS-1_Zebra_indexing_mode_is_deprecated
22:27:38 <gmcharlt> ok
22:27:39 <gmcharlt> moving on
22:27:54 <gmcharlt> #topic Coding guidelines - indentation in templates
22:28:43 <bgkriegel> 2 or 4?
22:28:43 <wahanui> 6
22:28:59 <gmcharlt> I think it's fair to say that there was no consensus reached at the first part of the meeting
22:29:15 <gmcharlt> and I think the discussion ought to be hashed out on the mailing list first
22:30:08 <tcohen> i agree we could make it on the list
22:31:11 <gmcharlt> yeah
22:31:30 <gmcharlt> #agreed further discussion about new or revised guidelines for whitespace to occur on the mailing list
22:31:51 <tcohen> i'd like to mention 12545, which could be used to make it easy to comply with the coding guidelines
22:32:05 <tcohen> whichever we find suit better
22:32:39 <bgkriegel> bug 12545
22:32:40 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12545 enhancement, P5 - low, ---, tomascohen, Needs Signoff , Add EditorConfig file to the source tree
22:33:07 <gmcharlt> #link http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12545
22:33:07 <huginn> 04Bug 12545: enhancement, P5 - low, ---, tomascohen, Needs Signoff , Add EditorConfig file to the source tree
22:34:04 <gmcharlt> #topic DBIC
22:34:07 <gmcharlt> #link http://wiki.koha-community.org/wiki/Examples_of_DBIC_in_Koha
22:34:14 <eythian> hi
22:34:15 <wahanui> niihau, eythian
22:34:20 <gmcharlt> the first part of the meeting basically punted the discussion
22:35:15 <gmcharlt> and to be honest, I'm inclined to punt as well
22:35:47 <tcohen> idiomatic issues here
22:35:56 <gmcharlt> sorry
22:36:02 <gmcharlt> punt == defer to the next dev meeting
22:36:05 <tcohen> ah
22:36:10 <gmcharlt> or discuss on the lsit
22:36:39 * gmcharlt slaps self for using an American football analogy
22:36:59 <pianohacker> that indentation bikeshed is gonna get a lot of comments
22:37:02 <tcohen> kck the ball
22:37:15 <tcohen> pianohacker: i know that one!
22:37:36 <gmcharlt> #topic Bugs
22:37:46 <gmcharlt> #info UTF-8 cleanup - bug 11944
22:37:47 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11944 major, P5 - low, ---, jonathan.druart, Needs Signoff , Cleanup Koha UTF-8
22:38:03 <gmcharlt> as part of the GBSD, Joubu and others have been doing some testing and found some minor issues
22:38:08 <gmcharlt> that I believe Joubu is working on
22:38:25 <tcohen> dpavlin was working on the search results front
22:38:54 <eternalsword> punts are also used in rugby if it makes you feel better.
22:39:24 <gmcharlt> eternalsword: thanks :)
22:40:21 * tcohen only speaks tennis
22:40:52 <gmcharlt> #info Test builder - bug 12603
22:40:53 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12603 enhancement, P5 - low, ---, yohann.dufour, Needs Signoff , TestBuilder - Module to simplify the writing of tests
22:40:58 <pianohacker> ooh
22:41:03 <gmcharlt> that one looks like a good candidate for folks to play with
22:42:17 <gmcharlt> #info renewing lost items - bug 9805
22:42:18 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9805 normal, P5 - low, ---, kyle, In Discussion , Lost items are un-lost if returned, but not if renewed.
22:42:56 <gmcharlt> my suggestion for 9805 is that somebody send a query to the general mailing list about the propsed changes
22:43:13 <gmcharlt> in an effort to identify policy preferences and/or edge cases
22:43:53 <gmcharlt> can somebody volunteer to do that (maybe first ask khall if he wants to)?
22:45:16 <pianohacker> khall would be the best candidate, I'd think
22:45:29 <tcohen> as the author of the patch, he'd be the best one to write it down
22:45:50 <gmcharlt> @later tell khall would you be willing to drop a note to the general mailing list soliciting input on library preferences for lost item handling (re bug 9805)?
22:45:50 <huginn> gmcharlt: The operation succeeded.
22:46:03 <gmcharlt> k, as you can see, I've made the request
22:46:22 <gmcharlt> are there other bugs that folks would like to emphasize?
22:46:41 <bgkriegel> input on bug 12477 will be most welcome
22:46:42 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12477 major, P5 - low, ---, gmcharlt, NEW , We need better ways to manage MARC Frameworks
22:47:15 <gmcharlt> #info Input requested for bug 12477 (better management of MARC frameworks)
22:49:21 <gmcharlt> OK, moving on
22:49:28 <gmcharlt> #topic "Big stuff we are working on"
22:51:17 <tcohen> i'm expecting to become a father by December, 21st. I'm making up my mind :-P
22:51:34 <gmcharlt> congrats!
22:51:41 <tcohen> :-D
22:52:16 <tcohen> thx
22:52:19 <gmcharlt> #info Feedback on GST RFC requested by end of August http://wiki.koha-community.org/wiki/GST_Rewrite_RFC
22:52:34 <gmcharlt> eythian: can you give an ES update?
22:52:45 <eythian> nothing much to report
22:52:59 <eythian> I've been distracted on a couple of migrations/new installations
22:53:40 <gmcharlt> fair enough
22:53:53 <gmcharlt> any other big projects?
22:54:25 <gmcharlt> ok
22:54:33 <gmcharlt> #topic Set time of next meeting
22:54:46 <gmcharlt> the first part of the meeting proposes  August, 5th, 15:00 + 22:00 UTC
22:54:51 <gmcharlt> comments?
22:54:51 <wahanui> comments are turned on
22:55:40 <bgkriegel> +1
22:55:55 <tcohen> +a
22:55:56 <tcohen> +1
22:56:17 <pianohacker> +1
22:57:10 <gmcharlt> #agreed The next development meeting will be August, 5th, 15:00 + 22:00 UTC
22:57:20 <gmcharlt> ok
22:57:24 <gmcharlt> thanks everybody!
22:57:27 <gmcharlt> #endmeeting