21:01:46 <gmcharlt> #startmeeting General meeting, 9 April 2014, part 2
21:01:46 <huginn> Meeting started Wed Apr  9 21:01:46 2014 UTC.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:46 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:46 <huginn> The meeting name has been set to 'general_meeting__9_april_2014__part_2'
21:02:00 <gmcharlt> #link http://wiki.koha-community.org/wiki/General_IRC_meeting_9_April_2014 Agenda
21:02:16 <gmcharlt> #link http://meetings.koha-community.org/2014/general_meeting__9_april_2014__part_1.2014-04-09-15.00.html Minutes from first part
21:02:30 <gmcharlt> #link http://meetings.koha-community.org/2014/general_meeting__9_april_2014__part_1.2014-04-09-15.00.log.html Log from first part
21:02:35 <gmcharlt> #topic Introductions
21:02:36 <wahanui> #info wahanui, a bot that has become sentient
21:02:46 <gmcharlt> #info Galen Charlton, 3.16 RM, Equinox, USA
21:02:53 <cait> #info Katrin Fischer, BSZ, Germany
21:03:18 <indradg> #info Indranil Das Gupta, L2C2, India
21:05:16 <cait> hm that could be a quick meeting
21:05:19 <gmcharlt> indeed
21:05:59 <cait> we should have a vote for something silly :)
21:06:20 <cait> don't go barton...
21:06:56 <barton_away> heh!
21:07:05 <gmcharlt> OK, give the small attendence, I'll start with repeating the most important announcements
21:07:09 <gmcharlt> #topic Announcements
21:07:19 * barton_away is *always* up for something silly.
21:07:23 <gmcharlt> #link http://lists.koha-community.org/pipermail/koha-devel/2014-April/040419.html Release schedule
21:08:19 <gmcharlt> #info 3.14 reelase schedule: 23 April - alpha release; 28 April - feature freeze; 30 April - beta release and soft string freeze; 5 May - firm string freeze; 19 May - RC cut; 22 May general release
21:08:43 <bag> #info Brendan Gallagher, ByWater
21:08:44 <gmcharlt> #info Folks will be trying to highlight the availability of sandboxes and the like to encourage testing of the beta
21:09:09 <gmcharlt> hmm, I think we can know swing the vote for the Official Sport of Koha to baseball! ;)
21:09:22 <bag> YES!!!
21:09:31 <bag> +many many many 1's
21:09:42 <thd> #info Thomas Dukleth, Agogme, New York City
21:09:43 <cait> heh
21:10:26 <gmcharlt> #link http://wiki.koha-community.org/wiki/Roles_for_3.18 Current 3.18 nominations
21:10:45 <gmcharlt> #info Galen will be posting a query regarding whether 3.12 and earlier releases will continue to be maintained
21:11:00 <gmcharlt> #link http://wiki.koha-community.org/wiki/Talk:What_does_a_module_maintainer_do module maintainer discussion
21:11:25 <gmcharlt> the next dev meeting is tenatively scheduled for 23 April, and project roles will be voted on there
21:11:45 <gmcharlt> I'm now thinking that 15/22 UTC may be better than 15/21 UTC
21:12:07 <cait> agreed
21:12:24 <barton> #info Barton Chittenden, ByWater
21:13:06 <gmcharlt> OK, unless there's an object, that's what I'll announce
21:13:29 <gmcharlt> #agreed Next dev meeting is scheduled for 23 April at 15:00 UTC and 22:00 UTC.  Voting for 3.18 project roles will take place then
21:13:31 <mtompset> #info Mark Tompsett
21:13:39 <bag> agreed
21:14:08 <thd> 22 UTC is a problem for me on the first Wed. of the month but I should not really need to attend both times.
21:14:47 <gmcharlt> at the first meeting we issued a call for volunteers to kick off the Koha 15 selection process
21:14:56 <gmcharlt> thd has volunteered, but can't get started until next month
21:16:04 <gmcharlt> and based on when we did it last year, that looks like it's soon eough
21:16:31 <gmcharlt> so thd, I guess you should plan on doing it
21:16:32 <thd> gmcharlt: Were you proposing to change next month's second time to 22 UTC or only the meeting for voting on roles?
21:16:44 <gmcharlt> thd: I think the general meeting as well
21:18:29 <gmcharlt> so speaking of which, the next general meeting was tentatively scheduled for 7 May at 15:00 / 21:00 UTC, but I suggest that the second part be scheduled for 22:00 UCT
21:18:34 <thd> OK, I should at least be present for the first time on the day and will plan on starting the process for KohaCon 15 next month.
21:18:35 <gmcharlt> thoughts?
21:19:11 <BobB> #info Bob Birchall, sorry I'm late
21:19:41 <bag> no comments - but I hope I still think
21:19:50 <gmcharlt> BobB: actually, you're just in time to answer a question regarding scheduling -- would 22 UTC work better for you rather than 21 UTC?
21:21:45 <thd> gmcharlt: I do not remember the consensus from the earlier meeting on how to further discussion defining the scope of module maintainer roles if such scope would even need to be defined.
21:22:18 <gmcharlt> I'll be moving the discussion to koha-devel, where it will have more exposure
21:22:39 <gmcharlt> but it also depends in large part on what structure tcohen wants to work with
21:24:45 <BobB> yes, 22 UTC is 8am, not 7
21:25:10 <BobB> yes gmcharlt, 22 UTC is 8am ,not 7
21:26:43 <cait> sounds a lot better
21:26:56 <BobB> :)
21:27:09 <gmcharlt> OK
21:27:22 * BobB is waking slowly
21:27:23 <gmcharlt> #agreed The next general meeting will be 7 May 2014 at 15/22 UTC
21:29:36 <gmcharlt> any other questions or discussions?
21:30:07 <BobB> I hope the first half was a little more active?
21:30:12 <mtompset> Mmm....
21:30:20 * mtompset goes hunting for agenda.
21:30:45 <cait> BobB: yes, I thimk we hit a better time there
21:31:17 <BobB> cool
21:31:32 <thd> BobB: Attendence was down at the earlier hour but more active than this presently.
21:31:56 <mtompset> Why do we have so many "active" versions of Koha?
21:32:07 <mtompset> 3.8, 3.10, ...
21:32:18 <cait> because we have module maintainers for those
21:32:35 <cait> as long as someone steps up, the version is maintained
21:33:03 <BobB> somepeople don't upgrade, there are forks etc
21:33:47 <mtompset> Is 3.8 the Windows XP of Koha?
21:33:50 <rangi> neither of those are really valid reasons though, basically maintaining a version while someone is willing to
21:33:53 <rangi> no
21:34:02 <gmcharlt> I have a preference for encouraging folks to not let themselves get too far behind
21:34:05 <rangi> 3.8 is only 2 years old
21:34:21 <rangi> and is no longer maintained anyway
21:34:39 <rangi> the last release was february
21:34:42 <gmcharlt> I think the big questions are 3.12 and possibly 3.10
21:35:25 <rangi> maintaining a version for 2 years seems pretty good to me
21:35:28 <BobB> the version one back from current should always be maintained, imo
21:35:51 <gmcharlt> yeah, I'd think stable and stable -1 would be the bare minimum
21:35:52 <rangi> if we want to get into debian proper and we do
21:35:53 <BobB> yeah, two years makes sense
21:36:02 <gmcharlt> which would translate to 3.16 and 3.14 upon the releae of 3.16
21:36:04 <rangi> we would need ot maintain for about that long
21:36:09 <gmcharlt> stable - 2 would be nice, as it's only 1.5 years back
21:36:30 <gmcharlt> but it does depend on (at least) a rmaint for 3.12 stepping up
21:36:35 <rangi> yep
21:37:18 <rangi> sorry for being late i was in a real life meeting
21:37:45 <BobB> rangi, this is real life!  :)
21:38:16 <gmcharlt> rangi: more generally, is 22 UTC preferable to 21 UCT for you?
21:38:22 <rangi> yes
21:38:29 <BobB> woot woot
21:39:13 <gmcharlt> OK, I'll do as I planned already, and put out a call for final nominations
21:39:20 <gmcharlt> with an emphasis on rmaints
21:39:32 <rangi> sounds good to me
21:39:39 <gmcharlt> rangi: thoughts on the MM discussion, or shall you just weigh in when I start a therad on koha-devel?
21:40:24 <rangi> basically that really they should work the way that the RM wants them to work, but that its vital they not short cut QA
21:41:08 <rangi> so if RM wants them to pick from things passed qa, push to master .. thats fine, if push to a branch, then merge to master fine too, the important step is that the QA role is still done
21:41:15 <rangi> but someone other than the person pushing
21:41:28 <rangi> thats my 2cents anyway
21:41:29 <cait> :) +1
21:41:29 <gmcharlt> other than /just/ the pesron pushing
21:41:43 <BobB> +1
21:41:44 <rangi> yep
21:43:10 <cait> I think the important bit is to have more people on the pqa witout reduing the eyes on a patch
21:43:15 <cait> if that makes sense
21:44:01 <gmcharlt> yep
21:44:25 <gmcharlt> OK, any final comments or topics?
21:46:16 <gmcharlt> OK, thanks everybody!
21:46:19 <gmcharlt> #endmeeting