14:59:17 <gmcharlt> #startmeeting Koha Dev Meeting, 25 February 2014 15:00 UTC
14:59:17 <huginn`> Meeting started Tue Feb 25 14:59:17 2014 UTC.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:17 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:59:17 <huginn`> The meeting name has been set to 'koha_dev_meeting__25_february_2014_15_00_utc'
14:59:29 <gmcharlt> #info Agenda http://wiki.koha-community.org/wiki/Developers_IRC_Meeting,_February_25,_2014
14:59:36 <gmcharlt> #topic Introductions
14:59:36 <wahanui> #info wahanui, a bot that has become sentient
14:59:46 <oleonard> #info Owen Leonard, Athens County Public Libraries
14:59:47 <marcelr> #info Marcel de Rooy, Netherlands
14:59:49 <gmcharlt> #info gmcharlt = Galen Charlton, 3.16 RM, Equinox, USA
15:00:17 <paul_p> #info Paul Poulain, BibLibre
15:00:18 <ashimema> #info Martin Renvoize, PTFS Europe
15:00:19 <Joubu> #info Jonathan Druart, BibLibre, France
15:00:20 <ColinC> #info Colin Campbell PTFS-Europe
15:00:32 <cait> #info Katrin Fischer, BSZ
15:00:33 <rhcl> #info rhcl = Greg Lawson, Rolling Hills Consolidated Library -ro
15:00:38 <fredericd> #info Frédéric Demians, Tamil
15:01:11 <thd> #info Thomas Dukleth, Agogme, New York City
15:01:44 <jajm> #info Julian Maurice, BibLibre, France
15:02:13 <matts> #info Matthias Meusburger, Biblibre, France
15:02:40 <slef> #info MJ Ray, software.coop, England
15:03:35 <gmcharlt> OK, folks can continue to chime in as they arrive
15:03:41 <gmcharlt> first, some annouceents
15:03:48 <gmcharlt> #topic Announcements
15:04:11 <gmcharlt> #info gmcharlt will be clearing the passed QA queue prior to the beginning of the hackfest in Marseille
15:04:42 <cait> gmcharlt++ :)
15:04:51 <gmcharlt> that means that I'm committing to push (or if need be in certain cases, reject) everything targetted for master  by then
15:04:53 <ashimema> gmcharlt++
15:04:54 <gmcharlt> to give a clear slate
15:05:10 <paul_p> gmcharlt++
15:05:29 <slef> #info the hackfest in Marseille is 10-14 March
15:05:30 <gmcharlt> after discussing this with cait, I'd like to request that for the next week, that QA team members focus on (1) needs-signoff and (2) kitten-rescue
15:05:30 <paul_p> gmcharlt what to you mean by "targetted for master" ?
15:05:33 <tcohen> #info Tomas Cohen Arazi, Universidad Nacional de Cordoba
15:05:50 <gmcharlt> paul_p: there are one or two in passed-QA that are targetted for maintenance branches
15:06:14 <marcelr> no further new qa's you mean?
15:06:20 <gmcharlt> a 3.8.x one, in fact, although I think khall tried applying it but ran into trouble with it
15:06:27 <gmcharlt> not sure of the details
15:06:42 <gmcharlt> marcelr: yes - let's say end of day tomorrow as a cutoff for new passed QA if you're in the middle of something?
15:06:52 <cait> gmcharlt:  I think continuing on things you are in the midst of should be ok, but not starting on new patches?
15:06:53 <huginn`> New commit(s) kohagit: Bug 11803: use $dbh consistently in _koha_modify_item <http://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;h=a07b32f4f9090ba0c50c3e510f0be56b8805faeb>
15:07:22 <gmcharlt> are there any other announcements folks wish to make at this time?
15:07:47 <cait> i thik we can add another #agreed for the cutoff :)
15:07:51 <cait> or info
15:07:56 <gmcharlt> cait: go for it
15:08:25 <cait> #info end of tomorrow will be cutoff for new passed QA until the hackfest in Marseille, QA team to focus on sign offs and kitten rescue
15:08:27 <paul_p> gmcharlt = do you think you'll have time to deal with the 84 waiting patches before the hackfest ?
15:08:38 <gmcharlt> paul_p: it's going to be my sole focus for Koha work
15:08:51 <jcamins> #info Jared Camins-Esakov, C & P Bibliography Services
15:08:54 <paul_p> gmcharlt = would it be wise to start by new feature/enh ? so hackfest participant can concentrate on testing master ?
15:08:57 <gmcharlt> (unless security issues intervene)
15:09:39 <gmcharlt> paul_p: I'm going to be doing the small fry first, then go to enh
15:09:42 <gmcharlt> enh/new
15:10:03 <gmcharlt> i.e., oleonard's DataTables stuff won't take much time in any event
15:10:04 <gmcharlt> btw
15:10:05 <jenkins_koha> Starting build #362 for job master_maria (previous build: SUCCESS)
15:10:11 <gmcharlt> oleonard++ # cleanup wizard
15:10:44 <cait> oleonard++
15:10:49 <gmcharlt> the next thing I'm going to do is to toss out some general questions
15:10:50 <cait> #thx for adding consistency to everything
15:10:58 <gmcharlt> they do *not* require an immediate response
15:11:03 <gmcharlt> #topic RM questions
15:11:28 <gmcharlt> #info What is the state of UNIMARC/DOM Zebra indexing? Are UNIMARC users ready to adopt it?
15:11:45 <gmcharlt> #info How many folks are using QueryParser in production?
15:12:10 <gmcharlt> #info Is deprecating GRS-1 a viable option for 3.16?
15:12:20 <paul_p> gmcharlt = I'll add the unimarc topic for the hackfest. We will have many french unimarc librarians at hand to test ;-)
15:12:27 <gmcharlt> paul_p++
15:12:41 <marcelr> anyone using SRU with DOM indexing ?
15:12:55 <cait> paul_p: my impression was there are still some bugs to shake out, but might not be hard to fix
15:12:56 <ashimema> gmcharlt, I'd love to see GRS-1 go the way of the dodo.
15:12:56 <gmcharlt> #agreed paul_p will add discussion/testing of UNIMARC Zebra-DOM to Marseille hackfest
15:13:02 <jenkins_koha> Starting build #1644 for job Koha_master (previous build: SUCCESS)
15:13:09 <gmcharlt> #info anyone using SRU with DOM indexing ?
15:13:18 <ashimema> marcelr, we have a few customers using SRU with DOM.. i believe
15:13:23 <gmcharlt> marcelr: are you seeing any issues with it?
15:13:34 <tcohen> SRU+DOM+UNIMARC?
15:13:43 <marcelr> i tried some time ago and it did not work at that time (out of the box or so)
15:13:47 <ashimema> not unimark from us.
15:14:21 <ashimema> I believe I had to modify at least one config file to get it outputting a sensible format.. it was outputting plain indexes to start with.
15:14:24 <gmcharlt> #info Is anybody actively testing or developing on Debian Jessie at the moment?
15:14:29 <cait> marcelr: I think there might have been a fix for that, worth trying again maybe
15:14:33 <ashimema> i can't remember the details.. it was a while ago and hasn't come up again since
15:14:36 <paul_p> gmcharlt = added to workshop list : "DOM indexing in UNIMARC We must test DOM indexing in UNIMARC to see if GRS-1 can be deprecated. Some patches pushed"
15:14:47 <gmcharlt> paul_p++
15:14:50 <wajasu> should ICU be the default oor such, if or when GRS1 goes away? or is there search value in CHR?
15:15:07 <cait> I'd be for ICU by default
15:15:10 <cait> a lot of libraries stumble on that
15:15:14 <paul_p> ICU by default++
15:15:16 <ashimema> icu for default... ++
15:15:20 <ColinC> One issue with Jessie may be that Queryparser's tests fail on newer perls
15:15:23 <tcohen> +1
15:15:27 <gmcharlt> is there a singular ICU config that folks like?
15:15:46 <cait> OpacSuppression + Queryparser don't work, that's kind of a blocker for the library that we tested it with
15:15:51 <gmcharlt> or shoudl we consider going a bit further to generate language-of-record specific configs that folks can use sysprefs to select?
15:16:20 <paul_p> Franziska = hello. Just seen your email now. happy to see that you could fix the problem to join us
15:16:21 <gmcharlt> ColinC: indeed - it's heavily depending on hash sort order, for some reason
15:17:14 <cait> paul_p: maybe testing QueryParser could also be a topic for the hackfest?
15:17:30 <gmcharlt> also - folks, please feel free to chime in on proposing these sorts of architectural/deprecation/compatbility questions now
15:18:00 <ashimema> testing QueryParser has been on my todo list for a while now, I'de be happy chipping in testing at hackfest should it become a topic
15:18:05 <Franziska> Hello from Koha Gruppo Italiano - Rome
15:18:14 <cait> the librarian testing force is strong at the hackfest usually
15:18:23 <cait> they have done some great testing int he past, also with plack
15:18:42 <tcohen> gmcharlt: do u think 11096 could be ready for 3.16?
15:18:51 <marcelr> bug 11096
15:18:52 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11096 major, P5 - low, ---, gmcharlt, Signed Off , Koha cannot retrieve big records from Zebra
15:19:07 <gmcharlt> #info is there a reasonable Plack configuration that we could include in 3.16, and encourage as a first-class install option?
15:19:21 <gmcharlt> tcohen: in a word, yes
15:19:42 <cait> gmcharlt: i think most use the out of the box icu now, but there is a wiki page on how to tweak it for arabic
15:20:08 <cait> gmcharlt: we had added some additional rules for umlaut indexing in the past, not sure how flexible configuration can be made here
15:20:21 <jcamins> I use the out-of-the-box configuration.
15:20:34 <jcamins> (for ICU, FWIW)
15:20:39 <gmcharlt> cait: OK, I"m going to tweet a request for folks to add their custom ICU configs to the wiki page
15:21:00 <ashimema> we use out of the box icu configs in lots of places.
15:21:17 <ColinC> ICU out of the box handles arabic cyrillic and chinese fairly well
15:21:30 <cait> gmcharlt: can we add icu by default as a question? or did i miss it?
15:21:47 <ashimema> gmcharlt.. I spent a fair bit of time testing the Plack during install bug on bugzilla.. It had a few issues.
15:21:57 <clrh> #info Claire Hernandez, BibLibre, France (late sorry)
15:22:02 <paul_p> gmcharlt = we have a working plack configuration at SAN-OP
15:22:26 <gmcharlt> ashimema: did you write up the issues?
15:22:34 <jcamins> I use ICU mostly for Russian, Arabic, and Hebrew.
15:22:53 <gmcharlt> paul_p: did you write up the config anywhere?
15:23:00 <cait> we use it with hebrew, out of the box icu, no complaints so far
15:23:01 <paul_p> for both OPAC & staff. We faced one problem with it though = we restarted plack every night, and sometimes, it stopped badly, and did not restart
15:23:04 <gmcharlt> all: did you write up the FOO anywhere? ;)
15:23:11 <ashimema> bug 9316
15:23:12 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9316 enhancement, P5 - low, ---, kyle, Needs Signoff , Add Nginx install options with plack
15:23:15 <paul_p> gmcharlt = not sure, will check & wiki-fy it
15:23:34 <gmcharlt> ashimema: thanks
15:24:01 <paul_p> both plack config & nightly crontab script
15:24:08 <ashimema> I need to look into it again.. not checked for a while.. i'll try to take a look between this meet and the next ;)
15:24:21 <cait> #info Can we make ICU indexing default for new installations?
15:24:30 <ashimema> nothing major.. just minor gripes really.
15:24:32 <cait> so it doesn't get lost :)
15:24:33 <ashimema> from memory
15:25:11 <gmcharlt> OK, I'm going to try to keep the meeting to an hour, so I'm going to move on
15:25:18 <gmcharlt> #topic ElasticSearch
15:25:34 <gmcharlt> it looks like we have two different ElasticSearch projects going on
15:25:47 <gmcharlt> and ... for obvious reasons it would be great if the efforts were coordinated
15:25:50 <paul_p> Franziska = look, it's for you now !!!
15:26:04 <gmcharlt> I imagine the NZers will be participating in the second version of this meeting today, of coruse
15:26:38 <paul_p> gmcharlt = what do you mean by "2 projects going on" ?
15:26:51 <Franziska> Great! Stefano will present the project in Marseille. Please join us on March 11th
15:27:19 <ashimema> Agreed, we need some collaboration going on this.
15:27:20 <paul_p> because what italians announced is not -yet- a project with code. It's a project to see how things could/should be done, and -try to- fund it
15:27:22 <Franziska> Additional information will be available on http://www.kohagruppoitaliano.moonfruit.com/ shortly
15:27:53 <paul_p> so it's not too late to coordinate. It's the perfect timing I think.
15:27:58 <ashimema> Franziska, are you in touch with Chris et al?
15:28:17 <paul_p> gmcharlt = the "other" ES project is made by chris & sponsored by bywater, isn't it ?
15:28:25 <gmcharlt> yes
15:28:32 <Franziska> No not yet, but we really hope to work with him on this project
15:28:47 <gmcharlt> and since it has code developing, it's going to set the tone
15:28:59 <gmcharlt> so Franziska, I *strongly* encourage you to get in touch with Chris ASAP
15:29:01 <paul_p> gmcharlt = so I hope things will be coordinated, because the "italian" project have American University in Rome, that is a ByWater customer !
15:29:10 <Franziska> Our goal is to help the community to make it happen
15:29:40 <cait> Franziska: being in NZ they won't make it to the hackfest in Marseille
15:30:11 <gmcharlt> they also tend to use IRC a lot; I recommend that you hang out in #koha
15:30:21 <Franziska> we are not assisted by Bywater...Stefano is in charge of our catalog
15:30:23 <cait> I think it would be great to see this worked out - funding and development :)
15:30:50 <Franziska> we are independent. Bywater is in charge of the American Academy's catalog.
15:30:59 <gmcharlt> right
15:31:16 <paul_p> Franziska oups, sorry, failed once again between AAR and AUR ...
15:31:33 <paul_p> I'll be successful one day... (maybe not this year :D :D )
15:31:48 <gmcharlt> paul_p: then we'll throw more acronyms at you
15:31:53 <gmcharlt> just to keep you on your toes ;)
15:31:59 <Franziska> For us it is a important to work out the way between funding and development
15:32:04 <paul_p> ABR ? ACR ? ADR ? AER ?
15:32:13 <cait> rangi left a note on the agenda - saying they will try to have something to play with for the hackfest
15:32:24 <gmcharlt> that should help
15:32:27 <cait> maybe this can help see where things are going and help getting started on coordination
15:32:34 <Franziska> what we essentially do is to promote Koha in Italy
15:33:06 <paul_p> what annoys me is that it seems that the work we made on solr won't be re-used at all. And I think/feel it's a shame.
15:33:13 <paul_p> (energy lost)
15:33:23 <paul_p> (not because we wrote it)
15:33:27 <Franziska> Sorry, my mistake - the promotion goes over the world
15:33:42 <marcelr> paul_p couldn't that be rescued somehow?
15:33:57 <clrh> marcelr: things are pushed in master
15:34:21 <clrh> marcelr: there is a base to wrote more things on many search engin as you want...
15:34:23 <ashimema> Franziska... do you guys have plans for A) Where the money should be coming from and B) What developers your hoping to employ to do the work.  I'm just thinking it should probably go to one of the bigger players already working in searhc for koha, as aposed to somone new implimenting in yet another way..
15:34:32 <ashimema> basically what paul_p just said ;)
15:35:08 <Franziska> The community has to choose amoung Solr and ElasticSearch
15:35:19 <paul_p> marcelr = I feel it could, I sent an email to rangi about that, and got no feedback.
15:35:35 <marcelr> unfortunate
15:36:11 <paul_p> Franziska = the best would be to have an search layer independant from any search engine. So we can plug ES, Solr, Zebra, whatever
15:36:29 <gmcharlt> I think it's fair to say that there's been an long-running technical disagreement about that.  There's no need to rehash it now, but I expect that once the ES stuff for testing at Hackfest is available, it may clarify things
15:36:54 <cait> also people from ByWater will be there
15:37:19 <cait> who have been working with Catalyst IT to make it happen
15:37:26 <paul_p> gmcharlt which one ? not clear to me (except the fact that we started to REPLACE zebra by solr, and the community wanted to have a CHOICE)
15:37:31 <Franziska> Koha Gruppo Italiano has no conflict with choice
15:38:04 <paul_p> gmcharlt and maybe another one with Moose, but not worth forgetting everything we made I think
15:38:33 <thd> paul_p: Could some of BibLibre work on the user interface for user configurat‭ion of indexing not be taken from the Solr/Lucene work and added to Elastic Search.
15:38:38 <thd> ?
15:39:13 <paul_p> thd = I really don't know. Everything is in master, we're open to questions.
15:39:32 <clrh> thd: erf do not understand the question ><
15:39:53 <gmcharlt> I actually think that's going to be a big question for 3.16 or possibily 3.18 -- how much of the Koha::SearchEngine stuff will remain
15:39:56 <Joubu> thd: the Solr config page (the one in master) can be used for ES too.
15:40:07 <gmcharlt> because, ATM, it's code that isn't actively used
15:40:15 <paul_p> right.
15:40:27 <paul_p> I don' tthink it's a reachable goal for 3.16
15:40:36 <paul_p> for 3.18, it should be a goal.
15:41:01 <cait> maybe we could do experimental
15:41:09 <gmcharlt> I'm actually hoping that the question gets settled by 3.16 - at least in terms of our having a pretty good idea about what parts will be staying in for the long run
15:41:10 <cait> if it doesn't break anything, nto sure how far they are
15:41:22 <thd> The issue would be for a librarian interface to control how the indexing functions.
15:41:43 <cait> oh, i misunderstood... i thought elastic search going in
15:41:46 <cait> not reading fast enough
15:41:51 <gmcharlt> considering that two piece of completely dead code contributed to the security release recently -- I'm feeling a bit less lenient about keeping in code that isn't used
15:42:15 <gmcharlt> cait: we'll see about when ES goes in - it's a bit too early to know for sure
15:42:45 <gmcharlt> *however* - I think we've exhausted this topic for now until the later meeting
15:42:50 <gmcharlt> so going to move on
15:42:59 <slef> I've some of the same concerns about ES as Solr. It's another Java app so another complication for Koha servers.
15:43:50 <gmcharlt> yeah, I think there will be a place for fast, self-contained search engines for a while yet
15:43:55 <gmcharlt> #topic DBIx::Class
15:44:10 <gmcharlt> so I think one of the issues here is this
15:44:16 <gmcharlt> how much abstraction to use
15:44:27 <wajasu> can we get the entire DB API coded in a test for DBIx and possibly reconcile historical names (borrower vs member, issue vs ...)  Then code won't bubble that up into the UI with varying concepts
15:44:44 <gmcharlt> the current DBIC suppport already provides basic data access classes
15:45:24 <gmcharlt> my current thinking is that for simple things, the DBIC schema classes can safely be used directly
15:45:42 <gmcharlt> and that we should interpose container classes only when needed
15:45:59 <gmcharlt> for example - the concept of a bib is one that I think lends itself to such an intermediate class
15:46:13 <gmcharlt> particularly since we're contemplating doing things like merging biblio and biblioitems
15:46:14 <ColinC> They are intended to give you usuable objects
15:46:24 <paul_p> gmcharlt my counter comment is "how will anyone know what it 'simple' and what is not" ? for newbies, won't it be less readable ?
15:46:43 <gmcharlt> but things like authorised values? I see less of a reason write wrapper classes
15:46:57 <gmcharlt> (though more scope to add methods to the base DBIC schema class if called for)
15:47:00 <paul_p> having the same container schema everywhere may be a little bit boring to write, but changes nothing to readability or efficiency, and will be clearer
15:47:14 <marcelr> lots of relative empty classes
15:47:15 <paul_p> and what if one day something simple become no more simple ?
15:47:25 <marcelr> create a class
15:47:27 <cait> more code to maintain
15:47:50 <gmcharlt> yes, piling on more code to maintain is not my preference
15:48:08 <gmcharlt> and too many layers of delegation can impose a performance penalty
15:48:40 <paul_p> gmcharlt the perf penalty is small (and tiny with plack)
15:48:50 <Joubu> In my opinion, if the code is easy to understand, it is not a problem to have more code
15:48:57 <ColinC> would be a good idea to do some concentrated work on an area of the application and learn a bit
15:49:03 <Joubu> Is there already an example on how to implement an OO class using DBIC into Koha?
15:49:17 <gmcharlt> paul_p: I do agree, however, that some syntactical sugar would be nice to get a schema class with less typing would be nice
15:49:24 <gmcharlt> schema object, rather
15:49:57 <gmcharlt> Joubu: well, the basic DBIC objects aren't hard to understand
15:50:10 <Franziska> I am leaving the meeting,Thank you for your attention.
15:50:39 <gmcharlt> so I don't per se see that more layers improve readability /necessarily/
15:50:50 <gmcharlt> I could be swayed by a specific counter-example
15:51:01 <gmcharlt> ColinC: yeah, that seems sensible
15:51:02 <Joubu> gmcharlt: I already submit propositions and all have been rejected, I just would like someone to show me how to do
15:51:22 <Joubu> Moreover, should we (QA team) authorize to use DBIC directly in pl scripts, or only in packages in the Koha namespace?
15:51:23 <wajasu> but should we provide   getRenewal vs. ???      wrap only were needed.   if we write good tests for the data access "API", we can NYTProf and such and make it solid the layer testable.
15:51:41 <cait> I think maybe some notes, good practice examples ont he wiki would help to clear confusion
15:52:02 <marcelr> Joubu i think we wanted to use them from the Koha namespace?
15:52:06 <cait> the RFC on the wiki is not quite what we have right now I think
15:52:09 <marcelr> only
15:52:27 <ColinC> The logic would be to use the objects directly in .pl scripts DBIC does the hiding of DBI for you
15:52:28 <Joubu> marcelr: it is not everybody's opinion
15:52:43 <gmcharlt> Joubu: IMO, direct use of DBIC in scripts is fine
15:52:47 <marcelr> ColinC: now we move them to modules
15:53:11 <vfernandes> hi :)
15:53:20 <marcelr> but it is just theory; in many cases you will need the module
15:53:23 <gmcharlt> one second, digging up an example of something
15:53:32 <paul_p> examlpe++
15:53:35 <ColinC> adding an extra layer adds a place to add complucations and bugs
15:54:00 <vfernandes> one question: i have a koha installation with 5 libraries... it's possible to block the user access to only some of that libraries?
15:54:14 <marcelr> this extra layer is now in C4?
15:54:15 <Joubu> gmcharlt: yes, I know :) But I disagree :)
15:54:29 <cait> vfernandes: can you waita bit longer? we are currently havign a meeting and it's hard to concentrate on 2 things atonce :)
15:54:42 <vfernandes> sorry :)
15:56:01 <gmcharlt> ok, didn't find what I was looking for
15:56:20 <gmcharlt> however, I agree with the general point that we need specific examples of recommended usage
15:56:25 <marcelr> the move from C4 to Koha is now interfering with the DBICifying
15:56:45 <gmcharlt> so I'll add that as a topic the March 5 meeting and work some up
15:56:47 <ColinC> how?
15:56:56 <cait> marcelr: there is not so much in Koha yet, maybe the newer ones could just use it?
15:57:07 <cait> marcelr: when we need one that is
15:57:10 <gmcharlt> #action gmcharlt will work on some DBIC examples; requests others to experiment as well
15:57:30 <marcelr> should we refrain from adding DBIC into C4 ?
15:57:57 <wajasu> for what was generated in master, did someone get that "work around" DBIC_????? flag out and was the schema adjusted to make DBIC happy (NULL foreign keys)?
15:58:18 <ashimema> i feel the line between C4 and Koha has become rather hazy at best.. I often find myself a bit confused as to where something should go now.
15:58:31 <gmcharlt> wajasu: yes
15:58:36 <wajasu> great
15:58:41 <marcelr> true and it will probably stay for some time :)
15:58:44 <cait> i feel new modules into Koha ideally, but harder to tell when just adding new bits and pieces
15:59:49 <ColinC> I think the difference is Koha modules have less history to support  the are meant to be new thought
16:00:10 <Joubu> gmcharlt: Note: I encountered an issue on writing UT for bug 8007 (cf patch UT). The transaction does not work, we use 2 handlers on the same DB
16:00:12 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=8007 enhancement, P5 - low, ---, jonathan.druart, Needs Signoff , Discharge management
16:00:57 <marcelr> i also submitted a report this afternoon on some warnings on the connect bug 11835
16:00:58 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11835 normal, P5 - low, ---, gmcharlt, NEW , Warnings from DBIx about Moo::_Utils and Class::XSAccessor in Koha::Schema
16:03:52 <cait> we are getting close to the hour now - maybe we need to talk about having another meeting/actions?
16:04:12 <gmcharlt> indeed
16:04:20 <gmcharlt> but very breifly, first
16:04:21 <wajasu> i did successfully code tests with http://search.cpan.org/~chisel/Test-DBIx-Class-Schema-1.0.2/lib/Test/DBIx/Class/Schema.pm
16:04:26 <gmcharlt> #topic Large enhancements
16:04:30 <gmcharlt> here's what I know of
16:04:37 <gmcharlt> #info Rancor (cataloging editor)
16:04:46 <gmcharlt> #info ElasticSearch
16:04:49 <gmcharlt> what else?
16:04:54 <cait> hm Accounts rewrite?
16:04:55 <wajasu> account rewrite
16:05:06 <paul_p> gmcharlt = how do you define "large" ?
16:05:12 <cait> #info Accounts rewrite
16:05:29 <Joubu> I have a lot of "large" enh in the queue
16:05:54 <gmcharlt> paul_p: in this case, things that would require special effort to for signoff and QA by their nature
16:06:11 <marcelr> when is the cutoff date?
16:06:18 <cait> maybe we can add the multi transports as well
16:06:29 <Joubu> bug 7180
16:06:30 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7180 enhancement, P5 - low, ---, jonathan.druart, Signed Off , Order from staged file improvements
16:06:33 <Joubu> bug 9016
16:06:35 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9016 enhancement, P5 - low, ---, jonathan.druart, Signed Off , Multi transport types for notices
16:06:38 <bag> morning
16:06:39 <wahanui> hmmm... morning is a state of cat
16:06:46 <Joubu> bug 10212
16:06:47 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10212 enhancement, P5 - low, ---, jonathan.druart, Signed Off , Columns configuration for tables
16:06:55 <Joubu> the history search
16:07:04 <Joubu> bug 10858
16:07:05 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10858 new feature, P5 - low, ---, jonathan.druart, Signed Off , Browse selected biblios
16:07:23 <cait> Joubu:  big enhancements, but bit smaller than the other 3 i think, thankfully
16:07:28 <marcelr> Joubu: bug 10858 will have my attention again very soon
16:07:52 <cait> smaller is good in that case
16:07:54 <marcelr> hopefully before end of tomorrow :)
16:07:57 <Joubu> cait: yes but they require special effort for so and qa
16:08:16 <jenkins_koha> Project master_maria build #362: SUCCESS in 1 hr 0 min: http://jenkins.koha-community.org/job/master_maria/362/
16:08:17 <jenkins_koha> Marcel de Rooy: Bug 11803: use $dbh consistently in _koha_modify_item
16:08:18 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11803 trivial, P5 - low, ---, m.de.rooy, Pushed to Master , Consistent use of $dbh in _koha_modify_item
16:08:19 <thd> What is involved in a 'special effort' for signoff?  What distinguishes a 'special effort'?
16:08:23 <Joubu> bug 9011 is quite large too
16:08:24 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9011 enhancement, P5 - low, ---, kyle, In Discussion , Add the ability to store the last patron to return an item
16:08:25 <gmcharlt> marcelr: I'm not setting a firm cutoff date just yet, but will do so by the March 5 meeting
16:08:31 <Joubu> bug 9811
16:08:32 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9811 enhancement, P5 - low, ---, jonathan.druart, Needs Signoff , Patrons search improvements
16:08:37 <marcelr> gmcharlt: ok
16:08:38 <cait> thd: everything gets special effort from the QA team ;)
16:08:45 <marcelr> :)
16:08:52 <wajasu> what about considering enduser migration from squeeze to wheezy.   or mysql vs postgres vs mariadb
16:08:59 <gmcharlt> thd: it's a bit of a gut feeling
16:08:59 <cait> thd: but some things are harder, like touching lots of functionality, sensitive spots like holds, etc
16:09:16 <marcelr> wajasu: isn't that linked to the dbic efforts..
16:09:20 <gmcharlt> but basically, something that isn't just an incremental additional to existing functionality
16:09:29 <cait> gmcharlt: i think another thing we need to fix eventually is the apache configuration for the new apache version
16:09:35 <gmcharlt> most of Joubu's aren't quite so "large"
16:09:46 <gmcharlt> (they're important, though, I'm not trying to minimize that)
16:10:07 <gmcharlt> wajasu: I don't know of any particular blockers for folks to upgrade to Wheezy
16:10:14 <gmcharlt> and they should do so soon, as Squeeze will be going away
16:10:30 <gmcharlt> MariaDB is already a valid option, IMO
16:10:46 <clrh> gmcharlt: not sure to understand what you are waiting for with this topic
16:10:49 <wajasu> I am running mariadb on archlinux now so can test that.
16:10:52 <ashimema> wajasu, we've updated lots of squeeze to wheezy.. none had any issues.
16:10:55 <gmcharlt> as far as Pg, it will be more better in 3.16, but I don't expect it to be a first-class option prior to 3.18 at the earliest
16:11:08 <gmcharlt> clrh: what I"m looking for is this, basically
16:11:17 <cait> we are using wheezy, i just checked
16:11:35 <gmcharlt> #info what big Koha dev projects have people been working on that they might like to get included soon, that they haven't really publicized or made avaialble for early testing
16:12:00 <gmcharlt> and I think we can leave it at that
16:12:05 <gmcharlt> #topic Follow-up
16:12:37 <gmcharlt> #info There will be a second running of today's meeting at 21:00 UTC
16:12:56 <gmcharlt> as far as follow-up, are folks amenable to an IRC meeting during hackfest?
16:12:57 <ashimema> I've been working on a refactoring of the patron import tools.. to introduce a command line version.. but it's not close to ready yet..
16:13:17 <cait> i think if it's not too late and interfering with lunch...
16:13:22 <gmcharlt> :)
16:13:25 <wajasu> i want to add font configuration support for  unicode fonts that support many languages like gentium/SIL and that can be used to print labels (TTF) as dobrivica is promoting.
16:13:26 <ashimema> gmcharlt.. a followup during hackfest sounds like a pretty good idea.
16:13:38 <gmcharlt> paul_p: what say you?
16:15:01 <wajasu> aybe for plack it might be doable to support/use systemd for servers, and that might give us a watchdog to restart our server if it crashes.
16:15:10 <paul_p> sorry, was with my kids. reading the logs...
16:15:35 <gmcharlt> the immediate question is my proposal to hold a follow-up dev IRC meeting during hackfest
16:15:42 <paul_p> yep, another meeting diring the hackfest is a good idea
16:15:46 <gmcharlt> maybe include Google Hangout and the like as an option
16:16:05 <gmcharlt> are there any days that are best during hackfest?
16:16:08 <Joubu> ashimema: we have worked on that too
16:16:19 <Joubu> (patron import tools)
16:16:19 <ashimema> question: is anyone working towards bug 8190 going in?
16:16:21 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=8190 enhancement, P5 - low, ---, jonathan.druart, Passed QA , Add a logging module to Koha
16:16:25 <paul_p> gmcharlt HG++, we use it all the time,
16:16:40 <paul_p> gmcharlt not monday nor friday. I would say wed
16:16:54 <paul_p> monday = not everybody here. friday= some already left.
16:17:02 <paul_p> tuesday = let's start
16:17:23 <paul_p> wed or thu = we're full power :D
16:17:26 <ashimema> Joubu.. we should chat.. I've been following the various open bugs and merging in stuff.. but my work is high refactoring so didn't want to publicise it untill at least some of it works ;)
16:17:27 <gmcharlt> does 15:00 UTC on 12 March work, then?
16:17:37 <clrh> ashimema: passed qa for 8 months what are you looking for ? Joubu worked on this bz
16:17:44 <gmcharlt> ashimema: Joubu: great, that's exactly the sort of thing I want to see
16:18:18 <cait> paul_p: wed or thu sound good to me too
16:18:25 <matts> ashimema, do you already have a BZ for that work ?
16:18:26 <gmcharlt> clrh: and to be blunt - it needs work; IMO a logging module that does not include syslog support right away, and reinvents standard CPAN modules, was problematic
16:19:07 <ashimema> not yet.. I'll put one up soon iminently.. was one of those things.. I started playing around with it and got lost in the details.
16:19:13 <Joubu> gmcharlt: so the status is failed qa?
16:19:31 <clrh> gmcharlt: but it adds value no ?
16:19:34 <gmcharlt> Joubu: IMO yes, and I apologize for not being more direct about it
16:20:06 <ashimema> gmcharlt, clrh: I'd love to see some decent logging in koha.. my recollection was that gmcharlt was going to post an counter proposal..
16:20:14 <wajasu> i was looking at Badger  maybe Badger::Log
16:20:17 <Joubu> gmcharlt: I didn't reinvent CPAN module, I used Log::LogLite anyway
16:20:24 <gmcharlt> clrh: adding value isn't the only criteria
16:20:34 <gmcharlt> ashimema: yes; time has gotten away form me
16:20:50 <clrh> gmcharlt: depends the point of view
16:20:53 <ashimema> okies.. no worries.. jsut wondered on status and thought today a good time to give it a nudge ;)
16:21:14 <gmcharlt> clrh: long-term supportability matters too, and in this case, there are better ways to do it
16:21:15 <marcelr> sounds more like In Discussion than Failed QA
16:21:19 <cait> clrh: i think the statsu shoudl probably have been In Discussion
16:21:25 <Joubu> gmcharlt: In my opinion, if a patch improves the existing code/behavior, it is worth pushing it.
16:21:28 <cait> as a lot of people have expressed concerns on the implementation
16:21:42 <clrh> for me adding value for a user a developper is time won - if it is better than today, what is the problem ?
16:21:49 <Joubu> gmcharlt: if it is not perfect, it could be improve later
16:21:50 <ashimema> too many ways to skin a cat.
16:21:54 <gmcharlt> Joubu: this is where we have a disagreement
16:22:03 <gmcharlt> please consider the concept of technical debt
16:22:18 <wajasu> we have alot of debt
16:22:26 <marcelr> :)
16:22:27 <gmcharlt> I woudl argue that we've incurred much more of it than we need to because of being a bit too willing to push anything that reaches us
16:22:31 <ashimema> that we do..
16:22:40 <gmcharlt> but I recognize that there's a balance
16:22:44 <gmcharlt> and room for valid disagreement
16:22:54 <thd> gmcharlt: What is mnt by 'technical debt'?
16:22:57 <Joubu> gmcharlt: I am quite reactive, I think. And I can provide follow-up quickly if it is needed. It is really hard to maintain 80 patches and to rebase them every weeks.
16:23:03 <ashimema> sorry.. didn't mean to start a war ;)
16:23:06 <thd> s/ment/meant/
16:23:20 <gmcharlt> thd: bascially, deferred technical maintenance on a codebase
16:23:35 <gmcharlt> the C4 => Koha switch is an example of a project to try to pay off some of that debt
16:23:35 <Joubu> cait: yes, there were concerns, but no proposition :)
16:23:53 <cait> i think rangi tried to show some code on how to do it different
16:24:12 <marcelr> remember he proposed another cpan module
16:24:18 <cait> I think we need to get better at communicating in general - and communicating early on
16:24:23 <gmcharlt> cait: he had; a bit more is needed, which was what I was aiming for but didn't get to
16:24:40 <gmcharlt> but let's pause a minute and settle the meeting time
16:24:47 <ashimema> agreed
16:24:55 <gmcharlt> 15:00 UTC and 21:00 UTC on 12 March 2014 for the next dev meeting?
16:25:00 <clrh> ashimema: talking about disagreements and trying explain ourselves about what we live everyday is not a war I think :)
16:25:18 <thd> gmcharlt: Do you mean that many small changes are difficult to push now because attention needs to be concentrated fixing historic problems?
16:25:48 <gmcharlt> thd: http://martinfowler.com/bliki/TechnicalDebt.html
16:26:03 <gmcharlt> I can bring up the schedulign question at the 5 March meeting
16:26:06 <ashimema> clrh, it was meant lightheardedly..
16:26:11 <cait> Joubu: for things in QA t might help to communicate - we communcate where we start with QA and then you can stop rebasing the other sin the meantime, if that would help
16:26:12 <gmcharlt> but can I have some initial +1/-1 on the date?
16:26:18 <ashimema> light-heartedly
16:26:34 <gmcharlt> ashimema: so you whispered it? ;)
16:26:40 <thd> +1
16:27:09 <oleonard> +1
16:27:14 <ashimema> :p
16:27:18 <tcohen> +1
16:27:21 <cait> +1
16:27:32 <ashimema> +1
16:27:33 <Joubu> +1
16:27:34 <marcelr> +1
16:27:40 <paul_p> gmcharlt = will the meeting last 1 hour ?
16:27:45 <matts> +1
16:27:48 <ashimema> +1
16:27:56 <ashimema> for a hour..
16:28:05 <wajasu> +1
16:28:10 <gmcharlt> paul_p: yeah
16:28:11 <ashimema> don't want to eat into hacking time too long ;)
16:28:12 <paul_p> +1 then
16:28:31 <gmcharlt> paul_p: I'll rely on you to manage the chatterboxes in Marseille ;)
16:28:52 <paul_p> IRC or hangout ?
16:28:59 <ashimema> hangout +1
16:29:02 <tcohen> hangout++
16:29:05 <cait> how many hanging out can the wifi support? :)
16:29:06 <gmcharlt> #agreed Next dev meeting will be at 15UTC/21UTC on 12 March 2014 (pending confirmation from the second half of today's meeting)
16:29:27 <ashimema> hangout on big screen maybe?
16:29:37 <ashimema> we can work that out closer to the time though me thinks.
16:29:45 <gmcharlt> possibliy both IRC and Hangout
16:29:46 <paul_p> ashimema in BibLibre office, we can HG on a projector
16:29:47 <Joubu> there is a limitation at 9 users on hg I think
16:29:54 <gmcharlt> given the limit, yes
16:30:14 <ashimema> think you can get around the limit using a google apps for business account?
16:30:19 <paul_p> all hackfest attendees can share the same HG, so it could work
16:30:29 <ashimema> sure I could offer ours if that's the case
16:31:02 <gmcharlt> ashimema: please find out
16:31:27 <gmcharlt> OK
16:31:29 <gmcharlt> #endmeeting