#koha: Koha Dev Meeting, 25 February 2014 21:00 UTC

Meeting started by gmcharlt at 21:01:00 UTC (full logs).

Meeting summary

    1. http://wiki.koha-community.org/wiki/Developers_IRC_Meeting,_February_25,_2014 (gmcharlt, 21:01:12)

  1. Introductions (gmcharlt, 21:01:22)
    1. wahanui, a bot that has become sentient (wahanui, 21:01:23)
    2. Mark Tompsett (mtompset, 21:01:36)
    3. gmcharlt = Galen Charlton, 3.16 RM, Equinox, USA (gmcharlt, 21:01:43)
    4. Robin Sheat, Catalyst IT, Wellington, NZ (eythian_, 21:01:48)
    5. Jesse Maseto - ByWater (JesseM, 21:01:55)
    6. Chris Cormack, Catalyst IT, Wellington, NZ (rangi, 21:02:03)
    7. Thomas Dukleth, Agogme, New York City (thd, 21:02:15)
    8. Katrin Fischer, BSZ (cait, 21:03:26)

  2. Announcements (gmcharlt, 21:04:30)
    1. gmcharlt will be clearing the passed QA queue prior to the beginning of the hackfest in Marseille (gmcharlt, 21:04:41)
    2. end of tomorrow will be cutoff for new passed QA until the hackfest in Marseille, QA team to focus on sign offs and kitten rescue (gmcharlt, 21:04:50)
    3. the hackfest in Marseille is 10-14 March (gmcharlt, 21:05:02)
    4. Jared Camins-Esakov, C & P Bibliography Services (jcamins, 21:05:14)

  3. RM questions (gmcharlt, 21:07:08)
    1. is there a reasonable Plack configuration that we could include in 3.16, and encourage as a first-class install option? (gmcharlt, 21:07:37)
    2. https://github.com/mkfifo/koha-gitify <-- ashimema (eythian_, 21:11:46)
    3. http://git.catalyst.net.nz/gw?p=koha-plack.git (eythian_, 21:12:21)
    4. http://git.catalyst.net.nz/gw?p=koha.git;a=commitdiff;h=459c750e4b0aa0fe5dba601e423e78070383b97b;hp=2c9581f75fdb1f76e60c83f86e253cb4dfe04597 (rangi, 21:13:29)

  4. Elastic Search (gmcharlt, 21:19:39)
    1. http://git.catalyst.net.nz/gw?p=koha.git;a=shortlog;h=refs/heads/elastic_search (rangi, 21:30:09)
    2. http://git.catalyst.net.nz/gw?p=koha.git;a=blob;f=Koha/ElasticSearch/Indexer.pm;h=d7dd8dc011fa2d09fc452aa8e29351815f30dc1d;hb=dcb4ab577d305ec415d06b84a0eca7d58ea685b4 <-- indexer (rangi, 21:36:18)
    3. http://git.catalyst.net.nz/gw?p=koha.git;a=blob;f=Koha/ElasticSearch/Search.pm;h=2efb53e04ab5e3b01958009ae925f3e1530cce51;hb=dcb4ab577d305ec415d06b84a0eca7d58ea685b4 <-- so tiny and cute (rangi, 21:38:43)
    4. http://git.catalyst.net.nz/gw?p=koha.git;a=shortlog;h=refs/heads/elastic_search (gmcharlt, 21:41:03)
    5. http://search.cpan.org/~drtech/ElasticSearch-0.66/lib/ElasticSearch.pm#Query_methods (rangi, 21:42:04)
    6. we plan to have a demo in time for the hackfest (rangi, 21:42:47)

  5. DBIx::Class (gmcharlt, 21:46:02)
  6. Searching (gmcharlt, 21:46:37)
  7. DBIx::Class (gmcharlt, 21:57:36)
    1. http://blogs.perl.org/users/ovid/2014/02/using-dbixclassschemaloader-to-find-design-flaws.html (rangi, 22:03:42)

  8. Pending Large Enhancements (gmcharlt, 22:06:39)
    1. http://git.evergreen-ils.org/?p=working/NCIPServer.git;a=summary <-- here (rangi, 22:11:38)
    2. http://git.catalyst.net.nz/gw?p=NCIPServer.git (rangi, 22:11:59)

  9. Next meeting (gmcharlt, 22:20:13)
    1. AGREED: Next dev meeting will be at 15UTC/21UTC on 12 March 2014 (pending confirmation from the second half of today's meeting) (gmcharlt, 22:22:57)
    2. AGREED: Next dev meeting will be at 15UTC/21UTC on 12 March 2014 (achivement unlocked: confirmation!) (gmcharlt, 22:23:14)


Meeting ended at 22:23:25 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. rangi (111)
  2. gmcharlt (105)
  3. ashimema (56)
  4. bag (34)
  5. cait (30)
  6. eythian_ (30)
  7. thd` (15)
  8. pianohacker (13)
  9. mtompset (10)
  10. wajasu (6)
  11. huginn` (5)
  12. wahanui (3)
  13. larryb (2)
  14. jcamins (2)
  15. francharb_afk (1)
  16. JesseM (1)
  17. thd (1)


Generated by MeetBot 0.1.4.