#koha: Koha Dev Meeting, September 16, part 1

Meeting started by cait at 15:03:21 UTC (full logs).

Meeting summary

  1. Introductions (cait, 15:03:36)
    1. wahanui, a bot that has become sentient (wahanui, 15:03:37)
    2. Galen Charlton (gmcharlt, 15:03:46)
    3. Tomas Cohen Arazi, Universidad Nacional de Cordoba (tcohen, 15:03:49)
    4. Kyle M Hall, ByWater Solutions (khall, 15:03:53)
    5. Katrin Fischer, BSZ (cait, 15:03:54)
    6. Jonathan Druart, BibLibre (Joubu, 15:03:57)
    7. Thomas Dukleth, Agogme, New York City (thd, 15:04:01)
    8. http://wiki.koha-community.org/wiki/Development_IRC_meeting,_16_September_2014 (cait, 15:04:05)
    9. Indranil Das Gupta, Kolkata (indradg, 15:04:18)

  2. RM 3.18 comments (cait, 15:05:03)
    1. Martin Renvoize, PTFS Europe (ashimema, 15:05:22)
    2. I've been busy with several kohacon14 stuff that needs to be ready this week (tcohen, 15:05:27)
    3. Barton Chittenden, Bywater Solutions, Louisville, KY, USA (barton_phone, 15:05:30)
    4. Colin Campbell PTFS Europe (ColinC, 15:05:49)
    5. Owen Leonard, Athens County Public Libraries (oleonard, 15:06:45)
    6. tcohen will push several bugfixes that are needed for the stable branches this week (tcohen, 15:08:30)
    7. zebra facets need feedback (cait, 15:09:01)
    8. we are arranging things so zeno and galen can bring us their presentations live (tcohen, 15:09:12)

  3. General technical discussion (cait, 15:10:32)
    1. link to the mailing list thread for DBIC is on today's agenda in the wiki (cait, 15:11:58)
    2. please voice your opinion on the mailing list, more comments needed (cait, 15:15:43)
    3. bug 12892 is an example for Kyle's position on how to use DBIC (cait, 15:18:16)
    4. ACTION: tcohen to schedule DBIC dev meeting for next week (cait, 15:24:18)
    5. which view should be displayed: default rules or logged in library rules? (cait, 15:29:00)
    6. idea 1: display logged in library to prevent accidentally editing the default rules (cait, 15:29:28)
    7. idea 2: display the default rules, if there are default rules (cait, 15:29:44)
    8. ACTION: khall will take the branch/default question to the general ml (cait, 15:34:48)
    9. ACTION: khall will add a status update to the indy branch groups bugs (cait, 15:37:27)

  4. Additions to coding guidelines (cait, 15:37:49)
    1. Perl 5.10 is still Koha's minimum requirement (cait, 15:38:40)
    2. Perl version dependent on what squeeze ships (cait, 15:39:13)
    3. ACTION: tcohen to ad HTML7 guideline about tt plugins to wiki (cait, 15:45:52)
    4. CLI guidelines, especially dryrun and -c to go to the ml (cait, 15:49:35)

  5. Bugs (cait, 15:50:33)
    1. ACTION: barton will write up coding guideline for database table/column names with khall (cait, 15:54:20)

  6. Big stuff we are working on (cait, 16:12:27)
    1. AGREED: the majority agrees on 'on-site checkouts' (cait, 16:12:58)
    2. some of the vat rewrite-plumbing got signed off by Paola (cait, 16:16:09)
    3. more tax rewrite patches to be submitted after decision on DBIC has been made (cait, 16:16:30)
    4. http://andromedayelton.com/blog/2014/09/10/why-i-support-the-ada-initiative-you-too/ (gmcharlt, 16:18:23)
    5. Donation link is https://supportada.org/?campaign=libraries (gmcharlt, 16:18:32)

  7. Actions from last meeting (cait, 16:21:31)
    1. gmcharlt will be releasing UTF-8 test cases in the enxt couple days (gmcharlt, 16:22:10)

  8. Set time for next meeting (cait, 16:23:40)
    1. we will try to schedule the next dev meeting during hackfest, time/day to be decided when we know a bit more about the schedule (cait, 16:27:00)


Meeting ended at 16:27:08 UTC (full logs).

Action items

  1. tcohen to schedule DBIC dev meeting for next week
  2. khall will take the branch/default question to the general ml
  3. khall will add a status update to the indy branch groups bugs
  4. tcohen to ad HTML7 guideline about tt plugins to wiki
  5. barton will write up coding guideline for database table/column names with khall


Action items, by person

  1. barton
    1. barton will write up coding guideline for database table/column names with khall
  2. khall
    1. khall will take the branch/default question to the general ml
    2. khall will add a status update to the indy branch groups bugs
    3. barton will write up coding guideline for database table/column names with khall
  3. tcohen
    1. tcohen to schedule DBIC dev meeting for next week
    2. tcohen to ad HTML7 guideline about tt plugins to wiki


People present (lines said)

  1. cait (170)
  2. tcohen (52)
  3. gmcharlt (40)
  4. Joubu (29)
  5. khall (22)
  6. thd (19)
  7. oleonard (12)
  8. wahanui (10)
  9. ashimema (7)
  10. ColinC (6)
  11. huginn (6)
  12. jcamins (5)
  13. indradg (4)
  14. barton (3)
  15. barton_phone (1)
  16. reiveune (1)


Generated by MeetBot 0.1.4.