09:16:54 <cait> #startmeeting Koha General IRC Meeting, part1
09:16:54 <huginn> Meeting started Wed Dec 17 09:16:54 2014 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:16:54 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:16:54 <huginn> The meeting name has been set to 'koha_general_irc_meeting__part1'
09:16:57 <drojf> ha you have not started^^
09:17:16 <cait> sorry for the dealy, i was doing some tricky sql updates (end of year things in acq)
09:17:19 <cait> forgot the time a bit
09:17:28 <cait> #topic introductions
09:17:29 <wahanui> #info wahanui, a bot that has become sentient
09:17:34 <cait> please introduce yourself with #info
09:17:55 <drojf> #info Mirko Tietgen, Berlin
09:17:57 <cait> #info Katrin Fischer, BSZ Germany
09:18:46 <thd> #info Thomas Dukleth, Agogme, New York City - via California for the next 10 days
09:18:48 <drojf> that's a small meeting :D
09:18:49 <cait> we could hold the meeting in german
09:18:53 <cait> ah, maybe not then :)
09:19:06 <Joubu> #info Jonathan Druart, BibLibre
09:19:25 <cait> I think ashimema will probably be back once i change topic :)
09:19:38 <cait> #topic Announcements
09:20:31 <cait> I can see a note from chris_n on the wiki
09:20:34 <drojf> oh we could have tried this as a video conference to test my webinar server ;)
09:20:48 <cait> but i think the issue has been resolved since
09:21:05 <cait> #link agenda http://wiki.koha-community.org/wiki/General_IRC_meeting_17_December_2014
09:21:52 <cait> #info bug 10821: For all interested parties, the fix for this has been applied in Library::Callnumber::LC
09:21:53 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10821 major, P1 - high, ---, cnighswonger, CLOSED WONTFIX, label pdf adding in strange breaking
09:22:06 <drojf> i assume voting up that bug requires a google account
09:22:15 <drojf> ah it's done already \o/
09:22:15 <cait> i think it's no longer necessary now
09:22:20 <cait> but it seems you need to be registered
09:22:27 <cait> #topic Update on releases
09:22:28 <ashimema> #info Martin Renvoize, PTFS Europe
09:22:36 <cait> any release maintainers awake and around?
09:23:27 <cait> from the info i have the releases are still scheduled to happen on 22nd
09:23:45 <ashimema> we can only hope ;)
09:24:10 <cait> and we had an unscheduled security release
09:24:15 <cait> release_maintainers++
09:24:36 <cait> #topic Discussion: Road Map for Koha
09:25:21 <ashimema> I like the idea of a Roadmap..
09:25:23 <cait> I think the goal was to discuss more about the contents this time
09:25:38 <cait> or the review bit for 3.18?
09:25:41 <ashimema> also happy to be not time baed.. just a sort of project directional aid
09:25:56 <cait> yeah i think general goals are good to write up
09:26:03 <cait> and update the status of them regularly
09:26:26 <cait> will people around now be able to make it to the second meeting tonight?
09:26:43 <drojf> i will probably
09:26:43 <cait> tonight/today
09:26:52 <thd> A roadmap of arbitrary depth and detail could be maintained easily in the wiki.
09:27:41 <thd> Maintaining a summary on the website would be a greater task and would necessarily be out of date.
09:27:47 <cait> yeah, I think the wiki will be a good place
09:27:50 <ashimema> hoepfully will be around
09:28:11 <ashimema> wiki++
09:28:18 <cait> as we are not so many people... maybe we can postpone deeper discussion to the second part today?
09:28:25 <thd> I think it would be better to point a roadmap page on the website to some suitable set of linked pages in the wiki.
09:28:28 <ashimema> agreed
09:28:49 <cait> #idea use the wiki, point from the website to the wiki - easier to keep updated
09:28:58 <thd> However, if anyone wants to maintain a summary on website, great.
09:29:25 <ashimema> wiki's can export to html given the right tools..
09:29:39 <ashimema> I'de maintain in the wikie and pull data from it on the website if it were me
09:29:58 <cait> #idea pull the data for the website out of the wiki
09:30:28 <cait> anything else?
09:30:39 <thd> ashimena: Certainly, however, the useful content for a summary from the wiki is liable to be multiple linked pages which may be different from the preferred presentation of a summary on the website.
09:31:30 <ashimema> yup.. hence there would need to be a small amount of manipulation website side..
09:31:41 <ashimema> I've done things like that before..
09:31:43 <cait> i think maybe a link to the wiki is all we need
09:31:54 <ashimema> grabbing links and trasnforming them into title for instance.
09:32:07 <ashimema> but a link is deffo suffice for the start
09:33:01 <cait> #idea use a link and leave content on the wiki
09:33:45 <cait> are we ok?
09:34:12 <cait> I will switch to the next topic
09:34:15 <cait> #topic Election: wiki curator
09:34:28 <cait> #link http://wiki.koha-community.org/wiki/Proposal_for_Wiki_Curator_3.20_Thomas_Dukleth
09:34:33 <thd> A summary even from linked wiki pages might be created from a script but the effort is probably better applied to creating and maintaing useful content in the wiki.
09:34:44 <cait> agreed
09:34:50 <ashimema> ++
09:35:19 <ashimema> I've expressed my thoughts on the curator proposal discussion page.
09:35:22 <thd> I posted a list of candidates for holding the position collectively for the previous meeting.
09:35:37 <cait> thd: do you have a link or can repost?
09:35:44 <ashimema> I'de rather a more open procedure for chsooing extensions etc..
09:35:53 <thd> checking
09:35:57 <ashimema> http://wiki.koha-community.org/wiki/Talk:Proposal_for_Wiki_Curator_3.20_Thomas_Dukleth
09:36:08 <cait> I tend to agree, I am worried about missing security updates etc. it seems we already fell behind quite a bit
09:36:30 <ashimema> we are at .16.. mediawiki was at .22 last I looked
09:36:38 <cait> maybe it's worth taking the chance to simplify our setup a bit
09:36:49 <ashimema> .24 in fact
09:37:26 <ashimema> I also tend to feel we're over complicating the wiki.. I've been wanting to nuke half the extensions for a long time now
09:37:33 <thd> We have very good backups in version control.
09:37:38 <cait> #info a discussion has been started on the wiki - http://wiki.koha-community.org/wiki/Talk:Proposal_for_Wiki_Curator_3.20_Thomas_Dukleth
09:37:56 <thd> Do we actually have many extensions?
09:38:11 <thd> I suspect that most people want more extensions.
09:38:33 <cait> I think while some of them are generally useful, we might not make use of them
09:38:50 <thd> The problem with updating is that it breaks things unless planned carefully.
09:38:51 <ashimema> we have like 6 category based extentions..
09:39:02 <ashimema> that make adding/editing the wiki plain hard.
09:39:44 <ashimema> We're using postgres, which isn't well supported by mediaiwiki or it's extensions either..
09:39:45 <thd> ashimena: Some work together with dependencies.
09:39:54 <ashimema> which is one of the issues preventing easy upgrades
09:40:16 <ashimema> personally.. I would remove all the category extensions..
09:40:33 <ashimema> and then choose a elected set to use
09:40:39 <thd> Upgrades are not prevented.  Upgrades require planning and testing.
09:40:59 <ashimema> removing the ability to add categories in the markup is a step backwards
09:41:12 <ashimema> they are prevented.. as they're in the hands of one or two people with no time..
09:41:15 <thd> We did that once without planning and testing and then I had to spend some days fixing things.
09:41:18 <ashimema> hense planning and testing is prevented..
09:41:46 <ashimema> I would prefer this convesation took place with more parties..
09:41:59 <cait> I think that's where being closer to a standard version could help us - making updates easier
09:42:10 <ashimema> I'm not against you here thd.. but I think we have very differeing opinions which could do with someexternal thoughts going forward
09:42:27 <thd> The implementation is under git  version control for which anyone can obtain a copy.
09:42:31 <cait> I am helping to maintain our dokuwiki here - and moving away from our customizations have helped a lot to increace maintainability
09:42:44 <thd> Thus, anyone could test.
09:42:49 <ashimema> that's not public knolledge as far asI'm aware
09:43:17 <drojf> not being familiar with the technical aspects of our wiki, what customisations are we talking about?
09:43:18 <thd> gmcharlt, might need to facilitate some access as it is hosted at Equinox.
09:43:45 <cait> #link http://wiki.koha-community.org/wiki/Website_Administration#wiki.koha-community.org
09:43:52 <cait> we culd put the information there
09:44:01 <thd> We had previously used DokuWiki.
09:44:17 <cait> #idea add information about installed plugins, changes to standard wiki to the wiki
09:45:08 <thd> The problems that had is with no authority control over suggesting categories most content had no categories and could not be found systematically.
09:45:08 <cait> thd: i know - just using it as an example. We encourage people to not change koha in ways that hinder update, but we seem to do just that with our wiki
09:45:59 <thd> The "cumbersome" category extensions make content findable in a systematic manner.
09:47:04 <thd> Yes, a burden is added to the user when creating a new page.  However, every later user of the page benefits from the initial effort.
09:47:08 <ashimema> ack.. my other call is getting busy..
09:47:11 <ashimema> dropping out again for a bit.
09:47:13 <ashimema> sorry
09:47:14 <cait> I think there are some valid concerns here - maybe we should gather some more info and try to rethink this together?
09:48:04 <thd> Mostly, maintenance has been neglected.
09:48:54 <thd> That is significantly my fault but I know how to remedy the situation.
09:49:15 <cait> I think the idea we propose is mostly making this more easy in the future
09:49:30 <cait> time is the single resource we never have enough of
09:49:39 <cait> more important than funding or anything else I think
09:50:04 <thd> The wiki should have content linked from the front page explaining good use and its advantages as I did for the former wiki before we lost that to PTFS/LibLime trouble.
09:50:30 <thd> s/did/had created/
09:50:44 <cait> I think we should not create too many rules/barriers
09:50:57 <thd> They were never rules.
09:52:01 <thd> The only rule that might be enforced is assigning at least one category to a newly created page to keep it from becoming lost.
09:52:06 <cait> i hop this didn't come across too negative - I appreciate that you want to take this on and hope we can have some discussion on how without being discourating
09:52:38 <thd> I had taken it on in the past.
09:52:53 <thd> Most of my work on the former wiki is sadly lost.
09:53:28 <thd> I also pushed for MediaWiki over DokuWiki.
09:54:40 <thd> The choice of wiki software was meant to be a contest.  However, LibLime took down the earlier DokuWiki wiki which had held most all of the content at the time.
09:54:43 <drojf> do we have usage statistics for the wiki? like, how people actually use it? maybe it's just me, but i hardly ever use anything but the search function
09:55:10 <thd> s/LibLime/PTFS\/LibLime/
09:55:50 <cait> that's all right
09:55:59 <cait> I didn't mean to question the mediawiki choice at all
09:56:07 <thd> drojf: Google has brainwashed you into thinking that libraries and curation are unnecessary when you have full text indexing :)
09:56:20 <cait> i personally prefer dokuwiki as we are using that here - but that doesn't mean i would want to propose a change .)
09:56:46 <drojf> thd: i don't want to imply it is not needed! not at all. i just wonder if there are statistics. i have no idea what other people do :)
09:57:23 <thd> MediaWiki is a larger and necessarily more complex project as it has to support whatever people want for Wikipedia.
09:57:24 <cait> I can only speak for myself, but i use the search feature too :)
09:57:25 <drojf> i don't think i am the regular wiki user. also i have bookmarked most of the stuff i use often ;)
09:58:26 <cait> thd: i think we are using mediawiki for the koha project - noone questions that
09:58:38 <thd> Categories allow finding RFCs for what people are working on, etc. in a systematic manner.
09:59:00 <cait> i think the problem here is maintenance, as those don't get updated, so the categories are not correct
09:59:17 <cait> and some rfcs are not marked, although they won't be implemented or have never implemented in the way written up on the wiki
09:59:48 <thd> cait: There was meant to be a question and a vote but the issue became somewhat moot when PTFS/LibLime took down the DokuWiki implementation.
09:59:53 <cait> but that's content we need to fix and maintain
09:59:54 <drojf> personally i am more concerned with outdated contents than categorisation at the moment
10:00:16 <drojf> i can't pass a link to a library that wants to switch to dom, because the information on the wiki is not accurate
10:00:36 <thd> drojf: We should tag the content as outdated but then encourage people to update it.
10:02:10 <thd> Some Wikipedia editors have a habbit of deleting pages which I think is a bad idea for a library software.  We should preserve it but mark it.
10:02:11 <drojf> is that possible at the moment? (tagging it outdated)
10:02:18 <cait> i think a 'how to' with hints on how to use the features might be good
10:02:33 <cait> like a note on how to add something to mark it 'outdated' most effectively
10:02:39 <cait> and in a searchable way
10:03:26 <thd> I had created a good tutorial for DokuWiki and was taken aback when it all went down.
10:04:25 <thd> At the time, it was a tit-for-tat response over starting an independent bugzilla instance.
10:04:31 <cait> I'd like to give the second part of the meeting the chance to contribute to this before we vote
10:05:04 <thd> Certainly.
10:05:05 <wahanui> certainly is confusing.. thanks for bringing ashimema's attention to it.
10:05:19 <thd> I will not be around for the second part.
10:05:48 <cait> hm ok
10:05:49 <cait> maybe the wiki?
10:06:05 <thd> We should at least consider in this part whether the more the merrier bug wrangler concept applies.
10:06:53 <thd> I favour that concept which has certainly contributed to and not lessoned the level of maintenance.
10:07:19 <cait> so the question is if we will have more than one wiki curator for the content?
10:07:28 <cait> or is this also about the technical side/server access?
10:07:32 <paxed> li#patronbasics img[src$="blank.png"] { display: none !important; }
10:07:43 <paxed> ^ hide the patron image if there is no image set
10:07:44 <thd> There have defacto been multiple wiki maintainers working simultaneously.
10:08:35 <drojf> i don't think it is possible for one person to maintain the whole wiki (speaking of accuracy contents) in their spare time
10:08:35 <thd> There is a list in the candidates page but others should be free to join.
10:08:42 <cait> I think i'd leave the role open to everyone who wants to contribute
10:08:43 <thd> +1
10:08:45 <drojf> (contents accuracy)
10:09:00 <cait> and we also have people with different areas of expertise
10:09:07 <cait> (if that works as an english word :) )
10:09:32 <thd> Maintenance has a very broad scope.
10:10:14 <thd> I had concentrated on the backend and trying to avoid orphan pages.
10:10:19 <cait> I am not sure how to proceed - i think what i see is a general agreement that curating is a multi-people thing?
10:11:00 <drojf> i'd agree to that
10:11:01 <cait> can i get a quick indication if that is right?
10:11:02 <cait> +1
10:11:06 <drojf> +1
10:11:07 <thd> +1
10:11:11 <Joubu> +1
10:11:38 <cait> #agreed Curating the wiki content should be a multi-people approach
10:11:47 <cait> hope that will make sense to the meeting later
10:11:57 <ashimema> right..
10:11:59 <ashimema> I'm back..
10:12:00 <ashimema> reading up
10:12:06 <cait> as we run out of time a bit, I'd like to move on more quickly now
10:12:21 <cait> #topic Communication manager
10:12:34 <cait> to my information noone has stepped up yet willing to fill the role
10:13:17 <thd> I am not certain that the scope of communications manager has been well defined.
10:13:37 <cait> yes, that might be the problem
10:13:40 <thd> However, no one has stepped forward for any definition.
10:14:13 <cait> I think maybe this would be better to bring up to the mailing list agan
10:14:36 <drojf> +1
10:14:43 <drojf> for the mailing list
10:14:49 <thd> +1
10:15:54 <cait> #agreed bring up the communication manager role on the mailing list again
10:16:02 <cait> #topic KohaCon15
10:16:10 <jransom> hi all. (jo ransom, hlt - nz)
10:16:16 <cait> hi jo :)
10:16:31 <cait> quite late for you!
10:16:51 <cait> you can add #info in front, then it will show up in the meeting minutes
10:17:17 <cait> I think today there is noone fromt he organisers around -maybe it's a bad time
10:17:21 <cait> i will move on
10:17:36 <cait> #topic Actions from the last meeting
10:17:43 <jransom> #info jransom
10:17:57 <ashimema> I'll add more thoughts on the wiki propositions to the discussion page rather than pollute further here
10:18:00 <cait> hm i think we have an old link on the wiki, one sec
10:18:39 <cait> the correct link to the last meeting:
10:18:41 <cait> #link http://wiki.koha-community.org/wiki/General_IRC_meeting_19_November_2014
10:18:46 <ashimema> I did allot fo the work on https://wiki.openstreetmap.org/wiki/Main_Page back in the day.. and that wiki is now happily self sustaining... I also install, maintian and train mediaiwki for a series of customers..
10:19:05 <ashimema> just so thd has some of my own background
10:19:31 <cait> #info the community website has been updated with information about kohacon15
10:19:59 <cait> #link http://koha-community.org/kohacon/kohacon15/
10:20:23 <cait> @later tell wizzyrea can you update http://koha-community.org/kohacon/ please to list Nigeria as upcoming? thx!
10:20:23 <huginn> cait: The operation succeeded.
10:20:54 <cait> and i think BobB emailed the list about the roles, but as said earlier we need to bring that up again
10:21:12 <cait> anything else?
10:21:59 <cait> #topic Set date and time for next meeting
10:22:09 <cait> I thik maybe we shoudl leave that to the second part
10:22:14 <cait> as we have only very small attendance today
10:22:16 <drojf> i'd vote for only one date
10:22:23 <cait> that ok?
10:22:30 <drojf> this split does not really seem to work well
10:22:47 <cait> #idea go back to 1 meeting instead of 2
10:22:51 <jransom> has the koha fundraising idea been discussed at all?
10:23:00 <drojf> jransom: nope
10:23:00 <cait> jransom: it hasn't been on the agenda - not sure about the state
10:23:01 <thd> Presumably the second part would be more interested in a later time.
10:23:04 <drojf> nobody showed up
10:23:11 <cait> drojf: jo did :)
10:23:14 <drojf> ah
10:23:17 <drojf> sorry :))
10:23:25 <cait> but i think maybe the time is bad for california/bag?
10:23:46 <thd> I am in California at the moment.
10:24:08 <thd> However, it is not a great time for California.
10:24:13 <cait> jransom: i think probably the second meeting - but it would have been good to add to the agenda - guess we forgot
10:24:24 <drojf> about splitting the meeting, i think we get more out of one meeting followed by mailing list discussions if necessary than with two seperate parts of one meeting
10:24:41 <cait> I have a feeling too that the experiment has not been successful
10:24:50 <cait> there is always one meeting with only very few attendees
10:24:51 <jransom> the fundraising idea is being discussed via email.
10:25:06 <thd> Nor is it a great time presently for the US in general.
10:25:09 <cait> #info leaving setting date and time to second part of the meeting
10:25:15 <cait> #endmeeting