19:05:02 <gmcharlt> #startmeeting Koha General Meeting, 5 March 2014
19:05:02 <huginn> Meeting started Wed Mar  5 19:05:02 2014 UTC.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:05:02 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:05:02 <huginn> The meeting name has been set to 'koha_general_meeting__5_march_2014'
19:05:05 <mtompset> wajasu++ #thanks for the sign off.
19:05:08 <gmcharlt> #link http://wiki.koha-community.org/wiki/General_IRC_meeting_5_March_2014 Agenda
19:05:17 <gmcharlt> #topic Introductions
19:05:18 <wahanui> #info wahanui, a bot that has become sentient
19:05:27 <mtompset> #info Mark Tompsett
19:05:29 <cait> #info Katrin Fischer, BSZ
19:05:30 <oleonard> #info Owen Leonard, Athens County Public Libraries
19:05:35 <magnuse> #info Magnus Enger, Oslo Public Library, Norway
19:05:36 <gmcharlt> #info gmcharlt = Galen Charlton, 3.16RM, Equinox, USA
19:05:41 <jwagner> #info Jane Wagner, LibLime/PTFS
19:05:44 <peggy> #info Peggy Thrasher, NH, USA
19:05:59 <jsasse> #info Joel Sasse, MN USA
19:06:01 <ColinC> #info Colin Campbell, PTFS-Europe
19:06:03 <mveron> #info Marc VĂ©ron, marc veron ag (www.veron.ch), Allschwil, Switzerland, member of Koha Support Schweiz
19:06:04 <jcamins> #info Jared Camins-Esakov, C & P Bibliography Services
19:06:07 <rhcl> #info rhcl = Greg Lawson, Rolling Hills Consolidated Library, St. Joseph, MO, USA  -ro
19:06:11 <clintD> #info clint deckard, Anact,NZ
19:07:13 <drojf> #info Mirko Tietgen, Berlin
19:08:55 <gmcharlt> ok
19:09:06 <gmcharlt> #topic Maintenance release updates
19:09:23 <gmcharlt> RMaints for 3.8, 3.10, 3.12, and 3.14, please give any updates you have now
19:10:45 <cait> I guess bad timing - none of them seems around?
19:11:07 <gmcharlt> ok, we'll just assume that they're all hunky-dory
19:11:25 <gmcharlt> #info No particular updates from the RMaints - no news is good news
19:11:47 <gmcharlt> #info 3.14.4 released on February 26
19:11:56 <gmcharlt> #info 3.12.11 released on February 25
19:12:07 <gmcharlt> #topic Update on 3.16
19:12:32 <gmcharlt> #info RM will be clearing the passed QA queue (via pushing or throwing patches back) prior to the Marseille hackfest
19:12:50 <gmcharlt> #info QA team is currently working on patch signoff and patch rescue during this period
19:13:10 <mtompset> When is the hackfest again?
19:13:21 <magnuse> mtompset: next week!
19:13:22 <wahanui> rumour has it next week is project week
19:13:47 <gmcharlt> #link http://wiki.koha-community.org/wiki/Developers_IRC_Meeting,_February_25,_2014 notes and minutes from the 25 February IRC dev meeting
19:13:54 <magnuse> gmcharlt: are there dates for feature freeze et al yet?
19:14:22 <gmcharlt> #info gmcharlt will set firm dates for feature freeze immediate after hackfest
19:14:39 <gmcharlt> #info The Marseille Hackfest runs from 10-14 March
19:15:00 <cait> gmcharlt++
19:15:53 <magnuse> gmcharlt++
19:15:56 <gmcharlt> any other questions?
19:16:44 <gmcharlt> #topic KohaCon 2014
19:17:08 <gmcharlt> looks like neither tcohen or bgkriegel are here, so this may be brief
19:17:49 <gmcharlt> ... and so it is
19:17:54 <gmcharlt> #topic KohaCon 2015
19:18:15 <gmcharlt> #info question was posed as to whether it is time to start site-selection for the 2015 conference
19:18:42 <gmcharlt> seems reasonable to me
19:18:55 * cait agrees
19:18:56 <gmcharlt> are there any volunteers here who want to go ahead and get that started?
19:19:47 <gmcharlt> @monologue
19:19:47 <huginn> gmcharlt: Your current monologue is at least 2 lines long.
19:20:16 <oleonard> Looks like the first call for 2014 proposals was June 2013?
19:20:57 <gmcharlt> in that case, doesn't hurt to defer for a bit longer
19:20:58 <cait> oleonard: maybe the next host wants to have it a bit earlier in the year - I think starting now would not hurt
19:21:35 <gmcharlt> yeah, to split the difference, a bit earlier than June for CFP would be good, but don't necessarily need to do it instantly
19:21:48 <oleonard> Whoops, cait just volunteered! ;)
19:21:57 <cait> ah sorry no
19:22:02 <cait> i have my hands pretty full already
19:22:06 <gmcharlt> :)
19:22:18 <gmcharlt> how about just an action item to put this on the agenda for the April meeting?
19:22:33 <jsasse> +1
19:22:38 <cait> +1
19:22:45 <mveron> +1
19:22:54 <magnuse> +1
19:22:54 <ColinC> +1
19:23:20 <gmcharlt> #action Galen will put getting the site-selection process starting for KohaCon 2015 on the April general meeting agenda
19:23:41 <gmcharlt> #topic Compiling LESS files more
19:23:49 <gmcharlt> (sorry, I could. not. resist.)
19:23:53 <magnuse> lol
19:24:03 <gmcharlt> #link http://wiki.koha-community.org/wiki/Working_with_Bootstrap_OPAC_LESS_files info on compiling LESS files
19:24:04 <cait> :)
19:24:11 <gmcharlt> oleonard: here's my current thinking -
19:24:31 <gmcharlt> it would be easy enough to make a build target to recompile the less
19:24:48 <gmcharlt> which would mean it would be done during installation and updates
19:25:08 <gmcharlt> however... I have  a question I'd like your opinion on
19:25:27 <gmcharlt> what would be your recommendation for somebody who wants to incoporate this into their OPAC customization tweaks
19:25:36 <gmcharlt> override bits of CSS is one thing
19:25:55 <thd> #info Thomas Dukleth, Agggme, New York City
19:26:02 <gmcharlt> but let's say somebody wants to do something like tweak the height of the navbar to accommodate a taller logo?
19:26:11 <gmcharlt> how would you recommend they go about that?
19:26:33 <gmcharlt> and is there call, you think, for compiling LESS files to potentially become part of the standard toolkit for tweaks?
19:27:27 <cait> hm it feels like the LESS would make more sense if you are using a css file opposed to the opacusercss?
19:27:36 <oleonard> There's no reason why folks can't customize using plain CSS, even while incorporated more complex tools like media queries. I don't think LESS needs to enter into the equation
19:28:32 <wajasu> what if tweakable bits are in sysprefs, and upon save, less is run to compile a new customized css file?
19:28:47 <oleonard> But I could foresee a system which took custom CSS from system preferences and automatically minified it and concatenated it with Koha's built-in CSS
19:28:50 <jcamins> If I were to customize dramatically based on the Bootstrap theme, I would use LESS.
19:29:36 <oleonard> I doubt most would do that much
19:29:41 <jcamins> But my feeling is anyone doing that level of customization is going to be figuring it out themselves, so I see no need to make special allowances for it.
19:29:52 <jcamins> oleonard: it would have to be pretty dramatic.
19:30:41 <gmcharlt> well, not necessarily /that/ dramatic -- changing the height of the navbar is, AFAICT, best done via LESS
19:30:49 <gmcharlt> though I'm open to suggestions that I'm wrong on that point
19:31:10 <oleonard> Along with LESS compiling, the other thing I have in mind is incorporating tasks using something like Grunt: http://gruntjs.com/
19:31:19 <jcamins> gmcharlt: that's true, but that seems kind of dramatic to me.
19:32:15 <gmcharlt> meh, not every library's logo fits well into a constraint that it be < 40 px tall
19:32:21 <gmcharlt> of course, there are other options for placing it
19:32:32 <peggy> It wouldn't see dramatic to a non-technical librarian
19:32:43 <peggy> seem
19:33:16 <jcamins> The reason I find that dramatic is that just changing the height of the navbar doesn't really seem to me to be enough... though maybe it's just a mouse and cookie problem.
19:34:19 <magnuse> peggy: very true!
19:34:20 <wahanui> I know. That's why I said it.
19:35:06 <gmcharlt> one second, I'm writing something up for BZ on this
19:36:14 <jcamins> (i.e. I might start out changing the height of the navbar, but by the time I'm done, I can reasonably expect to have changed a skajillion other things too; otherwise I could just override the places where the variable is used)
19:38:00 <gmcharlt> jcamins: right, but AIUI, that's the point of recompiling -- for certain things, you just set a Bootstrap variable, and it recalculates everything for you during the compilation
19:38:40 <gmcharlt> i.e., that certain types of changes would be basically one-liners in the LESS, but become larger in the generated CSS
19:38:55 <magnuse> aiui?
19:38:55 <wahanui> aiui is As I Understand It
19:39:04 <cait> wahanui++
19:39:13 <mveron> https://en.wiktionary.org/wiki/AIUI
19:39:37 <oleonard> Note that while that may be true for stock Bootstrap CSS it's not true for the bootstrap theme's LESS. We would need to make improvements.
19:40:18 <bag> #info Brendan Gallagher bywater
19:40:34 <oleonard> The bootstrap theme's LESS file only begins to implement all the features possible with LESS
19:40:50 <gmcharlt> bug 11896
19:40:50 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11896 enhancement, P5 - low, ---, gmcharlt, NEW , add tools for compiling LESS files
19:41:03 <gmcharlt> oleonard: jcamins: ^^ does this seem reasonable for a next step
19:41:34 <gmcharlt> blithely pushing aside, for the moment, the question of user-level customization task that would be best done via tweakign the LESS?
19:42:25 <oleonard> gmcharlt: Could this process be done so that instead of triggering the LESS compile directly it triggered a grunt task which included LESS file compilation?
19:42:36 <jcamins> That seems reasonable. Until we can build the LESS and cache it on the fly, OpacUserCSS is going to seem vastly preferable for anything that doesn't involve large numbers of changes, though, at least in my opinion.
19:43:45 <jcamins> (not that I think that generating the CSS on the fly is a crucial behavior that needs to be added NOW NOW NOW, just noting that the fact that we can compile our own LESS stylesheets doesn't make it a better idea than writing our own opac.css files for relatively small changes)
19:44:39 <thd> Is there an advantage to using less for web browser client specific changes or are all proper advantages of less server side?
19:44:46 <gmcharlt> oleonard: not necessarily opposed to grunt, but I note that it's not packaged by Debian
19:45:13 <thd> s/less/LESS/
19:45:14 <oleonard> gmcharlt: Hm, understandable.
19:45:14 <wahanui> understandable. is probably why i was running it against a local copy
19:46:17 <gmcharlt> on the other hand, things like https://www.npmjs.org/package/npm2debian might obviate that difficulty
19:46:24 <gmcharlt> dunno - experimentation required
19:46:34 <gmcharlt> but I'll add a comment to the bug with that suggsetion
19:47:15 <gmcharlt> cait has suggested that LESS-compilation be added to the agenda for the next dev meeting
19:47:18 <wajasu> what dists is npm packaged on?
19:47:19 <gmcharlt> and I'm inclined to agree
19:47:36 <gmcharlt> wajasu: npm itself is packaged only for Debian
19:47:42 <gmcharlt> gah
19:47:45 <gmcharlt> for Debian Jessie
19:48:35 <gmcharlt> for Ubuntu, looks like precise is the first release it's avaiable for
19:49:18 <gmcharlt> OK, to wrap up, I think
19:49:40 <gmcharlt> #info bug 11896 should be used for hashing out patches for adding LESS-compilation to the install/upgrade process
19:49:40 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11896 enhancement, P5 - low, ---, gmcharlt, NEW , add tools for compiling LESS files
19:49:55 <gmcharlt> #action gmcharlt will add LESS compilation to the agenda for the dev meeting next week
19:50:08 <gmcharlt> oleonard: anything else on this for the moemtn?
19:50:16 <mtompset> There's a dev meeting next week?
19:51:01 <oleonard> gmcharlt: yes
19:51:06 <cait> mtompset: yes
19:51:19 <gmcharlt> mtompset: see http://meetings.koha-community.org/2014/koha_dev_meeting__25_february_2014_15_00_utc.2014-02-25-14.59.html
19:51:40 <gmcharlt> #info Next dev meeting is scheduled for 15UTC and 21UTC on 12 March 2014
19:52:00 <mtompset> Okay. Thank you for the clarifications.
19:52:17 <gmcharlt> #topic Announcements
19:52:21 <gmcharlt> anyboyd?
19:53:42 * cait has none
19:53:49 <oleonard> gmcharlt: Question
19:53:51 <wahanui> Question is "What is the meaning of life, the universe and everything?"
19:54:06 <gmcharlt> oleonard: answer
19:54:07 <cait> maybe just: be prepared for lots of bugzilla mails next week :) and keep an eye on your patches? :)
19:54:16 <oleonard> Where has this discussion gotten us?
19:54:33 <oleonard> Are we still asking devs to submit patches containing both LESS modifications and compiled CSS?
19:54:42 <oleonard> ...until we get something else in place?
19:54:50 <gmcharlt> oleonard: from my POV it has gotten us to closer to setting up a install target
19:55:19 <gmcharlt> as far as LESS via CSS... ultimately LESS will be the only thing that gets stored in the Git tree
19:55:40 <gmcharlt> and as far as dealing with patches that include LESS vs. CSS, my inclination is to take the LESS as authoritative
19:56:02 <gmcharlt> and (pending further discussion at next week's meeting, I think) toss back any new ones that /only/ touch the CSS
19:57:48 <gmcharlt> oleonard: does that answer your question?
19:58:28 <oleonard> yes
19:58:32 <cait> so qa will fail when the less changes aremissing?
19:59:02 <magnuse> should this be added to the coding guidelines?
19:59:03 <gmcharlt> eventually - obviously there should be some sort of grace period
19:59:30 <gmcharlt> I don't think it needs to be in the coding guidelines, actually
19:59:35 <gmcharlt> agreement on koha-devel should suffice
19:59:52 <gmcharlt> reason: there ultimately won't be CSS files for Bootstrap in teh Git tree for folks to edit
20:00:27 <thd> If it would not be in the coding guidelines, how should everyone be expected to know?
20:00:31 <magnuse> ah, true
20:00:34 <wajasu> wiki?
20:00:34 <wahanui> wiki is http://wiki.koha-community.org
20:00:52 <cait> i think having some clear instructions would be good - on how to edit the css
20:01:01 <cait> how to do it right
20:01:05 <mveron> cait +
20:01:08 <cait> i am a bit lost there myself right now
20:01:15 * magnuse too
20:01:16 <wajasu> this all we have now: http://wiki.koha-community.org/wiki/Working_with_Bootstrap_OPAC_LESS_files
20:01:16 <gmcharlt> to reiterate, ultimately there would be no CSS to edit
20:01:43 <cait> not sure i understand less right
20:01:51 <cait> but wouldn't you have to generate one for testing your changes?
20:02:21 <gmcharlt> yes, but as a generated artificat, it wouldn't be stored in the Git tree, and you wouldn't be genreating patches against it
20:02:29 <gmcharlt> just the source LESS fiels
20:02:47 <cait> yeah, i was more thinking aobut a tutorial on 'how do i change the styling of X now' :)
20:03:08 <gmcharlt> ah
20:03:15 <gmcharlt> well, wouln't actually be much different
20:03:31 <gmcharlt> since for most things, the LESS files are very similar to CSS
20:03:53 <gmcharlt> so it would be (a) edit the LESS (b) run a command to generate/refresh the CSS (c) test
20:04:58 <wajasu> the tester must compile the patched LESS files.   the person submitting the patch might be nice and supply the test plan with how to compile to the target CSS file.
20:05:01 <thd> Certainly a prominent tutorial would be needed to keep Koha user friendly.
20:07:22 <oleonard> There is no reason why an individual patch would require a test plan describing the compile process
20:07:34 <oleonard> The process is the same for any LESS file changes.
20:08:40 <gmcharlt> and that's the point of things like the update_zebra_conf (sp?) makefile target
20:09:03 <gmcharlt> and a similar one could be created for LESS compilation
20:09:19 <gmcharlt> it's not beyond the realm of possibility that Git hooks could automate it
20:09:34 <gmcharlt> *however*, I think we're getting off into the weeds here -- further commentary on the bug, please
20:09:39 <mveron> That would be great.
20:09:56 <mveron> (automating)
20:10:07 <gmcharlt> #topic Setting time for next meeting
20:10:40 <gmcharlt> given the number of meetings this month
20:10:49 <gmcharlt> I propose 9 April as the date
20:11:06 <magnuse> +1
20:11:24 <jsasse> +1
20:11:25 <gmcharlt> as far as timing goes, I woudl like to propose an experiment
20:11:42 <gmcharlt> namely, a split meeting, 15UTC + 21UTC, similar to the last dev meeting
20:12:20 <gmcharlt> I feel that the current rotation we're on ends up resulting in at least 1/3 of the general meetings being barely attended at all
20:12:41 <cait> +1
20:12:50 <ColinC> +1
20:12:51 <oleonard> +1
20:12:58 <magnuse> +1 for experimenting
20:13:14 <jwagner> +1 worth a try
20:13:31 <mveron> +1 experimenting
20:13:36 <thd> +1 # Most any experiment for better attended meeting times.
20:13:43 <clintD> +1
20:13:54 <peggy> +1
20:13:55 <jsasse> +1
20:14:14 <wajasu> +1
20:14:34 <gmcharlt> #agreed The next general meeting will be a split one at 15UTC and 21UTC on 9 April 2014
20:14:57 <mtompset> +1 # worth the experiment.
20:15:00 <gmcharlt> I will also make a point of specifically mentioning this experiment on the general mailing list
20:15:24 <gmcharlt> thanks, everybody!
20:15:26 <gmcharlt> #endmeeting