22:01:07 <tcohen> #startmeeting Koha IRC Developer Meeting, July 2nd, part 2
22:01:07 <huginn> Meeting started Wed Jul  2 22:01:07 2014 UTC.  The chair is tcohen. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:01:07 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:01:07 <huginn> The meeting name has been set to 'koha_irc_developer_meeting__july_2nd__part_2'
22:01:25 <tcohen> #topic Introductions
22:01:26 <wahanui> #info wahanui, a bot that has become sentient
22:01:39 <tcohen> #info Tomas Cohen Arazi, Universidad Nacional de Córdoba
22:01:39 <cait> #info Katrin Fischer, BSZ, Germany
22:01:40 <eythian_> #info Robin Sheat, Catalyst IT, NZ
22:02:21 <JesseM> #info Jesse Maseto, ByWater
22:02:22 <bag> #info Brendan Gallagher, ByWater
22:02:29 <rangi> #info Chris Cormack, Catalyst
22:02:59 <tcohen> today we had a really long meeting
22:03:05 <tcohen> so, moving on :-D
22:03:12 <tcohen> agenda:
22:03:17 <tcohen> #link http://wiki.koha-community.org/wiki/Development_IRC_meeting,_2_July_2014
22:03:29 <tcohen> #topic RM 3.18 comments
22:04:00 <tcohen> I mentioned today that the jenkins tasks have been set to build and run tests for all stable branches
22:04:20 <tcohen> on ubuntu 12.04 & 14.04, and Debian 6 & 7
22:04:30 <tcohen> each one has its own DB
22:04:43 <tcohen> tweaks might be needed to the launching scripts
22:04:56 <tcohen> I ask everyone interested (specially RMaints)
22:05:18 <tcohen> to take a look and let me know their suggestions or stuff that needs to be done
22:05:43 <tcohen> #info Jenkins tasks have been changed/updated, feedback from RMaints and anyone interested is expected
22:06:31 <tcohen> Also, we are exploring the use of Trello to coordinate more efforts on the development team
22:07:01 <tcohen> Katrin is experimenting for QA, I expect dcook to do it on for his Search code rethink/rewrite effort
22:07:15 <tcohen> #info Koha Community org on Trello can be found at https://trello.com/kohadevel
22:07:48 <bgkriegel> #info Bernardo Gonzalez Kriegel, Argentina & late
22:08:12 <tcohen> #info anyone that wants to take a look at the Trello boards for Koha Community, just let tcohen know
22:08:55 <tcohen> also, I pushed my first "big patchset" (bug 9811)
22:08:55 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9811 enhancement, P5 - low, ---, jonathan.druart, Pushed to Master , Patrons search improvements
22:09:22 <tcohen> I'm excited, and expect to have feedback if something needs improvement
22:09:55 <tcohen> also, now bug 11703 is passed-qa, i'm considering it for pushing soon, tomorrow i'll be testing it too
22:09:55 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11703 enhancement, P5 - low, ---, kyle, Passed QA , Convert checkouts table to ajax datatable
22:10:19 <tcohen> questions on RM 3.8 comments?
22:10:50 <tcohen> s/\.8/\.18/ :-P
22:11:36 <tcohen> ok, moving on?
22:12:42 <cait> yep
22:12:44 <cait> move on :)
22:13:00 <tcohen> Ah, I forgot to mention that the new jenkins setup made visible some problems, most notably Perl 5.18 related
22:13:10 <tcohen> anyone that wants to take a look is welcome
22:13:21 <tcohen> ok, moving on
22:13:27 <tcohen> #topic Additions to Coding Guidelines
22:14:04 <tcohen> it's been discussed that non-XSLT should be deprecated
22:14:08 <tcohen> #link http://lists.koha-community.org/pipermail/koha-devel/2014-April/040456.html
22:14:54 <tcohen> on the first part we discussed changing the coding guidelines to reflect that
22:15:10 <eythian_> It'd be good to have a plan, like with prog->bootstrap
22:15:26 <eythian_> e.g. start making XSLT default, then in a couple of releases remove it.
22:15:33 <cait> xslt is already default :)
22:15:36 <eythian_> Just to ensure everyone has a heads up.
22:15:37 <eythian_> oh good :)
22:15:49 <cait> the next step would be identify features that are non-xslt only
22:15:54 <cait> it appears there is at least one
22:16:00 <tcohen> and sysprefs
22:16:01 <wahanui> hmmm... sysprefs is one
22:16:05 <cait> HighlightOwnItemsOnOPAC HighlightOwnItemsOnOPACWhich
22:16:42 <cait> and gmcharlt has written up a suggested no coding guideline - http://paste.lisp.org/display/143068
22:16:55 <cait> hm new coding guideline... not no
22:17:00 <tcohen> #info suggested coding guideline by gmcharlt http://paste.lisp.org/display/143068
22:18:09 <tcohen> do we agree on that addition to the coding guidelines?
22:18:43 <eythian_> +1
22:18:44 <tcohen> the plan is to freeze non-XSLT related code during 3.18
22:18:59 <cait> +1
22:19:26 <cait> adding no new features to non-xslt
22:19:58 <tcohen> +1
22:20:03 <tcohen> agreed?
22:20:07 <tcohen> #agreed add a deprecation warning to coding guidelines
22:20:28 <tcohen> #topic Bugs
22:20:50 <tcohen> I mentioned two bugs that remove stuff
22:21:01 <tcohen> which are passed QA
22:21:23 <cait> Removal of C4/Maintainance.pm - Bug 12456
22:21:23 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12456 normal, P5 - low, ---, yohann.dufour, Pushed to Master , The file C4/Maintainance.pm can be removed
22:21:25 <tcohen> bug 12456 (already on master)
22:21:32 <cait> Removal of misc/cronjobs/rss/rss.pl uses HTP - Bug 9000
22:21:32 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9000 enhancement, P5 - low, ---, gmcharlt, Passed QA , misc/cronjobs/rss/rss.pl uses HTP
22:22:06 <tcohen> does anyone have any concern on removing rss.pl?
22:22:39 <tcohen> it depends on HTML Template Pro which is not even a dependency for us
22:22:52 <tcohen> and we can always recover from git if needed
22:23:16 <eythian_> yeah, if it's never used and won't even work, toss it.
22:24:05 <tcohen> with cait we agreed earlier
22:24:45 <rangi> there are some people around the world using it, it will work fine if you installed koha a while ago and jsut kept on upgrading
22:25:00 <tcohen> rss.pl?
22:25:03 <rangi> so we would need to make it nice and clear in the release notes its being removed
22:25:04 <rangi> yes
22:25:11 <rangi> asheima said so in the last meeting
22:25:27 <rangi> if you have html::template::pro installed, it works
22:25:34 <cbrannon> Is anyone aware of an item limit for bib records?
22:25:37 <cait> it does
22:25:38 <rangi> and if you installed koha pre 3.4.0 you will have
22:25:42 <cait> it's not nice, but i tried it, untranslatable tho
22:26:01 <rangi> so we will have to document its being removed and provide easy instructions for an alternative
22:27:02 <cait> ashimema said at the last meeting he had checked with his coworkers and they 'would cope'
22:27:09 <tcohen> ok, i'll send an email to the general list as we said in part 1
22:27:18 <rangi> yes, thats fine for those who have a support company
22:27:33 <rangi> i still think we need to make it very clear in the release notes (not just an email to the list)
22:27:36 <cait> yes, so far it's just the only feedback from users we have
22:27:38 <tcohen> maybe they are interested in improving it
22:27:42 <rangi> im not against removing it
22:27:59 <cait> gmcharlt has also asked again on twitter, we can do mailing list and release notes
22:28:06 <rangi> just that it doesnt do the same thing as a saved search, so you will need to tell people how they can do the same thing
22:28:12 <bag> hey cbrannon there is a meeting going on - but I think you are looking for this http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11096
22:28:12 <huginn> 04Bug 11096: major, P5 - low, ---, gmcharlt, Pushed to Master , Koha cannot retrieve big records from Zebra
22:28:30 <cbrannon> sorry
22:28:35 <cbrannon> thanks
22:28:55 <tcohen> ok, we earlier agreed that there was no rush for it
22:29:07 <tcohen> and that a mail to the general list should be sent
22:29:12 <tcohen> (i'll do it)
22:29:21 <tcohen> asking people if they rely on that
22:29:49 <tcohen> #action tcohen will ask on the mailing list if someone still uses misc/cronjobs/rss/rss.pl (bug 9000)
22:29:49 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9000 enhancement, P5 - low, ---, gmcharlt, Passed QA , misc/cronjobs/rss/rss.pl uses HTP
22:30:21 <tcohen> #info rangi asked that removal should imply a clear statement for the users to be aware of the removal
22:31:16 <tcohen> agreed on that path?
22:31:39 <rangi> yep
22:31:58 <tcohen> so, next is
22:32:09 <tcohen> UTF-8 cleanup - Bug 11944
22:32:09 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11944 major, P5 - low, ---, jonathan.druart, Needs Signoff , Cleanup Koha UTF-8
22:32:33 <tcohen> Joubu worked hard on that. It is a tricky one
22:32:54 <tcohen> gmcharlt said he'll be reviewing that patch set
22:33:20 <tcohen> we need as many eyes as possible on that one
22:34:35 <cait> #info gmcharlt will set a date for a gbsd for the utf-8 clean up
22:35:43 <tcohen> #info cait will put the GBSD for UTF.8 cleanup in next general meeting's agenda
22:35:52 <cait> oh right.. there was that
22:35:54 <cait> :)
22:36:01 <tcohen> next is removal of prog/CCSR themes
22:36:35 <tcohen> #info oleonard said he'll be working on patches for that
22:36:54 <cait> oleonard++
22:37:10 <tcohen> defaults need to be changed, sysprefs deleted, and so on
22:37:39 <tcohen> #info Removal of prog/CCSR themes (bug 11346) - oleonard will be working on those patches
22:37:39 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11346 normal, P5 - low, ---, oleonard, NEW , Deprecate the PROG and CCSR themes
22:38:10 <rangi> oleonard++
22:38:23 <tcohen> one thing worth mentioning is that in will imply changing the opactheme syspref
22:38:57 <tcohen> syspref == ccsr || prog -> bootstrap
22:39:21 <rangi> yep
22:39:42 <tcohen> next is the removal of C4/SQLHelper
22:40:48 <tcohen> #info yohann sent several patches to move C4::SQLHelper-dependent code to using DBIx
22:41:14 <tcohen> khall_away offered to help him with that
22:41:26 <tcohen> and they are talking on hte public list about that
22:41:48 <tcohen> yohann++
22:42:14 <tcohen> ok, moving on
22:42:18 <tcohen> Better ways to manage MARC Frameworks - Bug 12477
22:42:18 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12477 major, P5 - low, ---, gmcharlt, NEW , We need better ways to manage MARC Frameworks
22:42:25 <tcohen> bgkriegel?
22:42:26 <wahanui> bgkriegel is, like, on a signoff spree
22:42:56 <bgkriegel> well, as said earlier, need opinions/ideas
22:43:28 <bgkriegel> I'm for using xml, at last in frameworks
22:43:37 <bgkriegel> other files could be also
22:43:58 <bgkriegel> main reason is to ease translations
22:44:00 <tcohen> the idea is to use xml for generating the data
22:45:11 <bgkriegel> it will be useful if some want to comment on that bug
22:45:25 <tcohen> using XML has the advantage that the current translation tools like it
22:45:38 <rangi> id like to see it as a first step away from being MARC specific
22:45:48 <rangi> id like to move it to cataloguing frameworks
22:45:54 <rangi> which might be marc
22:46:02 <rangi> might be dc, might be whatever
22:46:10 <tcohen> interesting
22:46:10 <wahanui> hmmm... interesting is sometimes good and sometimes bad
22:46:11 <rangi> xml seems like a good step in that direction
22:46:59 <wizzyrea> ^^
22:47:11 <wizzyrea> cataloguing_frameworks++
22:47:12 <rangi> with that, plus elasticsearch .. we are moving away from 1968 :-)
22:47:13 <tcohen> rangi: if you have any idea on an XML model that should help going that direction, please step in :-D
22:47:46 <tcohen> hi wizzyrea
22:48:05 <wizzyrea> most of the metadata formats have dtds I thought...
22:49:52 <tcohen> the cataloguing interface needs to be rewritten to support that I guess
22:50:01 <cait> hm for the data i think yes, but not sure that's the same
22:50:27 <cait> we would have to add to it maybe, but use vor validation?
22:50:51 <bgkriegel> and what about rancor?
22:51:01 <cait> not sure what i say makes sense it's quite late here
22:51:25 <rangi> thats designed heavily for cataloguers (ie people who like MARC) i doubt we'd touch that
22:52:01 <wizzyrea> could probably take some cues from projects like greenstone
22:52:08 <rangi> just not locking us into only being able to represent marc fields would be the first step
22:54:12 <tcohen> rangi et al: do u plan to work on that regarding the ES integration efforts?
22:54:30 <rangi> not in this release cycle no
22:55:02 <rangi> well elasticsearch already lets us index anything, not just marc so nothing more needed there really
22:55:30 <eythian_> Though a lot of the existing stuff it hooks into expects marc, but that's a solvable problem.
22:55:31 <rangi> just whatever we choose to represent our frameworks, it would be nice to not build in assumptions that it will always be MARC
22:55:56 <rangi> ie it doesnt have to support others yet, but just not make it harder to :)
22:56:28 <tcohen> DSpace uses an XML file to model the input form (cataloguing framework)
22:57:28 <cait> the change is also to make it easier translatable - i think maybe not try tomake it do everything now, but make afirst step?
22:57:29 <wahanui> okay, cait.
22:57:32 <tcohen> anyway, what bgkriegel want's to do for now, is abandoning the SQL files stored in the source tree, and move them to XML for better translation
22:57:48 <rangi> yep
22:58:05 <tcohen> we currently have one file for each language
22:58:37 <tcohen> ok, if anyone has any comment to do on that, approach bgkriegel
22:58:47 <tcohen> or comment on the bug (feedback is always welcome)
22:59:02 <tcohen> dcook for instance, proposed YAML instead
22:59:20 <tcohen> ok, moving on now, agreed?
22:59:49 <tcohen> #topic Testig of APIs, CAS, LDAP...
23:00:34 <tcohen> the QA team has several bugs in their queue
23:00:43 <tcohen> due to the lack of a proper testing environment
23:00:58 <tcohen> not everyone has a CAS or LDAP server
23:01:05 <tcohen> SIP, etc
23:01:12 <tcohen> biblibre set a CAS server for testing purposes
23:01:14 <tcohen> biblibre++
23:01:34 <tcohen> we still don't have an LDAP server for testing LDAP patches
23:01:37 * bag is working on getting an LDAP server for testing
23:01:43 <tcohen> :-D :-D
23:02:04 <bag> just got back in office from being out for about 40 days (work travel and vacation)
23:02:11 * tcohen is amazed most of the sentences are even aligned
23:02:17 <bag> so LDAP will come just not too fast
23:02:29 <bag> :)
23:02:52 <tcohen> bywater++
23:03:27 <tcohen> #actions ByWater is working to provide an LDAP server for testing purposes
23:04:06 <tcohen> ok next topic
23:04:11 <tcohen> #topic Big stuff we are working on
23:04:18 <tcohen> anyone?
23:04:19 <wahanui> Anyone? Anyone? Bueller? Bueller?
23:04:59 <tcohen> I mentioned earlier that I plan to work on a TemaTres<->Koha integration
23:05:02 <rangi> just the same as before
23:05:10 <bag> pianohacker just spent the last week working pretty heavily on http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11559
23:05:10 <huginn> 04Bug 11559: enhancement, P5 - low, ---, jweaver, Needs Signoff , Professional cataloger's interface
23:05:14 <rangi> elastic search, plack, and cover images
23:05:40 <bag> he should have more patches coming in another 3~4 weeks
23:05:42 <tcohen> bag: what needs to be done for rancor?
23:05:57 <tcohen> (from the release team)
23:06:27 <bag> right now pazpar2 isn't reliable - so pianohacker needs to decide on how he wants the z3950 searching done
23:06:56 <tcohen> ok, let everyone know if feedback is needed
23:07:07 <cait> :)
23:07:08 <bag> like why even change what we already have versus being creative with something new :)
23:07:42 <tcohen> :)
23:07:54 <cait> there is also the opac patch using pazpar2
23:07:57 <bag> will do
23:08:11 <bag> yup cait there is...
23:08:19 <cait> not sure what we could use instead
23:08:33 <bag> once we can have pianohacker in the "office" for a consistent period we'll be looking at all those again
23:08:44 <tcohen> excellent
23:09:42 <tcohen> rangi: about plack support
23:10:01 <tcohen> is there big stuff needing sign-off or any kind of feedback?
23:10:34 <eythian_> A few have been signed off, and one or two need a bit more work (of the ones I've done.)
23:10:51 * bag is working on getting 2 production sites up in the next two weeks for plack staff
23:11:06 <bag> see if we can't find some more bugs
23:12:28 <eythian_> yay bugs! :)
23:12:50 <tcohen> ok, i mentioned TemaTres
23:12:55 <eythian_> what is that?
23:12:56 <wahanui> well, that is the intended behavior?
23:13:16 <tcohen> is a tool for managing thesaurus and controled vocabularies
23:14:52 <bgkriegel> TemaTres: http://www.vocabularyserver.com/
23:15:03 <tcohen> thanks bgkriegel
23:16:18 <eythian_> That looks worthwhile.
23:16:54 <tcohen> we should move on, cait would fall asleep otherwise
23:17:07 <cait> huh?
23:17:17 * cait might already be half asleep
23:17:27 <cait> but it's the time
23:18:16 <tcohen> ok, moving on
23:18:31 <tcohen> #topic Dates of releases
23:18:44 <tcohen> we forgot to talk about that on part 1
23:19:01 <rangi> ah yeah
23:19:16 <tcohen> release dates are slippin
23:19:18 <rangi> ive notice we seem to be slipping from our release dates
23:19:39 <rangi> it used to be 15th was string freeze, and 22nd was release (for maintenance releases)
23:20:18 <rangi> but it kinda is all over the place now, which makes it harder for translators etc
23:20:54 <rangi> i just wanted to mention that, and see if people would like to try to get back to monthly regular releases
23:21:07 <bag> agreed - I think it should be back to 15th 22nd
23:21:24 <tcohen> yes, i'll talk to the guys about that
23:21:26 <tcohen> we can do it
23:21:30 <bag> I just don't want my calendar alerts to be wrong :P
23:21:31 <rangi> thanks
23:21:32 <bag> heh
23:21:56 <tcohen> ok
23:22:03 <cait> 22nd_releases++ :)
23:22:16 <tcohen> #topic Set time of next meeting
23:22:58 <tcohen> I proposed on koha-devel, trying a 3-week cycle for this meetings
23:23:19 <tcohen> thus, proposed July 23rd
23:23:37 <tcohen> same time
23:23:59 <tcohen> 15:00 UTC and 22:00 UTC
23:24:02 <eythian_> same_bat_time++
23:24:07 <rangi> +1
23:24:26 <bag> works  +1
23:24:58 <tcohen> http://bit.ly/1iXmSgC
23:25:06 <tcohen> ^^^^^^ kohacon14
23:25:40 <bag> ok I need dinner now
23:25:50 <tcohen> #agreed next meeting date: July 23rd (part 1: 15:00 UTC) (part 2: 22:00 UTC)
23:26:06 <tcohen> done
23:26:19 <tcohen> what was the command?
23:26:25 <tcohen> #endmeeting