14:08:29 <tcohen> #startmeeting Development IRC meeting 14 October 2015 - part 1
14:08:29 <huginn> Meeting started Wed Oct 14 14:08:29 2015 UTC.  The chair is tcohen. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:08:29 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:08:29 <huginn> The meeting name has been set to 'development_irc_meeting_14_october_2015___part_1'
14:08:39 <tcohen> #topic Introductions
14:08:40 <wahanui> #info wahanui, a bot that has become sentient
14:08:45 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
14:08:49 <nengard> #info Nicole C Engard, ByWater Solutions
14:08:58 <tcohen> please introduce yourselves like that ^^^^
14:09:03 <jajm> #info Julian Maurice, BibLibre
14:09:08 <ColinC> #info Colin Campbell PTFS-Europe
14:09:15 <khall> #info Kyle Hall, ByWater Solutions
14:09:23 <andreashm> #info Andreas Hedström Mace, Stockholm University Library
14:09:28 <barton> #info Barton Chittenden, ByWater Solutions
14:09:28 <brendan-bag> Brendan Gallagher ByWater
14:10:21 <tcohen> will wait one more minute
14:10:46 <brendan-bag> #info Brendan Gallagher ByWater
14:10:59 <cait> #info Katrin Fischer, BSZ
14:11:49 <tcohen> time
14:11:50 <tcohen> #topic RM 3.22 comments
14:12:25 <Joubu> #info Jonathan Druart
14:12:32 <tcohen> first of all, I want to apologize for the lag on the PQA queue
14:12:59 <tcohen> it has become more and more difficult to keep the pace on such big developments
14:13:03 <cait> tcohen++ looking better then the NQA ;)
14:13:22 <tcohen> testing them and making sure everything is ironed for the users worldwide
14:13:31 <tcohen> and having a life appart from that
14:13:32 <tcohen> heh
14:13:58 <nengard> tcohen I thought RMs weren't allowed to have lives? ;)
14:14:05 <tcohen> I'm happy with how things have been doing overall, but I know it is frustrating to see
14:14:17 <nengard> tcohen++
14:14:18 <tcohen> your work lag even when it was perr-review by several people
14:14:32 <tcohen> i think that will happen, always
14:14:47 <tcohen> because the RM position is very demanding
14:15:06 <tcohen> and it should be (somehow) funded so people can do it full time
14:15:23 <tcohen> just my two cents for the project's future
14:15:32 <brendan-bag> Here hear
14:15:40 <khall> tcohen++
14:15:48 <brendan-bag> Trying for that we are
14:15:49 <nengard> tcohen++
14:16:06 <tcohen> by 'funded' I mean that support companies should bring someone from their team to do it on work-hours
14:16:25 <tcohen> or whatever suits the community's possibilities at some point
14:16:40 <barton> btw, agenda at http://wiki.koha-community.org/wiki/Development_IRC_meeting_14_October_2015
14:16:47 <tcohen> i'm not complaining at all, I really enjoyed this, but it got more difficult than I expecetd
14:16:52 <tcohen> so
14:17:04 <tcohen> that was the "RM" bit
14:17:15 <tcohen> now the "3.22 comments" part :-P
14:17:45 <tcohen> some big stuff has been pushed recently
14:18:14 <tcohen> file-upload capabilities and refactoring
14:18:26 <marcelr> #info Marcel de Rooy
14:18:32 <tcohen> OAI implementation changes
14:18:51 <Joubu> bug 14321
14:18:52 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14321 enhancement, P5 - low, ---, m.de.rooy, Pushed to Master , Merge UploadedFile and UploadedFiles into Koha::Upload
14:19:21 <tcohen> that one requires ironing the deployment: i.e. we need to set a default upload_path
14:19:28 <marcelr> bug 14893
14:19:29 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14893 enhancement, P5 - low, ---, m.de.rooy, Needs Signoff , Separate temporary storage per instance in Upload.pm
14:19:57 <tcohen> overall things are pretty stable, even though jenkins is failing
14:20:22 <tcohen> #info tcohen asks patch authors to take care of things being broken on jenkins, might be your fault!
14:20:47 <tcohen> anyway
14:21:13 <tcohen> I repeat myself, but we need more teseting on koha-plack, that's the purpose of teh kohadevbox:ansible branch
14:21:30 <tcohen> Jonathan has been working on a couple problems we found
14:21:35 <tcohen> Joubu++
14:21:36 <cait> #link http://wiki.koha-community.org/wiki/Development_IRC_meeting_14_October_2015
14:21:40 <cait> Joubu++
14:21:59 <tcohen> but the fact is that we are a month and a half away from the release and there is no evidence
14:22:11 <tcohen> people have been testing the plack integration on the packages
14:22:18 <Joubu> bug 15005
14:22:19 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15005 major, P5 - low, ---, jonathan.druart, Needs Signoff , (Plack) Use of SCRIPT_NAME makes Koha generate wrong URIs
14:22:34 <bag> back
14:23:17 <tcohen> #info bug 15005 is really tricky to solve, with possible integration issues, and requires expert eyes
14:24:22 <tcohen> we have enough time to iron things out, but we will need to focus on this things
14:24:51 <tcohen> #action tcohen volunteers to help people set a suitable test environment for anywant willing to spend a couple minutes testing plack
14:24:56 <Joubu> stress session?
14:25:02 <tcohen> ah, that
14:25:02 <wahanui> ah, that is just to say that everything should be on one line
14:25:45 <tcohen> #info ByWater has provided a VM with external access, in which we will set a Koha+plack install so we can do stress tests on it
14:25:50 <tcohen> bywater++
14:26:03 <tcohen> questions?
14:26:04 <wahanui> questions are good :)
14:26:09 <Joubu> when?
14:26:22 <tcohen> i can set everything up tomorrow morning
14:27:04 <tcohen> #action tcohen will send an email to the devel list with data about the koha-common+plack server
14:27:09 <Joubu> we need as many people as possible, to simulate a normal circulation/search/etc. workflow
14:28:06 <tcohen> questions about 3.22?
14:28:10 <Joubu> It would be preferable to push 15005 before the stress session
14:28:53 <Joubu> yes, do you plan to push the ES work?
14:28:58 <tcohen> Joubu: I didn't realized you already provided the needed followups for ->url
14:29:01 <Joubu> and bug 11559?
14:29:02 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11559 enhancement, P5 - low, ---, jweaver, Needs Signoff , Professional cataloger's interface
14:29:14 <Joubu> and the REST api "base"
14:29:15 <nengard> Would love to see ^^ in 3.22
14:29:28 <andreashm> us too
14:30:02 <tcohen> I tested it and it has issues, but it can be pushed as it is an opt-in, once it gets PQA
14:30:08 <tcohen> (rancor)
14:30:09 <Joubu> I need to know the priorities to focus my work for the next month
14:30:39 <tcohen> I don't think the ES work will make it
14:30:46 <bag> imo ES needs more testing, I’ve tested it and I’ve got it set up,
14:31:07 <tcohen> I think the REST work should be pushed if we generate the needed patches for integrating with the packages
14:31:27 <tcohen> that's my opinion
14:31:32 <bag> bug number for need patches?
14:31:43 <bag> bug 13799
14:31:44 <wahanui> it has been said that bug 13799 is ready to go in master, if nobody complains about it
14:31:44 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13799 new feature, P5 - low, ---, julian.maurice, Failed QA , Add base for building RESTful API
14:31:54 <Joubu> I have not willing to see 13799 pushed without any guidelines
14:31:57 <tcohen> I welcomed ashimema's followups, I guess we just need to solve minor issues right now
14:32:09 <ashimema> :)
14:32:14 <Joubu> I thing we need to see discussion (yes again) on bug 14974 before
14:32:15 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14974 enhancement, P5 - low, ---, jonathan.druart, In Discussion , Use the REST API for cities
14:32:32 <ashimema> ooh.. meeting..
14:32:32 <wahanui> meeting is probably in two days, i thought was tomorrow. plenty of time then
14:32:34 <ashimema> oops
14:32:35 <tcohen> ashimema++
14:32:46 <ashimema> #info Martin Renvoize - PTFS Europe
14:33:27 <ashimema> agree with Joubu.. we're getting there with the rest stuff.. but I'd like to see some concrete examples and guidlines around implimenting controllers for it
14:33:30 <tcohen> I think ashimema's comment on 13799 should be the basis for those guidelines
14:33:35 <ashimema> so we get adoption going.
14:33:46 <Joubu> code please!
14:33:51 <ashimema> I know khall, joubu and I are all working on some examples
14:34:15 <Joubu> mine is submitted, I don't plan to do more
14:34:22 * ashimema goes off to remind himself of the comment
14:34:27 <ashimema> :)
14:34:45 <ashimema> I'm trying to find some time for my angualr guy to attack it
14:35:16 <tcohen> so you think we need guidelines on how the UI should use the REST api to accept it pushed?
14:35:37 <Joubu> (definitely)
14:35:41 <tcohen> or just guidelines on how to build the controllers?
14:35:44 <ashimema> not exactly.. I'd love to see some..
14:36:17 <ashimema> but I do think we need some clear guidelines on how controllers should be coded.. or rather spec'd
14:36:20 <tcohen> i don't think we need more than guidelines on the controllers code
14:36:36 <ashimema> it's important to build good specs with swagger.. else allot of the 'win' from using it is lost..
14:36:41 <Joubu> I'd like to see alternative patches suggested on 14974, to do exactly the same things as mine
14:36:47 <tcohen> becuase otherwise we should make a decision on the UI tools (angular?) before we can have a REST api
14:36:58 <ashimema> the current specs are too sparse in terms of the requests and responses are not schema'd up..
14:37:21 <Joubu> what's the point to have a "rest api base" if we don't know how to use/improve it?
14:37:23 <ashimema> i.e there is currently no validation going on before and after the controller code runs to varify what you 'think' you are getting in is what you actually are..
14:37:26 <ashimema> and vica versa
14:37:57 <ashimema> UI wise, i think that's the next step.. hopefulyl closely behind..
14:38:04 <Joubu> Better than specs, I'd prefer some code
14:38:35 <ashimema> I think getting the server level into master sooner rather than later good.. but also think before full release we need the ui examples and documentation in too
14:38:40 <ashimema> does that make sense
14:39:54 <tcohen> if we had a technical comitee, with schedules to make decisions I'd say we should wait for that
14:40:05 <tcohen> but we don't, we make decisions in places like this meeting
14:40:20 <tcohen> and mostly with code, provided by people that actually work on the implementations
14:40:47 <bag> that’s so true
14:40:55 <bag> catch 22
14:41:26 <tcohen> i'm happy with extracting martin's comments on how we should split the swagger file, and his guidelines on the types we need to choose for things
14:41:43 <tcohen> and consider that, and Julian's implementation something close to a guideline
14:41:48 <bag> seems reasonable
14:41:53 <tcohen> but I accept that we might not agree on that
14:42:22 <tcohen> I read Jonathan's implementation, and if it complied with martin's recommendation, I'd push it too :-P
14:42:32 <tcohen> well, I'm not sure about the UI part
14:42:41 <tcohen> but the controller and backend, yes
14:43:52 <Joubu> Where is Julian's implementation?
14:43:53 <tcohen> I'll close this topic, as we moved to the next one (REST :-D)
14:44:30 <tcohen> but first, I'd like to set feature slush for 23rd October
14:45:52 <tcohen> questions about feature slush
14:45:53 <tcohen> ?
14:46:06 <Joubu> In the bug reports linked to the "api base" I don't see a guideline on how using the REST api from Koha scripts
14:46:48 <Joubu> it's pretty soon :)
14:47:23 <marcelr> how do you explicitly define feature slush ?
14:47:54 <tcohen> the point were things that things that are not PQA are not *elegible* for poshing
14:47:58 <ashimema> I'll post the promised followups ot the rest bug shortly
14:48:01 <ashimema> just writing them now
14:48:12 <bag> sweet thanks ashimema
14:48:15 <ashimema> (found a bug in swagger2 lib which i'm fixing first.. hense the slow down)
14:48:28 <nengard> So we need everything that is signed off passed qa by the 23rd or else it won't be in 3.22?
14:48:30 <nengard> Got it
14:48:45 <marcelr> no this is about new features only
14:48:48 * ashimema has been writing tests furiosly for the Mojo Swagger2 lib the past few weeks.. to make sure feature we are using don't go away ;)
14:49:06 <ashimema> feature slush good :)
14:49:17 <nengard> oh good to know marcelr
14:49:31 <tcohen> i'm moving it November 26th, because people tend to work hard before the feature slush, and no point setting it to a friday when I'm not going to have time to push things
14:49:32 <marcelr> tcohen: and enhancements?
14:49:45 <khall> ashimema++
14:49:50 <tcohen> ashimema++
14:50:03 <marcelr> October 26th i guess
14:50:13 <tcohen> ah, yes, thanks marcelr
14:50:26 <tcohen> #info feature slush is October 26th
14:51:19 <tcohen> marcelr: I'm not sure, I guess small enhancements are not a problem, those that look more like a feature are
14:51:38 <marcelr> clear enough
14:52:11 <tcohen> in the end, it will depend on how much time I can spend on this, because I will be focusing on ironing things
14:52:27 <tcohen> unless people start seriously testing and let me spend more time pushing :-P
14:53:02 <tcohen> the next topic is the REST api implementation
14:53:13 <tcohen> #topic RESTful API Implementation
14:54:05 <Joubu> tcohen: you can count me in #testing
14:54:12 <tcohen> about bug 13799, I expected that Julian and Martin explained us the implementation details/decisions, and then Martin's followups, with the aim to have a general idea of those guidelines
14:54:13 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13799 new feature, P5 - low, ---, julian.maurice, Failed QA , Add base for building RESTful API
14:54:23 <tcohen> thanks Joubu
14:55:15 <tcohen> is there any volunteer that could extract that information from the bug so we start a wiki for those "guidelines"?
14:55:34 <Joubu> and code? :)
14:55:45 <khall> what guidelines are we looking for?
14:55:56 <khall> to add new services to the api, using the api, or both
14:56:07 <Joubu> both
14:56:11 <tcohen> my opinion is that we need the first
14:56:22 <tcohen> as mandatory
14:56:25 <khall> agreed.
14:56:35 <ashimema> I can write some guidelines based around using the swagger stuff meaningfully
14:56:37 <tcohen> we don't even have angular pushed to master
14:56:42 <ashimema> and write some examples too
14:56:48 <khall> I'll create the wiki page if ashimema and Joubu can go through and tweak it
14:57:03 <cait> back...
14:57:09 <ashimema> the clientside I'm less up to speed on and am honestly not entirely sure of the best aproach as yet..
14:57:38 <Joubu> khall: I have no idea on how to use it and I am not involved in the discussion from the beginning, so not me :)
14:57:40 <khall> agreed, the backend is far more important at this point
14:57:43 <tcohen> the guidelines should cover:
14:57:49 <ashimema> would like to see some angualr based stuff sooner rather than later.. and to see some non-blocking async calls going on.. we're really nto very good at async calls yet
14:57:54 <khall> Joubu: np!
14:58:03 <tcohen> - how to structure the controller scripts
14:58:16 <tcohen> - how to make decisions on the endpoint naming, etc
14:58:18 <khall> ashimema: a wiki page on that would be good
14:58:21 <ashimema> k.. khall and I will tag team writing that page :)
14:58:24 <tcohen> - how to organize the swagger files
14:58:25 <khall> with good and bad examples
14:58:34 <ashimema> certainly ;)
14:58:57 <ashimema> we have some nasty blocks in the few places (the patrons search page in the staff cleint is very blocky currently)
14:59:14 <ashimema> I'll do the controllers + swagger guidlines first..
14:59:32 <ashimema> then move onto utilising them clientside (with help of my tame angular dev)
14:59:47 <khall> ashimema: that sounds most excellent
15:00:07 <ashimema> :)
15:00:20 <tcohen> #info Jonathan worked on his own REST implementation test-drive on bug 14974, please, Mojo/Swagger/REST experts take a look and provide feedback
15:00:21 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14974 enhancement, P5 - low, ---, jonathan.druart, In Discussion , Use the REST API for cities
15:00:28 <ashimema> sorry guys.. my auth maintainer hat is beign put down for a while whilst this api stuff goes through the motions ;)
15:00:37 <ashimema> only so many hours in a day
15:01:03 <bag> :)
15:01:26 <tcohen> ashimema: we forgive you, if you help us have those guidelines :-D
15:01:49 <pianohacker> hallo
15:02:15 <tcohen> pianohacker: just in time, we said next one to login was the volunteer
15:02:21 <pianohacker> uh oh
15:02:28 <khall> lol
15:02:33 <pianohacker> volunteer for what? Finishing full port to dbic?
15:02:46 <ashimema> :)
15:02:59 * ashimema would love full dbic port.. (and a cleaner db schema to boot)
15:03:04 <tcohen> pianohacker: yes, but we need a full rewrite of all the things too, thanks for volunteering!
15:03:09 <pianohacker> oh, cool
15:03:13 <pianohacker> in perl 6 of course
15:04:12 <tcohen> pianohacker: yes, but needs to be backwards compatible
15:04:23 <pianohacker> with python? Can do!
15:04:26 <tcohen> back to perl 5.6
15:04:44 <pianohacker> man, I thought you were volunteering me for something HARD
15:04:45 <tcohen> ok, so can I put actions?
15:05:37 <ashimema> go for it
15:06:10 <tcohen> #action Kyle volunteers to start a wiki page for the REST guidelines
15:06:10 <tcohen> #action Martin volunteers to polish some Controller / Swagger guidelines for the REST implementation
15:07:15 <Joubu> and code/example, someone?
15:07:58 * Joubu has the impression that he is repeating himself
15:08:03 <tcohen> action pianohacker volunteers to take a look and comment on 14974
15:08:07 <tcohen> :-P
15:08:22 <pianohacker> good to know!
15:08:34 <tcohen> if you accept I'll add the dash
15:08:42 <bag> yes
15:08:45 <pianohacker> oh yeah can do
15:08:49 <tcohen> #action pianohacker volunteers to take a look and comment on 14974
15:08:52 <bag> excellent
15:08:57 <tcohen> pianohacker++
15:09:40 <tcohen> ashimema: please comment on anything you need, or whatever I/we can help with regarding the docs
15:10:09 <tcohen> and thanks
15:10:22 <tcohen> moving on
15:11:24 <ashimema> will also try to do some code example Joubu.. to go with the docs
15:13:16 <bag> sweet
15:15:50 <ashimema> :)
15:16:58 <tcohen> ok, sorry, had my boss asking me about my work :-/
15:17:07 <tcohen> (DSpace things)
15:17:26 <tcohen> #topic 'Big stuff we are working on'
15:17:36 <Joubu> tcohen: You don't do anything at work, just surfing on facebook, everybody knows that
15:17:43 <tcohen> yeah
15:17:54 * tcohen seriously things his boss belives so
15:18:42 <ashimema> so.. Bug stuffs?
15:18:49 <ashimema> s/Bug/Bug
15:19:14 <pianohacker> Working on rancor atm, but I think that's already been discussed
15:19:15 * tcohen suspects the guidelines will be full of typos
15:19:23 <tcohen> :-P
15:19:24 <bag> HA
15:20:16 <tcohen> pianohacker: yeap
15:20:25 <tcohen> ok, moving on
15:20:34 <tcohen> #topic Specific bugs that need feedback
15:21:14 <tcohen> #info please take a look at tests failing on jenkins, specially if your patches might be guilty
15:21:42 <pianohacker> tcohen: at least one of the jenkins build failures seemed to be due to DB connection issues
15:21:43 <tcohen> I'd also like to ask the QA team to give packages-related patches some priority
15:22:10 * ashimema is terrible at holding conversations in multiple windows and managing to stave off the typo's too
15:22:11 <tcohen> pianohacker: thanks, will check (on that free time I have heheh)
15:22:19 * Joubu missed the big bugs stuffs...
15:22:32 <tcohen> Joubu: only rancor was mentioned
15:22:40 <Joubu> we absolutely need to test 13618
15:22:40 <tcohen> would you like to add something?
15:22:45 <Joubu> because I won't rebase it for months!
15:22:47 <pianohacker> tcohen: you find any of that "free time" stuff, make sure to share your source
15:22:51 <pianohacker> bug 13618
15:22:51 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13618 normal, P5 - low, ---, jonathan.druart, Needs Signoff , Prevent XSS in the Staff Client and the OPAC
15:22:54 <barton> tcohen: silly question, but where do I look to see if one of my patches has broken jenkins? is 'prove' enough?
15:23:07 <Joubu> and I have provided a quick patch on bug 14778, because it was blocker for everybody
15:23:08 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14778 normal, P5 - low, ---, jonathan.druart, Failed QA , Get rid of DBIx::Connector
15:23:11 <Joubu> now there is a patch
15:23:15 <Joubu> and nobody cares
15:23:20 <pianohacker> barton: there's a link in the email that takes you to the jenkins site, and you can see the test output there
15:23:53 <tcohen> jenkins is sending emails to patch authors since it started failing
15:24:06 <tcohen> it doesn't know what patch broke things
15:24:15 <tcohen> (i.e. is not bisecting the git repo)
15:24:31 <pianohacker> Joubu: how sure are we that bug 13618 covers all the areas that output HTML?
15:25:06 <pianohacker> Joubu: and I think everyone very much cares but has no idea what is wrong
15:25:07 <Joubu> no way to know
15:25:33 <reiveune> bye
15:25:59 <Joubu> if we don't manage to make DBI::Mock works, since kick it out
15:26:04 <Joubu> s/since/then
15:26:13 <tcohen> Joubu: I agree
15:26:38 <pianohacker> does TestBuilder at least partially remove the need for it?
15:26:52 <Joubu> ye
15:26:53 <Joubu> yes
15:26:56 <tcohen> hmm
15:27:01 <Joubu> say yes
15:27:04 <Joubu> more or less
15:27:07 <tcohen> I think there is a conflict
15:27:24 <Joubu> but the tests using the DB Mock are not very useful
15:27:41 <tcohen> because TestBuilder is used for 'integration tests', in the sense that they need data on the DB, and things like that
15:27:59 <tcohen> Unit tests on t/ should actually mock everything+}
15:28:28 <tcohen> the fact that we are reaching DBIx::Class on some tests that are mocking DBI, is a symptom that we have mixed things too much
15:28:36 <Joubu> the tests using it could cover more use cases if they were DB dpes
15:28:37 <Joubu> deps
15:28:53 <tcohen> I'd say we shouldn't be using DBI::Mock on t/db_dependent
15:28:58 <pianohacker> there's only 6 tests that use DBD::Mock, but 4 of them (Koha, Biblio, Calendar and Members/cardnumber) are non-db-dependent
15:29:14 <Joubu> pianohacker: did you test the patchset on a customer's server?
15:29:15 * ashimema is catching back up
15:29:57 <pianohacker> Joubu: no, the site where we were experiencing issues has gone quiet for reasons we don't entirely understand :/
15:29:58 <Joubu> pianohacker: I have much more occurrences
15:30:02 <Joubu> t/Acquisition/Invoice.t for instance
15:30:29 <tcohen> pianohacker: every test file that uses t::lib::Mocks
15:30:39 <pianohacker> ohhhh, shoot.
15:30:49 <tcohen> the problem is mixing things
15:32:08 <John> Johnster
15:32:46 <tcohen> ok
15:33:13 <tcohen> #info 14778 is very important and needs urgent feedback
15:33:26 <Joubu> Note that it's not important for me :)
15:33:30 <ashimema> also on my todo pile is that bug ;)
15:33:40 <ashimema> 'tis for me
15:33:43 <John> I'm just happy that I got an install up and running--with one notable exception!
15:34:02 <ashimema> but need to get the customers test server up to date before I can get them to test it
15:34:34 <tcohen> thanks ashimema
15:34:55 <Brooke> o/
15:35:34 <tcohen> ok, I think it is time to move on
15:35:51 <tcohen> #topic Set time of next meeting
15:36:30 <tcohen> #info there will be at least one more dev meeting, tcohen might call for a topic-specific dev meeting if there is something urgent that needs feedback
15:36:57 <tcohen> #info please communicate fluently regarding bugs and things that might hit the next release
15:37:50 <tcohen> thanks everyone for attending and specially for volunteering, you all rock
15:38:03 <nengard> thanks tcohen
15:38:05 <tcohen> #endmeeting