15:09:34 <tcohen> #startmeeting Development IRC meeting, 21 January 2015
15:09:34 <huginn> Meeting started Wed Jan 21 15:09:34 2015 UTC.  The chair is tcohen. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:09:34 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:09:34 <huginn> The meeting name has been set to 'development_irc_meeting__21_january_2015'
15:09:42 <cait> #info Katrin Fischer, BSZ, Germany
15:09:59 <tcohen> #topic Introductions
15:10:00 <ashimema_> #info Martin Renvoize, PTFS Europe
15:10:04 <khall> #info Kyle Hall, ByWater Solutions
15:10:05 <tcohen> please introduce yourselves
15:10:10 <ColinC> #info Colin Campbell, PTFS Europe
15:10:13 <barton> #info Barton Chittenden, Bywater, Louisville, KY, USA
15:10:16 <tcohen> #info Tomas Cohen Arazi, Universidad Nacional de Cordoba
15:10:21 <kivilahtio> #info Olli-Antti Kivilahti Vaara-kirjastot
15:10:26 <jenkins_koha> Starting build #15 for job Koha_Docs_3.16.x (previous build: SUCCESS)
15:10:29 <jenkins_koha> Project Koha_Docs_3.16.x build #15: SUCCESS in 10 sec: http://jenkins.koha-community.org/job/Koha_Docs_3.16.x/15/
15:10:29 <jenkins_koha> * Nicole C. Engard: update HomeOrHoldingBranch
15:10:30 <jenkins_koha> * Nicole C. Engard: add note about independentbrances to circ rules
15:10:31 <oleonard> #info Owen Leonard, Athens County Public Libraries, OH, USA
15:10:40 <nengard> #info Nicole Engard, ByWater Solutions
15:10:41 <ashimema_> I might not be here for the whole thing.. so apologies now if I dissapear.. other half wants company at a midwifes appointment
15:10:54 <oleonard> other_half++
15:10:57 <marcelr> #info Marcel de Rooy
15:11:35 <cait> #link http://wiki.koha-community.org/wiki/Development_IRC_meeting_21_January_2015
15:12:02 <Joubu> #info Jonathan Druart, BibLibre
15:12:39 <tcohen> ok, moving on
15:13:01 <tcohen> #topic RM 3.18 comments / catching up after vacation
15:13:19 <tcohen> I just wanted to say I'm almost back from vacation
15:13:31 <tcohen> I'm trying to catch up with what you've been doing
15:14:00 <tcohen> I've been around (Stockholm syndrom) but not involved on a daily basis on RM duties
15:14:32 <tcohen> the main purpose of this meeting was to be back on track and hear from you all what's been going on
15:14:46 <tcohen> I put a small agenda (thanks Katrin for the link) to start with
15:14:53 <paul_p> #info Paul Poulain, BibLibre
15:15:12 <tcohen> but I'm sure there are several other stuff on the pipe, that we might discuss on a next meeting
15:15:15 <paul_p> (very busy answering an RFP, but you can yell me if needed)
15:15:16 <tcohen> hopefully soon
15:15:28 <tcohen> questions?
15:15:55 <Joubu> how was your holiday? :)
15:16:01 <ashimema_> :)
15:16:04 <nengard> I just want to let you all know that I'm back and working on getting the 3.18 manual up to date and then I will submit the help file patches for 3.18
15:16:09 <nengard> sorry that it's so late
15:16:13 <paul_p> tcohen = THE question: is manuel fine ? sleeping well ?
15:16:28 <paul_p> (don't say it's too hard, or ashimema will flee ;-) )
15:16:37 <ashimema_> hehe
15:16:54 <tcohen> my holidays, were short, I've mostly been enjoying Manuel
15:16:59 * oleonard suggests ashimema_ sleep while he can
15:17:08 <tcohen> we've been sleeping well, so far
15:17:51 <fridolin> tcohen: oki
15:18:25 <khall> that's great!
15:19:08 <Joubu> I think Manuel is the youngest signoffer of a patch in Koha ;)
15:19:15 <tcohen> he's got some pain in his belly ths days, so it is gwtting shorter :P but I like taking care of him
15:19:37 <tcohen> Manuel is chairing the meeting actully
15:19:44 <kivilahtio> Manuel?
15:19:54 <tcohen> ok, jokes aside, we are great
15:19:59 <tcohen> kivilahtio: my son
15:20:06 <tcohen> month and a half old
15:20:11 <kivilahtio> congratulations!
15:20:33 <tcohen> ok, moving on :D
15:20:52 <tcohen> next is General technical discussion
15:21:08 <tcohen> #topic Out of the box Plack support
15:21:35 <kivilahtio> oooo, that's cool
15:21:53 <tcohen> it'd be great that people with experience in Plack, start to think of the best way to set plack
15:22:24 <tcohen> there are some pending issues to make it default, notably on the intranet
15:22:29 <ashimema_> I sent a mail to the list asking for advice on that front..
15:22:41 <tcohen> comments on that? some volunteer?
15:22:43 <marcelr> what is the status of plack in relation to staff client?
15:23:02 <ashimema_> We have 'Plack for developers' pushed (bug 7844), 'Plack with nginx for production' in testing (bug 9316) and I'm aware of at least two koha-plackify scripts lurking around, Plackify-koha-common, koha-plack.
15:23:02 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7844 enhancement, P5 - low, ---, dpavlin, RESOLVED FIXED, plack scripts for developers
15:23:03 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9316 enhancement, P5 - low, ---, kyle, Needs Signoff , Add Nginx install options with plack
15:23:36 <ashimema_> I think the first step is to at least recommend, back one of those approaches so developers can install it with ease to start testing against it regularly
15:23:37 <tcohen> i know of issues with syspref caching
15:24:06 <ashimema_> right.. I need to dissapear :(..
15:24:09 <ashimema_> will read the minutes after.
15:24:20 <ashimema_> #info ashimema_ has left
15:24:55 <tcohen> #chair cait
15:24:55 <huginn> Current chairs: cait tcohen
15:25:04 <cait> huh?
15:26:02 <cait> ok, where were we?
15:26:17 <cait> have been in meetings all day and a long phone conf - so please have patience with me :)
15:26:32 <cait> #info plack: known problems with syspref caching
15:26:59 <cait> #info several approaches: Plack for developers' pushed (bug 7844), 'Plack with nginx for production' in testing (bug 9316), at least two koha-plackify scripts: Plackify-koha-common, koha-plack.
15:27:06 <cait> anything to add about plack?
15:28:03 <barton> are there any known issues other than syspref caching?
15:28:38 <tcohen> I know robin has been active working on plack support
15:28:53 <Joubu> Does someone use Plack in production?
15:29:00 <tcohen> I'll ask him to give us his vision on the current status
15:30:08 <cait> is this an action?
15:30:09 <barton> I know that bywater has one partner using it on OPAC in production. I haven't heard of any issues with it.
15:30:18 <cait> #action tcohen to ask eythian for a status report about plack
15:31:41 <kivilahtio> Regarding general technical discussion: http://gtmetrix.com/reports/oiva.vaarakirjastot.fi/cnP3Ro3h
15:32:07 <kivilahtio> Shouldn't we set the javascript/css-files expiration dates from the templates?
15:32:51 <tcohen> apache
15:33:39 <kivilahtio> tcohen: thanks
15:33:44 <oleonard> Related? Bug 12904
15:33:44 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12904 enhancement, P5 - low, ---, kyle, Needs Signoff , Force browser to load new javascript files after upgrade
15:35:22 <tcohen> possibly, i''ll add it to the agenda for the next meeting, ok?
15:35:34 <khall> I was hoping ashimema could verify if his alternate implementation would work with plack
15:36:03 <cait> #action ashimema will check if his implementatin of bug 12904 works with plack ;)
15:36:12 <cait> he is not here... so he gets volunteered, right?
15:36:26 <kivilahtio> tcohen: no need from my behalf
15:36:43 <tcohen> #topic non-XSLT view deprecation
15:37:50 <cait> +1
15:38:07 <tcohen> the point here was to highlight that a lot of the code complexity comes from this
15:38:12 <Joubu> Is there a bug report somewhere?
15:38:21 <cait> i think we amde one
15:38:23 <cait> looking fo rit
15:38:24 <tcohen> (regarding searching)
15:38:31 <cait> bug 12561
15:38:31 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12561 normal, P5 - low, ---, oleonard, NEW , Omnibus: Deprecate non-XSLT detail and result views
15:38:36 <marcelr> did any people object to removing it?
15:38:51 <cait> #info bug 12561: Omnibus: Deprecate non-XSLT detail and result views
15:39:00 <cait> iirc
15:39:07 <kivilahtio> marcelr: nope. I strongly support it :)
15:39:09 <cait> we wanted to check for features that only work with non-xslt
15:39:10 <cait> and created that bug
15:39:20 <cait> there are a couple depends on noted
15:39:32 <cait> bug 2619
15:39:32 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=2619 normal, P3, ---, gmcharlt, NEW , Turning on XSLTResultsDisplay preference turns off item detail display
15:39:36 <cait> bug 5229
15:39:36 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=5229 normal, P5 - low, ---, oleonard, NEW , OPACItemsResultsDisplay preference does not work with XSLT results
15:39:40 <cait> bug 10571
15:39:40 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10571 normal, P5 - low, ---, oleonard, Pushed to Master , IntranetBiblioDefaultView doesn't do anything with MARC21 XSLT
15:39:41 <Joubu> Yes, I think it's the first thing to do: find the difference between both views
15:39:43 <cait> bug 11426
15:39:43 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11426 normal, P5 - low, ---, oleonard, NEW , Make HighlightOwnItemsOnOPAC work with XSLT
15:39:49 <cait> bug 12574
15:39:49 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12574 normal, P5 - low, ---, oleonard, Pushed to Master , BiblioDefaultView doesn't affect XSLT results view
15:39:53 <cait> bug 12900
15:39:53 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12900 normal, P5 - low, ---, tomascohen, Pushed to Master , IntranetBiblioDefaultView doesn't do anything with NORMARC or UNIMARC XSLT
15:39:58 <cait> bug 12901
15:39:58 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12901 normal, P5 - low, ---, oleonard, Pushed to Master , BiblioDefaultView doesn't do anything with NORMARC or UNIMARC XSLT
15:40:04 <cait> bug 13327
15:40:04 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13327 normal, P5 - low, ---, oleonard, NEW , OPACPopupAuthorsSearch doesn't work with XSLT views
15:40:27 <cait> cool
15:40:32 <cait> looks like a lot are resolved
15:41:19 <cait> i think left are 2619 and 5229 and 11426 and 13327
15:41:25 <jcamins> ashimema_: I think it's probably implemented using jQuery, so just add a global watcher.
15:41:28 <Joubu> Naive question: why the xslt view is better?
15:41:37 <kivilahtio> Joubu: good question
15:41:42 <cait> becasue we show way mro information there
15:41:45 <cait> and we allow customizing
15:41:53 <Joubu> I would prefer a solution with TT, rather than the ****** xslt syntax
15:41:54 <kivilahtio> we can do that without xslt as well
15:42:07 <cait> the logic is better - the normla view uses old marc routines that are not ideal i think
15:42:20 <Joubu> TT is really more powerful and friendly to read/write than xslt
15:42:20 <kivilahtio> I think TT is a viable laternative
15:42:25 <kivilahtio> there is no point in having both
15:42:29 <cait> i think bringing the feautres we got in xslt now to the nonmarc is a much bigger project than the other way around
15:42:36 <kivilahtio> we should use either TT or XSLT, not both
15:42:37 <jcamins> Like ajaxStart or ajaxStop.
15:42:57 * tcohen thinks jcamins is too asynchronous
15:42:58 <oleonard> No one has developed a version with TT which is better than the XSLT version
15:43:12 <cait> and i think no point having 3 things
15:43:13 <kivilahtio> oleonard: well I believe not in speed that's for sure
15:43:20 <cait> deprecate the old normal view... move on to something else after?
15:43:25 <kivilahtio> they say XSLT is super, fast :)
15:43:45 <kivilahtio> but that is yet another technology, is it really owrth it?
15:43:56 <Joubu> I am just wondering if you should not spent time on something better
15:43:59 <kivilahtio> regarding hte learning curve and the fishy syntax you need to remember
15:44:02 <oleonard> Saying that the TT version *could* be better isn't a good reason not to deprecate the version which *is* worse.
15:44:13 <marcelr> the XSLT got a little out of hand too, but I think it is better than the old normal view
15:44:21 <kivilahtio> my point is reducing unnecessary technology overheead
15:44:24 <cait> Joubu: i think a better way would be nice, but right now I'd like to deprecate one of the 2 options
15:44:39 <cait> so we can really focus on something new and not maintaining something that needs to be rewritten
15:44:53 <ColinC> and the old normal view wasnt tt to begin with it has a bad history
15:45:00 <cait> good point
15:45:21 <kivilahtio> I am 100% for deprecating the old view
15:45:32 <cait> i see a problem with features that rely on it - but those seem moslty limited to the result view
15:45:46 <tcohen> i've been playing (on vacations) with some routines that generate XSLT out of some stuff (like frameworks, authorized values, etc)
15:45:56 <cait> Opacpopuauthorssearch and highlightOwnitemsonopac specifically
15:45:59 <kivilahtio> tcohen: I agree, XSLT is really powerfull
15:46:06 <ColinC> i dont like xslt but it does what we need and removing the old normal view does clear things to develop something better
15:46:06 <tcohen> i plan to benchmark it, but if you look at the current code
15:46:06 <Joubu> Does someone can evaluate the remaining work before depracating the no-xslt view?
15:46:07 <kivilahtio> tcohen: much more that TT is
15:46:43 <tcohen> you will notice that there's too much ad-hoc code, for each MARC flavour, and it is really under-performant and little flexible
15:46:46 <cait> Joubu: hm do you mean patches still out there or the missing features?
15:47:11 <Joubu> both :)
15:47:18 <kivilahtio> :)
15:47:19 <tcohen> a solution based on XSLT that allows the user to build those XSLT's ina a sane/visual way could be a better option, for the future
15:47:31 <kivilahtio> wow wow
15:47:38 <cait> i haven't seen new patches for the normal view in a longer time, but we got the splitter :)
15:48:14 <Joubu> I am not sure to understand what is the goal to reach...
15:48:25 <cait> #action cait to update the list of depending bugs on the omnibus bug for deprecating non-XSLT views
15:48:30 <cait> i will try to
15:48:33 <kivilahtio> Joubu: simplify alternate branches. eg. normalize the program flow?
15:49:15 <Joubu> yes but as cait said, there are no patch for the normal view in the queue :)
15:49:28 <kivilahtio> I think that the important thing now is to deprecate the old view. and refatctor to XSLT as it is the easiest route to take and make real progress.
15:49:29 <cait> khall: around?
15:49:34 <marcelr> Joubu: can the HEA stuff tell you how many people use the non-XSLT view?
15:49:37 <Joubu> so it does not caused a lot of extra work of SO/QA
15:49:49 <Joubu> marcelr: yes
15:49:52 <Joubu> or at least, it could
15:50:04 <kivilahtio> marcelr: I don't think very many.
15:50:18 <Joubu> actually no
15:50:29 <marcelr> too bad
15:50:38 <Joubu> we don't track the xslt pref (because their values is a path)
15:51:02 <cait> ah
15:52:01 <Joubu> I am not saying I am against the idea, I am just trying to understand the benefit
15:52:24 <Joubu> I find the TT syntax more powerfull, in term of readability/maintainability
15:52:35 <kivilahtio> Joubu: agreed
15:52:40 <cait> I see it as an option to reduce the number of options
15:52:44 <marcelr> Joubu: some TT files are very unreadable
15:52:53 <marcelr> as well as some xslt files too
15:52:59 <cait> it's quite old code with lots of display issues - at least the detail page is
15:53:09 <cait> deprecating = we ae not going to fix it
15:53:10 <Joubu> marcelr: not too much in the bootstrap theme :)
15:53:44 <oleonard> ...unless you really hate my indentation choices :P
15:53:47 <cait> and they are totally out of sync
15:53:54 <cait> and won't get updated for RDA
15:53:57 <kivilahtio> out of sync indentation? where?
15:53:59 <cait> i see no point in keeping them
15:54:09 <cait> out of sync in what each displays show
15:54:20 <cait> the xslt show much more information and i believe are more accurate
15:54:59 <Joubu> oleonard: I don't care of the indentation :)
15:55:15 <kivilahtio> Joubu:  I do, and you should too :(
15:55:27 <barton> vote?
15:55:43 <cait> we said no vote on agenda
15:55:44 <Joubu> barton: there is no vote today
15:55:50 <marcelr> too early to vote now
15:56:13 <cait> i can post an email to the mailing list with problems identified if that would help start the discussion?
15:56:26 <Joubu> cait: could it be possible to know what is the remaining work and what do we want with the xslt views?
15:56:30 <kivilahtio> I guess we can agree that we need to deprecate the old view?
15:56:41 <Joubu> What about the translation, the different marcflavour files, etc.
15:56:48 <cait> translations work vrey well
15:56:59 <cait> we have only ever been using the xslt views
15:57:04 <cait> from the beginning
15:57:05 <kivilahtio> yes, translations work fine
15:57:17 <cait> i think last hackfest people wnated to work on the unimarc xslt views
15:57:24 <cait> i am not sure how the sttaus is for unimarc
15:57:33 <cait> but marc21 is a lot better than non-xslt
15:57:41 <cait> maybe that's a difference to consider
15:57:50 <cait> we could also check with magnuse about normarc
15:58:01 <kivilahtio> normarc is almost 100% with MARC1
15:58:23 <marcelr> probably most non-xslt users are on the unimarc side?
15:58:40 <cait> #info keep different marc flavours in mind for deprecation
15:58:50 <kivilahtio> marcelr: damn unimarc :)
15:59:03 <marcelr> you wanna deprecate that too?
15:59:10 <barton> ha!
15:59:13 <kivilahtio> I do
15:59:14 <cait> heh
15:59:14 <Joubu> I think we are using the xslt view at BibLibre
15:59:38 <cait> i think that's what gaetan_B said, but that there was not a good stndard one in Koha?
15:59:56 * cait tries to remember from last year - hope no misunderstanding
16:00:01 <Joubu> I don't know :)
16:00:10 <gaetan_B> the default unimarc xslt is pretty bad indeed
16:00:33 * gaetan_B kind of knows what he would like to do at the next hackfest, again
16:00:42 <cait> not so far away :) maybe we can work it out there
16:00:53 <cait> #info discussion to be continued
16:00:56 <cait> moving on?
16:01:07 <cait> #topic GRS-1 removal - comments only, no vote today
16:01:19 <cait> tcohen: ?
16:01:22 <jenkins_koha> Yippee, build fixed!
16:01:23 <jenkins_koha> Project Koha_Master_U12_MariaDB build #222: FIXED in 1 hr 4 min: http://jenkins.koha-community.org/job/Koha_Master_U12_MariaDB/222/
16:01:24 <jenkins_koha> * Chris Cormack: Bug 12861 : Noisy warn in the error logs
16:01:24 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12861 minor, P5 - low, ---, chris, Pushed to Master , Noisy warns in C4/AuthoritiesMarc.pm
16:01:25 <jenkins_koha> * Jonathan Druart: Bug 12861: (follow-up) Noisy warn in error logs
16:01:26 <jenkins_koha> * Thomas: Bug 13584 - Able to view menu for Purchase Suggestions even when user does not have permission
16:01:26 <jenkins_koha> * Jonathan Druart: Bug 13584: (follow-up) Able to view menu for Purchase Suggestions even when user does not have permission
16:01:27 <jenkins_koha> * Abby: Bug 13587: Fix Authorised Values Toolbar
16:01:27 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13584 enhancement, P5 - low, ---, tomsStudy, Pushed to Master , Able to view menu for Purchase Suggestions even when user does not have permission
16:01:28 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13587 trivial, P5 - low, ---, abbyrobertson.student, Pushed to Master , Authorized Values toolbar missing '+' Icons
16:01:29 <jenkins_koha> * Fridolin Somers: Bug 11927 - Add gr install option
16:01:29 <jenkins_koha> * Fridolin Somers: Bug 11927 - Add greek chr lang_def file
16:01:29 <cait> heh jenkins!
16:01:29 <jenkins_koha> * Fridolin Somers: Bug 11927 - Add greek to word-phrase-utf.chr
16:01:29 <jenkins_koha> * Fridolin Somers: Bug 11927 - Small corrections on word-phrase-utf.chr
16:01:29 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11927 enhancement, P5 - low, ---, fridolyn.somers, Pushed to Master , Add greek support to CHR
16:01:31 <jenkins_koha> * Olli-Antti Kivilahti: Bug 13025 - Software error: Undefined subroutine &C4::Circulation::HasOverdues called at /home/koha/kohaclone/C4/Circulation.pm line 1925
16:01:33 <jenkins_koha> * Abby: Bug 7143: Adding releases to history file
16:01:33 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13025 minor, P5 - low, ---, olli-antti.kivilahti, Pushed to Master , Software error: Undefined subroutine &C4::Circulation::HasOverdues called at /home/koha/kohaclone/C4/Circulation.pm line 1925
16:01:34 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7143 trivial, P5 - low, ---, koha-bugs, Passed QA , Bug for tracking changes to the about page
16:01:35 <jenkins_koha> * Thomas: Bug 13582 - Able to view menu for Circulation History even when user does not have permission
16:01:35 <jenkins_koha> * Jonathan Druart: Bug 13582: (follow-up) Able to view menu for Circulation History even when user does not have permission
16:01:36 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13582 minor, P5 - low, ---, koha-bugs, Pushed to Master , Able to view menu for Circulation History even when user does not have permission
16:01:37 <jenkins_koha> * Tomas Cohen Arazi: Bug 10606: Remove MySQLism in GetUpcomingDueIssues
16:01:37 <jenkins_koha> * Justin: Bug - 11345 - Self registration captcha
16:01:37 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10606 minor, P5 - low, ---, gmcharlt, Pushed to Master , MySQLism in GetUpcomingDueIssues
16:01:39 <jenkins_koha> * Owen Leonard: Bug 13525 - Date sorting on accounts (fines) tab doesn't work correctly
16:01:40 <jenkins_koha> * Jonathan Druart: Bug 13001: Refactor VAT and price calculation - parcel page
16:01:40 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13525 normal, P5 - low, ---, oleonard, Pushed to Master , Date sorting on accounts (fines) tab doesn't work correctly
16:01:41 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13001 enhancement, P5 - low, ---, jonathan.druart, Pushed to Master , Refactor VAT and price calculation - parcel page
16:01:41 <jenkins_koha> * Jonathan Druart: Bug 13001: The total for received order should be based on the unitprice
16:01:49 <cait> are you done now?
16:01:52 <cait> ok
16:02:05 <cait> can we agree on deprecating grs-1 in favor of dom?
16:02:16 <kivilahtio> YEESSSSS!!
16:02:17 <tcohen> GRS-1 removal depends on UNIMARC people
16:02:20 <cait> i am not aware of any problems with dom now and the nice new facets only work with it
16:02:28 <tcohen> GRS-1 has already been deprecated in 3.16
16:02:37 * cait seconds kivilahtio motion to deprecate UNIMARC then :P
16:02:40 <tcohen> and is in no-maintenance mode
16:02:43 <marcelr> i thought so too
16:03:05 <cait> right, we are talking about removing it
16:03:11 <tcohen> the only reason we keep it, is because some people still rely on it, because UNIMARC DOM was not complete
16:03:11 <cait> to simplify the search code
16:03:13 <cait> andmake it easier to fix that
16:03:41 <Joubu> tcohen: Is it still not complete ?
16:03:52 <tcohen> several things like availability filtering, could be easily fixed using DOM capabilities
16:04:01 <reiveune> bye
16:04:04 <tcohen> Joubu: I don't use UNIMARC at all
16:04:05 <cait> #info grs-1 was already deprecated, this is about removing the code for it
16:04:33 <tcohen> I don't plan to raise a vote now, I'm just saying that many things would became easier, and better if we did
16:04:38 <kivilahtio> so UNIMARC people cannot migrate to the next Koha version? I think that might get them to fix those issues?
16:04:43 <tcohen> and we could think of removing it for the 3.20 release
16:05:20 <tcohen> and probably fix long-standing bugs that were difficult to fix for both GRS-1 and DOM without making the code worse
16:05:47 * barton is in favor of not making the code worse.
16:06:05 <cait> i can only see one open dom bug report right now that doesn't seem to be a new feature/improvement: bug 12948
16:06:05 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12948 minor, P5 - low, ---, z.tajoli, NEW , The language filter in advance search doen't work with DOM MARC21 - NORMARC
16:06:16 <cait> and that woudl be a really easy fix
16:06:22 * tcohen has the hidden agenda of making search results rendering faster
16:06:33 <ashimema_> back
16:06:38 * ashimema_ reading up
16:06:49 <cait> ashimema you got an action item
16:07:18 <cait> Joubu: could you check if there are known issues with dom for unimarc?
16:07:25 <cait> or ask someone to?
16:07:41 <cait> i feel like by supporting less options testing and fixing will get a lot easier
16:07:51 <kivilahtio> cait: you got it there
16:07:54 <cait> and also the 'this works with this feature... but not if you are using...'
16:07:55 <Joubu> cait: I will try...
16:07:57 <kivilahtio> less is more :)
16:08:56 <cait> #action all think about problems with removing grs-1 - especially if you are using UNIMARC
16:08:59 <cait> keeping it general
16:09:07 <cait> moving on?
16:09:14 <kivilahtio> sure
16:09:27 <cait> #topic tarball vs. packages installations - how to keep them in sync, workflow discussion
16:09:29 <paul_p> during my presentation of Koha 3.18 in Paris, 2 weeks ago, I said clearly that GRS-1 was deprecated and would be removed in 3.20
16:09:38 <cait> paul_p: yay :)
16:09:50 <paul_p> so OK for removing things. And if there are bugs to fix, we will fix them !
16:09:51 <kivilahtio> do we need to vote anymore :)
16:10:12 <paul_p> we plan to update BibLibre customers to 3.18 in late spring
16:10:21 <cait> similar here
16:10:30 <bag> yeah we are probably on that same path
16:10:31 <cait> we are also moving everyone to dom with that update
16:10:32 <tcohen> so, we can focus on DOM bugs
16:10:37 <cait> tests so far look good
16:10:54 <bag> right we've been pushing for dom and for bootstrap PAC only too
16:11:03 <tcohen> hi bag
16:11:14 <bag> so we've already moved a ton of partners to those two
16:11:18 <bag> heya tcohen
16:11:31 <cait> but actually
16:11:34 <kivilahtio> bag: Where do you come from?
16:11:35 <cait> we are talking about packages now :)
16:11:42 <jenkins_koha> Yippee, build fixed!
16:11:42 <jenkins_koha> Project Koha_Master_U12 build #298: FIXED in 59 min: http://jenkins.koha-community.org/job/Koha_Master_U12/298/
16:11:45 <jenkins_koha> * Owen Leonard: Bug 13525 - Date sorting on accounts (fines) tab doesn't work correctly
16:11:45 <jenkins_koha> * Jonathan Druart: Bug 13001: Refactor VAT and price calculation - parcel page
16:11:45 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13525 normal, P5 - low, ---, oleonard, Pushed to Master , Date sorting on accounts (fines) tab doesn't work correctly
16:11:46 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13001 enhancement, P5 - low, ---, jonathan.druart, Pushed to Master , Refactor VAT and price calculation - parcel page
16:11:46 <jenkins_koha> * Jonathan Druart: Bug 13001: The total for received order should be based on the unitprice
16:12:03 <bag> I come from my mom (Jane Gallagher)  - j/k  I'm in California
16:12:10 <Joubu> :p
16:12:13 <tcohen> :-P
16:12:18 <kivilahtio> bag: that's nice
16:12:22 <cait> tcohen: can you explain the topic?
16:12:29 <kivilahtio> bag: we have one thing in common
16:12:30 <bag> sweet yeah we've got most everyone on package
16:13:01 <tcohen> ok
16:13:14 <tcohen> there's usually a drift from one or the other
16:13:32 <bag> #info Brendan Gallagher - ByWater
16:13:37 <barton> tcohen: which tends to be ahead?
16:13:42 <gaetan_B> leaving for the train station, bye !
16:13:44 <paul_p> (same thing for bootstrap : I said to all french libraries that were at my demo, that 3.18 requires bootstrap)
16:13:52 <tcohen> I think the packages get most of the attention
16:14:17 <tcohen> I proposed (and couldn't send the patch yet) convergence of both
16:14:28 * bag sorry I am late
16:14:57 <tcohen> bug 11962
16:14:57 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11962 enhancement, P5 - low, ---, tomascohen, NEW , New 'cluster' install mode
16:15:12 <tcohen> so people can install from source having the same schema the packages have
16:15:24 <tcohen> but the current problem is methodological
16:15:45 <tcohen> and we can solve it enahncing the QA process for things touching configurations
16:15:47 <fridolin> #info Fridolin Somers - Biblire
16:15:50 <barton> tcohen: pardon me for being dense, but who uses koha tarballs, and why?
16:15:51 <fridolin> Biblibre
16:16:13 <fridolin> removing GRS1 is removing from installer no ?
16:16:31 <fridolin> old installs using it will not work anymore ?
16:17:30 <tcohen> barton: the main idea I had was simplifying the maintenance of install scripts
16:17:35 <kivilahtio> fridolin: if you dont upgrade them they do :)
16:17:42 <fridolin> ;)
16:18:02 <fridolin> since its zebra internal option, i think its yes
16:18:09 <tcohen> so generating a .deb, is just calling the correct install method on a chroot
16:18:25 <tcohen> instead of a normal install and lots of error-prone tweaking scripts
16:18:38 <tcohen> and it could also pave the way to supporting other distros
16:18:53 <tcohen> (if interested people fixes what needs to be fixed of course)
16:19:00 <fridolin> but i know DOM is better, we will have tests during hackfest to switch our installs little by little
16:19:24 <tcohen> anyway, I think the subject here is to send a message
16:19:45 <tcohen> that we should not provide patches that change configurations if we don't fix both install methods
16:20:09 <tcohen> put it like "the RM will reject patches that forget to fix both install methods"
16:21:11 <tcohen> fridolin: DOM is more flexible, and things like handling HTML entities for example is easier inside zebra
16:21:24 <Joubu> tcohen: could be great to have that on the wiki (guidelines)
16:21:27 <tcohen> but for now, we are trying to have functinal-parity
16:21:44 <barton> good idea, Joubu.
16:21:51 <tcohen> between both so people can definitely ju p into DOM ASAP
16:21:57 <fridolin> tcohen: ok thanks, I see we have changed the topic
16:22:00 <kivilahtio> speaking of Zebra. Is ElasticSearch-with-Koha dead and buried?
16:22:11 <oleonard> kivilahtio: It's not even born yet
16:22:26 <kivilahtio> oleonard: Someone was in labour
16:22:49 <tcohen> kivilahtio: that's another topic, following the next one
16:22:59 <kivilahtio> ok
16:23:11 <tcohen> ok, moving on?
16:23:44 <tcohen> #action tcohen will update the wiki so it mentions that patches touching configuration files should cover both install methods
16:23:45 <barton> seconded.
16:23:45 <cait> sorry got called away, back now
16:23:59 <tcohen> #topic Testing SIP
16:24:21 <ashimema_> right.. I've cuaght up now..
16:24:22 <tcohen> it is a shame we have tests for SIP
16:24:30 <kivilahtio> ?
16:24:38 <ashimema_> poo.. you moved on
16:24:56 <kivilahtio> you mean "shamefull tests" or "shame that we have tests"?
16:25:03 <tcohen> but no one knows how to set an environment to run them
16:25:10 <tcohen> or even have then run by jenkins
16:25:15 <tcohen> we need some volunteers
16:25:19 <ashimema_> was going to say I don't think all the dev work in in the packages side.. i've found allot fot he installer templates have changed on the other side as aposed to he pacakges side.
16:25:30 <ashimema_> colinc?
16:25:35 <ashimema_> ColinC even
16:25:36 <tcohen> to take a look at how we did with t/db_dependent/www/search_utf8.t
16:25:49 <kivilahtio> tcohen: I think this borders on making integratons tests to emulate CGI-calls and TT processing
16:25:50 <tcohen> and write something similar to set an environment
16:26:09 <tcohen> kivilahtio: we do that, on t/db_dependent/www
16:26:24 <ashimema_> I've just poked ColinC.. being SIP related
16:26:28 <ColinC> Problem is that there is a lot of stuff in the SIP tree thats just not integrated into Koha
16:26:51 <kivilahtio> Why is the SIP-tree so separated?
16:27:09 <cait> i think history - it was supposed to be shared
16:27:32 <ColinC> I think historically it was a dump of a development external to the Koha main tree
16:27:47 <cait> openncip project?
16:28:17 <kivilahtio> ok
16:28:22 <ashimema_> ColinC.. did your patches to bring it more into the koha tree go anywhere yet?
16:28:23 <ColinC> You can still install the stuff under SIP seperately from Koha
16:28:30 <ashimema_> I can't remember the state..
16:28:31 <cait> i found this: http://lists.gnu.org/archive/html/koha-devel/2009-02/msg00000.html
16:29:25 <ColinC> Well there was a patch thats been sitting there to use the Koha perl lib tree thats the first one
16:29:30 <Joubu> http://openncip.cvs.sourceforge.net/viewvc/openncip/src/
16:29:31 <kivilahtio> looking at  t/db_dependent/www/search_utf8, is there a database rollback here? Looks like the HTTP-requests  are just HTTP-requests to the web server and make DB changes?
16:29:35 <ashimema_> bug 7904 was it?
16:29:35 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7904 enhancement, P5 - low, ---, colin.campbell, Needs Signoff , SIP modules handling of @INC is confused
16:29:46 <ColinC> Yes
16:30:33 <ashimema_> tcohen.. perhaps that bug might help start the ball rolling on getting SIP tests worked through.. and better working of SIP in general..
16:30:33 <ColinC> It probably needs rebasing now but that was hopefully the first step to getting some integrated testing
16:30:38 <tcohen> kivilahtio: there isn't, well there's a delete of the imported batch at the end
16:30:55 <ashimema_> can we beg anyone to have a play with it. signoff
16:31:33 <kivilahtio> tcohen: my idea was to emulate the CGI-interface. But I haven't had the time to look into the cpan's CGI-implementation
16:31:40 <cait> #info bug 7904 needs a sign off and might help getting better sip tests
16:31:48 <kivilahtio> then run scripts.pl's in an eval block
16:31:57 <tcohen> kivilahtio: that tests go through apache
16:32:11 <tcohen> and are run by jenkins
16:32:12 <cait> someone volunteering for testing?
16:32:19 <cait> keen on having an action item in the minutes :)
16:32:36 <ashimema_> I could test.. but I'm also ptfs ;)
16:32:41 <ashimema_> mit colin
16:32:58 <ashimema_> I'de really like to see it tested though.. is a real step forward in my opinion
16:33:08 <tcohen> khall: volunteer?
16:33:21 <khall> sure!
16:33:29 <ashimema_> hehe.. sorry khall ;)
16:33:39 <khall> heh, np!
16:34:06 <cait> #action khall to test bug 7904
16:34:10 <cait> moving on?
16:34:19 <cait> #topic Bugs
16:34:27 <cait> ok, giving htis not much time
16:34:30 <cait> we are over already :)
16:34:35 <cait> has osmeone prepared something?
16:34:49 <marcelr_afk> have to go; bye
16:35:15 <Joubu> yes, wait 2 sec
16:35:29 <Joubu> I didn't prepare, but I have 2 things
16:36:03 <Joubu> On bug 13606, I proposed to extend sessions.a_session from TEXT to MEDIUMTEXT
16:36:03 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13606 normal, P5 - low, ---, jonathan.druart, Needs Signoff , Batch modification for records is limited to ~500
16:36:28 <cait> is that the right bug?
16:36:29 <Joubu> I don't find another way to do what I wanted, feedback welcomed :)
16:36:33 <Joubu> yes
16:36:51 <Joubu> I found the problem in production this morning (linked to bug 11395)
16:36:51 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11395 new feature, P5 - low, ---, jonathan.druart, Passed QA , Batch modifications for records
16:37:16 <Joubu> and the second one is bug 13601, a new one also
16:37:16 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13601 normal, P5 - low, ---, jonathan.druart, Needs Signoff , Get rid of DateTime::Format::DateParse
16:37:50 <Joubu> It will introduce issue, I am pretty sure about that... But IMO it's the best way to catch bad date manipulation
16:37:54 <ColinC> I'll rebase bug 7904
16:37:54 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7904 enhancement, P5 - low, ---, colin.campbell, Needs Signoff , SIP modules handling of @INC is confused
16:38:11 <fridolin> FIY I've pushed a followup on 11927 to fix jenkins UT Search.t
16:38:31 <Joubu> (see comment 8 for 1 of the bad date manip I have found)
16:39:23 <Joubu> and the tax rewrite + enh are going to be signed off, I hope so. So QAers be ready :)
16:39:52 <tcohen> great fridolin
16:39:52 <cait> :)
16:40:01 <tcohen> :)
16:40:06 <cait> thx Joubu
16:40:20 <cait> anyone volunteering?
16:40:51 <cait> i will try to keep workin gon the tax patches
16:41:09 <cait> #action cait will try to keep working on the tax patche as they come into the qa queue
16:41:17 <cait> so... someone dates? :)
16:42:36 <cait> okok
16:42:37 <Joubu> something else: I am a bit afraid of the bug I found in QP : http://lists.koha-community.org/pipermail/koha-devel/2014-December/041028.html
16:42:44 <cait> oh yes
16:42:52 <Joubu> I really don't know how debug this
16:42:59 <Joubu> to*
16:43:38 <Joubu> it's a quite simple query I tried, and does not work
16:44:08 <cait> :(
16:45:08 <cait> someone?
16:45:22 <cait> ok, we are way over our usual time
16:45:38 <cait> #topic big stuff we are working on
16:45:42 <ColinC> I tried using QP for something and it seemed not ready for use
16:46:23 <cait> we tried using it when it came in, but the bug about opacsuppression stopped us
16:46:30 <cait> it has been fixed since, but we haven't tried again
16:47:06 <ashimema_> Joubu.. only person beyond jcamins that seems to understand qp at all is dcook
16:47:19 <ashimema_> perhaps leave him a later?
16:47:53 <Joubu> ashimema_ : He answered me on the list :)
16:48:08 <cait> http://lists.koha-community.org/pipermail/koha-devel/2014-December/041040.html
16:48:12 <Joubu> "I've been looking at this for hour[...]" :)
16:48:13 <ashimema_> I was happy we fixed the opacsuppression piece too.. but also we've not had the confidence to switch to it...
16:48:20 <Joubu> hour*s*
16:48:21 <ashimema_> i'm wondering if anyone out there is using it?
16:48:34 <cait> Hea? :)
16:48:56 <ashimema_> HEA will be good.. but at the moment it's a bit limited cait..
16:49:15 <ashimema_> only a few ptfs europe customers and a bunch of biblibre customers submitting data ;)
16:49:24 <ashimema_> unless that's changed in the last few hours?
16:49:47 <cait> we still got to bring it to the newsletter
16:49:48 <cait> :)
16:49:57 <cait> ok, i think eythian is not here
16:50:13 <cait> so would people be ok with leaving elastic for the next meeting?
16:50:30 <ashimema_> 54 of 58 have it disabled (the rest don't have it set at all ;) )
16:50:52 <cait> ashimema: not very encouraging
16:51:14 <ashimema_> it's another of those we either need to adopt it or kill it..
16:51:21 <Joubu> There are 58 lib sending data :)
16:51:25 <ashimema_> I'm not liking all these things sitting in the middle
16:51:40 <ashimema_> :).. yeah.. that's a real improvment Joubu..
16:51:51 <ashimema_> think it was 37 when I added ours to the list..
16:51:52 <cait> ashimema agreed
16:52:01 <ashimema_> be good to get some older versions onboard soon
16:52:13 <Joubu> About ES: I have tested last week, but failed, I let a comment on bug 12478, I hope to get an answer soon to retest
16:52:14 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12478 enhancement, P5 - low, ---, robin, NEW , Elasticsearch support for Koha
16:52:27 <ashimema_> ooh.. cool.
16:52:34 <ashimema_> Joubu++ #for testing
16:52:35 <Joubu> not so much...
16:52:42 <cait> @later tell eythian could you give an update on the elastic search work on bug 12478 please?
16:52:42 <huginn> cait: The operation succeeded.
16:52:51 <cait> Joubu++ indeed
16:52:58 <cait> ok are we ok to end the meeting?
16:53:03 <cait> tcohen: when do you want the next one? :)
16:53:05 <Joubu> could be nice to have installation instructions to test it quickly
16:53:48 <oleonard> I wonder if ByWater will be encouraging their customers to submit data to Hea after upgrades to 3.18.x happen?
16:54:05 <bag> we will oleonard we will
16:54:41 <oleonard> So, lots and lots of new data could be on its way!
16:54:44 <cait> #info Hea: please think about adding your library/libraries
16:54:51 <kivilahtio> it's very good
16:54:58 <kivilahtio> it is verygood
16:55:00 <cait> so ending?
16:55:09 <cait> tcohen: 2 weeks? 4 weeks?
16:55:50 * cait thinks 2 weeks
16:55:58 <cait> so wednesday 4th
16:56:02 * barton agrees with cait.
16:56:08 <cait> vetos?
16:56:19 <cait> which time?
16:56:56 <cait> #action tcohen to set the time for the next meeting, suggestion is wednesday 4th
16:56:57 <Joubu> It's my birthday :)
16:56:58 <cait> oh
16:57:16 <cait> so better not?
16:57:30 <cait> #action tcohen to think about another date for the meeting to not collide with Joubu's birthday :)
16:57:32 <cait> #endmeeting