10:04:46 <cait> #startmeeting General IRC meeting 9 September 2015
10:04:46 <huginn> Meeting started Wed Sep  9 10:04:46 2015 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:04:46 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:04:46 <huginn> The meeting name has been set to 'general_irc_meeting_9_september_2015'
10:04:50 <cait> #topic introductions
10:04:50 <wahanui> #info wahanui, a bot that has become sentient
10:05:05 <cait> please introduce yourself with #info, the agenda of today's meeting can be found under
10:05:12 <cait> #link http://wiki.koha-community.org/wiki/General_IRC_meeting_9_September_2015
10:05:21 <cait> #info Katrin Fischer, BSZ, Germany
10:05:24 <drojf> #info Mirko Tietgen, Berlin, Germany
10:05:30 <BobB> #info Bob Birchall, Calyx, Australia
10:05:37 <thd> Thomas Dukleth, Agogme, New York City
10:05:46 <thd> #info Thomas Dukleth, Agogme, New York City
10:06:06 <cait> a lot of people are on vacation this week
10:06:13 <magnuse> #info Magnus Enger, Libriotech, Norway
10:06:40 <drojf> way less than last week, as was shown by anecdotal evidence at the last meeting
10:07:02 <ikourmou> #info Giannis Kourmoulis, Aristotle Univesity of Thessaloniki, Greece
10:07:09 <ashimema> #info Martin Renvoize, PTFS Europe
10:07:21 <cait> small = quick? one can hope :)
10:07:26 <magnuse> :-)
10:07:35 <cait> ok, moving on
10:07:37 <BobB> seldom turns out that way :)
10:07:42 <cait> #topic Announcements
10:08:18 <cait> noone?
10:08:18 <wahanui> noone is here!
10:08:26 <cait> we had a gbsd that i think was pretty successful
10:08:55 <cait> #info GBSD on  3 September was successful
10:09:00 <drojf> do you have the stats link?
10:09:03 <ashimema> I'm aware of the PTFS sandboxes being a bit fragile at the moment.. it's on my list at some piont to investigate.
10:09:05 <cait> can you find it?
10:09:14 <cait> do youwant me to info?
10:09:17 <ashimema> that was sorta related to gbsd
10:09:28 <cait> ok :)
10:09:42 <cait> khall did a screenshare session and i know at least 2 new sign-offers came out of it
10:09:44 <drojf> no did not bookmark it apparently
10:09:51 <cait> so i am pretty happy overall
10:10:10 <magnuse> yup, good gbsd!
10:10:13 <cait> #link http://wiki.koha-community.org/wiki/2015-09-03_Global_bug_squashing_day
10:10:22 <BobB> we didn't achieve a sign-off but a couple of things got moved along
10:10:25 <cait> i think it woudl be good if we offered something similar next time as well
10:10:33 * cait nods
10:10:38 <schnydszch2> #info Eugene Espinoza
10:10:43 <cait> also some bugzilla clean-up was done
10:10:49 <drojf> http://bugs.koha-community.org/cgi-bin/progress.pl
10:11:12 <drojf> definitely made an impact
10:11:22 <drojf> made, had, too early for english
10:11:31 <cait> ok, moving on :)
10:11:57 <cait> #topic Update on Releases
10:12:11 <cait> any RM* here?
10:12:36 <BobB> mtj?
10:12:37 <wahanui> i think mtj is DeM KraZy NutZ!!
10:12:53 <cait> ok, i'd say things aremoving along nicely
10:13:25 <cait> #info Fridolin announced EOL for 3.14 on the mailing list
10:13:44 <cait> anything else?
10:13:44 <wahanui> anything else is just being crap
10:14:00 <cait> ah
10:14:11 <cait> #info Plack packages need testing
10:14:15 <BobB> wahanui be polite
10:14:16 <wahanui> BobB: huh?
10:14:39 <cait> probably not a good description - but tomas pushed plack scripts for packages to master and they need more testing :)
10:14:47 <cait> ok, moving on
10:15:04 <cait> #info KohaCon15
10:15:07 <magnuse> there should be a branch in kohadevbox with that stuff soon, to help with the testing
10:15:07 <cait> um
10:15:40 <cait> #info magnuse and tcohen are working on a branch for kohadevbox to help with the testing
10:15:45 <cait> thx magnuse
10:15:46 <cait> moving on
10:15:51 <cait> #topic KohaCon15
10:15:59 <cait> is one of the organizers present?
10:16:10 <cait> or someone attending / with information?
10:16:16 <ashimema> We have a couple of customers running Plack and CGI in parallel for live systems now.
10:16:18 <drojf> when is it? octoberß
10:16:47 <cait> I thin in week 43
10:16:52 <cait> ashimema: runnign opac and staff?
10:16:56 <drojf> i don't live by weeks ;)
10:17:19 <ashimema> staff is what we're trailing I think
10:17:21 <drojf> but that would be in a month if my calendar is right
10:17:34 <cait> #link http://koha-community.org/kohacon/kohacon15/
10:17:35 <ashimema> to improve performance for them.. very big customers..
10:17:43 <cait> #link http://kohacon15.projektlinkkonsult.com/
10:18:01 <schnydszch2> Philippine representative here
10:18:18 <cait> anything more plack or kohacon15?
10:18:19 <drojf> brb
10:18:21 <schnydszch2> Workung meeting luch for me
10:18:28 <ashimema> not form me
10:18:38 <cait> ok
10:18:47 <cait> #topic KohaCon16
10:18:57 <cait> who wants to go first? :)
10:19:16 <cait> #link http://wiki.koha-community.org/wiki/KohaCon16_Proposals
10:19:17 <drojf> back
10:19:24 <cait> we got 2 proposals this year
10:19:29 <drojf> well, we have… yes, that :)
10:19:43 <ikourmou> Thessaloniki rep here
10:19:49 * drojf flips a coin
10:20:00 <cait> One from Thessaloniki, Greece and another from the Philippines
10:20:17 <cait> drojf: what's the result?
10:20:18 <wahanui> i guess the result is the same but legally, i don't think we can have discount on taxes...
10:20:23 <drojf> any news from greece about kohacon 2016, ikourmou?
10:20:55 <ikourmou> We are on track for the migration, we go live next week
10:21:08 <drojf> oh, good luck
10:21:25 <ikourmou> I would like to know the voting page URL, so that i inform my colleagues
10:21:52 <drojf> the proposal was clear, no questions from me. anything else you would like to add?
10:21:55 <ashimema> do we have one yet ;)
10:22:06 <drojf> no we don't, we will have at the end of the meeting :)
10:22:12 <cait> fingers crossed!
10:22:13 <ashimema> :)
10:22:29 <cait> oh
10:22:34 <drojf> hm timing is everything
10:22:35 <wahanui> i already had it that way, drojf.
10:22:36 <ikourmou> ok, if you need anything to clarify regarding our proposal...
10:22:37 <cait> ah we still got a schnydszch
10:22:45 <ikourmou> i'm willing to do so
10:22:59 <drojf> ikourmou: i think it is all there :)
10:23:12 <drojf> any news about kohacon 2016 from the philippines, schnydszch2?
10:23:17 <thd> schnydszch2: Do you have an update on the venue in consequence of the national library not being available?
10:23:35 <schnydszch2> We have the full support of the national library of the philippines on this
10:24:00 <schnydszch2> So the location will still be the national library of the philippines
10:24:09 <drojf> great
10:24:20 <schnydszch2> It will be available durong that tike according to estimate
10:24:25 <thd> schnydszch2: Great :)
10:24:49 <drojf> so should i add manila then to the voting site? so far i have "thessaloniki, greece" and "philippines" which is a little odd :)
10:25:14 <schnydszch2> Manila, philippones
10:25:25 <cait> #info Location for the Philippines is Manila, National library
10:25:26 <schnydszch2> Manila, Philippines*
10:25:41 <drojf> ok i will change that before it goes live
10:25:56 <drojf> schnydszch2 anything else you would like to add?
10:25:59 <schnydszch2> National Library of the Philippines, Manila, Philippines
10:27:02 <schnydszch2> Nothing. Everything else is in the wiki proposal
10:27:04 <drojf> we will start voting now. there are only two candidates, so that won't be too complicated. basically, i have two options
10:27:25 <drojf> "now", after the meeting really
10:27:36 <cait> how long is it going to run?
10:28:29 <thd> What had we determined about polling period last month.
10:28:32 <thd> ?
10:28:42 <drojf> we could do a simple radio button vote where you choose on option, or a ranking. the ranking would have also the option of either one or two votes, like "i prefer a, but would go to b" or "i would only go to a"
10:29:22 <drojf> in the latter case we would have to decide how to count that. given it is only two options, it will probably not make a difference in the end
10:29:29 <drojf> the voting period is one week
10:29:51 <cait> #info Voting for the bids is going to start today, the voting period is a week.
10:30:09 <drojf> to show you what i mean…
10:30:11 <thd> drojf: If using a radio button, it should be blank by default.
10:30:12 <magnuse> i'd say keep it simple: a or b, no second alternative
10:30:41 <drojf> option 1 http://abunchofthings.net/limesurvey/index.php/614551?lang=en
10:30:41 <drojf> option 2 http://abunchofthings.net/limesurvey/index.php/177931?lang=en
10:31:06 <drojf> thd: it's blank and the order is randomized
10:31:07 <cait> thd: it is
10:31:45 <ashimema> the second page is an error for me./
10:32:09 <drojf> oh? what kind of error?
10:32:12 <cait> permission setting i think
10:32:13 <schnydszch2> For me as well
10:32:19 <drojf> oh sorry. wait :)
10:32:21 <ashimema> yup.. permission error
10:32:23 <cait> We are sorry but you don't have permissions to do this.
10:32:25 <schnydszch2> Could be because i tested it?
10:33:45 <magnuse> 1st one works for me, not second. first time visitor.
10:34:08 <drojf> does that work http://abunchofthings.net/limesurvey/index.php/393475
10:34:19 <BobB> schnydszch2 and magnuse believe in the maxim 'Vote early and vote often!' :)
10:34:48 <drojf> it lacks the "not the real deal" warning now
10:34:52 <schnydszch2> Second one works
10:34:57 <drojf> but it is not, don'tpass it around ;)
10:35:10 <ashimema> yup..
10:35:34 <drojf> like magnuse, i would say for the two options the simple one is enough
10:35:47 <drojf> but i am open for opinions
10:36:01 <ashimema> I tihnk we'd need to clearly state how the votes count if we wen't for the latter.
10:36:06 <ashimema> before putting it up
10:36:14 <drojf> ashimema: yes, we would have to decide that now
10:36:17 <cait> rangi told me he preferred the ranking method
10:36:19 <ashimema> so yeah.. I agree.. go for the former ;)
10:36:20 <drojf> and put it in
10:36:25 <thd> #me hates drag and drop metaphor but likes ranked voting principle.
10:36:25 <ikourmou> yes, the first one (with the radiobuttons) is straightforward
10:36:44 <cait> a problem we had in the past is that it was not clear to everyone that you could rank only one option instead of all options
10:36:51 <ashimema> are there some ranking systems fro exactly this out there
10:36:56 <drojf> in case we had more proposals, ranking would definitely be interesting
10:37:02 <cait> so there is some possible fuzziness there
10:38:01 <schnydszch2> I think first one will work because we only have two
10:38:12 <drojf> do you waynt to vote on the way we vote? ;)
10:38:22 <cait> heh
10:38:23 <ashimema> I sorta like the ranking..
10:38:24 <drojf> so far i think the simple option is preferred
10:38:39 <ashimema> as it takes account of the 'I can't make it to x, but would attend y'
10:38:52 <drojf> my proposal for the ranking would be 2 points for first, 1 for second, 0 if not chosen
10:39:22 <drojf> there are probably a lot of schemes aqnd calculations about such things out there that i don't know about ;)
10:39:27 <schnydszch2> If one is chosen since there are only two so the ranking will be 2 points for the one chosen and one point for the pther
10:39:57 <cait> and if you only chose one option 2 points total?
10:40:00 <ashimema> if you do rank and you allow for a no vote..
10:40:05 <ashimema> then you have 4 options..
10:40:21 <drojf> atm you have to choose 1 or 2 options
10:40:24 <ashimema> a + b, b + a, a, b
10:40:24 <drojf> that can be set
10:40:25 <thd> In the past we would have a vote and examined the result under various schemes for interpreting ranking.
10:40:44 <cait> i think we should be clear now
10:40:53 <drojf> thd: have the results first and then choose the interpretation?
10:40:55 <cait> before the vote starts
10:41:00 <drojf> that sounds… odd :)
10:41:13 <ashimema> I'd almost say.. for the 'can't go there' it needs to almost be a negative vote
10:41:18 <thd> drojf:  Yes it was odd, however, ...
10:41:53 <drojf> ashimema: let#s not complicate things :P
10:41:59 <ashimema> if it's not.. and you just auto asign a second choice your in fact counting it against those who cannot attend a particular destination
10:42:06 <thd> the choice of scheme to interpret the results would not have changed the result in our actual experience.
10:42:27 <drojf> thd: that is true. the choice of voting style won't do that this time either
10:43:00 <drojf> people from greece will vote only greece, people from the philippines will only vote philippines. and some devs will ranks because the company pays travel expenses
10:43:11 <drojf> *rank
10:43:12 <cait> not sure if you can say that
10:43:20 <ashimema> lol
10:43:40 <cait> if people misunderstand the form, they also might rank 2 because they think they have to
10:43:47 <drojf> disclaimer: just my gut feeling, not an official announcement :)
10:43:47 <ashimema> yup
10:44:00 <drojf> yes, that was leading to trouble before
10:44:01 <cait> i am fine with either opton
10:44:14 <cait> but it's like to have a clear scheme for the ranking and a good clear note on the page
10:44:22 <magnuse> with the ranking you could have A 51% as first, B 49% as first - and then B might still win if it has a lot more 2nd places than A
10:44:35 <magnuse> so do we vote on the voting?
10:44:40 <drojf> magnuse: in theory, yes. depending in how that is counted
10:44:59 <thd> On one occasion at least, the preference order for some later ranked choices would have been different with different interpretation schemes.
10:45:24 <drojf> i'm fine with both options, as long as we agree on the interpretation upfront
10:45:55 <drojf> so we can say, if you rank, that means exactly this and that
10:46:18 <BobB> i like the simple option, but cait has to decide if this is going to a vote
10:46:23 <ashimema> agreed
10:46:24 <drojf> it has to be clear what is going on, no fuzzy interpretation afterwards
10:46:54 <cait> BobB: no problem with a vote to vote...
10:47:01 <cait> but i think it would be good to know how the secnd opton works :)
10:47:14 <cait> shall i start a vote?
10:47:15 <BobB> yup
10:47:15 <drojf> do you want to decide that before voting?
10:47:31 <thd> I like the drojf's simple 2, 1, 0 count on this occasion for interpreting ranking.
10:47:55 <drojf> we could vote on the vote count before we vote on the vote :P
10:47:59 <ashimema> if it's 2,1,0.. does a 0 vote pair with a 1.. or a 2
10:48:14 <BobB> i think if there is a majority for ranking, then spend time working out the schema ...
10:48:18 <drojf> ashimema: i don't understand the question :)
10:48:27 <cait> #startvote Should we be using the radiobutton or the ranking method for voting? (radio,ranking)
10:48:27 <huginn> Begin voting on: Should we be using the radiobutton or the ranking method for voting? Valid vote options are , radio, ranking, .
10:48:27 <huginn> Vote using '#vote OPTION'. Only your last vote counts.
10:48:28 <drojf> BobB: +1
10:48:31 <thd> Ultimately, I prefer a score voting but scheme, but that is a different discussion for a different poll.
10:49:00 <cait> noone?
10:49:00 <wahanui> noone is, like, here
10:49:01 <ashimema> a + b = 2 + 1
10:49:03 <ashimema> a only = 2 + 0 OR 1 + 0
10:49:24 <drojf> i abstain and follow orders then ;)
10:49:29 <thd> #vote ranking
10:49:35 <ikourmou> #vote radio
10:49:41 <cait> #vote radio
10:49:48 <BobB> #vote radio
10:49:51 <ashimema> #vote radio
10:49:56 <cait> i think radio vote doesn't mean you can't go to your second favourite choice if you want to :)
10:50:08 <ashimema> ranking is too hard with just this meeting to work it out ;)
10:50:25 <drojf> you all should go to kohacon 2016, regardless of the location and your vote ;)
10:50:49 <ashimema> that entirely depends on your employer in many cases I would imagine
10:50:50 <cait> i will certainly try :)
10:51:07 <cait> schnydszch: ?
10:51:12 <drojf> ashimema: true. but your vote for a should not keep you away from going to b :)
10:51:13 <ashimema> greece.. we could send a party of people.. phillapines we'll be lucky to afford to send one.
10:51:20 <BobB> droif airfares make a huge diff for us: one location, we send one delegate, the other location we can send three :)
10:51:31 <BobB> ashimema: snap
10:51:32 <thd> ashimema: The "too hard" aspect is partly why we had not specified a specific interpretation scheme in the past.
10:51:47 <ashimema> lol
10:51:56 <drojf> everyone voted i think?
10:52:11 <cait> i was hoping schnydszch
10:52:12 <ashimema> I'd go for ranking every time if we had a scheme agreed upon ;)
10:52:21 <magnuse> #vote radio
10:52:30 <cait> as they are bidding
10:52:35 <cait> but we might have lost him
10:52:45 * ashimema hates the first past the post method in politics too)
10:52:59 <thd> ashimema++
10:53:03 <cait> schnydszch2: back?
10:53:04 <wahanui> and forth.
10:53:05 <cait> the vote is still open
10:53:10 <drojf> ashimema: we still could ;)
10:53:28 <schnydszch2> Sorry got cut what's to vote on?
10:53:55 <cait> ould we be using the radiobutton or the ranking method for voting? Valid vote options are , radio, ranking, .
10:54:05 <cait> should we be using...
10:54:14 <schnydszch2> #vote eadio
10:54:14 <huginn> schnydszch2: eadio is not a valid option. Valid options are , radio, ranking, .
10:54:30 <schnydszch2> #vote radio
10:54:36 <cait> #endvote
10:54:36 <huginn> Voted on "Should we be using the radiobutton or the ranking method for voting?" Results are
10:54:36 <huginn> ranking (1): thd
10:54:36 <huginn> radio (6): magnuse, cait, schnydszch2, ashimema, BobB, ikourmou
10:54:41 <cait> hm ok
10:54:57 <ashimema> is there a second half to this meeting?
10:55:05 <cait> #agreed 2 Radiobuttons, randomized order and no preselection will be used for the vote
10:55:10 <cait> ashimema: not this time around
10:55:12 <ashimema> I reckon rangi etc would vote the other way ;)
10:55:17 <drojf> ok that seems clear. and both bidders voted for radio too, so they won't be unhappy with it
10:55:18 <cait> yeah
10:55:25 <ashimema> yup..
10:55:38 <cait> yeah i think it's good that we got the representatives here
10:55:40 * ashimema suggests we work uot the scheme nice and early for the next vote ;)
10:55:51 <cait> :) thx for attending ikourmou and schnydszch!
10:55:54 <drojf> ashimema: put it on the agenda for next time
10:56:05 <schnydszch2> You're welcome!
10:56:11 <ikourmou> thank you!
10:56:22 <drojf> ok i will set that up now while you continue. i will send out an email to the list with the url soon
10:56:35 <cait> ok, if you are done before, maybe can paste here too i am moving on
10:56:36 <drojf> so you can inform everyone interested
10:56:41 <drojf> yes
10:56:48 <cait> #info Support vendor listing on the website
10:56:57 <cait> #link http://wiki.koha-community.org/wiki/Paid_support_providers_list_RFC
10:57:04 <cait> there are no proposals added to the wiki page
10:57:04 <BobB> #topic cait
10:57:07 <cait> oh
10:57:08 <cait> thx
10:57:15 <cait> #topic Support vendor listing on the website
10:57:20 <cait> sorry for messing up the minutes
10:57:29 <cait> #link http://wiki.koha-community.org/wiki/Paid_support_providers_list_RFC
10:57:33 <BobB> thx for chairing!
10:57:43 <cait> wizzyrea has added a lot of the requests by now
10:57:52 <thd> ashimema: A problem with vote interpretation schemes is a lack of consensus amongst experts in voting theory on what the one true mathematically fair voting system would be.
10:57:55 <cait> so i think the state of the website directory is currently up to date
10:58:18 <cait> are there volunteers I could #action that want to follow up on the discussion?
10:59:54 <ashimema> .
11:00:55 <cait> if not
11:01:02 <cait> i'd like to remove this from the agenda for now
11:01:08 <ashimema> k
11:01:31 <BobB> yes
11:01:52 <cait> #info the discussion fo the suport provider list is going to be removed from the agenda for now
11:02:04 <cait> #topic Actions from last meeting
11:02:31 <cait> drojf send out an email - all done
11:02:44 <cait> #action drojf is going ot send out an email with the URL vor voting after this meeting
11:02:56 <cait> #topic Next meeting
11:03:13 <BobB> #action BobB will follow up with bag re fundraising
11:03:33 <cait> thx BobB
11:03:48 <cait> Suggestion: October 7
11:04:06 <cait> 20 UTC?
11:04:27 <BobB> just a mo'
11:05:18 <BobB> hmm 7am, ok
11:05:21 <thd> I like that suggestion, as it avoids a potential conflict as I conclude work protecting a friend from eviction.
11:05:39 <cait> ok?
11:05:46 <cait> not gong to start another vote :)
11:05:46 <ashimema> :)
11:05:53 <magnuse> +1
11:06:00 <thd> +1
11:06:06 <cait> #info Next meeting is going to be October 7, 20 UTC
11:06:13 <cait> thx everyone for attending!
11:06:18 <cait> #endmeeting