20:03:00 <cait> #startmeeting General IRC Meeting - 10 June 2015
20:03:00 <huginn> Meeting started Wed Jun 10 20:03:00 2015 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:03:00 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:03:00 <huginn> The meeting name has been set to 'general_irc_meeting___10_june_2015'
20:03:02 <pianohacker> oh yar
20:03:04 <cait> #topic introductions
20:03:05 <wahanui> #info wahanui, a bot that has become sentient
20:03:14 <cait> please introduce yourself with info, following the bot's example
20:03:19 <pianohacker> #info Jesse Weaver, ByWater Solutions
20:03:22 <cait> today's agenda can be found at
20:03:23 <cait> #link http://wiki.koha-community.org/wiki/General_IRC_meeting_10_June_2015
20:03:34 <cait> #info Katrin Fischer, BSZ, Germany
20:03:39 <drojf> #info Mirko Tietgen, Berlin, Germany
20:03:40 <indradg> #info Indranil Das Gupta, L2C2 Technologies, IN
20:03:42 <nengard> #info Nicole Engard, ByWater Solutions
20:04:14 <talljoy_DND> #info Joy Nelson, ByWater Solutions
20:04:16 <JesseM> #info Jesse Maseto, ByWater Solutions, USA
20:05:00 <cait> doesn't look like a big crowd tonight
20:05:05 <cait> let's move on
20:05:09 <cait> #topic Announcements
20:05:57 <cait> any announcements? :)
20:06:33 <JesseM> koha is awesome
20:06:37 <cait> heh ok
20:06:39 <cait> that counts
20:06:42 <cait> i am moving on then
20:06:49 <wnickc> #info Nick Clemens, VOKAL Consortium, USA
20:06:50 <cait> bgkriegel: maybe annoucne your hackfest?
20:07:51 <cait> well i have heard rumours about a koha hackfest in Buenos Aires sometime soon :)
20:07:53 <cait> moving on
20:08:05 <cait> #topic Updates on releases
20:08:14 <bgkriegel> #info Bernardo Gonzalez Kriegel
20:08:20 <bgkriegel> sorry late
20:08:32 <cait> np
20:08:36 <cait> want to add something now?
20:09:01 <nengard> Koha North American Users Group meeting will be in August
20:09:08 <bgkriegel> well, hackfest on Buenos Aires 2-3 July
20:09:14 <NateC> Nate from ByWater is here
20:09:19 <cait> #info Koha North American Users Group meeting in August
20:09:20 <nengard> http://www.mercyhurst.edu/academics/library/2015-koha-north-american-users-group-conference
20:09:33 <cait> #link http://www.mercyhurst.edu/academics/library/2015-koha-north-american-users-group-conference
20:09:33 <edveal> #info Ed Veal ByWater USA
20:09:52 <cait> #info Hackfest in Buenos Aires, Argentina, 2-3 July
20:10:04 <cait> so many fun Koha events! - is he teleporter ready finally?
20:10:08 <bgkriegel> We'll have some people from Chile!
20:10:12 <rangi> #info chris cormack, catalyst
20:10:19 <mtompset> #info Mark Tompsett
20:10:27 <NateC> #info Nate Curulla ByWater
20:10:47 <cait> ok, rangi - you are rmaint - any update on releases? :)
20:11:06 <rangi> steady as she goes, string freeze 15th, release on 22nd as normal
20:11:25 <cait> #info releases are on track - string freeze on 15th, release on 22nd as normal
20:11:31 <nengard> I'll need to get the help files updated probably before the next release (since I won't do it in the next 5 days)
20:11:42 <nengard> but I do believe the manual is mainly done for 3.20
20:12:01 <cait> #info manual is mainly done for 3.20, help files still to be updated
20:12:20 <cait> ok, anything else about releases before we move on?
20:12:42 <cait> moving on
20:12:54 <cait> #topic KohaCon15/16
20:12:56 <rangi> just that 14360 should get pushed soon, so it can go in all the releases
20:13:26 <cait> that was the security one
20:13:27 <cait> ?
20:13:38 <nengard> bug 14360
20:13:39 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14360 is not accessible.
20:13:46 <rangi> yup
20:13:51 <rangi> its passed qa
20:14:01 <cait> #info bug 14360 to be included into the next releases (security fix)
20:14:08 <nengard> is that the right bug number?
20:14:19 <cait> yes
20:14:26 <cait> it's not visible, because it's security
20:14:30 <nengard> got it
20:14:45 <cait> is someone from kohacon15 organizing team around tonight?
20:15:40 <rangi> doesnt look like it
20:15:50 <NateC> heh
20:15:55 <cait> #bids for KohaCon16 are still open - please add your proposal if you are interested in hosting!
20:16:03 <cait> can someoneget the link for me?
20:16:06 <mtompset> YAY, Philippines!
20:16:21 <JesseM> http://wiki.koha-community.org/wiki/Category:KohaCon16
20:16:28 <nengard> http://wiki.koha-community.org/wiki/KohaCon16_Proposals
20:16:42 <nengard> cait I don't see Germany there??!!
20:16:49 <cait> heh
20:16:54 <JesseM> :)
20:16:59 <cait> #link http://wiki.koha-community.org/wiki/KohaCon16_Proposals
20:17:02 <rangi> im just waiting to hear back from my bosses if they will cover the airfare to nigeria ill be going to kohacon15
20:17:07 * cait suggests harassing drojf :P
20:17:41 <nengard> Philippines is great too
20:17:51 <cait> ok, moving on
20:18:02 <cait> #topic Next steps in Fundraising
20:18:34 <cait> Bob posted the TOR 2 days ago, they can be found here:
20:18:37 <cait> #link http://wiki.koha-community.org/wiki/Fundraising
20:18:48 <cait> #info TOR = Terms of Reference posted for discussion
20:18:57 <cait> is someone from the fundraising committee here?
20:19:21 <NateC> Brendan is not in today
20:19:40 <NateC> moving into a new house
20:20:15 <cait> I have agreed with Bob and Brendan that I will ask for people to comment on the mailing list or the wiki
20:20:33 <indradg> +1
20:20:42 <cait> which i hereby do :)
20:20:59 <cait> #action all please read the Terms of reference and ask questions on the mailing list or leave comments on the wiki
20:21:36 <cait> anything?
20:21:37 <wahanui> anything is possible with enough development work :)
20:21:40 <cait> heh thx wahanui
20:22:05 <JesseM> +1
20:22:34 <cait> ok, moving on
20:22:51 <cait> #topic Misc
20:23:02 <nengard> I love Koha :)
20:23:03 <cait> indradg?
20:23:03 <wahanui> indradg is the one who told me.
20:23:26 <indradg> yeah.. i would like to discuss about the listed provider listing on the site
20:24:17 * mtompset cringes in fear over the heat that will be generated.
20:24:33 <indradg> being listed on it is being used by both vendors as well as users floating RFPs that the bidder must be a registered service provider or authorized service provider
20:24:58 <indradg> this was added in May 2014 - http://koha-community.org/clarification-regarding-the-list-of-paid-support-companies/
20:25:02 <indradg> as a clarification
20:25:25 <indradg> in Feb 2015, gmcharlt posted this on his blog, based on an actual violation https://galencharlton.com/blog/2015/02/ogres-hippogriffs-and-authorized-koha-service-providers/
20:25:53 <indradg> and if you are on facebook, you can see here https://www.facebook.com/photo.php?fbid=10153071477269442&set=a.99052774441.88671.573989441&type=1&theater
20:25:54 <cait> #link http://koha-community.org/clarification-regarding-the-list-of-paid-support-companies/
20:26:16 <indradg> a major university in India asking for registered vendors
20:26:17 <cait> #link https://galencharlton.com/blog/2015/02/ogres-hippogriffs-and-authorized-koha-service-providers/
20:26:31 <indradg> for instance L2C2 does not qualify to bid
20:26:57 <indradg> rangi has been aware of these concerns as is wizzyrea
20:27:20 <indradg> since the listing is maintained between wizzyrea and gmcharlt as volunteers
20:27:53 <indradg> cait: so here is the deal. as a community we can't perhaps go policing the providers.
20:28:19 <indradg> but India is one of the places which is seeing a very fast uptake/adoption of Koha
20:28:27 <slef> #info MJ Ray
20:28:39 <indradg> and the listing is being, at the lack of a better word "weaponized"
20:29:18 <cait> it's sad to hear it - I often point people to that page when they are looking for options
20:29:26 <cait> indradg: what do you suggest?
20:29:29 <slef> TOR is The Onion Router
20:29:36 <indradg> so, what can we do? - remove the listing altogether? word it better (little scope for that), c) have the vendors include a boilerplate text
20:30:31 <cait> we could put a more obvious note in the top i think - but you can't force people to read
20:30:42 <mtompset> And people will not read it.
20:30:58 <slef> sadly we can't stop buyers putting in whatever stupid things they want in their qualification criteria
20:31:11 <slef> it is up to their stakeholders to police them
20:31:34 <indradg> slef: if there is no listing there is no scope for "registered" / "authorised" service providers
20:31:58 <slef> indradg: and then everyone will post whatever lies they like on their own websites, like before
20:31:59 <rangi> the amount of stress it causes wizzyrea, id vote removing it
20:32:09 <mtompset> Which, by the way, we also could extend this problem into the Wiki.
20:32:10 <drojf> how is the list "weaponized"? i don't understand what is the problem
20:32:35 <cait> it's still a useful resource to others... not only a dark side to it
20:32:50 <nengard> I'd love a way that didn't cause stress for wizzyrea - but keep it - lots of open source software projects have a page of support providers
20:32:51 <mtompset> drojf: If a person isn't listed, they aren't considered an authorized provider.
20:32:52 <nengard> it's a useful tool
20:32:52 <indradg> drojf: I'm not listed. A tender says I must be a registered Koha support provider listed on koha-community.org
20:32:57 <cait> i'd be sad to see it gone
20:33:12 <slef> indradg: and also people will try to make their own astroturf sites beat koha-community.org in search results, like before
20:33:14 <cait> indradg: why are you not listed? sorry, but kinda asking the obvious question i guess :)
20:33:28 <drojf> indradg: maybe that is a stupid question for some reason, but why are you not listed?
20:33:40 <drojf> hi5 cait
20:33:50 <indradg> cait: laziness more than anything. I keep getting work via referrals
20:33:55 <rangi> you should see all the offlist mail wizzyrea gets too
20:33:56 <slef> remember what part of the point of the listing requirements was: to get lots of good library sites pointing to the community site as the recognised home of koha
20:34:09 <rangi> i reckon someone else should volunteer to maintain it
20:34:16 <indradg> India has the largest number of listed providers on that list
20:34:17 <rangi> because its a bs job
20:34:28 <indradg> and the lowest ratio in patches
20:34:35 <cait> maybe we could share it - or an autorespond to ask on the list
20:34:36 <indradg> that says its own story
20:34:37 <cait> or both
20:34:50 <rangi> so the people who want to keep it, one or a few of them should email wizzyrea to ask how they can help
20:35:00 <indradg> rangi asked about ckoha source earlier in the day
20:35:08 <drojf> ok. i understand the point of it being a bad job. i do not get the "i am too lazy to get listed, it has to go" part?
20:35:18 <slef> I also think we should update the listing requirements
20:35:47 <rangi> its not too lazy, its being on the site confers some kinda officialness which is crap
20:36:04 <slef> How about, if you are caught claiming to be an authorized or registered listing provider, we boot you off the list for a year?
20:36:17 <indradg> drojf: I never thought being listed was a criteria.
20:36:22 <rangi> that is the problem, people think its actually a useful list, when all it is a list anyone can get on, that we don't check up on, and is marketed as being an official list
20:36:47 <slef> s/listing//
20:36:50 <rangi> slef: yeah policing .. that will make the job even better
20:36:57 <rangi> bags not having anything to do with that
20:37:20 <rangi> specially as a support provider
20:37:29 <indradg> what is happening is that while applying for listing, the pages are clean and sweet... once listed, the text changes
20:37:32 <slef> rangi: I know it's a sucky job.  I've kept listings on various sites before.
20:37:41 <rangi> im not opening myself up to lawsuits for taking action against other support providers
20:38:00 <rangi> ive dealt with enough lawyers through koha to last a lifetime
20:38:07 <slef> rangi: indeed. When wizzyrea started doing the task, she wasn't working at a support provider. We probably need new people to do it.
20:38:14 <indradg> heh rangi :)
20:38:30 <slef> rangi: errr have I mentioned my peer certification idea here before?
20:38:33 <drojf> the only thing i tell people is to ask the support companies they consider working with about their involvement in the community.
20:38:34 <cait> i am not sure if working at a support provider has something to do with it
20:38:35 <nengard> I think it sounds like we need a few things: #1 a new title (not official)  #2 A description  #3 someone else to maintain the list
20:38:45 <Teejay> #info Tunji Adepeju Projektlink Konsult Limited Nigeria
20:38:53 <cait> hi Teejay
20:39:12 <nengard> Have a lit of providers - even unofficial - is useful to those who find the Koha page - then if theyr'e scared to do it alone they can find someone local easily
20:39:13 <slef> oh yeah, back in 2011
20:39:14 <rangi> cait: it does, if we are going to take action, like remove listings
20:39:16 <cait> maybe a first thing we shoudl do is ask wizzyrea if she wants to get rid of doing it
20:39:21 <rangi> hi Teejay :)
20:39:29 <Teejay> Hello
20:39:30 <rangi> i know she does
20:39:30 <wahanui> bidet, Teejay
20:39:35 <cait> and then gather some ideas to vote decideon on the wiki for the next meeting?
20:39:45 <rangi> i hear her swearing everytime the topic comes up
20:39:50 <cait> with someone mailing the mailing list?
20:40:03 <slef> http://irc.koha-community.org/koha/2011-07-12#i_711907
20:40:15 <rangi> now Teejay is here, we could revisit kohacon15 maybe?
20:40:28 <mtompset> Yes.
20:40:29 <cait> yep in a moment
20:40:50 <cait> would someone volunteer to email the mailing list asking for ideas and volunteers?
20:41:27 <slef> cait: about the listings?
20:41:32 <cait> yes
20:41:45 <Teejay> Thank you
20:41:46 <mtompset> http://wiki.koha-community.org/wiki/Category:Support_Companies
20:41:51 <mtompset> Same problem on the Wiki.
20:42:00 <Teejay> Had some difficulty with the Internet
20:42:02 <slef> anyone know when wizzyrea will be online next? I think we should talk to her first
20:42:28 <cait> maybe one idea: move it to the wiki
20:42:31 <NateC> I think the listing is useful as proof that the community is broad and that libraries don't need to worry about vendor lockin
20:42:38 <cait> not so nice sorting options then, but it will be 'less official'
20:42:50 <NateC> so in one way or another, the availability of options should be showcased
20:42:57 <cait> NateC++ yeah, that's how i feel about it too - but i see the problems
20:43:50 <NateC> another option is to get rid of the list and have another list that highlights companies who are regular contributors to the community
20:43:59 <cait> #info discussion about the presentation of the vendor list to be continued at next meeting
20:44:05 <NateC> either via signoffs or testing or devs etc...
20:44:13 <NateC> make it an incentive
20:44:14 <mtompset> Oooo... I like that idea, NateC.
20:44:23 <NateC> a karma page
20:44:27 <NateC> or something like that
20:44:43 <slef> NateC: that also removes the incentive for them to link back to koha-community.org, doesn't it?
20:44:46 <drojf> that sounds reasonable to me. its what i tell people to ask providers about anyway
20:44:49 <NateC> or "the community thanks the following vendors for their contributions" page
20:44:58 <cait> we kid of have that with the dashboard - but i think also need a place separate with contact information
20:45:28 <NateC> just brainstorming here..
20:45:55 <bgkriegel> NateC: not bad idea
20:46:06 <NateC> this is a meritocracy so those who deserve merit are recognized
20:46:13 <drojf> it may create a new genre of development. spam patches with the purpose of being listed :P
20:46:14 <NateC> we can do it for individuals too
20:46:15 <cait> i think we kept it simple to make it easy to verify
20:46:20 <cait> might make things even more complicate
20:46:37 <cait> fixing typos in the dev comments... :)
20:46:49 <slef> NateC is not listening, missing one of the points of having that listing.
20:46:50 <cait> are we ok to put this on the agenda for next time?
20:46:53 <slef> ok
20:46:56 <indradg> ok
20:47:02 <slef> I think indradg is asking us to solve a social problem with a technical solution.  Buyers can (and often do IME) put random junk in tenders.
20:47:25 <mtompset> true.
20:47:26 <cait> #topic KohaCon15
20:47:34 <slef> points 1, 2, 6 and 7 were also junk
20:47:39 <cait> oh no
20:47:43 <slef> (of the facebook example)
20:47:44 <cait> we lost Teejay
20:47:59 <slef> cait: can you remember where you last had Teejay?
20:48:04 <cait> heh
20:48:30 <cait> (22:42:00)?
20:48:52 <cait> give me a moment to look up the points for the next topic
20:49:17 <NateC> self there is a difference between not listening and not paying attention, I was listening :)
20:49:34 <talljoy_DND> that felt a little rude slef
20:50:32 <cait> #topic Actions from last meeting
20:50:46 <cait> #info there were no actions - so all got done
20:52:01 <cait> #topic Set time and date of the next General IRC Meeting
20:52:22 <cait> so normally we have a monthly cycle
20:53:18 <cait> we could maybe go for 2 or 3 weeks this time?
20:54:06 <cait> any preferences?
20:54:31 <drojf> why?
20:54:54 <drojf> i mean why have 2 or 3 instead of 4 this time?
20:55:13 <indradg> monthly is fine
20:55:15 * drojf is easily confused by everything today
20:56:25 <cait> ok, so monthly
20:57:07 <cait> July... 8th?
20:57:15 <cait> which is the next time? drojf?
20:57:56 <drojf> 10 utc?
20:57:56 <wahanui> i heard 10 utc was a good time, but is very early on east coast USA
20:58:05 <cait> ok, any veto?
20:58:27 <bgkriegel> +1
20:58:35 <talljoy_DND> +1
20:58:36 <cait> #agreed next meeting will be held at June 8th, 10 UTC
20:58:41 <cait> #endmeeting