19:11:38 <cait> #startmeeting  Development IRC meeting 13 April 2016
19:11:38 <huginn> Meeting started Wed Apr 13 19:11:38 2016 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:11:38 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:11:38 <huginn> The meeting name has been set to 'development_irc_meeting_13_april_2016'
19:11:44 <cait> #Introductions
19:11:50 <cait> Please introduce yourself using #info
19:11:57 <cait> #topic Introductions
19:11:57 <wahanui> #info wahanui, a bot that has become sentient
19:12:02 <cait> like wahanuijust did
19:12:04 <drojf> #info Mirko Tietgen, Berlin, Germany
19:12:11 <cait> today's agenda can be found at https://wiki.koha-community.org/wiki/Development_IRC_meeting_13_April_2016
19:12:13 <cait> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_13_April_2016
19:12:20 <cait> #info Katrin Fischer, BSZ, Germany
19:12:35 <bag> #info Brendan Gallagher, ByWater
19:12:45 <barton> #info Barton Chittenden, Bywater
19:13:30 <cait> tcohen: ?
19:13:49 <cait> kidclamp: ?
19:14:33 <cait> less than 5 again?
19:15:05 <kidclamp> #info Nick CLemens, ByWater Solutiojns
19:15:15 <kidclamp> #info Nick Clemens, ByWater Solutions
19:15:38 <cait> ok, moving on
19:15:49 <cait> #topic Review coding guidelines
19:16:32 <cait> khall had proposed to do a draft for a new goding guidelines page  - but I think it will take him a bit longer :)
19:16:55 <cait> so we can move on to the second suggestion from oleonard:
19:17:06 <cait> #info  [oleonard] Proposal: Add a coding guideline discouraging the use of  the "onclick" attribute in favor of defining click handlers in separate  JavaScript blocks or files.
19:17:28 <cait> oleonard has apologized from today's meeting
19:17:39 <cait> is this something people generally agree on or are there questions?
19:18:01 * barton generally agrees.
19:18:08 <kidclamp> is there a reason for the preference?
19:18:23 <cait> i think there is one... but i don't know it
19:18:40 <kidclamp> well, it seems reasonable and I trust oleonard to have agood reason
19:18:53 <cait> similar here
19:18:57 <cait> question is, can we vote?
19:19:34 <barton> I'm willing to vote.
19:20:13 <kidclamp> me too
19:20:34 <barton> +1
19:20:40 <cait> #vote Should we add oleonards proposed guideline to the coding guidelines? (yes,no)
19:20:44 <cait> sec
19:20:51 <barton> yes
19:20:52 <cait> #startvote Should we add oleonards proposed guideline to the coding guidelines? (yes,no)
19:20:52 <huginn> Begin voting on: Should we add oleonards proposed guideline to the coding guidelines? Valid vote options are , yes, no, .
19:20:52 <huginn> Vote using '#vote OPTION'. Only your last vote counts.
19:20:58 <cait> sorry, i always mess that up
19:21:05 <cait> #vote yes
19:21:06 <barton> yes
19:21:16 <barton> #vote yes
19:21:46 <kidclamp> #vote yes
19:22:04 <drojf> not really qualified to vote on this, but if oleonard wants it its probably right ;)
19:22:10 <drojf> #vote yes
19:22:22 <kidclamp> I think that is what we all agree, let's hope he does not go mad with power
19:22:45 <cait> :)
19:22:51 <cait> #endvote
19:22:51 <huginn> Voted on "Should we add oleonards proposed guideline to the coding guidelines?" Results are
19:22:51 <huginn> yes (4): kidclamp, cait, barton, drojf
19:23:20 <cait> #agreed Proposed guideline will be added.
19:23:44 <cait> #action oleonard to add his proposed coding guideline, maybe with an example, to the coding guidelines page
19:23:54 <cait> #topic Any bugs that are in discussion
19:24:02 <cait> does someone have a bug on mind he/she wants to bring up here?
19:25:10 <cait> if there is none, i'll jump to the next topic
19:25:26 <cait> #topic General development discussion
19:25:33 <drojf> nobody tested bug 15303 so far, so i wonder if i should invest the time to make the changed i intended or it's not going in the next release aqnyway
19:25:34 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15303 enhancement, P5 - low, ---, mirko, Needs Signoff , Letsencrypt option for Debian package installations
19:25:52 <cait> i think it might be something for testing at the hackfest maybe
19:26:19 <drojf> that is a little late for 16.05
19:26:21 <cait> i am not good about sysadmin - but i think there would be other people interested to get walked through it
19:26:28 <cait> true
19:26:49 <cait> i'd like very much to see it - but don't feel comfortable about testing myself
19:27:34 <kidclamp> does it renew the certificates too?
19:28:44 <drojf> that needs a cron job. i can add that
19:29:44 <kidclamp> I think that would make it even more appealing, but with cait, not my wheelhouse
19:30:10 <cait> tcohen maybe?
19:30:35 <drojf> i wanted to have some things in koha-letsencrypt and have an option to LE-ify existing instances. i would throw that in until end of the week, but as a lot of people so far said they want to have it and nobody tested the parts so far, i have more urgent things to do
19:31:46 <cait> maybe send a quick mail to the mailing list?
19:32:03 <cait> saying you need someone to test in order to make thi smoving at this point?
19:32:54 <drojf> hm. maybe
19:34:35 <cait> about the other 4 topics
19:34:42 <cait> i don't want to discuss all of them in this small group i think
19:34:49 <cait> is there somehting someone is specifically interested in ?
19:35:27 <drojf> in general, let's use more catmandu :)
19:35:52 <drojf> when is feature freeze?
19:36:06 <cait> 28th
19:36:18 <cait> lots of good things in the queue
19:36:24 <kidclamp> 15930 would be nice to get in, and backport
19:36:26 <cait> and Joubu sent a good summary email
19:36:33 <cait> bug 15930
19:36:34 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15930 normal, P5 - low, ---, jonathan.druart, Signed Off , DataTables patron search defaulting to 'starts_with' and not getting correct parameters to parse multiple word searches
19:36:47 <cait> hm agreed, looks like a bug fix
19:36:53 <drojf> ok then i'm trying to get my own tester :P
19:36:54 <cait> so should be not a problem for backporting hopefully
19:37:09 <cait> when you find out where to buy them tlel me
19:37:27 <cait> i need more qa people :)
19:37:48 <drojf> i hope tcohen will qa it when i get a signoff person
19:38:05 <cait> the other topics are all worthwhile, but probably for another time
19:38:09 <cait> can we move to updates from QA?
19:38:25 <barton> good by me.
19:38:35 <cait> #info bug 15930 for 16.05 and backport
19:38:47 <cait> #info feature freeze is on April 28
19:39:04 <cait> #info bug 15303 needs a tester to help it moving forward
19:39:05 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15303 enhancement, P5 - low, ---, mirko, Needs Signoff , Letsencrypt option for Debian package installations
19:39:11 <cait> just feeding the minutes
19:39:17 <cait> #topic Updates from the QA team
19:39:29 <cait> as always... fix all the bugs please, write good test plans and working code :)
19:39:37 <cait> but aside from that i have a proposal
19:39:39 <drojf> that is not an update :P
19:39:41 <cait> something i'd like to try
19:39:59 <cait> #info  [kfischer] proposal to have an 'exception rule' for SIP2  and LDAP related patches being able to pass QA with 2 sign offs.
19:40:10 <cait> we have tried several things.. but ldap and sip2 patches are getting stuck
19:40:21 <cait> there are not a lot of testers for those and they are hard to test
19:40:32 <cait> i'd like to try if it works with 2 sign-offs
19:40:35 <cait> and a qa 'nod'
19:41:04 <cait> what do people think?
19:41:54 <cait> you can say if you hate the idea - but the quiet is scary
19:42:19 <drojf> i wonder what is actually required to test those
19:42:20 <barton> cait: I'm ambivalent -- on one hand I think that moving patches through expiditiously is a good thing, but we also seem to have a lot of weird bugs show up in new releases, especially wrt/ sip.
19:42:40 <eythian> you could also suggest a hackfest project to make a SIP/LDAP test system :) (not volunteering ;)
19:42:53 <cait> i am torn myself
19:42:59 <cait> but a lot of bug fixes got stuck as well
19:43:20 <drojf> is ashimema coming to greece?
19:43:29 <kidclamp> I feel like it sounds reasonable, if the qa 'nod' includes a review fo the code
19:43:34 <cait> no - school holidays in UK
19:43:41 <cait> i'd say so
19:43:48 <drojf> who else has any idea of this stuff?
19:43:49 <kidclamp> faster passing through might make an extra bug, but allows for the fix to come in
19:43:53 <barton> did we ever get any unit tests for sip? I know that someone was working on it at some point...
19:44:00 <cait> khall - but he also writes a lot of the stuff
19:44:03 <cait> ColinC
19:44:21 <kidclamp> maybe get their views?
19:44:30 <cait> ColinC can technically pass QA - we approved of that a while ago as a first measure
19:44:36 <cait> to have an extra SIP person
19:45:01 <cait> at the moment the queue is not super bad
19:45:02 <cait> let me check
19:45:09 <beatsforthemind> Is there a reason why the Zebra SRU results don’t include the biblio numbers of the recrds?
19:45:12 <beatsforthemind> records*
19:45:17 <cait> hm for ldap i see imeediately on the dashboard
19:45:22 <cait> bug 14144
19:45:23 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14144 minor, P5 - low, ---, mtompset, Needs Signoff , Silence warnings t/db_dependent/Auth_with_ldap.t
19:45:29 <cait> bug 6979
19:45:30 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=6979 major, P1 - high, ---, alex.arnaud, Needs Signoff , LDAP authentication fails during password comparison
19:45:31 <drojf> beatsforthemind: we are in a meeting
19:45:38 <cait> bug 15006 sip
19:45:39 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15006 normal, P5 - low, ---, colin.campbell, Signed Off , Need to distinguish client timeout from login timeout
19:45:39 <beatsforthemind> sorry :/
19:46:01 <cait> beatsforthemind: pretty sure they do - checked 999$c?
19:46:03 <drojf> nothing to be sorry about, but you will probably get no answers atm
19:46:59 <barton> beatsforthemind: if you're looking at results in the opac, my guess is that numbers will be supressed if there's any hidden items.
19:47:02 <cait> probably more in needs sign off
19:47:22 <cait> barton: ?
19:47:31 <cait> SRU :)
19:47:45 <barton> ah. sorry. nvm.
19:48:09 * barton had his light out, got eaten by an SRU.
19:48:36 <barton> back to dev meeting.
19:48:48 <cait> heh
19:49:01 <cait> ok, we don't have to vote on this if people are not sure about
19:49:33 <barton> yeah, I'd want more input from the community.
19:49:36 <cait> i might encourage a second sign off in some cases to give the qa people a bit more
19:49:42 <beatsforthemind> 999$c is it. thanks cait!
19:49:49 <cait> yq
19:49:50 <cait> yw
19:49:58 <cait> ok, time for setting a date/time next meeting?
19:50:07 <cait> #topic Set time of next meeting
19:50:19 <cait> i have a proposal here too - i think this time doesn't work well
19:50:41 <cait> if we moved it by 2 hours, it won't work for europe well (11pm) but woudl be better for australia/nz i guess
19:50:45 <cait> is there something we could work out?
19:51:34 <cait> to keep with the rotation i'd suggest 15 utc otherwise for the next meeting
19:51:43 <cait> should we have another before feature freeze or is later fine too?
19:52:00 <barton> it seems like the 15 utc meetings are better attended.
19:52:03 <drojf> before would probably make sense?
19:52:06 <bag> ok back
19:52:14 <bag> ES is signed off!!!
19:52:26 <barton> bag: w00t!
19:53:22 <cait> bag: that was a real quick coffee? ;)
19:53:36 <cait> hm
19:53:40 <cait> that leves next week
19:53:43 <cait> or something like 26th
19:53:46 <barton> bag: what's the bug number on that?
19:53:57 <kidclamp> he had to pick, roast, grind and brew, pretty fast for all of that
19:54:07 <kidclamp> bug 12478
19:54:08 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12478 enhancement, P5 - low, ---, robin, Signed Off , Elasticsearch support for Koha
19:55:49 <kidclamp> next week could be good cait as low attendance today
19:55:54 <cait> ok
19:56:10 <cait> wednesday, 20th - 15 utc?
19:56:20 <kidclamp> +1
19:56:28 <barton> +1
19:56:31 <cait> #agreed Next meeting will be on April 20, 15 UTC
19:56:38 <cait> #endmeeting