#koha: Development IRC meeting 13 July 2016

Meeting started by cait at 14:08:13 UTC (full logs).

Meeting summary

  1. Introductions (cait, 14:08:17)
    1. wahanui, a bot that has become sentient (wahanui, 14:08:17)
    2. Jonathan Druart (Joubu, 14:08:34)
    3. Katrin Fischer, BSZ, Germany (cait, 14:08:52)
    4. https://wiki.koha-community.org/wiki/Development_IRC_meeting_13_July_2016 (cait, 14:09:10)
    5. Kyle M Hall, ByWater Solutions (khall, 14:09:36)
    6. Mirko Tietgen, koha.abunchofthings.net (drojf, 14:09:57)
    7. Ruth Bavousett, nobody important. (druthb, 14:10:08)
    8. Owen Leonard, Athens County Public Libraries (oleonard, 14:10:10)

  2. announcements (cait, 14:11:46)
  3. Review of coding guidelines (cait, 14:13:02)
    1. Should cache-only bugs require benchmarks to prove confirm speed improvements? (cait, 14:13:28)
    2. Marcel (marcelr, 14:15:27)
    3. ACTION: Joubu is going to check if some performance testing can be included in the qa scripts (launch a series of tests and compare diff) (cait, 14:25:04)
    4. VOTE: Voted on "new coding guideline: performance and chache related patches should include benchmarks of some sort to prove their effects. Question?" Results are, yes: 7 (cait, 14:28:17)
    5. AGREED: new coding guideline: performance and chache related patches should include benchmarks of some sort to prove their effects. (cait, 14:28:17)
    6. ACTION: khall to add new benchmark rule to the coding guidelines (cait, 14:28:48)

  4. Bugs in discussion (cait, 14:29:26)
    1. Topic: Koha::Patrons::Import (bug 12598) vs Koha::Exporter::Record (bug 14722) (cait, 14:29:48)
    2. ACTION: Joubu to ask on the mailing list about which namespace scheme should be used for the 'export things' (cait, 14:42:31)
    3. ACTION: ... delete last action (cait, 14:45:04)
    4. ACTION: ... and action item is in effect again (cait, 14:46:36)
    5. Topic: Allow Koha::Objects to be used as hashrefs ( Bug 15759 ) (cait, 14:46:58)
    6. ACTION: khall volunteers to focus on rewrite patches for QA (cait, 15:00:20)
    7. ACTION: Jobuu to provide a list of bug numbers waiting for QA in that area atm (cait, 15:00:38)

  5. Deprecate support for Debian Wheezy? (cait, 15:00:57)
    1. Deprecating Wheezy because of problems with ES, Plack, Apache 2.4 - will mean: note in release notes, not fixing bugs specific to wheezy, not backporting from packaging side (cait, 15:06:26)
    2. VOTE: Voted on "Should we officially deprecate Debian Wheezy?" Results are, yes: 4 (cait, 15:09:10)
    3. AGREED: Wheezy is officially deprecated (cait, 15:09:21)
    4. ACTION: bag to add a note to the next release notes (cait, 15:09:30)

  6. General development discussion (trends, ideas, ...) (cait, 15:10:01)
    1. Topic: thoughts on Angular vs React (cait, 15:12:20)
    2. ACTION: khall to provide a proof of concept for using React in Koha (cait, 15:17:09)
    3. more information in chat log about this - not easy to info all :) (cait, 15:17:35)
    4. cait would be interested in an online api tutorial - how to set it up, test, validate etc. (cait, 15:22:43)
    5. ACTION: khall to add react/angular and frontend build to to next agenda ;) (cait, 15:24:47)
    6. ACTION: oleonard to start a mailing list thread about the frontend build tool (cait, 15:28:54)

  7. Updates from the QA team (cait, 15:30:25)
    1. read Joubu's summary emails "what's on in koha-devel"! :) (cait, 15:34:03)
    2. Joubu started move of C4::Members to Koha::Patrons (cait, 15:34:16)

  8. Set time of next meeting (cait, 15:36:02)
    1. AGREED: next meeting will take place on august 10 at 19 UTC (cait, 15:39:17)


Meeting ended at 15:39:29 UTC (full logs).

Action items

  1. Joubu is going to check if some performance testing can be included in the qa scripts (launch a series of tests and compare diff)
  2. khall to add new benchmark rule to the coding guidelines
  3. Joubu to ask on the mailing list about which namespace scheme should be used for the 'export things'
  4. ... delete last action
  5. ... and action item is in effect again
  6. khall volunteers to focus on rewrite patches for QA
  7. Jobuu to provide a list of bug numbers waiting for QA in that area atm
  8. bag to add a note to the next release notes
  9. khall to provide a proof of concept for using React in Koha
  10. khall to add react/angular and frontend build to to next agenda ;)
  11. oleonard to start a mailing list thread about the frontend build tool


Action items, by person

  1. bag
    1. bag to add a note to the next release notes
  2. Joubu
    1. Joubu is going to check if some performance testing can be included in the qa scripts (launch a series of tests and compare diff)
    2. Joubu to ask on the mailing list about which namespace scheme should be used for the 'export things'
  3. khall
    1. khall to add new benchmark rule to the coding guidelines
    2. khall volunteers to focus on rewrite patches for QA
    3. khall to provide a proof of concept for using React in Koha
    4. khall to add react/angular and frontend build to to next agenda ;)
  4. oleonard
    1. oleonard to start a mailing list thread about the frontend build tool
  5. UNASSIGNED
    1. ... delete last action
    2. ... and action item is in effect again
    3. Jobuu to provide a list of bug numbers waiting for QA in that area atm


People present (lines said)

  1. cait (159)
  2. khall (91)
  3. Joubu (71)
  4. drojf (33)
  5. huginn (18)
  6. marcelr (13)
  7. oleonard (11)
  8. wahanui (6)
  9. oleonard_ (4)
  10. vfernandes (3)
  11. druthb (2)
  12. bag (2)
  13. eythian (1)
  14. reiveune (1)
  15. morgane (1)
  16. nengard (1)


Generated by MeetBot 0.1.4.