13:01:09 <kidclamp> #startmeeting Development IRC meeting 14 December 2016
13:01:09 <huginn> Meeting started Wed Dec 14 13:01:09 2016 UTC.  The chair is kidclamp. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:09 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:09 <huginn> The meeting name has been set to 'development_irc_meeting_14_december_2016'
13:01:23 <kidclamp> #topic Introductions
13:01:23 <wahanui> #info wahanui, a bot that has become sentient
13:01:27 <khall> #info Kyle M Hall, ByWater Solutions
13:01:31 <marcelr> #info Marcel de Rooy, Rijksmuseum, Netherlands
13:01:34 <kidclamp> #info Nick Clemens, ByWater Solutions
13:01:41 <Joubu> #info Jonathan Druart
13:01:49 <josef_moravec_> #info Josef Moravec, Municipal Library Usti nad Orlici, Czech Republic
13:01:52 <cc_> #info Colin Campbell, PTFS Europe Ltd
13:01:53 <LibraryClaire> #info Claire Gravely, BSZ, Germany
13:01:58 <d_antonakis> #info Dimitris Antonakis, Athens, Greece
13:02:01 <drojf> #info Mirko Tietgen, Berlin, Germany
13:02:14 <oleonard> #info Owen Leonard, Athens County Public Libraries, USA
13:03:09 <kidclamp> last call
13:03:18 <petter> #info Petter Åsen, Oslo Public Library, Norway
13:03:24 <AndrewIsh> #info Andrew Isherwood, PTFS Europe Ltd
13:03:45 <kidclamp> #topic Announcements
13:04:02 <gveranis_> #info George Veranis Thessaloniki, Greece
13:04:09 <kidclamp> Mr. RM? anything form you
13:04:27 <khall> I'm starting to push enhancements to master again
13:04:32 <khall> that is all ; )
13:04:51 <tcohen> #info Tomas Cohen Arazi, Theke
13:04:54 <kidclamp> light meeting so anyone feel free to add their thoughts :-)
13:05:09 <khall> this is a judgement free zone ; )
13:05:22 <tcohen> i wanted to ask
13:05:42 <tcohen> what is the status of the Koha::Patron implementation? we are waiting for it to complete the REST endpoint
13:05:55 <tcohen> is it something that will be pushed with some priority?
13:06:06 <Joubu> things are waiting for QA and push
13:06:33 <Joubu> I plan to continue the rewrite, but I need stuffs to move forward, otherwise it's to painful to maintain up-to-date
13:06:46 <tcohen> there's one bug that it is not easy to test, the GetBorrowersWithEmail one
13:06:53 <Joubu> https://bugs.koha-community.org/bugzilla3/showdependencygraph.cgi?id=16846
13:06:54 <kidclamp> bug numbers?
13:06:57 <tcohen> it is trivial that it works
13:07:03 <marcelr> :)
13:07:10 <Joubu> so "green" are not really green as they need to be rebased (status=blocked)
13:07:11 <tcohen> but the test plan includes PKI authentication and something else
13:07:43 <Joubu> bug 17554
13:07:44 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17554 enhancement, P5 - low, ---, jonathan.druart, Needs Signoff , Move GetBorrowersWithEmail to Koha::Patron
13:08:09 <kidclamp> #info Koha Patron bugs should be helped along
13:08:18 <Joubu> tcohen: I can resubmit a test plan without that part if you like :D
13:08:30 <kidclamp> #link https://bugs.koha-community.org/bugzilla3/showdependencygraph.cgi?id=16846 Dependencies and progress
13:08:32 <drojf> why does it say persona needs to be tested, isn't that dead?
13:08:49 <kidclamp> #link http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17554 Bug 17554
13:08:50 <huginn> 04Bug 17554: enhancement, P5 - low, ---, jonathan.druart, Needs Signoff , Move GetBorrowersWithEmail to Koha::Patron
13:08:51 <khall> I had thought the same thing
13:08:58 <oleonard> it shouldn't be broken before we officially remove it though should it?
13:09:19 <khall> It will be shut down in December 2016
13:09:28 <josef_moravec_> bug 17486
13:09:29 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17486 enhancement, P5 - low, ---, gmcharlt, NEW , Remove 'Mozilla Persona' as an authentication method
13:09:32 <barton> #info Barton Chittenden, BWS, Louisville, KY, USA
13:09:33 <drojf> "Mozilla announced in January 2016 plans to decommission the service by the end of the year."
13:09:44 <drojf> i don't think we can keep it working when mozilla kills it
13:10:37 <oleonard> I just mean we should work to remove it before Mozilla kills it dead, rather than just let it break by Mozilla's hand or ours.
13:10:38 <Joubu> I can take it (the drop) and rebase the other one on top
13:10:48 <magnuse> #info Magnus Enger, Libriotech, Norway
13:11:26 <kidclamp> #action Joubu will remove Mozilla Persona and rebase his work on top
13:12:36 <kidclamp> moving on if no more here
13:12:54 <kidclamp> #topic Review of coding guidelines
13:13:14 <kidclamp> nothing in the agenda but floor is open for anyone
13:13:38 <Joubu> ok, so, I need help on QA
13:14:09 <marcelr> this is about coding guidlines?
13:14:10 <barton> I'd like to talk a bit about documentation...
13:14:12 <Joubu> as usual, but the queue is growing too fast, I cannot maintain it alone (and don't want to)
13:14:28 <barton> developer documentation, that is...
13:14:39 <kidclamp> if noc doing guidelines we can jump to general discussion for both of these
13:14:47 <kidclamp> no coding
13:15:08 <kidclamp> cait still here?
13:15:08 <khall> sounds good. let's start with the qa queue and then go to developer documentation
13:15:11 <gveranis_> yes developer documentation could be useful
13:15:25 <khall> 63 bugs in signed off queue atm
13:15:33 <kidclamp> okay jumping 16.11 to gen disc.
13:15:41 <LibraryClaire> cait is currentlly AFK
13:15:42 <kidclamp> #topic General development discussion (trends, ideas, ...)
13:16:00 <kidclamp> #info The QA queue is growing and Joubu needs help
13:16:15 <marcelr> did you mean that , Joubu?
13:16:25 <kidclamp> in maintaining the queue
13:16:27 <Joubu> yes that's enough, nothing more to do about that
13:16:33 <AndrewIsh> pinging ashimema
13:16:54 <Joubu> I pingued the QAers last week, but no answers
13:16:59 <tcohen> I try to QA some stuff, but have a growing backlog on my side too
13:17:16 <khall> Joubu: do you now have push rights to the master branch?
13:17:27 <Joubu> yes I think so
13:17:56 <kidclamp> same boat here, working on what I can, if directed to any specific bug I am happy to make time but general QA sometimes gets missed
13:18:05 <khall> I will try to pitch in on qa. I would appreciate it if you could push anything I pass, just as a sanity check
13:18:27 <Joubu> khall: yep!
13:18:43 <khall> excellent, thanks!
13:19:05 <kidclamp> I plan on testing bug 17196 in the next few days
13:19:06 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17196 enhancement, P5 - low, ---, jonathan.druart, Signed Off , Move marcxml out of the biblioitems table
13:20:03 <Joubu> 2 QAs would not be superfluous
13:20:14 <kidclamp> agreed :-)
13:20:59 <tcohen> I will QA it too
13:21:24 <kidclamp> #action kidclamp and tcohen will be looking at bug 17196
13:21:44 <kidclamp> I think the floor is yours barton
13:21:55 <tcohen> after barton, I'd like to highlight something
13:22:00 <barton> kk.
13:22:09 <kidclamp> and I added something to the agenda after that :-)
13:23:11 <barton> I'd like to suggest that we make lack of developer documentation, e.g. POD, something that is an automatic failure in QA.
13:23:52 <marcelr> we normally should do that already?
13:23:53 <barton> I hate to put more work on the QA team, but I also hate not having documentation for everything.
13:24:15 <kidclamp> this came up in the last meeting on November 9th
13:24:17 <Joubu> it's already what we do I think
13:24:45 <kidclamp> is there a coding guideline?
13:24:46 <Joubu> but when the code is self-explanatory, it's not necessary useful to add pod
13:25:04 <Joubu> sub get_holds # well, it returns holds you know
13:25:21 <Joubu> barton: do you have something specific in mind?
13:25:26 <marcelr> perl13
13:25:36 <tcohen> it should be documented that it returns an array of Koha::Hold objects, though
13:25:41 <tcohen> :-P
13:25:48 <marcelr> existing rule
13:25:55 <cc_> we should stress if an interface changes the change should update existing pod doc
13:26:28 <eythian> https://perldoc.koha-community.org/ keep in mind it goes here too, so the code may not be immediately visible.
13:26:36 <barton> Joubu: I found that a lot of the Koha::Objects don't have any...
13:26:48 <kidclamp> #info POD coverage should be checked during QA per coding guideline PERL13
13:28:15 <kidclamp> #link https://perldoc.koha-community.org/ In perldoc even simple code could benefit form POD
13:28:51 <kidclamp> it was proposed to add POD coverage to the QA script, but I don't know fi there was consensus
13:29:24 <tcohen> i think a minimal POD should be required on QA
13:29:33 <barton> Ok, so here's part of my quandry ...
13:29:37 <tcohen> at least the type of the stuff that is returned
13:29:43 <marcelr> harder is writing that for an interface change as mentioned by cc_
13:29:46 <Joubu> so we need to decide what we want in our POD...
13:30:19 <barton> I think that there are a lot of times when the grandfather clause is used when something isn't documented...
13:30:43 <Joubu> I don't think PERL13 is applied appart from SearchSuggestion
13:30:51 <tcohen> I'd say the type for params and return values is the minimum we should require
13:30:54 <barton> a small change is made to a module that doesn't have much documentation...
13:31:20 <barton> ^^ I'm with tcohen there.
13:32:16 <tcohen> can we decide or should we schedule this for another meeting?
13:32:42 <marcelr> decide: just add this to perl13
13:32:43 <barton> tcohen: I'm fine with tabeling the discussion; I'll try and come up with some better examples.
13:33:02 <khall> I'd be interested to know what Perl Best Practices has to say on it, if anything
13:33:03 <Joubu> I think we need a volunteer to write the POD for existing methods
13:33:09 <marcelr> and be pragmatical
13:33:10 <khall> I know there is a full chapter on documentation
13:33:11 <Joubu> to have good examples of what we are expecting
13:33:48 <barton> Ok, I'll volounteer for writing POD.
13:33:51 <khall> yes, we need a template
13:33:59 <oleonard> So we wait and vote on a specific proposal?
13:34:06 * tcohen revisits his latest patches and finds incomplete PODs
13:34:07 <Joubu> barton: please don't be too verbose :)
13:34:16 <kidclamp> #action Barton volunteers to write POD for existing docs, brief POD
13:34:43 <kidclamp> anyone volunteer to work up the guidleline for POD going forward?
13:34:56 <kidclamp> and maybe send to the mailing list to vote next meeting?
13:35:09 <barton> Joubu: I don't have enough time to write a *lot* of POD ;-)
13:35:13 <Joubu> I think methods from Koha namespace should be quite easy to document as they are short and do not do lot of things
13:35:21 <tcohen> true
13:35:37 <tcohen> and are covered by functional tests
13:35:39 <khall> indeed
13:35:56 <barton> There are some things that could really use it though ... holds queue, search.pm...
13:36:11 <tcohen> forget about Search.pm please
13:36:18 <marcelr> rewrite it
13:36:19 <kidclamp> heh
13:36:20 <tcohen> yeah
13:36:21 <cc_> we should adopt a recommended location for POD whether inline or after __END__
13:36:23 <barton> heh.
13:36:30 <marcelr> inline
13:36:32 <khall> cc_: it's all inline
13:36:33 <tcohen> inline
13:36:36 <Joubu> after :p
13:36:42 <marcelr> no Joubu
13:36:42 <tcohen> Joubu--
13:36:49 <khall> after is what PBP reccomends
13:36:53 <Joubu> I do not care about the doc when I can see the code
13:36:54 <khall> inline is all we do ; )
13:37:04 <marcelr> inline++
13:37:17 <Joubu> PBP++ :)
13:37:26 <khall> Joubu: I bet you can find a plugin for $editor that will collapse the pod ; )
13:37:28 <eythian> Joubu: if it's not inline, no one sees it and never updates it.
13:37:42 <khall> agreed
13:38:23 <kidclamp> alright folks...I will volunteer to send something to the mailing list to add to the coding guidelines and compile issues, so fight it out there
13:38:51 <kidclamp> #action kidclamp will send a call out to the list for POD guidelines and draft for a vote next meeting
13:39:03 <tcohen> is it my turn?
13:39:04 <kidclamp> your issue tcohen?
13:39:06 <kidclamp> yes
13:39:07 <tcohen> he
13:39:19 <tcohen> as this is a dev meeting
13:39:43 <tcohen> I'd like to share that I started to work on resurrecting bug 13757
13:39:44 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13757 enhancement, P5 - low, ---, tomascohen, Needs Signoff , Make patron attributes editable in the opac if set to 'editable in OPAC'
13:40:13 <tcohen> the UI part was done on the bug, and so the CRUD for the opac_editable attribute for extended attributes
13:40:41 <tcohen> but work on borrower_modifications is missing (i.e. handling modification requests for extended attributes)
13:40:45 <tcohen> all this to say
13:40:59 <tcohen> that I got more into writing code using Koha::Object
13:41:26 <tcohen> trying to do a Koha::Object-ify as I touch stuff
13:41:29 <tcohen> aprroach
13:41:42 <tcohen> my first try on Koha::Object was bug 17755
13:41:42 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17755 enhancement, P5 - low, ---, tomascohen, Needs Signoff , Introduce Koha::Patron::Attribute::Type(s)
13:41:52 <tcohen> a simple one
13:42:06 <tcohen> that had something in common with Koha::Patron::Category
13:42:23 <tcohen> it is constrained by library (formerly branch)
13:42:32 <kidclamp> #info tcohen is working on moving code to use Koha::Object
13:42:45 <tcohen> so i came up with Koha::Object::Limit::Library
13:43:16 <tcohen> which in conjunction with multiple inheritance, makes it easy to extend a Koha::Object to provide suche a constraint
13:43:25 <tcohen> I'd like other QAers opinions
13:43:34 <tcohen> on that specifically
13:43:35 <marcelr> should have a closer look first
13:43:38 <tcohen> yes
13:43:44 <khall> I like it!
13:43:45 <Joubu> Sounds ok to me
13:43:53 <tcohen> I don't expect you to do it now, just thought worth mentioning
13:44:12 <tcohen> and encourage you devs to give Koha::Object a try
13:44:27 <tcohen> because I was skeptical about it when I pushed it
13:44:30 <marcelr> uploads is in Koha;:Object too in the NSO queue
13:44:38 <kidclamp> #info QA and interested parties should look at  Koha::Object::Limit::Library on bug 17755
13:44:50 <tcohen> and now find it really handy and looking at Jonathan's work on moving stuff into using it
13:44:57 <marcelr> bug 17501
13:44:58 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17501 enhancement, P5 - low, ---, m.de.rooy, Needs Signoff , Koha Objects for uploaded files
13:45:35 <kidclamp> #info see work on using Koha::Object for uploads on bug 17501
13:45:36 <tcohen> the code looks simple to read, fast to develop
13:45:37 <oleonard> Joubu++
13:45:49 <tcohen> it really improved my dev workflow
13:45:49 <oleonard> tcohen++
13:46:02 <tcohen> ok, that's it. I wanted to share that I like it :-D
13:46:07 <Joubu> yes it's very useful for now. Some stuffs are a bit "too much". We have too many objects. And some object's responsabilities are not correctly defined
13:46:13 <marcelr> tcohen++
13:46:14 <tcohen> and encourage people to look at the ideas behind 17755
13:46:25 <Joubu> but we will be able to clean that a bit when we will have more code moved to the Koha ns
13:46:28 <tcohen> Joubu: I agree
13:46:51 <marcelr> some refactoring might create weird new methods in the Koha objects
13:47:06 <Joubu> marcelr: yes, that's why I start with easy ones
13:47:10 <tcohen> marcelr: Koha::Object::Limit::Library was a try to avoid that
13:48:15 <kidclamp> okay, I have a thing :-)
13:48:37 <kidclamp> I would like to propose turning on voting in Bugzilla
13:48:38 <kidclamp> https://www.bugzilla.org/docs/4.0/en/html/voting.html
13:48:51 <tcohen> +1
13:49:01 <marcelr> voting on what aspects?
13:49:12 <kidclamp> interest/importance generally
13:49:25 <kidclamp> I have been doing a number of talks with users who want to get involved
13:49:47 <kidclamp> they want an easy way to mark a bug as important to them, even if they can't comment on code or implementation
13:50:00 <marcelr> add to cc?
13:50:03 <kidclamp> the idea being that users can see what matters to other users and gain support for fundings
13:50:14 <kidclamp> and devs can see where work might benefit users
13:50:16 <marcelr> but i do not oppose
13:50:22 <kidclamp> adding to cc doesn't give us a count we can sort by
13:50:33 <marcelr> the number in the cc list?
13:50:37 <kidclamp> and honestly, they don't all want emails
13:50:48 <kidclamp> I don't think we can search/report that marcelr
13:51:08 <kidclamp> the worst consequence I see would be a feature we ignore
13:51:27 * Joubu is gonna create several bz accounts to vote for his own bugs
13:51:47 <kidclamp> heh
13:51:56 <kidclamp> Joubu had an extra bowl of sass today
13:52:40 <kidclamp> #info kidclamp proposes to add voting to Bigzilla
13:52:45 <kidclamp> #link https://www.bugzilla.org/docs/4.0/en/html/voting.html Bugzilla voting
13:52:57 <barton> s/Bigzilla/Bugzilla/
13:53:02 <Joubu> I don't think will get more involvement with that, but we can try
13:53:03 <kidclamp> if there is opposition I will talk to whoever maintains bugzilla
13:53:14 <drojf> will that lead to people complaining that stuff they voted on is not magically happening?
13:53:28 <tcohen> +1 # it won't hurt anyway, should be announced so people use it
13:53:41 <kidclamp> if they complain and comment at least they are involved drojf :-)
13:53:46 <khall> drojf: I think the idea is to bring awareness to things everyone wants but think only they want
13:53:58 <khall> and by knowing each other, they can group sponsor work
13:54:11 <marcelr> +1 # just try
13:54:20 <barton> +1
13:54:22 <drojf> in a magical world where they have money to sponsor :)
13:54:42 <drojf> +1 # sure why not
13:54:53 <kidclamp> hooray! thanks guys
13:55:08 <marcelr> is it on now? kidclamp ?
13:55:11 <marcelr> lol
13:55:38 <kidclamp> hah, I think I have to ping rangi, I think catalyst maintains bz
13:55:45 <khall> drojf: power in numbers, just had a development sponsored by 30 something libraries pitching in very small amounts
13:55:58 <khall> +1 from me as well
13:56:01 <marcelr> kidclamp: yes, better do it via rangi
13:56:05 <kidclamp> #topic Updates from the QA team
13:56:13 <drojf> khall: nice!
13:56:26 <kidclamp> anything more to add?  I think we covered it in discussion
13:56:55 <Joubu> yes just
13:57:00 <Joubu> not QA related
13:57:05 <kidclamp> :-)
13:57:12 <Joubu> but ldap seems broken under plack
13:57:27 <kidclamp> possibly shib/SAML too
13:57:27 <Joubu> on the general Koha ML
13:57:40 <Joubu> I quickly looked at the code C4/Auth_with_ldap
13:57:53 <Joubu> and it has wrong var scope
13:58:08 <Joubu> someone knowing this part of code should get a look
13:58:17 <ashimema> I can varify shib is broken under plack
13:58:17 <Joubu> it may be easy to fix
13:58:26 <ashimema> and I have a plan to fix it.. when I get a moment
13:58:42 <ashimema> ldap I wasn't aware of being broken.
13:58:55 * kidclamp hands ashimema all of his round tuits
13:58:57 <cait> edi libary ean is broken too
13:59:02 <cait> you can't add any
13:59:03 <khall> ashimema++
13:59:14 <ashimema> shib is a case of switching from env variables to request headers
13:59:14 <cait> qa is no longer my topic, but from rmaint's point of vie
13:59:14 <cait> w
13:59:17 <kidclamp> we have ldap working under plack in 3.22 in at least one instance
13:59:26 <khall> cait: is there a bug number for that? I'd be happy to fix it
13:59:33 <cait> yes of course
13:59:46 <cait> there are lots of open bug reports waiting for patches - please also take a look at those. I am going to call string freeze tomorrow and then release on 22nd
13:59:59 <cait> it would be really good if dev coudl take a look at the blocker - major ones recently filed
14:00:07 <cait> bug 17692
14:00:18 <kidclamp> #info LDAP and shib may not be entirely plack safe
14:00:37 <cait> bug 17764 is evil too
14:00:38 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17764 critical, P2, ---, oleonard, NEW , OPAC search fails when lost items are in the result set and there is no logged in user
14:00:42 <kidclamp> #topic Progress on next release (16.11)
14:00:44 <cait> OPAC search fails when lost items are in the result set and there is no logged in user
14:00:51 <kidclamp> #info there are lots of open bug reports waiting for patches - please also take a look at those
14:00:59 <kidclamp> #info string freeze on the 22nd
14:01:04 <Joubu> 17764 is for me
14:01:17 <cait> it would be great if we could still get those into 16.11.1
14:01:24 * oleonard runs off to an irl meeting
14:01:34 <kidclamp> #info bug 17692 and bug 17764 are high priority for 16.11.1
14:01:39 * ashimema apologises for having missed most of this meeting.. feeling rough so went back to bed and slept through the alarm
14:01:43 <kidclamp> oleonard++
14:01:52 <cait> ther are more, those i remembered off the top of my head
14:02:10 <marcelr> any relation with bug 17502
14:02:11 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17502 normal, P5 - low, ---, m.de.rooy, Needs Signoff , Resolve internal server error on 0000-00-00 (with Plack)
14:02:32 <marcelr> also a failing search
14:02:32 <Joubu> cait: could you send me the list, if you have one?
14:02:58 <kidclamp> anything more cait?
14:03:01 <cait> i can try and create one - maybe by tomorrow?
14:03:14 <cait> there is also a fixme now search on bugzilla
14:03:17 <cait> that cvould be helpful
14:03:24 <kidclamp> #action cait will compile a list of bugs wanted/needed for 16.11.1
14:03:51 <cait> hm where could we put those so it's not just me?
14:04:02 <kidclamp> send to koha/koha-devel
14:04:37 <cait> also some problems with mulitple holds and sip i think
14:04:55 <cait> there is always lots of bugs - so please don't hit me if i miss an important one
14:05:12 <kidclamp> #info don't hit cait
14:05:12 <cait> i will check what i held back i my inbox - but can't go look through all of bugzilla
14:05:25 <Joubu> bug 17775
14:05:26 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17775 blocker, P5 - low, ---, gmcharlt, NEW , Add new user with LDAP not works under Plack
14:05:34 <cait> yeah, some evil plack things around
14:05:38 <marcelr> cait: 17502
14:05:44 <kidclamp> #topic Set time of next meeting
14:06:15 <kidclamp> I am proposing something around 20UTC according to survey until someone has a better method/time
14:07:11 <barton> +1
14:07:25 <kidclamp> January 11, 20UTC?
14:07:49 <tcohen> we should have 2 dev meetings a month
14:07:49 <Joubu> Wed
14:07:50 <tcohen> brief ones
14:08:07 <marcelr> this was a good time btw
14:08:14 <barton> agreed.
14:08:25 <kidclamp> agreed, this time was nice
14:08:38 <kidclamp> tcohen - I am all for it if somone else will chair the second meeting
14:08:54 * tcohen volunteers
14:09:01 <kidclamp> but keeping meeting short is harder than I thought :-)
14:09:12 <tcohen> I'll ask for help if i cannot attend
14:09:16 <tcohen> true
14:09:27 <marcelr> kidclamp++
14:09:37 <kidclamp> #action tcohen proposes to hold a second dev meeting - he will chair
14:10:00 <kidclamp> do you want to set a time now tcohen, 2 weeks or so? or wait until January to being?
14:10:03 <kidclamp> begin
14:10:18 <tcohen> wait until january, because end of the year is complicated for everyone
14:10:26 <kidclamp> sounds good
14:10:51 <kidclamp> #info next meeting 11 January 2016, 20 UTC
14:11:02 <kidclamp> #endmeeting