10:01:21 <cait> #startmeeting Development IRC meeting 19 October 2016
10:01:21 <huginn> Meeting started Wed Oct 19 10:01:21 2016 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:01:21 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:01:21 <huginn> The meeting name has been set to 'development_irc_meeting_19_october_2016'
10:01:29 <cait> #topic Introductions
10:01:29 <wahanui> #info wahanui, a bot that has become sentient
10:01:38 <cait> please introduce yourself following wahanui's example
10:01:46 <BobB> #info Bob Birchall, Calyx, Sydney Australia
10:01:49 <cait> today's agenda can be found at https://wiki.koha-community.org/wiki/Development_IRC_meeting_19_October_2016
10:01:52 <cait> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_19_October_2016
10:01:56 <kidclamp> #info Nick Clemens, ByWater Solutions
10:01:57 <cait> #info Katrin Fischer, BSZ, Germany
10:02:00 <LibraryClaire> #info Claire Gravely, BSZ, Germany
10:02:02 <petter> #info petter, Oslo public library, Norway
10:02:14 <Joubu> #info Jonathan Druart, France
10:02:31 <bensinober> #info Benjamin Rokseth, Norway
10:03:30 <d_antonakis> #info Dimitris Antonakis, Athens, Greece
10:04:13 <khall> #info Kyle Hall, Bywater Solutions
10:04:36 <cait> ok
10:04:44 <cait> let's move on to announcements
10:04:51 <cait> #topic Announcements
10:04:53 <irma> #info Irma, CALYX, Sydney Australia
10:05:23 <cait> the dashboard says it's only 34 days until release of 16.11
10:05:36 <cait> so we need to start thinking about 17.04
10:05:44 <cait> #link https://wiki.koha-community.org/wiki/Roles_for_17.05
10:05:56 <cait> i'd schedule elections for november 2nd, if that's ok?
10:06:09 <BobB> yes cait, ok
10:06:36 <cait> and otherwise... please all sign up!
10:06:48 <cait> #action all Sign up for roles for 17.05
10:07:00 <cait> any other announcements? :)
10:07:44 <drojf> hoppla
10:07:49 <cait> moving on then
10:07:59 <drojf> #info Mirko Tietgen, Berlin, Germany
10:08:10 <cait> #topic Review of coding guildelines
10:08:16 <cait> there is nothing listed on the agenda
10:08:20 <cait> does someone have a proposal?
10:08:48 <cait> moving on!
10:08:57 <cait> #topic Deadlines for 16.11
10:09:10 <cait> khall has the keyboard
10:09:47 <khall> ok, then. Brendan and I have outlined some dates leading up to the 16.11 release
10:10:15 <khall> November 1st will be the feature slush, so only bug fixes after that
10:10:23 <tajoli> #info Zeno Tajoli, CINECA
10:10:33 <khall> On the 3rd we will create a 1st draft of the release notes for everyone to review
10:10:42 <cait> #info November 1st will be the feature slush, so only bug fixes will get pushed after that
10:10:58 <cait> #info November 3rd: first draft of the release notes for review
10:11:00 <khall> on the 10th we'll do a second draft of the release notes, assuming we will have been pushing bug fixes to master
10:11:25 <cait> #info Novmeber 10th: second draft of the release notes
10:11:43 <khall> Nov 15th will be the feature freeze, so after that only bug fixes not requiring string changes will be pushed
10:12:04 <khall> on the 17th, we will publish the final draft of the release notes
10:12:27 <khall> and finally, Nov 22 will be the release day!
10:12:49 <cait> do you mean feature freeze or string freeze?
10:12:51 <cait> for 17th
10:12:58 <cait> because feature slush is november 1st?
10:13:32 <khall> string freeze, thanks cait!
10:14:28 <cait> #info November 15th: String freeze, only bug fixes requiring no string changes to be pushed
10:14:39 <cait> #info November 17th: final draft of release notes
10:14:50 <cait> #info November 22nd: Release!
10:14:58 <cait> any questions? :)
10:14:59 <cait> ah, i got one
10:15:05 <cait> when is a good day for "qa slush"
10:15:35 <khall> I think that would be a call best left to the head of the qa team!
10:15:49 <cait> eek :)
10:15:57 <cait> i think we will keep qa'ing
10:16:07 <cait> but probably shoudl focus a bit on finishing the enh for now first
10:16:19 <khall> yes, that makes the most sense
10:16:21 <cait> bad bugs of course too, but priority to enh until the slush date
10:16:40 <cait> Joubu: ok?
10:16:44 <Joubu> yep
10:17:04 <cait> #info QA team to focus on enh/new features until the feature slush date (exceptions for bad bugs and security of course)
10:17:16 <cait> any other questions about the deadlines?
10:17:36 <cait> moving on then
10:17:50 <cait> #topic General development discussion
10:17:57 <cait> I got something there .)
10:18:09 <cait> I have started to create a collection of pages with documentation for beginners/testers
10:18:11 <cait> on the wiki
10:18:11 <wahanui> on the wiki is probably more information about the packages
10:18:46 <cait> I have started to update some of the pages for that, bug reporting and sandboxes for a start
10:18:46 <cait> https://wiki.koha-community.org/wiki/Sandboxes
10:18:55 <cait> #link https://wiki.koha-community.org/wiki/Sandboxes
10:19:04 <cait> at the bottom there is a box that will hold the links for the 'handbook'
10:19:18 <cait> please feel free to add and change this
10:19:41 <cait> #info New 'Tester handbook' on the wiki, collecting pages with information important for beginners and testers
10:19:52 <cait> we could also add a link to easy to test bugs
10:19:58 <cait> have we agreed on a new keyword now?
10:21:15 <khall> I thought we'd already chosen one previously, but for the life of my I cannot remember what it was
10:21:21 <khall> it doesn't look like it got impormented
10:21:23 <kidclamp> I think Rangi said using Academy was fine
10:21:30 <khall> implemented that is
10:21:40 <cait> i think kidclamp got an action to make up a proposal
10:22:19 <cait> but academy works for me
10:22:33 <d_antonakis> +1
10:22:40 <cait> #action all please add/suggest changes to the tester handbook
10:22:56 <cait> #info Use 'academy' keyword' in bugzilla for highlighting easily testable bugs
10:23:04 <cait> moving on?
10:23:32 <cait> #topic Updates from the QA team
10:23:50 <cait> Joubu, do you have something to highlight?
10:24:00 <Joubu> not specifically
10:24:23 <BobB> joubu your periodical updates are very helpful
10:24:27 <cait> signed off is 87 right now thx to hackfest
10:24:31 <cait> we will be working on it
10:24:34 <Joubu> I will try and send a "post hackfest" email
10:24:36 <cait> yep Joubu++
10:24:48 <cait> #action Joubu to send a 'post hackfest' email
10:24:55 <cait> cool
10:25:07 <khall> excellent!
10:25:07 <cait> Questions to the qa team?
10:25:10 <cait> otherwise we can move on
10:25:20 <LibraryClaire> Joubu++
10:25:28 <cait> #topic Koha and Qvarn
10:25:37 <cait> i think... rangi fell asleep
10:25:56 <cait> so we will have to postpone this again to a meeting time that is better for nz
10:26:38 <cait> ok, next meeting
10:26:40 <Joubu> maybe an email to koha-devel could be a first step
10:26:51 <cait> yeah i think that's a good idea
10:27:10 <cait> does someone has another topic before we set the date for next meeting?
10:27:32 <Joubu> QA ALL THE THINGS
10:27:34 <Joubu> maybe?
10:27:34 <wahanui> maybe is a momentaneous error
10:27:39 <cait> hehe .)
10:27:43 <cait> yep :)
10:27:47 <cait> FIX ALL THE BUGS!
10:27:50 <cait> ok, moving on
10:27:55 <cait> #topic Set date of next meeting
10:28:30 <cait> suggestions for the time?
10:29:15 <Joubu> looks like this is a good time (unless for Argentina & NZ), but not enough topics
10:29:28 <cait> also bad for some parts of US
10:30:04 <Joubu> (actually I thought it was a general meeting... and I thing I have c/p the wrong email yesterday)
10:30:20 <Joubu> I will try to add more topics for the next meeting
10:30:24 <cait> general is 20 utc on november 2nd
10:30:27 <cait> cool :)
10:30:31 <cait> ok, but next meeting... when?
10:30:37 <cait> we had 21utc for the one before this
10:30:43 <cait> this was 10 utc
10:30:49 <Joubu> and nobody attempted
10:31:08 <cait> so november 9th good?
10:31:08 <Joubu> someone, suggestions?
10:31:15 * ashimema is terribly late.. silly telephone calls
10:31:19 <cait> but i am not going to suggest a time this time .)
10:32:09 <cait> 19 UTC?
10:32:09 <wahanui> i guess 19 UTC is fine by me.
10:32:31 <Joubu> what about a survey?
10:32:53 <magnuse> #info Magnus Enger, Libriotech, Norway
10:32:59 <cait> some people iwll never be able to attend then
10:33:02 <Joubu> we could ask on the list, what is the best time for everybody
10:33:05 <cait> because they are in a minority
10:33:05 <ashimema> #info Martin Renvoize, PTFS Europe
10:33:21 <kidclamp> or pick two times and alternate between them
10:33:38 <cait> that's what we used to do, but it's complicated
10:33:53 <cait> i will log 19utc, if someone wants to organize a survey, i am not against moving it
10:34:03 <cait> which we can still do until a few days before
10:34:19 <cait> #info Next meeting Novembe 9th, 19 UTC
10:34:41 <cait> the problem i see with voting is that the time will always end up to be good for europe possibly :)
10:35:12 <cait> #endmeeting